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1. 1.
2.

 After the download is complete, run the installer.3.

If you encounter any issues installing the software, try performing the installation in
administrator mode.
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Download and install the Flight Stand Software on your computer.

Steps:
Visit tytorobotics.com/download1.
Locate the "Flight Stand Software" section and click the "download" button.2.

1. Download the Software
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1. 1.
2.

 To simulate a dual or multi-motor system, return to the Hardware tab and click
"Connect Simulated Board" again, adding another simulated powertrain.

3.

Once the simulated board is connected, you can proceed as if it were a real thrust stand
and perform the setup, tests, and data visualization described in the next sections.
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2. Setup the Simulated Board (optional)

The software includes a simulated board that users can use to simulate a test and
explore the software before purchasing a thrust stand. Connecting a simulated board is
optional but a great way to become familiar with the platform, no purchase necessary.

The data output from the simulation is based on tests with a real motor, which were used
to create a performance model.

Video Tutorial: https://www.youtube.com/watch?v=oszJTbkftbE

Steps: 
 Open the Flight Stand Software and navigate to the Hardware tab.1.
 Click "Connect Simulated Board". In the left panel, simulated data will be displayed.2.
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3. Software Configuration

Video tutorial: https://youtu.be/JUSK1Mns0TA?si=jojtv8rcm57Np1vZ&t=27

Steps:
Open the Flight Stand software.1.
Connect your Flight Stand to the USB port of your computer. In the left panel, the
Force Measurement Unit and Electrical Measurement Unit will appear.

2.

Click on ’Setup’: customize your units of measurement.3.
Click on ‘Hardware’: see details about the Flight Stand(s) connected, including serial
number, firmware, and which additional systems are active, such as servo controllers
and probes.

4.

Click on ‘Safety limits’: set safety cut-off values that will limit how high or low your
thrust, torque, voltage, current, RPM, and other parameters can go.

5.

Click on ‘Powertrains’: map your powertrains by assigning names to your motor,
propeller, ESC, and power source. Ensure that the powertrains are associated with the
correct force and electrical measurement units.

6.

Configure the software before beginning your tests to ensure optimal performance and
safety. Here we will cover the settings in the first four options of the drop-down menu.

Force measurement unit 1
Electrical measurement unit 1

4
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1. 1.

2.

3.

4.

5.

jl6.

When you are finished, deactivate your ESC by unchecking the box next to the slider.7.

Stop continuous recording by again clicking on the ‘Record’ button8.

Click ‘Save and new’ to save your test.9.

View your results in the ‘Test’ tab where you can also export your data.10.
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4. Manual Testing

Perform manual control tests using the ESC throttle slider.

Video tutorial: https://youtu.be/FzfvaZogpwQ?si=6XANU7NCvHQAaHju

Steps:
Connect and configure your Flight Stand.1.
Select ‘Manual Control’ in the main drop-down menu.2.
Name your test.3.
Select how you would like to record data: continuously by clicking ‘Record’ or with
snapshots using the ‘Take sample’ button.

4.

Activate your ESC by checking the box next to the throttle slider.5.
Drag the throttle slider to start the test or enter a throttle value in the text box. The
incoming data is visible on the real-time plots.

6.

5
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1. 1.

 2.

Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to test.3.

Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which you’d

like to make a change in the throttle.

4.

In the ‘Powertrain throttle’ column, add the throttle values you’d like to correspond

with the time points in the ‘Time’ column.

5.
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5. Automated Testing

Set up and program automated tests using one of several methods:
     a. Values table
     b. CSV Upload/ Flight Replay
     c. Python API
     d. Prepared test scripts

a. Values table

Video tutorial: https://youtu.be/0RqCtd3qnwc?si=l44I6jeJQab18dnr

Steps:
In the ‘Manual Control’ tab, activate the ESC.1.
In the ‘Automatic Control’ tab, select a type of test (Step or Ramp).2.

6
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
5.

Choose how you would like to collect data:6.
To take a sample at each time point, check the ‘Take sample’ box in the table.a.
To continuously record data, scroll down to ‘Sequence runner’ and toggle on
‘Continuous recording”.

b.

Scroll down to the ‘Sequence Preview’ to see how your test looks.7.
To loop your test, enter the number of repeats in the ‘Loop sequence’ box.8.
Name the test in the ‘Title’ box.9.
Click ‘Execute sequence’ to run the test.10.
Once the test is complete, a yellow box will appear in the left panel where you can
Save or Discard your data.

11.
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5. Automated Testing
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
Scroll down to preview and execute the sequence. Once the test is complete, a yellow
box will appear in the left panel where you can Save or Discard your data.

5.
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5. Automated Testing

b. CSV Upload/ Flight Replay

Video tutorial: https://youtu.be/FroCYgVlPgQ?si=3QrXeoAZ26-I1jBM

Steps:
After selecting a type of automated test, under ‘Sequence editor’, click the ‘Tools’
drop-down and select ‘Load demo example’.

1.

Again under the ‘Tools’ drop-down, select ‘Export sequence from CSV’.2.
Use the exported CSV file as a template and add your desired time and throttle
points.

3.

Once your file is ready, return to the ‘Tools’ drop-down, select ‘Import sequence from
CSV’ and upload the edited CSV file from your computer.

4.

8

Flight Stand Software User Manual
Document ID: FUM112

V2.1 2025-02-14

https://youtu.be/FroCYgVlPgQ?si=3QrXeoAZ26-I1jBM


1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
Open your preferred text editor (i.e. PyCharm).5.
In PyCharm you will need to configure a virtual environment.6.

If you are using another text editor such as VS Code you will have to install
Python or the Python extension.

a.

In PyCharm, open the Python folder in the repository.7.
Open up a terminal in the folder and run the following command: py -m pip install
grpcio grpcio-tools

8.
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5. Automated Testing

c. Python API

Video tutorial: https://youtu.be/Gkf0dAnA1w4?si=nV3WNBGPCv49miR8

Steps:
Before starting, ensure you have the latest version of the Flight Stand software
installed on your computer as well as a text editor with a Python compiler.

1.

In the ‘Hardware’ tab of the Flight Stand software, connect your Flight Stand.2.
Navigate to the ‘Automatic Control’ tab and select ‘Python API’ from the test options.3.
Open the repository at: https://gitlab.com/TytoRobotics/flightstand-api and read the
‘README’ file.

4.

9
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
Open your preferred text editor (i.e. PyCharm).5.
In PyCharm you will need to configure a virtual environment.6.

If you are using another text editor such as VS Code you will have to install
Python or the Python extension.

a.

In PyCharm, open the Python folder in the repository.Open up a terminal in the folder
and run the following command: py -m pip install grpcio grpcio-tools

7.

8.
To verify your connection, open the Flight Stand software and make the real-time
plots visible. Then in Python, run example.py.

9.

In PyCharm, the terminal will output all available boards, automatically connect
the simulated board, and list all available inputs and outputs for that board.

a.

If the connection was successful, the last few lines in the terminal should reflect
the ESC throttle values you see in the Flight Stand software.

b.
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5. Automated Testing
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d. Prepared test scripts

This Google sheet:
https://docs.google.com/spreadsheets/d/1XvXoo7h2_0t1s1L2px2kDtGj2X2kDnwxDqttWxkE
Fus/edit?usp=sharing contains the templates for the Sine wave, Chirp signal, and
Sawtooth tests. Add a copy to your Google Drive by clicking ‘File’ → ‘Make a copy’.

i. Sine wave

Video tutorial: https://youtu.be/0pu8JYqnV80

Steps:
 Open your copy of the Google sheet and navigate to the ‘Sine/Chirp Generation’ tab.1.
Adjust the # of lines, speedup, frequency, amplitude, and offset values in row 2 to
design your sine wave. This will adjust the preview in the ‘Throttle vs. Time’ graph.

2.

Copy the ‘Time’ and ‘Throttle - Sine’ data into the ‘Sine Wave Data for Export’ tab.3.
Download the file as a CSV file (File → Download → .csv).4.

Tyto Robotics
B1 - 80 rue Adrien Robert • Gatineau, QC, Canada J8Y 3S2

                                 sales@tytorobotics.com
tytorobotics.com • 1-844-722-8378

5. Automated Testing
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
Open the Flight Stand software and navigate to the ‘Automated Control’ tab, click on
‘Step test’.

5.

Under ‘Tools’, select ‘Import sequence from CSV’.6.
Select and import the CSV file that you downloaded from the Google sheet.7.
The sine wave data points will be displayed in the table and a preview of the wave
will be shown in the Sequence preview window.

8.

Click ‘Execute sequence’ to run the test.9.
Once the test is complete, a yellow box will appear in the left panel where you can
Save or Discard your data.

10.
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5. Automated Testing

ii. Chirp signal

Video tutorial: https://youtu.be/0pu8JYqnV80?si=GQYjKerpszKwcb5q&t=129

Steps:
Open your copy of the Google sheet and navigate to the ‘Sine/Chirp Generation’ tab.1.
 Adjust the # of lines, speedup, frequency, amplitude, and offset values in row 2 to
design your wave. This will adjust the preview in the ‘Throttle vs. Time’ graph.

2.

Adjust the ‘Speedup of chirp’ value.3.
Copy the data from the ‘Time’ and ‘Throttle - Chirp’ columns into the ‘Chirp Data for
Export’ tab.

4.

Once you have added the data to the appropriate columns, download the file as a
CSV file (File → Download → .csv).

5.

Open the Flight Stand software and navigate to the ‘Automated Control’ tab, click on
‘Step test’.

6.

Under ‘Tools’, select ‘Import sequence from CSV’.7.
Select and import the CSV file that you downloaded from the Google sheet.8.
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Copy the data from the Time  and Throttle  Chirp  columns into the Chirp Data for
Export’ tab.

4.

Once you have added the data to the appropriate columns, download the file as a
CSV file (File → Download → .csv).

5.

Open the Flight Stand software and navigate to the ‘Automated Control’ tab, click on
‘Step test’.

6.

Under ‘Tools’, select ‘Import sequence from CSVmport th7.
e CSV file that you downloaded from the Google sheet.8.
The chirp test data points will be displayed in the table and a preview of the wave
with increasing frequency will be shown in the Sequence preview window.

9.

Click ‘Execute sequence’ to run the test.10.
Once the test is complete, a yellow box will appear in the left panel where you can
Save or Discard your data.

11.
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5. Automated Testing

iii. Sawtooth

Video tutorial: https://youtu.be/0pu8JYqnV80?si=c1WeU3UYjajHE6Bu&t=204

Steps:
Open the Flight Stand software and navigate to the ‘Automated Control’ tab.1.
Click on ‘Ramp test’.2.
In the ‘Sequence editor’ table, enter 2 lines of data for time, throttle and rate of change.3.
A preview of a simple up/down pattern (sawtooth) will appear in the ‘Sequence
preview’ window below.

4.
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
Enter the number of repeats you would like in the ‘Loop sequence’ box and click
‘Execute sequence’.

5.

Once the test is complete, a yellow box will appear in the left panel where you can
Save or Discard your data.

6.
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5. Automated Testing

iv. PID tuning

Note: we highly recommend watching the video tutorial for this section (link on page 15).

A PID controller is a special algorithm that aims to maintain a specific value for a sensor.
For propulsion systems, the PID controller achieves this by continuously adjusting the
throttle output required to make your propulsion system converge on the desired value.

Before completing this tutorial, you will need to be able to successfully run the first
example.py file in the repository. If you have not yet done so, go to section 5c of this user
manual to learn how to do so.
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Video tutorial: https://youtu.be/8HSNoONR3yg

Steps:
Assuming you were able to successfully run the example.py file (section 5c), open the
Flight Stand software.

1.

Open your Python compiler and open a console to ensure you have simple-pid
installed. You can check by running the command: py -m pip install simple-pid

2.

Find the number corresponding to the signal of the variable you would like to target
by opening the .proto file (we will use thrust as an example), then scroll until you see
the list of input signals. Thrust (FZ) corresponds to number 11, note the number.

3.

1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

Open example 4. Change the input and output signals to match the powertrains in the
software. You can find this information in the Flight Stand software’s ‘Hardware’ tab.
Click on your powertrain and highlight the first line of text in the ‘Identification’ tab.

4.
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5. Automated Testing
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
Paste this information into the input/output board information in the Python file.5.
Run the Python file. The terminal will output a list of available inputs. 6.
Find the input corresponding to your target variable’s signal number (#11 for thrust)
and enter it in example_PID_constant_thrust.py after the target input board.

7.

Scroll down to ‘Target value’ and enter the value you would like to target in SI units
(Newtons for thrust).

8.
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5. Automated Testing
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py p p
Export’ tab.
Once you have added the data to the appropriate columns, download the file as a
CSV file (File → Download → .csv).

5.

Open the Flight Stand software and navigate to the ‘Automated Control’ tab, click on
‘Step test’.

6.

Under ‘Tools’, select ‘Import sequence from CSVmport th7.
e CSV file that you downloaded from the Google sheet.8.
Check your settings for the length of the period, and set starting values for your PID
parameters, Ki, Kd, and Kp.

9.

The Ki term (integral term) is a constant that is multiplied by the integral of the
error. The product is then added to offset the error.

a.

The Kd term (derivative term) is a constant that is multiplied by the derivative of
the error.

b.

The Kp term (proportional term) is similar to the integral and derivative terms but
it's the product of the error and the constant.

c.

Run the script and observe the Flight Stand react accordingly.10.
Adjust your Ki, Kd and Kp values as needed until you have a PID response that you
are satisfied with.

11.
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5. Automated Testing
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a. Motor rate limiter

Video tutorial: https://youtu.be/JRjxpPYXfaA?si=o8jKjLdUQG9nKL5b

Control the acceleration rate to protect your motor from torque or current overloading.

Steps (manual test):
Before activating your ESC, click the gear icon to the left of the throttle slider.1.
In the ‘Rate limiter’ text box, enter a maximum acceleration value in µs/s. 2.

For example, with a rate of 500 µs/s it will take 2 seconds to reach the maximum
throttle of 2000 µs. 

a.

Activate the ESC and increase your throttle. An orange bar will show you the status of
the throttle with the rate limiter applied.

3.
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6. Test Settings and Data Handling

Steps (automated test):
If you leave the rate limiter on in the manual control tab, it will apply the limit to
automated control tests as well. This is the best option if you would like to apply the
same rate limit to the entire test.

1.

You can also configure unique rate limits to different stages of the test within the
automated control tab. Navigate to the ‘Automated Control’ tab to start.

2.

Select a type of test and input your sequence steps in the ‘Sequence form’ table.3.
The fourth column is the rate limiter. Enter your desired limit for each step.4.
Scroll down to the Sequence preview to see how this will look when the test is run.5.
Click ‘Execute sequence’ to run the test with the rate limiter.6.
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1. 1.
  2.
Next, use the Timespan slider in the middle to control how much time is displayed on
the x-axis. The default is 30 seconds but you can view more or less time as desired. 

3.

The ‘Layout’ button to the right of the slider opens a window with options to
configure the plot display. The order and size of plots can be adjusted, as well as the
number of columns displayed.

4.

b. Customize live data plots

Video tutorial: https://youtu.be/apKQZ2ikbIA?si=jY44hL1aK1W8Zo3a

Customize how data is displayed in the real-time plots during your test.

Steps:
Enlarge the real-time data plots window by using the drag feature to pull them up or
use the arrows on the right side of the ‘Real-time plots’ window to have them pop-up.

1.

If you have multiple powertrains, you can select which one(s) you want to display in
the plots by checking the box next to each powertrain in the top right corner.

2.

Tyto Robotics
B1 - 80 rue Adrien Robert • Gatineau, QC, Canada J8Y 3S2

                                 sales@tytorobotics.com
tytorobotics.com • 1-844-722-8378

6. Test Settings and Data Handling
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
The ‘Pause’ toggle switch freezes the data display at a specific time snapshot. When it
is toggled off, the charts will return to displaying live data.

5.

The ‘Show unfiltered’ toggle switch controls whether displayed data is filtered or
unfiltered. By default, a 1 Hz low pass filter is applied to smooth out readings.

6.
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6. Test Settings and Data Handling

c. Noise removal

Video tutorial: https://youtu.be/avy0mIs2qX0?si=DM2XTDYIilkrDlHh

Control the noise filter that is applied to your data. To control the noise filter on the real-
time data plots, see point 6 in the previous section.

Note: data is recorded without a noise filter. This feature implements a post-test low
pass filter with a selectable cutoff frequency.

Steps:
Navigate to the ‘Tests’ tab and open the test you would like to adjust.1.
Go to the ‘Plots’ tab and use the ‘Noise filter’ slider to adjust the level of noise
removal.

2.

A 1 Hz filter is automatically applied, but you can turn that off or apply a higher or
lower filter.

a.
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6. Test Settings and Data Handling

d. Resample data

Video tutorial: https://youtu.be/Mc9S9Y9fUxo?si=bzWJC6vo5SsKjMGk

Export your data at a custom sampling rate after your test.

Steps:
After completing your test, go to the ‘Tests’ tab and click on your test.1.
Go to the export tab, where you'll see a table with all your data points.2.
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1. 1.
  2.
Under ‘Time resolution’, check the option next to ‘Resample’ and type in your desired
resolution in the text box that appears. The number you enter is how often you’d like
a sample to be given in seconds.

3.

The default resampling rate is 0.1 seconds or 10 samples per second.a.
The only limitation is that you cannot increase the sampling rate above the limits
of your thrust stand (100 samples/ second for Standard Flight Stands and 1000
samples/ second for Pro).

b.

1. 1.
  2.

3.
Click 'Export to CSV' to save the test to your computer at the desired sampling rate.4.
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7. Connect a CAN ESC

Our Flight Stands support most ESC protocols. These additional steps are required for
CAN ESC protocols.

In our example, we are using the Yukon software which works specifically with Zubax
devices. Other CAN products may use other third-party software.

Video tutorial: https://youtu.be/BiZuCrVQNnU?si=V2gVWdD7fGlJeMeZ

Steps: 
Download and open the Flight Stand software.1.
Download the repository at https://gitlab.com/TytoRobotics/flightstand-api and
extract the repository on your computer.

2.

Download the latest version of Python as well as PyCharm Community edition.3.
Open Pycharm and open the downloaded repository.4.
In the downloaded folder, go to ‘languages’ → ‘python’ → ‘examples’ → ‘canbus-cyphal’5.

This is where you'll find the examples that we will be running.a.
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
5.

Configure your Python interpreter by going to ‘File’ → ‘Settings’ → ‘Project’ → ‘Python
interpreter’ and in the pop-up click ‘Add interpreter’ → ‘Add local interpreter’. 

6.

Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 7.
To confirm that you have the virtual environment set up correctly, you can either
find it in the virtual environment path or open the terminal where you will see the
virtual environment before the command line.

a.

Open the ‘README’ file under ‘examples’.8.
Run the three commands listed in the README file, which will install the proper
packages in order for you to run the Python API. 

9.

To verify that the connection is working, open the Flight Stand software. Confirm
that a simulated board has been connected under “Hardware” and that it has an
ESC throttle input.

a.
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

e4.
5.

rwg6.
7.

Configure your Python interpreter by going to “File” → “Settings” → “Project” →
“Python interpreter” and in the pop-up click “Add interpreter” → “Add local
interpreter”. 

8.

9.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 10.
e11.

12.
To confirm that you have the virtual environment set up correctly, you can either find
it in the virtual environment path or open the terminal where you will see the virtual
environment before the command line.Open the ‘README’ file under ‘examples’.

13.

Click ‘OK’ then right click and click ‘Run example 1 Main’.14.

Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
5.

Configure your Python interpreter by going to “File” → “Settings” → “Project” →
“Python interpreter” and in the pop-up click “Add interpreter” → “Add local
interpreter”. 

6.

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
e9.

10.
To confirm that you have the virtual environment set up correctly, you can either find
it in the virtual environment path or open the terminal where you will see the virtual
environment before the command line.Open the ‘README’ file under ‘examples’.

11.

Highlight the environment variables from lines 20 - 24, right click, and select ‘Modify
Run Configuration’. 

12.

In the environment variables line, hit Ctrl A then Ctrl V to replace the variables.13.

“Python interpreter” and in the pop-up click “Add interpreter” → “Add local
interpreter”. 

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
To confirm that you have the virtual environment set up correctly, you can either find
it in the virtual environment path or open the terminal where you will see the virtual
environment before the command line.Open the ‘README’ file under ‘examples’.

9.

Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy and paste the command in line 15 from the code to the console and hit Enter to
install an additional package.

11.
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1. 1.
 2.
Under ‘Controlled outputs’ check the box next to the powertrain(s) you’d like to
test.Under ‘Sequence form’, use the ‘Add Row’ box to enter the time points at which
you’d like to make a change in the throttle.

3.

rwg4.
5.

Configure your Python interpreter by going to “File” → “Settings” → “Project” →
“Python interpreter” and in the pop-up click “Add interpreter” → “Add local
interpreter”. 

6.

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
To confirm that you have the virtual environment set up correctly, you can either find
it in the virtual environment path or open the terminal where you will see the virtual
environment before the command line.Open the ‘README’ file under ‘examples’.

9.

Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy and paste the command in line 15 from the code to the console and hit enter to
install an additional package.

11.

e12.
e13.
e14.
e15.
e16.
The Flight Stand software will restart and the license key tab will then show that the
license has been activated.

17.

Go to Pycharm and click ‘Run example 1 Main’.18.
In the Flight Stand software, confirm that you’ve connected a simulated heater.19.
In Pycharm, open example_1_plant.py20.
Copy the environment variables into the runtime configuration and hit run.21.

In the Flight Stand software, you will now see an output control for the heater in
the ‘Manual control’ tab.

a.

p p y
environment before the command line.Open the ‘README’ file under ‘examples’.
Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy and paste the command in line 15 from the code to the console and hit enter to
install an additional package.

11.

e12.
e13.
e14.
You need a license key to use this feature → simply email support@tytorobotics.com
to request the license key associated with your Flight Stand.

15.

Once you have the license key, open the Flight Stand software, and on the ‘Setup’ tab
click ‘License’, enter your license key, and hit Enter.

16.

Tyto Robotics
B1 - 80 rue Adrien Robert • Gatineau, QC, Canada J8Y 3S2

                                 sales@tytorobotics.com
tytorobotics.com • 1-844-722-8378

7. Connect a CAN ESC

26

Flight Stand Software User Manual
Document ID: FUM112

V2.1 2025-02-14

mailto:support@tytorobotics.com


1. 1.
 2.
Unde3.
rwg4.

5.
Configu6.

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
To confirm that you have the virtual environment set up correctly, you can eith9.
Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy e11.
e12.
e13.
e14.
e15.

16.
The Flight Stand software will restart and the license key tab will now show 17.
Go back to Pycharm and click ‘Run example 1 Main’.18.
In the Flight Stand software, confirm that you’ve connected a simulated heater.19.
Open example_1_plant.py20.

21.
Set up the Yukon software, which will allow you to interact with CAN bus Cyphal
devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub
releases

22.

Click the hyperlink then scroll down and click to download the Yukon.exe file.a.
Open the Yukon file. Here we will set up the DSDL name space.23.

Note that the Zubax DSDL files are specific to Zubax Cyphal CAN devices, and
other manufacturers may have different DSDL files that you need to import.

a.

Click on the ‘Settings’ tab and click ‘Add path’ then ‘Browse’. Navigate to the
downloaded Flight Stand API folder. Go to ‘languages’ → ‘python’ → ‘examples’ →
‘canbus_cyphal’ and select ‘public_regulated_data_types’.

24.
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Copy e11.
e12.
e13.
e14.
e15.
f16.
f17.
The Flight Stand software will restart and the license key tab will now show 18.
Go back to Pycharm and click ‘Run example 1 Main’.19.
In the Flight Stand software, confirm that you’ve connected a simulated heater.20.
Open example_1_plant.py21.

22.
Set up the Yukon software, which will allow you to interact with CAN bus Cyphal
devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub
releases, click the hyperlink then scroll down and click to download the Yukon.exe
file.

23.

Open the Yukon file. Here we will set up the DSDL name space.Ne that the Zubax DSDL
files are specific to Zubax Cyphal CAN devices, and other manufacturers may have
different DSDL files that you need to import.Click on the ‘Settings’ tab and click “Add
path” then “Browse” then navigate to the downloaded Flight Stand API folder. Go to
“languages” → “python” → “examples” → “canbus_cyphal” and select
“public_regulated_data_types”.

24.

Click ‘Add path’ → ‘Browse’, then navigate to the same subfolder, but this time select
the ‘zubax_dsdl’ folder. Scroll to the bottom of the page and click ‘Save
configuration’.

25.

Close and restart the Cyphal software. 26.
In the ‘UDP interface’ field in the top right panel, change the value to 127.0.0.127.
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1. 1.
 2.
Unde3.
rwg4.

5.
Configu6.

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
To confirm that you have the virtual environment set up correctly, you can eith9.
Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy e11.
e12.
e13.
e14.
e15.
f16.
f17.
The Flight Stand software will restart and the license key tab will now show 18.
Go back to Pycharm and click ‘Run example 1 Main’.19.
In the Flight Stand software, confirm that you’ve connected a simulated heater.20.
Open example_1_plant.py21.

22.
Set up the Yukon software, which will allow you to interact with CAN bus Cyphal devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub releases, click the hyperlink then scroll down and
click to download the Yukon.exe file.

23.

Open the Yukon file. Here we will set up the DSDL name space.Ne that the Zubax DSDL files are specific to Zubax Cyphal CAN devices, and other manufacturers may have different DSDL files that you need to
import.Click on the ‘Settings’ tab and click “Add path” then “Browse” then navigate to the downloaded Flight Stand API folder. Go to “languages” → “python” → “examples” → “canbus_cyphal” and select
“public_regulated_data_types”.

24.

Click “Add path” again, “Browse” and navigate to the same subfolder, but t25.
his time select the “zubax_dsdl” folder. Scroll to the bottom of the page and click “Save configuration”.26.
Close and restart the Cyphal software. In the “UDP interface” field in the right panel near the top, change the value 127.0.0.127.
Click “Start this transport”.28.

If you get the error “Cannot find wcap.dll library”, you will need to download the Npcap software (free) from www.npcap.com. On the home page scroll down to “Downloading and Installing Npcap Free
Edition”, click and download the Npcap installer, then complete the installation process.

a.

Once the installation is complete, go to Yukon and click “Start this transport” again.29.
n Pycharm, make sure you only have example_1_plant running, then in Yukon, right click on the line next to 2346. Click “Subscribe to 2346” then “Subscribe” again in the pop-up window. This will allow you to see
the simulated temperature in real time in the Flight Stand Software.

30.

Do the same for line 2347, but click ‘Publish to 2347’ and ‘Add number field’. Choose
‘volt’ and in the last text box enter ‘5’ to set the voltage to 5 V. 

31.

Click ‘Enable’ and you'll see the Kelvin temperature measurement slowly start to
increase in the window above.

32.

Set up the Yukon software, which will allow you to interact with CAN bus Cyphal devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub releases, click the hyperlink then scroll down and
click to download the Yukon.exe file.

23.

Open the Yukon file. Here we will set up the DSDL name space.Ne that the Zubax DSDL files are specific to Zubax Cyphal CAN devices, and other manufacturers may have different DSDL files that you need to
import.Click on the ‘Settings’ tab and click “Add path” then “Browse” then navigate to the downloaded Flight Stand API folder. Go to “languages” → “python” → “examples” → “canbus_cyphal” and select
“public_regulated_data_types”.

24.

Click “Add path” again, “Browse” and navigate to the same subfolder, but t25.
his time select the “zubax_dsdl” folder. Scroll to the bottom of the page and click
“Save configuration”.

26.

Close and restart the Cyphal software. In the “UDP interface” field in the right panel
near the top, change the value 127.0.0.1

27.

Click ‘Start this transport’.28.
If you get the error ‘Cannot find wcap.dll library’, you will need to download the
Npcap software (free) from www.npcap.com. Scroll down to ‘Downloading and
Installing Npcap Free Edition’, and download the Npcap installer, then complete
the installation process.

a.

Once the installation is complete, go to Yukon and click ‘Start this transport’ again.29.
In Pycharm, ensure only example_1_plant is running, then right click on the line next
to 2346 in Yukon. Click ‘Subscribe to 2346’ then ‘Subscribe’ in the pop-up window. This
will enable the real time simulated temperature in the Flight Stand Software.

30.
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his time select the zubax_dsdl  folder. Scroll to the bottom of the page and click Save configuration .26.
Close and restart the Cyphal software. In the “UDP interface” field in the right panel near the top, change the value 127.0.0.127.
Click “Start this transport”.28.

If you get the error “Cannot find wcap.dll library”, you will need to download the Npcap software (free) from www.npcap.com. On the home page scroll down to “Downloading and Installing Npcap Free
Edition”, click and download the Npcap installer, then complete the installation process.

a.

Once the installation is complete, go to Yukon and click “Start this transport” again.29.
n Pycharm, make sure you only have example_1_plant running, then in Yukon, right click on the line next to 2346. Click “Subscribe to 2346” then “Subscribe” again in the pop-up window. This will allow you to see
the simulated temperature in real time in the Flight Stand Software.

30.

Do the same for line 2347, but click “Publish to 2347” and “Add number field”. Choose
“volt” and in the last text box enter “5” to set the voltage to 5 V. 

31.

lick enable and you'll see the Kelvin temperature measurement slowly start to
increase in the window above.

32.

Terminate the previous two examples in Pycharm and open ‘example_3’33.
Connect your ESC to your computer. For the Zubax ESC, connect one USB cable to
power the ESC, and the other USB cable to connect the Babel device.

34.

Open Yukon and make sure the hardware is set up correctly. Go to ‘Settings’ and
make sure that all the required DSDL files are present, like the Zubax DSDL.

35.

In the right panel, navigate to ‘CAN’ and ‘SL/CAN’, ensure you are using COM3, then
click ‘Start this transport’.

36.

Scroll to the ‘Unassigned ports’ table and link the fields to the appropriate ports:37.
Next to ‘zubax.physics.dynamics’ enter ‘100’. a.
Next to ‘zubax.physics.electronics’ enter ‘101’. b.
Next to ‘setpoint_rat_torque’ enter ‘111’.c.
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make sure that all the required DSDL files are present, like the Zubax DSDL.
In the right panel, navigate to “CAN” and “SL/CAN”, ensure we’re using COM3, then
click “Start this transport”.

36.

Scroll down to the Unassigned ports table and link the fields to the appropriate ports:37.
Next to “zubax.physics.dynamics” enter “100”. a.
Next to “zubax.physics.electronics” enter “101”. Next to “setpoint_rat_torque”
enter “111”.

b.

Click ‘Restart’ in the left panel to restart the connection.38.
In the ‘Monitor’ tab, right click on the ‘power’ arrow and select ‘Subscribe to 101’ then
right click on the ‘dynamics’ arrow and select ‘Subscribe to 100’. Click ‘Subscribe’
again in both pop-up windows.

39.

Right click on ‘setpoint_rat_torque’ and select ‘Publish to 111’. In the ‘Publisher’
window, click ‘Add number field’ and select ‘value (0)’ then enter 0.05 for torque (in
Nm) in the right-most text box.

40.

Click ‘Enable’ and the ESC will cause the motor to spin. If there was a load on the
motor, it would limit the speed to the RPM associated with 0.05 Nm.

41.
1. 1.
 2.
Unde3.
rwg4.

5.
Configu6.

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
To confirm that you have the virtual environment set up correctly, you can eith9.
Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy e11.
e12.
e13.
e14.
e15.
f16.
f17.
The Flight Stand software will restart and the license key tab will now show 18.
Go back to Pycharm and click ‘Run example 1 Main’.19.
In the Flight Stand software, confirm that you’ve connected a simulated heater.20.
Open example_1_plant.py21.

22.
Set up the Yukon software, which will allow you to interact with CAN bus Cyphal devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub releases, click the hyperlink then scroll down and
click to download the Yukon.exe file.

23.

Open the Yukon file. Here we will set up the DSDL name space.Ne that the Zubax DSDL files are specific to Zubax Cyphal CAN devices, and other manufacturers may have different DSDL files that you need to
import.Click on the ‘Settings’ tab and click “Add path” then “Browse” then navigate to the downloaded Flight Stand API folder. Go to “languages” → “python” → “examples” → “canbus_cyphal” and select
“public_regulated_data_types”.

24.

Click “Add path” again, “Browse” and navigate to the same subfolder, but t25.
his time select the “zubax_dsdl” folder. Scroll to the bottom of the page and click “Save configuration”.26.
Close and restart the Cyphal software. In the “UDP interface” field in the right panel near the top, change the value 127.0.0.127.
Click “Start this transport”.28.

If you get the error “Cannot find wcap.dll library”, you will need to download the Npcap software (free) from www.npcap.com. On the home page scroll down to “Downloading and Installing Npcap Free
Edition”, click and download the Npcap installer, then complete the installation process.

a.

Once the installation is complete, go to Yukon and click “Start this transport” again.29.
n Pycharm, make sure you only have example_1_plant running, then in Yukon, right click on the line next to 2346. Click “Subscribe to 2346” then “Subscribe” again in the pop-up window. This will allow you to see
the simulated temperature in real time in the Flight Stand Software.

30.

Do the same for line 2347, but click “Publish to 2347” and “Add number field”. Choose “volt” and in the last text box enter “5” to set the voltage to 5 V. 31.
lick enable and you'll see the Kelvin temperature measurement slowly start to increase in the window above.32.
Terminate the previous two examples in Pycharm and open example_333.
Connect your ESC to your computer. For the Zubax ESC, connect one USB cable to power the ESC, and the other USB cable to connect the Babel device.34.
Open Yukon and make sure the hardware is set up correctly. Go to “Settings” and make sure that all the required DSDL files are present, like the Zubax DSDL.35.
In the right panel, navigate to “CAN” and “SL/CAN”, ensure we’re using COM3, then click “Start this transport”.36.
Scroll down to the Unassigned ports table and link the fields to the appropriate ports:37.

Next to “zubax.physics.dynamics” enter “100”. a.
Next to “zubax.physics.electronics” enter “101”. Next to “setpoint_rat_torque” enter “111”.b.

Click “Restart” in the left panel to restart the connection.38.
In the “Monitor” tab, right click on the “power” arrow and select “Subscribe to 101” then right click on the “dynamics” arrow and select “Subscribe to 100”. Click “Subscribe” again in both pop-up windows.39.
Right click on “setpoint_rat_torque” and select “Publish to 111”. In the “Publisher” window, click “Add number field” and select “value (0)” then enter 0.05 for torque (in Nm) in the right-most text box.40.
Click “Enable” and the ESC will cause the motor to spin. If there was a load on the motor, it would limit the speed to the RPM associated with 0.05 Nm.41.

Open example_3_telega_ESC.py and change the port in line 44 to COM3 as this is the
port the ESC is connected to.

42.
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1. 1.
 2.
Unde3.
rwg4.

5.
Configu6.

7.
Click ‘Apply’ and Pycharm will automatically set up the virtual environment. 8.
To confirm that you have the virtual environment set up correctly, you can eith9.
Under ‘examples’, open the canvas.cyphal folder and open example_1_main.10.
Copy e11.
e12.
e13.
e14.
e15.
f16.
f17.
The Flight Stand software will restart and the license key tab will now show 18.
Go back to Pycharm and click ‘Run example 1 Main’.19.
In the Flight Stand software, confirm that you’ve connected a simulated heater.20.
Open example_1_plant.py21.

22.
Set up the Yukon software, which will allow you to interact with CAN bus Cyphal devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub releases, click the hyperlink then scroll down and
click to download the Yukon.exe file.

23.

Open the Yukon file. Here we will set up the DSDL name space.Ne that the Zubax DSDL files are specific to Zubax Cyphal CAN devices, and other manufacturers may have different DSDL files that you need to
import.Click on the ‘Settings’ tab and click “Add path” then “Browse” then navigate to the downloaded Flight Stand API folder. Go to “languages” → “python” → “examples” → “canbus_cyphal” and select
“public_regulated_data_types”.

24.

Click “Add path” again, “Browse” and navigate to the same subfolder, but t25.
his time select the “zubax_dsdl” folder. Scroll to the bottom of the page and click “Save configuration”.26.
Close and restart the Cyphal software. In the “UDP interface” field in the right panel near the top, change the value 127.0.0.127.
Click “Start this transport”.28.

If you get the error “Cannot find wcap.dll library”, you will need to download the Npcap software (free) from www.npcap.com. On the home page scroll down to “Downloading and Installing Npcap Free
Edition”, click and download the Npcap installer, then complete the installation process.

a.

Once the installation is complete, go to Yukon and click “Start this transport” again.29.
n Pycharm, make sure you only have example_1_plant running, then in Yukon, right click on the line next to 2346. Click “Subscribe to 2346” then “Subscribe” again in the pop-up window. This will allow you to see
the simulated temperature in real time in the Flight Stand Software.

30.

Do the same for line 2347, but click “Publish to 2347” and “Add number field”. Choose “volt” and in the last text box enter “5” to set the voltage to 5 V. 31.
lick enable and you'll see the Kelvin temperature measurement slowly start to increase in the window above.32.
Terminate the previous two examples in Pycharm and open example_333.
Connect your ESC to your computer. For the Zubax ESC, connect one USB cable to power the ESC, and the other USB cable to connect the Babel device.34.
Open Yukon and make sure the hardware is set up correctly. Go to “Settings” and make sure that all the required DSDL files are present, like the Zubax DSDL.35.
In the right panel, navigate to “CAN” and “SL/CAN”, ensure we’re using COM3, then click “Start this transport”.36.
Scroll down to the Unassigned ports table and link the fields to the appropriate ports:37.

Next to “zubax.physics.dynamics” enter “100”. a.
Next to “zubax.physics.electronics” enter “101”. Next to “setpoint_rat_torque” enter “111”.b.

Click “Restart” in the left panel to restart the connection.38.
In the “Monitor” tab, right click on the “power” arrow and select “Subscribe to 101” then right click on the “dynamics” arrow and select “Subscribe to 100”. Click “Subscribe” again in both pop-up windows.39.
Right click on “setpoint_rat_torque” and select “Publish to 111”. In the “Publisher” window, click “Add number field” and select “value (0)” then enter 0.05 for torque (in Nm) in the right-most text box.40.
Click “Enable” and the ESC will cause the motor to spin. If there was a load on the motor, it would limit the speed to the RPM associated with 0.05 Nm.41.
Open example_3_telega_ESC.py and change the port in line 44 to COM3 as this is the port that the ESC is connected to.42.

Set up the runtime environment by copy-pasting the runtime variables into the
configuration (right click → ‘Modify Run Configuration’ → in the environment
variables line, Ctrl A then Ctrl V to replace the variables → Apply).

43.

Make sure that the Flight Stand software is open then right click and select “Run
example_3_telega_ESC.py”.

44.

f the “Zubax ESC” appears in the Flight Stand software under “Hardware”, then you’ve
successfully performed the connection.

45.

Under the ‘Powertrain Mappings’ tab, ensure that the Zubax ESC is mapped correctly.46.
Test the connection by activating the ESC in the ‘Manual Control’ tab.47.

py
e12.
e13.
e14.
e15.
f16.
f17.
The Flight Stand software will restart and the license key tab will now show 18.
Go back to Pycharm and click ‘Run example 1 Main’.19.
In the Flight Stand software, confirm that you’ve connected a simulated heater.20.
Open example_1_plant.py21.

22.
Set up the Yukon software, which will allow you to interact with CAN bus Cyphal devices. Go to www.github.com/opencyphal/yukon then scroll down to GitHub releases, click the hyperlink then scroll down and
click to download the Yukon.exe file.

23.

Open the Yukon file. Here we will set up the DSDL name space.Ne that the Zubax DSDL files are specific to Zubax Cyphal CAN devices, and other manufacturers may have different DSDL files that you need to
import.Click on the ‘Settings’ tab and click “Add path” then “Browse” then navigate to the downloaded Flight Stand API folder. Go to “languages” → “python” → “examples” → “canbus_cyphal” and select
“public_regulated_data_types”.

24.

Click “Add path” again, “Browse” and navigate to the same subfolder, but t25.
his time select the “zubax_dsdl” folder. Scroll to the bottom of the page and click “Save configuration”.26.
Close and restart the Cyphal software. In the “UDP interface” field in the right panel near the top, change the value 127.0.0.127.
Click “Start this transport”.28.

If you get the error “Cannot find wcap.dll library”, you will need to download the Npcap software (free) from www.npcap.com. On the home page scroll down to “Downloading and Installing Npcap Free
Edition”, click and download the Npcap installer, then complete the installation process.

a.

Once the installation is complete, go to Yukon and click “Start this transport” again.29.
n Pycharm, make sure you only have example_1_plant running, then in Yukon, right click on the line next to 2346. Click “Subscribe to 2346” then “Subscribe” again in the pop-up window. This will allow you to see
the simulated temperature in real time in the Flight Stand Software.

30.

Do the same for line 2347, but click “Publish to 2347” and “Add number field”. Choose “volt” and in the last text box enter “5” to set the voltage to 5 V. 31.
lick enable and you'll see the Kelvin temperature measurement slowly start to increase in the window above.32.
Terminate the previous two examples in Pycharm and open example_333.
Connect your ESC to your computer. For the Zubax ESC, connect one USB cable to power the ESC, and the other USB cable to connect the Babel device.34.
Open Yukon and make sure the hardware is set up correctly. Go to “Settings” and make sure that all the required DSDL files are present, like the Zubax DSDL.35.
In the right panel, navigate to “CAN” and “SL/CAN”, ensure we’re using COM3, then click “Start this transport”.36.
Scroll down to the Unassigned ports table and link the fields to the appropriate ports:37.

Next to “zubax.physics.dynamics” enter “100”. a.
Next to “zubax.physics.electronics” enter “101”. Next to “setpoint_rat_torque” enter “111”.b.

Click “Restart” in the left panel to restart the connection.38.
In the “Monitor” tab, right click on the “power” arrow and select “Subscribe to 101” then right click on the “dynamics” arrow and select “Subscribe to 100”. Click “Subscribe” again in both pop-up windows.39.
Right click on “setpoint_rat_torque” and select “Publish to 111”. In the “Publisher” window, click “Add number field” and select “value (0)” then enter 0.05 for torque (in Nm) in the right-most text box.40.
Click “Enable” and the ESC will cause the motor to spin. If there was a load on the motor, it would limit the speed to the RPM associated with 0.05 Nm.41.
Open example_3_telega_ESC.py and change the port in line 44 to COM3 as this is the port that the ESC is connected to.42.

Set up the runtime environment by copy-pasting the runtime variables into the
configuration: right click → ‘Modify Run Configuration’. In the environment variables
line, Ctrl A then Ctrl V to replace the variables → Apply.

43.

With the Flight Stand software open, right click on ‘example_3_telega_ESC.py’ and
select ‘Run example_3_telega_ESC.py’.

44.

If the ‘Zubax ESC’ appears in the Flight Stand software under ‘Hardware’, then you’ve
successfully performed the connection.

45.
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1.
f2.

3.
 Under “Name”, enter an alias for the sensor (e.g., “Sound Sensor”).4.
Select the unit type from the drop-down options or select “Custom units” and input
"dB" for decibels.

5.

Assign the voltage general analog input to variable “a”.6.
In the “Formula” field, type the conversion formula provided in the sensor’s
datasheet. I.e.: a * 50: Decibel Value (dBA) = Output Voltage (V) × 50

7.
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8. Connect and Configure Analog Sensors (Input Transformations)

The Input Transformations software tab allows you to connect and configure 3rd party
analog sensors, synching the data with your other Flight Stand measurements.

We will explain how to connect a sound level meter, though these steps can be applied to
any kind of sensor. 

Video tutorial: https://www.youtube.com/watch?v=2uMntS8-XE4

Steps: 
Verify that the Flight Stand hardware is connected via USB.1.
Navigate to the Input Transformations tab.2.
Click “Add new transformation”.3.
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1.
2.
3.
4.
5.

 6.
7.

Enter system limits based on the datasheet specifications to trigger an automatic
motor cut-off if the sound level exceeds the defined range.

8.

Click “Save”9.
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3.
4.
5.
6.
7.

f 8.
9.

Navigate to the Powertrain Mappings tab.10.
Click “Extra mappings” and select “Transformations - Sound Sensor”. Live data from
the sensor can now be viewed in the left panel and in the real-time plots.

11.

1.
2.
3.
4.
5.
6.
7.
8.

d9.
f10.

11.
Proceed as you would with a regular test. The sound sensor data will have its own
column in the data file exported to CSV.

12.
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35

Flight Stand Software User Manual
Document ID: FUM112

V2.1 2025-02-14



Tyto Robotics
B1 - 80 rue Adrien Robert • Gatineau, QC, Canada J8Y 3S2

                                 sales@tytorobotics.com
tytorobotics.com • 1-844-722-8378

9. Remotely Control the Software

Remotely controlling the software is useful in many situations, such as using the software
on a different operating system or enhancing user safety. This section explains how to set
up a remote connection using two computers on the same network: one connected to the
Flight Stand’s Sync Hub via USB, and a second controlling the software remotely.

Be aware that this feature has some safety implications as anybody in the network can
activate the motor, so ensure there is good communication within the team, the
environment is controlled, and the network is private.

Video tutorial: https://youtu.be/kfvCMsBG8mg

Steps: 
Ensure the Flight Stand software is closed, then right click on the software’s shortcut.1.
Click on “Properties” and find the ‘Target’ field. At the end of the line, add the
command line argument “--remote”.

2.

If this error appears: “the name is not valid”, add a space before "--remote".a.
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Ensure the Flight Stand software is closed, then right click on the software’s shortcut1.
Click on “Properties” and find the “Target” field. At the end of the line, add the
command line argument “--remote”.

2.

When the software is opened, a warning message will appear in the left panel to
indicate that the software is accepting remote connections from any device on the
network.

3.
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9. Remotely Control the Software

Ensure the Flight Stand software is closed, then right click on the software’s shortcut1.
Click on “Properties” and find the “Target” field. At the end of the line, add the
command line argument “--remote”

2.

hen you open the software, a warning message will appear to remind you that you are
accepting remote connections, as this does have some safety implications.

3.

On the same computer, find the computer’s IP address by entering the command
“ipconfig” in Command Prompt.

4.
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Ensure the Flight Stand software is closed, then right click on the software’s shortcut1.
Click on “Properties” and find the “Target” field. At the end of the line, add the
command line argument “--remote”

2.

hen you open the software, a warning message will appear to remind you that you are
accepting remote connections, as this does have some safety implications

3.

On the same computer, find the computer’s IP address. You can do so by entering the
command “ipconfig” in Command Prompt.

4.

On the second computer, right click on the Flight Stand software shortcut.5.
Click on “Properties” then find the “Target” field and at the end of the line, add the
command line argument “--target=192.168.86.57:50051”, the number before the colon
being the first computer’s IP address.

6.

To test the connection, navigate to the “Manual Control” tab, activate the ESC and try
increasing the throttle. The first computer and Flight Stand should mirror the input
prompts.

7.
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10.  Propeller Balancing
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The Propeller Balancing software feature allows you to balance motors and propellers to
G quality grades associated with the 21940-12:2016 ISO standard.

We will explain how to balance a 2-blade propeller, though these steps can be applied to
propellers with any number of blades as well as motors. 

Video tutorial: https://youtu.be/YK-HO4V_Ons?si=pxNOqHQLI1XVUleF

Steps: 

Open the Balancing tab in the Flight Stand software. Click “New Balancing Session”.1.
Enter the details of the powertrain and test parameters. 2.
The correction radius is the distance from the center of the propeller where the
correction weight will be placed. We placed the weight toward the blade tip to
achieve the desired correction with minimal mass. To reduce the effect of the added
weight on lift and thrust generation, add the tape closer to the propeller's base at 1/4
- 1/3 of its radius.

3.

Click “Create”. 4.
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1.
2.

e3.
4.

Increase the throttle until the target RPM is reached, then click “Capture” to get a base
reading. The software will indicate how much weight to add for the next trial run.

5.

Add the trial weight to the propeller at the correction radius specified in Step 1.
Increase the throttle until the target RPM is reached, then click “Capture” to get a
reading.

6.
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10.  Propeller Balancing
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1.
2.
3.
4.
5.
6.

The software will suggest a permanent correction weight to achieve a passing
balancing grade. Add the weight to the propeller, increase the throttle and click
Capture.

7.
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 1.
2.
3.
4.
5.

e6.
7.

A green check mark will normally appear next to the Final quality grade, indicating
the propeller is within tolerance. In some cases it may suggest an additional
correction weight to achieve a passing balance. The test summary can be found in
the Report tab.

8.
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2.
3.
4.
5.
6.

f7.
8.

When balancing a motor without a propeller, select Disk Mode under the "Number of
Blades" section. When balancing a propeller with more than two blades, ensure you
select the correct blade count. 

9.

      
     Refer to the conventions below for marking your added weights:
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f1.
f2.
f3.
f4.
Navigate to the Manual Control tab. Click to activate the ESC throttle for the
powertrain.

5.

Ensure the throttle has full range of motion. Test the throttle servo to confirm that it
can reach full stroke. Use the toggle bar to ensure it can reach full left and right, all
positions.

6.

Open the Flight Stand software. Users should be familiar with the software before
beginning. Use the previous sections of this document as a reference.

1.

Verify that the latest version of the software is installed.2.
In the left-hand panel, ensure the FMU and DAQ are connected, indicated by a green
check mark.

3.

Navigate to the Powertrain Mapping tab and click on “Extra mappings”. Map the
throttle control to the servo port where the throttle device is connected.

4.
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11. Gas Engine Testing
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1.
2.
3.
4.
5.

e6.
7.

Click the “Tare sensors” button in the top right of the software window.8.
Establish a safe test environment and prepare to start the engine. This guide
assumes that gas has already been pumped to the carburetor.

9.

Toggle the throttle bar to low speed.10.
Confirm the choke position and turn on the ignition unit. The ignition safety button
should now be turned on.

11.

Use a starter to ignite the engine and let it idle.12.
Keep the engine at medium speed if it is not yet broken in and check the colour of
the smoke to see if the mixture is too lean or too rich.

13.

Start the test - use the throttle slider in the Manual Control tab to control the
throttle.

14.
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