{
  "affected": [
    {
      "ecosystem_specific": {
        "urgency": "not yet assigned"
      },
      "package": {
        "ecosystem": "Debian:12",
        "name": "activemq"
      },
      "ranges": [
        {
          "events": [
            {
              "introduced": "0"
            }
          ],
          "type": "ECOSYSTEM"
        }
      ]
    },
    {
      "ecosystem_specific": {
        "urgency": "not yet assigned"
      },
      "package": {
        "ecosystem": "Debian:13",
        "name": "activemq"
      },
      "ranges": [
        {
          "events": [
            {
              "introduced": "0"
            }
          ],
          "type": "ECOSYSTEM"
        }
      ]
    }
  ],
  "details": "Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB.    A user can create a durable subscription with a clientId and subscription name that have a combined length \u003e 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable.     This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12.    Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.",
  "id": "DEBIAN-CVE-2026-111821",
  "modified": "2026-11-06T13:47:24.881078392Z",
  "published": "2026-11-04T10:17:25.363Z",
  "references": [
    {
      "type": "ADVISORY",
      "url": "https://security-tracker.debian.org/tracker/CVE-2026-111821"
    }
  ],
  "upstream": [
    "CVE-2026-111821"
  ]
}