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Perform Initial Setup 

For some organizations, a system administrator might perform the HeadMaster Installations. Once the installations 
are complete, the HeadMaster program must be set up and configured for all of the individuals in the organization 
who will use it. Setting up and configuring the program requires an individual with an administrator account. 
 
The lists below outline the steps for getting started with HeadMaster. As an administrator, you can complete all the 
steps in the following order. 

 
Before you install and begin setting up HeadMaster 

• Verify that your computers meet the minimum requirements.  
• View our installation recommendations.  
• Select an installation method. 
• Connect to the HeadMaster database.  
• Log into HeadMaster for the first time.  
• Set up users and user security. 
• Customize program options and lists.  
• Import and export data.  
• Backup and restore data.  

 

 
 

 
 

  

Note: If you need to perform any of the above, take a look at our Getting Started User Guide.  

Tip: If your organization purchased HeadMaster Online, we recommend that you ensure HeadMaster properly 
uploads data to HeadMaster Online. Remember that once HeadMaster Desktop version data is uploaded to 
HeadMaster Online, relevant charges will apply.  Please refer to the Online Guide for Administrative Staff to 
learn how to upload data such as grades, assignments, and financial information to HeadMaster Online.  
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Set Up Users and User Security 

  

Create an Administrator Account 
 
Once you connect to the HeadMaster Database and log into Headmaster for the first time, we recommend that you 
create an administrator account.  
 
This account can access all areas of the program and is the only account that can create other user accounts. 

1. On the Home screen, click User Administration. 
2. Click New > New User. 
3. Enter the username, password, and full name, then select the Administrator check box. 
4. Click Save. 
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Add a New User 
 
As an administrator, you can add new users to HeadMaster. When you add a new user, you can add them to a user 
group, or you can build a custom profile for them. 
 
To add users 

1. On the Home screen, click User Administration.  
2. Click New > New User. 
3. Enter the username, password, and full name.  
4. Set security using one of the following methods.  

a. To grant the user full rights, select Administrator.  
b. To associate the user with a group of users, in the User Group list, select the group.  
c. To create a unique profile, in the Profile list, select the areas of the program you want to grant 

the user to have access.  
5. Select lunch security settings for the user. 
6. Select each database you want to grant the user access to.  
7. Click Save.  

 

  

  

   

Useful Information: If you are using HeadMaster Pro with Classroom Manager, you do not have to enter your 
teachers as users. However, you must enter the teacher’s username and password in the teacher record. The 
username and password allow them access to their students and classes.  
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Add a New User Group 
 
As an administrator, you can add new user groups to HeadMaster. User groups are two or more users grouped 
together with common access levels within the program. For example, if an administrator wants to allow all 
secretaries access to the same areas of the program, the administrator enters a user group named "Secretary” and 
sets access levels for the group. 
 
To add a new user group 

1. On the Home Screen, click User Administration. 
2. Click New > New Group. 
3. Enter the group name and description.  
4. In the Profile list, select the areas of the program you want to grant the group access to.  
5. Select lunch security settings for your group.  
6. Click Save.  
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Change a User's Password 
 
As an administrator, you can change other user's passwords. 

1. On the Home screen, click User Administration. 
2. In the Users list, click the user's name. 
3. Click Edit > Change Password. The Change Password dialog box displays. 
4. Enter the password information and click OK. 
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Change a User's Permissions 
 
As an administrator, you can change other user's permissions. 

1. On the Home screen, click User Administration. 
2. In the Users list, click the user's name. 
3. Click Edit.  
4. Click Save.  

 

  

  

   

Useful Information: You can change the user permissions in three ways. 
• Select the Administrator check box.  
• Select a user group.  
• Select access options in the Profile list.  
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Change a User's HeadMaster Online Username 
 
As an administrator, you can change a user's HeadMaster Online username. 

1. On the Home screen, click Parents, Students, or Teachers. 
2. In the list, double-click the name of a record. 
3. On the General tab, in the Login Information section, enter a username. Or, click Get Random to assign a 

random username generated by the program. 
4. Click OK. 
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Change a User Group's Permissions 

 
As an administrator, you can change a user group's permissions. 

1. On the Home screen, click User Administration. 
2. In the User Groups list, click the group's name. 
3. Click Edit and select or clear the access options in the Profile list. 
4. Click Save. 

  

  

   



Copyright © 2014, ACS Technologies 10 

 
 
 
View Users Logged into the Program 
 
As an administrator, you can view a list of users currently logged into the program. 

1. Go the File menu. 
2. Click Show Active Users.  

 

  

Note: If a user has not logged our properly, their name will display. To remove them from the list, select the 
user and click Remove. To force users to log out of the program, see the section below.  



Copyright © 2014, ACS Technologies 11 

 
 
 
Force Users to Log out of the Program 
 
As an administrator, you can force users to log out of the program. This may be necessary when you have to run 
updates, install upgrades, or run utilities, such as backing up data. 
 

1. On the File menu, click Show Active Users.  
2. Select one or more users and click Force Logout.  

 

 

  

   

Useful Information: When the administrator clicks Force Logout, users who are currently logged in will 
receive a message alerting them that they have one minute to exit the program before they are completely 
logged out. 
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Mass Change Data 

Replace Activities 
 
You can replace one activity with another activity within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Activities.  
3. Click Replace Activity. 
4. Make the appropriate selections. 
5. Click Change.  
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Delete Teacher Assignments 

 
You can delete assignments for a specific teacher or all teachers at once. 

1. On the File menu, select Mass Change. 
2. Double-click Assignments. 
3. Click Teacher Assignments. 
4. Make the appropriate selections. 
5. Click Delete.  
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Change Area Codes 
 
With the rapid growth in the use of telecommunication devices, area codes frequently change and are added to 
service regions. As an administrator, you can perform a mass change to convert all the area codes in the system at 
the same time. 
 

 
To change area codes 

1. On the File menu, select Mass Change. 
2. Double-click Attributes. 
3. Click Area Codes. 
4. Enter the old area code and the new area code.  
5. Click Change. 

 
 

  

   

Note: This process alters data. We recommend backing up your data before proceeding.  
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Change Phone Numbers 

 
If you have the same phone number entered in multiple records, as an administrator, you can use Mass Change to 
locate the phone number and update it with a new number. 

1. On the File menu, select Mass Change. 
2. Double-click Attributes. 
3. Click Phone Numbers. 
4. Enter the old phone number and the new phone number. 
5. Click Change. 
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Change Online Status for Students 
 
You can change the online status for multiple student records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Students. 
3. Click Online Status. 
4. Make the appropriate selections. 
5. Click Update.  
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Delete Behaviors 
 
You can delete behaviors within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Students. 
3. Click Behaviors. 
4. Make the appropriate selections. 
5. Click Delete.  
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Change Homeroom Teachers 
 
You can change homeroom teachers within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Students. 
3. Click Homeroom Teacher. 
4. Make the appropriate selections. 
5. Click Change.  
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Change Graduation Dates 
 
You can change the graduation date within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Students. 
3. Click Graduation Date. 
4. Make the appropriate selections. 
5. Click Change.  
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Delete Correspondence Log Entries 
 
You can delete Correspondence Log entries within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Individual. 
3. Click Correspondence Log. 
4. Make the appropriate selections. 
5. Click Delete.  
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Change the Status of Individual Types 
 
You can change the status of individual types within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Individual. 
3. Click Individual Types. 
4. Make the appropriate selections. 
5. Click Change.  
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Activate Grading Periods 
 
You can activate grading periods within multiple class records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Setup. 
3. Click Grading Period. 
4. Make the appropriate selections. 
5. Click Update.  
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Change Term Dates 
 
You can change term dates within multiple permanent records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Permanent Records. 
3. Click Term Dates. 
4. Make the appropriate selections. 
5. Click Change.  
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Change Programs of Study 

 
You can change programs of study within multiple records all at once. 

1. On the File menu, select Mass Change. 
2. Double-click Permanent Records. 
3. Click Program of Study. 
4. Make the appropriate selections. 
5. Click Change.  
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Fill Blank Grade Averages 

 
If permanent records are converted or transfer classes are brought in with blank grade averages, but they have been 
assigned a letter grade and/or a GPA, as an administrator, you can fill in the grade averages. 

1. On the File menu, select Mass Change. 
2. Double-click Permanent Records. 
3. Click Fill Blank Averages. 
4. Make the appropriate selections. 
5. Click Update. 
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Constant Contact 

Add a Constant Contact Account 
 

Constant Contact® provides email marketing and online survey tools. It offers real-time response tracking and email 
management features to ensure that you don’t send emails to people who've opted not to receive them. 
With a Constant Contact account, you can manage email lists created in HeadMaster. You can send HTML-based 
emails formatted with a custom template or simple plain-text emails.  
 

 
Once you receive approval to manage your Constant Contact account in HeadMaster, you can add your account in 
HeadMaster.  

1. On the Tools menu, select Constant Contact. 
2. Click Manage. 
3. Click Add. 
4. In the Account Name field, enter an account name to identify this Constant Contact account within 

HeadMaster. 
5. Enter your Constant Contact username and password. 
6. Click OK. 

  

  

   

Useful Information: To manage your Constant Contact account in HeadMaster, you must submit a request 
directly to Constant Contact. To do this, call Constant Contact support at 1-866-289-2101 or 1-800221-
2701. You’ll need to provide your Constant Contact username and password.  

https://acstechnologies.constantcontact.com/index.jsp
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Create a Constant Contact Email List 
 
As an administrator, once you’ve added your Constant Contact® account to HeadMaster, you can create new 
Constant Contact email lists. You can create a list by manually locating individuals by type or by loading individuals 
from saved search results. 
 
To create a constant contact email list  

1. In the Tools menu, select Constant Contact. 
2. Click New List. 
3. Click View Type and select the record type you want to view. 
4. To add an individual to the email list, select the name within the list and click Add. You can add individuals 

from various record types. Repeat steps 3 and 4 until you are satisfied with your email list. 
5. Enter a name for the email list and click Upload. 
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Import and Export Data 

Use Advanced Export 
 
As an administrator, you can customize and extract larger amounts of data specifically for your reporting or 
information needs with the Advanced Export Utility. You can also save frequently used exports in this utility so that 
they can be easily run repeatedly. 
 
Advanced Export is available only with HeadMaster Pro and the OnDemand School package, and it contains 
categories of information or data sets composed of various fields that can be exported. If you are using a third-party 
Scheduler program, extra options are available. 
 
Advanced Export allows you to: 

• Easily transmit selected data to disconnected HeadMaster users (such as a laptop user). 
• Export fields to other file formats, enabling you to create reports such as call lists, immunization records, 

or emergency pickup lists. Supported programs and file formats include Microsoft® Excel, Microsoft® 
Access, comma separated text file, tab delimited text file, or an XML file for viewing in a Web browser. 

• Customize the sorting of fields and records prior to exporting data. 
 
The Advanced Export window displays lists of saved exports. From this window, an administrator can create, edit, 
delete, or process data from the HeadMaster program. 
 

 
To access Advanced Export, on the Windows Start menu, click All Programs > HeadMaster > Advanced Export. 
Select the data set from which you want to export the information.  
 
Useful Information: Once you start Advanced Export, you can press F1 on your keyboard to view Help.  

1. On the toolbar, click Customize. 
2. The Customize Export Grid dialog box opens and displays column names that don't currently appear in 

the grid. 
3. To add columns, click a column heading name on the Customize Export Grid menu. Drag and drop the 

name to the column heading row. You can click and drag column heading names to rearrange them. 
4. To remove a column heading, click the column heading name and drag it to the Customize Export Grid 

menu. 
5. On the toolbar, click New. 
6. In the Categories menu, click to select an export category. 
7. To customize the contents of the data you plan to export, select the Include the Deactivated Records 

check box or select a saved search from the User Search drop-down list. 
8. Click Next . 
9. In the HeadMaster Fields menu, click the plus sign (+) next to an item to display more choices. To add field 

names to the Selected Fields window, double-click the field names. 

10. To rearrange the order of the fields you selected, click . 
11. Click Next . 
12. To select a field to sort by, double-click a field name in the Available Fields menu. You may select multiple 

fields. The records will sort in the order the fields are listed. 
13. Click Next. 
14. Enter a title and description, and click Finish . 
15. Highlight the export you want to process. 

  

 or  

Useful Information: If you access HeadMaster through OnDemand, click the HM Advance Export icon to use 
the Advanced Export.  
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16. Click Process. Each record that will be exported can be viewed in the Export Data window. To filter 

records, select a field name and click Filter by Selection . To remove the filter, click Clear Filter . 
17. On the toolbar, click the Export drop-down list and select As CSV to create a comma-separated text file; 

select As Tab Delimited to create a tab-separated text file; or select As Fixed Length. 
18. In the Save As window, navigate to the drive and folder where you want to save the file. 
19. Enter a name for the file. 
20. Click Save. 
21. Highlight the name of the saved export. 
22. Click Edit. 
23. Edit the categories, fields, sort order, title, or description.  
24. Click Finish. 
25. Highlight the name of the saved export. 
26. Click Delete. 
27. Click OK. 

 
The following categories are included in Advanced Export: 

• Class 
• Courses 
• Immunization 
• Individuals 
• Pickup 
• Prospective Students 
• Staff Emergency 
• Student Custom Fields 
• Student Emergency 
• Students 
• Teacher Emergency 
• Teachers 
• FCS Control* 
• FCS Courses* 
• FCS Requests* 
• FCS Student* 
• FCS Teacher* 

 
*These options are available only with the FCS scheduler program.  
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Import Data from ACS People 
 
If you are an ACS People user, as an administrator, you can import multiple records from ACS People into 
HeadMaster. With this option, you can decrease manual data entry time by using basic information that already 
exists in People. For more information about ACS People, visit our website. 

1. On the File menu, click Import > Import from ACS. 
2. To designate an age range for children in the families to display, select only families with children between 

the ages of the check box. Select the low and high end of the age range.  
 

 
3. Click Set Filters. 
4. To select People records, click the check box beside each name you want to import. 

 

 
5. Click Import.  

 
 

  

  

  

   

Note: The program defaults to families with children ages 5 - 18. 

Useful Information: Optionally, to view specific information that will be imported, double-click 
Parent Information or Child Information to expand the view. To close the view, double-click the 
header again.  

Useful Information: To locate a specific family in the Import ACS window, enter a name in Search 
Family Name for.  

http://www.acstechnologies.com/products/acs/features/acs-people
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Import Data from Full Control Scheduler (FCS) 
 
As an administrator, if you recently exported data from HeadMaster into FCS for the purpose of processing course 
requests, it's time to import the schedules into HeadMaster. If you have an FCS license on your computer, you can 
use HeadMaster’s Import Utility to import data into HeadMaster. 
 
Before you can begin this process, the HMServer.exe must be stopped. On the server base computer, right-click on 
the HeadMaster Server icon and click Stop. After you finish the process, right-click on the icon again and click Start. 

1. Open the Utility Manager. 
a. Windows 7 and Windows Vista: On your Windows desktop, click the Start button  in lower-left 

corner of the screen. The Start menu displays. Click All Programs > HeadMaster > Utility 
Manager. Log in with your username and password and click OK. The Database Utilities window 
displays.  

b. Windows 8.1: On the Windows desktop, click the Start Button  in the lower-left corner of the 

screen. The Start screen displays. Click the arrow button . The Apps view displays. In the 
HeadMaster section, click Utility Manager. Log in with your username and password, then click 
OK. The Database Utilities window displays.  

c. Windows 10:  On the Windows desktop, click the Start button  in the lower-left corner of the 
screen. The Start menu displays. Scroll to the HeadMaster section and click Utility Manager. Log 
in with your username and password, then click OK. The Database Utilities window displays.  

2. Click Import Schedule. The Database Utilities dialog box displays. 
3. In the data set list, select the data set to import the FCS displays.  
4. Select the directory that contains the FCS data. This is normally the FCS32 folder.  
5. Click Next.  
6. When scheduling is complete, click OK.  
7. Click Exit. 

 
 

  

   



Copyright © 2014, ACS Technologies 32 

 
 
 
Import from Classroom Manager (Administrator) 
 
When teachers use Classroom Manager on laptops that are disconnected from the network, the school administrator, 
secretary or teacher must import data back into HeadMaster in order to update the school data set. 

1. On the File menu, click Import > Import from Classroom Manager. 
2. Click Browse. 
3. Select the location of the file to import and click Open. 
4. Click Import. 
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Refresh Imported People 

 
You can refresh people imported from ACS. On the File menu, click Refresh Imported People to display the most 
recent data from the ACS People module. 
 
If any names can't be found in ACS, the Information window will display with a list of the names. 
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Import Pictures 
 
There are two options available for importing pictures to student records.  
 
Option 1 – You can import pictures from a specific folder location with file names that correspond with each ID 
number per record in the program. 

  
For example: you have all student pictures in a folder called Yearbook Pictures and Nelly Nancy’s ID is 10002 
making her picture file 10002.jpg.  

 
Option 2 – If you have pictures with specific names created by you or the photographer, you can create a .csv file in 
Microsoft® Excel ®where Column 1 has the individual’s ID number and Column 2 has picture file name. This .csv file 
can be imported along with the picture’s files from a specific location to attach the pictures to their corresponding 
individual records. 
 

 
To import pictures 

1. On the File menu, click Import > Import Pictures. The Picture Import dialog box displays.  
2. Select Option 1 or Option 2b.  
3. Select the image directory you want to import. If you selected Option 2, also select the CSV file.  
4. Click Import.  

 
 

  

   

Note: The recommended picture size is Standard size is 800 x 600. We also recommend no larger than 600 
pixels.  



Copyright © 2014, ACS Technologies 35 

 
 
 
Import Online Payments 
 
Once you set up online payments, you'll be able to import the payments into HeadMaster. When you import the 
payments into HeadMaster, each payment will be applied to the oldest invoice. 
 

To import online payments into HeadMaster 
1. On the File menu, select HM Online. 
2. Select Import Payments. 
3. Select the payments you want to import. 
4. Click Post Selected. 

 
This imports all of the online payments to the family records.  
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Back Up and Restore Data 

Archive Datasets 
 

As an administrator, you can archive older data sets so that they cannot be accessed by users in other parts of the 
program. 
 
The data sets you archive will no longer appear in the Dataset drop-down menu within the HeadMaster login dialog 
box. They will also be hidden in a number of administrative applications and processes such as Advanced Export, 
HeadMaster Import, Table Maintenance, Import Schedule, Promote, Rename Database, and Delete Attendance. 
 
To archive datasets 

1. In your local HMaster directory, double-click the HMUtils.exe file. 
2. Enter your username and password and click OK. The Database Utilities window displays. 
3. Click Archive Dataset. 
4. Click the data set name. 
5. Click Deactivate. 
6. Repeat for each data set you want to archive. Click Activate to make archived data sets visible again. 
7. Click Close. 
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Back Up HeadMaster Data 

 
As an administrator, you can use the Backup utility to perform routine system backups. Before backing up and 
restoring data, you must stop the HMServer.exe service. 
 
To back up and restore your data 

1. On your server, locate the HM Server icon  in the System Tray. 
2. Right-click on the icon, then click Stop.  
3. In your local HMaster directory, double-click the HMUtils.exe file. 
4. Enter your username and password, then click OK. The Database Utilities window displays. 
5. Click Create Backup. 
6. To select the location where you want to save your backup, click Browse. 
7. To omit picture files, select Omit Picture Files.  
8. Click Backup. 
9. After the HeadMaster data is backed up, click OK. 
10. In your local HMaster directory, double-click the HMUtils.exe file. 
11. Enter your username and password, then click OK. The Database Utilities window displays. 
12. Click Restore Backup. 
13. To select the location where you want to restore, click Browse. 
14. Click Next. 
15. Click Finish to restore the selected backup. 
16. After the HeadMaster data is restored, click Close. 

 

   

Note: Do not restore data from a version older than the one you are currently using.  



Copyright © 2014, ACS Technologies 38 

 
 
 
Copy a Term 
As an administrator, you can copy all data from the old term into the new term. 
 

 
To copy a term 

1. In your local HMaster directory, double-click the HMUtils.exe file. 
2. Enter your username and password, then click OK. The Database Utilities window displays. 
3. Click Copy Term. 
4. Select the name of the database that you want to copy a term to and click Next. 
5. Select the database that you are copying from and click Next. 
6. Click Finish. 
7. When the process is complete, click OK. 

  

  

   

Note: Before you can begin this process, the HMServer.exe must be stopped. On the server base computer, 
right-click on the HeadMaster Server icon and click Stop. After you finish the process, right-click on the icon 
again and click Start.  
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Create a New Database 
 
As an administrator, at the beginning of a new school year, or as organizational changes are made, you may find it 
necessary to create a new, empty database. 
 

 
To create a new database 

1. In your local HMaster directory, double-click the HMUtils.exe file. 
2. Enter your username and password, then click OK. The Database Utilities window displays. 
3. Click Create Database, then enter a name for the new database. 
4. Click Next > Finish. 
5. The next time you log into HeadMaster, select the new database name in the Dataset list. 
6. When the process is complete, click OK. 

  

  

   

Note:  
• Prior to creating a new database, all users must exit HeadMaster.  
• Before you can begin this process, the HMServer.exe must be stopped. On the server base computer, 

right-click on the HeadMaster Server icon and click Stop. After you finish the process, right-click on the 
icon again and click Start.  
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Delete a Database 
 
As an administrator, you can delete a database.  
 

 
To delete a database 

1. In your local HMaster directory, double-click the HMUtils.exe file. 
2. Enter your username and password, then click OK. The Database Utilities window displays. 
3. Click Delete Database. 
4. Select the name of the database you want to delete and click Next. 
5. Click Delete Database. 
6. To proceed, click Yes. 
7. When the process is complete, click OK. 

  

  

   

Note: 
• Before you can begin this process, the HMServer.exe must be stopped. On the server base 

computer, right-click on the HeadMaster Server icon and click Stop. After you finish the process, 
right-click on the icon again and click Start. 

• This process alters data. We recommend backing up your data before proceeding.  
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Rename a Database 
 
As an administrator, you can use the Rename Database utility to change the name of an existing database. Database 
names are limited to eight characters. 
 

 
To rename a database 

1. In your local HMaster directory, double-click the HMUtils.exe file. 
2. Enter your username and password, then click OK. The Database Utilities window displays. 
3. Click Rename Database. 
4. Select the name of the database that you want to rename and click Next. 
5. Enter the new name and click Next. 
6. Click Finish. 
7. When the process is complete, click OK. 

  

  

   

Note: 
• Before you can begin this process, the HMServer.exe must be stopped. On the server base 

computer, right-click on the HeadMaster Server icon and click Stop. After you finish the process, 
right-click on the icon again and click Start. 

• This process alters data. We recommend backing up your data before proceeding.  
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Set Security for a Report 

As an administrator, you can set up security for a report. 
1. On the Home screen, click Reports. 
2. Right-click on a report and click Set Security. 
3. Select a security option and click Add. 
4. Click Save. 
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Schedule HeadMaster Online Uploads in HeadMaster Desktop 

In order to save time through the convenience of automated tasks, you can set up scheduled HeadMaster Online 
uploads in the HeadMaster desktop. This must be set up on your server, and HeadMaster must be installed locally 
on the C: drive of your workstation. 
 

 
To set up a scheduled upload to HeadMaster Online in Microsoft Windows 

1. Log in to HeadMaster and click Tools > Options > Scheduled Tasks. 
2. Select a data set. 
3. Click Close and exit HeadMaster. 
4. In Microsoft Windows, open the Control Panel. 
5. In the Control Panel, click Administrative Tools. This step is for the "Classic View" in the Control 

Panel. 
6. Double-click Task Scheduler. 
7. On the main menu, click Action > Create Task. 
8. On the General tab, enter a name for the task and make the other selections you want. 
9. On the Triggers tab, click New. Select On a schedule in the drop-down list, make the other selections 

you want, and click OK. 
10. On the Actions tab, click New. Click Browse, navigate to your local HMaster directory, select 

HMUtils.exe, and click Open. 
11. In the Add arguments data field, type UPLOAD and click OK. 
12. On the Conditions and Settings tabs, make the other selection you want. 
13. Click OK. 

 

  
 

  

  

   

Note:  If you plan to make the automated upload into a scheduled task, we recommend that you set your 
automated upload settings first. Navigate to Tools > Options > Scheduled Tasks. In the drop-down list, 
select a data set. Then, select if you want to import lunch preorders.  

Useful Information: Headmaster OnDemand users can also schedule uploads. To learn how to schedule 
HeadMaster online uploads in OnDemand check out our Online Guide for Administrative Staff.  
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View Statistics About Your HeadMaster Data 

The Statistics tab is a customizable, statistics-at-a-glance feature where you can readily track the information that 
most interests you. The Statistics tab contains a list of predefined information categories from which you can select. 
 

 

To customize the statistics, you want to view 
1. On the Home screen, click the Statistics tab located at the bottom of the screen. 
2. Select an information category from the Options list and click Add. Your selection displays in the right 

box. 
 

 
 

3. Select an option for how to display the information as well as a color.  
 
 
 

 
4. You can view your information and click Print if you want.  

 
 

  

  

  

  

  

   

Useful Information: The Statistics tab is viewable only to administrators and regular users with the Report View 
permission.  

Note: you can select a maximum of four information categories to view simultaneously. 

Note: The Pie Chart and Bar Graph views both display the number of records. The Grid view 
displays the number of records and a percentage.  
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Post School Announcements 

Administrators can publish school announcements. Enter the announcements in HeadMaster, then upload them 
to HeadMaster Online (the HMOnline option in the File menu) so parents and students can view them when they 
log in. 
 
To post school announcements 

1. On the Home screen, click Announcements. 
2. Click New. The Announcement dialog box displays. 
3. Enter the Title, such as “Candy Sales End Tomorrow!” 
4. Enter a Publish Date. This is the first day you want the announcement to be available online. 
5. Enter an Expiration Date. This is the last day you want the announcement to be available online. 
6. If applicable, select Public.  
7. If the announcement is limited to a single grade or class, select the appropriate Class. if the 

announcement should display for the whole school, leave the default <None>. 
8. If there is a website for more announcement details, enter the full address in the Web Link field. 
9. Enter any notes you want in the Notes field. 
10. Click OK. 

 

 

 
  

   

Useful Information: If an announcement is public, people can view it outside of HeadMaster Online. You can 
display public announcements using the link found in Web Links when logged into HeadMaster Online as an 
administrator. 
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Post Events 

You can publish events to HeadMaster Online and group them by categories so that students and parents can filter 
events on the calendar and view what is of interest to them. 

Prior to adding events, you must set up event categories. Once these categories are set up, you can enter events and 
post them to HeadMaster Online. 
 

 
To add a new event 

1. On the Home screen, click Define List. The Define List dialog box displays. 
2. In the Available Fields list, expand Events and click Categories. 
3. Click Add. The New Event Category dialog box displays. 
4. Enter the category name, such as Athletics, Fund raisers, Lower School, etc. 
5. Click OK. 
6. On the Home screen, click Events. 
7. On the toolbar, click New. The Add Event dialog box displays. 
8. Enter the general information about the event and the primary contact information. 
9. Click OK. 

The next time you publish to HeadMaster Online, events with dates between the current date and 14 days out will 
be visible to students and parents. 

  

  

   

Note: If applicable, select Public. If an event is public, people can view it outside of HeadMaster Online. You 
can display public events using the link found in Web Links when logged into HeadMaster Online as an 
administrator.  
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View Today's Attendance and the Students and Teachers Currently Checked In 

As an administrator, you can view a list of the teachers who have posted school attendance for the day as well as a 
count of teachers and students who are currently checked in. Teachers and staff can add and view information on 
the calendar too. To view this information, on the Home screen, click the Calendar tab. 
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Set Class Period Times 

You can add, edit, or delete the period structures used for each class. 
1. On the Home screen, click Options. 
2. In the options list, click Period Setup. 
3. Click Add. The Add New Period dialog box displays. 
4. Enter the period information. 
5. Repeat steps 3-4 for each period. 
6. Click OK. 
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Track Changes of Individual Records 

You can keep track of changes, such as deletions and grades, to individual records. 
1. On the File menu, click Change Log. The Change Log dialog box displays. 
2. Select the Use Date Range check box and enter a date range. 
3. Click OK. 

 

 

  

  

  

Useful Information: As changes are made during the selected date range, they will display in 
each of the tabs.  
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