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Integrate HeadMaster Online Information with Your School's Web Site 
 
Once you’re up and running with HeadMaster Online, you’ll want to provide access to it from your school website. 
Your school’s web administrator can create a link that points to the following URL: 

 

This URL removes the Site Number field from the login window. So, your HeadMaster Online users only have to 
enter their username and password without having to recall your school's site number. This makes their login 
experience simple and convenient. 
 
How about a link on the school website for prospective students to apply for admission? Just have your web 
administrator create a link that points to the following URL: 

 

Since this links to your HeadMaster Online site, the HeadMaster banner and header will display by default. 
However, visitors won't be required to log in to HeadMaster Online in order to view the announcements on the 
page. 
  

 https://secure.headmasteronline.com/hmolweb/login.aspx?SiteNumber=#####                                    

( Replace ##### with your school's site number. ) 

https://secure.headmasteronline.com/hmolweb/newstudentinfo.aspx?site=##### 

( Replace ##### with your school's site number. ) 

Insert the following URL: 

https://secure.headmasteronline.com/hmolweb/publicevents.aspx?sitenumber=##### 

( Replace ##### with your school's site number.)  

Examples 

If your school's site number is 999999, both of the URLs should be entered on the school website like this: 

https://secure.headmasteronline.com/hmolweb/login.aspx?SiteNumber=999999 

https://secure.headmasteronline.com/hmolweb/newstudentinfo.aspx?site=999999 
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Hide the HeadMaster Banner and Header 
 

If you want to hide the HeadMaster banner and header, use the following URL: 
 
 
 
 

  

https://secure.headmasteronline.com/hmolweb/publicevents.aspx?sitenumber=#####&NoHeader=true 

Replace ##### with your school's site number.)  

Useful Information: You can insert either of the URLs in an <iframe> HTML tag. This will dock the 
announcements in a separate window within your website. That way, visitors won’t be directed away from your 
school website.  
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Set up Financial Upload Options 
 
If you use HeadMaster Billing or interface with ACS Accounts Receivable, you can upload statements to 
HeadMaster Online for parents to view and print.  

1. This allows families to check their payment history and current balance due. 
2. In HeadMaster, on the Home screen, click options. 
3. Click HMOnline. 
4. Under Financial Upload, make a selection. 
5. If you selected ACS Accounts Receivable, click Select, and select the ACS data set you want to upload. 
6. Click Close. 
7. In the ACS Reports window, under Accounts Receivable, expand Extracts and select HeadMaster Online 

Extract. 
8. Under HeadMaster Online Extract, click Customize. 
9. On the Options tab, select Print One Per Family. 
10. Make any additional selections you want and click Extract. 
11. Once the extract is complete, click OK. You can now upload the extract to HeadMaster Online. 

 

 
 

 

   

Tip:  
Before you upload ACS Accounts Receivable data to HeadMaster Online, make sure you’re using ACS Version 
10.0.1.6, 10.2.1.1, or later, and complete the following tasks: 

• Import your student records from HeadMaster into ACS Accounts Receivable. 
• In ACS Accounts Receivable reports, generate the HeadMaster Online Extract. 

 
We recommend that you also select Group Payments with Invoices.  
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Perform Billing Inquiries 
 
Your financial office can specify an email address for parents to use when they have billing questions. 

1. In HeadMaster, on the Home screen, click Options. 
2. Click HM Online. 
3. In the Billing Contact E-mail field, enter the email address that financial questions should be sent to. 
4. Click Close. 
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View a Family's Credit Balance 
 
If you use HeadMaster Billing and a family has a credit balance, it will only display on the Overview page if you also 
use Accounts Receivable or Lunch: 
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Otherwise, you can click the Reports tab and select Billing Report to view the credit balance: 
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Set Up Optional Uploads 
 
Selection of these items adds new elements to the HeadMaster Online screens. The new menu items, tabs, and 
panes will be available to parents and students when they log on to HeadMaster Online. 

1. In HeadMaster, on the Home screen, click Options.  
2. Click HMOnline. 
3. Make your selections under Upload Options. Use the descriptions below for reference. 

a. Upload Class Attendance - The next time you upload to HeadMaster Online, an Attendance > 
Class Attendance menu item will become available. Attendance information will also be added to 
the main dashboard in a new pane. 

b. Upload School Attendance – The next time you upload to HeadMaster Online, an Attendance > 
School Attendance menu item will become available. Attendance information will also be added to 
the main dashboard in a new pane. 

c. Upload Behavior –The next time you upload to HeadMaster Online, a Behavior menu item will 
become available. Behavior information will also be added to the main dashboard in a new pane. 

d. Upload Calendar – The next time you upload to HeadMaster Online, the calendar will become 
available. 

e. Upload Lunch Calendar – The next time you upload to HeadMaster Online, the Lunch Calendar will 
become available. 

f. Use Online Re-enrollment – The next time you upload to HeadMaster Online, a Re-enrollment tab 
will be available for parents to select which students will be returning for the upcoming year. 

4. Click Close. 
 

  

Tip: If you have HeadMaster Lunch, you can also select to Upload Lunch Calendar and/or Allow Pre-orders. 
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Upload Grade, Assignments, and Financial Information to HeadMaster Online 
 
You can upload student grades, assignments, and financial information to HeadMaster Online so that parents and 
students can log in and view them from home. 
 
To upload grades, assignments, and financial information to HeadMaster Online 

1. In HeadMaster, on the File menu, click HM Online > Upload. The HeadMaster Online Export window 
displays. 

2. Click Next. 
3. Click Upload. 
4. Once the program uploads your files, click OK. 

 
  

Note: You’ll need to run uploads regularly in order to keep the information in HM Online updated.  
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Select an Active Grading Period 
 
You can set up HM Online so that a specific grading period uploads to HM Online and displays by default when you 
log in. 
 
To select an active grading period 

1. In HeadMaster, on the Home screen, click Options. 
2. Click HMOnline. 
3. Under Active Period, select the grading period from the drop-down lists. 
4. Click Close.  
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Publish Announcements 
 
Teachers can enter and publish announcements for their classes, and administrators can publish school 
announcements. Enter the announcements in HeadMaster, and then upload them to HeadMaster Online (the 
HMOnline option in the File menu) so that parents and students can view them the next time they log in. 

1. In HeadMaster, on the Home screen, click Announcements. 
2. On the toolbar, click New. The Announcement dialog box displays. 
3. Enter the Title, such as “Candy Sales End Tomorrow!” 
4. Enter a Publish Date. This is the first day that you want the announcement to be available online. 
5. Enter an Expiration Date. This is the last day you want the announcement to be available online. 
6. If it's applicable, select a Class. For example, if the announcement should appear for the whole school, 

leave the default <None>. If the announcement should be limited to a single grade or class, select the 
appropriate grade or class from the list. 

7. If there's a website to refer a parent to for more announcement details, enter the full address in the Web 
Link field. 

8. Click OK.  
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Publish Events 
 
Publish events online using the Events feature. You can group events by categories so that students and parents 
can filter events on the calendar and view what is of interest to them. Prior to adding events, you must set up Event 
Categories in Define List. Once these categories are set up, enter events and publish online. 
 
To add a new event category 

1. In HeadMaster, on the Home screen, click Define List. 
2. In the Available Fields list, expand Events, and click Categories. 
3. Click Add. The New Event Category dialog box displays. 
4. Enter the category name, such as Athletics, Fund raisers, Lower School, etc. 
5. Click OK. 
6. Repeat steps 3 through 5 to add categories. 
7. Click OK. You're now ready to add events. 

 
To add a new event 

1. In HeadMaster, on the Home screen, click Events. 
2. On the toolbar, click New. The Add Event dialog box displays. 
3. Enter the general information about the event and the primary contact information. 
4. Click OK. 

 
The next time you publish to HeadMaster Online, events with dates between the current date and 14 days out will 
be visible to students and parents.  
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View Administrative Reports 
 
There are three reports that Administrative staff can view: System Log, Upload Log, and Online Payments. To view 
administrative reports, in HeadMaster Online, click Reports. Select the report you want to view. 

  

Additional Field Information 

System Log 
View a list of all log-in occurrences within your HeadMaster Online version. You have options to filter the list according to individual user names and  

whether the log in attempts were successful or not. Any time you change the filtering options, click   to refresh the list. Click   to delete the list  Go Clear 
entries. 

Upload Log 

View the dates and times that the administrator uploaded a data set and whether each upload was successful or not. Click   to delete the list  Clear 
entries. 

Online Payments 
View a list of all online payment transactions. You have options to filter the list according to payment period dates and transaction types. Any time you  

change the filtering options, click   to refresh the list. Click   to open or save the list in Excel® (.xls)  format. Go Export 
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Select a Dataset for Automatic Upload to HeadMaster Online 
 
You can schedule an automatic upload of a data set to HeadMaster Online. However, you must select which data 
set you want to upload from within HeadMaster. 

1. In HeadMaster, on the Home screen, click Options. 
2. Click Scheduled Tasks. 
3. In the drop-down list, select the data set you want to upload. 
4. To save, click Close. 
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Manage HeadMaster Online (HMOL) Change Requests 
 
You can use the HMOL Change Request Manager to accept or decline changes made online to information on 
individual’s accounts. Individuals can update their names, titles, phone numbers, mailing addresses, and email 
addresses. Parents can update their marital status, company, and job title. A student’s emergency contacts, and 
pickup information can be updated, as well. 
 
We recommend that you check this frequently to keep your records up to date. 

1. In HeadMaster, on the File menu, click HM Online > Manage Change Request. 
2. Select an individual under Pending Request and note the changes they have requested under Changes. 
3. Select the corresponding tab(s) at the bottom of the screen to view the requested changes. 
4. If you want to decline the change, clear the Accept check box. 
5. Click Post.  
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Getting Started with Online Payments 
 
Offering online payment options for your customers makes payment transactions more convenient, streamlines 
your receivables, and provides additional convenience for parents/guardians to make payments through the 
HeadMaster Mobile App. We partner with Vanco Payment Solutions to process the online transactions. To start 
using online payments, you must apply for a merchant account with Vanco Payment Solutions. 
 
You can apply for a Vanco account by doing one of the following: 

• Go to www.acstechnologies.com/vanco 
• Log in to HM Online as an administrator 

 
If you log in to HM Online as an administrator: 

1. Go to Options > Online Payment Setup. 
2. Enter your first and last name in Step 1. 
3. Complete the application in Step 2. 

 
 
 

  

 

  

  

  

 

Note: To apply for your merchant account, you’ll need the following: 
• Voided check 
• Copy of the first page of your organization’s bank statement 
• Federal Tax ID Number 
• Legal name as it appears on current IRS records for your organization 

https://wiki.acstechnologies.com/display/headmaster/Make+an+Online+Payment+with+HeadMaster+Mobile
http://www.acstechnologies.com/vanco
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Importing online payments 
 
If you have both HeadMaster and ACS, you can import your online payments into HeadMaster and ACS Accounts 
Receivable. 
 
Import Online Payments 
 
Once you set up online payments, you'll be able to import the payments into HeadMaster. 
When you import the payments into HeadMaster, each payment will be applied to the oldest invoice. 
 
To import online payments into HeadMaster 

1. On the File menu, select HM Online. 
2. Select Import Payments. 
3. Select the payments you want to import. 
4. Click Post Selected. 

 
This imports all of the online payments to the family records. 

 

  

https://wiki.acstechnologies.com/display/headmaster/Setting+Up+Online+Payments
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Importing HeadMaster Online Payments into Accounts Receivable  
 
If you use HeadMaster Online, you can use the Import Payments option to import those payments into Accounts 
Receivable. 
 
When importing online payments from HeadMaster, the default Payment Fee type is Miscellaneous, but you can 
select any type of Payment Fee to assign to the payments you are going to import. The payments that you import 
will apply to the oldest unpaid invoices first. The name, date, and amount of each transaction will display, as well 
as the total amount selected for import. 
 
All records from the HeadMaster Online Import will import as online payments, but you still need to post them. 
You can edit the entries before posting them if you need to make changes. 
 

 
To import Payments into Accounts Receivable from HeadMaster Online Import 

1. Under Manage Records, click the Transactions tab. 

2. In the drop-down list, select Accounts Receivable Payments and click Go . 
3. Click Add/Edit Payments, then Import Payments. 
4. Click HeadMaster Online Import. 
5. Select the Payment Fee type you want to import and select the Posting Period. 
6. Select the transactions you want to import, then click Import. 

  

Note: HeadMaster Lunch deposits do not get posted in A/R. You will need to import those payments into 
HeadMaster on a regular basis.  
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Online payments for parents 
 
Parents can make their online payments via HeadMaster Online or HeadMaster Mobile. Check out our 
Headmaster Guide for Parents and Students to learn more about: 

• Making Online Payments 
• Installing Headmaster Mobile 
• Making Online Payments with HeadMaster Mobile 
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Setting Up Online Payments 
 
Your organization must have a merchant account with Vanco Payment Solutions in order to set up online 
payments. 
To help ensure the security of customer financial information, only Administrative users can set up online 
payments. 
In order for the parent/guardian of a student to make online payments, they must be in the student's primary family 
and the student record must be set to Publish Online. 
 

To set up online payments 
1. Log into HeadMaster Online as an administrator.  
2. Navigate to Options > Online Payments Setup. 
3. Select the types of payments you want to accept: Family payments, lunch payments, or both. 
4. Select the forms of payments you want to accept: Credit card, electronic check, or both. 
5. Select your deposit account. 
6. Enter the person in your organization who parents can contact about online payment questions. Be sure to 

include the contact email address. 
7. Edit any of the email templates you want: 

a. Payments Processed – sent when an online payment has been processed. 
b. Recurring Payments Setup – sent when a parent sets up a recurring payment. 
c. Expired Credit Card – sent when a credit card on file has expired. 
d. Expiring Credit Card – sent when a credit card on file is expiring soon. 
e. Deleted Payment – sent when a parent deletes a payment. 
f. Payment Processing Error – sent when there is an error processing the online payment. 

8. Enter the reply to email address for the automated emails, and the signature. 
9. Click Save. 

 
Your ability to accept online payments is now set up. Parents can begin making one-time payments to your 
organization, or they can set up recurring payments. 
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Online Payments Administration 
 
There are a couple of locations within HeadMaster Online from which you'll handle online payment administration: 

1. Click Options > Online Payments Setup. You completed this during initial setup, and now you can edit 
any of the fields anytime as needed.  

2. When your done editing, click Save.  
3. Click the Reports tab to view administrative reports. There are several reports that you may find useful: 

a. Online Payments – Displays all online payments given for a selected date range. It lists who made 
the payment, payment date, payment type, receipt number, and amount paid. 

b. Bank Deposit Report – Displays all deposits in your bank account. It lists the Batch ID, deposit 
date, batch type, number of transactions, and deposit total. 

c. Scheduled Payments Report – Displays all recurring payments that have been scheduled. 
Deleted Payments Report – Displays all online payments that have been deleted. 

 
In order for the parent/guardian of a student to make online payments, they must be in the student's primary family 
and the student record must be set to Publish Online. 
 
There's not much to administering your online payments because the process is efficient for you and your online 
payment customers. 

 

 
 
 
 
  

Useful Information: Reasons why a transaction fails: 
• Unprocessed recurring payments are placed on hold, and parents are notified by email. From this email, 

parents can sign into HeadMaster Online and fix the payment method.  
• Banks may or may not notify parents about any returns. Vanco will always notify the school but never 

email parents directly. It’s up to the school to decide how to communicate this. 
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Implement New School Year Procedures for HeadMaster Online 
 
The annual preparation for a new school year is a major task for your school, and it’s important that your school 
performs that task well every year. There are a number of HeadMaster procedures that you can use to ensure that 
your school is properly prepared for the new school year.  
 
You must have performed your promotions to the new school year before implementing the new school year 
procedures.  
 

 

Useful Information: At the beginning of a new school year, you may find it necessary to create a new database.  
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Set up the School Information 
 
The first procedure is setting up your term description. 

1. In HeadMaster, on the Home screen, click Options. 
2. In the Term section, enter the new school year in the Description field. Example: 2012-2013 
3. Click Close.  
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Set Up Grading Period Dates 
 
To have correct attendance totals appear in HeadMaster and on the student report cards, you must set up the 
grading period dates for the new school year. 

1. In HeadMaster, on the Home screen, click Options. 
2. Click Grading Periods. 
3. From the tabs at the bottom of the screen, click a grading period. 
4. Click Set Dates. 
5. For each period, enter a Start Dates and End Dates. 
6. Click Close. 
7. If needed, select another Grading Period. 
8. After you enter all the dates you want, click Close.  
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Enroll Prospective Students 
 
If you have been using Prospective Students to manage the waiting list for new students to your school, you must 
move those students to the Active Student list. You can enroll one student at a time or multiple students at the same 
time. 

1. In HeadMaster, on the Home screen, click Prospective Students. 
2. Double-click the student you want to enroll. 
3. Click the Enrollment tab. 
4. Ensure the Status information is complete. 
5. Click the Enroll Now. 
6. In HeadMaster, on the Home screen, click Prospective Students. 
7. Select multiple students while pressing Shift or Ctrl on your keyboard. 
8. On the icon toolbar, click Actions. 
9. Click Enroll.  
10. Click OK.  
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Enter New Students 
 
The Add Student Assistant provides a convenient way for you to enter new students. 

1. In HeadMaster, on the Home screen, click Add Student. 
2. Enter the student's information. 
3. Click Next. 
4. Select Enter new family information. 
5. Click Next. 
6. Enter the Primary Family Information. 
7. Click Next. 
8. If there is no secondary family, select None. If secondary family information is available, select Enter new 

family information. 
9. Click Next. 
10. Enter secondary family information (If applicable). 
11. Click Next. 
12. Enter emergency contact and pickup information. 
13. Click Finish.  



 

Copyright © 2014, ACS Technologies 29 

Assign Homeroom Teachers 
 
You have the ability to mass assign homeroom teachers if you have not retained homeroom teachers during the 
promotion process. You can move groups of students from one homeroom teacher to another, or you can select 
different students for each homeroom teacher. 

1. In HeadMaster, on the toolbar, click File > Mass Change. 
2. Click to expand Students. 
3. Click Homeroom Teacher. 
4. In the Options section, select Search and Replace. 
5. In the Value to Change field, click the drop-down arrow and select the current homeroom teacher. 
6. In the New Value field, click the drop-down arrow and select the new homeroom teacher. 
7. Click Change. 
8. Click Yes. 
9. Click OK.  
10. To change more homeroom teachers, repeat steps 5-10. 
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Select individuals for mass change 
1. In HeadMaster, on the toolbar, click File > Mass Change. 
2. Click to expand Students. 
3. Click Homeroom Teacher. 
4. In the Options section, select Select Individual. 
5. Click Select. The Select student dialog box displays. 
6. Click the Grade Level column header. 
7. Select multiple students while pressing Shift or Ctrl on your keyboard. 
8. Click Add. 
9. Click OK. 
10. In the New Value field, click the drop-down arrow and select the new homeroom teacher. 
11. Click Change. 
12. Click Yes. 
13. Click OK.  
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Enroll Students in Classes 
 
You can enroll multiple students into multiple classes at the same time, or you can do student schedules one at a 
time. 

1. In HeadMaster, on the Home screen, click Student Schedule. 
2. Select a scheduling option. The following procedure steps will assume selecting the first scheduling option. 
3. Click Next. 
4. Select the students you want to create schedules for. Select multiple students while pressing Shift or Ctrl on 

your keyboard. 
5. Click Add. 
6. Click Next. 
7. Select the classes you want to add to the student schedules, and click Add. Select multiple classes while 

pressing Shift or Ctrl on your keyboard. 
8. Click Save. 
9. To continue adding classes, click Yes.  
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Set Up the School Calendar 
 
The School Calendar is created using the start and end dates of your grading periods. Before you begin adding events 
or closings to the calendar, ensure your grading periods are set up properly. 

1. In HeadMaster, on the toolbar, click Tools > School Calendar. 
2. Enter the Start Date. 
3. Enter the End Date. 
4. Select the Type. 
5. Select the days the school meets. 
6. Click OK. 
7. In HeadMaster, on the toolbar, click Tools > School Calendar. 
8. On the calendar, right-click a date. 
9. Select the calendar option that you want. (To add more items to the calendar, repeat steps 3-4) 4.  To save 

the calendar, click OK. 
10. In HeadMaster, on the toolbar, click Tools > School Calendar. 
11. On the calendar, click Print and select the view that you want to print.  



 

Copyright © 2014, ACS Technologies 33 

Reset Lesson Plans 
 
If your teachers have been using the Lesson Plans feature and you have copied the lesson plans to the new data set, 
you can reset the dates for all teachers' lesson plans. 

1. In HeadMaster, on the Home screen, click Tools > School Calendar. 
2. Click Reset Lesson Plans. 
3. Enter the date for the first day that the lesson plans begin. 
4. Click Run. 
5. After the lesson plans have been rescheduled, click OK. 
6. To close the school calendar, click OK.  
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Enter New Teachers and Staff 
 
When you add a teacher, a staff record is automatically created. However, when you add a staff person, a teacher 
record is not created. 
 
To enter a teacher record 

1. In HeadMaster, on the Home screen, click Teachers. 
2. Click New. 
3. Enter personal information on each tab. 
4. To save the teacher record, click OK. 

 

To enter a staff record 
1. In HeadMaster, on the Home screen, click Staff. 
2. Click New. 
3. Enter personal information on each tab. 
4. To save the staff record, click OK.  
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Set Up the Lunch Calendar 
 
You can customize a weekly or monthly lunch calendar by adding items to days in Lunch Calendar. 
 
To set up the lunch calendar 

1. In HeadMaster, on the Home screen, click Lunch. 
2. Click Lunch Calendar. 
3. Click the calendar arrows to select a month. 
4. Click a calendar date. 
5. In the Menu Items column, double-click each menu item that you want to add. You can also right click a 

calendar date and add the menu items in that manner. 
6. To add multiple menu items at the same time, select them while pressing Shift or Ctrl on your keyboard and 

then click Add Item to Selected Day. 
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To copy/paste the lunch calendar 
1. In HeadMaster, on the Home screen, click Lunch. 
2. Click Lunch Calendar. 
3. Click a calendar date. 
4. Click Copy/Paste, and then click either Copy Day or Copy Week. 
5. Click the calendar date to which you want to copy the menu items. 
6. Click Paste. 
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To delete the lunch calendar 
1. In HeadMaster, on the Home screen, click Lunch. 
2. Click Lunch Calendar. 
3. Click a calendar date and click the menu item you want to delete. 
4. Click Delete, and then click Delete Item. Click Clear Day to delete all the menu items for the selected day.  
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Change Billing Code Amounts 
 
Your tuition and registration may increase each year. However, you do not need to enter new billing codes. You can 
simply edit the existing billing codes with the new price. 

1. In HeadMaster, on the Home screen, click Define List. 
2. Click to expand Billing. 
3. Click Billing Codes. 
4. Click the billing code you want to edit. 
5. Click Edit. 
6. Change the amount. (To edit more billing code amounts, repeat steps 4-6) 
7. Click OK. 
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Select Setup Options 
 
As an administrator, you have rights to set preferences in HeadMaster Online regarding the Student Directory, Staff 
Directory, and Report Options. 
 

1. In HeadMaster Online, click Options > Setup Options. 
 

2. The Student Directory tab and the Staff Directory tab both contain the same options. 

 

3. As the administrator, you set the options, but the parents/staff can override your selections by setting their 
own preferences. The only exception is that parents/staff cannot select to display a field that you don't 
select in the Select Directory Display Fields section. In their preferences, such a field option will display 
grayed. 

 

4. The third tab in the window is Report Options where you can select the student reports that you want give 
parents/staff access to. 

 
5. When you're finished with your selections, click Save. 
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Change Your Password and Learn More About HeadMaster Online Password Security 
 
For the sake of protecting your data, we recommend that you change your password often. 

1. In HeadMaster Online, click Preferences. 
2. Click the Change Password tab. 
3. Create your password and click Submit. 

 

 
Creating a strong password protects the security of your data, parents, teachers, staff, and students who use 
HeadMaster Online. 
 
As parents, students, teachers, and staff create a password, it should: 

• Contain two or more numbers and both lower- and upper-case characters 
• Be over 8 characters long 
• Not contain your username or email or include any of the following characters: < & > \/ % or space. 

 
As an administrator, ensure that you have a valid email address on record for your parents, teachers, staff, and 
students. That way, they'll receive an email notification any time their password is changed. 
 

 
After the upload to HeadMaster Online from HeadMaster Desktop, the new passwords are no longer visible within 
the Web Logon List report in HeadMaster Desktop. The entries in the Password column of the report will display the 
statement "Password changed by User." Therefore, no user password information is displayed anywhere in the 
program.  
 
As an additional security measure, if a user forgets their password and selects the "Forgot your password?" option, 
the system emails a hyperlink for them to click to reset their password instead of emailing it. 
  

  

Useful Information: Changing the HeadMaster Online password is available for parents and teachers. This option 
isn’t available to administrators, staff, and students.  

Useful Information: If a student doesn’t have a personal email address, the email address of their primary parent 
will be used – specifically the email address of the parent entered first in the system.  
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Schedule HeadMaster Online Uploads in OnDemand 
 
You can use OnDemand to schedule tasks in HeadMaster Online to run when you're busy working on other projects, 
or when your staff is the least likely to be working in the system. This can be particularly helpful for uploading 
assignments and homework to HeadMaster Online. However, only one task may be added per hour. For example, if 
you schedule an assignment upload at 3 p.m., the next task cannot be scheduled to begin until 4 p.m. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To schedule tasks 
1. In HeadMaster, select Tools > Options > Scheduled Tasks. 
2. Select the data set you want to schedule for uploading.  
3. On the OnDemand overlay, select Schedule Tasks. 
4. Click Add to begin adding a task for a specific time. 
5. Select the task you want to run, followed by the time and dates you want the task to run. 
6. Optional: Click Adjust to set your local time. Click Close. 
7. Click OK. 
8. Click Yes. Click the Task Log tab to view previously scheduled tasks.  
9. Click Close. 

 

  

Note:  
• If you plan to make automated upload into a scheduled task, we recommend that you set your automated 

upload settings first. Navigate to Tools > Options > Scheduled Tasks. In the drop-down menu, select a 
data set. Then, select if you want to import lunch preorders.  

• To add more than one scheduled task per day, you must create a separate task using the new time.  
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To edit a task  
1. Highlight the task you want to edit. 
2. Click Edit. 
3. Make changes to the time and dates, as needed. 
4. Click OK. 

 

To delete a task  
1. Highlight the task you want to delete. 
2. Click Delete. 
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Set a Message for Students on Administrative Hold 
 
Students who are flagged for administrative hold aren't allowed to view some academic information in HeadMaster 
Online, such as report cards. Their parents can't view it either. 
 
You can set a message to display whenever they try to view academic information. Use the default wording in the 
program or customize the message.  
 
To set a message for students on administrative hold 

1. In HeadMaster, on the Home screen, click Options. 
2. Click HMOnline. 
3. In the Administrative Hold section, enter a message. 
4. Click Close. 
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The Customize Online Enrollment Window 
 
To customize your school's online enrollment form: In HeadMaster, on the File menu, click HM Online > Customize 

Online Enrollment. 
 
The Customize Online Enrollment window contains five tabs, each containing different information. You can create 
new fields as well as edit current fields on each tab. 
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To add a row 
1. To add an extra row of four more fields in the Customize Online Enrollment window, click 

. 
2. To undo all your changes in the Customize Online Enrollment window, click Restore Defaults. 

 
To add new fields 

1. Click                                             . 
 

2. The Select a Field dialog box displays so you can enter information for your new field. See below.  

 

3. Notice that the Last Name and First Name field names have red asterisks. That's because they're required 
fields by default, and their status cannot be changed. 

4. When you're done, click OK > Save and Close. 
 

To edit current fields 

1. Click on the field:  
2. The selected field displays with a red box around it. 
3. To edit the field, click the Edit Field icon . The Select a Field dialog box will display exactly the same as 

when you're creating a new field. 
4. In the Select a Field dialog box, edit the field information. When you're done, click OK > Save and Close.  

. 
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To delete current fields 

1. Click on the field:  
2. The selected field displays with a red box around it. 
3. To delete the field, click the Delete icon        . 

 

 
  

  

Add a Field Dialog Box Information 

Select a Type 

Add a Field  – Adds a field in the form of a box that parents can enter information into.  

Add Plain Text  – Adds a field in the form of text, so the field receives no input. 

Add Separator Line  – Adds a line across the entire width of the form. 

  Add Field 

Header  – The name of the field as it'll display on your online enrollment form only. 

Column Size  – The design of the form divides it into four equal columns. So, you have four different column sizes to choose from. 

Required  – Select if you want the field to be required. Check boxes cannot be required fields. 

Field 

 Information  Tab name ( ) – This list will have the same name as the tab you’re working on. For example, it'll be titled   if you're on the  Student Information 
Student Information tab. 

It contains a list of the information fields on each tab. Select a field that you want to add to your enrollment form. You can use each field only once. 

Custom Fields  – Contains a list of your current   that you have defined for students and prospective students. Select a field that you want  custom field s 
to add. You can use each field only once. 

Note: To move a field in the Customize Online Enrollment window, you must delete it and then add it as a new 
field wherever you want it. This is because the window has no drag and drop functionality.  
 
Be sure to run an upload to HM Online so that your online enrollment form gets updated with your saved 
changes. 

https://wiki.acstechnologies.com/display/headmaster/Add+a+Custom+Field
https://wiki.acstechnologies.com/display/headmaster/Add+a+Custom+Field
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Allow Other Staff to Customize Your Online Enrollment Form 
 
Administrators have permission to customize the online registration form by default. But, an administrator can assign 
the permission to other staff (either as individuals or a group) using the Customize Online Registration security bit.  
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Manage New Student Requests 
 
As parents fill out your school's online enrollment form for their kids, you can pull that information down to 
HeadMaster: 

1. On the File menu, click File > HM Online > New Student Requests. The New Student Requests window 
displays. 

2. Click Post, and a record will be created for each student in the Prospective Students section. 
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	Parents can make their online payments via HeadMaster Online or HeadMaster Mobile. Check out our Headmaster Guide for Parents and Students to learn more about:
	 Making Online Payments
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	Setting Up Online Payments
	Your organization must have a merchant account with Vanco Payment Solutions in order to set up online payments.
	To help ensure the security of customer financial information, only Administrative users can set up online payments.
	In order for the parent/guardian of a student to make online payments, they must be in the student's primary family and the student record must be set to Publish Online.
	To set up online payments
	1. Log into HeadMaster Online as an administrator.
	2. Navigate to Options > Online Payments Setup.
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	d. Expiring Credit Card – sent when a credit card on file is expiring soon.
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	f. Payment Processing Error – sent when there is an error processing the online payment.
	8. Enter the reply to email address for the automated emails, and the signature.
	9. Click Save.
	Your ability to accept online payments is now set up. Parents can begin making one-time payments to your organization, or they can set up recurring payments.

	Online Payments Administration
	There are a couple of locations within HeadMaster Online from which you'll handle online payment administration:
	1. Click Options > Online Payments Setup. You completed this during initial setup, and now you can edit any of the fields anytime as needed.
	2. When your done editing, click Save.
	3. Click the Reports tab to view administrative reports. There are several reports that you may find useful:
	a. Online Payments – Displays all online payments given for a selected date range. It lists who made the payment, payment date, payment type, receipt number, and amount paid.
	a. Online Payments – Displays all online payments given for a selected date range. It lists who made the payment, payment date, payment type, receipt number, and amount paid.
	b. Bank Deposit Report – Displays all deposits in your bank account. It lists the Batch ID, deposit date, batch type, number of transactions, and deposit total.
	b. Bank Deposit Report – Displays all deposits in your bank account. It lists the Batch ID, deposit date, batch type, number of transactions, and deposit total.
	c. Scheduled Payments Report – Displays all recurring payments that have been scheduled. Deleted Payments Report – Displays all online payments that have been deleted.
	c. Scheduled Payments Report – Displays all recurring payments that have been scheduled. Deleted Payments Report – Displays all online payments that have been deleted.
	In order for the parent/guardian of a student to make online payments, they must be in the student's primary family and the student record must be set to Publish Online.
	There's not much to administering your online payments because the process is efficient for you and your online payment customers.

	Implement New School Year Procedures for HeadMaster Online
	The annual preparation for a new school year is a major task for your school, and it’s important that your school performs that task well every year. There are a number of HeadMaster procedures that you can use to ensure that your school is properly p...
	You must have performed your promotions to the new school year before implementing the new school year procedures.

	Set up the School Information
	The first procedure is setting up your term description.
	1. In HeadMaster, on the Home screen, click Options.
	2. In the Term section, enter the new school year in the Description field. Example: 2012-2013
	3. Click Close.

	Set Up Grading Period Dates
	To have correct attendance totals appear in HeadMaster and on the student report cards, you must set up the grading period dates for the new school year.
	1. In HeadMaster, on the Home screen, click Options.
	2. Click Grading Periods.
	3. From the tabs at the bottom of the screen, click a grading period.
	4. Click Set Dates.
	5. For each period, enter a Start Dates and End Dates.
	6. Click Close.
	7. If needed, select another Grading Period.
	8. After you enter all the dates you want, click Close.

	Enroll Prospective Students
	If you have been using Prospective Students to manage the waiting list for new students to your school, you must move those students to the Active Student list. You can enroll one student at a time or multiple students at the same time.
	1. In HeadMaster, on the Home screen, click Prospective Students.
	2. Double-click the student you want to enroll.
	3. Click the Enrollment tab.
	4. Ensure the Status information is complete.
	5. Click the Enroll Now.
	6. In HeadMaster, on the Home screen, click Prospective Students.
	7. Select multiple students while pressing Shift or Ctrl on your keyboard.
	8. On the icon toolbar, click Actions.
	9. Click Enroll.
	10. Click OK.

	Enter New Students
	The Add Student Assistant provides a convenient way for you to enter new students.
	1. In HeadMaster, on the Home screen, click Add Student.
	2. Enter the student's information.
	3. Click Next.
	4. Select Enter new family information.
	5. Click Next.
	6. Enter the Primary Family Information.
	7. Click Next.
	8. If there is no secondary family, select None. If secondary family information is available, select Enter new family information.
	8. If there is no secondary family, select None. If secondary family information is available, select Enter new family information.
	9. Click Next.
	10. Enter secondary family information (If applicable).
	11. Click Next.
	12. Enter emergency contact and pickup information.
	13. Click Finish.

	Assign Homeroom Teachers
	You have the ability to mass assign homeroom teachers if you have not retained homeroom teachers during the promotion process. You can move groups of students from one homeroom teacher to another, or you can select different students for each homeroom...
	1. In HeadMaster, on the toolbar, click File > Mass Change.
	2. Click to expand Students.
	3. Click Homeroom Teacher.
	4. In the Options section, select Search and Replace.
	5. In the Value to Change field, click the drop-down arrow and select the current homeroom teacher.
	6. In the New Value field, click the drop-down arrow and select the new homeroom teacher.
	7. Click Change.
	8. Click Yes.
	9. Click OK.
	10. To change more homeroom teachers, repeat steps 5-10.
	Select individuals for mass change
	1. In HeadMaster, on the toolbar, click File > Mass Change.
	2. Click to expand Students.
	3. Click Homeroom Teacher.
	4. In the Options section, select Select Individual.
	5. Click Select. The Select student dialog box displays.
	6. Click the Grade Level column header.
	7. Select multiple students while pressing Shift or Ctrl on your keyboard.
	8. Click Add.
	9. Click OK.
	10. In the New Value field, click the drop-down arrow and select the new homeroom teacher.
	11. Click Change.
	12. Click Yes.
	13. Click OK.

	Enroll Students in Classes
	You can enroll multiple students into multiple classes at the same time, or you can do student schedules one at a time.
	1. In HeadMaster, on the Home screen, click Student Schedule.
	2. Select a scheduling option. The following procedure steps will assume selecting the first scheduling option.
	3. Click Next.
	4. Select the students you want to create schedules for. Select multiple students while pressing Shift or Ctrl on your keyboard.
	5. Click Add.
	6. Click Next.
	7. Select the classes you want to add to the student schedules, and click Add. Select multiple classes while pressing Shift or Ctrl on your keyboard.
	8. Click Save.
	9. To continue adding classes, click Yes.

	Set Up the School Calendar
	The School Calendar is created using the start and end dates of your grading periods. Before you begin adding events or closings to the calendar, ensure your grading periods are set up properly.
	1. In HeadMaster, on the toolbar, click Tools > School Calendar.
	2. Enter the Start Date.
	3. Enter the End Date.
	4. Select the Type.
	5. Select the days the school meets.
	6. Click OK.
	7. In HeadMaster, on the toolbar, click Tools > School Calendar.
	8. On the calendar, right-click a date.
	9. Select the calendar option that you want. (To add more items to the calendar, repeat steps 3-4) 4.  To save the calendar, click OK.
	10. In HeadMaster, on the toolbar, click Tools > School Calendar.
	11. On the calendar, click Print and select the view that you want to print.

	Reset Lesson Plans
	If your teachers have been using the Lesson Plans feature and you have copied the lesson plans to the new data set, you can reset the dates for all teachers' lesson plans.
	1. In HeadMaster, on the Home screen, click Tools > School Calendar.
	2. Click Reset Lesson Plans.
	3. Enter the date for the first day that the lesson plans begin.
	4. Click Run.
	5. After the lesson plans have been rescheduled, click OK.
	6. To close the school calendar, click OK.

	Enter New Teachers and Staff
	When you add a teacher, a staff record is automatically created. However, when you add a staff person, a teacher record is not created.
	To enter a teacher record
	1. In HeadMaster, on the Home screen, click Teachers.
	2. Click New.
	3. Enter personal information on each tab.
	4. To save the teacher record, click OK.
	To enter a staff record
	1. In HeadMaster, on the Home screen, click Staff.
	2. Click New.
	3. Enter personal information on each tab.
	4. To save the staff record, click OK.

	Set Up the Lunch Calendar
	You can customize a weekly or monthly lunch calendar by adding items to days in Lunch Calendar.
	To set up the lunch calendar
	1. In HeadMaster, on the Home screen, click Lunch.
	2. Click Lunch Calendar.
	3. Click the calendar arrows to select a month.
	4. Click a calendar date.
	5. In the Menu Items column, double-click each menu item that you want to add. You can also right click a calendar date and add the menu items in that manner.
	6. To add multiple menu items at the same time, select them while pressing Shift or Ctrl on your keyboard and then click Add Item to Selected Day.
	To copy/paste the lunch calendar
	1. In HeadMaster, on the Home screen, click Lunch.
	2. Click Lunch Calendar.
	3. Click a calendar date.
	4. Click Copy/Paste, and then click either Copy Day or Copy Week.
	5. Click the calendar date to which you want to copy the menu items.
	6. Click Paste.
	To delete the lunch calendar
	1. In HeadMaster, on the Home screen, click Lunch.
	2. Click Lunch Calendar.
	3. Click a calendar date and click the menu item you want to delete.
	4. Click Delete, and then click Delete Item. Click Clear Day to delete all the menu items for the selected day.

	Change Billing Code Amounts
	Your tuition and registration may increase each year. However, you do not need to enter new billing codes. You can simply edit the existing billing codes with the new price.
	1. In HeadMaster, on the Home screen, click Define List.
	2. Click to expand Billing.
	3. Click Billing Codes.
	4. Click the billing code you want to edit.
	5. Click Edit.
	6. Change the amount. (To edit more billing code amounts, repeat steps 4-6)
	7. Click OK.

	Select Setup Options
	As an administrator, you have rights to set preferences in HeadMaster Online regarding the Student Directory, Staff Directory, and Report Options.
	1. In HeadMaster Online, click Options > Setup Options.
	2. The Student Directory tab and the Staff Directory tab both contain the same options.
	3. As the administrator, you set the options, but the parents/staff can override your selections by setting their own preferences. The only exception is that parents/staff cannot select to display a field that you don't select in the Select Directory ...
	4. The third tab in the window is Report Options where you can select the student reports that you want give parents/staff access to.
	5. When you're finished with your selections, click Save.

	Change Your Password and Learn More About HeadMaster Online Password Security
	For the sake of protecting your data, we recommend that you change your password often.
	1. In HeadMaster Online, click Preferences.
	2. Click the Change Password tab.
	3. Create your password and click Submit.
	Creating a strong password protects the security of your data, parents, teachers, staff, and students who use HeadMaster Online.
	As parents, students, teachers, and staff create a password, it should:
	 Contain two or more numbers and both lower- and upper-case characters
	 Be over 8 characters long
	 Not contain your username or email or include any of the following characters: < & > \/ % or space.
	As an administrator, ensure that you have a valid email address on record for your parents, teachers, staff, and students. That way, they'll receive an email notification any time their password is changed.
	After the upload to HeadMaster Online from HeadMaster Desktop, the new passwords are no longer visible within the Web Logon List report in HeadMaster Desktop. The entries in the Password column of the report will display the statement "Password change...
	As an additional security measure, if a user forgets their password and selects the "Forgot your password?" option, the system emails a hyperlink for them to click to reset their password instead of emailing it.

	Schedule HeadMaster Online Uploads in OnDemand
	You can use OnDemand to schedule tasks in HeadMaster Online to run when you're busy working on other projects, or when your staff is the least likely to be working in the system. This can be particularly helpful for uploading assignments and homework ...
	To schedule tasks
	1. In HeadMaster, select Tools > Options > Scheduled Tasks.
	2. Select the data set you want to schedule for uploading.
	3. On the OnDemand overlay, select Schedule Tasks.
	4. Click Add to begin adding a task for a specific time.
	5. Select the task you want to run, followed by the time and dates you want the task to run.
	6. Optional: Click Adjust to set your local time. Click Close.
	7. Click OK.
	8. Click Yes. Click the Task Log tab to view previously scheduled tasks.
	9. Click Close.
	To edit a task
	1. Highlight the task you want to edit.
	2. Click Edit.
	3. Make changes to the time and dates, as needed.
	4. Click OK.
	To delete a task
	1. Highlight the task you want to delete.
	2. Click Delete.

	Set a Message for Students on Administrative Hold
	Students who are flagged for administrative hold aren't allowed to view some academic information in HeadMaster Online, such as report cards. Their parents can't view it either.
	You can set a message to display whenever they try to view academic information. Use the default wording in the program or customize the message.
	To set a message for students on administrative hold
	1. In HeadMaster, on the Home screen, click Options.
	2. Click HMOnline.
	3. In the Administrative Hold section, enter a message.
	4. Click Close.

	The Customize Online Enrollment Window
	To customize your school's online enrollment form: In HeadMaster, on the File menu, click HM Online > Customize Online Enrollment.
	To customize your school's online enrollment form: In HeadMaster, on the File menu, click HM Online > Customize Online Enrollment.
	The Customize Online Enrollment window contains five tabs, each containing different information. You can create new fields as well as edit current fields on each tab.
	To add a row
	1. To add an extra row of four more fields in the Customize Online Enrollment window, click .
	2. To undo all your changes in the Customize Online Enrollment window, click Restore Defaults.
	To add new fields
	1. Click                                             .
	2. The Select a Field dialog box displays so you can enter information for your new field. See below.
	3. Notice that the Last Name and First Name field names have red asterisks. That's because they're required fields by default, and their status cannot be changed.
	4. When you're done, click OK > Save and Close.
	To edit current fields
	1. Click on the field:
	2. The selected field displays with a red box around it.
	3. To edit the field, click the Edit Field icon . The Select a Field dialog box will display exactly the same as when you're creating a new field.
	4. In the Select a Field dialog box, edit the field information. When you're done, click OK > Save and Close.
	To delete current fields
	1. Click on the field:
	2. The selected field displays with a red box around it.
	3. To delete the field, click the Delete icon        .

	Allow Other Staff to Customize Your Online Enrollment Form
	Administrators have permission to customize the online registration form by default. But, an administrator can assign the permission to other staff (either as individuals or a group) using the Customize Online Registration security bit.

	Manage New Student Requests
	As parents fill out your school's online enrollment form for their kids, you can pull that information down to HeadMaster:
	1. On the File menu, click File > HM Online > New Student Requests. The New Student Requests window displays.
	2. Click Post, and a record will be created for each student in the Prospective Students section.


