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INTRODUCTION 
This workshop will introduce the concepts of workbooks and worksheets in MS Excel. Tasks such 
as navigating within a workbook; entering, selecting, editing and formatting data within a cell; 
formatting a worksheet; creating a quick formula and printing from Excel will be addressed in this 
workshop. This session assumes no prior knowledge of MS Excel, but does require all participants 
be proficient working in Windows 2000 or newer and have experience working with a mouse and 
keyboard. 

 

MS EXCEL OVERVIEW 
MS Excel allows you to build workbooks with multiple worksheets. Cells in worksheets may be 
formatted and populated with data. The data entered in cells may then be utilized for formulas and 
the creation of charts/graphs. All of these functions are presented in the menu and standard toolbars 
discussed below. 

 

Starting MS Excel 
 
Excel opens in the Normal view by default (see Fig. 1.1). To start Excel follow the step below: 
 

1. Click the Start button -->Programs -->Microsoft Excel... 
             

 
 

Figure 1.1 - Normal View 
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Task #1 
 

Use the appropriate features to complete the following task: 
 

1. Open Microsoft Excel. 
 

Title Bar 
 
The uppermost bar in Excel is the Title Bar (see Fig. 1.2). The Title Bar displays the program name 
(Microsoft Excel) followed by the document name. The program opens with the default document 
name “Book1.xls.” 

 

                  
 

Figure 1.2 – Title Bar 
 

Menu Bar 
 
The Menu Toolbar provides dropdown text menus with available options. Some options on a 
menu may be grayed-out; these options are not available for the area you are working. When a 
menu is first selected from the Menu Toolbar, only the most recent or most often used options 
display and the Expand Button appears at the bottom. Clicking your mouse on the Expand Button 
or keeping the menu open for more than three seconds will expand the menu to display all options 
(see Fig. 1.3). 

 

                               
 

Figure 1.3 – Menu Bar 

Menu Bar 

Title Bar 

Dropdown Menu 

Grayed-out Option
Expand Button 
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Standard Toolbar 

 
The third bar at the top of the screen is the Standard Toolbar. This toolbar offers access to many of 
the often used file commands via graphic buttons known as icons (see Fig 1.4). 
 

         
 

Figure 1.4 - Standard Toolbar 
 
 

Formatting Toolbar 
 

The Formatting Toolbar allows you to access most of the common text formatting options via icons 
(see Fig. 1.5). 
 

 
 

                                                   Figure 1.5 – Formatting Toolbar 
 

Formula Toolbar 
 
The Formula Toolbar, the last toolbar to open automatically, contains the cell Name Box and the 
Formula Bar. The address of the active cell is displayed in the Name Box. The cell address is the 
intersection of a row and column and is designated by a column letter and row number (e.g. A1). 
The Formula Bar contains a value, formula, or text content of the active cell (see Fig. 1.6).  

FOOD FOR THOUGHT 
 

A shortcut to many options is displayed as an underlined letter in the word. 
Simultaneously clicking the Ctrl key and the corresponding underlined letter on the 
keyboard will access the option. 

Standard 
Toolbar 
Icons 

Formatting 
Toolbar 
Icons 



MS Excel Part 1: Organizing Data                                                                                                                             ATCS 

Microsoft Survival Skills                                                                                                                                                      5 

         
 

Figure 1.6 - Formula Toolbar 
 
 

Accessing Other Toolbars 
 
Many other toolbars are available and can be added to the Standard Toolbar area. To access 
additional toolbars follow the step below: 
 

1. From the Menu Toolbar, click View -->Toolbars -->(toolbar name) 
 

A checkmark in front of a toolbar option indicates it is turned on (see Fig. 1.7). A single click on a 
checked toolbar option will turn it off and remove the selections from the toolbar area.  
 

                      
 

Figure 1.7 - Additional Toolbars 

Formula 
Toolbar 

Name Box Formula Bar 
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Task Pane 
 
The Task Pane is a new feature with the Office XP package. It provides another way to access 
some of the more commonly used features. To access the Task Pane follow the step below: 
 

1. From the Menu Toolbar, click View-->Task Pane. 
 
The options in the Task Pane will change according to the actions being performed or selections 
made from the Menu Toolbar (see Fig. 8). 
 

 
 

Figure 1.8 -Task Pane 
 

Task #2 
 
Use the appropriate features to complete the following tasks: 
 

2. Use the Menu Toolbar to turn off the Task Pane. 
3. Double click in cell B1 and type ‘January’. 
4. Use the Standard Toolbar to make the text bold, red and centered. 
 

Completed task shown below (see Fig. 1.9). 
 

 
 

Figure 1.9 – Completed Task #1 
 

Task Pane 
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NAME A NEW WORKBOOK 
By default, Excel opens with a blank workbook and three blank worksheets. The generic name 
“Book1” will be displayed in the Title bar. The workbook can be renamed when you use the Save 
As option and enter a new name in the File Name text box. The shorter and more descriptive the 
file name the easier it will be to recognize at a later time. Avoid using unusual characters and too 
many spaces as these items could make it harder for some versions of MS Excel software to 
recognize your file. 
 

SAVE AS Option 
 

To name a Workbook with the Save AS option follow the steps below: 
 

1. From the Menu Toolbar, click File -->Save As. 
2. In the Save As dialog box, select the location in which to save your document from the 

Save in dropdown text box. 
3. In the File name text box, type the name of your document. The Save as type default is 

set to MS Excel and automatically adds the file extension .xls to the file name when you 
save the document. 

4. Click the Save button (see Fig 1.10). 
 
Your Excel document will now be renamed and stored in the location you selected. 

 

 
 

Figure 1.10 – Naming and Saving a Document 
 

Step 1

Step 2

Step 3

Step4
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Task #3 

 
Use the appropriate features to complete the following task: 
 

1. Save your workbook on the Desktop using the name 'My Workbook’. 
 

Completed task shown below (see Fig, 1.11). Note the new workbook name in the Title bar. 
 

                                     
 

Figure 1.11 – Completed Task #2 
 
 

USING MS EXCEL HELP 
 
There are many options to find help on any topic from the Microsoft Excel Help window: 
Contents, Answer Wizard, or Index (see figure 1.12). To access Excel Help follow the steps 
below: 

1. Type a question in the Ask Question field on the toolbar 
2. Press Enter on your keyboard 
3. Select a Topic from the list o open Help 

 
 

Contents 
 
The Contents tab is located on the Microsoft Excel Help window (see Figure 1.12). It consists of 
a series of books with each containing one or more topics. To access the Contents tab follow the 
steps below: 
 

1. Click on a Closed Book-->an Open Book--> any topic. 
 
 
 

FOOD FOR THOUGHT 
 

You should save your document often (every 10 minutes) to ensure your work will not 
be lost if there is a computer problem or power failure. Once your document is named 
you only need to click the Save option from the File menu to automatically save it with 
the same name in the same location.  



MS Excel Part 1: Organizing Data                                                                                                                             ATCS 

Microsoft Survival Skills                                                                                                                                                      9 

Answer Wizard 
 
The Answer Wizard tab is also located on the Microsoft Excel Help window (see Figure 1.12) 
and respondsto your question with a list of topics you can select for display. To access the Answer 
Wizard tab follow the steps below: 
 

1. Type your question in the What would you like to do? text box. 
2. Click Search. 
3. Click on a topic in the Select a topic to display field. 

 
Index 

The Index tab, located next to the Answer Wizard tab (see Figure 1.12), is similar to an index in a 
book. It contains an alphabetical listing of every Help topic available. Topics are accessed by 
typing or selecting a keyword(s) to display a list of topics to choose from. To access the Index tab 
follow the steps below: 

 
1. Type a keyword(s) in the Type keywords text box or select an option from the choose 

keywords field. 
2. Click Search 
3. Click a topic in the Choose a Topic field 

 

 
 

                                                       Figure 1.12 – Microsoft Excel Help 
 
 
 
 
 

Contents Tab 
 
Answer Wizard Tab 
 
Index Tab 

Topic List 

Ask Question field 
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Task #4 
 

Select a help option to complete the following task in My Workbook.xls: 
 

1. Obtain help on how to include yourself in Properties as the Author of your document. 
2. Follow the directions from Help and enter the following in the Summary tab: 

     Title: Microsoft Excel Part 1 
     Subject: Organizing Data  
     Author: Your Name 

3. Click OK and Save your work. 
 
Completed task shown below (see Fig. 1.13). All options will lead to the same text display on the 
right hand side of the Microsoft Excel Help window. 
 

 
 

Figure 1.13 – Completed Task #3 
 
 

NAVIGATING A Workbook 
Navigating a Workbook is easily accomplished with tabs, cells, scroll bars and the keyboard.  
 

Worksheet Tabs 
 
By default, each workbook starts with three worksheets located at the lower left of the screen (see 
Fig.1.14). To move between sheets follow the step below:  
 

1. Single click the tabs labeled Sheet 1, Sheet 2 etc. 
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Active Cell 
 
The active cell is marked by a bold outline (see Fig. 1.14). Normally, any actions taken will 
address the active cell. To activate a cell follow the steps below: 
 

1. Single click in a cell, or type the cell address in the Name box on the Formula Toolbar to 
perform most formatting functions. 

2. Double click in a cell to add or edit text. 
 

Scroll Bars 
 

Most Excel windows will have two scroll bars to help you move side to side and up and down in a 
worksheet. A horizontal scroll bar (side to side) is located toward the bottom of the screen and a 
vertical scroll bar (up and down) is located on the right (see Fig. 1.14). There are two methods of 
operating the scroll bar: 

1. Line by line – Repeatedly click on the arrows located at either end of a scroll bar. 
2. Continuous flow – Click and drag the scroll box located within the scroll bar. 

 

 
 

Figure 1.14 – Completed Task #3 
 
Keyboard 

 
The keyboard can also be used to navigate around a worksheet. A list of keyboard navigation 
strokes follows (Table 1.1): 
 

Active Cell 

Worksheet Tabs Scroll Bars 
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Table 1.1 – Keyboard Navigation 

 
 

Task #5 
 

Use the appropriate keyboard strokes to complete the following in My Workbook.xls: 
 

1. Locate the cell address for the last row and last column of Sheet # 2. 
2. Share the address shown in the Name Box with the class. 
3. Return to Sheet #1. 

 
Completed task shown below (see Fig. 1.15).  
 

           
 

Figure 1.15 – Completed Task #4  

Movement Key Stroke 

One cell in the direction of the arrow L,K,I,J (also see Enter and Tab) 

Bottom or top of a worksheet Ctrl (plus) L or  Ctrl (plus) K 

First or last cell in a row Ctrl (plus) I or  Ctrl (plus) J 

Up one screen Page Up 

Down one screen Page Down 

Left most cell in a row (column A) Home 

Upper-left corner of worksheet Ctrl (plus) Home 

Lower-right corner cell that contains data Ctrl (plus) End 

Next cell directly below Enter (also see arrow keys) 

Next cell to the right Tab (also see arrow keys) 
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CREATING HEADERS AND FOOTERS 
Headers and Footers are used to add information to the top and bottom of your document that will 
print on every page. The information can include any text, page numbers, current date and time, 
workbook file name and worksheet tab name. Data is entered in the header or footer in the Page 
Setup window by accessing the Headers and Footers option from the View menu. A drop-down 
menu provides a list of preformatted options that may be selected for either the header and/or 
footer. A custom header and/or footer may be created by clicking the Custom Header or Custom 
Footer buttons (see Fig. 1.16). To create a custom header and/or footer follow the steps below: 
 

1. From the Menu toolbar click View -->Header and Footer-->Custom Header or 
Custom Footer. 

2. Click in the section (Left, Center, Right) you wish to add data. 
3. Type your data or click on an icon to automatically display the associated text or graphic. 

 

 
 

Figure 1.16 – Header and Footer 
 
When combining icons to display multiple data on the same line make sure to use spaces, commas, 
slashes, dashes, etc. after selections or data will run on with no break in between. Icons and the 
data they display in the header and footer section are shown in Table 1.2. 

 

Step 1

Step 2

Step 3 
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Table 1.2 – Icon Description 
 

Task #6 
 

Add the following data to the header and footer in My Workbook.xls. 
 
Header: 

1. Left section – use an icon to add the Workbook name. 
2. Middle section – type the title ’Household Expenses – 2002’. 
3. Right section – use an icon to add the date (automatically updates to current date). 

 
Footer 

1. Middle section – use icons to add the worksheet name and page number. (Remember to 
add a coma and space between icon selections.) 

2. Save your work. 
 

Completed task shown below (see Fig. 1.17). To view your worksheet, click File-->Print Preview. 
Click Close to exit Print Preview. 
 

Icon Data Displayed 

 
Format text (font, style, size, etc.) 

 
Shows number of current page displayed (1, 2, 3, etc.) 

 
Updates to display the total number of pages in the document (3, 9, 
18, etc.) 

 
Updates to displays current date (mm/dd/yyyy) 

 
Updates to display current time (1:51 PM) 

 
Path to file (C:\Documents and Settings\User\My Excel Files\2002 
Monthly Expenses.xls) 

 
File name (2002 Monthly Expenses.xls) 

 
Worksheet name (May Expenses) 

 
Insert picture 

 
Format Picture 
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Figure 1.17 – Completed Task #5 
 
 

CREATING LABELS WITH A SERIES 
A label series is a list of words or numbers that are created by Excel when just the first one or two 
items in the list are provided (see Fig. 1.18). To fill a label series: 
 

1. Click in the cell that will be the first cell in the series. 
2. Type the first entry, such as a day of the week, a month, etc. (Note: To create a number 

series enter enough numbers in consecutive cells to establish a pattern.) 
3. Point to the fill handle, the black box in the lower-right corner of the cell. Your mouse turns 

into a black cross. (Note: When creating a number series select all cells in the pattern.) 
4. Click and drag the cross through the cells into which you want to fill the series. 
5. When the series is complete, release the mouse. 

 
 

                                                      
 
                                                Figure 1.18 – Label Series 

Step 3 & 4 

Steps 1 & 2 

Steps 5 

+ 
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Task #7 
 

Use the fill handle of cell B1 to complete the following in My Workbook.xls: 
 

1. Fill the cells in the row with January through March. 
2. Save your work. 

 
Completed task shown below (see Fig. 1.19). 
 

                  
 

Figure 1.19 – Completed Task #6 
 

WORKING WITH RANGES 
A range is a selected area which may include a single cell, row of cells, column of cells or a 
combination of cells in rows and columns. Ranges can be used to format a group of cells with one 
step, print only a selected group of cells or use with formulas. 

 
Selecting a Range 

A range appears highlighted when selected. Ranges can be selected in several ways as shown 
below (Table 1.3): 

 
Table 1.3 – Selecting a Range 

Row Click the row heading number at the left edge of the worksheet.  

Column Click the column heading letter at the top edge of the worksheet. 

Connect cells in rows and 
columns 

Move the mouse pointer to the upper-left corner of the range. Click and 
hold the left mouse button down as you drag to the lower-right corner of 
the range.  

Disconnected cells or ranges Select the first cell or range, hold down the Ctrl key and select the next 
cell or range.  Repeat to add more cells and/or ranges. 

FOOD FOR THOUGHT 
 

You can also create your own custom lists for text or numeric patterns. To learn 
how click Help-->in What would you like to do? type “custom fill series”-->in 
Select topic to display click Create, change, or delete a custom fill series. 
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Copy and Paste a Range 
 
A selected range can be copied from one area of a worksheet or workbook and pasted to a 
different location. To copy and paste a range follow the steps below: 
 

1. Highlight the range to be copied. 
2. From the Menu Toolbar, click Edit-->Copy.  
3. Click the mouse in the upper-left corner of the cell where the range will begin. 
4. From the Menu Toolbar, click Edit-->Paste.   

 
The rows and columns are filled with the data in the range (see Fig 1.22). 

 
                   

 
 

Figure 1.20 – Copied Range 
 
 

                         
 

   Figure 1.21 – Locating and Pasting a Range                      Figure 1.22 – Pasted Range in New Location 
 

 
 

Task #8 
 

Copy and paste a range to complete the following in My Workbook.xls: 
 

1. From Expense Data.xls located on your desktop, select and copy the range A1 through 
D11. 

2. Into My Workbook.xls select A2 as the beginning range and paste the copied data. 
3. Save your work. 

Step 1 

Step 2 

Step 3 

Step 4 
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Completed task shown below (see Fig. 1.23). 
 

                             
 

Figure 1.23 – Completed Task #7 
 
FORMATTING WORKSHEETS 

Formatting can occur in a single cell or a range of cells. Cell height and width, adding and deleting 
columns and rows, and changing text attributes can be accomplished with the aid of mouse clicks, 
Format Cells Dialog Box, Format Painter, options from the Toolbar Menu. 
 

Adding and Deleting Columns and Rows 
 
At times you may find it necessary to add or delete a row or column in your worksheet. These 
tasks are easily accomplished with the Insert and Edit options on the Menu Toolbar. 
 
Inserting Columns or Rows - To insert a column or row follow the steps below: 
 

1. Select single or multiple column headings to the right of where you want to insert a 
column, or select single or multiple row headings below where you want to insert a row. 

2. From the Menu Toolbar – click Insert-->Column or Row. 
 
A new colum is inserted to the left of your column selection or above your row selection. The 
formattting of the selected column(s) or row(s) carries over to the new cells (see Fig. 1.25). 
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                                  Figure 1.24 – Inserting Rows                       Figure 1.25 – New Row Added Above 
 

 
Deleting Columns or Rows – To delete a column or row follow the steps below: 
 

1. Select single or multiple column or row headings that you want deleted.  
2. From the Menu Toolbar – click Edit-->Delete.  

 
When you delete a column, the remaining columns shift left and when you delete rows, the 
remaining rows move up (see Fig. 1.27). 
 

                    
 
                 Figure 1.26 – Deleting Rows                         Figure 1.27 – Rows Deleted on Left                   
 
 

Column and Row Height and Width  
 
One of the easiest ways to improve the overall appearance of your worksheet is to adjust the width 
of columns or height of rows to accommodate the data displayed. Height and width adjustments 
can be made by dragging, double clicking (see Fig. 1.26), or from Format options on the Menu 
Toolbar (see Fig 1.27). To adjust height and/or width follow the options listed below: 
 
Column Width 

1. Dragging – Click the column heading you want to change then point to the seam to the 
right of the letter (column) you wish to change. A double pointed arrow will appear on 
the cursor. Click on the seam and drag the mouse to the desired size and release (see Fig. 
1.28 and Fig. 1 .29).  

Step 1 

Step 2 

Step 1 

Step 2 
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             Figure 1.28 – Click Heading                          Figure 1.29 – Drag Seam 

 
 
2. Double clicking – At the column heading you wish to change double click the seam to the 

right of the letter (column) where the double pointed arrow cursor appears and the 
column width will change to fit the longest text in the column. 

3. Menu Toolbar – click the column heading you want to change then from the Menu 
Toolbar click Format-->Column-->Width and enter a figure in the column width text 
box. 

 
Row Height 

1. Dragging – Click the row heading you want to change then point to the seam below the 
number (row) you wish to change and a double pointed arrow cursor will appear. Click 
on the seam and drag the mouse to the desired size and release. 

2. Double clicking – At the row heading you wish to change double click the seam below 
the number (row) where the double pointed arrow cursor appears and the row height will 
change to fit the height of the text in the row. 

3. Menu Toolbar – click the row heading you want to change then from the Menu Toolbar 
click Format-->Row-->Height and enter a figure in the Row Height text box (see Fig. 
1.30). 

 

          
 
                                       Figure 1.30 – Formatting from Menu Toolbar 
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Worksheet Names 
 
Each worksheet contains 65,536 rows and 256 columns (16,777,216 total cells). Even though this 
is more space than is needed for most jobs, you may wish to use several worksheets for 
organizational purposes and to avoid scrolling through long columns and rows. By default, 
worksheets are named Sheet 1, Sheet 2, Etc. To change a worksheet name follow the steps below: 
 

1. Double-click (or, right click) the tab of the worksheet you want to rename. 
2. Type a new name and press Enter (see Fig. 1.31).  

 

                                   
 
                                               Figure 1.31 – Renaming a Worksheet 
 

Task #9 
 
Use the appropriate feature to complete the following tasks in My Workbook.xls: 
 

1. Delete the row labeled Tuition. 
2. Add a row above Cable TV and type “Entertainment” in the first column. 
3. Adjust the width of the first column to accommodate the longest expense category. 
4. Rename the first worksheet to read “1st Qtr.” 
5. Save your work. 

 
Completed task shown below (see Fig. 1.32). 
 

                              
 
                                             Figure 1.32 – Completed Task #8 
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Cell Formatting 
 
The Format Cells dialog box can be used to change a cell or range of cell attributes at one time. 
The dialog box contains tabs to change number configurations, text alignment, font characteristics, 
cell borders, cell patterns and colors and add hide and lock protection to cells (see Fig. 1.33 
through Fig. 1.38). 
 
To format cells from the Format Cells dialog box follow the steps below: 
 

1. Select the cell or cells you wish to format. 
2. From the Menu Toolbar, click Format-->Cells 
3. From the Format Cells dialog box select a tab. 
4. Set the desired options and click OK. 

 
 

 

 

 
Figure 1.33 – Number Tab  Figure 1.34 – Alignment Tab 

Controls how numbers are displayed 
(e.g. $100.00, 100% etc.). 

 Controls how text is oriented on a page. 

 

 

 

Figure 1.35 – Font Tab  Figure 1.36 – Border Tab 

Controls text characteristics.  Controls borders around and in selected 
cells. 
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Figure 1.37 – Patterns Tab  Figure 1.38 – Protection Tab 

Controls application of color and 
pattern to a cell or cells. 

 Controls locking of cells and hiding of 
formulas (must also be selected from 
the Tools-->Protect  on the Menu 
Toolbar). 

 
 

Format Painter 
 
You can easily copy the format of one cell to other cells with the Format Painter. To apply 
formatting with the Format Painter follow the steps below: 
 

1. Click a formatted cell you wish to copy. 
2. From the Standard Toolbar, click the Paint Brush Icon and your cursor will become a 

paint brush graphic. 
3. Drag the Paint Brush Icon over the cells you want the format to change. 

 

                                     
 
            Figure 1.39 – Format Painter                Figure 1.40 –Cells Changed with Format Painter 
 

Step 1 

Step 2 

Step 3 
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Task #10 
 

Use the appropriate formatting options to complete the following in My Workbook.xls: 
 

1. Use Format cells Dialog box to add a border, background color and pattern to the cell 
titled January (A2). 

2. Use Format Painter to apply the January cell formatting to February and March cells. 
3. Use Format cells Dialog box to add dollar signs to the figures in range B2 to D12. 
4. Enter $200 in the January column of the Entertainment expense. 
5. Use the label series technique to add the $200 entertainment expense to February and 

March. 
6. Save your work. 
 

Completed task shown below (see Fig. 1.41). 
 

                                  
 

Figure 1.41 – Completed Task #8 

 
 

CREATING QUICK FORMULAS 
Excel provides a means to quickly and accurately perform simple calculations to a spreadsheet by 
using the Auto Sum function on the Standard Toolbar and using the fill handle to paste a formula. 

 
 

Auto Sum 
 
The Auto Sum icon ( ) located on the Standard Toolbar calculates the sum of selected cells and 
enters the answer in the next available cell. The drop down menu to the right of the Auto Sum icon 
provides additional mathematical options that can be applied to a selection of cells (see Fig. 1.42). 
To apply an Auto Sum function from the drop-down menu, follow the steps below: 
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1. Select the range of cells you wish to calculate. 
2. From the drop-down menu to the right of Auto Sum, click on a mathematical function to 

apply it to the selected cells. The calculated figure appears in the cell that follows the 
selected cells.  

 

                  
 
                              Figure 1.42 – Applying Auto Sum                      Figure 1.43 – Completed calculation 

 
 

Pasting a Formula 
 
When you have a calculation that will be used over several columns or rows you can enter it once 
and use the fill handle to paste it in adjacent cells. To paste a formula follow the steps below: 
 

1. Left click the fill handle of the formula cell you wish to duplicate. 
2. Drag the handle through the desired number of cells. 

 

                          
 
Figure 1.44 – Select Formula Cell Fill Handle                                   Figure 1.45 – Dragging Fill Handle  
 
 
Task #11 

 
Use the appropriate options to complete the following in My Workbook.xls: 
 

1. Type the title “Item Total” in cell E1. 
2. Use Format Painter to format the “Item Total” cell the same as the other headings. 
3. Type the title “Monthly Total” in cell A13. 
4. Change the color of “Monthly Total” text to red and bold the letters. 
5. Use Auto Sum to calculate the sum of row 2. 
6. Use the fill handle to paste the formula in E2 into all rows. 

Step 1 

Step 2 

+ Step 1

Step 2
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7. Use Auto Sum to calculate the sum of column B. 
8. Use the fill handle to paste the formula in column B into all columns.   
9. Save your work. 
 

Completed task shown below (see Fig. 1.46). 
 

 
 

Figure 1.46 – Completed Task #10 
 
 

PRINTING FROM EXCEL 
Prior to printing your excel document you should preview it to make sure it will print the way you 
expect. In the Page Setup dialog box you have options to change the page layout, margin size, 
header/footer information, and sheet features. 
 

Setting Up a Page for Print 
 
Before printing you must define for the printer what it is you want printed. You can print a whole 
worksheet, a portion of a worksheet, a chart or an image by clicking on the worksheet tab, graphic 
image or chart and proceeding to the Print option from the File Menu. Multiple worksheets can be 
printed by holding the Ctrl key down while clicking the mouse on the worksheet tabs you wish to print. To 
print a portion of the worksheet follow the steps below: 
 

1. Select the range of cells you wish to print. 
2. From the Menu Toolbar, click File -->Print Area-->Set Print Area. 
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Figure 1.47 – Stetting the Print Area 
 

Once you have set the print area you will want to use Print Preview to view the image as it will 
print and adjust any options that will achieve your purpose. The Page Setup window provides four 
tabs to allow you to make necessary changes: Page, Margins, Header/Footer, and Sheet. To begin 
setting up your page follow the step below: 
 

1. From the Menu Toolbar, click File-->Page Setup. 
 

 
 

Figure 1.48 – Accessing Page Setup 
 
Page Setup displays a window with four tabbed options (see Fig. 1.49 through Fig. 1.52) for you 
to make changes.  

Step 1 

Step 2 
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Figure 1.49 – Page Tab  Figure 1.50 – Margins Tab 

Controls content orientation and size, paper 
size and print quality. 

 Controls margin size for page content and the 
header and footer. 

 

 

 
Figure 1.51 – Header/Footer Tab  Figure 1.52 – Sheet Tab 

Controls header and footer information.  Controls print area, repetition of column and 
row labels, some print characteristics and text 
direction. 

 
After changing all options use Print Preview again to be sure the document will appear as expected. 
When you are satisfied with the appearance you are ready to begin printing. 
 

Printing 
 
After you setup your print area, print options and previewed the document’s print display you are 
ready to send your print request to the printer. To send your document to the printer, follow the 
steps below: 
 

1. From the Menu Toolbar, click File-->Print. 
2. In the Print window, click the printer Name from the drop-down menu. 
3. From Print range, select a range or all pages. 
4. From Print what, click an option. 
5. From Copies select the Number of copies. 
6. Click OK. 
7. Retrieve the printed copy of you document at the printer. 
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Figure 1.53 – Print Window 
 
 

             
 

Figure 1.54 – Printed Document 

Step 1 

Step 2 

Step 3 

Step 4 

Step 5 

Step 7 

Step 6 
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Task #12 
 

Use the appropriate options to complete the following in My Workbook.xls: 
 

1. Range set to A1 through L37. 
2. Page orientation set to Landscape. 
3. Sheet printed with gridlines. 
4. Save your work. 
5. Preview your print settings. 
 

Completed task shown below (see Fig. 1.55). 
 

 
 

Figure 1.55 – Completed Task #11 
 
 

RESOURCES 
 
MS Excel questions should be emailed to the ICT Help Desk at ict.helpdesk@emich.edu  or call 
734.487.2120.  
 
Use the built in Help function form the Menu Toolbar. 
 
Visual QuickStart Guide: Microsoft Office XP for Windows, Sagman, Peachpit Press, Berkeley, 
CA, 2002. ISBN 0-201-74147-4. 
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Microsoft Excel for Windows 2002, Langer, Peachpit Press, Berkeley, CA, 2002. ISBN 0-201-
75844-X. 
 
Excel home page: http://www.microsoft.com/office/excel/default.asp 
 
For more information on other computer training sessions and materials being offered by ICT visit 
ICT’s web site at: http://www.emich.edu/public/itech/training 
 
Corrections or suggestions for this manual should be reported to Diane Lawrence at 
dlawrence3@emich.edu. 

 


