Contents

CHAPTER 1  Overview ............................................... 1
  Major Features of Cindex ........................................ 1
  How to Use This Guide ........................................... 4
  On-Screen Help .................................................... 5
  Updates ............................................................ 5
  Cindex Documents ............................................... 5

CHAPTER 2  Starting an Index ................................. 9
  The Elements of an Index ....................................... 9
  Creating and Saving Indexes ................................... 10
  Setting Preferences .............................................. 13

CHAPTER 3  Adding and Editing Entries ............... 19
  Index Records ................................................... 19
  Making New Entries ............................................ 22
  Editing Existing Entries ....................................... 37
  Working Efficiently with Records ......................... 37
  Using Hot Keys .................................................. 48
  Abbreviations .................................................... 49
  Duplicating Records ............................................ 53
  Deleting and Restoring Records ......................... 54
  Labeling Records ................................................ 55

CHAPTER 4  Viewing, Finding and Printing Entries ... 59
  Views ............................................................. 59
  Selecting Entries ............................................... 67
  Working with Subsets of Records ....................... 68
Finding Entries .................................................. 70
Printing Entries ................................................. 83

CHAPTER 5  Advanced Editing .............................. 85
Macros .................................................................. 85
Searching for and Replacing Text ......................... 87
Adjusting References ............................................ 92
Splitting Headings ............................................... 97
Reconciling Heading Levels .................................... 99

CHAPTER 6  Checking Spelling ............................... 103
Checking Words in Entries ...................................... 103
Checking Only Part of the Index .............................. 107
Spelling Options .................................................. 108

CHAPTER 7  Cross-References ............................... 111
How Cindex Identifies Cross-References ................. 111
Verifying Cross-References .................................... 114
Converting Cross-References to Fully-Qualified Entries ........................................ 114
Generating Cross-References Automatically .......... 115
Placing and Formatting Cross-References .............. 118

CHAPTER 8  Page References ................................. 125
How Cindex Identifies Locators ............................. 125
Working Efficiently with Page References ............... 129
Checking Page References ..................................... 130
Evaluating and Sorting Page References ................. 130
Formatting Page References .................................. 138

CHAPTER 9  Sorting Entries .................................. 147
Language .......................................................... 147
Field Evaluation Order ......................................... 147
Alphabetical Sorting ............................................. 151
Overriding Sorting Rules for Individual Entries ...... 159
Sort Substitutions ............................................... 165
CHAPTER 10  Formatting the Index.           167
  Margins and Columns .......................... 167
  Headers and Footers............................ 170
  Grouping Entries............................... 172
  Style and Layout of Entries................... 174
  Typography and Punctuation of Headings........ 181
  Style Sheets .................................. 184

CHAPTER 11  Exchanging Documents with Other Applications.   187
  Saving Formatted Indexes....................... 187
  Managing Markup Tags........................... 193
  Direct Transfer of Index Entries............... 200
  Saving Index Records........................... 201
  Importing Records.............................. 204

CHAPTER 12  Managing Index Documents .............. 211
  Specifying the Structure of Records........... 211
  Managing Fonts.................................. 214
  Specifying Attributes of New Indexes.......... 216
  Getting Information About Indexes............... 217
  Checking Index Entries........................ 221
  Expanding Index Entries....................... 229
  Compressing Index Entries..................... 230
  Managing Groups............................... 232
  Cumulating and Combining Indexes............... 234
  Breaking an Index into Parts................... 236

CHAPTER 13  Patterns. ............................ 239
  Forming Patterns............................... 239
  Using Patterns with Find....................... 249
  Using Patterns when Replacing Text............. 250
  Using Patterns when Altering References........ 255

CHAPTER 14  Reference. ............................ 261
  Scope of Operations............................ 261
Toolbars .......................................................... 263
File Menu ....................................................... 264
Edit Menu ...................................................... 270
View Menu ..................................................... 282
Character Menu ............................................. 284
Document Menu ............................................. 285
Tools Menu .................................................... 300
Window Menu ............................................... 317
Help Menu .................................................... 317

Index ......................................................... 319
CHAPTER 1  Overview

Cindex™ is a uniquely capable program for preparing indexes to books, newspapers and other periodical publications. It offers the professional indexer unmatched features and ease of use. You can also use it to prepare glossaries, or to create subject authority lists based on existing indexes. Cindex does not replace you as the indexer, but supports you through a host of features that greatly simplify index preparation and enable you to produce the finest indexes in virtually any format.

In many respects Cindex behaves like a word-processing program—it displays the index in a document window, formatted like a printed index, and you can explore and move through this document as you would any other word-processor document. In other fundamental respects Cindex is unlike a word-processor. For example, when you make a new index entry, you do not type into the document directly, but into a record—analogous to an index card—and Cindex, following alphabetizing rules you have specified, determines where this entry will appear in the index.

MAJOR FEATURES OF CINDEX

Instant, Automatic Alphabetizing

As you make or change entries, Cindex instantly alphabetizes them, and you see your index in alphabetical order as you work with it. You may sort entries using letter-by-letter or word-by-word alphabetizing, or by order of page references or by date. If you wish, Cindex will alphabetize main headings and place subheadings in ascending or descending order of page number. Numbers and symbols appearing in entries are ignored or evaluated at your option. Cindex automatically ignores any of a selected set of words (usually leading prepositions), or any
### Major Features of Cindex

- **Language and Script Support**: Cindex accommodates entries in multiple languages and scripts (including right-to-left scripts such as Hebrew and Arabic), and sorts entries by the collation rules appropriate for your chosen language.

- **Automatic Formatting**: You do not format or punctuate entries as you enter them, or merge duplicate entries or arrange cross-references; Cindex does all these things automatically, providing you with a fully up-to-date index at all times. You have full control over the appearance of the finished index, which you can see on the screen exactly as it will appear on paper. You can choose from several formats in addition to the standard indented and run-in (paragraph) styles. Special formatting options make Cindex ideal for the production of magazine or newspaper indexes.

- **Documents for Typesetting**: Cindex can provide finished indexes as documents designed for word-processing programs, and document layout programs. Cindex will also make fully marked-up XML and SGML documents. You can define your own markup tags for particular publishers.

- **Embedding Index Entries**: Cindex can embed index entries directly in word-processing documents (for example, those used by Microsoft Word), so that page numbers and index formatting can be provided by the word-processor.

- **Instant Recall of Words and Phrases**: If you use a certain phrase often in an index—such as a standard subheading for a magazine index, or a clinical condition in a medical index—you can create an abbreviation to represent it. When you type the abbreviation, Cindex will instantly recall the full word or phrase that it represents. You can keep different sets of abbreviations for different kinds of indexes.

- **Search and Replace**: You can find any entry instantly by specifying the letters it starts with, or you can find any word or phrase in the index regardless of its position in the entry. You can make a conditional search for words and phrases—for example the presence of “friends” and “foes” in the same entry. In addition to searching for and replacing specific words or phrases, Cindex allows you to search for patterns of characters. For example, you might want to find “any word beginning with an...
Major Features of Cindex

uppercase letter and ending in ‘ing’,” or “any four-digit number beginning with 19 and enclosed in parentheses.” A global search and replace function allows you to modify entries quickly and easily throughout the index.

Powerful Spelling Check

Cindex includes a powerful spell-checker that quickly finds and helps you correct misspelled words. Dictionaries for many languages are freely available.

Working with Groups of Records

If you want to work with only a subset of the entries in the index (for example, those for a particular chapter), Cindex can act as though these are the only records in the index.

Cross-References

Cindex will place cross-references (e.g., See and See also) immediately following main headings or as the first or last subheadings, as you prefer. Cindex will automatically apply designated typographical effects (e.g., italics) to text forming the lead to a cross-reference or the body of it, and will punctuate the cross-references automatically in any way you require. Cindex can tell you which entries have references made to them, it can generate cross-references automatically when it encounters terms you specify, and it can convert cross-references to fully-qualified entries.

Page References

Cindex handles page references in virtually any form, including mixed Roman and Arabic numerals, dates (including names of months) and multi-part references of the kind often found in periodicals. Cindex can sort dates and complex references in virtually any way you might want, no matter how they are entered in records. When Cindex displays or prints the formatted index it will arrange references in ascending or descending order, and will abbreviate them (for example, printing 321–325 as 321–25), conflate them (for example, printing 23, 24, 25–26 as 23–26) and suppress component parts as you require. If a publisher adds or removes pages in a book that you have already indexed, Cindex can adjust page references automatically.

Managing Subheadings

Cindex can identify entries that contain orphaned subheadings, or unnecessary levels of subheading. If you wish Cindex will automatically convert redundant subheadings to modifiers of the heading at the level above. Cindex will also identify modified headings that should properly be organized as heading and subheading, and if you wish will make that conversion too.
How to Use This Guide

Comprehensive Index Checks

Cindex provides powerful tools to check the correctness and consistency of index entries. Checks fall into three broad groups covering:

- Errors within entries, including misused special characters, misplaced or questionable punctuation, letter case errors.
- Inconsistencies across headings, such as letter case, style or punctuation, plurals; also orphaned subheadings.
- Errors in references, such as missing or otherwise incorrect cross-references; overlapping or excessive numbers of page references.

Work on Indexes Concurrently

Cindex allows you to work on several indexes concurrently, so that, for example, you can prepare author and subject indexes together as you work through a book. You can instantly move from one index to the other as you make or modify entries.

Cumulations and Spin-off Indexes

Should the need arise, you can combine (cumulate) separate indexes into one large one, and Cindex will automatically merge the entries. You can just as easily split a large index into parts.

Importing and Exporting Entries

Cindex can import index records from, and export records to, XML documents and plain text documents of the kind produced by database programs. Cindex can also import records stored in the formats exported by the indexing programs Sky Index and Macrex.

HOW TO USE THIS GUIDE

This Guide to Cindex is organized in two parts. Chapters 1 through 13 take you through the steps required to make an index, explaining features at each stage. Chapter 14 provides a reference to all the Cindex commands, organized by the menus in which they appear. Use the first part to familiarize yourself with Cindex and what it can do for you; use the reference to find explanations of menu commands and pointers to tutorial discussions (these pointers appear in square brackets beside each item in the reference).

The Guide assumes you are familiar with Windows, with the mouse, and with menus and dialog boxes. It also assumes that you understand folders and that you
On-Screen Help

know how to start an application program. These features of Windows are explained in help provided with your computer.

Notational Conventions

This Guide uses the following conventions:

<table>
<thead>
<tr>
<th>Font Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tempo Font</td>
<td>Identifies a menu item or an item in a panel.</td>
</tr>
<tr>
<td>SMALL CAPS</td>
<td>Identifies a keystroke or keystroke combination that you type.</td>
</tr>
<tr>
<td>[WWW]</td>
<td>Reference (Chapter 14). Identifies the page on which a topic is discussed fully.</td>
</tr>
</tbody>
</table>

ON-SCREEN HELP

Cindex provides comprehensive on-screen help. Choose Help Topics from the Help menu (or hit F1).

Most of the dialog boxes that Cindex displays have a? in the title bar. To learn about the function of any item in the dialog box click the? then click the item.

UPDATES

From time-to-time Indexing Research releases updates to improve the performance of Cindex. When Cindex is installed it is set to check automatically for updates. If an update is available Cindex will notify you and ask if it should download the update. You can turn off the automatic check if you prefer not to be notified (see “Checking for Updates” on page 15).

CINDEX DOCUMENTS

Cindex makes and uses several different kinds of files on your computer. Each type of file has a distinctive icon associated with it. The following paragraphs
introduce these documents. Later sections of this Guide describe fully the various kinds of documents that they represent.

**Indexes**

Index files hold index entries, from which you produce the finished index. Index files, which carry the filename extension .ucdx, work with both Cindex for Mac and Cindex for Windows.

**XML Records**

XML Record files hold index entries in an open format suitable for interchange with any software that parses XML. XML Record files carry the filename extension .ixml.

**Archives**

Archive files hold index records in a compressed form. Archives cannot represent the full range of accented letters and symbols accommodated by Cindex 3, and are recommended only for interchange with earlier versions of Cindex (both Mac and Windows). Archive files carry the filename extension .arc.

**Templates**

Template files hold models of indexes. They contain all the information about how entries should be formatted and sorted, etc., but contain no entries. Template files, which carry the filename extension .utpl, work with both Cindex for Mac and Cindex for Windows.

**Style Sheets**

Style sheets contain information about the style of an index and how index entries are formatted and laid out on a page. You can keep different style sheets for different layouts. Style sheets files, which carry the filename extension .ustl work with both Cindex for Mac and Cindex for Windows.
Cindex Documents

Abbreviations

Abbreviation files hold abbreviations you have defined to represent long words or phrases. You can insert the word or phrase in an index entry merely by typing its abbreviation. You can maintain different sets of abbreviations for different purposes. Abbreviation files work only with Cindex for Windows, and carry the filename extension .ucbr.
THE ELEMENTS OF AN INDEX

A Cindex index is a collection of entries that you can view and print in any form you wish and in any order you wish. Each entry is a complete reference to some material in the work being indexed. Cindex maintains each index entry as a distinct entity in the document, so that it can display entries in the style and order that you prefer.

An index entry consists of a heading and one or more locators (usually page numbers, sometimes cross-references to other entries) that show where the indexed material can be found. An entry may contain subheadings as well as headings. Subheadings are used to avoid making headings that would otherwise contain too many locators.

Cindex can display and print entries in any order and in a wide variety of formats, as long as you prepare entries in a standard way. To help you do this, Cindex uses records to hold the text of index entries. A record always contains a heading and a page reference or a cross-reference; it may also contain one or more subheadings.

A record is usually, but not always, equivalent to an index entry. When Cindex displays or prints a formatted index it may combine several records (identical except perhaps for page references or cross-references) to form a single entry.
CREATING AND SAVING INDEXES

Creating the Index

To start a new index choose New... from the File menu, or click in the toolbar. Cindex will display a dialog box that asks you to name the index. (Unlike a word-processor, Cindex cannot work with a new “untitled” document—you must create and name a new document before you make entries). It is often useful to give the index a name that identifies the material being indexed.

NOTE: You can set Cindex so that it will initially use a standard folder when saving and opening indexes. See “Default Folder” on page 15. for more information.

When you click Save, Cindex will open a new document window in which the index entries are displayed as you make them. Most of your commerce with the index will be through this window. When you close this window, Cindex closes and saves the index document.

Standard Settings

To make a properly organized index out of a collection of records, Cindex needs to know how the entries held in records should be sorted (for example, alphabetically, or in order of page number) and how they should be formatted for display (for example, in indented style, or in run-in style). Cindex also needs to know what restrictions (if any) you want to place on the contents of entries (for example, it can require that locators conform to some specification, or that entries may not have sub-subheadings).

When you create a new index, Cindex endows it with standard settings. These settings are initially taken from a special set built into Cindex. You can change both the standard settings and the settings for individual indexes:

- To review or change the way in which entries are sorted, see Chapter 9 “Sorting Entries” on page 147.
- To review or change the way in which entries are formatted, see Chapter 10 “Formatting the Index” on page 167.
- To review or change the properties of index records, see Chapter 12 “Managing Index Documents” on page 211.
Creating and Saving Indexes

Using Templates
Cindex can create a new index from a template—an existing index that serves as a model for the new one. The new index inherits all its settings from the template. “Using Templates” on page 217 explains how to set up and use templates.

Setting an Index Aside
To close an index at any time click the close box in its main window, or choose Close from the File menu. Cindex automatically saves changes to the index, and remembers the size and position of its window. To close all open indexes, choose Close All from the Window menu. To close all open indexes and quit Cindex, choose Exit from the File menu.

Backing-up Your Work
When you finish a session of work on an index always make a copy of it (preferably on some other disk). You can copy an index using Windows Explorer, or you can use Cindex to save a copy of any index you have open for work.

To save an exact copy of the active index, choose Save Backup Copy… from the File menu.

You can make a plain text document that contains all the information about the content of entries (though not information about the document format, or about how the index entries are alphabetized) by choosing Save As… from the File menu, then selecting XML Records format. For more information see “XML Records” on page 201.

Saving Changes
As you add or modify index entries, Cindex automatically saves them. To allow you to work quickly, however, Cindex does not do this immediately for every small change you make. Cindex is initially set to save changes automatically every ten minutes; you can change that interval, or you can disable automatic saving. See “Automatically Saving Changes” on page 14.

NOTE: When an index contains unsaved changes Cindex indicates this by displaying an asterisk (*) beside its name in the title bar.
Creating and Saving Indexes

Opening an Existing Index

To open an existing index, choose Open… from the File menu or click 📝. Cindex displays a list showing the names of indexes it can open. Click the index name to select it in the displayed list, then click Open. To open an index from Windows Explorer (and start Cindex if necessary), double click its icon.

You can open an index as a read-only document that cannot be modified. To do this check Read Only; this item is dimmed if the selected document cannot be opened as a read-only document.

To open a recently-used index choose it by name from the File menu. To set how many names will appear in the menu, choose Preferences… from the Edit menu. Cindex will display the dialog box shown in Figure 1 on page 14. Choose from Maximum Number of Recent Indexes.

You can configure Cindex so that when you start it up it will automatically open the last index you worked on. See “Opening an Index on Startup” on page 13.

Checking Index Integrity

Cindex checks the integrity of each index it opens. If Cindex finds errors or damage it will ask if should attempt repairs. It is generally advisable to allow this. If records have been damaged Cindex will report the number of repairs made and will “mark” the repaired records so that you can later find and examine them. For more information on marked records see “Marked Records” on page 88.

Preserving and Discarding Changes

For each open index Cindex keeps a private copy that it updates each time it saves the index automatically, or you save the index with Save. If you make changes to an index and then wish to discard them, you can restore the index to its last-saved state by choosing Revert to Saved from the File menu.

To save a copy of the active index choose Save Backup Copy… from the File menu.
**Setting Preferences**

*Working with Several Indexes*

Cindex allows you to work on several indexes concurrently (for example, subject and author indexes to the same volume), while keeping each index completely separate from the others. Choose **New…** or **Open…** from the File menu to create or open each index you want to work on.

If you have more than one index open, Cindex operates only on the index whose window is active; to make an inactive index active, click its window, or choose it by name from the Window menu.

**SETTING PREFERENCES**

You can customize Cindex to suit your preferences. Some settings govern how Cindex deals with all index documents; others pertain to individual indexes.

*Setting General Preferences*

**Opening an Index on Startup**

You can set Cindex so that when you start it by double-clicking its icon (rather than by opening one of its documents with the Windows Explorer), it will automatically open the last index you worked on or will display a panel through which you can open a document. To specify how Cindex should behave when it starts, choose **Preferences…** from the Cindex menu (Figure 1) and click **Open Last Index** or **Show Open Panel**.
Setting Preferences

![Preferences dialog box](image)

Identifying the Indexer

Cindex can include in a record information to identify the person who made or modified the record. To include such information in records, choose **Preferences…** from the Edit menu (Figure 1 on page 14) and enter up to four identifying characters at **User ID**. Cindex will attach the identifier to each record you make or modify (this information is not part of the record text).

If you want to use a different identifier in different sessions with Cindex, check **Prompt for User ID**. Each time you start Cindex it will display a dialog box (Figure 2) through which you can enter your identifying initials.

![Cindex User Identifier](image)

Automatically Saving Changes

Set **Save Open Indexes Every…** to the interval at which you want Cindex to save changes. If you set the interval to 0, Cindex will not save changes automatically.

CHAPTER 2  Starting an Index
Setting Preferences

Regardless of your setting, Cindex always saves changes when you close an index or end your session. To save changes to the document at any time choose **Save** from the File menu or click 🔄.

**Default Folder**
You can specify a folder in which Cindex will initially browse when you choose **Save**... or **Open**... from the File menu. To specify this default folder choose **Preferences**... from the Edit menu (Figure 1) then click **Default Folder**. Cindex will open a file dialog box through which you can find or create the folder you want to use.

**Default Window Sizes**
You can set Cindex so that it automatically uses the full screen when you start it (otherwise it sets its main window to the size last used). You can also set Cindex to display indexes in the largest possible window (otherwise it sets the index window to the size last-used). To make these settings, choose **Preferences**... from the Edit menu (Figure 1).

- Check **Maximize Cindex** to make Cindex use the full screen.
- Check **Maximize on Opening** to make Cindex display indexes in the largest possible window.

**Checking for Updates**
Check **Automatically check for updates** to let Cindex check automatically and notify you when an update is available from Indexing Research. If you turn off the automatic check you can at any time check for an update by choosing **Check for Updates**... from the Help menu.

**Default Font and Size**
When you start a new index Cindex establishes a default font and size in which all entries are displayed, except for parts explicitly marked for display in some other font. The default font is initially set to Arial, 12 point, though you can change it at any time. For more information See “Fonts and Styles” on page 34.

**Editing Records**
Cindex provides several features for simplifying the editing of records, and checking for mistakes you might make while entering them. These settings, made through the Preferences dialog box, are described in “Working Efficiently with Records” on page 37.
Setting Preferences

Setting Preferences for Individual Indexes

Three broad classes of settings govern the way Cindex works with individual indexes.

Views
Cindex provides several settings that allow you to specify what parts of an index it should display, and how it should display them. You make these settings through the View menu. Chapter 4 “Viewing, Finding and Printing Entries” on page 59 provides information on views.

Style and Layout
Cindex can display formatted index entries in several styles (for example, indented or run-in) laid out on pages in different ways. Chapter 10 “Formatting the Index” on page 167 describes the formatting options.

Sorting
Cindex can sort entries in whichever way you prefer (for example, alphabetically, or by order of page reference). Chapter 9 “Sorting Entries” on page 147 explains how to set up the sort order you prefer.

Toolbars
Cindex provides toolbars with buttons that execute some of the most often-used commands. The main toolbar is displayed just under the menu bar. A second toolbar appears when you add or edit entries (Figure 5 on page 23). You can customize both toolbars.

To rearrange or remove or restore buttons, double-click anywhere on the toolbar except on a button. Cindex will display the following dialog box.
Setting Preferences

To move a button already in the toolbar, drag it to a new position in the right-hand panel.
To remove a button from the toolbar, drag it from the right- to the left-hand panel.
To restore a button you have removed, drag it from the left- to the right-hand panel.
To restore the toolbar to its state when Cindex was first installed, click **Reset**.

Cindex remembers your settings until you change them.

Cindex offers shortcuts for rearranging and removing buttons without your having to open the dialog box:

- To move a button to a new position, hold down the **ALT** key and drag the button to its new position, then release it.
- To remove a button from a toolbar, hold down the **ALT** key while you drag the button off the bar, then release it.
Setting Preferences
This chapter describes how to make and edit index entries. As you work on your index, you might need more information than is provided here. The following chapters provide full discussions of topics mentioned here:

- For information on cross-references, see Chapter 7 “Cross-References” on page 111.
- For information on page references, see Chapter 8 “Page References” on page 125.
- For information on sorting entries, see Chapter 9 “Sorting Entries” on page 147.

INDEX RECORDS

The Need for Records

Consider the following fragment from an index to a book on neurology:

Homonymous hemianopsias, 215
pituitary tumors and, 222, 225-227f

This contains two entries (there are references to two distinct topics) and were you preparing entries on index cards you would make them initially on two separate cards. One card would contain the entry

Homonymous hemianopsias, 215
Index Records

and the other would contain the entry

**Homonymous hemianopsias**

*pituitary tumors and, 222, 225-227f*

If you did not use two cards, but prepared both entries on a single card, as in the first illustration, any entry you made later, such as

**Homonymous hemianopsias**

*optic tract damage causing, 312*

could not easily be fitted between the other two. So that Cindex can re-arrange levels of headings as you add and remove entries, each distinct entry (a heading with one or more subheadings and a locator such as a page reference, or cross-reference) must occupy its own record.

**Record Structure**

You can think of a record as a computerized index card on which you type the entry, just as you would type an entry on an ordinary card. Cindex assigns a number to each record you make. This number serves merely to identify the record—it is not part of the content of the record—and reflects the order of the record’s addition to the index. You can (but need not) use record numbers in locating and managing index entries. Records generally retain their numbers permanently.

The entry you make in a record must have a heading and will usually (though need not) have a locator. The entry may have a subheading and sub-subheadings. Each distinct element of an entry (heading, subheading, etc.) occupies a separate *field* of a record. Each field has a name that indicates the kind of element it contains.
Figure 4 shows a record with four fields (three heading fields and a locator field), each labeled to identify its contents. Cindex provides default names for the fields of records. You can provide your own names if you prefer. For more information on this see “Specifying Field Names, Sizes and Contents” on page 213.

By keeping elements of entries segregated in fields, Cindex can arrange and manipulate entries in exactly the way you want. For example, Cindex can sort page references in a wide variety of formats, and can alter or remove page references selectively. It can also combine, conflate and abbreviate references to identical headings. To accomplish these things Cindex has to know what part of the record contains the page reference. To ensure that Cindex can always identify references, these are placed in a separate locator field (often called the Page field).

Every record must have a field for a main heading and a field for a locator. The locator field (called the Page field in the window shown in Figure 4) is always the last field in a record. Between the main heading and the locator there can be other fields for a subheading, sub-subheading, sub-sub-subheading, etc. When Cindex is installed it is set up to accept records with up to four levels of heading (i.e., records that might contain sub-sub-subheadings) plus a locator. If you want your index to accommodate more levels of heading, you can increase the number, up to fifteen. See “Specifying the Structure of Records” on page 211.

Cindex normally allows records to contain a variable number of fields. Every record contains at least two (for the main heading and the locator), but Cindex
Making New Entries

normally adds fields for subheadings only when you need them. Some kinds of indexes require every entry to be organized with a fixed number of headings. If you are preparing an index of this sort you can set Cindex so that records in the index will always have a fixed number of fields. See “Specifying the Structure of Records” on page 211.

Some publishers require that headings conform to certain specifications—for example, they must not contain more than a specified number of characters, or may not contain particular characters. You can, if you wish, place constraints on the characters Cindex will accept in particular fields of records. See “Specifying Field Names, Sizes and Contents” on page 213.

An index record can hold only a certain number of characters. When Cindex is installed, this number is set to 100, which is adequate for many indexing purposes. You can increase this number whenever you need to. See “Specifying the Structure of Records” on page 211.

MAKING NEW ENTRIES

This section illustrates the steps in making a record, using as an example an entry that when formatted would appear as:

Homonymous hemianopsias
parietal lobe lesions and, 222, 225-227f

To begin a new entry, choose New Record from the Edit menu, or click in the toolbar. Cindex will open at the foot of the main index window a record entry window in which you type the text of the entry. You can set the window to any convenient height by dragging the dashed bar at its top margin.

NOTE: If you prefer to work with a record window that is completely separate from the main index window, you can configure Cindex to provide this. Choose Preferences… from the Edit menu, then click the Editing tab. Cindex will display the window shown in Figure 9 on page 29. Check Use Separate Window.
Follow these steps to make the record:

1. Type the heading *Homonymous hemianopsias* beside the ‘Main’ prompt. Cindex provides all the standard Windows editing capabilities for you to select and correct text as you type it. You can clear, cut, copy, or paste text by choosing the appropriate item from the Edit menu or using a toolbar button. You can undo or redo changes to the text. Use the BACKSPACE key to delete characters backward; use the DEL key to delete characters forward. Cindex provides additional shortcuts for working with words or fields as units of text. Table 1 on page 24 summarizes these.

As you enter characters in the record (or remove them), the display in the status line changes to show how much space you have used and how much is available in the record (Figure 5 on page 23). If you use all the space Cindex will warn you with a beep, and will not allow you to enter further characters. The section “Changing Record Size” on page 212 describes what to do if you find that a record cannot hold the text that you want to enter.
## Table 1. Shortcuts for managing text in the record entry window

<table>
<thead>
<tr>
<th>Key(s)</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>↓</td>
<td>Move insertion point to next line [plus SHIFT to select]</td>
</tr>
<tr>
<td>↑</td>
<td>Move insertion point to previous line [plus SHIFT to select]</td>
</tr>
<tr>
<td>CONTROL ↓</td>
<td>Move insertion point to last line</td>
</tr>
<tr>
<td>CONTROL ↑</td>
<td>Move insertion point to first line</td>
</tr>
<tr>
<td>←</td>
<td>Move insertion point back one character [plus SHIFT to select]</td>
</tr>
<tr>
<td>→</td>
<td>Move insertion point forward one character [plus SHIFT to select]</td>
</tr>
<tr>
<td>CONTROL ←</td>
<td>Move insertion point back one word [plus SHIFT to select]</td>
</tr>
<tr>
<td>CONTROL →</td>
<td>Move insertion point forward one word [plus SHIFT to select]</td>
</tr>
<tr>
<td>END</td>
<td>Move insertion point to end of field (or next field if at end) [plus SHIFT to select]</td>
</tr>
<tr>
<td>HOME</td>
<td>Move insertion point to start of field (or previous field if at start) [plus SHIFT to select]</td>
</tr>
<tr>
<td>TAB</td>
<td>Move insertion point to start of next field</td>
</tr>
<tr>
<td>SHIFT TAB</td>
<td>Move insertion point to start of previous field</td>
</tr>
<tr>
<td>CONTROL BACKSPACE</td>
<td>Delete text to start of word</td>
</tr>
<tr>
<td>CONTROL DELETE</td>
<td>Delete text to end of word</td>
</tr>
<tr>
<td>CONTROL SHIFT BACKSPACE</td>
<td>Delete text to start of field</td>
</tr>
<tr>
<td>CONTROL SHIFT DELETE</td>
<td>Delete text to end of field</td>
</tr>
<tr>
<td>CONTROL +</td>
<td>Exchange heading at insertion point and the one below it (Full flip) [with SHIFT reverses the Smart Flip preference setting]</td>
</tr>
<tr>
<td>CONTROL -</td>
<td>Replace heading at insertion point with the one below it (Half flip)</td>
</tr>
<tr>
<td>CONTROL ]</td>
<td>Increase by 1 the last page reference in the locator field</td>
</tr>
<tr>
<td>CONTROL [</td>
<td>Decrease by 1 the last page reference in the locator field</td>
</tr>
<tr>
<td>CONTROL SHIFT S</td>
<td>Exchange the leading text in a field with parenthesized text that follows</td>
</tr>
<tr>
<td>CONTROL N</td>
<td>( N ) is a number key. Inserts text of heading level ( N ) from the last-edited record</td>
</tr>
<tr>
<td>CONTROL 0</td>
<td>Insert text of locator field from the last-edited record</td>
</tr>
<tr>
<td>CONTROL RETURN</td>
<td>Enter new/changed record in index, close window</td>
</tr>
<tr>
<td>ENTER (keypad)</td>
<td>Enter new/changed record in index, close window</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>Enter new/changed record, move to next</td>
</tr>
<tr>
<td>SHIFT PAGE DOWN</td>
<td>Enter new/changed record, leave a copy as a new record</td>
</tr>
</tbody>
</table>
Making New Entries

CHAPTER 3 Adding and Editing Entries

2. To complete the heading and create a field for a subheading, hit the RETURN key. Beside the ‘Sub1’ prompt type the subheading pituitary tumors and. Do not type leading spaces to indent it. This is unnecessary because Cindex produces the indentations automatically when it displays or prints the formatted entry. If you leave leading or trailing spaces in any part of a record, Cindex will remove them when it saves the record.

Each time you hit RETURN Cindex opens a field for a new level of heading. You can break any field (except the very last field) into two new fields by hitting RETURN; you can combine two fields by placing the entry point at the beginning of the second and hitting BACKSPACE. If you leave any fields empty, Cindex will remove unnecessary ones when it saves the record.

3. When you have completed the subheading, click to the right of the ‘Page’ prompt (or hit TAB) to move the text entry point to the locator field. Insert as many references as you want (up to the limit of the available space in the record), separating each from the next by a comma. You need not insert spaces between adjacent references and can save space by not doing so; Cindex will generate the spaces between the references automatically when it displays the formatted index. When you have finished with the record, it should resemble the one shown in Figure 6.

FIGURE 6. A record with a heading, subheading, and page references
A similar entry with a cross-reference might look like this:

![Figure 7](image)

**FIGURE 7.** A record with a heading, subheading, and a cross-reference

*Characters*

**Accented Letters and Symbols**

Cindex uses Unicode to represent characters. A record may contain any character you can type on the keyboard (including characters you form when you hit a key while holding down the CONTROL key, using shortcuts for Microsoft Word; Cindex Help provides a table of shortcuts for accented characters). You can also choose characters from the Character Map. Choose **Character Map**… from the Character menu. Cindex will display the window shown in Figure 8. To view the characters available in a symbol font or other special font, choose the font from the **Font** drop-down list in the map.

To insert a character from the Character Map into a record, click the character in the map to enlarge it, then drag it to the place in the record where you want to insert it. Alternatively (or if you want to insert a series of characters), click them in turn in the Character Map, then copy the set from the map to the record.
Reserved Characters

The characters < > { } ~ \ have special significance in the sorting of entries. “Overriding Sorting Rules for Individual Entries” on page 159 explains their functions. To include one of these characters as a literal character in a record, place \ immediately before it. Thus, to use \ as a literal character you would type \\ in a record; to use ~ as a literal character you would type \~. When Cindex displays the index entry it shows only a single \ or ~.

Formatting and Punctuating Entries

Headings and subheadings will sometimes be too long to fit on a single line in the record window, or too wide fit on a line in the main index window. You should not try to organize headings into lines of the proper length, nor should you worry about indenting runover lines or providing punctuation at the end of field (for example a comma that would appear before page references. Cindex automatically breaks long lines, indents runover lines and inserts appropriate punctuation when it displays or prints the formatted index, following a docu-
Making New Entries

ment layout specified for the index. Cindex will not be able to format an entry properly if you provide leading or trailing punctuation in record fields. For information on how to specify the document layout see “Formatting the Index” on page 167.

There is generally no limit to the length of text in a single field (providing it is less than the total record size) and if you type beyond the edge of the record window Cindex will wrap the heading around to the next line (you can set the size of the window to display the text in the way you prefer). How Cindex breaks lines of text in the record window has no bearing on the appearance of the entry in the formatted index. Use the RETURN key only to indicate the end of a heading or subheading; do not use it to break a long line of text at the edge of the window.

Saving a New Entry

When you have completed your entry, hit CONTROL RETURN (or ENTER on the keypad). Cindex will close the window and display the saved record in the main document window, formatted in the manner dictated by current settings. If your record is empty Cindex will discard it automatically.

NOTE: To close the window and discard the entry hit ESC.

If you are using a free-standing window for record entry, you can also save the entry by clicking the close box, or by choosing Close from the File menu. If you use either of these methods, Cindex normally asks if you want to save (or discard) the record. You can set Cindex so that it will not query you, but instead always discards changes to the record, or always saves changes to the record. To specify how Cindex should behave when you close the record window, choose Preferences... from the Edit menu, then click the Editing tab. Cindex will display the window shown in Figure 9. Choose the behavior you want by clicking the appropriate item in the box labeled On Closing Window.
Making New Entries

CHAPTER 3  Adding and Editing Entries  29

FIGURE 9. Preferences for adding and editing records

- If you click **Always Save**, Cindex will always save a record, no matter how you close the window (it always discards changes if you hit ESC).

- If you click **Ask**, (the default setting) Cindex will prompt you to decide what it should do if you close the window by clicking the close box or choose **Close** from the File menu.

- If you click **Always Discard**, Cindex will always discard changes if you close the window by clicking the close box or choose **Close** from the File menu (it always saves changes if you hit CONTROL RETURN, or ENTER on the keypad).

Cindex remembers your setting.

Displaying New Entries

As you add each record to the index, Cindex displays it in the main window. If that is set to display index entries in draft view, Cindex will display a bullet beside the lowest level of heading in the new entry to indicate that the record has been changed during your current session with Cindex.

While you are adding new records, Cindex normally displays them in record-number order so that you can see the most recently-added records in their order.
Making New Entries

of entry. If you prefer, Cindex will display each new record in its sorted position in the index.

To make Cindex display new entries in their sorted positions, choose Preferences... from the Edit menu, then click the Editing tab. Cindex will display the window shown in Figure 9 on page 29. Check Track New Entries.

Checking Entries

As you store each record Cindex checks for certain typographical errors. It automatically removes leading or trailing spaces in any field, and removes excess blank fields. If you have used parentheses, square brackets or quotation marks to enclose any part of a heading or any part of a page reference, Cindex checks for matching pairs. If it finds a mismatch, it will warn you with a beep and will highlight the field that contains the mismatched elements. If you really do want to leave the mismatched characters in a field, Cindex will accept the record when you make a second attempt to store it.

If you have enclosed text in < > or { } —special characters that Cindex uses to control the sorting of entries—Cindex checks that these occur in matched pairs in a field. If Cindex detects a mismatch, it will beep and highlight the field that contains the mismatched elements. If you make a another attempt to enter the record without having first corrected the error, Cindex will display an explicit warning message.

Cindex allows you to impose your own restrictions on the contents of individual fields of records—for example, you can stipulate that the locator field must contain only numerals. For information on how to do this see “Specifying Field Names, Sizes and Contents” on page 213. If you have imposed some restriction on the contents of a field, Cindex will warn you with a beep (and will highlight the offending field) if you try to save a record that contains forbidden characters or character sequences.

Stamping Records with Date and User Identifier

When you add a new record to the index, or modify an existing record, Cindex stamps it with the date and time at which the record was added or changed, and the user identifier (if any) you provided. This information is held separately from the record text. When you view a record in the record window Cindex displays the date and time of modification and the user identifier in the status line at the
Making New Entries

foot of the window. You can find records by their date of modification or by the
user identifier. “Controlling the Scope of the Search” on page 76 explains how to
do this.

Making a Series of Entries

To make several new records in succession, can save each new one by hitting
PAGE DOWN (or clicking ▼ ) rather than CONTROL RETURN. Cindex will save
the record and clear the record window for a new one.

To save a new record and leave a copy of it as the foundation of another one, hit
SHIFT PAGE DOWN or click .

Moving Through Entries

When the record entry window is open you can use the PAGE DOWN and PAGE
UP keys, or the ▼ and ▲ buttons, to move forward or backward through the
records displayed in the main index window, bringing each in turn into the
record window. You can change the text of any record in the window; the
changed record will be saved automatically when you move to another one.
When you move beyond the last record in the index, Cindex will leave the
record window empty for a new entry.

To edit any entry visible in the main document window, double click it, or click
to select it and hit RETURN or choose Edit Record from the Edit menu. Cindex
will place the record in the record entry window for you to make changes. When
you are finished, hit CONTROL RETURN to save changes and close the window, or
click ▲ or ▼ (or hit PAGE UP or PAGE DOWN) to save the record and move to
the previous or next one, or click SHIFT PAGE DOWN to save the record and leave
a copy as the foundation of a new one. To discard changes and close the window
hit ESC.
Making New Entries

Page References and Cross-References

Cindex has powerful capabilities for searching among and modifying locators, for sorting multiple locators that follow a single entry, and for formatting them in different ways. (“Page References” on page 125, and “Cross-References” on page 111, describe what Cindex can do with page references and cross-references.) Cindex can employ its capabilities only if knows where to find locators, and how to recognize multiple locators when an entry contains them. The following paragraphs introduce some basic principles you should follow when making and editing entries.

To ensure that Cindex knows where to find locators (both page references and cross-references), always put them in the locator field of the record. The locator field is always the last field in a record.

To ensure that Cindex can display cross-references and page references in their correct positions in the formatted index (these positions can vary with the index style you choose), do not mix cross-references and page references in the same record. If an entry has both page references and cross-references, you should make two records that contain identical headings, one with page references in the locator field, the other with cross-references in the locator field. Cindex provides simple ways to duplicate a record so that you need not type it twice.

To ensure that Cindex can recognize multiple locators when you place more than one in the locator field, you should use a standard character to separate one reference from the next. This character should not be one that would ever appear within a locator. When parsing locator fields Cindex assumes that page references are separated from each other by a comma, and that cross-references are separated from each other by a semicolon. If you want to use other characters as separators, you must designate them explicitly. “Specifying the Structure of Page References” on page 126 explains how to do this for page references; “Specifying the Structure of Cross-References” on page 112 explains how to do this for cross-references.
Page References
To find or adjust page references, Cindex needs to know what character denotes an inclusive range (e.g., 55-57). Cindex normally recognizes a reference to an inclusive range of page references by the appearance of a hyphen between the numbers, but you can use another character if you wish. “Specifying the Structure of Page References” on page 126 explains how to change that character. When Cindex displays entries in the fully formatted view it can translate this separating character to some other character or sequence of characters. For example, Cindex can display as ‘55 to 57’ a reference that exists in a record as ‘55-57’. “Formatting Page References” on page 138 explains how to arrange this.

When you need to specify a range of page numbers (e.g., 237-239), always enter the range in full, even if your publisher wants it abbreviated (e.g., 237-9). Cindex can abbreviate references automatically when it formats entries; if you abbreviate references when you place them in records, Cindex might not always be able to find locators when you search for them.

Cindex will work fluently with compound locators that consist of multiple components, including dates, roman numerals and letters. If you use compound locators do ensure that the character you use to separate distinct references (the default character is a comma) does not appear within a reference.

When you put several page references in one locator field, you need not place them in ascending order. Cindex will sort them when it displays the formatted entries.

Cross-References
Cindex recognizes a cross-reference by identifying its introductory phrase as one of the following: See, See also, See under, or See also under. If your index uses cross-references that begin with some other kind of introductory word or phrase, you must designate that explicitly. Chapter 7 “Cross-References” on page 111 explains how.

When you type a cross-reference, you need not apply a style to the introductory phrase. When Cindex displays formatted entries it can apply different designated styles automatically to the introductory phrase and to the body of a cross-reference.
When you put several cross-references in one locator field, you need not place them in alphabetical order. Cindex will sort them when it displays the formatted entries.

Comments, Web Addresses and Other Special Text

You may want to attach to your index entries comments that should not appear in the finished index, or special text such as web addresses (URLs) that augment normal locators in the last fields of records. This is most easily achieved by reserving a record field for the purpose.

When you want records to contain special text that is not part of the normal entry you can assign a special attribute to the last subheading fields (those that immediately precede the locator fields), and can place the special text in these fields. When you assign the special attribute Cindex ensures that the last text field is always attached to the locator field, and cannot be joined to any other, or split into multiple fields. Subheadings you add to the record are always inserted above the special field.

Text in the special field can be hidden when you view the formatted index, and can be ignored in sorting entries.

To configure your index records to have a special last text field preceding the locator field see “Special Last Text Field” on page 213.

To suppress the display of this field in the formatted index see “Typography and Punctuation of Headings” on page 181.

To ignore the contents of this field when sorting entries see “Field Evaluation Order” on page 147.

Fonts and Styles

Fonts

Except for parts of entries explicitly marked for display in a particular font, all entries are displayed in a standard font. When the main window for an index is
active, you can change the standard font and type size by choosing from the appropriate drop down list in the main toolbar

**NOTE:** When you start a new index Cindex establishes a standard font and size in which all entries are displayed. By default, Cindex also uses this font and size when it displays records for editing in the record window. The standard font is initially set to Arial, 12 point.

To change default fonts and sizes, choose **Preferences**… from the Cindex menu and click the View tab (Figure 10). Under Default Font use the menu to set the font that Cindex will assign initially when it creates a new index. At **Main View** set the size of text to be used initially for displaying entries in the main index window; at **Entry View** set the type size to be used when you work in the record window (you cannot change the type size locally within a record). If you set this to 0, Cindex will always set the text in the record window at the size used for display in the main window.

![View Preferences](image)

**FIGURE 10. View Preferences**

When you are working in the record window, you can set any part of an entry in a font of your choosing. Select the text you want to change, then choose from the font drop-down list in the main toolbar.
Making New Entries

To restore to the standard font any segment of text set in some other font, select the text, then choose Default Font from the Character menu, or click in the record window toolbar, or right-click and choose from the contextual menu.

Styles

The default style for an index is plain text. You cannot apply another style to a complete index, but you can apply a style automatically to particular elements of entries. For example, Cindex can display all main headings in boldface capitals, regardless of how you entered the headings in records. Similarly, Cindex can display and print the introductory See or See also phrases of cross-references in a specified style (e.g., italics) and the body of a cross-reference in some other style, such as small caps. For more information about applying styles automatically to headings, see “Typography and Punctuation of Headings” on page 181; for information about applying styles to page references see “Formatting Page References” on page 138; for information about applying styles to cross-references, see “Placing and Formatting Cross-References” on page 118.

To apply a style to text in the record window, select the text, then choose the style from the Character menu or the contextual menu displayed when you right-click in the record window. The most often-used styles, boldface, italics and underline are available through the , , and buttons on the record window toolbar. You can apply multiple styles to the selection. If you choose a style when no text is selected, that style will be applied to the next characters you type.

NOTES: If you apply the SMALL CAPS style, Cindex will display the text in the record window as small letters, but will not change the case. In the main index window lowercase letters will appear as small uppercase letters.

To remove all styles from a selection choose Plain from the Format menu or the contextual menu. To remove a single style from a selection that contains several styles, choose that style from the menu.

Case Conversion

To convert the case of selected text, choose the appropriate conversion option (Uppercase, Lowercase, Initial Caps) from the Character menu.
EDITING EXISTING ENTRIES

From the main view of the index you can edit any record by double-clicking it or by selecting it then hitting RETURN or choosing Edit Record from the Edit menu.

Cindex will display the record in the record window. You can modify it using the techniques described in the preceding section. To discard any changes you have made, and restore the record to its original state, click or hit CONTROL SHIFT O; to discard changes and close the window, hit ESC. When you have completed your changes, hit CONTROL RETURN to save the record and close the window, or click or (or hit PAGE UP or PAGE DOWN) to save and move to the previous or next record.

To leave behind a copy of the edited record as the foundation of a new record, hit SHIFT PAGE DOWN or click .

When you finish editing a series of records, Cindex normally leaves the main view window showing the last-edited record. If you prefer, you can make Cindex restore the display to its state before you started editing. To do that, choose Preferences... from the Edit menu, click the Editing tab and check Return to Entry Point.

WORKING EFFICIENTLY WITH RECORDS

Cindex provides several features that help minimize errors and keystrokes when you make and edit entries. This section provides information about a range of techniques for working with individual records. “Advanced Editing” on page 85 introduces some methods for making changes to many records concurrently.

Cindex provides powerful features to help you find the records you want to edit. For information on how to use these, see “Finding Entries” on page 70.
Contextual Menus

Some of the most often-used menu items are available in a pop-up menu that Cindex will display when you click the right mouse button in the main index window or in the record-entry window. The set of items in the menu depends on the window in which you click.

Auto-Completion of Entries

As you begin typing the text of a new entry, Cindex can automatically complete each record field if what you have typed matches text in the corresponding field of an existing record. To enable auto-completion of entries, choose Preferences… from in the Edit menu (Figure 9 on page 29), and click the Editing tab. In the box Adding check Auto-Complete Entries.

When you enable auto-completion, and you begin typing the text of a heading in a new record, Cindex will look for any existing record whose heading begins with the text you have typed. If Cindex finds a match, it will append and highlight the text to complete the heading you are typing.

NOTE: Auto-completion works only when the index is sorted alphabetically. It does not work if your index is sorted by page number. If your index is sorted using letter-by-letter or word-by-word alphabetizing, Cindex will not attempt to complete an entry until you have typed enough of it to specify where the entry would appear in the index. For example, if you begin an entry with a quotation mark (which is ignored in letter-by-letter and word-by-word alphabetizing), Cindex will wait until you have typed further characters before looking for a matching entry. For this reason you may find it most convenient to use Simple alphabetizing while adding entries to the index. For more information on sorting entries see Chapter 9 “Sorting Entries” on page 147.

If the appended text is what you would have typed, you can accept it and open a new field by hitting RETURN, or you can accept it and move to the next field by hitting TAB. If you want to append text hit →. If the supplied text is not what you want, continue typing. As you type, Cindex will automatically search for a record that has a matching heading, and will continually supply you with the first heading (if any) that matches exactly what you have typed. As soon as you
Working Efficiently with Records

type a character that would make the current record no longer match an existing one, Cindex will remove any highlighted text it has automatically appended.

Cindex can automatically complete subheadings at any level, as long as the main heading and any preceding levels of subheadings match an existing record in the index.

When you have checked Auto-Complete Entries, Cindex makes two other options available (Figure 9 on page 29). To make Cindex complete entries that match existing ones, regardless of letter case and type style, check Ignore Style & Case.

NOTE: If you have checked Ignore Style & Case, and Cindex completes an entry from a source that does not match in style and case, it automatically adjusts the style and case of the text you have typed. If you subsequently type characters that no longer match the completed text, Cindex restores the style you had set initially.

If you wish, Cindex will display in the main view (behind the record-entry window) the entry it is using as the source of text to complete the heading you are typing. To enable this display, check Track Source.

NOTE: If you have checked Track Source, Cindex will display the source entry only if it would normally be visible in the current view of the index.

Manipulating Fields in Records

Cutting, Copying and Pasting Text

When you cut or copy text that spans more than one field, Cindex preserves the field divisions in the text; when you paste text into a record, the field boundaries are also pasted. If pasting text would cause a record to contain more than the maximum number of fields allowed in the index, Cindex will not paste the text, and will warn you with a beep. If cutting text from a record would cause it to have fewer than the minimum number of fields required by an index, Cindex will replace the cut text with empty fields.

Cindex gives you control over how it pastes text:
Working Efficiently with Records

- When you paste text that originates within Cindex (e.g., copying from one record to another), the pasted text normally keeps the style and font of the source. To discard only font information, hold down the ALT key as you paste; to discard both style and font information hold down the SHIFT key.

- When you paste text that originates outside Cindex (e.g., from a PDF document), the default behavior is to keep the style but not the font of the source text. To change this behavior, choose Preferences… from the Edit menu, and click the Editing tab (Figure 9 on page 29). In the box labeled Paste and Drop Text choose the behavior you want.

You can override your preferred setting at the time of pasting:

Hold the SHIFT key to deliver plain text (if the default behavior is to deliver with styles or styles & fonts) or to deliver text with styles and fonts (if the default behavior is to deliver plain text).

Hold the ALT key to deliver styled text in the default font (if the default behavior is to deliver with styles & fonts, or plain text) or to deliver text with styles and fonts (if the default behavior is to deliver styled text).

Removing Superfluous Spaces

When two or more successive spaces are entered in a record, these are automatically reduced to a single space. To change this behavior, choose Preferences… from the Edit menu, and click the Editing tab (Figure 9 on page 29). In the box labeled General uncheck Remove Extra Spaces.

Dragging and Dropping Text

When the record window is active, you can drag text between fields, or between the record window and the record window of another index. You can also drag text between a record window and another application program, such as a word-processor. To drag text, select it, release the mouse button briefly, then press the mouse button and begin the drag. If dragging text into a record would cause the record to contain more than the maximum number of fields allowed in the index, or more characters than the record can hold, Cindex will not complete the drop, and will warn you with a beep.

When you drag and drop text within a record, Cindex moves the text unless you hold down the CONTROL key while completing the drag, in which case the text is copied. When you drag text from one record to another, Cindex removes the
Working Efficiently with Records

text from the first record unless you hold down the CONTROL key while completing the drag.

NOTE: When you drag and drop text, you can control whether the dropped text carries the style and font of the source. See “Cutting, Copying and Pasting Text” on page 39.

Retrieving a Field from the Last-Edited Record

While working on any record, you can retrieve headings individually from the last record you edited. To retrieve the text of a main heading from the last-edited record and place it at the insertion point, hit CONTROL 1; for other heading levels hit CONTROL N, where N is the level of heading to be retrieved (2 for subheading, 3 for sub-subheading, etc.). To retrieve text from the locator field of the last-edited record hit CONTROL 0.

Managing Page Numbers

Cindex provides several ways to simplify the entry of page numbers.

- When you add a series of new records, the entries in successive records will often refer to the same page of text. You can set Cindex so that as it creates each new record it fills the locator field with the contents of the one you last made. To do this, choose Preferences... from the Edit menu (Figure 9 on page 29) and click the Editing tab. Check Carry Locators Forward.

  When Carry Locators Forward is checked, each new record you create starts with its locator field holding the same references as the record you last added. When you alter the references in the locator field in a new record, the altered ones become the ones Cindex will load into subsequent new records.

- You can configure Cindex to generate the second part of a page range automatically when you type the character that connects the two parts of the range. For example, if a dash is the connecting character, and you enter 55- Cindex will complete the reference as 55-56. Cindex does this only if the last recognized component of the last page reference in the locator field is a number in Arabic numerals. To enable auto-completion of page ranges, choose Preferences... from the Edit menu (Figure 9 on page 29) and click the Editing tab. Check Complete Page Ranges.

- With a single keystroke you can increment or decrement the last page number in the locator field (the text cursor can be anywhere in the record). To increment the page number, hit CONTROL \]. To decrement the page number hit CONTROL [. This operation affects only the last component of the last page reference in the locator field. If the last recognized component is not a number in Arabic numerals (e.g., it consists of Roman numerals or is an alphabetic suffix), the operation does nothing.
Managing Acronyms

When a record field contains a phrase followed by text in parentheses (for example, an acronym followed by its expansion, or *vice-versa*) you can exchange the contents of the leading text with the text in parentheses by clicking the toolbar button or hitting CONTROL SHIFT S.

Inserting Fields

To insert a subheading in a record that has only a main heading and a locator, place the insertion point at the end of the main heading and hit RETURN. Cindex will make a new field between the main heading and the locator. Use the same method to insert a sub-subheading. To demote a heading to a subheading, so that you can insert a new main heading above it, place the insertion point at the beginning of the main heading, and hit RETURN.

**NOTE:** If you want to gather a group of disparate entries under a new main heading, you should use the **Demote Headings** command. See “Demoting Headings” on page 44.

If you inadvertently add too many blank fields, do not worry about removing them. Cindex automatically removes excess blank fields and any fields that contain only spaces when you save the record. Cindex also removes leading and trailing spaces in any field.

Breaking Fields

To convert a heading with a modifying phrase into a heading with a subheading, place the insertion point to the right of the comma before the modifying phrase, hit BACKSPACE to delete the comma, then hit RETURN. Cindex will move the modifying phrase into a new subheading field. You can break any field (except the locator field) by placing the insertion point where you want the break then hitting RETURN.

**NOTE:** In the course of preparing an index you might create many records with modified headings that would be better arranged as headings with subheadings. To relieve you of the tedious task of finding and editing such entries individually, Cindex will do the job for you automatically. For information on how organize this, see “Reconciling Heading Levels” on page 99.

Joining Fields

While you are making records, you will often produce them with subheadings (or even sub-subheadings) in the expectation of adding further entries for the same heading. If you do not in fact add other records, you will end up with isolated records that contain a single entry organized as heading and subheading, as in:
In such cases, you will normally want the isolated subheading to be brought up as a modifier to the main heading.

To change a subheading to a modifier, place the insertion point the beginning of the subheading then hit BACKSPACE. Now type a comma, or another character you want to separate the heading from the modifier. You can use the same method to bring up a sub-subheading as a modifier to a subheading.

NOTE: You do not need to edit such records individually. Cindex can automatically convert redundant subheadings to modified headings. For more information on this, see “Reconciling Heading Levels” on page 99.

To exchange (flip) the contents of any two fields, place the insertion point anywhere in the upper field and click , or hit CONTROL +. To discard the contents of the upper field and pull up the contents of the lower field (half flip) click or hit CONTROL −.

Cindex is initially set to make flips and half-flips that are ‘smart’. In a smart flip:

• A flipped heading inherits the case of the initial letter of the heading it replaces.
• If the subheading field that becomes the main heading begins with words from a set you specify, these words are moved to the end of the main heading that will become the subheading. If the lower field is the locator field and contains a see reference, the cross-reference prefix is removed as the field is promoted; if the locator field contains a see also reference, the prefix is transferred to what will become the new locator.
• (Full flip only) If the subheading field that becomes the main heading ends with words from the specified list, these words are moved to the beginning of the main heading that will become the subheading.

To disable smart flipping choose Preferences… from the Edit menu, click the Editing tab (Figure 9 on page 29), then uncheck Smart Flip.
When you make a full flip (CONTROL +) or a half flip (CONTROL –) you can override the current mode (smart or not) by holding down the SHIFT key while you give the command.

To edit the set of prefix and suffix words that can be moved during a smart flip, choose **Smart Flip Words**… from the Document menu. Place a ~ immediately before any word (such as and or versus) that should maintain its prefix or suffix position as it is moved from one field to the other.

**NOTE:** If you set Smart Flip Words when no index is open for work, your settings become the defaults applied to new indexes.

**Demoting Headings**

You can easily gather, under a new heading, existing entries that have different headings but related content. For example, in a cookbook index, various scattered entries that refer to different kinds of pies might be better gathered as sub-entries under a heading “Pies.” To place a collection of existing entries as subentries under a new heading, follow these steps:

- Ensure that you are viewing the entries as a block of contiguous records (either they follow each other in sorted order, or you have made a group using **Find**…).
- Select and highlight the records of interest.
Choose **Demote Headings** from the Edit menu (also available in the contextual menu displayed when you right-click on the selected records).

Cindex will insert a placeholder main heading in all the selected records. The placeholder has the form __xxx__, where xxx is the date and time of heading creation, such as 2018-10-5T15:30:45. Cindex will then open the first of the records and select the placeholder text so that you can edit it as required.

![Placeholder following heading demotion](image)

**FIGURE 12. Placeholder following heading demotion**

**Propagating Changes to Subordinate Records**

When you work in the record window and change the contents of an index heading, you will normally want all succeeding records that shared that heading to be changed in the same way. When Cindex is installed it is set to ensure that when you change the text of one or more headings, and save a record, the changes are automatically propagated to all succeeding records that shared the original heading(s).

You can disable propagation generally, and reinstate it on a record-by-record basis, or you can enable propagation generally, and disable it on a record-by-
record basis (this is how Cindex is initially set). To set the general behavior, choose Preferences... from the Edit menu, click the Editing tab (Figure 9 on page 29) then check (or uncheck) Propagate Changes.

If propagation is enabled generally, ✤ is initially depressed when Cindex opens the record window for editing. You can disable it and enable it as required for each record. If propagation is disabled globally, ✤ is initially raised when Cindex opens the record window for adding or editing.

NOTE: Automatic propagation of editing changes can save an enormous amount of work, but to use it to best effect you need to watch that you edit the right record. For example, to change a main heading, you should edit the first record in a series. Cindex does not propagate changes backward, so any records above the one you change will be untouched.

Checking Locators

You can set Cindex to check locators and warn you about (or forbid) the entry of a record that has an empty locator field or a malformed range of page numbers (e.g., 95-93). Choose Preferences... from the Edit menu, click the Editing tab (Figure 9 on page 29) then click the appropriate button under Bad Locator.

• If you click Accept, Cindex will accept an empty locator field or a malformed locator.
• If you click Warn, Cindex will beep on your first attempt to enter a record with an empty locator field or malformed reference, but will accept a subsequent attempt.
• If you click Forbid, Cindex will never allow the entry of a record with an empty field or malformed reference.

Cindex remembers your setting.

NOTE: Cindex can also check that no entry contains too many unqualified page references. See “Page References” on page 228.

Identifying Acceptable References

Cindex can check that each reference you enter falls within limits that you specify. You can specify a value that no reference may exceed, and you can specify the greatest permitted span in a range of references. To specify limits choose Refer-
Working Efficiently with Records

ence Syntax... from the Document menu. The relevant settings are under Page
References.

To specify the largest permissible value for a locator (typically the number of the
last page in the work being indexed), enter it at Maximum Value. This may be a
compound (multi-part) locator if your index uses these. Do not enter a range of
locators. To set no limit, leave Maximum Value blank.

To set the largest span acceptable in a range of references, enter the number of
pages at Greatest Range. For example, to permit a span of 10 pages or less, such as
23-33, or 102-112, but not a span of eleven pages, you would enter 10. To place
no restriction on the allowable span, set 0.

NOTE: Cindex uses any limits you specify for Maximum Value or Greatest Range only
when reference checking is enabled (see “Checking Locators” on page 46).

For more information on the types of locators Cindex can work with, see Chap-
ter 8 “Page References” on page 125.

Checking Cross-References

Cindex can check that cross-references you enter in records have targets else-
where in the index.

Choose Preferences... from the Edit menu, click the Editing tab (Figure 9) then
click the appropriate button under Bad Cross-Ref.

- If you click Accept, Cindex will accept a cross-reference that has no target.
- If you click Warn, Cindex will beep on your first attempt to enter a record with an
cross-reference that has no target, but will accept a subsequent attempt.
- If you click Forbid, Cindex will never allow the entry of a record with cross-reference
that has no target.

NOTE: Cindex checks that a target heading begins with the text of each cross-reference
in the locator field of a record. It does not check that the cross-reference is a full match
to the target heading. For more rigorous verification of cross-references See “Cross-Ref-
erences” on page 225.
Using Hot Keys

USING HOT KEYS

You can designate a set of keys or key-combinations (hot keys) that you can use to simplify editing. A hot key can have attached to it frequently-used words or phrases that you can insert in a record simply by hitting the appropriate key. The text you attach to a key can contain style attributes such as boldface and italics. When Cindex is first installed two hot keys have text attached: the word ‘See’ is attached to SHIFT F1, and the phrase ‘See also’ is attached to SHIFT F2.

Setting-up Hot Keys

To review or change the text assigned to hot keys, choose Hot Keys from the Tools menu. Cindex will display a dialog box through which you can change settings.

To define or change a key, click in a left panel under Key, and type the keystroke combination you want to use, e.g., CONTROL F1. Do not type the words as you see them in the panel; simply enter the keystrokes.

NOTE: Choose your keys or key combinations carefully, so as not to conflict with normal usage by Cindex or other programs. Once you have defined a hot key or key combination, that definition prevents Cindex (or any other active application program) using the key for any other purpose while Cindex is active.

To specify or change the text attached to a key, click in a right hand panel under Attached Text, and type the text you want to use. You cannot apply attributes to text you type, but you can drag or paste text that contains styles. The most convenient source of such text will probably be a selection in the record entry window.

NOTE: If you attach text that contains font attributes, Cindex remembers only the Symbol font. All other hot-key text is rendered in the default font for the index.

Using Hot Keys

To insert text in a record, click where you want the text to appear (or select any text you want to replace), then hit the appropriate key or key combination. If the inserted text would cause the record to contain too many fields, or too many characters, Cindex will warn you with a beep.
Cindex lets you use abbreviations to represent long words or phrases; when you type the abbreviations in records Cindex automatically expands them to the phrases they represent. For example, you might define ards to represent Adult respiratory distress syndrome.

Cindex can maintain multiple sets of abbreviations that you can use in different kinds of indexes, but it can use only a single set at one time.

Defining Abbreviations

Cindex initially has no abbreviations defined. You can define abbreviations and their expanded phrases as you work on an index, or independently of it. You can define abbreviations in two ways: by entering them through the Abbreviations window, or by extracting a word or phrase from a record as you work on it in the record-entry window.

While you are adding or editing a record, you can define an abbreviation for any word or phrase that you have typed. Select the text for which you want to define an abbreviation, then choose New Abbreviation from the Edit menu or right-click and choose from the contextual menu. Cindex will display a small window in which you can type the name of the abbreviation. Click OK to complete the definition.

To view or edit abbreviations, choose Edit… from the Abbreviations submenu in the Tools menu. Cindex will open a window that shows all its abbreviations and the phrases they represent.
To add an abbreviation, choose *New Abbreviation* from the Edit menu. Cindex will display and highlight the word NEW in the left column. Replace this by typing the abbreviation you will enter in a record to recover the long phrase (‘ards’ in the example above), then hit TAB, and type the full phrase you want the abbreviation to represent (‘Adult Respiratory Distress Syndrome,’ above).

The abbreviation may contain any sequence of up to eight characters except a space and certain punctuation marks discussed on page 52. If the expanded phrase or parts of it should appear in a particular style, select the text and choose the style from the Character menu. (You cannot specify a font—abbreviations are always expanded in the font in use at the insertion point in a record.)

Use the normal text-editing functions to edit any abbreviation or its expanded phrase. If you create or change an abbreviation so that it matches another one, Cindex will warn you when you close or deactivate the Abbreviations window. You must change the duplicate; Cindex will not allow the same abbreviation to represent two different phrases.

To remove an abbreviation, select it together with its expanded phrase (as a shortcut you can triple-click it), then choose *Clear* from the Edit menu, or hit DELETE.

The number of abbreviations you can have in a single set is limited only by the available memory on your computer.
You can view abbreviations sorted alphabetically by abbreviation or by expanded phrase. Click the appropriate column header (Abbreviation, or Expansion) to sort by that key.

To save the current set of abbreviations when the Abbreviation window is active choose Save or Save As… from the File menu.

NOTE: If you have changed but not saved abbreviations during a session, Cindex will always ask you, before quitting, if you want to save the changes.

To print the current set of abbreviations and their expanded phrases, ensure that the abbreviation window is active, then choose Print… from the File menu.

Saving and Loading Abbreviations

Cindex works with one active set of abbreviations (its name is displayed as the title of the window in which you edit abbreviations), and when you define a new abbreviation Cindex always adds it to the active set. You can maintain multiple sets of abbreviations for use on different occasions.

To start a completely new set of abbreviations, choose New… from the Abbreviations submenu in the Tools menu.

To deactivate the current set of abbreviations, leaving none active, choose Close from the Abbreviations submenu in the Tools menu.

To open an existing set of abbreviations, choose Load… from the Abbreviations submenu in the Tools menu.

Cindex keeps track of the set of abbreviations you last used, and automatically uses it when you start a new session.
Using Abbreviations

To insert expanded form of an abbreviation anywhere in a record, simply type the abbreviation. If there is enough room in the record Cindex will expand an abbreviation that is preceded by a space or any of these characters:

```
( [ " " ]
```

and succeeded by a space or any of these characters:

```
) ], : ; " "
```

Cindex will not accept any of the above characters in an abbreviation, though they may appear in the expanded phrase. If there is not enough room to accommodate the expanded phrase, Cindex will beep.

If you type the abbreviation at the end of a field, Cindex will expand it if you use ↓ or TAB or RETURN to move to the next field.

If you find that you must use an abbreviation literally, you can insert it in a record with the following procedure: append some spurious character to it, followed by the character that would normally trigger its expansion, then move the entry point back to the spurious character and delete it. Because Cindex checks abbreviations only when you type one of the special terminating characters that triggers expansion, it will not expand the abbreviation that results from deleting the spurious character.

To prevent conflict between acronyms you want to use literally and acronyms you want to use as abbreviations, begin your abbreviations with a character or symbol that you are unlikely to use in the index. For example, if you want to use CME both as an abbreviation for “Continuing Medical Education” and as an acronym, you could name the abbreviation !CME, @CME or #CME.
DUPLICATING RECORDS

When you double-post entries you produce two very similar sets of entries, perhaps differing only in the organization of the main heading. For example you might have a series of entries under the heading “Dogs and cats” that you want also to appear under the heading “Cats and dogs.” Cindex makes it easy to produce one set of records based on another.

To make a new record based on the one currently open in the record window, choose Duplicate from the Edit menu, or hit SHIFT PAGE DOWN, or click . Cindex will make a new record from the one currently displayed (after saving any changes to the current record). The window's title shows you that it contains a new record. You can modify this new record as required. At any time before you save it you can click (or hit CONTROL SHIFT O) to restore it to its original form. Cindex will save the record when you click , or , or use a corresponding shortcut. If you do not modify the new record—that is, the record remains an exact duplicate of the one on which it was based—Cindex simply discards it.

When the main document window is active, you can duplicate any records on display. Select those you want to duplicate, then choose Duplicate from the Edit menu. Cindex will duplicate the selected records and place the new one(s) properly in the index. For more information on finding and selecting records to duplicate, see “Selecting Entries” on page 67 and “Finding Entries” on page 70.

Because you normally duplicate records as a prelude to modifying them, Cindex displays the new record(s) so as to facilitate editing:

- If you duplicate a single record, Cindex immediately opens it for editing in record-entry window. Regardless of whether or not you subsequently modify it, the record remains a part of the index.
- If you duplicate several records, Cindex forms a temporary “group” from them, and displays just this group in the main document window. You can edit these records in the normal way. “Groups of Records” on page 68 explains what groups are and how to use them while preparing an index. To restore the display of all index records in the main document window, choose All Records from the View menu or click .
Deleting and Restoring Records

NOTE: You can also duplicate selected entries by choosing Copy from the Edit menu, then Paste from the Edit menu. If you use this method, Cindex does not open the record window (for a single record) or form a temporary group (for multiple records).

Copying Entries from One Index to Another

To copy entries from one index to another, select them in the main index window, then drag them into the main window of the destination index. (For more information on selecting records, see “Selecting Entries” on page 67.) Alternatively, you can copy and paste the records: select the records you want, then choose Copy from the Edit menu or click . Activate the main window of the index into which you want to paste the entries, then choose Paste from the Edit menu, or click .

NOTES: You cannot undo this drop or paste, but you can restore the index to its last-saved form by choosing Revert to Saved from the File menu. See “Preserving and Discarding Changes” on page 12.

Cindex always inserts pasted records—it never replaces any records currently selected.

You can copy and paste, but cannot drag and drop, records within the same index.

You cannot paste or drag records into an index when its record window is open.

If the records in the destination index cannot accommodate as many fields as are in the records being dropped or pasted, Cindex will ask you if you want to increase the permitted number of fields.

If the record size in the destination index is too small to accommodate the records being dropped or pasted, Cindex will ask if you want to enlarge the record size.

DELETING AND RESTORING RECORDS

To remove a record (or records) from the index, select them in the main document window then check Deleted in the Edit menu, or click in the main toolbar. A deleted record is not physically removed from the index—it merely
becomes hidden when you view a fully formatted index. In a draft or unformatted view, a deleted record is shown with the symbol ✗ (in blue) in the left margin beside it. Deleted records are never displayed in a formatted view.

To restore deleted records select them in the main document window and uncheck Deleted in the Edit menu, or click ✗ in the toolbar.

In the record window you can delete the current record by checking Deleted in the Edit menu (or clicking ✗). You can restore a deleted record by unchecking Deleted (or clicking ✗). The status line at the bottom of the record window displays “Deleted” if the current record is deleted.

To remove deleted records permanently choose Compress… from the Tools menu. “Compressing Index Entries” on page 230 explains how to use Compress. Deleted records cannot be restored after you have compressed the index.

**LABELING RECORDS**

Cindex lets you label records that it will display in conspicuous colors. A label serves as a marker you can use for any purpose you choose (for example to identify records that contain incomplete entries). The label has no other function than to provide a tag that you can use to identify a class of records and make it conspicuous. Cindex can use a label as a search criterion in find and replace operations. A record may carry one of seven different labels.

To label a record or records, select them in the main document window then choose the label you want from the Labeled submenu in the Edit menu, or right-click and choose from the contextual menu, or click in the toolbar and choose from the drop-down menu.

A labeled record is displayed in a distinctive color. If you are working in a draft view of the index the whole record is displayed in that color; if you are working in a fully formatted view of the index, you can control whether the text is colored...
Labeling Records

(see “Labeling Options” on page 56). You can also control whether labeled records are visible. See “Displaying Labeled Records” on page 61.

To change or remove the labels on records, select those you want to change:

- To remove all labels, choose No Label from the submenu or drop-down list.
- To remove only the label that matches the first record in the selection, choose that label from the submenu or the drop-down list.

**NOTES:** If the first record in the selection carries no label, choosing a label from the submenu will apply that label to all selected records.

When you change the label on a record, Cindex normally does not mark the record as ‘modified’ (i.e., it does not update the record’s user identifier and date stamp). If you prefer to have the record marked as modified, choose Preferences… from the Edit menu, click the Editing tab, then click Label Sets Change Flag.

To label or unlabel the record in the record-editing window, choose from the Labeled submenu in the Edit menu, or from the contextual menu, or from the toolbar drop-down list.

**Labeling Options**

To change the colors Cindex uses to labeled records, choose Preferences… from the Edit menu, click the View tab, then under Label Colors double-click the colored cell for the label you want to change. Cindex will display a panel through which you can set the color.

Cindex normally applies the label color to records only when displaying index entries in a draft view (for information about different views of the index, see “Views” on page 59). To make Cindex use the label color in the fully formatted view, choose Preferences… from the Edit menu, click the View tab, then under Label Colors click Display in Formatted View.

In the formatted view the label color is applied only to the page references or cross-references from a record (or the lowest-level subheading if there are no page references or cross-references).
Labeling Records

When you print index entries, whether or not labeled records appear distinctive depends on the capabilities of your printer.
Labeling Records
CHAPTER 4 Viewing, Finding and Printing Entries

VIEWS

Cindex provides several ways for you to view the index as you work on it. These range from a fully formatted view that lays out the index exactly as you would see it printed in a book to an unformatted view that makes explicit the structure of the records from which the index is formed. Cindex also allows you to display and work with only parts of the index.

The title of a main document window is always the name of the index. The status bar at the bottom of the window (Figure 14) displays:

- Which records are accessible in the view.
- How many records are accessible in the view.
- How many new records have been added in your current session.
- How entries are sorted.

Fully Formatted View

To display the fully formatted index, choose Full Format from the View menu, or click in the toolbar.

In this view (Figure 14) index entries are displayed in fully finished form, in whatever index style (indented, run-in, etc.) you have specified. Cindex suppresses the display of duplicate headings, gathers together and sorts page references from the same heading, and gathers and sorts cross-references from the
Views

same heading. For full information on setting the style and layout see “Formatting the Index” on page 167.

You can switch between indented and run-in views of the index by clicking or in the toolbar. In the fully formatted view Cindex will hide deleted records and records that contain no text, and it will hide certain text in records—for example, phrases that you have inserted specially to control alphabetizing of entries.
Views

You should always use a fully formatted view when printing the finished index or saving it for typesetting, but because this view obscures the structure of individual records you will probably find that during development of the index it is less useful than a draft formatted view (Figure 16).

Displaying Labeled Records

In the fully formatted view Cindex normally displays labeled records, though they will appear in their distinctive colors only if you have enabled that (see “Labeling Options” on page 56).

**NOTE:** In the formatted view only page references or cross-references from a labeled record will be colored. If a record has no page references or cross-references, the lowest-level subheading is colored.

You can use labels to control which records Cindex will display. To hide records that carry a particular label or labels (or no label at all) choose **Hide by Attribute…** from the View menu. Cindex will show the box in Figure 15.

![Figure 15. Hiding Records by Attributes](image)

For each class of record that you want to hide, check the corresponding box, then check **Enable Hiding**. Records that are hidden are generally treated as though they did not exist: for example, you cannot find them by searching through the index.

**Draft Formatted View**

To display the draft formatted index, choose **Draft Format** from the View menu, or click ![Draft Format Icon](image) in the toolbar.
Views

In draft view Cindex displays all records, without hiding any content that it might make invisible in the fully formatted view. In draft view Cindex shows the entries in a standard indented format. Cindex permits you some control over the layout of entries (for example, margins and columns, line spacing, and placement of cross-references), but most of the more advanced style and layout options are unavailable in draft view. “Formatting the Index” on page 167 describes the format settings, and which of them apply to the draft view.

When Cindex opens the record window for you to add new records, it normally changes the display to show entries in draft view if the main window was displaying entries in a fully-formatted view. This makes it easier to see how complete entries are formed from records. If you prefer to add and edit entries with the main window showing fully formatted entries, you can prevent Cindex changing the display.

To specify how Cindex should display entries in the main view while you are adding or editing records, choose Preferences from the Edit menu. In the dialog box that Cindex displays (Figure 9 on page 29) click the Editing tab, then check or uncheck Switch to Draft View.
Views

Customizing the Draft View

You can customize the draft view in two ways:

1. **Showing Record Numbers.** As you add each record to the index, Cindex assigns it a unique number. You can use this number (although you never have to) in working with records. To see record numbers (Figure 17) check **Show Numbers** in the View menu. To hide record numbers, uncheck **Show Numbers.** The initial setting is to hide numbers. Cindex remembers your setting and uses it until you change it again.

   ![Figure 17: Draft view with record numbers displayed](image)

2. **Depth of Headings to Display.** Cindex normally displays all fields in records. You can set it to display only main headings, or only main headings and subheadings, etc. (Figure 18). To display headings to a specified depth, choose a heading level from the **View Depth** submenu in the View menu. The initial setting is to show all levels of headings. Cindex remembers your setting and uses it until you change it again.
Summary View

The summary view shows only the main headings of entries, together with cross-references made both to and from these entries. Records that are the sources of cross-references are displayed to the heading level from which the cross-references originate; records that are the targets of cross-references are displayed to the depth of heading level referred to. To display the index in summary format (Figure 19) choose Summary from the View menu.
Views

When Cindex shows the text of a cross-reference made to a heading, it displays the cross-reference in square brackets [...] appended to the heading. Each cross-reference is contained in a separate set of brackets. If the cross-reference was from a subheading, the contents of the brackets show the heading and the subheading, after a semicolon.

Customizing the Summary View

When Cindex displays records in summary view, you can show or hide record numbers, as outlined under “Customizing the Draft View” on page 63.

Unformatted View

In the unformatted view, all the fields of all records are displayed in full, with fields laid out sequentially. To display the index as unformatted entries (Figure 20) choose **Unformatted** from the View menu.
Views

CUSTOMIZING THE UNFORMATTED VIEW

When Cindex displays records in this view, you can show or hide record numbers, and can control the depth to which headings are displayed, as outlined in “Customizing the Draft View” on page 63. You can also specify whether Cindex should wrap long entries on to continuation lines, or clip them at the edge of the window. By default Cindex wraps long entries; to display clipped entries, uncheck Wrap Lines in the View menu. To wrap lines, check Wrap Lines.

SORTED AND UNSORTED VIEWS

Cindex is set initially to display entries in alphabetical order, following rules described in “Alphabetical Sorting” on page 151. You can quickly switch between an alphabetical sort and a page order sort by clicking or in the toolbar.

Cindex can also display index entries in unsorted (record number) order. This can be useful if you want to see the order in which you added records to the index. To view the index in record number order, uncheck Sorted in the View menu. To display entries in whatever order is dictated by the sort rules in effect, check Sorted in the View menu. You can also quickly switch between sorted and unsorted views by clicking in the toolbar. “Sorting Entries” on page 147 describes how to change the sort rules to suit your requirements.
SELECTING ENTRIES

Many Cindex operations are undertaken on entries that are selected (highlighted) in the main document window.

You can select any index entry by clicking it; you can extend the selection by dragging (forward or backward) through the displayed entries, or by SHIFT-clicking the entry at the other end of the range. You can also extend the selection by using the keyboard shortcuts shown in Table 2 on page 71. To clear any selection, hit ESC.

Cindex provides a shortcut for selecting blocks of entries under a heading. To select all the records under a particular main heading, move the mouse to the left margin of the screen. The pointer will change from a left-arrow to a right-arrow (Figure 21) signifying that Cindex can select blocks of records. Click beside the main heading of the set of records you want to select. Cindex will select all the records under that heading. To select all the records under a particular subheading, place the mouse to the left of the subheading, then click. You can use the same method to select blocks of records under any lower level of heading.

To select the record displayed at the top of the window, hit SHIFT TAB.
WORKING WITH SUBSETS OF RECORDS

When you open an index you have access to all its entries through the main document window. Often you will want to work with only a subset of entries, which can be more conveniently done if these are isolated. Cindex provides several ways to isolate entries for work.

New Records

To see only new records (that is, those added to the index since you began work in the current session) choose New Records from the View menu. If you have added no records in the current session, this item is dimmed.

Cindex will display (in order of entry in the index) only the new records. When you set the view to show new records, Cindex generally behaves as though these were the only records in the index. Suppose, for example, that your index contained 900 records, 100 of which were new. When the view is set to show new records, Cindex will behave as though the first 800 records do not exist, and operations such as searching the index (discussed later in this chapter), examine only new records. The status bar at the bottom of the main document window will indicate that you are viewing New Records, and that there are 100 of them. To restore the view of the complete index, choose All Records from the View menu, or click  in the toolbar.

NOTE: When viewing new records, you cannot use the tools Expand (described in “Expanding Index Entries” on page 229) Compress (described in “Compressing Index Entries” on page 230) or Reconcile Headings (described in “Reconciling Heading Levels” on page 99). These items in the Tools menu are dimmed.

Groups of Records

Cindex can form defined subsets (“groups”) of records in the index, treating each group as though it contained the only records in the index.
Working with Subsets of Records

Making a Group

You can make a group from any records in the main index window. To do this, select the records you want to work with, then choose New Group from the File menu (also available through the pop-up menu Cindex displays when you click the right mouse button). Cindex will display just this set of records in the main document window, giving it the title Temporary Group. The number of records that a group can contain is limited only by the amount of memory in your computer. To restore the view of all records, choose All Records from the View menu. To view the group choose Temporary Group from the View menu.

The temporary group survives only until you create another group, finish your current session with Cindex, or explicitly make the group permanent (see below).

NOTE: Although the group is temporary, the records in it are permanent. That is, when Cindex discards a group it discards only the information about which records belong to a group; it does not discard the records.

Working with Groups

When Cindex displays a group, it generally behaves as though the records in that group were the only ones in the index. For example, when Cindex searches for text in entries, it searches only among records in the group.

There are a few restrictions on what you can do with groups:

• You cannot switch between sorted and unsorted views of a group: Cindex displays records in the order in which they appeared when the group was formed. You can, however, change the sorted order of a group by choosing Sort… from the Tools menu to resort the group. This sort need not use the sort rules employed in the main index.

• When you modify records that belong to a group (for example, by editing a record), Cindex will display the changes but will not rearrange the order of the records in the group, which might no longer be correctly sorted. You can re-sort the group explicitly, if you wish. Records are always correctly sorted when you restore the view to show All Records.

• If you add a record to the index while you are viewing a group, the record does not become a member of the group, and Cindex therefore does not display it until you change the view to show All Records.
Finding Entries

- Some Cindex tools cannot be used on groups. You cannot use the tools Expand (described in “Expanding Index Entries” on page 229) Compress (described in “Compressing Index Entries” on page 230) or Reconcile Headings (described in “Reconciling Heading Levels” on page 99). These items in the Tools menu are dimmed when a group is displayed in the main document window.

Making a Permanent Group

You can preserve any temporary group permanently. To save the group, first make sure it is on view (if necessary, choose Temporary Group from the View menu), then choose Save Group… from the File menu. Cindex will display a dialog box through which you should provide the name you want to give the group. When you click OK, Cindex will remember the group. Cindex automatically saves information about groups that belong to the index.

Each group you save becomes an item in the Group submenu in the View menu (it is no longer accessible through the Temporary Group item in the View menu). To view a group at any time, simply select it by name from the menu. To restore the view of all records, choose All Records.

Managing Groups

Cindex provides several tools to help you manage groups. For information on these see “Managing Groups” on page 232.

FINDING ENTRIES

Cindex provides several ways for you quickly to find records you want to work on. You can display a particular entry instantly by typing the beginning text of its heading, or by entering its record number. You can search the index to find entries that contain specified text or references.
Finding Entries

Navigation Shortcuts

When the main index window is active, you can use the keys and keystroke combinations shown in Table 2 as navigation shortcuts.

TABLE 2. Navigation shortcuts in the main document window

<table>
<thead>
<tr>
<th>Key(s)</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>↓</td>
<td>Moves selection (if any) down one record or entry.</td>
</tr>
<tr>
<td>↑</td>
<td>Moves selection (if any) up one record or entry.</td>
</tr>
<tr>
<td>SHIFT ↓</td>
<td>Extends selection (if any) down one record or entry.</td>
</tr>
<tr>
<td>SHIFT ↑</td>
<td>Extends selection (if any) up one record or entry.</td>
</tr>
<tr>
<td>TAB</td>
<td>Brings selection (if any) into view.</td>
</tr>
<tr>
<td>SHIFT TAB</td>
<td>Selects record at top of window.</td>
</tr>
<tr>
<td>ESC</td>
<td>Removes highlighting from selected records.</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>Moves display down one page (does not affect selection).</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>Moves display up one page (does not affect selection).</td>
</tr>
<tr>
<td>HOME</td>
<td>Moves display to head of index (does not affect selection).</td>
</tr>
<tr>
<td>END</td>
<td>Moves display to foot of index (does not affect selection).</td>
</tr>
<tr>
<td>RETURN</td>
<td>Opens the selected record for editing.</td>
</tr>
<tr>
<td>Other characters</td>
<td>Treated as the leading text in a record (or a record number, if digits). Cindex brings the matching record into view. Text you type appears in the status bar at the foot of the index window.</td>
</tr>
</tbody>
</table>

Finding by Beginning Text in Headings

When the main index window is active, you can instantly bring into view and highlight any record by typing the character (or characters) that begin its heading. Cindex tracks the characters you type, and as you define more precisely the beginning text of the heading, it will narrow the range of displayed records. You need type only as much of the heading as you need to identify it unambiguously. Cindex displays the text you type in the right-most panel of the status bar at the bottom of the window (Figure 14 on page 60). If you type text that matches no heading, Cindex will beep.
CHAPTER 4 Viewing, Finding and Printing Entries

Finding Entries

To locate a subheading under a heading, type enough of the heading to locate it, then type a semicolon, then the leading text of the subheading. For example, to find the subheading ‘international’ under the heading ‘Trade’ you might type

\texttt{tr;in}

if that were enough to identify the heading and subheading unambiguously.

\textbf{NOTE}: If the heading of the record you want begins with a numeral, you should type the character \texttt{\} immediately before you start typing the beginning of the heading. If you do not use \texttt{\} Cindex will assume you are looking for a record by its number.

Cindex knows that successively typed characters are part of the same heading as long as you type them at reasonable speed; if a long interval separates keystrokes, Cindex assumes you are starting to specify a new heading. The interval Cindex attends to is determined by standard Windows keyboard settings.

If you need to enter a long sequence of characters to specify the target heading and any subheadings, choose Go To… from the View menu. Cindex will display the panel in Figure 22. This allows you to enter text at your leisure.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{figure22.png}
\caption{Go To a specified entry}
\end{figure}

Type as much leading text as you need from the heading and any subheadings, separating levels of heading with a semicolon, click Record to tell Cindex that you are searching for a record, then click OK.
Finding Entries

Cindex remembers up to 16 of your previous Go To… search requests. To recall and reuse a previous search specification, click the arrow beside the text box to display and select the specification you want.

Finding by Record Number

When the main document window is active, you can bring a record into view by typing its number. Cindex will track the digits as you type them, and will highlight the record whose number matches what you type.

If you prefer, you can specify the record number by choosing Go To… from the View menu (Figure 22). Type the record number, click Record to tell Cindex that you are searching for a record, then click OK.

Finding by Formatted Page Number

To bring into view the entries that will appear on a particular page of the formatted index, choose Go To… from the View menu. Cindex will display the panel shown in Figure 22. Click Formatted Page to indicate that you want to see entries that fall on a particular page, then click OK. Cindex will display entries from the first that would appear on that page.

To find records that contain references to specified pages in the work being indexed, see “Searching for Locators” on page 78.

Finding Records that Contain Specified Text

Cindex can find records that contain particular words or phrases anywhere within the record. To search for a word or phrase, choose Find… from the Edit menu, or click in the toolbar. Cindex will display the window shown in Figure 23.
Finding Entries

To make a simple search for a word or phrase, type the word or phrase where the indicator is blinking. Click **Find** (or hit RETURN) to begin the search for the first occurrence of the word or phrase.

**NOTE:** Cindex generally dims the **Find** button unless you have specified some text to search for.

When Cindex finds the first record that contains the target word or phrase, it displays that record in the main document window. If you are working with a draft view of the index, Cindex highlights the target word or phrase; if you are working with a fully formatted view, Cindex highlights the whole entry that contains the target word or phrase.

To continue the search after Cindex has found a target, click **Find Again**, or choose **Find Again** from the Edit menu. Cindex will find the next record that contains the target text.

To work on the highlighted record, click the main document window to activate it, then double-click the record to open it for editing.

To resume the search after interrupting it, click the Find window, then click **Find Again** to continue.
To cancel a search, and restore Find settings to their default values, click **Reset**.

To close the Find window, hit ESC, or click the close button in the title bar.

You need not keep the Find window open after you have specified what you want Cindex to search for. To find the next record that matches a search specification you have previously provided, choose **Find Again** from the Edit menu. When Cindex finds a record it will highlight it (or the relevant part of it). To open any highlighted record for editing, double-click it, or hit RETURN.

**NOTE**: Cindex maintains a list of the words and phrases used in previous searches. To search for a word or phrase you have sought in the recent past, click the arrow button at the right-hand edge of the box that contains the search text, then choose from the list displayed.

To find all records that contain the text you want click **Find All**. When you do this Cindex examines all the records that could be displayed in the current view and collects in a group all those that contain matching text. When it has completed the search, Cindex displays these records in the main window as a temporary group.

To switch the view to show all records, choose **All Records** from the View menu, or click the button in the toolbar. To switch the view back to the records found in the last search, choose **Temporary Group** from the View menu. You can switch the view to this group at any time until you form another group, or save the group as a permanent group. (“Making a Permanent Group” on page 70 explains how to make a group permanent.)

When you make a permanent group from the results of a search, Cindex saves with the group information about the search criteria used to find the records that belong to the group. As you add or modify records, some might become eligible for inclusion in the group, or some already in the group might no longer meet the criteria for inclusion. To cope with such situations, you can rebuild the group by applying the original search criteria to the modified index. For information on this see “Managing Groups” on page 232.
Finding Entries

Searching for Styles and Fonts

To search for text formatted in a particular style or font, or text that does not contain a specified style or font, click Attributes… Cindex will display a dialog box through which you can specify the attributes of the text you are looking for. Click OK to set the style(s) or font. To indicate that it will search for styled text, Cindex displays the appropriate letter (B for boldface, etc.) to the right of the Attributes… button. If Cindex will search for a font, it displays § beside the button.

Cindex can search for style and font attributes applied to, or absent from, any text. To find any text set in a particular style or font, or any text that is not set in a particular style or font, set Attributes… to specify the style and font you want, but do not specify any search text. Then click OK.

Controlling the Scope of the Search

Normally Cindex searches among all records that are accessible in the current view. Cindex can confine the search to certain parts of the index, or to records modified at specified times or by a particular user.

- To search among all records click All Records in View.
- To confine the search to records you have selected, click Selected Records (this is dimmed if no records are selected).
- To confine the search to a range of records in the view, specify the starting and ending records in From and to. You can specify a range of headings by entering leading text, e.g., Abr through Doc. You can also specify a range of record numbers (e.g., 55 through 79) within which Cindex should confine the search. To search among specified headings, you need only provide as much of the beginning text as will identify a record uniquely. Your specification can include leading text from a subheading: append a semicolon to the heading text then add subheading text (see the example under “Navigation Shortcuts” on page 71). To specify a heading that begins with digits, place a \ before the first digit; Cindex will otherwise interpret leading digits as a record number.

If you omit the first part of the range Cindex will search from the head of the index until it finds a record that matches the end of the range. If you omit the second part of the range, Cindex will search from the starting record until it reaches the foot of the index.

NOTE: When Cindex searches among a range of records, it proceeds in whatever order the records are displayed on the screen. Before beginning the search it checks that the
Finding Entries

last-specified record appears after the first. If the last record appears before the first, Cindex will display a warning message.

- To search among records last modified on or after a specified start date and before a specified end date, enter the dates in the boxes labeled From and to. Cindex interprets dates and times in the form appropriate to the country you are working in (e.g., month, day, year or day, month, year) and can accept dates and times in a wide variety of forms (e.g., Jan. 1 96, 1/1/96, 1 January 96, January 1 1996, today, 3:30 pm). If you omit the year Cindex assumes the current year; if you omit the month, Cindex assumes the current month; if you omit the day (providing only a time), Cindex assumes today. If you omit a starting date, Cindex assumes January 1, 1970; if you omit an ending date, Cindex assumes a date far in the future.

   NOTE: If you enter a date or time in a form that Cindex does not understand, it will beep, and highlight the date field.

- To search among records made or edited by a particular user, enter the user’s identifying initials in the User ID box.

   NOTE: When you specify a range of records, or dates, or the User ID, and you do not specify text that Cindex should find, Cindex will find any record that meets your search criteria.

Using Record Attributes

You can confine the search to records that possess specified attributes or lack specified attributes. In the Only Among box, click Records that are to confine the search to records that carry all the attributes you will check; click Records that are not to confine the search to records that carry none of the attributes you will check.

- To include or exclude new records (those created during your current session with Cindex) check New Records.

- To include or exclude records you have changed in the current session with Cindex, check Modified Records.

- To include or exclude deleted records (those that will not appear in the fully formatted index), check Deleted Records. For more information on deleted records see “Deleting and Restoring Records” on page 54.

- To include or exclude marked records (those on which Cindex was unable to undertake some global editing operation you had specified, or which Cindex has repaired), check Marked Records. For more information on marked records, see “Marked Records” on page 88.
Finding Entries

- To include or exclude records that Cindex has created automatically, check **Generated Records**. For more information on generated records, see “Converting Cross-References to Fully-Qualified Entries” on page 114 and “Generating Cross-References Automatically” on page 115.

- To include or exclude labeled records, check **Labeled Records**. Use the drop-down list to specify a particular label, or any label. For more information on labeled records, see “Labeling Records” on page 55.

**NOTES:** When you are working with a fully formatted index, Cindex ignores deleted records and records that you have designated as hidden (see “Displaying Labeled Records” on page 61).

You need not specify target text (although you can) when deploying attributes (New, Modified, etc.) in a search. If you do not specify target text, Cindex finds any record that has all (or none) of the attributes you checked.

**Searching within Specified Headings**

Cindex normally looks for the target text in all fields of a record. To confine the search to a specified field or fields use the drop-down list at the bottom left of the window.

- To search among all fields choose **All Fields**.
- To search among all text fields (excluding the locator field) choose **All Text**.
- To search only within the lowest-level text field, choose **Last Text**.
- To search only within a specified text field (main heading, subheading, etc.) choose the field by name from the lower part of the list. You need not specify target text (although you can) when you confine the search to any single subheading field. If you do not specify target text, Cindex finds records in which that field contains no text. (You must always specify target text when you choose the main heading field, or **All Fields**, or **All Text**).

**Searching for Locators**

To confine the search to the locator field choose **Page** from the drop-down list at the bottom left of the window (this item—always the one immediately after **Last Text**—will have a different name if you have assigned a name to your locator field).

When you confine a search to the locator field, Cindex normally treats the text to be matched as a locator specification, rather than plain text (the item **Evaluate References** is automatically checked). For example, if your search text is 57-66,
Finding Entries

Cindex will find any record that refers to a page within the range 57-66, rather than looking for the character sequence “57-66.” Cindex makes intelligent decisions about references. For example, if you ask it to find records that refer to any page in the range 22–35, it will also find a record in which the locator field contains a sequence such as 20–40. When you specify a range of pages, the second should be greater than the first. Cindex will warn you if you enter a badly-formed range.

Cindex can evaluate and search for complex locators (for example 1996: May 393) or ranges of them. “Evaluating and Sorting Page References” on page 130 provides more information on how Cindex evaluates these.

To find records that contain no page references, or contain badly-formed ranges of references, provide no page reference (leave the text field empty).

NOTE: Cindex understands that it should search for locators that fall within a range when it sees two locators separated by a hyphen, for example: 57-66. You may use another character as a connector that denotes an inclusive range, but only if you have told Cindex what this character is. “Specifying the Structure of Page References” on page 126 explains how to change the standard connecting character.

To prevent Cindex evaluating locators (and make it treat your search characters as plain text) when searching in the locator field, uncheck Evaluate References.

Additional Options

Cindex normally accepts a match to the target text regardless of whether or not it forms a whole word or part of a word. To make Cindex accept matches to whole words only, check Whole Word. For this purpose a whole word is a continuous sequence of letters and digits. If your search text contains punctuation or spaces, the check box is dimmed.

Cindex normally ignores the case of letters when finding a match to the target text. To require matches of the same case, check Case.

In addition to searching for words or phrases, Cindex can look for more complicated sequences of characters that match a pattern, such as “any three digit number,” or “any occurrence of the word ‘and’ at the beginning of a line.” See “Patterns” on page 239 for a description of patterns and how to use them. To
Finding Entries

make Cindex treat the search target as a pattern rather than literal text, check Pattern. When Cindex searches for text that matches a pattern it dims the search options to evaluate locators, and to find whole words.

Cindex normally begins a search at the head of the index and progresses forward. To search backwards from the end, click Up; to search forward, click Down.

Conditional Searches

Cindex lets you look for combinations of words or phrases, e.g., the occurrence of the word “university” and the word “finance” in the same record; it can also find an occurrence of a particular word or phrase without some other word or phrase, e.g., a reference to “Warsaw Pact” and no reference to “Soviet Union.”

The first step in finding such records is to form a simple statement of the conditions, e.g., Find university and finance, or Find Warsaw Pact and not Soviet Union, or Find cars or automobiles. When you do this it becomes clear that to make a conditional search you need to be able to represent the entities and, or and not. Cindex provides these entities (known as conditional or Boolean operators) for you to use in specifying conditions that a record must meet before it can be displayed.

To find records that do not contain the text or the specified text attributes, check Not (positioned immediately before the box where you specify the search text). For example, to find records that did not contain the word ‘See’, you would set up the search as shown in Figure 24.

**FIGURE 24. Finding records that lack specified text**

To find records that contain the specified text and/or some other text, select and or or from the drop-down list to the far right of the text. Cindex will extend the
Finding Entries

window so that you can specify a second word or phrase to search for (and other attributes to be associated with it, such as a style or a whole word, etc.) By choosing and or or you can extend the window repeatedly for up to four search sequences. For example, to find any record that contained Smith or Smythe or Schmitt, you would provide three search phrases, connecting the first to the second with or and the second to the third with or, as shown in Figure 25.

To find any record that contained theater and not New York, you would enter the search phrases as shown in Figure 26.

For each component of a conditional search you can specify the field (if any) to which Cindex should confine the search, whether or not Cindex should seek a whole word, whether or not the search is to be case-sensitive, and whether or not the search sequence specifies a pattern.
Finding Entries

Grouping elements of a Search

A search expression that contains several components might be interpreted in a number of ways. For example, a search for

\[
\text{NATO and not Warsaw Pact or China or Japan}
\]

could mean “find a record that refers to Nato and not to the Warsaw pact, or a record that refers to China or a record that refers to Japan,” or it could mean “find a record that refers to Nato and does not refer to the Warsaw Pact or to China or to Japan.”

Cindex interprets the expression in the first way, as a result of following these simple rules: \text{not} applies only to the component immediately following, because it takes precedence over the other operators. Cindex then groups the components connected by \text{and} because \text{and} has a higher precedence than \text{or}. If we could use parentheses to indicate how Cindex groups the components for evaluation, we would write the previous search sequence as

\[
(\text{NATO and (not Warsaw Pact)}) \text{ or China or Japan}
\]

Bear these issues in mind if you need to construct a complex search sequence. For example, to look for records that contained NATO and bombs or missiles, where you intended

\[
\text{NATO and (bombs or missiles)}
\]

you would specify a search for

\[
\text{NATO and bombs or NATO and missiles}
\]
Evaluation Order

Cindex evaluates search components from first to last, and stops evaluation as soon as a test is conclusive. Thus, were you searching for

Smith or Smythe or Schmitt

and a record contained ‘Smith’, Cindex would not look for ‘Smythe’ or ‘Schmitt’.

Were you searching for

theater and not new york

and a record did not contain ‘theater,’ Cindex would not look for ‘new york’.

PRINTING ENTRIES

Before you print the index you should ensure that you have selected a printer, and that you have specified the page setup you prefer.

Page Setup

To specify how Cindex should print documents, choose Page Setup from the File menu. Cindex will display a dialog box through which you can set the paper size, page orientation, and margins (You can also set margins, with additional flexibility, by choosing Margins & Columns… from the Document menu). The available page setup options are explained in the documents provided with your printer or with Windows.

Printing

Cindex prints entries as you see them on the screen. If you are viewing a fully formatted index, the printed pages contain fully formatted entries; if you are viewing a draft format, the entries are printed in draft format. The index style and the layout of entries on the screen or page are determined by settings you make.
Printing Entries

through choices from the Document menu. These are described fully in Chapter 10 "Formatting the Index" on page 167. When Cindex is installed it takes standard settings that will be suitable for many purposes.

To print entries, choose Print from the File menu. Cindex will display the standard Print dialog box. Except for the options noted below, all the settings you can make are determined by the software the controls your printer, not by Cindex, and are explained in the documents provided with your printer or with Windows.

You can specify which entries should be printed from among those available in the current view of the index. Choose from among the options available in the Print range box.

- To print all the entries click All in View.
- To print a range of pages click Page, and enter the starting page number at from. To stop printing at a particular page, enter the page number at to. If you provide a starting page number but no ending number, Cindex will print all pages from the starting page through the end of the index. If you provide an ending page number but no starting one, Cindex will print all pages from the first through the ending number.
- To print selected entries, click Selection (this item is dimmed if no entries are selected).
- To print a range of entries, click Records. Specify the starting entry at from and the ending entry at to. You may specify the entries by the leading text from their headings (for example, Gov through Man), or by their record numbers. If you need to print a range of subentries under a single heading, you can specify these by entering enough of the heading to specify it uniquely, then entering a semicolon, followed immediately by the beginning text of the subheading at which you want to start (or stop) printing. If you specify a starting entry but no ending one, Cindex will print entries from the starting one through the end of the index. If you specify an ending entry but no starting one, Cindex will print entries from the beginning of the index through the ending entry. To specify a heading that begins with a number, place a \ (backslash) immediately before the first digit, otherwise Cindex will interpret the number as a record number. Because the \ has this special function, to specify any entry whose heading begins with \ you must place a \ before it (i.e., the specification must begin with \\).
Cindex provides several powerful capabilities that gather and execute sequences of commands (macros), search for and replace text in records, adjust page references automatically (for example when pagination is changed after an index has been prepared), and consolidate or separate multiple references to the same heading. Cindex can also reconcile headings so that the index contains no unnecessary levels of heading.

MACROS

Macros provide a way to encapsulate a long or complex series of operations in a single command. Cindex can create a macro by recording a sequence of keystrokes that complete some operation on an index. You can then invoke this recorded sequence at any time by choosing the command to replay the macro.

A macro is most useful when you want to undertake the same sequence of steps repeatedly, perhaps on several index records. For example, you might want to set the subheading in italics in a series of records. This involves opening each record, selecting the text in the subheading, choosing Italic from the Character menu, then saving changes and moving to the next record. By defining a macro that records the steps you undertake to make changes to the first record, you can make changes to all subsequent records by choosing a single command.

You can record or replay a macro whenever a main index window or a record-entry window is active.
Using Macros

To start recording keystroke events, choose **Record Events** from the Tools menu, then from the submenu choose the macro (1 to 10) you want to record. Until you stop recording, Cindex will remember every keystroke. While Cindex is recording a macro, it displays “Recording” blinking in the status window.

To stop recording, hit CONTROL BREAK (the break key is next to the keyboard status lights). Cindex remembers any recorded macro until you record a new one with the same number. Cindex can remember up to 10 different macros at any one time.

To define a macro to set a series of subheadings in italics, you would do the following:

1. Open the first record for editing.
2. Start recording the macro.
3. Hit ↓ to move to the subheading field.
4. Hit SHIFT END to select all text in the field.
5. Hit CONTROL I or click ✂ or choose **Italic** from the Character menu.
6. Hit SHIFT PAGE DOWN or click ✏️ to save changes and advance to the next record.
7. Hit CONTROL BREAK to stop recording the macro.

Having defined the macro, you can execute it on any open record.

To execute a recorded macro, choose **Play Events** from the Tools menu, then from the submenu choose the macro you want to execute. Cindex will deliver the series of keystrokes you had previously recorded. While Cindex is playing a macro, it displays “Playing” blinking in the status window.

**NOTE:** Your use of macros is not confined to the record-entry window; you can record and use a macro when a main index window is active.
Searching for and Replacing Text

SEARCHING FOR AND REPLACING TEXT

To search for and replace text anywhere in the index, choose **Replace**… from the Edit menu, or click . Cindex will display the window shown in Figure 27. Through this you specify the text to be sought and the text to replace it.

**NOTE:** Although you can use **Replace** to make global changes to page references, Cindex provides a more flexible tool specially designed for adjusting page references. See the section “Adjusting References” on page 92.

To make a simple replacement of a word or phrase, type that word or phrase where the indicator is blinking in the **Find** field, and the text to replace it in the **Change to** field. Click **Find** (or hit RETURN) to begin the search.

![Replace window](image)

**FIGURE 27.** Replace window

Cindex looks for matching text that falls entirely within a single field of a record; it will not find a phrase that straddles two or more fields of a record. When Cindex finds the first record that contains the target word or phrase, it displays the record in the main index window, and highlights the target text (in draft view) or the whole entry (in fully formatted view). Click **Replace** to replace it, or **Find Again** to move to the next instance.
To resume the search after interrupting it, click the Replace window, then click Resume to continue.

To stop a search, and restore Replace settings to their default values, click Reset.

NOTE: Cindex maintains a list of the words and phrases used in recent searches. To search for a word or phrase you have sought in the recent past, click the arrow button at the right-hand edge of the Find box, then choose from the list displayed.

To replace all instances of matching text click Replace All. When you choose to replace all occurrences, Cindex continues its search from the current record and replaces all further occurrences of the matching text. It does not replace text in records you have already passed over.

NOTES: When using Replace All take care not to make unintended replacements. A common error is the substitution of embedded words. For example, if you changed all occurrences of “disc” to “disk,” you could produce words such as “diskussion” or “diskard.” You can avoid this hazard by checking Whole Word.

You cannot undo replacements, but you can restore the index to its last-saved form by choosing Revert to Saved from the File menu. See “Preserving and Discarding Changes” on page 12.

To remove specified text from records, leave the Change to field blank. If you delete text that occupies a complete field in a record, Cindex will remove the empty field from the record (providing the record will still contain at least the required minimum number of fields).

To close the Replace window, hit ESC, or click the close button in the title bar.

Marked Records

If the replacement of one word or phrase by another would cause a record to exceed the space allowed for it, Cindex will not make the change. When this happens, Cindex puts a special internal mark on the record, and after it has completed its scan of the index, displays a warning message. When you view records in draft view, Cindex displays # beside any record that has been marked. The mark has no function other than to indicate that Cindex could not complete some operation on the record. The mark is never displayed when you view or print a fully formatted index. The record remains marked until subsequently
Searching for and Replacing Text

modified. You can search the index with **Find** (Edit menu) to find records that have been marked.

**NOTE**: A record will also be marked if Cindex ever has to repair it (see “Checking Index Integrity” on page 12).

To manually remove the mark on a record or records, select them in the main index window, then right-click on the selection, and choose **Remove Mark** from the contextual menu.

Finding and Replacing Styles and Fonts

To search for text formatted in a particular style or font, or for text lacking a particular style or font, click **Attributes…** (next to the **Find** text). Cindex will display a dialog box through which you can specify the attributes of the text you are looking for. Click **OK** to set the style(s) or font. To indicate that it will search for styled text, Cindex displays the appropriate letter (B for boldface, etc.) to the right of the **Attributes…** button. If Cindex will search for a font, it displays § beside the button.

To change attributes, click **Attributes…**, next to the **Change to** text. Cindex will display a dialog box through which you can specify changes you want to make.

- To leave a style unchanged (either present or absent) click the appropriate button under **Ignore**.
- To add a style click the appropriate button under **Apply**.
- To remove a style click the appropriate button under **Remove**. (Buttons in this column are enabled only for styles for which you are searching.)
- To leave the font unchanged, click **Ignore** in the **Font** box.
- To change the font click the button beside the drop-down font list. Choose `<Default>` to restore the font to the default, or choose a font by name to apply a particular font.

To search for and replace styles or fonts regardless of the text they are attached to do the following:

- Specify search attributes without specifying search text.
Searching for and Replacing Text

- Specify replacement attributes without specifying replacement text.

  **NOTE:** The **Find** button is dimmed if you specify neither a font change nor a style change.

Controlling the Scope of the Search

Cindex normally searches for and replaces text among all records accessible in the current view.

- To confine the search to records you have selected, click **Selected Records**.

- To confine the search to a range of records within the view, specify the starting and ending records in **From** and **To**. You can enter the beginning text of the headings that define the range (e.g., Abr and Doc) or a range of record numbers (e.g., 55 and 79). To confine the range to some subheadings under a heading, enter in each box as much text from the heading as you need to specify it uniquely, then type a semicolon followed immediately by the leading text of the relevant subheading. If you are specifying a heading that begins with a numeral, place a \ (backslash) immediately before the number. Otherwise, Cindex will interpret leading numerals as a record number. Because the \ has this special function in a record specification, to find any record that begins with this character you must place a \ before it; that is, \ must appear at the beginning of the specification. If you omit the first part of the range Cindex will search from the head of the index until it finds a record that matches the end of the range. If you omit the second part of the range, Cindex will search from the starting record until it reaches the foot of the index.

- To search among records last modified on or after a specified start date and before a specified end date, enter the dates in the boxes labeled **From** and **To**. Cindex interprets dates and times in the form appropriate to the country you are working in (e.g., month, day, year or day, month, year) and can accept dates and times in a wide variety of forms (e.g., Jan. 1 96, 1/1/96, 1 January 96, January 1 1996, today, 3:30pm). If you omit the year Cindex assumes the current year; if you omit the month, Cindex assumes the current month; if you omit the day (providing only a time), Cindex assumes today. If you leave the starting date blank, Cindex assumes January 1, 1970; if you omit an ending date, Cindex assumes a date far in the future.
Searching and Replacing among Records with Particular Attributes

You can confine the search to records that possess specified attributes or lack specified attributes. In the **Only Among** box, click **Records that are** to confine the search to records that carry **all** the attributes you will check; click **Records that are not** to confine the search to records that carry **none of** the attributes you will check.

- To include or exclude new records (those created during your current session with Cindex) check **New Records**.
- To include or exclude records you have changed in the current session with Cindex, check **Modified Records**.
- To include or exclude deleted records (those that will not appear in the fully formatted index), check **Deleted Records**. For more information on deleted records see “Deleting and Restoring Records” on page 54.
- To include or exclude marked records (those on which Cindex was unable to undertake some global editing operation you had specified, usually because there was too little room in the record), check **Marked Records**. For more information on marked records, see “Marked Records” on page 88.
- To include or exclude records that contain automatically-generated cross-references, check **Generated Records**. For more information on generated records, see “Generating Cross-References Automatically” on page 115.
- To include or exclude labeled records, check **Labeled Records**. Use the drop-down list to specify a particular label, or any label. For more information on labeled records, see “Labeling Records” on page 55.

**NOTE**: When you are working with a fully formatted view, Cindex ignores deleted records and records that you have designated as hidden (see “Displaying Labeled Records” on page 61).

Searching and Replacing in Particular Fields

Cindex normally looks for the target text in all fields of a record. To confine the search to a specified field or fields choose from the **Field** drop-down list under the **Find** field.

- To search among all fields choose **All Fields**.
Adjusting References

- To search among all text fields (excluding the locator field) choose *All Text*.
- To search within the lowest-level text field, choose *Last Text*.
- To search only within a specified text field (main heading, subheading, etc.) choose the field by name from the lower part of the list.
- To confine the search to the locator field choose *Page* (this item—always the one immediately after *Last Text*—will have a different name if you have assigned a name to your locator field).

Additional Options

Cindex normally finds and replaces the specified text regardless of whether it matches a whole word or part of a word. To make Cindex accept matches to whole words only, check **Whole Word**.

When Cindex searches for text to replace, it normally requires a case-sensitive match. To make Cindex ignore letter case, uncheck **Case**.

Cindex can search for and replace text that matches a pattern (sometimes known as a regular expression). “Patterns” on page 239 describes the syntax of patterns, and how to exploit them in making complex replacements. To make Cindex treat the search target as a pattern rather than literal text, check **Pattern**.

ADJUSTING REFERENCES

Indexes often are prepared when final pagination is uncertain, requiring you to change page references when the correct numbers become known. Page numbers might also need revision if a previously indexed volume is split into parts, or several separate volumes are combined into a single one. Cindex provides special tools for adjusting page references. These tools allow you to add offsets to page numbers or subtract offsets from them. For example, you can add 2 to every reference to pages between 550 and 634.

To make adjustments to page numbers, choose **Alter References...** from the Tools menu. Cindex will display the dialog box shown in Figure 28.
NOTE: Before using any of the procedures described in this section you should ensure that Cindex knows what character you use to denote an inclusive range of references, and what character you use to separate successive references when more than one appears in a page field. “Specifying the Structure of Page References” on page 126 explains how to specify these.

Adding an Offset to All Page Numbers

To add an offset to all page references given in Arabic numerals, in all records accessible in the current view:

1. Under **Scope** click **All References**.
2. Under **Action** click **Adjust Only**.
3. Enter in **Adjustment** the number you want to add to (or subtract from) every page reference in the index.
4. Click **OK** to adjust all page references.

Cindex ignores references in Roman numerals, cross-references, and any references that contain no Arabic numerals (e.g., Frontispiece, or February). Cindex adjusts references in all records that are accessible in the current view, coping properly with ranges such as 78-82. If you are viewing all records, Cindex will act on all records; if you are viewing a group of records, it will act only on records in the group.
Adjusting References

NOTES: You cannot undo adjustments to references, but you can restore the index to its last-saved form by choosing Revert to Saved from the File menu. See “Preserving and Discarding Changes” on page 12.

An adjustment to page references may require Cindex to add characters to a record. If there is insufficient space for the alteration, no adjustment is made and Cindex marks the record. If Cindex has marked any records it will display a warning message after it has completed the adjustments. If a record is marked, a # appears beside it when it is displayed in draft view. You can find marked records with Find (Edit menu). Cindex removes the mark when you edit the record.

Adjusting Parts of Compound Locators

If your locators are compound references, (e.g., 23:14:2 or 34[2]:25–27), Cindex will normally adjust only the first component. To make adjustments to other parts of compound references, you can provide a pattern to specify leading parts of references that Cindex should skip to find the single element it should adjust. “Using Patterns when Altering References” on page 255 explains how to use patterns to specify which element of compound references Cindex should adjust.

Adding an Offset to a Range of Page Numbers

Sometimes you will need to adjust page references to a restricted set of pages. To add an offset to references falling within a specified range:

1. Under Scope click Range, and enter the lowest and highest page numbers that should be adjusted. Be sure to enter the numbers as they exist before adjustment. If you specify only an upper limit Cindex assumes the lower limit to be 1. If you specify only a lower limit, Cindex assumes the upper limit to be all higher references.

2. Under Action click Adjust Only.

3. Specify in Adjustment the offset to be added to (or subtracted from) every reference that falls within the range.

4. Click OK to adjust references that fall within the required range.

References needing adjustment may be intermixed in a record with others that do not need adjustment; Cindex disregards references that fall outside the range you have specified.
Removing References to Page Numbers

To remove references to a range of pages from an index (you might need to do this when a chapter is removed from a book after you have prepared the index):

1. Under **Scope** click **Range**, and enter the lowest and highest page numbers that should be removed. You must specify at least one limit (high or low) of the range of references to be removed. If you specify only an upper limit Cindex assumes the lower limit to be 1. If you specify only a lower limit, Cindex assumes the upper limit to be all higher references.

2. Under **Action** click **Remove References**. When Cindex removes page references, it normally adjusts all references to higher-numbered pages. You can inhibit this adjustment (if you want to leave room for new material), by checking **Hold Higher Values**.

3. If you want to add an additional offset to (or subtract one from) the automatic adjustment of references to higher numbered pages, specify it in **Adjustment**.

4. Click **OK** to remove all the required references.

Cindex removes only references in Arabic numerals. It copes intelligently with references that specify a range of page numbers (e.g., 45–60). If either the high or the low limit falls within the range defined by such a reference, it is adjusted appropriately.

Adjusting References after Movement of Chapters or Sections

All too often chapters or sections of a book are moved to different places after the text has been indexed. As long as you know the old and new page numbers, Cindex can correct all the entries automatically. By forming a group for the records that are associated with each chapter or section that needs to be moved, you can quickly and easily adjust the entries in the index.

Suppose that a book of 550 pages contains a chapter beginning on page 325 and ending on page 337 (thirteen pages). After you have indexed the book, the publisher moves the chapter to start at page 430 and end at page 442. You have to add 105 to all references to pages in the chapter being moved, and you have to
Adjusting References

subtract 13 from all references to pages in the block that is displaced. In planning the alterations it helps to visualize the layout in blocks of pages, like this:

<table>
<thead>
<tr>
<th>Initial positions:</th>
<th>1–324</th>
<th>325–337</th>
<th>338–442</th>
<th>443–550</th>
</tr>
</thead>
<tbody>
<tr>
<td>Final positions:</td>
<td>1–324</td>
<td>325–429</td>
<td>430–442</td>
<td>443–550</td>
</tr>
</tbody>
</table>

To make the adjustments, follow these steps:

1. Ensure that each record contains only a single page reference (or that all references in any one record refer to the same chapter or section). To ensure that each record contains only a single locator, choose Expand from the Tools menu (see “Expanding Index Entries” on page 229). Cindex will create as many new records as it needs to accommodate a single reference in each one.

2. Ensure that the view is set to show all records. If necessary choose All Records from the View menu.

3. Form a group of records that refer to the each block of pages to be changed:
   Use Find (Edit menu) to find records that contain references to the pages in the required range (for the first group this would be 325-337).

Enter the range of page numbers as the text to be found, being careful to separate the range with a hyphen (see figure).

Choose the locator field from the Field drop-down list to confine the search to the page references, and be sure to check Evaluate References (see figure).

Click Find All. Cindex will make a temporary group that contains all the records with references in the specified range.

Choose Save Group from the Edit menu and save the group with an appropriate name.

4. Repeat steps 2 and 3 to form a group of records for each additional block of page numbers the need adjustment (in this example, 338-342).

5. Add the appropriate offset to all references to the each block of pages:
Splitting Headings

Set the view to show the appropriate group (choose it by name from the Group submenu in the View menu).

Choose Alter References from the Tools menu.

Click Adjust Only and set Adjustment to the offset required for that group (in this example the first group would require an adjustment of 105).

Click OK to make the adjustment.

6. Repeat step 5 for each additional group that requires adjustment (in this example the second group would require an adjustment of -13).

You can use this technique even when many segments of a book have been rearranged.

SPLITTING HEADINGS

When you make an author index, you will often import several names in a single operation, e.g., by copying and pasting names from a list of references, or importing a list of references that contains names, possibly with additional text such as dates. The record heading that results then has to be edited to remove superfluous text, often requiring the generation of additional records, each for a single name. Cindex can do all this automatically for you, via Split Headings… in the Tools menu.

Cindex will scan the index looking for headings that contain specified terms (e.g., author names in the form Surname, Forenames(s)). If a heading contains multiple terms, Cindex creates a new record for each except the first. The first term on its own is left in the original record. For every term, including the first, Cindex removes extraneous text around it, leaving the term unadorned.

When you choose Split Headings… Cindex displays the following panel:
Splitting Headings

FIGURE 29. Split Headings sheet

Use the popup menu to specify the kind of terms Cindex should find. The default, *Terms Separated by Punctuation* finds phrases. If you choose this option, Cindex will find sequences of words separated by spaces, putting each sequence it finds in a separate record. A comma in a phrase will be ignored if preceded by ~.

To find and break out more complex terms, choose the type from the Identify popup menu.

- When you choose *Surname, Forename(s)* or *Forename(s) Surname*, Cindex will correctly identify complex names in a wide variety of forms, as long as they are consistently of the type chosen (Surname first or Surname last). When parsing names, Cindex automatically excludes from consideration any conjunction or preposition that is contained in the list used in making smart flips (*Smart Flip Words…* from the Document menu).

- Cindex uses patterns to identify terms. If you are comfortable using patterns you can define your own to find and extract terms that aren’t of a standard type. To provide your own pattern, choose *User-defined pattern* from the popup, and enter the pattern text in the box. Cindex checks the validity of the text you enter.

Cindex normally preserves the text style(s) associated with extracted terms. To remove any styles check *Remove Styles*.

Cindex normally ignores records that contain no terms of the kind being sought. To make Cindex mark them, check *Mark Records With No Matches*. 

98  
CHAPTER 5  Advanced Editing
For a preview (strongly recommended) of how Cindex will split entries, click **Preview Splits**. Cindex opens a window that shows the terms found in every record. Each term that would be in its own record is displayed inside brackets (the first term will be the new heading in the original record). In the preview list, Cindex also identifies records that contain no terms of the kind being sought. Click any row in the list to bring the corresponding record into view in the main index window.

**NOTE**: Before making the split, Cindex will warn you that it will change records. It is wise to save the index (and also have a backup copy) before proceeding, so that you can revert to the saved version if you dislike the results of the split.

**RECONCILING HEADING LEVELS**

When forming entries you will often create records that have more levels of headings than are necessary, and in which orphaned subheadings would be better organized as modifiers of the heading above (or perhaps removed). Conversely, you might create several records, each of which has a different modifier following the same heading, but which would be better arranged as a series of subheadings under a single main heading. Cindex can reconcile headings automatically by making conversions of either kind.

**NOTE**: If you simply want to identify orphaned subheadings, without converting them or removing them, the **Check Index…** command (Tools menu) will provide a list. See “Orphaned Subheadings” on page 225.

To reconcile headings, choose **Reconcile Headings…** from the Tools menu. Cindex will display the dialog box shown in Figure 30.
Reconciling Heading Levels

Choose from the **Check Headings Below** drop-down list the level below which you want Cindex to examine subheadings. For example, to seek orphans or redundant subheadings only at the sub-subheading level or below, choose the name of the subheading field.

When Cindex reconciles headings it first scans the whole index looking for modified headings (i.e., those in which the heading is followed by some qualifying phrase that might otherwise be a subheading). Cindex normally assumes that text appearing in the heading after a comma (and not part of some larger segment of text in quotation marks or parentheses) is a modifier; you can specify another character if you use a different one to introduce modifiers. Wherever Cindex finds a modified heading, it breaks that provisionally into a heading and subheading (it will also apply the same procedure to subheadings and sub-subheadings). You can inhibit this step if you wish.

Cindex then re-scans the index, converting any redundant subheading to a modifier of the heading at the level above. The result is an index in which no modified headings exist that should be heading and subheading, and in which no levels of subheading are redundant.

Before you click **OK**, review the following options.

**Options**

If your headings contain some character other than a comma to introduce a modifying phrase (for example, a semicolon), set the appropriate character at **Modifying Phrases Follow**. You should enter only a single character.
Reconciling Heading Levels

If you want Cindex merely to convert redundant levels of subheading to modified headings (without previously examining and possibly breaking any modified headings that currently exist) check **Preserve Modified Headings**.

If your index contains words or phrases that might follow a comma (or other introductory character you have specified with **Modifying Phrases Follow**) and which do not represent modified headings (for example, in a name index, where a forename or initials might follow a surname), you should check **Protect Names**. This prevents Cindex breaking any heading if the text that follows the introductory character begins with an uppercase letter. **Protect Names** is automatically checked if you check **Preserve Modified Headings**.

When Cindex encounters an orphaned subheading (i.e., the only subheading at a particular level) it can convert the subheading to a phrase modifying the heading above or it can remove the subheading altogether. Click **Convert Orphans to Modifying Phrases** to convert the subheading to a modifier of the heading above; click **Remove Orphans** to delete the orphaned subheading (leaving the rest of the record intact).

**NOTES**: You can reconcile headings only when you are viewing All Records and only when you are viewing them in alphabetical order.

Cindex adds characters to a record when reconciling headings. On occasion Cindex may be unable to reconcile headings in a record because the record cannot accommodate the additional characters, or would contain too many fields. If this happens Cindex will mark the record and will display a warning message.

You cannot undo changes made during reconciliation, but you can restore the index to its last-saved form by choosing **Revert to Saved** from the File menu. See “Preserving and Discarding Changes” on page 12.
Reconciling Heading Levels
CINDEX User’s Guide

CHAPTER 6  Checking Spelling

Cindex can check your index entries to find misspellings and typographical mistakes. The spell-checker is organized to cope with the special demands of checking index entries (for example, it ignores parenthetical endings to words, and it will ignore page references if you wish).

CHECKING WORDS IN ENTRIES

To check the spellings of words in entries, choose Check Spelling from the Edit menu. Cindex will display the panel shown in Figure 31.

![Spelling window](image)

**FIGURE 31.** Spelling window

Cindex is provided with one standard dictionary, for US English. Dictionaries for other dialects and languages are available via Internet download. For indexers with specialized needs, a dictionary containing medical terms is available. You
Checking Words in Entries

can also create your own dictionaries for terms that are not in any standard dictionary.

Cindex checks spelling in whatever language is shown in the Language dropdown list in the lower left part of the panel. If this is not already set to the language you want, choose the appropriate one from the list. Cindex will remember your choice for future sessions.

To begin checking the spelling of entries click Start. Cindex will examine entries from the first accessible in the current view.

To restore the spelling checker to its initial state, check Reset.

To close the window, hit ESC, or click the close button.

If Cindex finds a word it does not know, a questionably punctuated word, or a duplicated word, it will display the word in the Unknown box:

If Cindex does not know the word, or the word is badly punctuated, Cindex will try to suggest alternatives. If Cindex makes suggestions it puts the most probable word (which will be at the top of the list) in the Change To box; if Cindex can find no probable alternative spelling, it places a copy of the unknown word in the Change To box. In either case Cindex highlights the word, and you can edit it as required.

NOTE: If you prefer Cindex to offer suggestions only when you ask for them, you can disable the automatic suggestion. “Suggesting Alternative Spellings” on page 109 explains how to do this.

If the unknown word is misspelled, and Cindex has placed the correctly spelled version in the Change To box, click Change to accept the suggestion and continue.

If the correctly spelled word is somewhere in the list of suggestions, click it to place a copy in the Change To box, then click Change to change the misspelled word.
Checking Words in Entries

If Cindex has not suggested the correct word, type the correct one directly into the Change To box then click Change; Cindex will check the word you have typed. To delete a misspelled word simply remove it from the Change To box.

NOTE: You can at any time place a copy of the original (unknown) word in the Change To box: simply click the unknown word.

Unknown but Correctly Spelled Words

If Cindex objects to a word that is correctly spelled, you can ignore the single occurrence by clicking Ignore; you can ignore all future occurrences within the current session by clicking Ignore All. If you want Cindex to remember a new word permanently, click Add to add it to a personal dictionary.

Duplicate Words

If a word is duplicated, Cindex indicates this. To delete the word click Delete; to ignore the duplicated word click Ignore.

Using Personal Dictionaries

You can maintain personal dictionaries for specialized terms. When Cindex encounters a word that is not in its main language dictionary it looks for it in a personal dictionary (if you have designated one). You can keep as many personal dictionaries as you wish, but you can use only one at a time. You add words to your active personal dictionary as you encounter them while checking spelling.

To add a word to a personal dictionary click Add. Cindex will add the word to whichever dictionary is named in the Dictionary drop-down list. When Cindex is first installed it has no personal dictionaries, and the drop-down list will show <None Selected>.

If no dictionary has been selected, Cindex will ask if you want to create a new dictionary. Click OK to create a dictionary (Cindex will then ask you to provide a name for the dictionary, before adding the word to it); otherwise click Cancel. When you create a new personal dictionary, or choose one from the Dictionary drop-down list, Cindex remembers your choice.

Managing Personal Dictionaries

To examine or edit the words in a personal dictionary, click Options… Cindex will display the dialog box shown in Figure 32.
Checking Words in Entries

Choose the dictionary you want from the list under Personal Dictionary, then click Edit. Cindex will display a list of the words in the dictionary. You can add, change or delete words freely, and you can paste text from other documents. Words may be in any order, but each must be on a separate line, or be separated from the next by some space.

To create a new, empty, personal dictionary, click New. Cindex will display a box in which you can type the name of the new dictionary.

Interrupting and Resuming Spell Checking

While Cindex is checking the spelling of entries, you can interrupt it (for example to edit a record) by clicking the main index window, then double-clicking the record you want to edit.

To resume checking spelling at the point where you interrupted it, choose Check Spelling from the Edit menu (or click the Spelling window), then click Resume.

To stop checking and reset the spelling checker so that it can begin again at the head of the index, click Reset.

NOTE: If, during the course of checking entries you change the scope of the examination—for example, you change from checking all fields of records to checking only the
main headings—Cindex will reset the spelling checker so that it restarts at the beginning of the index.

CHECKING ONLY PART OF THE INDEX

Cindex normally checks the spelling of all records accessible in the current view of the index, and normally checks words in all the text fields of records. It ignores anything but cross-references in the locator field. You can confine the examination to a subset of the records in the current view, and you can control which fields of records are checked.

Specified Range of Records

To check all records accessible in the current view, click **All Records in View**.

To confine the check to records you have selected, click **Selected Records** (this is dimmed if no records are selected).

To confine the check to a range of records in the view, specify the starting and ending records in **From** and **to**. You can specify a range of headings by entering leading text, e.g., Abr through Doc. You can also specify a range of record numbers (e.g., 55 through 79) within which Cindex should confine the search. If you want to check among specified headings, you need only provide as much of the beginning text as will identify a record uniquely. You can specify leading text from a subheading by appending a semicolon to the heading text then adding subheading text. To specify a heading that begins with digits, place a \ before the first numeral; Cindex will otherwise interpret leading digits as a record number. If you omit the first part of the range Cindex will examine entries from the head of the index until it finds a record that matches the end of the range. If you omit the second part of the range, Cindex will examine entries from the starting record until it reaches the foot of the index. If you omit both ends of the range, Cindex examines all records in the current view.

**NOTE:** When Cindex examines a range of records, it proceeds in whatever order the records are displayed on the screen. Before beginning the examination it checks that the last record in the range appears after the first. If the last record appears before the first, Cindex will display a warning message.
**Spelling Options**

**Checking only Records with Particular Attributes**

You can further restrict spell-checking to records with particular attributes:

- To examine only records created during your current session with Cindex, check **New Records** (this option is dimmed if there are no new records)
- To examine only records changed in the current session with Cindex, check **Modified Records**.

**Specified Fields in Records**

Cindex normally checks all text fields of a record; in the locator field it normally examines only cross-references. To confine the search to a specified field or fields choose from the **Field** drop-down list.

- To check all fields choose **All Fields**.
- To check all text fields (excluding the locator field) choose **All Text**.
- To check only the lowest-level text fields choose **Last Text**.
- To check only within a specified text field (main heading, subheading, etc.) choose the field by name from the lower part of the list.
- To confine the check to the locator field choose **Page** (this item—always the one immediately after **Last Text**—will have a different name if you have assigned a name to your locator field). Cindex normally checks only cross-references in this field. If you want Cindex to examine the spelling of locators other than cross-references, check **Check Page References**.

**NOTE:** If you have used the **Field** drop-down list to exclude the locator field, Cindex will dim the item **Check Page References**.

**SPELLING OPTIONS**

**Languages**

To specify the language in which Cindex will check spelling, choose from the **Language** pop-up menu. If supplementary dictionaries are installed for that language, they will be displayed in the **Use Additional Dictionaries** list, visible when you click **Options**. Check any you want to use.
Spelling Options

If the language you want is not displayed, you can download a dictionary. Cindex employs open-source spell-checking technology that is used in major web browsers (Firefox, Chrome, Safari, Opera), email clients such as Thunderbird, and office suites such as OpenOffice. Dictionaries for many languages, and some dictionaries containing specialized terms, are available at no cost. The Indexing Research web site (https://www.indexres.com/resources/spelling) provides information about where to find and download publicly available dictionaries.

Installing Dictionaries

To enable Cindex to use additional dictionaries, you must install them in the correct place. The following procedures apply generally to downloaded files. Any variations for particular dictionaries are described at https://www.indexres.com/resources/spelling.

- Append the filename extension ".zip" to the name of the downloaded file, then unzip it.
- Inside the unzipped folder (or contained in a folder within it) will be a file that has the extension .dic and another (with the same name) that has the extension .aff. These files are named using a standard convention for representing languages and country variants. For example: en_US.aff and en_US.dic (US English); en_AU.aff and en_AU.dic (Australian English); nl_NL.aff and nl_NL.dic (Dutch).

  NOTE: If the dictionary is one containing specialized terms (e.g., a medical dictionary) there may be no .aff file.

- Copy or drag the .aff file and the .dic file to this folder:
  C:\Users\Public\Public Documents\Indexing Research\Cindex4.0

  NOTE: If your disk is not named C, substitute the appropriate drive letter in the instructions above.

General Options

You can control several aspects of spelling by setting options. Click Options in the Spelling window to display the dialog box shown in Figure 32.

Suggesting Alternative Spellings

Cindex can suggest alternative spellings of words it does not recognize. It can do this whenever it encounters an unknown word, or only when you request it. When Cindex is first installed it is set to suggest spellings automatically.
To make Cindex seek alternative spellings whenever it finds an unknown word, click **Always Suggest Alternatives**. To make Cindex suggest spellings only when you want them, uncheck **Always Suggest Alternatives**. Cindex will then suggest alternatives only when you click **Suggest** in the main spelling window. Cindex remembers your setting until you change it again.

**Ignoring Words in Capital Letters**

To make Cindex ignore words in capitals (often abbreviations or acronyms) check **Ignore Words in CAPITALS**. Cindex remembers your setting from session to session.

**Ignoring Alphanumeric Sequences**

To make Cindex ignore alphanumeric character sequences such as aa99 or 9b32, check **Ignore Alphanumeric Strings**; if you leave this item unchecked, Cindex will treat all such sequences as misspelled words. Cindex remembers your setting from session to session.

**Clearing Words to be Ignored**

Each time you click **Ignore All** when checking a document, Cindex adds the word to be ignored to a private list that it maintains for the duration of your current session. Cindex discards this list when you quit. If you want to clear that list without quitting, so that Cindex forgets the words you had told it to ignore, click **Clear Ignore List**.
CHAPTER 7  Cross-References

Cindex does much of the work required to manage cross-references: it will place cross-references in the position of your choice (immediately following the heading, or before or after subheadings); it will automatically format the introductory phrase (See and See also) and the body of the cross-reference in whatever style you choose; it will sort and combine multiple references to the same heading or subheading; it will check cross-references and warn you if you have made circular references or references to non-existent entries. Cindex will also tell you if you have made cross-references to headings under which there are fewer than a specified minimum number of entries. Cindex can generate cross-references automatically, so that, for example, if a particular heading appears in your index, there will always be a correctly-formed cross-reference to it.

HOW CINDEX IDENTIFIES CROSS-REFERENCES

To identify cross-references and organize them correctly, Cindex has to know not only what word will begin a cross-reference (e.g., See), but also what words might make up the remainder of the introductory phrase (e.g., also or under). Cindex normally assumes that a cross-reference can begin with see (in any mixture of upper- and lowercase letters) followed by any combination of also and under. Thus, See, See also, See under and See also under are all acceptable introductions to cross-references. If your cross-references begin with a word other than see and continue with words other than also or under, you must change the settings Cindex uses, otherwise it will be unable to check or format cross-references.
To manage cross-references properly Cindex also has to know how they are punctuated. If you place several cross-references in a single record, Cindex needs to know how to distinguish them, so that it can check them and format them properly. Cindex normally assumes that one cross-reference is separated from the next by a semicolon (;) and looks for this character when examining entries. Cindex also uses this character when it combines and sorts multiple cross-references from several records under the same heading. If Cindex does not know how to separate multiple cross-references it will not be able to check them or format them.

Regardless of where you want cross-references to appear in formatted entries, you should enter them in the locator fields of records. If you do this, Cindex will place and punctuate them correctly, and combine and sort multiple references from otherwise identical records. Cindex does not prevent you entering cross-references in other fields, but most of its capabilities for managing cross-references will not be available if you do.

**Specify the Structure of Cross-References**

To specify the structure of a cross-reference, choose *Reference Syntax...* from the Document menu. Cindex will display the box shown in Figure 33.
How Cindex Identifies Cross-References

Items that affect how Cindex recognizes cross-references are in the box labeled Cross-References.

To specify the words that can begin the introductory phrase, type them at Lead. You may enter text in upper- or lowercase letters—Cindex ignores letter case when searching for these words. The first word in the list must be the word that begins any cross-reference, but subsequent words in the list may appear in any order. The list Cindex uses initially lets it recognize cross-references that begin with see and continue with also or under, or also under.

To specify the character that will separate one cross-reference from the next, when more than one cross-reference is made from a heading, enter a single ASCII character at Separator.

To specify words that introduce general cross-references of the form “See individual drugs” or “See also specific treaties,” enter the appropriate words at General. When Cindex is installed this list contains the words ‘individual’ and ‘specific’. Cindex uses these words when:

• sorting multiple cross-references to the same heading; those that begin with a general term are normally placed at the end of the series.
• verifying cross-references; Cindex does not look for a target entry for any cross-reference that begins with a general term.

To permit Cindex to recognize cross-references entered as subheadings, uncheck Recognize Cross-References in Locator Field Only. This is generally not recommended because some of the tools for managing cross-reference work only with cross-references entered in the locator field. Moreover, if you enter a cross-reference a subheading, Cindex may be unable to distinguish it from normal text that begins with the words used to identify a cross-reference.

NOTE: To use the word that introduces a cross-reference (usually ‘see’) in some other context, place a ~ (tilde) immediately in front of it to prevent Cindex treating it as the start of a cross-reference.
VERIFYING CROSS-REFERENCES

As you enter a cross-reference in a record, Cindex can check and warn you if there is no target entry (see “Checking Cross-References” on page 47).

Cindex can also provide comprehensive verification of cross-references, checking that they refer correctly to record(s), that they are not circular, that they are of the right type (e.g., see or see also), and that they match in letter accent and case. To help you decide when double-posting would be preferable to making a cross-reference, Cindex can also identify cross-references made to a heading under which there are fewer than a specified number of entries. These additional checks, and others, are available through Check Index… from the Tools menu (see “Cross-References” on page 225.

CONVERTING CROSS-REFERENCES TO FULLY-QUALIFIED ENTRIES

Cindex can automatically convert entries that make see references into fully qualified entries that contain all the information from target entries, giving rise to fully double-posted entries. You may wish to convert cross-references when they point to fewer than a specified number of targets.

To convert see references, choose Manage Cross-References from the Tools menu. Cindex will display the box shown in Figure 34.

FIGURE 34. Managing Cross-References
Generating Cross-References Automatically

Set **For Fewer Targets Than** to the number of target entries below which you want Cindex to convert a cross-reference into a set of full entries. For example, to convert into a fully qualified entry any cross-reference that points to one or two target entries, set **For Fewer Targets Than** to 3. Cindex examines all the records in the current view, and where it finds a cross-reference to fewer than the minimum number of target entries generates new records that contain full entries.

**NOTES:** Cindex deals only with records that contain cross-references in the locator field. It ignores records that contain cross-references as subheadings.

Cindex ignores deleted records, both as the sources and the targets of cross-references. Cindex also ignores as sources any labeled records that you have designated as hidden (see “Displaying Labeled Records” on page 61).

Cindex marks as deleted, but does not otherwise alter, the record making the original cross-reference.

If for some reason Cindex cannot create new records, it leaves the original one intact.

To view the new records that Cindex creates, use **Find** (Edit menu) and search for **Generated** records.

**GENERATING CROSS-REFERENCES AUTOMATICALLY**

If you regularly prepare indexes on a particular topic, you might use a relatively standard set of terms, and some standard cross-references. To ease the burden of providing the correct cross-references, you can create a source of standard ones that Cindex will automatically place in an index whenever the index contains the appropriate target entries.

**Preparing a Source Index**

Use **New...** to create a new index in the standard way. This index will be the source of generated cross-references, and should be sorted alphabetically, using a letter-by-letter or word-by-word sort. For information on how to choose the alphabetizing method, see “Alphabetical Sorting” on page 151.
Generating Cross-References Automatically

The special index should contain one cross-reference in each record, organized as follows:

- In the main heading field, enter the text that will be the main heading of the cross-reference.
- In the first subheading field enter any subheading that accompanies the main heading. You can continue this to whatever depth of sub-subheading you wish.
- In the locator field enter the text of the target entry, without any leading See or See also. Cindex will decide what form of introductory phrase is required when it includes the cross-reference in another index. If you want to refer to a subheading under a main heading, enter the main heading with the text of the subheading as a modifier, after a comma.

Suppose you wanted to generate a cross-reference from “Leningrad” whenever your index contained an entry for “St. Petersburg.” The record in your special cross-reference index would look like Figure 35:

![Figure 35](image)

**FIGURE 35.** The form of an entry in a special cross-reference index

When you generate cross-references for your working index, any entry for St. Petersburg will trigger the formation of a new record that contains:
Generating Cross-References Automatically

To insert special cross-references in your working index, choose Manage Cross-References from the Tools menu. Cindex will display the dialog box shown in Figure 34. Choose Generate from File… to open the special index that will be the source of the cross-references. As soon as you open this index, Cindex will extract the appropriate cross-references from it. If your working index already contains a cross-reference that would be generated, Cindex will not add another one.

Cindex normally generates both See and See also references, as appropriate, but if you want to create only See references (omitting any See also references) check the “See” References Only box before opening the index.

Cindex knows which records contains automatically generated cross-references, and can find these at any time. To find generated records, choose Find… from the Edit menu, and check Generated. When you click the Find button, Cindex will display the first automatically-generated record it finds.

You can remove automatically generated records from the index by choosing Compress… from the Tools menu. “Compressing Index Entries” on page 230 explains how to do this.

NOTE: If you edit and change a generated record, Cindex no longer considers it to have been generated automatically.
PLACING AND FORMATTING CROSS-REFERENCES

Different styles of indexes require different arrangements of cross-references, varying both in the placement and the punctuation of the references.

To specify the punctuation, placement, and ordering of cross-references, choose Cross-References… from the Document menu. Cindex will display the dialog box shown in Figure 37.

NOTE: The settings you make take full effect only when you view the fully-formatted index. In a draft view of the index, Cindex will show cross-references in the correct position in the index, but will not punctuate them automatically, nor will it necessarily arrange them alphabetically if several references are made from the same heading.

Cross-References from the Main Heading

To specify the arrangement of references made from the main heading, click the From Main Heading tab.

Punctuation

Cindex can punctuate See and See also references differently. Enter at Prefix the punctuation (including any spaces) you want to separate each kind of cross-reference from its heading or preceding page references. Enter at Suffix any trailing
punctuation (e.g., a period, or a closing parenthesis) that should follow the last cross-reference made from an entry.

*See* references, which direct a reader to other entries in the index, generally appear immediately following the headings from which they are made. Cindex can place a *See* reference either run on from the heading, or as a subheading. Choose the arrangement from the **Position** drop-down list.

*See also* references are made from entries that also carry page references, and their positions depend upon the style of the index and the preference of the publisher.

In indented (set-out) style a *See also* reference from a heading generally appears in one of three places:

- Immediately following the heading (this is often the preferred form):
  
  Parking, 325
  Parks, 465. *See also* National Parks; State Parks management, 473
  noise, 460
  Pelicans, 267

- As the first subheading:
  
  Parking, 325
  Parks, 465
  *
  See also* National Parks; State Parks management, 473
  noise, 460
  Pelicans, 267

- As the last subheading:
  
  Parking, 325
  Parks, 465
  management, 473
  noise, 460
  *
  See also* National Parks; State Parks
  Pelicans, 267

In run-in (paragraph) style the cross-reference may appear in one of two places:
Placing and Formatting Cross-References

• Immediately after the heading (this form is often preferred):
  Parking, 325
  Parks, 465 (See also National Parks; State Parks); management, 473; noise, 460
  Pelicans, 267

• After all the subentries:
  Parking, 325
  Parks, 465; management, 473; noise, 460. See also National Parks; State Parks
  Pelicans, 267

To specify where Cindex should place “See also” cross-references from a main heading, choose from the Position drop-down list. This provides the following options:

• **Heading (always).** “See also” references from a heading follow the heading (or any preceding page reference) directly, without a line break. Cindex is initially set to use this placement of “See also” references.

• **Heading (no page).** “See also” references from a heading follow the heading directly, without a line break, but only if there are no preceding page references. If there are preceding page references, the See also references are formatted as a subheading.

• **First Subheading.** “See also” references from a heading are gathered together and displayed as the first subheading, above any regular subheadings that carry page references.

• **Last Subheading.** “See also” references from a heading are gathered together and displayed as the last subheading, below any regular subheadings that carry page references.

• **Last Subheading (conditional).** “See also” references are displayed as the last subheading; if there are no subheadings the cross-reference directly follows the page references from the heading.

**NOTES:** When See also references may be placed run-on from the main heading or as subheadings, depending on context (the second and last options, above) Cindex provides Prefix and Suffix punctuation only when the cross-references are run on from the main heading. Cindex suppresses punctuation if the cross-references are formatted as subheadings.
Placing and Formatting Cross-References

Depending on the position you choose for “See also” references, Cindex may re-sort the index.

Cross-References from Subheadings

To specify the punctuation of cross-references made from subheadings, click the From Subheading tab. Enter at Prefix the punctuation (including any spaces) you want to separate the cross-reference from its subheading or preceding page references. Enter at Suffix any trailing punctuation (e.g., a period, or a closing parenthesis) that should follow the last cross-reference made from a subheading.

When placing cross-references from subheadings Cindex provides the same options as are available for cross-references from main headings (Figure 37 on page 118). Choose from the Position drop-down lists how See and See also references should be placed.

Sorting Cross-References

When Cindex displays the fully formatted index it draws together all the cross-references from a single heading, even if you have entered these in different records, then normally sorts them in a single alphabetical sequence.

Cindex maintains a list of words that introduce general cross-references that should be placed at the end of any sorted set. “Specifying the Structure of Cross-References” on page 112 describes this list and how to modify it. If in some instance you want Cindex to place a general cross-reference in its alphabetical position in a series, put a ~ immediately in front of the leading word, as in “~specific.”

If you do not want Cindex to arrange multiple cross-references alphabetically (but instead display them in the order in which you entered them in records), uncheck Alphabetize Multiple References (Figure 37 on page 118).

NOTES: Cindex alphabetizes a series of cross-references only when you view the index as a fully-formatted document.
Placing and Formatting Cross-References

Cindex cannot arrange cross-references alphabetically unless they appear in the locator fields of records.

Suppressing Cross-References

You might on occasion want to display or print index entries without cross-references. To do this, check Suppress All References (Figure 37 on page 118).

NOTE: Cindex suppresses cross-references only when you view the index as fully formatted document. Cross-references are always visible in draft or unformatted views.

Text Style and Capitalization

Cindex will automatically apply a style you designate to the introductory phrase of a cross-reference, and will apply the same or a different style to the body of the cross-reference. When Cindex is first installed it is set to display the introductory phrase in italics, and the body in plain text. To specify a style for the introductory phrase click Prefix Style… (Figure 37 on page 118). To specify a style for the body of the cross-reference, click Body Style… For either setting, Cindex will display the dialog box shown in Figure 38.

Choose the styles and form of capitalization you want. Capitalization options differ depending on whether you are setting prefix style or body style.

- When setting prefix style you can choose Automatic capitalization to make Cindex capitalize the phrase according to preceding punctuation: Cindex will automatically capitalize the first word of the prefatory phrase if the cross-reference is formatted as a
Placing and Formatting Cross-References

Subheading, or the preceding punctuation mark (with any intervening space) is a period; Cindex will set the initial letter to lowercase if the preceding punctuation is a comma (with any intervening space) or an opening parenthesis.

- When setting body style you can choose Title Case, in which case Cindex follows these rules: the initial letter of every word is capitalized, unless preceded by ~; every letter after the first in a word is set in lowercase, unless preceded by ~; words in the list for smart flipping (Smart Flip Words… in the Document menu) are not capitalized.

Cindex does not apply styles or capitalization to the body of any cross-reference that begins with a word you have identified as introducing a general cross-reference. See “Specifying the Structure of Cross-References” on page 112.

NOTE: Cindex applies styles automatically to cross-references only when you view the index as a fully-formatted document.

Suppressing Automatic Styles

When the body of a particular cross-reference already has some style applied, you would not normally wish the prefix to carry the same style. If you check Don’t Apply Prefix Style if It Matches Existing Body Style in the main Cross-References panel, Cindex will not apply an automatic style to the prefix if that style is already applied to the body of the cross-reference.
Placing and Formatting Cross-References
CHAPTER 8  Page References

Cindex manages both ordinary page references and unusual locators such as dates or multi-part references. Even if you have spread references to the same entry across several records, Cindex will combine and order them properly when it formats the index; it can sort entries by date, no matter what the format of the date in a record; it can conflate and abbreviate references and can suppress repeated components of multi-part references. To take advantage of these capabilities you need to follow a few general principles when putting your references in records. The first part of this chapter therefore provides general guidance on entering locators.

HOW CINDEX IDENTIFIES LOCATORS

Any text in the locator field of a record, not specifically identified as a cross-reference, Cindex treats as a locator (generally a page reference). Figure 39 shows examples that Cindex can recognize and evaluate.

Frontispiece, 89, 106–108n., 202f
vi, xiv, 9-15, illus. 45
mcmlxv, mcmlxx
53(vii)A, 53(vii)B, 53(ix)A

FIGURE 39. Examples of references that Cindex can evaluate
How Cindex Identifies Locators

You can place as many references as you want in the locator field of a single record. Cindex therefore needs to know how to recognize distinct references.

Specifying the Structure of Page References

To specify the structure of a page reference, choose Reference Syntax… from the Document menu. Cindex will display the dialog box shown in Figure 40.

Settings that affect how Cindex recognizes page references are made in the Page References box.

Cindex normally assumes that if several page references are in a single record, each will be separated from the next by a comma. Cindex also uses the comma when it concatenates references from several otherwise identical records. You can use a different separating character, but you must tell Cindex what that character is. If Cindex does not know the correct separator it might treat a single reference that contains a comma as two separate references, and might rearrange the components of the reference when it formats the index. For example, some references shown in Figure 39 contain commas (e.g., May 2, 1977) and would not be correctly understood unless Cindex knew that the separator was a semicolon. Set the separator you want (a single ASCII character) at Separator.
How Cindex Identifies Locators

NOTE: If a complex locator must contain within it the character that you have designated as separating one locator from the next, you can prevent Cindex recognizing it as a separator by enclosing it in <...> or placing \ immediately before it.

Identifying an Inclusive Range

You will often indicate an inclusive range of pages (e.g., 155–158) by joining the references with a hyphen. Cindex needs to know how you denote an inclusive range, so that it can conflate or abbreviate references properly when it formats the index, and can adjust them properly when required. If you use the hyphen in chapter-page notation, so that for example, 5–7 means chapter 5, page 7, you must specify some character other than the hyphen to indicate an inclusive range. Specify the separating character at Connector. You can use any single ASCII character such as $ or @ that has no special meaning for Cindex. This character need not be the one you wish to see in the fully formatted document: when Cindex produces the formatted index it will translate the connecting character into whatever character or sequence of characters you wish to have displayed and printed. For example, if you specified $ as your connecting character, you could enter 6–8$6–10 in the locator field of a record and have Cindex display and print it as 6–8 to 6–10.

Recognizing and Classifying Components of References

After identifying an individual reference, Cindex parses it into segments. There are two kinds of segments, those comprised of Arabic numerals, and those comprised of letters.

A simple locator consists of a single segment; a compound (multi-part) reference of the kind shown in Figure 39 can contain several. A digit or series of digits followed immediately by a letter or series of letters (e.g., 55f) is considered to be two segments; a reference of the form 67a2 would be treated as having three segments. Segments can also be separated by one or more spaces, symbols or punctuation marks. These separators are all treated as equivalent. A reference such as 10:xix 67 therefore has three segments.

After Cindex has identified segments of a reference it classifies them. A segment consisting of digits (e.g., 345) is always evaluated as a number. A segment comprised of letters can be evaluated as a number in Roman numerals (e.g., xiv), as
How Cindex Identifies Locators

the spelled-out name of a month (e.g., May) or as plain text (e.g., Plate), depending on settings you make.

When Cindex is first installed, it is set to recognize Arabic numerals, and to treat any letter sequence as a plain text segment (it does not recognize Roman numerals or names of months). When Cindex compares reference segments of different types, it assigns higher precedence to Arabic numerals, and lower precedence to segments made of letters. “Evaluating and Sorting Page References” on page 130 describes how to change the kinds of segments Cindex recognizes, and how it evaluates them.

**Roman Numerals**

Cindex can recognize Roman numbers comprised of these characters: IVXL-CDM or ivxlcdm. Do not mix upper- and lowercase characters in the same number; if you do, Cindex will treat it as plain text. Be sure that the number is neither preceded nor succeeded by another letter. This restriction is designed to ensure that Cindex will not mistake normal text for a Roman number. For example, Cindex recognizes the number 6 in vi, [vi], and vi:a, but not in avid, vision, or province.

**Names of Months**

Cindex can recognize names of months spelled out in English, in any mixture of upper- or lowercase letters, as long as the name of the month is not preceded or succeeded by a letter. Cindex therefore recognizes “may” and “May” but not “maybe” or “dismay” as a month. The name of any month may be abbreviated to as few as three letters.

**Plain Text**

Any sequence of letters not recognized as Roman numerals or the name of a month is treated as plain text. When evaluating letters as plain text, Cindex distinguishes upper- and lowercase versions of a letter, and assigns them the following precedence:

AaBbCc... ...Zz
If you follow these guidelines, you will be best able to take advantage of Cindex in organizing page references as you want them.

**Use the locator field**

Always put page references in the locator field of a record (usually called the Page field). Cindex depends on references being in that field when it organizes or transforms them.

**Provide Complete References**

When you make an entry, you should as a general rule provide a complete reference, even though you may not wish the whole reference to appear in the formatted copy of the index. For example, if your publisher requires references to an inclusive range of pages to be abbreviated (e.g., 307–10 instead of 307–310) you should enter the full range (307-310) and allow Cindex to abbreviate the reference when it formats the index. It is a good idea to do this even when the inclusive range includes volume or part numbers (e.g., 22:55-22:58 rather than 22:55-58). You should also enter full references if your entries refer to volume numbers or dates (e.g., June: 23, June: 27, August: 15) even if you want repeated numbers or dates to be suppressed in the formatted output (e.g., June: 23, 27; August: 15). When Cindex produces the formatted copy of the index it will suppress as much as you require of repeated volume numbers or dates.

The benefit of entering full references is that Cindex can always find entries that refer to a particular page or date, no matter how complex the locator, and can make automatic adjustments of the kind you might need if your publisher adds, removes or rearranges pages after you have finished the index. If you have entered some shortened form of a reference Cindex might not always be able to deduce its full form and might not be able to find it or modify it properly.

**Apply Type Styles to Individual References**

You can use text styles and fonts freely in references, even in complex ones that contain several parts (e.g., 1987: May 15). However, you might not need to apply styles explicitly to references or parts of them. When Cindex displays or prints a fully formatted copy of the index, it can automatically apply specified
Checking Page References

type styles to all or selected parts of page references. For more information see “Applying Type Styles to References” on page 144.

CHECKING PAGE REFERENCES

While you are entering records in the index Cindex makes a variety of checks to ensure that the references are properly formed and fall within acceptable ranges (see “Checking Locators” on page 46).

Cindex can also warn you about entries that make too many undifferentiated references from a particular heading, or contain overlapping references, even if these occur across multiple records. These additional checks, and others, are available through the Check Index… command in the Tools menu (see “Page References” on page 228).

EVALUATING AND SORTING PAGE REFERENCES

Cindex evaluates page references under the following conditions:

- When a single entry has multiple references, and these have to be ordered when the formatted index is displayed or printed.
- When entries are ordered alphabetically, but are identical at all levels of heading that are being evaluated.
- When you want entries ordered by page reference.

Before Cindex can arrange references in the order you want, it has to know what precedence to assign to different kinds of segments (for example, whether a reference to a name of a month should precede a page reference in Arabic numerals), and it has to know how you want it to evaluate multi-part references (for example whether a three-part reference of the form month:day:year should be evaluated in the order year:month:day). Cindex is initially set up to:

- recognize letters as plain text (ignoring their possible interpretation as Roman numerals or names of months).
Evaluating and Sorting Page References

- assume that a reference consisting entirely of letters (e.g., Plate) should succeed one that is in Arabic numerals.

Cindex evaluates multi-part references from left to right.

Setting the Precedence of Reference Segments

You can specify how Cindex should recognize segments comprised of letters (as Roman numerals, spelled out months, or plain text), what precedence it should assign to different classes of components, and in what order it should evaluate components.

To change how Cindex recognizes components of a reference—for example, to enable the recognition of Roman numerals and names of months—or to change the precedence of different classes of components, choose Sort... from the Tools menu, then click the Locators tab.

Cindex will display the items shown in Figure 41.

![Sorting locators](image)

**FIGURE 41. Sorting locators**
Evaluating and Sorting Page References

Through the **Type Precedence** list you specify whether or not Cindex will recognize a segment of a particular class, and (if it does recognize it) what precedence Cindex should assign to it.

Cindex recognizes only segments corresponding to the classes that are checked with + marks. If a member of the list is unchecked, Cindex never recognizes a segment of the corresponding class. To check or uncheck a member of the list, double-click it.

**NOTE:** If you uncheck all the classes of segments comprised of letters (Roman Numerals, Letters, Months), Cindex will treat letters as punctuation.

When Cindex examines references and compares two components of different classes (e.g., a component interpreted as a spelled out month and one in Arabic numerals), it uses the order in which recognized classes appear in the **Type Precedence** list to determine the precedence of the components they represent. The checked item at the top of the list has the highest precedence; unchecked items always appear at the bottom of the list. To change the order of components that are checked, drag them to the positions you require. When Cindex is first installed it recognizes Arabic Numerals, and Letters, with Arabic Numerals having the greater precedence. Cindex is set not to recognize Roman Numerals or names of Months.

When Cindex is set to recognize two or more classes of segments that can be comprised of letters, it assigns a particular set of letters to the highest-precedence class whose requirements the set satisfies.

**Attending to the Style of a Reference**

Sometimes text styles—bold, italic, underline—are used to distinguish different types of page references. When Cindex finds two locators (or the least significant parts of multi-part references) that have identical values it uses their text styles to order them according to a precedence that you can specify. When Cindex is first installed it sorts otherwise identical references in this order: plain, bold, italic, underline.
Evaluating and Sorting Page References

To change the precedence of text styles, drag items in the Style Precedence list. The style represented by the top item has the highest precedence.

Setting the Evaluation Order of Multi-Part References

Cindex is initially set to evaluate multi-part references from left to right. For some kinds of multi-part references, particularly dates, the normal evaluation order may not be satisfactory. For example, if your references had the form `month:day:year` you would probably want them to be evaluated in the order `year, month, day`. Cindex will evaluate components of a multi-part reference in any order you choose.

Through the Segment Order list you specify whether or not Cindex will evaluate a segment, and (if a segment is to be evaluated) the order in which it will be evaluated. A name in the list identifies a recognized segment by its position in a reference. For example, *First* refers to the first recognized segment of a reference. Your settings of Type Precedence, discussed in the previous section, determine what Cindex will recognize as a segment.

Cindex evaluates only reference segments associated with checked items in the list. Double-click an item to make Cindex evaluate (or ignore) the corresponding segment of a reference. For example, were you to check *First, Second, Third,* and no other segments, Cindex would ignore any segments of references in positions four or higher. If you checked only *Second, Third, Fourth,* Cindex would ignore the first segment and the fifth and any higher segments.

The order in which the checked items appear in the list is the order in which Cindex evaluates their corresponding segments. When Cindex is first installed it is set to evaluate up to ten components of a compound reference in the order (from left to right) first, second, third ... tenth. To make Cindex evaluate segments in some other order, for example third, first, second, simply drag the item corresponding to a component to the appropriate position in the list. (The order *Third, First, Second* would ensure that a reference of the form month:day:year was evaluated chronologically.)
Evaluating and Sorting Page References

If Cindex is set to evaluate a segment that does not appear in a reference (for example you specified the evaluation order Third, Second, First and a reference contains only two segments), it will treat the missing segment as if it had zero value.

**NOTE:** If you are working with multi-part locators that contain more than ten recognized segments Cindex ignores the Segment Order setting and evaluates all the segments from left to right.

“Searching for Locators” on page 78 described how to use **Find** (Edit menu) to find records that contain references to particular pages or ranges of pages. You can use the same methods to find entries that contain multi-part locators, but there are additional points to bear in mind.

To search for a connected range of references, you must separate the low and high references in your specification with whatever character you have designated as the page reference connector (usually –). Cindex will understand an abbreviated form of the higher reference. To find all references to volume 20, pages 10-15 you could specify either

$$20:10-20:15$$

or

$$20:10-15$$

Cindex also makes allowance for suppressed components in records. For example, if the locator field contained 20:10-15 (meaning 20:10-20:15), Cindex would implicitly expand the suppressed segment before checking whether it fell within the range sought.

Cindex will interpret a truncated reference sensibly. For example, if references in records had the form “year:month day” (1988: Jan 10) and you wanted to find any references to January 1988, regardless of day, you could look for

$$1988:JAN$$
When you seek compound references, and specify fewer components of references than are contained in records, Cindex will find all references that satisfy the components specified in the search string; it will ignore less significant components. Thus if you specified

```
1988
```

Cindex would find any record with a reference whose first component was 1988.

**NOTE:** When evaluating references while searching with Find, Cindex uses the evaluation order you have specified through your settings or Segment Order (see “Setting the Precedence of Reference Segments” on page 131). If some component that Cindex is set to evaluate is omitted from the specification you provide with Find, Cindex will behave as if you had specified that component with zero value.

When Cindex parses a multi-part reference, it does not care what characters separate the components. In specifying the reference for which Cindex should look, you therefore need not use exactly the form that appears in records. For example, specifying

```
20:10:a
```

would find a record that referred to **20_10_a** or **20.10.a** or **20#10a**.

**Placing References in Descending Order**

Settings of Type Precedence, Segment Order and Style Precedence that you make through the Sort... dialog box (Figure 41) tell Cindex how to decide whether one page reference is larger or smaller than another one. These settings do not tell Cindex whether a smaller reference should precede a larger one, or vice-versa. Normally, Cindex arranges references in ascending order (smaller to larger), but you might occasionally need to produce an index (possibly a chronological one) in which references must be arranged in descending order (i.e., most recent first). To select descending order, uncheck Ascending Order under the Locator tab in the Sort... dialog box (Figure 41).
Ordering References by the First in a Record

If Cindex needs to use the value of a locator when positioning a record in the index (it generally does this only when positioning otherwise identical records), and the locator field contains more than one page reference, Cindex normally uses the lowest-valued reference (or highest-valued one if Ascending Order is unchecked). To make Cindex order entries by the value of the first reference in the locator field, uncheck Examine All under the Locator tab in the Sort… dialog box (Figure 41).

Forcing the Order of Individual References

Suppose you want a series of references from a heading to appear in this order:

18, 45–47, Plate XIV, A–2

With its standard settings of Type Precedence, Cindex would normally rearrange the references, and display them in this order:

18, 45–47, A-2, Plate XIV

You can interfere selectively with the automatic ordering of page references by adding components that will influence the sorted order but will not be visible in the fully-formatted display. The components will be visible in a draft display. To force a particular reference to the right place you can place a number enclosed in {} (braces) immediately before it, as in Figure 42.
Evaluating and Sorting Page References

**FIGURE 42.** Using braces to force correct sorting of references

**NOTE:** You can enclose selected text in braces by clicking `{}` in the record-entry window.

Cindex uses the `{47}` and `{1000}` in ordering the page references, but suppresses them when displaying the formatted entry. (In the example shown, the `{1000}` is used as an arbitrarily large number to ensure that the A–2 reference appears last). You may use braces to enclose any component of a reference in the locator field. The braces will not appear in the fully formatted display.

You can hide whole references or parts of references from the page ordering mechanisms by placing them within angle brackets `< >`. When you place text in angle brackets, Cindex ignores it unless it is the only thing that distinguishes two locators.

For example, you might have references containing Roman numerals that Cindex will evaluate. If an occasional reference also contains a letter that might be interpreted as a Roman number, you can hide it from the ordering mechanism by placing it inside angle brackets, as shown in Figure 43

**NOTE:** You can enclose selected text in angle brackets by clicking `<>` in the record-entry window.
The angle brackets will not appear in the fully-formatted display.

**NOTE:** You must always match opening and closing braces or angle brackets in a record. If you neglect to provide a closing brace or bracket, Cindex will warn you, and will not let you store the record until you have corrected the error.

**FORMATTING PAGE REFERENCES**

When Cindex displays a fully-formatted index, it sorts, formats and punctuates page references. Cindex first gathers all the references from identical records. It then (optionally) discards any duplicates and merges any redundant references to single pages or ranges of pages that overlap any other range of pages. After doing this it can conflate a series of separate references to consecutive pages, it can abbreviate page ranges, and it can suppress repeated volume numbers in multipart references. Cindex never alters records when it displays references in different formats.
To specify how Cindex should format page references, choose **Page References…** from the Document menu. Cindex will display the dialog box shown in Figure 44.

![Page Reference format settings](image)

**FIGURE 44.** Page Reference format settings

**NOTE:** The settings discussed below take effect only when you use a fully formatted view of the index.

**Formatting Inclusive Ranges**

Cindex provides several features for formatting inclusive ranges of page references.

**Translating the Connecting Character**

When you enter references in records you must use a single ASCII character (typically a hyphen, or minus sign) to denote a connected range of pages such as 55–67. “Specifying the Structure of Page References” on page 126 explains how to specify this character.

When Cindex displays formatted entries, it translates the connecting character to another character or sequence of characters you specify. References that appear in records as 55-67 can therefore be displayed as 55–67, or 55 to 67, or 55 through 57. When Cindex is first installed it is set to translate the hyphen to a
single en-dash. To use some other character or sequence of characters to denote an inclusive range, set Connecting Text to the character or sequence of characters you want.

When formatting entries, Cindex will if necessary break a line at any space, or after a hyphen. To prevent Cindex breaking a line in the middle of an inclusive range of references, use an en dash (ALT 0150 on the keypad) or a non-breaking space (ALT 0160 on the keypad) where you might otherwise use a conventional hyphen or space in Connecting Text.

Conflating References

When an entry contains a series of separate references to consecutive pages, Cindex normally arranges them in order, but does not conflate them into a single range. Cindex can conflate references to consecutive pages, so that a series of references entered in records as

34, 33, 35, 37, 39, 40-42, 41-43

can appear as

33-35, 37, 39-43

You can set Cindex so that it will conflate aggressively, whenever two references refer to consecutive pages, or more conservatively, when there is some larger number of references to successive pages. To enable conflation, use the Conflate Beyond drop-down list to specify the critical number of references to consecutive pages. For example, to conflate references whenever two refer to consecutive pages, choose First; to conflate when there are references to three or more successive pages, choose Second, etc. To disable conflation, choose None.

When conflating multi-part references Cindex attends only to the last component in Arabic numerals (or the last two components if they form an inclusive
Formatting Page References

range). A non-digit may appear after the last number. Thus references normally appearing as:

1988 (Jan) 3f, 1988 (Jan) 4f, 1988 (Jan) 5f

would be conflated as:

1988 (Jan) 3f-1988 (Jan) 5f

NOTE: Cindex will conflate references correctly only if they are ordered properly. To guarantee that references are ordered properly in the formatted entry, regardless of their positions in the locator field, you should let Cindex rearrange them if necessary. To ensure this, check Arrange in Sorted Order.

Abbreviating References

Cindex can abbreviate the upper part of an inclusive range of page numbers, so that a range entered in a record as 920-923 might be displayed as 920-23. Two established conventions dictate how page numbers should be abbreviated. One is recommended by the *Chicago Manual of Style* (Chicago, University of Chicago Press, 1993), the other by *Hart's Rules* (Oxford, Oxford University Press, 1983). A third convention permits very aggressive abbreviation of references. For a series of complete references that look like this

3-10, 16-18, 100-104, 107-108, 210-213, 321-325, 1496-1504, 1536-1538

the Chicago convention would format them as

3-10, 16-18, 100-104, 107-8, 210-13, 321-25, 1496-1504, 1536-38

Hart’s convention would format them as

3-10, 16-18, 100-4, 107-8, 210-13, 321-5, 1496-504, 1536-8
and the aggressive convention would format them as

3-10, 16-8, 100-4, 107-8, 210-3, 321-5, 1496-504, 1536-8

To abbreviate the upper part of a range of page numbers, choose from the Abbreviation Rule popup menu: Chicago (for University of Chicago Press rules), or Hart (for Hart’s rules) for Full (for aggressive abbreviation).

If your index contains multi-part page references, and you specify references fully in records when you provide an inclusive range (e.g., 20:ix:552–20:ix:555 rather than 20:ix:552–555), Cindex will abbreviate the second reference only if you have told it to suppress the leading parts (see “Formatting Multi-Part References”, below). When you suppress leading parts the inclusive range 20:ix:552–20:ix:555 will appear as 20:ix:552–555, and after abbreviation it will be transformed (using Chicago Rules) to 20:ix:552–55.

If Cindex is set to both conflate and abbreviate references, it will conflate them before abbreviating them.

Formatting Multi-Part References

When formatting compound locators such as 1986 a(ii):55, Cindex can suppress the display of repeated leading parts that are common to successive references, so that in the second and subsequent reference only the least significant, and changing, part of a locator is actually displayed. For example, if your record contained the following set of references to a heading (with a semicolon being the designated page reference separator)


Cindex could display them as

XIV 55:10, 62, 79; XV 56:108-9; XVI 57:232, 240
To enable this kind of suppression, check **Suppress Repeated Parts.** You must also provide Cindex with information about how much of the leading part of a complex reference it should suppress, and you must tell Cindex what characters it should insert in the formatted display to denote a concatenated reference (a comma in the example above).

To stipulate how much of the leading text should be suppressed, enter at **Suppress to** a marking character or set of marking characters that Cindex must encounter in the parts of references it will suppress. The point in the reference at which Cindex finds the last marking character is the point up to which it will suppress repeated leading components. Thus for references like those shown above, your template might be a space followed by a colon. Cindex will search through each reference until it finds the first space, after which it continues to search for a colon. If successive references match as far as the colon, Cindex replaces the leading components of the second and any subsequent matching references with a separating sequence of characters that you enter at **Concatenate with** (in the above example a comma followed by a space). The concatenating sequence should not contain the character that you use to separate successive complete references.

**NOTES:** When comparing characters in a reference against the marking characters in a suppression template, Cindex ignores leading spaces at the beginning of any reference. You should therefore not count these when forming a template.

Cindex will suppress repeated leading components of a reference only when the references are correctly ordered. To ensure proper ordering of page references, you should check **Arrange in Sorted Order.**

If Cindex is set to conflate references, it will conflate them before it suppresses any repeated leading components.

**Punctuating Page References**

Cindex always displays page references immediately after the text of the entry to which they belong. Cindex inserts punctuation of your choice before and after a set of page references. If you wish, Cindex will provide different leading punctuation depending on whether a single page reference follows a heading or multiple references follow a heading.
To specify leading punctuation (including any spaces) that Cindex should use to separate a single reference from the text of an entry, enter it at Before Single.

To specify leading punctuation (including any spaces) that Cindex should use when two or more references follow the text of an entry, enter it at Before Multiple.

Cindex is initially set to provide a comma followed by a space as the leading punctuation before both single and multiple references.

To specify text that Cindex should insert after the last page reference of an entry, enter the text at After.

When working with an index formatted in indented style, Cindex can format page reference so that they appear flush against the right margin of the page. To make Cindex display references in this format, check Right Justify. To make Cindex display right-justified references with a dot leader, check Dot Leader (this is dimmed unless right-justification is checked).

Applying Type Styles to References

Cindex can automatically apply type styles to page references when it displays or prints them. This can save you the effort of entering styled text in records. If your index contains multi-part locators, you can set Cindex to apply a different style to each part. Cindex is initially set to display all parts of page references in plain text.

To specify the style in which Cindex should display and print references, click Style... in the Page References dialog box. Cindex will display the dialog box shown in Figure 45.
Cindex can apply styles to up to ten segments of multi-part locators. You can specify a different style for each segment. For the purpose of applying styles, Cindex treats each segment of a reference as consisting of possibly two components: a part that can be evaluated (Arabic numerals, Roman numerals, text, etc.), and any filling or punctuating characters that might precede it. Cindex treats as punctuation any characters that it does not recognize as part of a reference element. For each segment you can specify styles separately for the reference element and its preceding punctuation (if any).

1. Click the tab corresponding to the position of the segment to which you want to apply a style (for a simple reference, use the First segment).
2. Under Locator Element check the style(s) for the reference element.
3. Under Lead Punctuation check the style(s) for any preceding punctuation.

Ordering References

When Cindex displays the fully formatted index it draws together all the page references from a single heading, even if these are contained in several records, then normally sorts them in an ascending sequence. (The earlier section “Evaluating and Sorting Page References” on page 130 explains how to set the rules Cindex uses for sorting references). If you want Cindex to display multiple page references in the order in which you entered them in records, uncheck Arrange in Sorted Order (Figure 44 on page 139).
NOTE: Several of the advanced options Cindex provides for formatting page references (for example, conflating them) depend upon references being displayed in sorted order. If you want to use any of the advanced options you should ensure that **Arrange in Sorted Order** is checked.

**Managing Duplicate and Redundant References**

When Cindex is set to arrange references in sorted order, it can also suppress the display of duplicate references and redundant references (e.g., 355, when there is also a reference to the page range 353-356) and can merge overlapping ranges of references (e.g., 56-59, 57-60 is displayed as 56-60). To enable this, check **Merge Redundant References**.

When managing redundant multi-part references Cindex attends only to the last component in Arabic numerals (or the last two components if they form an inclusive range). A non-digit may appear after the last number. Thus references entered as:

```
1988 (Jan) 4f, 1988 (Jan) 3f-1988 (Jan) 5f
```

would be formatted as:

```
1988 (Jan) 3f-1988 (Jan) 5f
```

**Suppressing Page References**

You might on occasion want to display or print index entries without page references. To do this, check **Suppress All References** (Figure 44 on page 139).

NOTE: Cindex suppresses locators only when you view the index as fully formatted document. In draft or unformatted views, locators are always displayed.
CHAPTER 9  Sorting Entries

This chapter describes the principles that Cindex follows when sorting entries, and explains how you can modify them when you need to.

LANGUAGE

Different languages have different alphabetizing conventions. For example, in a Swedish index, entries beginning with Å are placed after entries beginning with Z. Cindex can alphabetize entries by the rules appropriate for many languages. Cindex uses English by default. To specify another language, choose Sort… from the Tools menu, then choose the language from the Language pop-up menu.

If an index uses more than one script, Cindex normally follows a Unicode standard to determine the sorting precedence of letters and other characters (Latin letters have the highest precedence, followed by Greek letters, then letters and characters from other scripts). When you choose a language for sorting, you can give characters from the script for that language precedence over characters from other scripts, so that entries in that script are placed ahead of entries in all other scripts. To set this check Language Script has Precedence. When Language Script has Precedence is unchecked (always the case if the sort language uses the Latin alphabet), Cindex uses the default script ordering.

FIELD EVALUATION ORDER

When Cindex sorts records, it evaluates text fields alphabetically, and evaluates the locator field numerically (if it contains page references) or alphabetically (if
Field Evaluation Order

it contains cross-references). Cindex can evaluate fields in any order that you specify. When first installed it is set to alphabetize first on the main heading, then on successive levels of subheading, down to the lowest level present; if records are identical at all levels, their positions are determined by values of page references; if page references are identical the positions are determined by record number. By changing the order in which Cindex evaluates fields, you can change the way that entries are sorted. For example, if you set Cindex to evaluate the locator field first, your entries will be sorted by order of page reference.

To specify which fields Cindex will attend to, and the order in which it will evaluate them, choose Sort… from the Tools menu, then click Fields. Cindex will display the panel shown in Figure 46.

![Figure 46. Fields settings in Sort dialog box](image)

The order in which Cindex evaluates fields is determined by the list displayed under Order. The items in this list show, from top to bottom, the order in which Cindex will evaluate fields when sorting records. Cindex attends to fields that have a + beside them, and ignores fields without a +. To change the order of a field, drag its item to the position you want it to occupy. To make Cindex ignore
Field Evaluation Order

a field, double-click it to remove the +; to make Cindex attend to a field that is currently ignored, double-click it to restore the +.

To make Cindex sort entries by main heading only, ignoring other fields, set:

To make Cindex sort on the main heading, then by page references, then (if entries are identical in the main heading and page references) successively lower levels of subheading, set:

NOTE: When Cindex is set to ignore subheadings, records that have the same main heading and subheading, but different page references, may become separated in the index. To avoid this potential problem you should ensure that your index contains no duplicate records with different page references. Cindex can combine references from duplicate records into a single record. “Consolidating References from Multiple Records” on page 231 describes how to do this.

Sorting by Page Reference Order

To make Cindex sort entries by page reference, then by heading level, set:

When you sort entries by order of page references, Cindex places all records that contain empty locator fields at the beginning of the index, and places records that contain cross-references at the end of the index (in alphabetical order of reference). Cindex normally sorts the records in ascending order of page reference. If a locator field contains multiple references, Cindex uses the lowest-valued reference by default. You can change these ordering principles if you wish. “Placing References in Descending Order” on page 135 explains how to sort references in descending order. “Ordering References by the First in a Record” on page 136 explains how to sort references by the first that appears in the locator field.
Locating Records in a Page Order Sort

When an index is sorted by order of page reference, Cindex expects that if you want to find a record quickly you will specify it by a page reference. When you use navigation shortcuts to find entries in the main document window (page 71) Cindex interprets what you type as a locator, and looks up the first record that contains that locator. If the locator begins with a numeral (as it usually will) you must type a \ immediately before it to prevent Cindex treating the number as a record number. The same principles apply if you use Go To… to find an entry.

When an index is sorted by page reference, you cannot bring an entry into view in the main window by typing the beginning characters of its heading.

**NOTE:** You cannot use the tools Check Index or Reconcile Headings when the index is sorted by order of page reference.

Ignoring the Lowest-Level Subheading

Certain kinds of indexes require entries alphabetized on all levels of heading except the lowest (at whatever level this happens to be), which is ordered by page reference. For example, in the following fragment the entries directly under the heading are ordered by page reference; entries under subheadings are also ordered by page reference, but the subheadings are ordered alphabetically:

**FOOTBALL**
- viewing statistics, 57
- televising, 78
- College
  - new rules take effect, 14
  - NCAA approves drug tests, 827
- Professional
  - Super Bowl interviews, 31
  - NFL tryout results, 126

To make Cindex sort entries in this way, specify a conventional **Order**, and check Ignore Lowest Subhead. Cindex will sort the index in the order determined by **Order**, but will order the lowest-level heading by page number. If two headings at the lowest-level have identical page numbers they will be ordered alphabetically.
Alphabetical Sorting

**Sorting Shortcuts**

Cindex provides a quick method for sorting the index either alphabetically or by order of page number, without your having to choose **Sort...** from the Tools menu. On the main toolbar click ☰ to sort entries alphabetically; click ☰ to sort entries in locator (page number) order.

Clicking either of these buttons causes Cindex to use its current sort settings (made by choosing **Sort...** from the Tools menu), except that the order in which fields are evaluated is (for alphabetical sorting) from the main heading through the last subheading to the locator field, or (for sorting by page reference) the locator field, then the main heading through all the subheadings. If you want levels of heading to be evaluated in any but these two simple sequences (for example you want this order: main heading, locator, then subheading) you should specify that order by using the full range of sorting options available by choosing **Sort...** from the Tools menu.

**ALPHABETICAL SORTING**

When first installed, Cindex uses a *simple* alphabetical sort, but does not ignore numerals and punctuation in records. This is often the best way to keep the index organized while you work on it, but because the simple sort attends to all characters that appear in records, it is generally inadequate for production of the final index. Before producing your final copy you will usually sort the index by letter-by-letter or word-by-word alphabetizing rules.

In a letter-by-letter sort, spaces between words are ignored, and records are compared one letter at a time up to the first mark of punctuation. If the records match up to this point, the comparison continues to the next punctuation mark, and so on. In a word-by-word sort, letters are compared up to the end of the first word. If records match up to that point, the comparison starts again at the sec-
Alphabetical Sorting

In most instances the two alphabetizing rules produce identical results; however, there are exceptions:

**Letter-By-Letter**
- endings
- endogenous
- end piece
- end zone

**Word-by-word**
- end piece
- end zone
- endings
- endogenous

In both types of alphabetizing, Cindex ignores all characters but letters, except where noted in the following section.

**Principles of Alphabetizing**

When Cindex sorts records in letter-by-letter or word-by-word order it follows these rules:

**Letters**

Cindex ignores letter case unless that is all that distinguishes entries. When Cindex does distinguish upper- and lowercase letters, it follows language-specific conventions. For example, in English, lowercase sorts before uppercase; in Latvian, uppercase sorts before lowercase.

Accented letters are sorted according to language-specific collation rules. When sorting in English, Cindex treats any accented letter as its (unaccented) English counterpart, unless the accent is the only thing that distinguishes two entries. In this case the entry containing the unaccented letter comes first. If the same letter with different accents is all that distinguishes two entries, then the entries are ordered by the letter’s Unicode value.

**Punctuation**

When Cindex alphabetizes entries it assigns the punctuation marks . , : and ; a higher precedence than any other characters. These punctuation marks (especially the period) are often used in contexts, such as in abbreviations, where they should be ignored altogether. Cindex cannot infallibly identify special uses of punctuation marks, but it tries to detect them by ignoring any mark that is not followed by a space or a hyphen. Thus U.S.A. is alphabetized as USA. If you
Alphabetical Sorting

wish, Cindex will always ignore punctuation marks when alphabetizing. “Treatment of Punctuation” on page 157 explains how to do this.

Hyphen (-) and Slash (/)

Cindex ignores the hyphen and slash (solidus) in letter-by-letter alphabetizing, but in word-by-word alphabetizing it normally treats these characters as spaces, unless they are the only characters that distinguish entries. In such cases, the solidus has a higher value than the hyphen, and the hyphen has a higher value than a space. Thus the following entries are alphabetized in the order shown:

sodium potassium
sodium-potassium
sodium/potassium

If you wish, Cindex will ignore the hyphen and slash in word-by-word alphabetizing. “Treatment of Punctuation” on page 157 explains how to arrange this.

Symbols

In making a letter-by-letter or word-by-word sort, Cindex normally ignores symbols, but if two otherwise identical entries contain different symbols, the order of entries is determined by the character values of the symbols they contain.

You can sort entries on symbols if you wish. “Filing Entries under Symbols and Numbers” on page 163 explains how to do this.

Numbers

Cindex normally ignores numerals when alphabetizing, unless these are the only characters that distinguish entries. In this case Cindex evaluates a series of numerals as a number, and orders the entries by the values of these numbers. Cindex will therefore automatically place the following entries in the order shown, regardless of the order in which they were added to the index:

AAAS, 7th Annual Meeting
AAAS, 49th Annual Meeting

If you wish, Cindex will always evaluate numbers. For a full discussion of this, see the section “Evaluating Numbers” on page 158.
**Alphabetical Sorting**

**Identical Entries**
Records that are alphabetically identical are ordered by page reference. If the records also contain identical references they appear in the index ordered by record number.

**Choosing the Alphabetizing Method**

Cindex provides three different rules for alphabetizing entries, and for each of them offers variations on the basic methods. All the settings that govern alphabetizing are made under the **Text** tab in the **Sort...** dialog box (Figure 47).

![FIGURE 47. Settings for alphabetizing](image)

Choose the alphabetizing method from the **Alphabetizing Rule** popup menu. In addition to the standard letter-by-letter and word-by-word alphabetizing options, Cindex offers three variant forms of each: one recommended by the *Chicago Manual of Style* (15th Edition), another other recommended by the International Standards Organization (ISO), and a third recommended by the *Society of Biblical Literature* (SBL). If you choose a variant form Cindex configures for you most of the other settings available through the panel.
Alphabetical Sorting

Depending on the alphabetizing method you select, Cindex will disable various other options in the box. The section “Modifying the Basic Alphabetizing Rules” on page 156 describes these options. Choose any options you want, then click OK to sort the index.

While Cindex is re-sorting the index it displays an indication of progress. Nothing in the index is permanently changed by any type of sort. You can re-sort the index at any time by any sort rule.

When an index is sorted by the letter-by-letter or word-by-word alphabetizing rules, you can work with records in the usual way. When you add a record, or change a record’s alphabetical position by editing, Cindex places or replaces it properly according to the sort rule in effect. You can undertake all your work with the index sorted by the word-by-word or letter-by-letter alphabetizing rules, but for the reasons discussed below you may prefer to use the simple alphabetical sort.

If the index has been sorted by word-by-word or letter-by-letter rules, when you seek records by typing leading text from the main heading Cindex applies the sorting rules to the text you type before looking-up the record. It may therefore not find records in quite the way you expect. Suppose you were using a letter-by-letter sort and wanted to display a record beginning with

32-bit processors

If you typed \32 to show the entry in the main index window (you use the \ because Cindex otherwise interprets 32 as a record number) Cindex would not find the record because the standard letter-by-letter sort rule ignores numerals, spaces and hyphens. To find the record you could type bit.

In dealing with records that contain leading text that will be ignored by the sort rule Cindex is using, always type enough of the heading to get past characters that will be ignored.
Modifying the Basic Alphabetizing Rules

The following paragraphs describe how you can modify the basic alphabetizing rules that apply to all records. Not all options are available with each method of alphabetizing.

For sorting purposes Cindex recognizes three classes of characters: letters, Arabic numerals and symbols. Numerals and symbols are normally ignored, but if Cindex attends to them it normally treats all symbols as having higher precedence than all numbers, and all numbers as having higher precedence than all letters. You can specify a different precedence through the list labeled Character Priority. Drag the item corresponding to a character class to the position you want it to occupy in the list. The order in which these items appear in the list determines the precedence of the classes they represent—the item at the top of the list has the highest precedence.

When Cindex uses symbols in sorting entries, the standard ASCII symbols proceed in the following order:

!"#$%'()*+,-./:;<=>?@[\]^_`{|}~

Other symbols proceed in the order of their Unicode values.

You will usually want to ignore leading prepositions and articles when you alphabetize subheadings. Cindex maintains a list of words (mostly prepositions, conjunctions, and articles) that it will ignore when they begin subheadings. Cindex ignores all words at the start of a subheading until it finds one that is not in its list. For example, Cindex would alphabetize the subheadings in the following entries under ‘depression’ and ‘television’.

Political campaigns
during the depression
before television
To modify the set of leading words to be ignored, edit them in the box **Ignore Subheading Prefixes**. The words to be ignored can appear in any order. Leave a space between adjacent words. Cindex disregards the case of the words to be ignored, which may contain any mixture of upper- and lowercase characters.

**NOTE:** Cindex does not ignore leading words in subheadings when you use a simple sort.

To alphabetize an exceptional subheading on a leading word that would normally be ignored, place a ~ (tilde) immediately before the first word of the subheading.

In standard letter-by-letter alphabetizing, punctuation marks following a word or phrase have a higher precedence than any letter, so the following entries would be alphabetized as shown:

- Adolescent, physical examination
- Adolescent parents

An increasingly common practice is to ignore punctuation entirely in letter-by-letter alphabetizing. To do this, check **Ignore ,;:** under **Exceptions**.

In word-by-word alphabetizing Cindex normally treats the hyphen and slash as spaces (they are always ignored in letter-by-letter alphabetizing) unless these are the only characters that distinguish entries. You can make Cindex ignore the hyphen and slash in word-by-word alphabetizing. To do this check **Ignore */।**.

**NOTE:** This option is available only when you use standard word-by-word alphabetizing.

Cindex can ignore phrases in parentheses. To enable this, check **Ignore Parenthetical Phrases**. When this is checked, Cindex will attend to the text in parentheses if that is all that distinguishes two entries.

If you want Cindex to ignore parenthetical endings only in particular entries, do not check this box. Instead, enclose the parenthesized ending in angle brackets:
Alphabetical Sorting

< >. “Ignoring Specified Characters or Words” on page 159 provides more information about the use of angle brackets to hide text for sorting purposes.

NOTE: This option is not available when you use a simple sort. It is always checked when you use a variant form of letter-by-letter or word-by-word alphabetizing.

Ignoring Parenthetical Endings

You can set Cindex to ignore parenthetical endings to words. To do this, check Ignore Parenthetical Endings.

NOTE: This option is not available when you use a simple sort.

Evaluating Numbers

Because Cindex normally ignores numerals in standard letter-by-letter and word-by-word alphabetizing, it will usually arrange the following entries in this order:

- Regulation 2725–1(a)(6) cited in special report, 1082
- Regulation 2725–1(a)(5) revised in supplement A2, 1082
- Regulation 2725–2(a) examined in special report, 902
- Regulation 2725–1(b), draft of, 1152

In cases like these you will probably want to evaluate numbers embedded in entries, so that the entries are sorted by their leading letters, then (if the letters are the same) by the values of any numbers they contain:

- Regulation 2725–1(a)(5) revised in supplement A2, 1082
- Regulation 2725–1(a)(6) cited in special report, 1082
- Regulation 2725–1(b), draft of, 1152
- Regulation 2725–2(a) examined in special report, 902

To make Cindex evaluate numbers that it would normally ignore check Evaluate Numbers, under Exceptions. Cindex will then compare entries in the specified order (letter-by-letter or word-by-word) until it finds an Arabic numeral or series of numerals, which it will evaluate as a number. If the entries being compared contain the same numbers, the comparison continues; if the numbers differ, Cindex will place the records in numerical order. If only one of the entries contains a number it will normally be placed before the one without, although you can make Cindex place it differently by changing the precedence of charac-
OVERriding Sorting Rules for Individual Entries

You will sometimes want to make exceptions to the normal rules for alphabetizing. For example, you might want to ignore a Greek letter at the beginning of a heading, or you might want an abbreviation to be treated as if it were spelled out. This section describes how to make such exceptions for individual entries.

**NOTE:** The options described here apply only when you choose letter-by-letter or word-by-word alphabetizing. Sorting rules cannot be overridden when you work with a simple alphabetical sort.

**Ignoring Specified Characters or Words**

The following examples show how you can place entries correctly in the index by making Cindex ignore words or parts of words in records.

Entries sometimes will contain words you want Cindex to ignore during alphabetizing. For example, you would probably want the following entries alphabetized by last name then first name, with the title ignored:

- Hunter, Gregory, 59
- Hunter, Stewart, 43
- Hunter, Thomas, 22
- Hunter, Major William, 83

To ensure that the title “Major” is ignored during alphabetizing, enclose it in angle brackets:
Overriding Sorting Rules for Individual Entries

**NOTE**: You can enclose selected text in angle brackets by clicking in the record-entry window.

Cindex ignores characters in angle brackets during sorting, unless these are the only ones that distinguish entries. In that case the order of entries is determined by the characters in the brackets. The angle brackets themselves do not appear in the fully formatted display, though they do appear in the draft display.

**NOTES**: In word-by-word alphabetizing, Cindex attends to spaces and hyphens between words. When you mark a word or passage of text to be ignored, you should always include within the angle brackets any trailing space or hyphen, as in the example in Figure 48. If you leave a trailing space outside the brackets you may find that your entry is misplaced.

You may use angle brackets as often as you like in any field of a record.

If you want to hide particular text in all records in an index, you can configure Cindex to do this globally. See “Sort Substitutions” on page 165.

Ignoring the Beginning of an Entry

If you are working on a scientific index you might make an entry like this:

\[ \text{\textgamma-} \text{Aminobutyric acid, 453} \]

Such an entry would normally be alphabetized under "Aminobutyric acid" rather than under the Greek letter \( \gamma \). To make Cindex ignore the leading letter and the following dash (which would normally be treated as a space in word-by-word alphabetizing), place them in angle brackets, as in Figure 49.
Figure 49. Using < > to hide leading characters

Ignoring Page References

If you enclose the whole of a locator field within angle brackets (< >) Cindex will ignore all the references contained in it. This can be useful if you are preparing an index that is to be organized alphabetically by heading with subheadings ordered by reference or date, except for certain classes of headings (e.g., Births, Deaths) under which subheadings are to be ordered alphabetically. Use this order of fields to specify the overall arrangement:

For the exceptional cases you can obtain the alphabetical order of subheadings by hiding the complete contents of the locator field in < >.

Spelling-out Numbers, Symbols and Abbreviations

Entries that begin with numbers or symbols might need to be placed in the index as if the numbers or names of symbols were spelled out. Similarly, entries that contain abbreviations might need to be placed as if the abbreviations were spelled-out.

Arabic numerals in headings and subheadings are normally ignored in both letter-by-letter and word-by-word alphabetizing. To place an entry that begins with a number as if the number were spelled out, put the spelled-out form in braces immediately before the heading, as shown in Figure 50.
Overriding Sorting Rules for Individual Entries

**NOTE:** You can enclose selected text in braces by clicking `{}` in the record-entry window.

Notice that there is no space between the closing brace and 1066. Cindex uses the characters enclosed in braces to determine the alphabetical position of the record, but hides them and the braces when it displays the fully-formatted index (the braces and enclosed characters are visible in the draft view). You may use text braces as often as you like in an entry.

You can use the same technique to alphabetize any symbol. For example, to alphabetize the Greek letter $\beta$ (beta) at the beginning of an entry for $\beta$–Thalassemia, you would place `{beta}` immediately before $\beta$.

Cindex attends to braces only when using letter-by-letter or word-by-word alphabetizing. Cindex treats braces as ordinary characters when using a simple sort.

**NOTE:** If you want to deploy particular spelled-out forms in all records in an index, you can configure Cindex to do this globally. See “Sort Substitutions” on page 165.

Expanding Abbreviations and Unusual Spellings

To sort names beginning with Mc as Mac, or sort abbreviations as if they were spelled out, insert the missing letter(s) in braces, for example:
Overriding Sorting Rules for Individual Entries

FIGURE 51. Using {} to expand a name for sorting

The entry would be alphabetized under MacDonald, but in the fully formatted view would be displayed or printed as McDonald. If Cindex encounters both the expanded abbreviation (Figure 51) and the fully spelled version in otherwise identical entries, the full version will precede the abbreviated version.

NOTE: If you want to deploy particular spelled-out forms in all records in an index, you can configure Cindex to do this globally. See “Sort Substitutions” on page 165.

Filing Entries under Symbols and Numbers

In letter-by-letter and word-by-word sorting Cindex normally ignores Arabic numerals and symbols, so entries are filed under the first letter that appears in a heading. Certain indexes may require entries beginning with symbols or numbers to be filed under the appropriate symbol or numeral. For example, in the index to a book on computer programming entries might be filed under symbols such as ^ and !. To make Cindex sort an entry on a character that would normally be ignored place a ~ (tilde) immediately in front of the character, as shown in Figure 52.
Overriding Sorting Rules for Individual Entries

You may use the ~ as often as you like anywhere in a record.

When you place ~ before a digit (0-9), Cindex treats the digit as a character; it does not evaluate a number comprised of a series of digits. If you wish, Cindex will evaluate and sort numbers comprised of a series of digits. The section “Evaluating Numbers” on page 158 explains how to arrange this.

When Cindex attends to symbols or numerals in sorting entries, it normally files symbols before numerals, which are filed before letters. You can change this order if you prefer. The section “Setting Precedence of Letters, Numerals and Symbols” on page 156 explains how.

Reserved Characters

Because the characters \ { } < > and ~ have special meanings for Cindex, they are normally neither displayed in a fully formatted view nor evaluated in sorting a record.

Even if a reserved character is preceded by \ to disable its special function (for example \\) and allow Cindex to display it as a normal character, Cindex will not attend to it in letter-by-letter or word-by-word alphabetizing entries (because the special character is a punctuation mark). If you want Cindex not only to display a reserved character but also to evaluate it during sorting, place a ~ before it. If you enter ~\ in a record, Cindex treats \ as a literal character and sorts it by its value. The same applies to ~<  ~}  ~{  ~} and ~~.
SORT SUBSTITUTIONS

If you will always want to spell out certain words (e.g., “St.” as “Saint”), or will always want to ignore certain words or phrases, you can set Cindex to do this automatically, without needing to insert spelled-out text in {...} or text to be ignored in <...>. You manage this by specifying sets of text pairs: target text that Cindex looks for in records, and substitute text (which may be nothing) used in its stead when alphabetizing.

To set up sort substitutions, click Substitutions… on the Text tab in the Sort Panel. Cindex will display a table like the following, through which you can provide substitution pairs of the kind shown (Cindex provides no substitutions by default).

![Text Substitutions Table]

**FIGURE 53. Settings for text substitution**

**NOTE:** Text substitutions function only when you use letter-by-letter or word-by-word alphabetizing. When you use a simple sort, Cindex attends to every character in a record.

Each row in the table contains, on the left, target text that is to be sorted as if it were the counterpart on the right. There are restrictions on text you can enter:

1. Target text (on the left) must be a complete word or the start of a word (i.e., it must begin with a letter or a number). It may be a prefix to its own substitute (on the right), but it may not match, or be a prefix to, any other text in the list.

2. The substitute text (on the right) may not begin with text that matches any target except its own. It may be empty, which causes Cindex to ignore the target text when alphabetizing entries.
Sort Substitutions

Cindex will not allow you to enter non-conforming targets or substitutes.
CHAPTER 10  Formatting the Index

A strength of Cindex is that you can form entries in records without being concerned with how they will look in the fully formatted copy—Cindex deals quite separately with the content of an index and its appearance. As a result, you can at any time change the way in which entries are arranged and displayed or printed. This chapter describes how to control the overall layout of a document, and how to control the style and format of individual index entries.

For detailed information on arranging and formatting cross-references, see “Placing and Formatting Cross-References” on page 118. For detailed information on arranging and formatting page references, see “Formatting Page References” on page 138.

MARGINS AND COLUMNS

To set the page margins and columns, choose Margins & Columns… from the Document menu. Cindex will display the dialog box shown in Figure 54.
You can set margin widths and column spacing in inches, millimeters, points, or picas. Choose the unit you want to work in from the Unit drop-down list. Cindex will display all measures in the unit you choose.

To set margins, enter the sizes you require in the boxes marked Top, Bottom, Left, and Right. If you check Facing Pages, Cindex uses inside and outside margins rather than left and right margins when it prints even and odd-numbered pages.

To specify the number of columns (up to six), choose from the Columns drop-down list. In Gutter, set the space you wish to appear between columns.

NOTE: When you select more than one column, Cindex displays screen text in a column of the correct width, but does not show side-by-side columns. These appear only on the printed page.

Cindex knows the paper size your printer is set to use (you specify that through printer settings described in “Page Setup” on page 83) and uses this information, together with the margin and column settings, to determine how much space to allow for each column. Cindex does not allow you to specify column width as a fixed number of characters, because the column width does not correspond to a fixed number of characters in a proportionally-spaced font. If your publisher requires lines that contain a fixed number of characters, do the following:
Margins and Columns

1. Display your index in a monospaced font at an appropriate size (10 point Courier provides 12 characters per inch; 12 point provides 10 characters per inch).

2. Calculate how wide each column of text should be to accommodate the required number of characters at the point size you are using.

3. Decide how much space you want to leave between each column (the “gutter”).

4. Use the following formula to set the left and right (or inside and outside) margins:

\[
\text{Left Margin} + \text{Right Margin} = \frac{\text{Page Width} - \#\text{Columns} \times \text{Column Width} + (\#\text{Columns}-1) \times \text{Column Width}}{\#\text{Columns}}
\]

Continuing Headings across Column and Page Breaks

When printing an index in the fully-formatted view only, Cindex can repeat at the top of any new column or page the heading from any entry broken at the foot of the previous column or page. When it repeats the broken heading Cindex can append some phrase (such as “continued”) to indicate that the entry was broken. Page and column breaks are not visible in the screen display, so Cindex does not show on the screen any repeated headings from entries that will straddle a column or page break.

To make Cindex repeat at the start of a page any headings from entries broken at the bottom of the previous page, click At New Page; to make Cindex repeat at the top of a new column any heading from an entry broken at the foot of the preceding column or page, click At New Column.

Choose from the To Level drop-down list the lowest level of heading that you want repeated after a break. For example, to have only main headings repeated, but not subheadings, choose the first item.

To make Cindex print some identifier after the repeated heading or subheading, supply the text at Append. To specify the style in which the appended text should be displayed (italic is the default) click Style… Cindex will display a dialog box through which you can set the style and capitalization.
HEADERS AND FOOTERS

To specify the contents of headers and footers, choose **Headers & Footers…** from the Document menu. Cindex will display the dialog box shown in Figure 55.

![Headers & Footers dialog box]

**FIGURE 55. Setting Headers and Footers**

If you have chosen to format your index on facing pages with different inside and outside margins (see page 168) Cindex provides separate headers and footers on left- and right-hand printed pages. Your options will be **Left Header, Left Footer, Right Header, Right Footer**. If you have not selected facing pages, Cindex provides a single set of headers and footers for all pages.

Each header or footer can have three segments (left, centered and right) and can be printed in any font or type style you choose.

- At **Left** type the text you want to appear at the left side of the header/footer.
- At **Center** type any text you want centered.
- At **Right** type the text you want to appear at the right side of the header/footer.

In any of these fields you can use the following special characters to denote entities that Cindex will provide automatically when it prints pages:

- **@** denotes the current date/time.
Headers and Footers

- # denotes the current page number.
- % denotes the name of the index.

To use @, # or % as a literal character in a header or footer field, place a \ immediately before the character (as in \@).

If you are using facing pages and want identical headers and identical footers on odd and even pages, set up the header and footer for one page (odd or even) then click « Copy » to transfer the settings to the other page. This button is available only when your Margins & Columns… settings specify Facing Pages.

Setting the Font and Style

To set the font in which the header/footer will be printed, choose from the Font drop-down list. The first item in this list (<Default>) represents the standard font in which the index is displayed (you specify that font by choosing from the Font drop-down list in the toolbar).

To specify the size, chose from the Size drop-down list (or type in the box) the size of text, in points. If you set 0, Cindex will print the header or footer in the text size used for the body of the index.

To set the style in which the header/footer will be printed, click Style… Cindex will display a dialog box through which you can specify the text style.

You can set a different font, size and style for each header and footer.

Setting the Initial Page Number and Format

If you have used # in a header or footer to specify automatic page-numbering, Cindex will give the first page the number you set in First Page Number (by default, 1). Choose the number format (Arabic or Roman numerals) from the Number Format drop-down list.

Printing the Date and Time

If you have used @ to represent a date, you can choose the format in which Cindex will print the date by clicking the appropriate button in the Date Format box. To include the time with the date, check Add Time.
The Long and Short formats are the standard ones provided by Windows, and you can customize these through the Date tab of your computer’s Region and Language Settings Control Panel.

GROUPING ENTRIES

Alphabetical groups of index entries are often set off by titles (e.g., the leading letters common to headings in the groups). When displaying or printing the fully formatted index, Cindex can provide titles to groups of entries, and can provide extra spacing between groups. Cindex does not display titles in any draft view.

To provide titles to groups, choose Grouping Entries… from the Document menu. Cindex will display the dialog box shown in Figure 56.

NOTE: The section “Line Spacing” on page 180 explains how to control the spacing between groups.

At Text, enter any text you want to appear at the head of each group of entries (if you supply no text, Cindex displays no title). Use the character %, on its own or as part of a longer text sequence, to stand for the leading letter of the group of headings. When Cindex displays the title it will replace the % with the appropriate letter or symbol.
CHAPTER 10  Formatting the Index

Cindex treats each letter of the alphabet as belonging to a distinct group, but it lets you choose how it groups entries beginning with numbers and symbols. In the Group Numbers and Symbols box, choose from the Grouping Method drop-down list the method you want it to use. In each item the square brackets […] contain the classes of leading characters that Cindex will include in a single group. For example, the item [@] [#] [$] [%]… [1] [2] [3] [4]… indicates that each leading symbol and each leading numeral forms a distinct group. The item [@#$%1234…] indicates that all symbols and all numbers fall in a single group (this is the setting Cindex uses when it is first installed).

Enter at All Numbers Title, All Symbols Title, and Numbers & Symbols Title any titles Cindex should display above the generic numbers/symbols groups.

NOTE: To identify the group to which an entry belongs, Cindex uses the first character that is not ignored in sorting. This need not be the first character in the entry (it will usually not be the first character if the entry begins with a symbol or a numeral).

To specify the font in which the title will be displayed or printed, choose from the Font drop-down list. Choose <Default> to use the standard font in which entries are displayed.
To specify a style in which the text should be displayed, click **Style…** Cindex will display a dialog box through which you can specify the style in which the title is to be displayed.

**STYLE AND LAYOUT OF ENTRIES**

Cindex keeps information about the contents of entries, held in records, quite separate from information about the arrangement of entries and the index style (indented or run-in). This makes it possible for Cindex to display the same index entries in a variety of styles and layouts.

To specify the index style, choose **Style & Layout…** from the Document menu. Cindex will display the dialog box shown in Figure 57.

![Style & Layout dialog box](image)

**FIGURE 57. Setting Style and Layout**

**NOTE:** With the exception of line spacing, the settings you make apply only when you view the fully formatted index; other views use their own, fixed, settings.
Setting the Index Style

Cindex can display and print indexes in indented and run-in styles and in several variants of these.

Entries formatted in run-in style look like this:

American frontier, 89-93; Oregon trail, 92
American Indians; art, 55; dance, 89

Run-in style is not generally suitable for formatting entries that have sub-subheadings (although variants of it may be), and entries with several levels of heading are usually formatted in indented style:

American frontier, 89-93
   Oregon trail, 92
American Indians
   art, 55
      jewelry, 57
      masks, 60
   dance, 89

To specify the basic index style, click Indented or Run-in. If you click Run-in, you can also specify through the drop-down list the level of heading below which you want headings run-in. The initial setting, which is standard, is to run-in all levels below the main heading. The entries shown below are formatted with headings run-in below the subheading:

American frontier, 89-93
   Oregon trail, 92
American Indians
   art, 55; jewelry, 57; masks, 60
   dance, 89

For each major style, Cindex provides variants you can select through the Variant drop-down list below the buttons.
Style and Layout of Entries

Modified Run-in Style

If your index contains sub-subheadings as well as subheadings (which normally precludes the use of the run-in style), you can make Cindex format entries so that subheadings are run-in from headings, except when any subheading has a sub-subheading beneath it, in which case all the subheadings under the relevant heading are indented and sub-subheadings are run-in:

American frontier, 89-93; Oregon trail, 92
American Indians
art, 55; jewelry, 57; masks, 60
dance, 89

To use this format, choose *Indent Major Subheadings* from the **Variant** drop-down list.

Modified Indented Style

Cindex provides two variants of the basic indented style.

1. In the first variant, Cindex will modify the layout of any entry in which a subheading (or sub-subheading) falls under a heading (or subheading) that contains no immediately following page reference. Cindex converts the subheading (or sub-subheading) to a phrase that modifies the main heading (or subheading), as in this example, where ‘art’ is a subheading:

American frontier, 89-93
Oregon trail, 92
American Indians, art, 55
jewelry, 57
masks, 60
dance, 89

To set this style, choose *Run-back Subheadings* from the **Variant** drop-down list.

2. In the second variant, Cindex prints every level of heading for each entry, (i.e., it does not suppress repeated headings).
To use this style, choose *Repeat all Headings* from the *Variant* drop-down list.

### Custom Run-On Headings

When you have chosen an indented style you can override the default layout on an entry-by-entry basis, and force subheadings to be run-on from a particular level. If the last character of any heading or subheading is a vertical bar (|), Cindex will format lower levels of heading run-on from that level. Cindex automatically substitutes the appropriate leading punctuation for the bar as it formats the entry.

### Collapsing Headings

If your entries contain multiple levels of heading, you can collapse heading levels in the formatted index, so that, for example, all subheadings are hidden, and the page references and cross-references that belong to them are merged with those from the main heading. This can be especially useful if you have to shorten an index by removing some low-level headings, but want to preserve their cross-references and page references.

To collapse headings choose from the *Collapse Headings below* drop-down list the level of heading below which headings will be collapsed. When you collapse entries, Cindex automatically suppresses “See” (but not “See also”) references that originate from a heading level that is collapsed.
Style and Layout of Entries

NOTE: Cindex collapses headings only when displaying entries in the fully formatted view. Collapsing headings merely alters the display of entries; it does nothing to the contents of index records.

Indentation

In an indented index each level of subentry is indented more than the level above. In both indented and run-in styles an entry that occupies more than one line is run over on a continuation line, suitably indented. The settings discussed in this section allow you to organize the indentation of entries in virtually any way you want. All these settings are made in the **Indentation** box.

The **Type** drop-down list provides four methods to control indentation:

- No indentation. Cindex provides no leading or runover indentation. Choose **None** to suppress all indents.
- Incremental Indentation. Cindex indents the start of each subheading by a specified amount that depends upon the subheading level; for any runover lines Cindex adds an additional amount to the lead indent. You specify the runover indentation and the lead for the first level of subheading, and Cindex calculates all other indents automatically. Choose **Incremental** to specify this method. This is the method Cindex uses when it is first installed.
- Fixed Indentation. Cindex indents headings and runover lines by amounts that you specify separately for each level of heading. This method provides the greatest control over indentation, but requires more settings than others. Choose **Fixed** to use this method. If you choose fixed indentation Cindex displays a series of tabs, one for each heading level in the index.
- Incremental Indentation, with special indentation for the lowest level of heading in an entry. This method is like standard incremental indentation, but the lowest level of subheading in an entry (regardless of its actual level) has fixed lead and runover
Style and Layout of Entries

indents. This method is designed for indexes in which the body of an entry must be indented by a fixed amount regardless of its placement under a main heading or a subheading:

**NEOPLASMS**
    Data files now online from Cancer Data Center, Dec. p 12

**Drug Therapy**
    Adjuvant pain treatment in cancer: a case for psychopharmacology,
        Jun pp 60-65

**Prevention & Control**
    Implications of allied health and nursing students' knowledge of cancer prevention, Aug pp 63-65
    State Cancer Plan designed to control cancer, Sep p 5

To use this method choose *Special Last* from the drop-down list.

Cindex can form indents in absolute units (inches, centimeters, points or picas), or in units based on the size of characters in the font in which the index is displayed. For font-based measurement, Cindex uses the em space (the width of the capital letter M).

Choose from the *Unit* drop-down list the unit in which you want to specify indents. When you change units Cindex converts the indents to the new unit. Cindex is set initially to form automatic indents using em-space units, with the leading indent for the first subheading set to 1 em space and the runover indent set to 2.5 em spaces. Specify the lead and runover indents in the *Lead* and *Runover* boxes. You can use fractional values for both the lead and runover indents.

When using *Incremental* indentation, you need specify only one lead indent and one runover indent.

When using *Fixed* indentation, you should specify a lead and runover indent for each level of heading that will appear in your index. Click the tab for the appropriate heading level, then set the lead and runover indents.
Style and Layout of Entries

When using Special Last indentation, you must specify incremental indents that will be used for all levels of heading except the last. You must also specify fixed indents that will be used for the lowest-level headings.

Line Spacing

Cindex will display and print entries single spaced, double-spaced, or spaced one and one-half lines apart, with the line space chosen automatically to suit the font you are using, or fixed at some size you specify. Line spacing is controlled through items in the Line Spacing box:

To specify the spacing of entries, choose Single, 1.5 Lines, or Double, from the drop-down list.

To make Cindex space lines automatically at an interval appropriate for the font you are using, check Auto (this is checked when Cindex is first installed). To make Cindex space lines at a fixed interval, choose from the drop-down list the unit in which you want to specify the space, then enter the value in the box. Cindex will uncheck Auto if the space differs from the space it would choose automatically. If you change the unit, Cindex displays the value of the line space in the new unit.

When displaying fully formatted entries, Cindex can insert extra blank lines at the transition from one main heading to the next, and at the transition between alphabetical groups of entries. To insert extra lines between main headings, set the number at Extra at Main Headings; to insert extra lines between alphabetical groups of entries, set the number at Extra at Alphabetic Groups.
Adjusting Punctuation

Cindex punctuates entries automatically as it formats them, for example placing a comma or some other character between the text of an entry and a following page reference.

Automatic punctuation might result in Cindex placing a period or a comma immediately after text enclosed in quotation marks, or after some text printed in italics or boldface, or in a special font. Good practice dictates that the period or comma should fall inside any trailing quotation mark and should appear in the same type style or font as the immediately preceding word. You can set Cindex so that it will adjust punctuation appropriately around quotation marks or the closing of a type style.

To make Cindex move trailing punctuation inside quotation marks (either punctuation it supplies automatically, or punctuation you have misplaced in an entry) check Around Quotation Marks in the Style and Layout dialog box (Figure 57 on page 174). When this is checked Cindex adjusts punctuation around a closing quotation mark (‘ ” ” or ’) when that is not preceded by punctuation, and when a matching opening quotation mark is not preceded by a letter.

To make Cindex move trailing punctuation inside the closing of a type style (e.g., italics or boldface) or non-standard font, check Around Styled Text. When this option is checked, Cindex will also automatically italicize parentheses or square brackets that enclose a phrase that is fully italicized.

TYPOGRAPHY AND PUNCTUATION OF HEADINGS

When displaying or printing a fully-formatted index, Cindex can show headings and subheadings in any font and style you choose, and can provide custom punctuation for them. Cindex can also suppress the display of headings at specified levels.
To specify the font and/or style in which Cindex will display and print headings, choose **Headings...** from the Document menu. Cindex will display the dialog box shown in Figure 58.

**NOTE:** These settings apply only to entries displayed in the fully formatted view. When displaying entries in other views, Cindex uses fixed, standard settings.

**FIGURE 58. Specifying heading formats**

You can provide different settings for each level of heading in the index. Click the tab for the level of heading for which you want to set a font and style.

**NOTE:** If the name of the field displayed in the tab has an asterisk beside it, this is a required subheading field (see “Special Last Text Field” on page 213).

From the **Font** drop-down list choose the font. The first item in the list (**<Default>**) stands for the standard font used in the main view. Cindex is initially set to use this font for all levels of heading.

To set the style or capitalization to be applied to the heading, click **Style...** Cindex will display a panel through which you can specify the attributes.

**NOTES:**

When setting text in title case, Cindex follows these rules: the initial letter of every word is capitalized, unless preceded by ~; every letter after the first in a word is set in lowercase, unless preceded by ~; words in the list for smart flipping (**Smart Flip Words...** in the Document menu) are not capitalized.

The font and style settings you provide do not override any explicit font and style settings in individual records (capitalization settings do override those in individual records).
Typography and Punctuation of Headings

To specify a character or sequence of characters that Cindex will show as the prefix to any heading enter the text at **Leading Text**. The prefix appears immediately after the first line indent, before the heading text.

To specify closing punctuation or other characters that Cindex will append to a heading that has no immediately following page references or cross-references, enter the text at **Trailing Punctuation**.

To suppress the display of the heading, check **Suppress**. Cindex will suppress the heading and any below it, together any associated page references and cross-references.

**NOTE**: Suppressing a heading is not the same as collapsing headings (page 177). When headings at or below a particular level are collapsed, all the page references and cross-references from these headings are displayed as if they belonged to the heading at the level above.

Page References and Cross-References

Cindex can display page references and cross-references in a wide variety of formats. “Formatting Page References” on page 138, explains how to organize the display of page references; “Placing and Formatting Cross-References” on page 118, explains how to specify the display of cross-references.

Styling Text Automatically

Cindex can automatically apply designated type styles to specified words or phrases that appear in an index. You can always apply a style explicitly to text in individual records, but if you regularly use words or phrases that must be displayed in a particular style, you can save time and effort by entering them in records in plain text, and allowing Cindex to apply the style automatically when it displays or prints fully-formatted entries, in much the way it applies styles automatically to cross-references or page references. When Cindex is first installed it is set to italicize *vs.* and *versus* wherever they appear in formatted entries.
To review or modify the words and phrases to which Cindex should automatically apply a style, choose **Styled Strings**… from the Document menu. Cindex will display the dialog box shown in Figure 59.

**FIGURE 59. Specifying automatically-styled character strings**

The list shows words or phrases to which some style will or can be applied. To review or change the styles to be applied to a particular word or phrase, click in the list to highlight it. Double-click to edit it.

- To change the styles for the selected word or phrase, check or uncheck the appropriate boxes.
- To delete the selected word or phrase, click **Delete**.
- To add a new word or phrase to the list, click **Add** then type it in the text box that Cindex opens in the list.

**STYLE SHEETS**

You can gather together and save in a “Style Sheet” the collection of settings that together determine the layout of pages and index entries. You can later apply the style sheet to any index. You can keep different style sheets for different kinds of indexes.

A style sheet includes these settings: **Margins & Columns, Headers & Footers, Grouping Entries, Style & Layout, Headings, Cross-References, Page References** and **Styled**
**Style Sheets**

**Strings.** The style sheet also contains information about the standard (default) font and size of text in which entries are displayed and printed.

To save a style sheet, choose **Save Style Sheet…** from the File menu, and give the style sheet a name.

To recall a style sheet, choose **Open…** from the File menu, choose **Style Sheets** from the **Files of type** drop-down list, then open the sheet you want.

**NOTE:** If you load a style sheet when no index is open for work, the settings in the style sheet become the default ones that Cindex bestows on new indexes when you create them.
CHAPTER 11  Exchanging Documents with Other Applications

While you work on an index Cindex keeps it in a private format, but it can save the index in a variety of formats that other document-management systems understand. The first part of this chapter describes the different formats in which Cindex can export documents, and explains how to prepare them. These documents fall into two broad classes:

- Documents that contain the index entries, plus information about the style of index (for example, indented or run-in) and layout. Cindex includes in the documents the information needed to produce an index that looks like the finished one you would view on the screen. You would normally make this kind of document when sending an index to a publisher for typesetting.

- Documents that contain the index entries, but no information about the index style and layout. You would normally make this kind of document when preparing index entries for a database.

Cindex can also include in an index entries prepared on other document systems. The second part of this chapter describes the forms in which Cindex can import entries, and explains how you can incorporate in an index records that have been prepared elsewhere.

SAVING FORMATTED INDEXES

When Cindex prepares an index as a document for a typesetting system or a word-processor, it always formats entries as they would appear in a fully formatted view (even if the current view is set to some draft format). Cindex includes in
Saving Formatted Indexes

the document most of the information needed to make the index look like it did when viewed as a fully-formatted index on the screen.

Since Cindex does not know about the page size used that will be used by the recipient system, nor does it know about the page numbering, or running heads, etc., it does not include information about settings related to page size, margins and columns, or headers and footers, nor does it include line-breaks for runover lines. Since there are no page or column breaks in the document, it contains no repeated headings of the kind Cindex might otherwise print at the top of a new page or column.

Entity Tags or Styles

For most publishing and word-processing programs the basic unit of text is the “paragraph”—a block of words terminated by a special character (often a carriage-return) and occupying one or several lines. All the information about how the paragraph is to be printed (typeface, size, indentation, line spacing, etc.) is represented by a ‘tag,’ 'style' or 'markup' identifier that is attached to the paragraph. By changing the formatting information associated with a tag, you change the formatting of all paragraphs that carry that tag. In the context of producing an index with Cindex, think of each level of heading in the formatted copy as a paragraph of a different type.

When Cindex produces a document for another system, it attaches tags to main headings, subheadings, etc., and also includes in most documents information about the attributes associated with each of these tagged entities (for example, the font and size in which it is to be displayed). Some document formats such as XML identify only the entities in the index—headings, subheadings, page-references, cross-references, etc., leaving the appearance of these entities to be determined by the document systems that will format the index.

Document Formats

Rich Text Format (RTF)

RTF is an interchange format widely-used for text documents on Windows and Macintosh. RTF documents can be read by word-processors and by most document publishing systems. Each level of index heading in the RTF document has a unique ‘style’ attached to it. Cindex sets the initial properties of the document
and its styles to reflect the settings you have given the index (number of columns, indentations of headings and runover lines, etc.), so that when the document is imported into a word-processor or page-layout program it will look much like it did when displayed by Cindex. The appearance of the index can be changed within a word-processor or page-layout program simply by re-defining the attributes of the styles associated with different levels of heading.

QuarkXPress and InDesign are publishing programs available for both Windows and Macintosh. Each uses its own system of tags to identify styles that belong to different elements of a document. Cindex can save a formatted index as a tagged document in QuarkXPress or InDesign format. Each level of heading has a unique 'style' attached to it, and carries the attributes that belong to that heading. These attributes can be changed in QuarkXPress or InDesign.

Many typesetting systems work with documents in which the elements (such as headings and subheadings) carry identifying tags. The tags contain information about document structure, but little or no information about the attributes associated with tags, so they say little about the document's final appearance. Instead, the final appearance depends on the attributes that the typesetter assigns to the tags.

Cindex comes equipped to make documents that are marked up using conventions derived from the Standard Generalized Markup Language (SGML) standard for constructing markup languages. Notably, Cindex provides for marking up using XML (Extensible Markup Language). XML is designed to handle Unicode text and is syntactically strict. Cindex also provides for markup using conventions such as HTML, and those recommended by the Association of American Publishers (AAP) and the University of Chicago Press (UCP). You can define your own sets of tags to suit your needs.

Cindex provides for you to define your own sets of markup tags to suit your needs. The later section “Managing Markup Tags” on page 193 explains how to do this.

You may encounter rare situations in which you have to prepare an index for a document-processing system that does not require, or cannot interpret, informa-
Saving Formatted Indexes

...tion about format tags and their attributes. In such cases you can save an index as a plain text document, with entries formatted as you would view them on the screen, but containing no information about fonts or type styles.

When you save a plain text document, Cindex does not break long entries into multiple runover lines, instead leaving it up to the application program that reads the document to decide where to break lines.

For maximum compatibility with other application programs, Cindex by default writes plain text documents using Windows ANSI character encoding. This encoding cannot represent all Unicode characters, and may lose information. Cindex also can export plain text documents using UTF-8 (Unicode) encoding. To specify the encoding, choose Preferences... from the Edit menu, click the Formatted Export tab, then click your choice at Encode Plain Text Documents.

Saving the Index

To save an index as formatted document, choose Save As... from the File menu.

From the Save as type drop-down list choose the type of document you want to make. The list shows all types Cindex can make. Choose from among the following types of formatted document. Other document types at the top of the list are discussed later.

- Plain Text
- Rich Text Format
- QuarkXPress
- InDesign
- XML Tagged Text
- SGML Tagged Text

When Cindex saves an XML or SGML document, it marks up the document using tags from a set you have previously specified. See the later section “Managing Markup Tags” on page 193 for more information.
Saving Formatted Indexes

Choose a document type, set the name of the document, then click **OK** to save the document. Cindex automatically provides the appropriate filename extension when it saves the file. Cindex always saves a fully-formatted index, regardless of the view (draft or formatted) you are currently using. Cindex normally saves all of the index that is accessible in the current view (either all records, or a group). To include only a part of the index in the document, see the next section.

To save only a part of the formatted index in a document, click **Options** before you save the file. Cindex will display the dialog box shown in Figure 60.

![FIGURE 60. Options for saving a formatted index](image)

- To include only records you have selected, click **Selection** (this is dimmed if no records are selected).
- To include records that would fall on specified pages (for your current page setup) click **Pages**, and set at **From** and **to** the range of pages you want to include. Cindex will include only entries that would fall on the specified pages, were they being printed.
- To include a range of records, click **Records**, and specify the starting and ending records in the boxes beside **From** and **to**. You can specify a range of headings by entering leading text, e.g., Abr through Doc. You can also specify a range of record numbers (e.g., 55 through 79). To include entries under specified headings, you need only provide as much of the beginning text as will identify a record uniquely. You can specify leading text from a subheading by appending a semicolon to the heading text then adding subheading text. To specify a heading that begins with digits, place a \ before the first numeral; Cindex will otherwise interpret leading digits as a record number.
Saving Formatted Indexes

If you omit the first part of the range Cindex will include entries from the head of the index until it finds a record that matches the end of the range. If you omit the end part of the range, Cindex will include entries from the starting record until it reaches the foot of the index. Cindex dims **OK** if you have clicked a range of records but have specified neither a beginning nor an ending record.

**NOTE:** Before including a range of records, Cindex checks that the last record in the range appears after the first. If the last record appears before the first, Cindex will display a warning message.

### Defining Subheading Indentation

When saving documents in Rich Text Format, or in the formats required by QuarkXPress or InDesign, Cindex can define leading indents to subheadings in one of several ways. You can choose to have indents defined as an attribute of the style attached to the subheading, by using ‘tab’ characters (one for each level of subheading), or by using a character of your choice (one for each level of subheading).

The method Cindex uses by default is determined by your Preferences settings. To set the default, choose **Preferences…** from the Edit menu, then click the Formatted Export tab. Click the appropriate button beside **Define Indent by.** When you save the formatted index, you can override the default setting via **Save As…** options (Figure 60 on page 191).

### Setting Style Names

By default, the names of heading styles in the exported index are taken from the names you use to identify record fields (see “Specifying Field Names, Sizes and Contents” on page 213), and the name ‘Ahead’ is used as the style name for an alphabetic group. You can specify alternative style names if you prefer.

To set alternative style names, click **Options** in the Save Panel, then click **Paragraph Style Names…** (Figure 60 on page 191). Cindex will then display a panel through which you can set style names.

By default, Cindex takes its style names from the names you use for record fields, and the table contents are fixed. To specify different names, click the **Table** button, and enter names in the appropriate cells.
Managing Markup Tags

When exporting the index, Cindex uses whichever set of names you have selected: the names of record fields, or the names you have set in the table. Cindex maintains a separate set of style names for each type of exported document, and remembers style names you set in the table, even if you are not using them.

MANAGING MARKUP TAGS

Cindex provides ready-made sets of tags for marking-up XML documents and SGML documents. You can also design your own sets of tags to meet needs of particular publishers. Tag sets are available for markup when you choose **Save As…** from the File menu.

Tags identify various elements of the index, but do not describe its appearance:

- Structure tags define the overall structure of the index, and identify levels of heading and subheading, and page references and cross-references.
- Style tags identify parts of the index that should be displayed in a particular style (e.g., boldface).
- Font tags identify parts of the index that should be displayed in a particular font.
- Special tags identify miscellaneous entities.

To create, modify or review sets of tags choose **Markup Tags…** from the Tools menu. Cindex will display a dialog box (Figure 61) through which you can define (or edit) tags that will denote various entities in the formatted index.

![Figure 61. Managing tag sets](image)

CHAPTER 11  Exchanging Documents with Other Applications  193
Click the XML tab to work with tag sets for XML markup; click the SGML tab to work with tag sets for less strict SGML markup. The drop-down list on the tab shows all the available tag sets of the type you have chosen (XML or SGML). If the tag set is built-in to Cindex, you can view it (the right most button will be labeled View…) but you cannot edit or delete it. If the tag set is one you have created, you can edit or delete it.

NOTE: The tag set named in the drop-down list on the XML tab or the SGML tab is the one that Cindex will use to mark up the formatted index when you choose Save As… from the File menu and select XML Tagged Text or SGML Tagged Text.

To view or edit an existing tag set, choose it from the drop-down list then click View… or Edit… To duplicate the tag set as the foundation for another, click Duplicate…; to start a new tag set, click New…. Cindex will ask you to name the tag set; the name you provide is the one you will use to invoke that tag set when you save indexes as tagged text files. The name may contain any character permissible in a filename, but may not begin with $. To delete the tag set, click Delete…

XML Tags

XML (Extensible Markup Language) is designed to handle Unicode text and is syntactically strict. When you export an index as an XML document, Cindex uses Unicode (UTF-8) to encode characters.

When you open a set of XML tags, Cindex displays the panel shown in Figure 62.
Structure Tags

These identify the different structural elements of an index. Cindex provides tags to denote the start and end of the index (Index), tags to denote the start and end of an alphabetical group of records (Group), and tags to denote the start and end of the title to a group of records (Heading). Additional tags identify the beginning and end of each level of heading, the beginning and end of the body of the heading (the text that appears before any page references or cross-references), the beginning and end of a page reference, and the beginning and end of a cross-reference.

**NOTES:** Tag names should consist of plain ASCII characters. They should not contain accented letters or non-ASCII symbols.

A tag name may not contain any of these characters: `<`, `>`, `&`, `''`

You define only start tags; Cindex automatically creates counterpart end tags.
Managing Markup Tags

You can configure particulars of the markup:

- Check **Identify Level with Attribute** to make Cindex add to each Level tag an attribute that identifies the heading level with a number (0 for Level 0, etc.).
- Check **Nest Subheadings** to make Cindex nest each level of subheading hierarchically under the level above.
- Check **Tag Individual References** to make Cindex apply the page reference tag or the cross-reference tag to each reference separately, rather than to the group of references in an entry.
- Check **Suppress Leading and Trailing Text in References** to make Cindex suppress the leading and trailing punctuation that it would normally place before and after page references and cross-references.

**Style Tags**

Style tags identify type styles, such as italic and boldface. Cindex will embed style tags in the document where the index contains styled text. If you define a tag for **Bold Italic**, Cindex will use that whenever it encounters a part of an entry that carries both bold and italics styles. If the tag is empty, Cindex applies tags for the separate **Boldface** and **Italic** attributes.

**Font Tags**

Font tags are used to denote changes of font. The first tag in the set denotes the standard font in which the index is displayed in the main document window. Use this tag to identify the concept of a default font, not a particular font. Cindex embeds a tag for this font only when the current font reverts to the default font after having been explicitly set to some other one.

When Cindex emits a tag to identify a font, it can emit the unadorned tag, or can add an attribute that identifies the font, either numerically, or by name. To make Cindex add the identifying attribute click **ID** (for numerical identifier) or **Name** (for the name of the font).

**SGML Tags**

To examine or modify tags, click the SGML tab, then choose the set from the drop-down list. If you have chosen one of the standard tag sets provided with Cindex (identified by a name beginning with $) click **View** to examine it. Other-
wise click **Edit** to examine or modify it. Cindex will display the dialog box shown in Figure 63.

![Figure 63. Panel for Editing SGML Tags](image)

### Structure Tags

These identify the different structural elements of an index. Cindex provides tags to denote the start and end of the index (**Index**), tags to denote the start and end of an alphabetical group of records (**Group**), and tags to denote the start and end of the title to a group of records (**Heading**). Additional tags identify the beginning and end of each level of heading, the beginning and end of a page reference, and the beginning and end of a cross-reference.

**NOTES:** Tag names should consist of plain ASCII characters. They should not contain accented letters or non-ASCII symbols.

A tag name may not contain any of these characters: & ' ”

You can configure particulars of the markup:
Managing Markup Tags

• Check **Nest Subheadings** to make Cindex nest subheadings hierarchically under headings.

• Check **Tag Individual References** to make Cindex apply the page reference tag or the cross-reference tag to each reference separately, rather than to the group of references in an entry.

• Check **Suppress Leading and Trailing Text in References** to make Cindex suppress production of the leading and trailing punctuation that it would normally place before and after page references and cross-references.

**Style Tags**

Style tags identify type styles, such as italic and boldface. Cindex will embed style tags in the document where the index contains styled text. Most markup systems require tags to define both the beginning and the end of a run of text in a particular style, but in some cases (for example, the AAP tags for superscript and subscript) there is no ‘off’ tag, and the ‘on’ tag is presumed to apply only to the immediately following character.

If you define a tag for **Bold Italic**, Cindex will use that whenever it encounters a part of an entry that carries both bold and italics styles. If the tag is empty, Cindex applies tags for the separate **Boldface** and **Italic** attributes.

**Font Tags**

Font tags are used to denote changes of font. The first tag in the set denotes the standard font in which the index is displayed in the main document window. Use this tag to identify the concept of a default font, not a particular font. Cindex embeds a tag for this font only when the current font reverts to the default font after having been explicitly set to some other one.

**NOTE**: the font that is represented by particular tags will vary from index to index, depending on your font usage. For more information about fonts see “Managing Fonts” on page 214.

**Special Tags**

These tags represent miscellaneous entities that might need to be encoded in a marked-up document.

Tags usually begin and/or end with special characters that cannot themselves be used as ordinary characters (for example, < and > are used to open and close a tag in several tagging schemes). To use < or > as a literal character you would there-
Managing Markup Tags

fore have to define a tag to represent it. You can define up to eight tags that each represent a character that needs special treatment.

Under **Special Characters** enter in a left-hand cell a *single* ordinary character that needs to be represented by a tag when it is used literally in the index; in the right-hand cell enter the tag that will represent it. Cindex will embed this tag in the document whenever it encounters the special character in the index.

Under **Non-ASCII Characters** specify how Cindex should encode non-ASCII characters such as accented letters. Cindex encodes a character’s Unicode value numerically, in either decimal or hexadecimal notation, preceded by the text you specify for Prefix and succeeded by the text you specify for **Suffix**.

When producing a tagged index, Cindex treats each index entry as a paragraph, and terminates it with the standard character that represents the end of a paragraph. If your publisher requires a special end-of-paragraph tag to be emitted before the standard character, provide it at **End Paragraph**.

Cindex does not currently use the tag for **End Line**.

If your chosen index format specifies right-justified page-references, Cindex normally inserts a tab character in a tagged index to separate page references from their entry. If your tagging scheme requires the tab character to be represented by a tag, provide the text at **Tab**.

At **File Type** enter the characters (up to three) that Cindex will use as the filename extension that identifies the type of file made when this set of tags is used in markup. If this is blank Cindex will automatically supply the filename extension ‘tag’ when it makes the file.
DIRECT TRANSFER OF INDEX ENTRIES

Copying and Dragging Formatted Entries

When you are viewing the fully formatted index, you can select and copy (or drag) a collection of entries into any open document window of a word-processing program.

Entries that you copy or drag carry style and format attributes, and will appear as they do when formatted by Cindex, providing the application program that receives the entries can display text in different fonts and styles.

Embedding Entries in Other Documents

Cindex can directly embed index entries in Microsoft Word documents or documents from any other word-processor that uses the standard Rich Text Format (RTF) definitions of index entries. When you view an index in draft view, and drag (or copy) entries into a word-processor document, Cindex prepares them as RTF index entries for direct embedding in the word-processor document. The following notes describe the entries that Cindex prepares, and assume that you are broadly familiar with the way in which Microsoft Word and similar word-processing programs handle embedded index entries.

Entries embedded by Cindex have the following properties:

1. They carry no page references (which will be supplied by Microsoft Word, or whatever word-processor you are using), but they do carry information about how the page references should be formatted (as boldface or italic, etc.—make these settings by choosing Page References... from the Document menu). For your own purposes you can place page references in the locator fields of records, but Cindex will not transfer them during embedding.

2. If the locator field contains the character you use to define a range of pages, either alone or as part of a real page reference, the embedded index entry will refer to a fictitious bookmark (“$$$$”). To display the page range correctly in the generated index, select the full span of the referenced text, create a bookmark, then in the embedded index entry replace $$$ with the name of the bookmark.
3. The embedded index entries carry any cross-references from the locator fields of records. These will be formatted in the style you have previously specified by choosing Cross-References… from the Document menu.

4. Each heading in the index entry normally carries a sort key that is used by the recipient program when it arranges the entries in the formatted index. Cindex constructs this sort key (which will not appear in the formatted index) according to the sort rules you have specified for the index. To take maximum advantage of Cindex’s powerful alphabetizing capabilities, you should ensure that index entries are sorted as you would wish them to appear, before you embed them.

You can omit the sort key, and let the recipient program arrange entries by its own alphabetizing rules. To do this choose Preferences… (Edit menu) and under the Formatted Export tab uncheck Include Sorting Information when Embedding Entries.

NOTES: Cindex formats embedded entries as hidden text. If you want to see the text that has been embedded be sure to set your word-processor to show hidden text.

Cindex formats entries correctly for embedding only when the view is set for draft format. If the view is set to display a fully formatted index, an entry you drop or paste appears directly in the document as it would on the screen in Cindex, and no hidden embedded entry is created.

SAVING INDEX RECORDS

Cindex can save documents that contain just the contents of index records (without information about the style or layout of the index). To save index records, choose Save To… from the File menu then from the File Format pop-up menu choose one of the document formats described in the next section.

Document Format

XML Records

Cindex can export index records as tagged entities in XML documents—plain text documents that can represent all Unicode characters. This is the recommended format for interchange with other software. Tags identify key elements of records, such as required last text fields, and locator fields, and the fonts and text styles used in records.

NOTE: Before saving XML Records, Cindex checks the index for records that contain mismatched < > or mismatched { } within a field. If any records contain mismatched
Saving Index Records

< > or { }, Cindex will warn you and will display the records in a group. You will need to correct the mismatches before you can export the records.

Cindex Archive

A Cindex Archive is a document in a private format that contains index records (including information about fonts and styles used in entries) but no information about how entries are to be sorted or laid out. Archives are readable by all versions of Cindex, but cannot represent all Unicode characters, so you should use them only when you must export records for use by Cindex version 2 (Mac or Windows).

NOTE: Index documents made by Cindex versions 3 and 4 (those with the .ucdx filename extension) are fully interchangeable between Cindex for Mac and Cindex for Windows.

Tab-Delimited Text

Cindex can save the text of index records (the contents of the record fields, including the locator field) in a form that is widely used by database management programs. In this form all the fields of an index record lie on a single line, each field being separated from the next by a ‘tab’ character. When imported into a database program, each field in the index record will occupy a different field in the database.

The saved document contains only plain text; Cindex saves no font and style information, nor does it save any information about the layout of entries in the finished index. Cindex does not export text in { } used to control sorting, nor does it export any of the characters { } < > ~ \ unless they have been used literally in records.

Cindex by default uses UTF-8 (Unicode) character encoding. You can change the encoding to the Windows ANSI character set via Options... when the Save As... panel is displayed.

Options for Saving Records

Cindex lets you control aspects of how records are saved in documents. To review and set options, click Options... in the Save panel before you save the records. Cindex will display the panel shown in Figure 64 (options will vary with the particular document type you are saving).
Saving Index Records

To include only records you have selected, click Selected Records (this is dimmed if no records are selected).

To include a range of records in the view, specify the starting and ending records in the boxes beside From and To. You can specify a range of headings by entering leading text, e.g., Abr through Doc. You can also specify a range of record numbers (e.g., 55 through 79). To include specified headings, you need only provide as much of the beginning text as will identify a record uniquely. You can specify leading text from a subheading by appending a semicolon to the heading text then adding subheading text. To specify a heading that begins with digits, place a \ before the first numeral; Cindex will otherwise interpret leading digits as a record number.

If you omit the start of the range Cindex will include entries from the head of the index until it finds a record that matches the end of the range. If you omit the end of the range, Cindex will include entries from the starting record until it reaches the foot of the index.

**NOTE:** Before including a range of records, Cindex checks that the last record in the range appears after the first. If the last record appears before the first, Cindex will display a warning message.

Saving Deleted Records

When saving records, Cindex does not normally include deleted records. If you want these included in the document, check Include Deleted Records.

FIGURE 64. Options for saving index records
NOTE: When you save tab-delimited text, records contain no indication that they were deleted.

Writing Order

When Cindex exports records, it can save them in the order in which they are displayed in the main view window, or in record number order. The default for XML records and archives is to write in record number order; the default for tab-delimited text is to write in sorted order. To specify the order, check or uncheck Write in Record Number Order.

Character Encoding

When you save records as plain text Cindex can encode the characters using Unicode (UTF-8) or the Windows ANSI character set. The default is UTF-8. To specify the encoding, choose UTF-8 Encoding or ANSI Encoding.

Saving Records with a Minimum Number of Fields

When you save records as plain text Cindex can format them so that each contains at least a specified minimum number of fields. To set a minimum, type it at Minimum Number of Fields. If a record contains fewer than this number Cindex will write extra blank fields before the locator field. To specify no minimum, set 0.

IMPORTING RECORDS

Cindex can import records in XML format (XML Records) and in archive format (Cindex Archive). Cindex can also import records in formats used by other programs:

- Plain text records, from a word-processing program, text editor, or database program.
- Records from the indexing programs SKY Index.
- Records from the index program Macrex.
- Records from the legacy program Cindex for DOS.

XML Records and Archives

You can add the contents of an XML record document or an archive to an existing index, or you can create a new index from it. To add the contents of the archive to an existing index, choose Import... from the File menu, then select the document you want to import.
To create a new index from XML records or an archive, choose **Open…** from the File menu, then select the document by name from the displayed list.

**NOTE:** You can open an XML record document or an archive from Windows Explorer (and start Cindex if necessary), by double-clicking the document’s icon.

If no index with the name of the XML document or archive exists in the folder that contains it, Cindex will automatically create a new index with the name of the document and will import the records. If an index with the name of the document already exists, Cindex will present a panel through which you should choose a new name and location for the index to be created.

When Cindex opens an XML record document or archive, it checks to see that the fonts used by entries are available on your computer. If any font is unavailable, Cindex will ask you to designate a substitute. For more information on font management, see “Managing Fonts” on page 214.

### Other Import Formats

#### Records from a Database

Cindex can import index records from plain text documents that have the filename extension `.txt`.

Records must conform to a simple specification: each record must be contained in a single paragraph terminated by a carriage-return character, or a line-feed character, or a carriage-return/line-feed character pair. The fields of the record must be separated from each other by a ‘tab’ character, and the locator field, which contains page references or cross-references, must be the last field. Such a record might look like this when displayed by a word-processor:

```
Main heading   subheading   sub-subheading   1-3, 15-17f
```

Cindex assumes that the last field in any record is the locator field, so you should ensure that any record that has no locator (page reference or cross-reference) has a blank last field (i.e., one with nothing after the last tab character). You need not include empty fields between headings and the locator field: if you import
Importing Records

records into an index in which records have a fixed number of fields, Cindex will automatically add empty fields when necessary.

If you are preparing records in a word-processor, you should make each record a separate paragraph. It will generally not matter that long records are wrapped on to two or more lines. Most word-processors provide an option to save a document as “plain text without line breaks.” You should save the records in this format.

Each record can contain up to fifteen tab-separated fields that hold the text of headings, plus a field that contains the locator.

When Cindex imports the records it checks whether the file starts with the special sequence of characters that indicate UTF-8 (Unicode) encoding. If Cindex finds the special characters, it imports the text as UTF-8; otherwise it assumes that text is encoded using the Windows ANSI character set.

When Cindex imports plain text records, it places a \ before any of the characters that have special functions ({ } < > ~ \) to ensure that they are treated as literal characters (e.g., { becomes { in the Cindex record).

Records from SKY Index

Cindex can import records in the tab-delimited format used by Sky Index 7 (filename extension .sky7) or the comma-delimited quoted format used by Sky Index 6 (filename extension .txt—Cindex will detect this format by examining the contents of the document).

As Cindex imports records it captures bold, italic, underline, small caps, subscript and superscript styles (for Sky Index 7 it translates any strikeout text style to small caps). Cindex also translates the following attributes:

- Text to be ignored in sorting entries is enclosed in <...>.
- Text to be used in sorting entries but to be hidden in a formatted display is enclosed in {...}.
- 'Note' text is enclosed in <{...}>.
Importing Records

Sky Index records may use up to three alternative fonts (two for Sky 6), but the exported document contains no information about what these fonts are. If the records use alternative fonts, Cindex assumes the Sky Index default assignments:

- Alternative Font 1: Symbol
- Alternative Font 2: Courier New
- Alternative Font 3: Times New Roman

Characters in Alternative Font 1 (Symbol) are converted to their Unicode equivalents.

Records from Macrex

Cindex can import records that have been saved by Macrex in its backup format (filename extension .mbk). These records contain some information about text styles, and information about how records should be sorted.

The backup format used by Macrex does not unambiguously distinguish locators and the body of an index entry: commas can separate different levels of headings and can separate locators from headings and from each other. When Cindex imports Macrex records, it resolves this ambiguity by looking for the first number after which there are no more letters, or only letters contained in braces { }. It places this number and everything that follows it in the locator field of the Cindex record.

When you have read your records into a Cindex index, you will be able to remove some of the notations required by Macrex:

- Cindex automatically ignores leading numerals in a record during alphabetizing, so you can remove any braces (which Cindex will have translated to < >) that you have used to hide numerals from Macrex.
- Macrex requires cross-references entered as subheadings to have the sequence ~zzz~ (which Cindex translates to {zzz}) immediately in front of them to ensure their proper placement. You should remove the {zzz}, because they will interfere with Cindex's capacity to recognize and sort cross-references.
- Cindex will automatically apply a chosen style to See and See also, so you can remove any styles applied to these words.
Importing Records

Records from Cindex for DOS

You can import index records prepared using the legacy program Cindex for DOS and saved in its backup format (filename extension `.dat`). Records contain information about text styles and other special attributes of entries that control how they should be sorted.

Reading Records

To import records choose Import… from the File menu. Cindex will display a panel through which you can choose the document. File types that Cindex does not recognize are dimmed.

When importing records made by SKY Index, Macrex, or Cindex for DOS, Cindex interprets information about text styles and other special attributes of entries. Cindex also translates characters to Unicode, where appropriate.

Checking the Records

Before importing records, Cindex examines the document to check the following:

- Will new records fit within the current record size?
- Does any record have more fields than Cindex can accommodate?
- Does any new record contain unacceptable characters?
- Is any record badly-formed (for example, does it lack a delimiter)?

If Cindex detects that some new records are longer than the current record size, it will ask if you want to increase the record size. Click OK to let Cindex enlarge the record size then import the records.

If Cindex detects that some new records require more levels of headings than are permitted in the index, it will ask if you want to increase the maximum number of heading levels. Click OK to let Cindex increase the permitted number of fields then import the records.

If Cindex finds any other problem it will warn you that the document contains bad records, and will provide you the option to read the document anyway, ignoring any bad records it contains. If you click Cancel, Cindex will stop the
operation and display a window that provides information about what was wrong with the records it was trying to import. Each line in the window identifies an error, and shows the line number in the document being read and the type of problem.

Cindex accumulates information on up to 200 errors. If the document being read contains more than this number of errors, the most likely cause is that the document does not contain records, or that records are not in the format Cindex expects.

When Cindex reads records containing characters that might require translation it will alert you if any record contains unknown characters. When Cindex encounters a character it cannot translate, it substitutes the unknown character symbol (�). Cindex marks any records that contain untranslatable characters; you can find these by choosing Find from the Edit menu.
Importing Records
This chapter describes some general tools that Cindex provides to help you manage and obtain information about Cindex documents. It also describes techniques for combining indexes to multiple volumes and for breaking indexes into parts for spinoff volumes.

**SPECIFYING THE STRUCTURE OF RECORDS**

You can specify several aspects of the structure and organization of index records. For example, you can use any names you want for the different fields in records, and you can specify limits on the number and kinds of characters that can be contained in fields. Cindex provides default settings when you begin a new index, but you can change these at any time.

To change the structure of index records, choose **Record Structure...** from the Document menu. Cindex will display the dialog box shown in Figure 65.
Specifying the Structure of Records

![Record Structure Dialog Box](image)

**FIGURE 65. Setting Record Structure**

**NOTE:** When you start a new index with New… from the File menu, you can click Options… to display and change the structure settings before the index is created.

### Changing Record Size

To change the maximum number of characters that a record can contain, set **Maximum Characters in Record**. You can enter any number up to 2000 (Cindex will round the number if it is odd), as long as it is not less than the number of characters in the longest record currently in the index. If the index contains any records Cindex displays that number in the box to the right.

### Changing the Number of Fields

A record must contain at least two fields (a heading field and a locator field), and may contain up to sixteen. By default, Cindex allows records to have variable numbers of fields up to five, and adds or removes fields automatically as you enter text in records. You can set minimum and maximum numbers of fields that records may contain.
Specifying the Structure of Records

To set the maximum number of fields, choose from the Max drop-down list. (Cindex does not display numbers smaller than the number of fields in the record that contains the most fields.)

To set the minimum number of fields, choose from the Min drop-down list. If you change the minimum number for an index that contains records, Cindex will examine all records, adjusting the number of fields if necessary.

If you set the minimum and maximum to be the same, records will contain a fixed number of fields.

Special Last Text Field

You can arrange that each record will contain a special subheading field that immediately precedes the locator field. Other subheadings will always be placed above this special field, which cannot be split or separated from the locator field. You might use this special field to store a comment or a URL, etc. To enable this attribute of the last text field, check Subhead Preceding Locator is Required. (This is dimmed unless you have specified that the records have at least 3 fields.) At your option Cindex can ignore the special last field when sorting records (see “Ignoring the Lowest-Level Subheading” on page 150) and can hide it when it displays a formatted index (see “Typography and Punctuation of Headings” on page 181).

When you set properties of record fields (below), or specify the formatting of headings (via Headings… in the Document menu) Cindex will identify the special subheading level by displaying an asterisk (*) beside its name.

When exporting a formatted index in a file, Cindex treats the special heading as though it were at the deepest level permitted in the index, and applies the formatting associated with that level.

Specifying Field Names, Sizes and Contents

You can provide a name for each field in a record. Cindex displays field names in various drop-down lists and in the record window. You can also specify the maximum and minimum number of characters each field may contain, and a tem-
Managing Fonts

plate that its contents must match before Cindex will save the record in the index.

Click the tab corresponding to the field you want to work with (First for main heading, Second for subheading, etc. The last tab is always reserved for locators.)

- To change the field name type a name in the Field Name box.
- To specify a minimum number of characters the field must contain, enter the number in the Minimum Chars box. If you set 0, Cindex sets no minimum value. (You cannot set a minimum if the index already contains entries; in that case, Cindex displays the number of characters in the record with longest field.)
- To specify a maximum number of characters a field can contain, enter the number in the Maximum Chars box. If you set 0, Cindex sets no maximum value.
- To specify a template that text in a field must match, enter at Match a pattern to define the template. See “Patterns” on page 239 for information on defining and using patterns. If you leave Match empty, Cindex accepts any text in a field.

Using Field Templates

When you make or modify a record, and Cindex finds a mismatch between the contents of a field and a template you have defined for it, Cindex can ignore the error, warn you about it but accept it, or refuse to accept it. To specify how Cindex should behave, choose Preferences… from the Edit menu, and click the Editing tab. Make your setting in the box labeled Mismatch to Template:

- Click Accept to make Cindex accept mismatches.
- Click Warn to make Cindex will warn you on your first attempt to save a record with a field whose contents do not match its template; Cindex will always accept the record on your second attempt.
- Click Forbid to make Cindex refuse to save a record in which the contents of a field do not match its template.

MANAGING FONTS

Cindex provides tools to check which fonts are used in an index, and to make substitutions among fonts. You might need to make a substitution when you work on an index that has been moved from another computer, and uses fonts not available on yours.
Managing Fonts

To cope with potentially missing fonts, Cindex maintains an alternative font for each (preferred) font you use in your index. Cindex always uses the preferred font when that exists on your computer. If you open an index that uses a missing preferred font, Cindex automatically substitutes the alternate font when displaying entries. If you later move the index to a computer that provides the preferred font, Cindex will revert to using it. If you open an index in which a preferred font and its alternate are missing, Cindex will display a dialog through which you must specify an alternate font from among those present on your computer. See “Substituting Fonts” on page 216 for more information on this.

To manage fonts choose Fonts… from the Tools menu. Cindex will display the dialog box shown in Figure 66.

![Manage Fonts](image)

**FIGURE 66.** Managing Fonts

Checking Font Use

The table shows the preferred fonts you have used, together with their alternates. The first font in the table is always present, and is the default font used for the standard display of entries. Additional fonts in the list are those you have used in records, or to display formatted headings, etc.

If you cease to use a font, Cindex does not immediately forget it. To make Cindex update its list to display only fonts that are currently in use, click **Clear Unused** (this button is dimmed if all fonts in the list are used).
Specifying Attributes of New Indexes

Substituting Fonts

You can change the preferred and alternate fonts Cindex uses in an index. To change a font assignment:

- Click the list to select the row for the font you want to change.
- To specify a preferred font choose from the Preferred drop-down list (or type its name if the name is not in the list—a preferred font need not be one available on the computer you are using). If you enter the name of a font that is not available on your computer, Cindex will use the alternate font, and will revert to the preferred font when that becomes available.
- To specify an alternate font choose from the Alternate drop-down list. An alternate font must be chosen from among those available on the computer you are using.

If you move an index to a computer that lacks any preferred font, Cindex will use the alternate font. If the alternate is not available, Cindex will display the font-substitution dialog box when you open the index, so that you can choose an alternate from among those available. A missing alternate font is indicated by a gap where its name would be displayed. To specify a new alternate font, choose from the Alternate drop-down list in the appropriate row.

When Cindex includes font information in a formatted document, it includes information about preferred fonts, not alternate fonts.

SPECIFYING ATTRIBUTES OF NEW INDEXES

Modifying Cindex Default Settings

When you create a new index, Cindex provides it with standard default settings for record structure and reference syntax, and for sorting and formatting entries. These settings have initial values assigned when Cindex is first installed, but you can change them so that any new index you create starts with settings you prefer.

To change the default settings Cindex will bestow on new indexes it creates, close all open indexes (you can use Close All from the Window menu) and choose from
Getting Information About Indexes

the appropriate menu the item whose default values you want to set. You can set default values for all items in the Document menu, and for Sort… in the Tools menu. (Items for which you cannot change default settings are dimmed). The settings you make when no indexes are open become the default ones that Cindex applies to new indexes.

To restore the default settings to their original installed values, quit Cindex and restart it while holding down the SHIFT key.

NOTE: When you restart Cindex with the SHIFT key held down, Cindex restores all its settings to their original values (including those of items you set by choosing Preferences from the Edit menu).

Using Templates

When Cindex creates a new index it can use the record structure and other standard settings (for sorting and formatting entries) from an existing index. To use one index as a model for another, you must first create a template. To make a template:

• Open and activate the index you want to use as a model.
• Choose Save As… from the File menu, then select Template from the Save as type drop-down list. When you save an index as a template, Cindex saves information about the structure of records, and all the other settings that belong to the active index, but saves no records.

To open a template choose Open… from the File menu, and from the Files of type drop-down list choose Templates. (You can also open a template by double-clicking its icon in Windows Explorer.) Cindex will ask you to provide a name for a new index, and will then create it with the settings contained in the template.

GETTING INFORMATION ABOUT INDEXES

Cindex can provide several analyses of indexes and the entries they contain.
Getting Information About Indexes

Obtaining General Statistics

To obtain basic information about the index document, such as the times of its creation and modification, and the time you have spent working on it, together with information about the number of formatted entries and the pages they occupy, choose **Index Statistics...** from the Tools menu. Cindex will display the dialog box shown in Figure 67.

![Index Statistics dialog box](image)

**FIGURE 67. Index Statistics**

Click **Go** to start the analysis.

Initially, the panel shows:

- The date and time of index creation.
- The date and time at which the index was last modified.
- The accumulated time the document has been open for work.

To obtain further information, click **Go**. Cindex will examine the index then display the following information:

- The number of printed pages, and lines occupied by the index.
- The number of index entries (this might not be the same as the number of records in the index), and the number of unique main headings.
If you are viewing a fully formatted index (but not if you are viewing a draft index) Cindex will also show:

- The number of page references.
- The number of cross-references.

Normally, Cindex examines all records that are accessible in the current view. Cindex can confine the examination to certain parts of the index.

**NOTE:** Your settings of *Hide by Attribute*... (View menu) determine whether labeled records are accessible in the formatted view.

To examine records that would fall on specified pages (for your current page setup) click **Pages**, and set at **from** and **to** the range of pages you want to examine. Cindex will examine only entries that would fall on the specified pages, were they being printed.

To examine records you have selected, click **Selection** (this is dimmed if no records are selected).

To examine a range of records in the view, click **Records** and specify the starting and ending records in **from** and **to**. You can specify a range of headings by entering leading text, e.g., Abr through Doc. You can also specify a range of record numbers (e.g., 55 through 79) within which Cindex should confine the search. To look among specified headings, you need only provide as much of the beginning text as will identify a record uniquely. You can specify leading text from a subheading by appending a semicolon to the heading text then adding subheading text. To specify a heading that begins with digits, place a \ before the first numeral; Cindex will otherwise interpret leading digits as a record number.

If you omit the first part of the range Cindex will start at the first record in the view and stop at the record at the end of the range. If you omit the second part of the range, Cindex will start at the specified record and continue until it reaches the last record.
NOTE: Before beginning the examination Cindex checks that the last record in the range appears after the first. If the last record appears before the first, Cindex will display a warning message.

Counting Records

To learn about the distribution of records under particular letters of the alphabet or under different headings, and about the numbers of fields and characters they contain, choose Count Records... from the Tools menu. Cindex will display the dialog box shown in Figure 68.

Click Count to obtain a count of the number of main headings that begin with each letter of the alphabet (more properly, the first character on which records are sorted). Cindex will display:

- The number of records examined.
- The numbers of modified, deleted, marked, generated and labeled records (a single record might fall in more than one category). Records carrying different labels are distinguished in the count.
- The number of heading levels in the deepest record.
- The number of characters in the longest record.
Checking Index Entries

Specifying Records to be Counted

- A table showing the numbers of records sorted under each leading character.

Normally, Cindex counts all records that are accessible in the current view. To confine the count to selected records or to a specified range of headings make the appropriate setting under Scope. The scope options are the same as those available when you use Find or Replace, and are described fully in “Scope of Operations” on page 261.

**NOTE**: Your settings of Hide by Attribute… (View menu) determine whether labeled records are accessible in the formatted view.

To confine the count to records that contain references falling within a certain range, define the range in the box Containing Locators. The locators can be simple page references (e.g., 55 and 66) or compound references (e.g., 1997:5a:xv and 1997:7b:xiv). You must supply both starting and ending locators (or none at all). If your locators are simple page numbers, Cindex will display the average number of records per indexed page when it makes the count.

To confine the examination to records with certain attributes (and within the range defined by Scope), check the appropriate attributes (Modified, Deleted, Marked, Generated or Labeled).

Checking Index Entries

Cindex provides a rich set of tools for checking the correctness and consistency of index entries. These are available through Check Index… in the Tools menu.

The available tools fall into three broad groups covering:

- Errors within entries, including misused special characters, misplaced or questionable punctuation, letter case errors.
- Inconsistencies across headings, such as letter case, style or punctuation, or plural forms; also checks for orphaned subheadings.
- Errors in references, such as missing or otherwise incorrect cross-references; overlapping or excessive numbers of page references.
Checking Index Entries

Use the Check Index… panel to specify the checks you want Cindex to make. The following sections describe these. After you have specified the checks you want (which Cindex will remember), check OK. Cindex will then examine all records in the current view, and display a list that identifies any errors, and the records in which they arise.

NOTES:

When checking the index, Cindex ignores deleted records. Cindex also ignores labeled records that you have designated as hidden (see “Displaying Labeled Records” on page 61).

When a particular error (e.g., a space missing before an opening parenthesis) occurs identically in a succession of records, Cindex reports only the first occurrence.

When an error is related to page references, and more than one record contributes references to the set of references, the record number identified in the report will be that of the first record in the set.

Click any item in the list (or use the ↑ and ↓ keys) to bring its record into view in the main document window; double-click an item (or hit RETURN) to open a window in which to edit its record.

Basic Checks

Basic checks on punctuation and letter case are available on the Basic tab of the Check Index… panel.
Checking Index Entries

**FIGURE 69. Check References sheet**

| Misused Special Characters | This checks that special Cindex characters ~ \ { } < > are correctly used in records (e.g., that a ~ is not the last character in a record field). This check cannot be disabled. |
| Misplaced or Questionable Punctuation | This checks for such things as spaces before closing punctuation, repeated punctuation, and questionable sequences of punctuation characters. |
| Missing Spaces | This finds instances of misplaced parentheses or brackets. It does not flag cases such as ‘Innovation(s)’ or ‘waltz(es)’, and will ignore any parenthetical suffixes to numbers, such as 401(k). |
| Unbalanced Parentheses or Brackets | This finds instances of unmatched opening/closing parentheses or brackets. |
| Unbalanced Quotation Marks | This finds instances of unmatched opening/closing quotation marks. |
| Mixed Case Words | This finds letter case errors. It will not flag a word that has an initial cap only, or words that are plural acronyms (e.g., EFTs). |
Consistency of Headings

These checks, available on the **Headings** tab of the **Check Index**… panel, compare heading content (at all levels above the locator field) in successive records, and flag records in which the differences between records are probably errors.

![Check Index panel](image)

**FIGURE 70. Check References sheet**

- **Capitalization**
  This finds headings that are identical except for letter case.

- **Style and Typeface**
  This identifies entries that are identical except for text style (boldface, italics, etc.) and/or font.

- **Punctuation**
  This finds headings that are identical except for punctuation.

- **Leading Conjunctions/Prepositions**
  Flags headings that differ in a leading conjunction or preposition. When making this check, Cindex uses conjunctions and prepositions from the list for making smart flips in records (**Smart Flip Words**… in the Document menu).

- **Endings**
  This checks for three different kinds of inconsistencies in headings:
  - Inconsistent plural endings, e.g., otherwise identical headings end in ‘berry’ and ‘berries.’
Checking Index Entries

- Headings that differ in a terminal conjunction or preposition. When making this check, Cindex uses conjunctions and prepositions from the list for making smart flips in records (Smart Flip Words... in the Document menu).
- Headings that are identical except for any ending phrase in parentheses.

Orphaned Subheadings

This identifies records that contain subheadings that are unnecessary (ones that occur as the only subheading below a heading at the level you specify), and are therefore candidates for removal, or pulling up as modifying phrases to the level above.

**NOTE:** Cindex can convert orphaned subheadings for you, either by removing them, or pulling them up as modifying phrases to the headings at the level above. See “Reconciling Heading Levels” on page 99.

Cross-References

As you enter a cross-reference in a record, Cindex can check and warn you if there is no target entry (see “Checking Cross-References” on page 47). Through the References tab of the Check Index... command you make additional checks: that cross-references are not circular, that they are of the right type (e.g., see or see also), and that they match in letter accent and case. To help you decide when double-posting would be preferable to making a cross-reference, Cindex can also find cross-references made to a heading under which there are fewer than a specified number of entries. To enable verification, check Verify Cross-References.
Checking Index Entries

FIGURE 71. Check References sheet

If a record contains several cross-references, Cindex will check all of them, as long as each reference is separated from the next by a semicolon (;) or some other punctuation mark you have designated (see “Specifying the Structure of Cross-References” on page 112).

NOTES: Cindex looks only among records accessible in the current view when seeking target entries.

Cindex ignores deleted records, both as the sources and the targets of cross-references. Cindex also ignores as sources any labeled records that you have designated as hidden (see “Displaying Labeled Records” on page 61).

Cindex maintains a list of words that introduce general cross-references that it will not attempt to verify (Cindex will, however, alert you if you make a general cross-reference of the wrong type). When Cindex is installed this list contains the words ‘individual’ and ‘specific’. (“Specifying the Structure of Cross-References” on page 112 describes this list and how to modify it).

Cindex normally accepts as a legitimate cross-reference a shortened form of the main entry, or one that differs in letter accent or case, so it will not object to
Checking Index Entries

cross-references of the kind shown below, where the See also reference is a short form of the complete entry.

Austin, Emily Margaret Brown (daughter of MA)...
  ...
  ...
  Bryan, Emily Austin. See also Austin, Emily Margaret

Cindex will also accept a cross-reference to a subentry made by referring to the entry as if the subentry were a modifier. The reference

Bone
tuberculosis of. See Tuberculosis, skeletal
tumors, 1878
  ...
  ...
Tuberculosis
  skeletal, 2306

might be directing the reader to the subentry “skeletal” under the entry “Tuberculosis,” or it might refer to the modified heading “Tuberculosis, skeletal.” When Cindex encounters a cross-reference that has some qualifying phrase after a comma it first tries to find the modified heading (i.e., “Tuberculosis, skeletal”). If it fails to find that heading, it will try to find the heading “Tuberculosis” with the subheading “skeletal.” If the cross-reference contains multiple phrases separated by commas, Cindex assumes that the candidate subheading follows the last comma.

To insist that Cindex find an exact match (including letter accent and case) between a cross-reference and its target entry (and therefore flag references of the forms shown in the examples above) check Require exact matches. When you insist on exact matches, Cindex requires only that the text of the cross-reference matches that of the target; styles and fonts are ignored (style/font mismatches are reported separately).
Finding References to Too Few Target Entries

A cross-reference can often be dispensed with altogether, and replaced with a full entry, when the heading to which it refers carries one or few entries. Cindex can flag cross-references made to fewer than a certain number of entries. (Cindex must always find at least one target of a cross-reference, otherwise it flags a reference as missing.) Set \textbf{Require at Least $N$ Matches} to the minimum number of target entries Cindex must find for each cross-reference.

\textbf{NOTE}: Cindex can automatically convert cross-references to fully-qualified entries. See “Converting Cross-References to Fully-Qualified Entries” on page 114.

Cindex will report the following kinds of errors:

- \textbf{Missing target}: a cross-reference to a heading that was not in the index or (if you have checked \textit{Require exact matches}) whose text did not fully match that of the target.
- \textbf{Inexact match}: a cross reference that differs from its target in style or letter case.
- \textbf{Circular or open}: a cross-reference that refers to another cross-reference.
- \textbf{Too Few targets}: a cross-reference that refers to a heading with fewer than the stipulated minimum number of subentries (see “Finding References to Too Few Target Entries” on page 228).
- \textbf{Type}: a \textit{See} cross-reference that should have been a \textit{See also}, cross-reference (or \textit{vice-versa}). This indicator can accompany any of the others, above.

\section*{Page References}

While you are entering records in the index Cindex makes a variety of checks to ensure that the references are properly formed and fall within acceptable ranges (see “Checking Locators” on page 46). Through the \textit{References} tab of the \texttt{Check Index…} command you can make additional checks.

To find entries that make too many undifferentiated references from a particular heading, even if these occur across multiple records, check \textit{More than $N$ undifferentiated}, then enter the maximum acceptable number of undifferentiated locators.

\textbf{NOTE}: Cindex counts references as they would be displayed in the formatted index.

To find cases where a single reference is duplicated, or a single reference or a range of references overlaps another range check \textit{Overlapping ranges}. When deal-
Expanding Index Entries

...ing with references that contain non-numerical suffixes, (e.g., 37t), or are styled (e.g., 522), Cindex examines them for potential overlap only if the suffix is the same, or the style is the same. When dealing with compound (multi-part) locators (e.g., 25a:64), Cindex examines them for potential overlap only if all segments but the last are identical.

To identify entries in which any heading level above the lowest subheading has a reference attached to it, check **On headings above lowest**. (Some publishers require that page references appear only at the lowest heading level.)

EXPANDING INDEX ENTRIES

A Cindex record often contains several page references or cross-references. This usually makes it easier to work with entries, and helps keep down the size of index documents. Sometimes you might need to work with groups of records that refer to different sets of pages (for example, if chapters are moved or repaginated after you have prepared an index), and then it is often easier to deal with records that each contain only a single page reference or cross-reference.

Cindex can unpack references from records that contain more than one, and generate new records as necessary, so that none in your index contain more than one page reference or cross-reference. To expand an index in this way, choose **Expand** from the Tools menu. Before you can do this the main view must show **All Records**; you cannot expand an index when viewing new records, or a group.

**NOTES:** When Cindex expands references, it normally recognizes successive page references separated with a comma, and successive cross-references separated with a semi-colon. If you have used different characters to separate these two kinds of references, you should ensure that Cindex knows what they are. “Specifying the Structure of Page References” on page 126 explains how to specify the page reference separator; “Specifying the Structure of Cross-References” on page 112 explains how to specify the cross-reference separator.

When Cindex expands an index it invalidates any record groups that belong to the index. “Rebuilding Groups” on page 233 explains how you can restore invalid groups.
COMPRESSING INDEX ENTRIES

While working on an index you might create records that are exact duplicates of others, and you might create some empty records. You will also probably have deleted some records. Cindex never displays or prints any of the above kinds of records in a fully formatted view, so you can safely leave them in the index, but if you want to reduce the size of your index you can remove them permanently.

To remove records permanently, choose Compress… from the Tools menu. Cindex will display the dialog box shown in Figure 72. Compress… is available only when the view is set to show All Records. It is dimmed if you are viewing new records, or a group.

Removing Unnecessary Records from the Index

To remove records that contain no text check Remove Empty Records.

To remove deleted records check Remove Deleted Records.

To remove exact duplicates check Remove Duplicated Records. Cindex cannot remove duplicated records if the index is sorted in page number order, in which case this item is dimmed.

Click OK to remove the chosen records.
Compressing Index Entries

NOTE: When Cindex removes records from an index it renumbers those that remain. You should not rely on a record having the same number before and after you compress an index.

Cindex uses a record’s number to keep track of its membership in any group. Because record numbers often change when you compress an index, Cindex invalidates all the groups. For information on reconstructing invalid groups, see “Managing Groups” on page 232.

Removing Generated Records

Cindex can automatically generate cross-references for an index (see “Generating Cross-References Automatically” on page 115 for more information about these), and can automatically convert cross-references to fully-qualified entries (see “Converting Cross-References to Fully-Qualified Entries” on page 114). When Cindex does either of these things, it creates new records, and keeps track of them.

To remove records that were automatically-generated check Remove Generated Records.

NOTE: If you edit a record that contains automatically generated text, Cindex no longer considers it to be a generated record.

Consolidating References from Multiple Records

As you build an index you might create several records that are identical except for their page references or cross-references. This is of no real consequence, because Cindex always aggregates references when it displays or prints a fully-formatted index, but the index document might be larger than it needs to be. To simplify the organization of records, Cindex can merge the identical entries, putting all their page references and cross-references into as few records as possible, and deleting any unnecessary records that result.

To consolidate references from records that have identical headings, and to remove records that are no longer needed, check Consolidate References. Cindex will not normally consolidate references from records that carry different labels.
Managing Groups

To consolidate regardless of record labels, check **Ignore different Labels**. When Cindex consolidates across records with different labels, the resulting record carries the label (if any) of the first of the set.

**NOTES:** Cindex cannot consolidate references and remove duplicated records if the index is sorted in page number order. If the index is sorted by page number, **Consolidate References** is dimmed.

When Cindex consolidates references, it normally separates successive page references with a comma, and successive cross-references with a semicolon. If you have used other characters to separate these two kinds of references, you should ensure that Cindex knows what they are. See “Specifying the Structure of Page References” on page 126, and “Specifying the Structure of Cross-References” on page 112.

When you click **OK**, Cindex will accumulate references where it can. If there are more references than can be placed in a single record, Cindex will retain as many records as it needs.

**MANAGING GROUPS**

Cindex provides several tools for managing groups of records you have defined. You can get information about how and when they were formed, you can delete them, or you can rebuild them by applying the search criteria used in their formation.

You may need to rebuild groups after using either of the tools **Expand**… or **Compress**… Both of these operations invalidate existing groups in an index.

To manage groups, choose **Groups**… from the Tools menu. Cindex will display the dialog box shown in Figure 73.
Getting Information About Groups

When Cindex makes a group, it saves information about the group, including:

- The number of records in the group.
- The time the group was created.
- How the group was made (from a selection or from search results). If the group was made from search results, Cindex saves information about the search.
- Whether the group has been changed since it was created.
- How the group is sorted.

To view a digest of this information, click Info…. Cindex will display a dialog box containing information about the group.

Rebuilding Groups

Cindex knows how a group was made originally (e.g., from a search, or from a selection of records). If a group was made from a search, Cindex can rebuild it using the original search criteria.

To rebuild one or all groups that belong to an index choose from the Group drop-down list the name of the group you want to rebuild, (or click All Groups to rebuild all of them), then click Rebuild.
Cumulating and Combining Indexes

NOTE: Although Cindex applies the correct search criteria when rebuilding a group, it does not keep information about the records it should examine. For example, it does not know if a group to rebuild was formed by a search of the whole index, or a search of another group.

Removing Groups

To remove a group choose the group you want to delete from the Group drop-down list (or click All Groups if you want to remove all of them), then click Delete.

When Cindex removes a group it deletes only the information it has stored about which records belong to the group; Cindex does nothing to the records themselves.

Linking Cross-References

Cindex can find and add to a group all the records that make cross-references to records already in the group. You might want this when a work you have indexed is broken into multiple volumes, and you want to find all the records that belong to each volume. (For more information on breaking indexes see “Breaking an Index into Parts” on page 236).

To add to an existing group all the records containing cross-references to records already in it, choose the group from the Group drop-down list (or click All Groups to link cross-references for all of them), then click Link Cross-References (this is dimmed if the index is not sorted alphabetically). When you click OK Cindex will examine all records in the index, and will add to the group any record that contains a cross-reference to a record already in the group.

CUMULATING AND COMBINING INDEXES

Indexes to serial publications are often cumulated at intervals, and indexes to individual volumes in a multi-part series are often combined into a single master index. Cindex copes efficiently with these kinds of tasks, relieving you of most of the work. The following sections explain how to proceed.
Managing Locators in Cumulations

Locators in cumulated indexes will often need to be adapted from their forms in the component indexes. Usually you will need to do one of two things:

- If only the *indexes* to volumes are being cumulated, you will probably need to attach some kind of volume identifier to page references from each component volume.
- If the *contents* of volumes are being combined to make an integrated volume, pages will probably be renumbered, and you will need to adjust the page references in the index entries.

Cindex provides different means for modifying locators, depending on the kind of change you need to make. It is easiest to change locators *before* adding records to the combined index.

Adding Volume Numbers

If you are combining several indexes and need to add volume numbers to the page references in the component indexes, follow the directions given in “Adding Volume Numbers to Page References” on page 250.

Adjusting Page Numbers

If a publisher combines the contents of several volumes into a single one with a uniform run of page numbers, the page references for entries in the indexes to component volumes will need to be adjusted. You can use *Alter References*… from the Tools menu to adjust page references in the component indexes before adding records to the combined index. For information on how to do this see “Adjusting References” on page 92.

Building the Master Index

After having made any necessary adjustments to page numbers, follow these steps to build a master index:

1. Create a new index that will contain the cumulated or combined components. Do not be concerned about the record size; Cindex will re-size the index if necessary when it adds records to it.
2. Open a component index that you want to include in the master index.
3. Select the records you want to include in the master index (choose Select All from the Edit menu if you want to include all records).

4. Drag the records to the main window of the master index.
   Alternatively, copy the records (choose Copy from the Edit menu), activate the master index (click its main window, or choose it by name from the Window menu), then paste the records (choose Paste from the Edit menu).

5. Repeat steps 2 through 4 for each component index.

BREAKING AN INDEX INTO PARTS

Single volume works are sometimes broken into multiple (spinoff) volumes, each with its own index. In such cases one wants to extract from the index to the single volume the entries that will belong to the separate volumes (adjusting page references if the text pages have been renumbered).

Follow these steps to break out the appropriate records into separate indexes.

1. Ensure that each record contains a single locator. If any records contain more than one page reference, choose Expand from the Tools menu. For more information see “Expanding Index Entries” on page 229.

2. Find page references that belong to each spinoff volume. With the view set to show all records, choose Find from the Edit menu. In the Find window set the drop-down list under the search text to confine the search to the locator field (usually named Page field), and check Evaluate References. Enter as search text the range of page numbers that are to be included in the spinoff volume. (For more information see “Searching for Locators” on page 78.) Click Find All to locate all records that refer to these pages. Cindex will make a temporary group that holds the results of the search.

3. Choose Save Group… from the File menu to create a permanent group from the results of the search. Use a name that helps you identify the spinoff volume.

4. Choose Groups… from the Tools menu, then in the dialog box Cindex displays click Link Cross-References (ensure that the list shows the name of the group you have just made). When you click OK Cindex will examine all records in the index, and will add to the group any record that contains a cross-reference to a record already in the group.

5. Repeat steps 2 through 4 for each set of pages that will constitute a different spinoff volume.
Working with Spinoff Indexes

The pages in a spinoff volume are usually numbered differently from their counterparts in the original volume (each spinoff volume is likely to have its first page numbered 1). You will therefore probably need to adjust the page references in the group of records that represent each component index.

If you are confident that no records in the parent index appear in more than one of the groups (a record might appear in more than one group if the spinoff volumes have some content in common), you can make the required page number adjustments on each group of records separately. However, it is generally advisable to make a completely new index for the records in each group. To do this:

1. Activate the main view window for the parent index.
2. Set the view to show the group for a spinoff index (choose the group from the View menu).
3. Select the records in the group (choose Select All from the Edit menu).
4. Copy the records (choose Copy from the Edit menu).
5. Create a new index for the group. Do not be concerned about setting the right record size—Cindex will re-size the index if necessary when it adds records to it.
6. Paste the records (choose Paste from the Edit menu).
7. Repeat steps 1 through 6 for each group that contains records for a spinoff index.

For each new spinoff index, adjust the page references to take account of the changed page numbers. “Adjusting References” on page 92 explains how to do this.
Breaking an Index into Parts
CHAPTER 13 Patterns

You might sometimes need to search for (or replace) a set of characters that meets some general specification, such as “any numeral at the beginning of a line followed by the letter X,” or “any word beginning with an uppercase letter and ending in ‘ing,’” or “any four-digit number beginning with 19 and enclosed in parentheses.” When you use Find… and Replace… you can specify a pattern that describes a class of characters, words or phrases that Cindex should look for (or replace) in the index.

You can also use patterns with Alter References… to specify a class of page references (for example, those in a particular volume) to which you want to restrict page reference adjustments.

You can also use patterns to define templates to which headings in records must conform when you enter them.

Patterns are sometimes called regular expressions. They provide an extraordinarily powerful tool for inspecting and modifying entries in your index. This chapter explains how to form and use them.

FORMING PATTERNS

For the most part patterns consist of ordinary characters for which Cindex searches. For example, if you use Find to search for the following sequence of characters as a pattern (to make Cindex treat the characters as a pattern you must check Pattern in the Find window):
Cindex will display the first record that contains the sequence of letters “abc-defg.” The power of patterns derives from their use of special characters. The following sections introduce these special characters and explain how to use them.

. (period)

The . stands for any character. If you use . in a pattern Cindex will find a match to any character. For example, to find records that contain sequences of three letters that begin with ‘c’ and end with ‘t’ you would use the pattern

```
c.t
```

You can use . as often as you like and in combination with other special characters described below.

[: :] (character set)

Within [: :] you specify a character that is a member of a set. For example, [:letter:] identifies the set of letters. If you specified the pattern

```
[:letter:]
```

Cindex would find a match to any letter (in any script). To specify a character that is not a member of the set, place a ^ immediately after the opening square bracket, e.g.

```
[^:letter:]
```

Cindex recognizes many kinds of character sets, such as currency symbols, diacritical marks, and classes of punctuation. Table 3 identifies some of those. You can use the full name or the short name when specifying a set. The collection of character sets that Cindex recognizes corresponds to the Unicode Char-
Cindex provides a set of ready-made patterns to help you search for character classes. See “Using Patterns with Find” on page 249.
Cindex also recognizes many script sets, such as [:arabic:], [:devanagari:], [:cyrillic:], [:greek:], [:han:], [:hangul:], [:hebrew:], [:katakana:], [:latin:]. For a complete list see http://www.unicode.org/charts/#scripts.

You can form new character sets by combining existing ones.

- To make a set that is the union of other sets, just concatenate them:
  [:letter:][:symbol:] (or [:l:][:s:]) is the set of all letters and all symbols.
- To make a set that is the difference of two sets, connect them with -
  [:letter:]-[:latin:] is the set of all letters from scripts other than latin.
- To make a set that is the intersection of two sets (the set of characters common to both), connect them with &:
  [:letter:]&[^:han:] is the set of all letters that are not Han.

[ ] (square brackets)

If you enclose a set of characters in square brackets, Cindex will find a match to any one of the characters in the brackets. The pattern below will find records that contain any of the following sequences: 1985, 1986 or 1987.

198[567]

You may include character sets as elements within square brackets, e.g.

[[[:digit:]abc]]

will find any digit followed by the letter ‘a’ or ‘b’ or ‘c’.

When you use [ ] to search for any of a contiguous range of characters, you need not specify every character explicitly: you can specify just the first and the last, separating them with a hyphen. Thus [a–z] will match any lowercase letter, and [0–9] will match any single numeral. When you use the – (hyphen) to specify an inclusive range of characters, Cindex understands the range to include all characters having Unicode values between the lowest and the highest.
any character from a set it is generally better to use a named set (e.g., [:lowercase letter:] than to enumerate the characters.

You can search for a character that is not in the set by placing a ^ (caret or circumflex) immediately after the opening square bracket. To find any number that is not followed by a space, you could use the following pattern:

\[0-9]+[^0-9 ]\]

(See below for an explanation of + .) The caret is special only if it appears as the first character inside the brackets. The . and some other special characters described below lose their significance (and are treated as ordinary characters) when they are included in a set enclosed by [ ]. To search for one of a set of characters that includes ] (the closing square bracket), you must place that bracket first in the sequence, immediately after the opening square bracket or after any initial ^. The – (hyphen) loses its special significance when it occurs as the first character (or after any initial ^) or the last character inside square brackets.

\(\text{parentheses}\)

When you form a pattern you can group elements of it by enclosing them in parentheses ( ). Such a group is called a subpattern. When finding a match to the whole pattern Cindex keeps track of the text matched by any subpattern, and allows you to use that text as part of what must be matched later in the pattern.

Suppose you wanted to find all records in which you had typed a word twice in succession. The solution is to match the first occurrence of the word with a subpattern and check whether the text matched by this subpattern appears a second time after an intervening space. You can do this by using the following pattern:

\(\backslash b[:l:]++ \backslash 1\)
Forming Patterns

The pattern can be read as “any sequence of one or more letters starting on a word boundary, followed by a space, then by a second occurrence of the same sequence of letters.” It can be dissected as follows:

\b specifies that the following element occurs at the start of a word (see later discussion of \).
[:l:] specifies any continuous sequence of letters.
+ specifies one or more occurrences of the preceding element (see later discussion of +).
( ) enclosing [[[:l:] ]] + marks it as a subpattern.
\1 denotes whatever text was matched by the first defined subpattern.

Properties of Subpatterns

You can define up to nine subpatterns in a single pattern, so to refer to text matched by a particular subpattern you must identify the one you want. Cindex provides a simple convention for this. It numbers subpatterns implicitly from left to right, by their order of appearance in the pattern. To refer to a subpattern, use \ followed by a numeral in the range 1-9. For example, \1 denotes the text matched by the first subpattern, \7 the text matched by the seventh.

You can nest subpatterns, i.e., you can include one subpattern inside another. When you do this the outer patterns have lower numbers.

If you use \N where N refers to a subpattern that has not yet been defined, Cindex will display a warning message.

Parentheses have no special significance if they appear within [ ].

A later section, “Including Parts of Matched Text in the Replacement” on page 252, explains how you can use subpatterns with Replace to rearrange text in records.

* (asterisk)

The * stands for any number of occurrences (including none) of the preceding element. This can be a character matched by a set enclosed in [ ], e.g., [0-9]*, or a
character from a set, e.g., [:l:]*, or a subpattern, e.g. cat(s)*. You can refer to a previously defined subpattern with an expression of the form \(N\)*, where \(N\) is a digit in the range 1–9. This means “any number of occurrences (including none) of what was matched by subpattern \(N\).” To find anything in parentheses, search for

\[
\text{(.*\text{ })}
\]

The * finds the maximum possible number of matching occurrences of the preceding element.

**NOTES:** If multiple parenthetical phrases occur in a field, a match to the above pattern would span all of them. For a pattern to capture text in a single set of parentheses, see “Minimal Matches” on page 246.

If you want to find text contained in parentheses, but exclude the parentheses from the match, Cindex provides a ready-made pattern. See “Using Patterns with Find” on page 249.

The * has no special significance if it is the first character in a pattern or if it appears in a set of characters contained within [ ].

**NOTE:** Because * can match 0 occurrences of the preceding element, patterns like [0-9]* can match an empty field. Cindex ignores any such empty matches.

**+ (plus)**

The + stands for one or more occurrences of the preceding matched element. This element can be a character matched by a set enclosed in [ ], or one from a character set, such as [:l:], or a subpattern.

The + finds the maximum possible number of matching occurrences of the preceding element.

The + has no special significance if it is the first character in a pattern or if it appears in a set of characters contained within [ ].
? (question mark)

The ? stands for zero or one occurrence the preceding matched element. This element can be a character matched by a set enclosed in [ ], or one from a character set, such as [:l:], or a subpattern.

Minimal Matches

The ? has an additional special role when it follows * or + or ? or a number in braces (see below). It is used to ensure that the matched text is the least that satisfies the pattern. For example, to find a single phrase in quotes in a record field that might contain multiple phrases in quotes, use this pattern:

".*?"

The ? has no special significance if it is the first character in a pattern or if it appears in a set of characters contained within [ ].

{N,N} (number or numbers in braces)

A number N in braces specifies how many occurrences of the preceding element are to be matched. This can be a character matched by a set enclosed in [ ], or one from a character set, such as [:l:], or a subpattern. For example, to find any 5-digit number search for.

[0-9]{5}

The braces may contain two numbers separated by a comma, where the first specifies the minimum number of matches required, and the second specifies the maximum number of matches. Thus

[0-9]{3,5}

finds any number that has 3, 4 or 5 digits. If the second number is omitted, e.g., {3,} the match must satisfy at least the minimum. Cindex normally seeks the greatest number of matches that satisfy the pattern. If ? follows the braces, as in
Forming Patterns

{3,5}? or {3,}? Cindex will seek the smallest number of matches that satisfy the pattern.

| (vertical bar)

The | separates alternative patterns to match. To find a match to "cat" or "dog," search for

\texttt{cat|dog}

You can specify multiple alternative matches (e.g., \texttt{cat|dog|canary|snake}). The | causes everything to its left (as far as a preceding |) to be treated as one pattern to match, and everything to its right (as far as a succeeding |) as an alternative pattern to match. You can limit the leftward and rightward scope of the | within a larger pattern by enclosing it and its operands in (), thus: (\texttt{cat|dog}).

The | has no special significance if it is the first character in a pattern or if it appears in a set of characters contained within [ ].

^ (caret)

If the caret (circumflex) is the first character in a pattern, Cindex will find a match to the remainder of the pattern only if the match can be made at the start of a field. The pattern

\texttt{^between}

will make Cindex find records that contain the word “between” at the beginning of a field; it will ignore occurrences of “between” elsewhere in a record. Similarly

\texttt{^[[:punct:].[:punct:]}}

will find records in which any field begins with any single character enclosed in any kind of quotation marks.
The ^ is not interpreted literally as a character; it merely indicates that any match to the remainder of the pattern must appear at the beginning of a field. This use of the caret is distinct from its special function as the first character in a series enclosed in [ ]. The caret has no special significance (and is interpreted as an ordinary character) if it occurs elsewhere in a pattern.

$ (dollar sign)

If $ is the last character in a pattern, Cindex will find a match to the rest of the pattern only if the match can be made at the end of a field. The pattern

```
and$
```

will find only the records in which “and” (or some word ending in “and”) appears at the end of a field. $ has this special meaning only if it is the last character in a pattern; it has no special significance (and is interpreted as an ordinary character) if it appears elsewhere.

\ (backslash)

The backslash has three different functions:

1. When placed before certain letters, \ introduces a special operation. A notable one is \b to indicate that the pattern element that follows must match on a word boundary. For example

```
\banti
```

would find a match to “anti” only at the start of a word. For a full list of special operations introduced by \, see www.regular-expressions.info/reference.html.
Using Patterns with Find

2. When placed immediately before any of the characters with special functions:
   * ? + [ ( ) { } ^ $ | \ .
\ causes the following character to lose any significance it would otherwise have in a pattern. For example, to search for any sequence of characters enclosed in square brackets (that is, square brackets are a literal part of the sequence) use
   \[.*\]
   To use a backslash as a literal character in a pattern, place another backslash immediately before it.

3. The \ functions quite differently in a pattern when it is placed immediately before a digit in the range 1 through 9. Here it refers to the text that matches an earlier component in a pattern (a subpattern).

The \ has no special significance when it appears as part of a set of characters contained within [ ].

USING PATTERNS WITH FIND

To simplify your use of patterns, Cindex provides a set of ready-made ones that you can use alone or in combination when searching with Find... To deploy a ready-made pattern, right click or CONTROL click in the box where you enter search text. Cindex will display a contextual menu that offers different kinds of patterns, grouped under General Patterns, Character Properties, and Scripts. When you choose a pattern Cindex enters it in the search box. You can edit the pattern, or combine it with others chosen from the menu.

Remember these points when searching with patterns:

- Cindex searches for text that matches a pattern only when you have checked the Pattern box.
- Any match to a pattern will lie wholly within a single field of a record. Cindex will not find a match that straddles two fields.
- Cindex will always find the longest sequence of characters that matches a pattern, unless you have used ? to specify that the match be the shortest that satisfies the pattern. See “? (question mark)” on page 246.
Using Patterns when Replacing Text

**USING PATTERNS WHEN REPLACING TEXT**

To search for and replace sequences of characters that match a pattern use **Replace...** from the Edit menu, and construct the pattern exactly as you would using **Find...**, as described in the previous section.

A special advantage of patterns in search-and-replace operations is that Cindex can include the characters that match the pattern in the replacement text. That is, the text you are looking for can be put back in the record, augmented by other text, or transformed in one of several ways. The following sections provide examples.

*Adding Volume Numbers to Page References*

Suppose that you have indexed a work in a single volume and have used simple page references, and now need to incorporate the index into a larger one in which references have to be tagged with the number of the volume in which they appear. Consider a series of references such as:

45, 66, 89-91, 200

that you want to convert to

2:45, 2:66, 2:89-91, 2:200

You can easily add a volume number to each reference with the following pattern:

```
Find: [-0-9]+  
Field: All  
Match: Whole Word  
Case: On  
Pattern

Change to: 2\&
```

The pattern tells Cindex to find (in the locator field) the longest sequence that contains one or more digits and possibly a hyphen. In other words the pattern describes a simple page reference or a range of references.
Using Patterns when Replacing Text

The characters \\ (backslash, ampersand) in the replacement sequence denote the text that matched the pattern. When Cindex makes the substitution it incorporates this text in the replacement sequence. Thus Cindex replaces each reference by itself, preceded by the characters \:\.

**NOTE:** To include the \ (backslash) as a literal character in replacement text, it must be preceded by itself (\\). This restriction applies only when you use a pattern. In making ordinary replacements, \ is treated as a literal character.

**Case Conversion**

You can use \& together with the + and – signs to convert words and phrases from lowercase to uppercase and vice-versa. Suppose you have an index in which the first character of every main heading is a lowercase letter and you want to convert it to uppercase. You can do this quite simply with the following replacement:

**Find:** \[[:ll:]]
**Change to:** \&+

This causes Cindex to replace every lowercase letter that occurs at the beginning of a main heading with its uppercase counterpart.

**NOTE:** You need never actually make a change of the kind just shown. Cindex can automatically capitalize the leading letters of headings when it displays or prints a formatted copy of the index. “Typography and Punctuation of Headings” on page 181 explains how.

You could capitalize all of the first word of each main heading with

**Find:** \[[:ll:]]+
**Change to:** \&+

---

*CHAPTER 13  Patterns* 251
Using Patterns when Replacing Text

This causes Cindex to find the longest continuous sequence of letters from the beginning of the main heading, then convert it to uppercase.

You can convert a whole field (for example the main heading field) to uppercase letters with

Find: \^.*$  
Change to: \&+

NOTE: You need never actually make a change of the kind just shown. Cindex can automatically capitalize headings when it displays or prints a formatted copy of the index. “Typography and Punctuation of Headings” on page 181 explains how to do this.

If you include \&– in the replacement text, Cindex will convert to lowercase any letters in the sequence of characters that matches the pattern.

A later section explains how to capitalize the initial letters of every word in a heading.

NOTES: The & in the replacement sequence is interpreted specially only if preceded by \. The + or – has its special effect only if it appears immediately after \&. You can disable the special effect of + or – by placing \ immediately before either character (e.g., \+ or \–).

If the segment of text matched by a pattern is very long, there might not be sufficient space in the record to accommodate it in a replacement phrase. If this happens, Cindex marks the record and displays a warning message when it has finished making replacements.

Including Parts of Matched Text in the Replacement

When you replace text matched by a pattern you can incorporate selected parts of the matched text in the replacement sequence. The following examples exploit this capability.
Changing the Format of References

Suppose that your index contains references to pages in several volumes and that each reference has the form vol: ppp, as in

3:55, 3:66, 4:72, 5:60-63

and you want to change the references so that the volume number appears in parentheses, as in

(3)55, (3)66, (4)72, (5)60-63

You need to find one or more digits followed by a colon, then replace what is matched by that pattern with the same digits enclosed in parentheses. You can do this by exploiting a feature that allows you to include in the replacement text only a part of the sequence of characters that matched the pattern. In this instance you will include just the digits that represent the volume number.

The following operation replaces each volume number and its terminating colon with the same number enclosed in parentheses:

Find: \([1-9][0-9]*\):  
Change to: \(\1\)

The ( ) (parentheses) enclose a part of the pattern (a subpattern) that matches the volume number. The character pair \1 in the replacement sequence tells Cindex that the replacement text should include the characters that matched the first subpattern. Thus the above replacement text can be read as “whatever was matched by the first subpattern, enclosed in parentheses.” The colon is discarded during the replacement.

You can define and use up to nine subpatterns. For more information on subpatterns see “Properties of Subpatterns” on page 244.
Using Patterns when Replacing Text

Capitalizing Initial Letters of Words

To capitalize the initial letter of every word in the main heading you could use

Find: $(\[:ll:]\)\([\[:l:\]*]\)

Change to: $\1+\2$

This causes Cindex to find every continuous sequence of letters that start with a lowercase letter, by matching the first letter with subpattern 1 and any remaining letters with subpattern 2. Cindex then replaces the first letter with its uppercase version and replaces all the others by themselves.

The above operation does not guarantee that all letters after the first in each word will be lowercase—were these uppercase to begin with, Cindex will have left them alone. To ensure that all letters after the first are made lowercase, use the following replacement sequence:

Find: $(\[:ll:]\)\([\[:l:\]*]\)$

Change to: $\1+\2-$

Rearranging the Format of Dates

The following example illustrates how you can use several subpatterns to rearrange the forms of references. Suppose your entries had dates in the form `year:month day` (e.g., 1992:Jun 15) and wanted them to read `day month year` (e.g., 15 Jun 1992). You can define a pattern to recognize a date, identifying each component as subpattern, then rearranging the components by forming a replacement sequence built from text matched by the subpatterns.

Here the three components of the date are matched by three subpatterns connected by the appropriate punctuation:

$\{[12][90][0-9][0-9]\}$ identifies a year in the 20th or 21st century.
Using Patterns when Altering References

Find:  ([12][90][0-9][0-9]):([ADFJMNOS][a-z][a-z]) ([1-9][0-9]*)
Change to:  \3 \2 \1

{[ADFJMNOS][a-z][a-z]} identifies a three letter sequence beginning with the initial capital letter from the name of a month. (A more elaborate subpattern would be necessary to identify months uniquely, but in the context of the overall pattern the form shown here would almost certainly be sufficient.)

{[1-9][0-9]*} identifies a day. (This subpattern does not uniquely identify a legitimate date, because it permits a match to more than 2 digits, but in the context of the overall pattern it is sufficient.)

By forming the replacement sequence from the text elements matched by the subpatterns, but in the reverse order of their appearance in the original record, you have rearranged the dates:

**USING PATTERNS WHEN ALTERING REFERENCES**

When you use *Alter References*... (from the Tools menu) to adjust page references, Cindex normally changes the first number (or range) that falls within the range you specify. If records contain multi-part page references you will probably want to restrict the alterations to a particular segment. You can do this by using patterns, as shown in the following examples.

*Changing Page Numbers in Selected Volumes*

Suppose you have an index with page references like these:

**MED:** 45-47, **ART:** 325, **ART:** 4, **ENG:** 257-261, **HIST:** 3
and you want to change all references in the “ART” volume, but not in any others. You can confine alterations to the correct references by specifying a **Matching Pattern** in the panel (shown in full in Figure 28 on page 93):

Cindex will disregard references that do not contain the characters “ART.” After alteration the references will look like:

**MED: 45-47, ART: 326, ART: 4, ENG: 257-261, HIST: 3**

When you specify a pattern Cindex examines each reference for characters that match the pattern. If part of the reference matches the pattern, Cindex examines the remainder of the reference (i.e., the part that lies to the right of the section matched) and makes the required adjustment if it is in the correct range.

**NOTE:** When a reference is to a range of pages (two parts separated by – or whatever other character to have specified to denote a range), Cindex will apply the pattern intelligently to the second part. For example, if the pattern were MED: Cindex would adjust the second part of the range in both of the following cases: MED:45-47; MED:45-MED:47.

No special pattern-matching characters (e.g., ^ * $) were used in the above illustration, but you may use them as required. For example, to adjust every page number (the last element) in compound references such as

**1988(3)55, 1988(4)66, 1988(5)72, 1988(4)60-63**

you could use the following pattern to exclude all components of the reference up to and including the closing parenthesis:

**Using Patterns when Altering References**
Removing References to Entries in Selected Volumes

You might on occasion need to remove references to selected volumes from the index to a multi-volume work. You can do this very easily with Alter References… by defining a pattern that identifies the volume for which you want to remove references, and then subtracting a very large number from each reference in that volume. Cindex will automatically remove any reference to a page number that would be less than 1. If removing such a reference leaves a locator field empty, Cindex marks the record for deletion. Consider an index in which references had the following form:


To remove from records all references to 1988 set up this adjustment:

The pattern identifies any reference beginning with 1988 and includes all of it up to the page number. For every reference that satisfies this pattern, Cindex will subtract 10000 from the page number. This would make the page numbers less than 0, so Cindex will remove all references to pages in the 1988 volume. Cindex deletes records from which it removes all references.

Indexing with Temporary Page Numbers

Sometimes you will have to index a book before final pagination is known. In such a case you can assign temporary references while you make entries and when you later learn the initial page numbers of chapters you can use Alter References… to make the conversion automatically.
Using Patterns when Altering References

When you index with temporary page numbers you should include with each reference some distinctive means to identify the chapter to which it belongs. For example, if you were indexing chapter 6 you might identify a reference to page 32 with 06%32, where the 06% provides a distinctive identifier. You can use an equivalent notation to identify references to other chapters (e.g., 14%). (You can use other forms of tag to identify a chapter, but you should choose a character or sequence of characters that would not otherwise appear in a reference.) You should identify the chapter with as many digits as there are in the highest numbered chapter, e.g., if the highest-numbered chapter were 23, you would use two digits, placing a leading 0 before any chapter numbered between 1 and 9. Each reference should have its chapter tag placed immediately in front of it.

NOTES: When making a reference to a range of pages (e.g., 54-57) place a temporary marker before the first member of the range only (e.g., 06%54–57).

Be sure that Cindex knows what character you use to separate page references. “Specifying the Structure of Page References” on page 126 explains how to specify this.

When you know the correct first page for chapter 6 (e.g., 189), choose Alter References... from the Tools menu, and set up an adjustment of this sort (see “Adjusting References” on page 92):

This will add 188 to all references that have 06% immediately before them. (We add 1 less than the number of the starting page of the chapter, because temporary page numbers began with 1). Use the same method for other chapters, substituting the appropriate chapter identifier and starting page.
When you have made all your alterations you can remove your temporary chapter markers. If you have used a consistent scheme to mark chapters (e.g., the chapter number always ends with %) you can remove all of them in a single operation. Use Replace… (from the Edit menu) to search for the following pattern (confined to the locator field), and replace each match with nothing:

Find: \[0-9]\+%  
Change to:

This finds in the locator field a number followed by %; it then removes both the number and the % (leaving behind the unadorned page reference).
CHAPTER 14  Reference

This chapter begins with a discussion of certain principles common to a broad range of operations that Cindex undertakes, then briefly summarizes the function of menu items, in their order of appearance in menus.

Where a topic is discussed fully elsewhere in the Guide, a page reference appears in square brackets in the left margin, thus: [155].

SCOPE OF OPERATIONS

When you choose a menu item that initiates some global action on records (for example replacing text, or checking spelling) Cindex confines that action to records accessible in the current view. For example, if the view is set to show only a group of records, the action is confined to that group. Certain actions can be undertaken only when the view shows all records.

Cindex allows you to restrict the scope of many actions to a subset of the records accessible in the current view. For example, when using Find…, or Replace…, or Count…, or certain options of Save As…, Cindex will provide you with options of the following sort:

- To permit the operation on all records accessible in the current view, click All Records in View.
NOTE: When you work with a fully formatted view, deleted records are never accessible, and labeled records are accessible according to your settings of "Hide by Attribute…" (View menu). For more information see “Displaying Labeled Records” on page 61.

- To confine the operation to records you have selected, click Selected Records (this is dimmed if no records are selected).
- To confine the operation to a range of records in the view, specify the starting and ending records in From and to. You can specify a range of headings by entering leading text, e.g., Abr through Doc. You can also specify a range of record numbers (e.g., 55 through 79) within which Cindex should confine the operation. To look among specified headings, you need only provide as much of the beginning text as will identify a record uniquely. You can specify leading text from a subheading by appending a semicolon to the heading text then adding subheading text. To specify a heading that begins with digits, place a \ before the first digit; Cindex will otherwise interpret leading digits as a record number.

If you omit the first part of the range Cindex will start at the first record in the view and stop at the record at the end of the range. If you omit the second part of the range, Cindex will start at the specified record and continue until it reaches the last record in the view. 

NOTE: When Cindex operates on a specified range of records, it proceeds in whatever order the records are displayed on the screen. Before beginning the operation it checks that the last record in the range appears after the first. If the last record appears before the first, Cindex will display a warning message.

When searching for text with Find… or Replace…, Cindex offers a further option to control the scope of the search: you can confine the search to records made or modified between certain dates:

To confine the operation to records last modified on or after a specified start date and before a specified end date, enter the dates in the boxes labeled From and To. Cindex interprets dates in whatever form is standard in the country you are working in (e.g., month, day, year or day, month, year) and can accept dates in a wide variety of forms (e.g., Jan 1 96, 1/1/96, 1 January 96, January 1 1996). If you omit the year Cindex assumes the current year; if you omit the month, Cin-
Toolbars

Index assumes the current month; if you omit the day (providing only a time), Cindex assumes today. Cindex also understands the constructs ‘yesterday’, ‘today’, ‘tomorrow’. Cindex also understands the constructs ‘yesterday’, ‘today’, ‘tomorrow’. If you leave the starting date blank, Cindex assumes January 1, 1970; if you omit an ending date, Cindex assumes a date far in the future.

In many operations (such as searching for text, or counting records), you can confine action to records that possess (or lack) specified attributes. Several of the dialog boxes Cindex displays offer one or more check boxes for the following attributes.

- **New Records.** Records added to the index in your current session with Cindex.
- **Modified Records.** Records changed during your current session with Cindex.
- **Deleted Records.** Records that are deleted.
- **Marked Records.** Records that have been marked because some operation could not be completed (usually because there was insufficient space in the record). The mark remains on the record until you edit it.
- **Generated Records.** Records that contain automatically-generated cross-references.
- **Labeled Records.** Records that you have labeled. When you use Find or Replace you can also specify a particular label.

TOOLBARS

**Font drop-down list** [34]  This list shows the fonts available on your computer.

When the main index window is active any font you choose becomes the one in which all entries are displayed (except where a font has been explicitly specified in a record, or in a format setting).

When the record window is active any font chosen is applied to the currently selected text (the list is dimmed if no text is selected).

**Size list** [34]  The box shows the character size (in points) used by the active index. When the main index window is active you can change the size either by typing directly into the box, or choosing from the drop-down list.
**File Menu**

**Buttons**

Toolbar buttons execute the actions of often-used menu items or, in the case of the two buttons at the right-hand end of the toolbar, switch between commonly used formats that can be chosen via **Style & Layout** in the Document menu.

To learn the function of a button place the mouse pointer over it.

**FILE MENU**

**New...**

This creates a new index, or a new set of abbreviations. Cindex displays a standard dialog box. Choose from the **File of type** list whether to create an index or a new set of abbreviations.

**Options...** (new index only). This displays a dialog box through which you can specify the structure of records (for more information see “Record Structure...” on page 297). You have complete freedom to change record structure before you add records to the index. After the index contains records, you cannot change the minimum number of fields in a record, or the minimum number of characters in a field.

**Open...**

This opens one of several kinds of document that Cindex works with. Cindex displays a standard dialog box through which you can choose the document and the folder that will contain it.

**Files of type.** This list allows you to choose the kinds of documents Cindex will show.

**Read Only.** Check this to open an index as a read-only document (this is dimmed if you select another kind of document). When you open an index as a read only document, you cannot make changes to it.

**Close**

This closes the active window. **Close** has the same effect as clicking the close box at the right corner of the title bar of a window.
**File Menu**

**Save**

This saves to disk the document displayed in the active window.

**Save As...**

This saves the document in the active window under another name and/or another format. Depending on the contents of the active window, Cindex will offer options via the *Save as type* drop-down list.

**Saving Contents of Text Windows**

Cindex can save the contents of text windows as plain text or in Rich Text Format (RTF).

**Saving Abbreviations**

Cindex saves and closes the old set, leaving a copy as the active one.

NOTE: When you save a set of abbreviations under a new name, the saved set becomes the active one. Cindex remembers where this set of abbreviations was saved, and opens it when you begin your next session. To save a copy of abbreviations without that copy becoming the active set, see "Save Backup Copy..." on page 268.

**Saving Indexes**

Cindex can save indexes in several formats. These are summarized below. In some cases Cindex provides options that allow you to specify more precisely what should be saved or how it should be saved.

11. **Cindex Index.** Cindex saves and closes the old index document, leaving a copy as the active index.

217. **Template.** Cindex saves a description of the index (information about record structure, how records are sorted, and the layout of entries in the finished index) but no records, in a document that you can use as a template for creating another index.

201. **XML Records.** Cindex saves index records in a plain format from which you can recreate an index when necessary. This format is useful for backup storage. (For Options see “Options for Saving Unformatted Documents” on page 266).

202. **Cindex Archive.** Cindex saves index records in a compact format that you can use for interchange with earlier versions of Cindex. (For Options see “Options for Saving Unformatted Documents” on page 266).

202. **Delimited Records.** Cindex saves the text of index records as a plain text document that can be read by database programs. The text of each record is contained on a
single line, with each field separated from the next by a ‘tab’ character. (For Options see “Options for Saving Unformatted Documents” on page 266).

[189] **Plain Text.** Cindex saves the text of the index as it would appear in the fully formatted view, but without any style or font information, and without breaking long lines to form runover lines. (For Options see “Options for Saving Formatted Documents” on page 267).

[188] **Rich Text Format (RTF).** Cindex saves the fully formatted index along with information about fonts, styles and layout of headings. The RTF document contains the information a word-processor or desktop publishing program would need to display a fully formatted index. (For Options see “Options for Saving Formatted Documents” on page 267).

[189] **QuarkXPress.** Cindex saves the index as a tagged document for use by QuarkXPress. (For Options see “Options for Saving Formatted Documents” on page 267).

[189] **InDesign Tagged Text.** Cindex saves the index as a tagged document for use by Adobe InDesign.

[194] **XML Tagged Text.** Cindex saves the fully formatted index as an XML document, marked-up with tags you have specified. (For Options see “Options for Saving Formatted Documents” on page 267).

[196] **SGML Tagged Text.** Cindex saves the fully formatted index with embedded tags for typesetting or display by a publishing system. Cindex uses tags you have specified. (For Options see “Options for Saving Formatted Documents” on page 267).

Cindex will display a dialog box that contains some or all of the following elements, depending on the type of document:
Items under **Scope** define the collection of records to be saved. For more information on this see “Scope of Operations” on page 261.

**[203]** Include Deleted Records. Cindex does not normally save deleted records. Check this item to include deleted records in the saved document.

**[204]** Write in Record Number Order. Check this item to make Cindex put records in the document in order of record number. Otherwise Cindex uses the order in which records appear in the current view.

**[204]** UTF-8 Encoding/ANSI Encoding. Specifies whether character values are encoded using UTF-8 (Unicode) or the Windows ANSI character set.

**[204]** Minimum Number of Fields. Plain text records can be written with a minimum number of fields (blank fields are inserted before the locator field if a record contains fewer than the specified minimum).

For saving formatted documents, Cindex will display a dialog box that contains the following elements:
FIGURE 75. Options for saving formatted documents

[191] **Range to Save.** Items define the collection of records to be saved. For more information on this see “Scope of Operations” on page 261.

[192] **Subhead Indent.** Click the appropriate button to specify how Cindex will define leading indents to subheadings in the saved document.

**Paragraph Style Names.** Presents a panel through which you specify the style names for paragraphs in exported documents.

**Save Backup Copy...**

[11] [51] This saves a copy of the document in the active window under another name. You can save either an index or an abbreviation set. The active document does not change.

**Revert to Saved**

[12] This restores the index to its last-saved state (its state when you last saved it with Save... or when Cindex last saved it automatically).

**Save Style Sheet...**

[184] This saves a style sheet that contains all the settings that govern the layout of entries in the formatted index. Cindex saves these settings: **Margins & Columns, Headers & Footers, Grouping Entries, Style & Layout, Headings, Cross-References, Page References** and **Stylish Strings**.
To apply a style sheet to the active index choose Open… from the File menu.

**Import…**

This imports index records from a text document into an index. Cindex can read several document formats, and can usually recognize the format by examining the document’s filename extension and contents. The Files of type drop-down list in the dialog box offers these options:

- **XML Records.** Records are encoded using the XML format recommended for interchange with other indexing software.
- **Cindex Archive.** Records are in the backup format used by earlier versions of Cindex.
- **Delimited Records.** Each record is contained in a single line of plain text, with heading levels separated by ‘tab’ characters.
- **Sky Text.** Records are in the tab-delimited format used by Sky Index 7.
- **DOS Cindex Data.** Records are in the tab- or quote-delimited format produced by the legacy program Cindex for DOS.
- **Macrex.** Records are in the backup format produced by Macrex indexing software.

**New Group**

This makes a temporary group from the records selected in the main index window. This item is dimmed if no records are selected.

**Save Group…**

This converts to a permanent group the temporary group displayed in the main index window. Cindex displays a dialog box in which you type the name you want to give the group. This item is dimmed unless the view shows a temporary group.

**Page Setup…**

This displays the standard Windows dialog box through which you specify paper settings for your printer.
Edit Menu

Print... [83] This displays, with some additional items that are special to Cindex, the standard Windows dialog box through which you specify how you want the document printed.

Recent Files [12] These items identify the most recently used indexes. To open a recently-used index choose it by name from the menu. Via Preferences... you can set the maximum number of filenames displayed.

Exit [11] This saves and closes all open documents, then shuts down Cindex.

EDIT MENU

Undo

In any window containing editable text this undoes your last action (Cut, Paste, etc.) Actions on other windows cannot be undone. This item is dimmed if the last action cannot be undone.

Redo

In a window in which you are editing text this redoes the last action that you undid.

Cut [39] This cuts selected text in a window that contains editable text. The text can be viewed in the Clipboard window (from the Window menu). This item is dimmed if nothing can be cut.

Copy

This copies to the Clipboard the selected items in the active window. The copied selection can be viewed in the Clipboard window (from the Window menu).

If the main index window is active, Cindex copies selected records.
Edit Menu

[39] If a text-editing window is active, Cindex copies selected text.

Paste

This pastes items from the Clipboard to the active window. This item is dimmed if the clipboard contains no object of a kind that can be pasted into the active window.

[54] If the main index window is active, Cindex pastes records.
[39] If an editable text window is active, Cindex pastes the text at the insertion point (or replaces any selected text).

Clear

If the active window contains editable text, this removes any selected text.

Select All

This selects all items in the active window.

New Record

[22] This opens a window (below) that contains a new, empty record.

[(Image)] FIGURE 76. Window for adding or editing records

Edit Record

[37] If a main index window is active, Cindex opens a window that contains the text of the first selected record.
**Edit Menu**

**Duplicate**

[53] If the main index window is active, this duplicates the selected record(s). If you duplicate a single record, Cindex immediately opens it for editing; if you duplicate several records, Cindex puts them in a temporary group and displays that group in the main window. This item is dimmed if nothing is selected.

[53] If the record window is active and contains an existing record (not a new one), this saves the record and displays a copy of it.

**Demote Headings**

Places a block of existing entries as subentries under a new heading.

**Deleted**

[54] When the main index window is active, this deletes or undeletes selected records. Deleted records are invisible in a formatted view, but remain in the index until you compress it with Compress… from the Tools menu. In any draft view of the index, a deleted record is identified by a x beside it.

When the record window is active, this deletes or undeletes the record (the status line at the bottom of the window will show 'Deleted' if the record is deleted).

**Labeled**

[55] When the main index window is active, this applies the specified label to selected records if the first record in the selection does not already carry that label; otherwise it removes the specified label from all selected records that carry it.

When the record window is active, this applies the specified label or removes a label from the active record (the status line at the bottom of the window will show 'Labeled' if the record is labeled).

**Find…**

When the main index window is active, this displays a window (Figure 77) through which you can search for text in records.
Items in the **Scope** box control the scope of the search. For more information on them see “Scope of Operations” on page 261.

Items in the **Only Among** box specify the attributes records must have to be included in or excluded from the search. For more information see “Using Record Attributes” on page 77. If any attributes are checked, you can find records that have (or lack) these attributes simply by specifying no search text.

**Find/Find Again/Resume.** Click this to find the first/next occurrence of the search text (or the first record with the checked attributes, if no search text is specified).

**Find All.** Click this to find all records that contain the search text (or have the checked attributes, if no search text is specified). Cindex makes a temporary group for the records.

**Reset.** Click to clear the current settings and set up for a new search.

Enter the search text in the box marked in Figure 77. The following items govern how Cindex treats this text.

**Not.** When this is checked Cindex finds records that do not contain the specified text or the specified text attributes.

**Attributes.** Click this to display a dialog box through which you can specify the attributes of the text for which you are searching. When an attribute has been specified, Cindex identifies it in the sunken box beside the button.
Field. This list identifies the fields in records that Cindex will examine when searching for text.

Evaluate References. When this is checked, Cindex treats the search text as specifying a locator (or range of locators) and will find any record that contains a reference falling within the range. This item is dimmed unless the search is confined to the locator field.

Match Whole Word. When this is checked, Cindex matches only a whole word (a continuous sequence of letters or numbers). This item is dimmed if the search text contains anything other than letters or numbers.

Match Case. When this is checked Cindex finds text in which the case of letters matches the target text.

Match Pattern. When this is checked Cindex treats the text as a pattern to be matched.

Only/And/Or. Items in this drop-down list determine whether Cindex searches for the specified text alone or in conjunction with some other text. Choose And or Or to extend the window to accommodate the specification of a second segment of text. You can specify up to four segments altogether.

Find Again

Find the next occurrence of the search target previously specified with Find.

Replace...

When the main index window is active, this brings up a window (Figure 78) through which you can search for and replace text in records.
Edited Menu

CONFINING THE SEARCH TO RECORDS WITH SPECIFIED ATTRIBUTES

Items in the **Scope** box control the scope of the search. For more information on them see “Scope of Operations” on page 261.

Items in the **Only Among** box specify the attributes records must have to be included in the search. For more information on them see “Using Record Attributes” on page 77.

**Find.** This contains text for which Cindex searches. The drop-down list contains a history of recent searches.

**Find/Find Again/Resume.** Click this to find the first/next occurrence of the search text.

**Replace.** Click this to replace the search text in the highlighted record. Cindex automatically looks for the next occurrence after replacing the text.

**Replace All.** Click this to replace every occurrence of the search text in records.

**Reset.** Click to clear the current settings and set up for a new search and replace.

**Specifying the Search Target and Replacement**

Enter the search text in the **Find** box in Figure 78. Type the replacement text at **Change to.** The following items govern how Cindex treats the search text.
[89] Attributes (search). Click this to display a dialog box through which you can specify the attributes of the text for which you are searching. When an attribute has been specified, Cindex identifies it in the sunken box beside the button.

[91] Field. Use this list to choose which fields in records Cindex examines when searching for text.

[92] Match Whole Word. When this is checked, Cindex matches only a whole word (a continuous sequence of letters or numbers). This item is dimmed if the search text contains anything other than letters or numbers.

[92] Match Case. When this is checked Cindex finds text in which the case of letters matches the target text.

[92] Match Pattern. When this is checked Cindex treats the text as a pattern to be matched.

[89] Attributes (replacement). Click this to display a dialog box through which you can specify the attributes to be added or replaced.

**Spelling…**

When the main index window is active, this opens a window (Figure 79) through which you can check the spelling of text in records.

![Figure 79. Spelling dialog box](image)

**Scope**

Items under Scope control the scope of the examination. For more information on most of these see “Scope of Operations” on page 261.
Field. The chosen item determines which field or fields Cindex will check.

Check Page References. If this is checked Cindex will check the spelling of text in the locator field, whether or not the text is a cross-reference. If this item is unchecked, Cindex checks only cross-references.

Language. The chosen item identifies the main language dictionary Cindex will use for checking spelling.

Dictionary. The chosen item identifies the personal dictionary (if any) that Cindex will use in addition to the main language dictionary.

Suggest. Clicking this causes Cindex to suggest alternative spellings for an unrecognized word. The button is dimmed if Cindex is set to suggest alternatives whenever it encounters an unknown word (see “Setting Options” on page 277).

Start/Resume/Ignore/Delete. Clicking this starts spell-checking, or (if spell-checking is already under way) causes Cindex to ignore a word it has not recognized, or delete a repeated word.

Change. Clicking this causes Cindex to change the misspelled word to the word displayed at Change To.

Reset. Clicking this causes Cindex to stop checking spelling, and restores the Spelling window to its initial state.

Ignore All. Clicking this causes Cindex to ignore all further occurrences of the unknown word in your current session.

Add. Clicking this adds the unknown word to the active personal dictionary.

Options… displays the dialog box shown in Figure 80.
Edit Menu

**FIGURE 80. Spelling Options dialog box**

- **Use Additional Dictionaries.** This shows any additional specialized dictionaries that can be used with the chosen language.

- **Personal Dictionary.** This contains a list of available personal dictionaries. For the dictionary chosen, **Edit...** displays a dialog box that shows all words in it. You can edit the words in the list. **New...** displays a dialog box through which you name and create a new personal dictionary.

- **Always Suggest Alternatives.** When this is checked Cindex will always try to suggest alternative spellings for unknown words.

- **Ignore Words in CAPITALS.** When this is checked Cindex will not check any word that consists entirely of capital letters.

- **Ignore Alphanumeric Strings.** When this is checked Cindex will not check any word that contains both letters and numerals.

- **Clear Ignore List.** Clicking this causes Cindex to forget any words it has been told to ignore (via **Ignore All** in the Spelling window).

**New Abbreviation...**

- **New Abbreviation...** When the Abbreviation window is active, this starts the definition of a new abbreviation. When the record-editing window is active, this displays a dialog box through which you can define an abbreviation for selected text.
Preferences…

This displays a dialog box through which you make settings that govern the general behavior of Cindex.

![Preferences dialog box]

**FIGURE 81. Preferences dialog box**

**General Tab**

- **No Action/Open Last Index/Show Open Panel.** This determines whether Cindex will open the last index you worked on when it starts up (unless you started Cindex by double-clicking an index), displays the **Open...** panel, or does nothing.

- **Maximize Cindex.** This specifies whether or not Cindex occupies your whole screen when it starts.

- **Prompt for User ID.** This specifies whether or not Cindex will prompt you for a user identifier each time you begin a session.

- **Maximize on Opening.** This specifies whether or not Cindex will maximize each index as it is opened.

- **Save Open Indexes Every...** This specifies the interval (in minutes) at which Cindex automatically saves indexes to disk. To disable automatic saving set this to 0.

- **Maximum Number of Recent Indexes.** This specifies how many names of recently-used indexes are displayed in the **File...** menu.
Edit Menu

[14] **User ID.** Enter up to four identifying characters that Cindex will attach to each record that you make or modify. Cindex displays these characters on the status line in the record window. You can use User ID as a search criterion with Find.

[5] **Automatically check for updates.** Check this to make Cindex check automatically and notify you when an update is available.

[15] **Default Folder.** Click this to display a dialog box through which you can specify the folder that Cindex will use by default when it saves or opens indexes.

Editing Tab

Items here control how Cindex behaves when you add or edit records through the record window.

[22] **Use Separate Window.** When this is checked the record-entry window is detached from the bottom of the main window and displayed separately.

[62] **Switch to Draft View.** When this is checked, and the main window shows fully formatted entries, Cindex will temporarily switch the view to show records in draft format when it opens the record window.

[40] **Remove Extra Spaces.** When this is checked, Cindex will reduce multiple spaces between words to a single space, whenever multiple spaces are entered in records.

[43] **Smart Flip.** When this is checked, Cindex will intelligently adjust the case of leading letters and the positions of prepositions and articles when it swaps the contents of two record fields.

[41] **Complete Page Ranges.** When this is checked, Cindex will automatically complete a page range when you type the connecting character that follows the first part of the range.

[29] **Track New Entries.** When this is checked, Cindex immediately displays each new entry in its sorted position in the main index window.

[41] **Carry Locators Forward.** When this item is checked, the locator field of each new record you make is automatically loaded with the contents of the locator field from the record most recently added to the index.

[38] **Auto-Complete Entries.** When this is checked, Cindex will attempt to complete any record field when what you have typed matches an entry already in the index.
**Edit Menu**

[38] **Ignore Style & Case.** When this is checked, Cindex will auto-complete entries if what you have typed matches and existing entry, regardless of letter style and case.

[38] **Track Source.** When this is checked, will display in the main view window the entry that provides the source of the text used in auto-completion.

[45] **Propagate Changes.** When this item is checked, Cindex will propagate editing changes to any following records in which fields originally matched those that were changed.

[37] **Return to Entry Point.** When this item is checked, after editing a series of records Cindex restores the main index display to show the entries it contained when you started editing.

**Label Sets Change Flag.** When checked, changing the label on a record will change the record’s date stamp.

**Paste and Drop Text.** The active button determines how Cindex delivers text style and font information when it pastes or drops text into a record.

[46] **Bad Locator.** The active button determines what Cindex does when you attempt to save a record that has an empty locator field, or a badly-formed locator.

[47] **Bad Cross-Ref.** The active button determines what Cindex does when you attempt to save a record containing a cross-reference that has no target.

[214] **Mismatch to Template.** The active button determines what Cindex does when you attempt to save a record in which the contents of a field do not match a template specified for it.

[28] **On Closing Window.** The active button determines how Cindex behaves when you close the record-editing window by clicking its close box, or by choosing Close from the File menu.

**View Tab**

[34] **Default Font.** The list specifies the font Cindex will use initially as the standard font for a new index it creates.

[34] **Main View.** This specifies the size of the characters Cindex will use initially to display entries in a new index it creates.
**View Menu**

**[34] Entry View.** This specifies the type size Cindex will use when it displays entries for editing in the record window. Set 0 to make Cindex use whatever type size is set for the main window.

**[56] Label Colors.** Double-click any colored cell to display a dialog box through which you can specify the color in which records carrying the label will be displayed.

**[56] Display in Formatted View.** Check this to make Cindex display unique parts of labeled records in their distinctive color when using a formatted view. In a draft view records are always displayed in their distinctive colors.

**Formatted Export Tab**

**[192] Plain Text/RTF/Quark/InDesign.** The item chosen here determines how Cindex will form the leading indents to subheadings when it saves formatted indexes in Rich Text Format, as plain text, or in the tagged text formats used by QuarkXPress or Adobe InDesign.

**[200] Include Sorting Information when Embedding Entries.** Check this to make Cindex include with embedded entries information about how they should be sorted.

**[189] Encode Plain Text Documents.** Specifies the character representation (UTF-8 Unicode or Mac Roman) Cindex will use when saving plain documents.

**VIEW MENU**

**Go To…**

**[71] Go To…** When the main index window is active this brings up a dialog box (Figure 82) through which you can specify an entry, or a page of entries, you want to bring into view.

![Go To dialog box](image)

**FIGURE 82.** Go To dialog box
View Menu

To display a particular record, click \textit{Record} and specify it by the contents of its headings or by its number (see the discussion under “Scope of Operations” on page 261). To display entries that would fall on a particular printed page of the index, click \textit{Formatted Page} and enter the page number.

\textbf{All Records} \hfill \textsuperscript{[68]}

This sets the view to show all records in the index.

\textbf{New Records} \hfill \textsuperscript{[68]}

This sets the view to show only new records. This item is dimmed if there are no new records.

\textbf{Group} \hfill \textsuperscript{[70]}

This submenu identifies groups that belong to the index, and sets the view to show records in the chosen group. This item is dimmed if the index has no groups.

\textbf{Temporary Group} \hfill \textsuperscript{[69][75]}

This sets the view to show records in any temporary group that Cindex has formed. Temporary groups can be formed from selected records, or by using \textit{Find…}, from the Edit menu. This item is dimmed if the index has no temporary group.

\textbf{Full Format} \hfill \textsuperscript{[59]}

This sets the view to show fully-formatted index entries.

\textbf{Draft Format} \hfill \textsuperscript{[61]}

This sets the view to show index entries in draft format.

\textbf{Summary} \hfill \textsuperscript{[64]}

This sets the view to show entries in summary format (a draft format showing headings and cross-references only). Cindex scans the index before displaying entries in this format.
Character Menu

### Unformatted

This sets the view to show unformatted records.

### Hide by Attribute...

Displays a dialog box through which you can specify the visibility of records carrying particular labels. This item is available only when Cindex displays fully formatted entries.

### Show Numbers

This hides (when unchecked) or shows (when checked) record numbers in any view except the fully formatted one. This item is dimmed when Cindex displays fully formatted entries.

### View Depth

The checked item in this submenu identifies the lowest heading level that Cindex will display, in any view but the fully formatted one. This item is dimmed when Cindex displays fully formatted entries.

### Wrap Lines

This item determines whether Cindex clips, or wraps to the next line, record text that would extend beyond the right margin of the page. This item is available in the unformatted view only; it is dimmed otherwise.

### Sorted

This item determines whether index entries are displayed in sorted or unsorted order. It is available only when the view is set to show all records, and is dimmed otherwise.

### CHARACTER MENU

### Default Font

When the record editing window is open this sets selected text in the default font for the index.
Plain

When the record editing window is open this clears all styles from the selected text.

Bold ... Superscript

The styles Bold, Italic, Underline, Small Caps and Subscript or Superscript can be applied concurrently to any selection. A check mark indicates when a style is applied to the whole of the selected text.

Character Map...

Opens a window that displays the full character set available in any font. From this window you can enter special characters directly in records, or in specifying search text with Find or Replace.

DOCUMENT MENU

Items in this menu control aspects of the structure or formatting of indexes. If an item is chosen when the main window for an index is active, the settings apply to that index only. If an item is chosen when no index is open, Cindex applies the settings to new indexes when it creates them.

Margins & Columns...

This displays the dialog box shown in Figure 83.
Setting Margins

[167] **Top.** This specifies the size of the top margin, in the unit displayed in the **Unit** drop-down list.

[167] **Bottom.** This specifies the size of the bottom margin, in the unit displayed in the **Unit** drop-down list.

[167] **Left/Inside.** This specifies the size of the left or inside margin, in the unit displayed in the **Unit** drop-down list.

[167] **Right/Outside.** This specifies the size of the right or outside margin, in the unit displayed in the **Unit** drop-down list.

[167] **Facing Pages.** When this item is checked Cindex formats pages with inside (near binding) and outside (far from binding) margins. When this item is unchecked, all pages are printed with the same left and right margins.

Setting Columns

[167] **Columns.** This drop-down list specifies the number of columns that will appear on the printed page. The screen display always shows a single column, but of the correct width.

[167] **Gutter.** This specifies the space between columns, in the unit displayed in the **Unit** drop-down list.

Repeating Broken Headings

[169] **Never/At New Page/At New Column.** These buttons specify the conditions under which Cindex should repeat, at the start of a new column or page, the heading(s) from any entry broken at the foot of the preceding column or page.
To Level. The chosen item in this list specifies the lowest-level heading that Cindex will repeat if it breaks an entry.

Append. Cindex appends this text to each level of heading it repeats after breaking an entry.

Style… This brings up a dialog box through which you can set the style of any text Cindex will append to a repeated heading.

Headers & Footers…

This displays the dialog box shown in Figure 84.

[FIGURE 84. Headers & Footers dialog box]

Header/Footer (Left Header/Left Footer, etc.). Click the tab to make settings for the appropriate header or footer.

Left/Center/Right. Each of these segments contains text the will appear left-justified, centered, or right-justified in the header or footer line on the left or right page. When building the header or footer Cindex does not check if the segments of text will overlap.

Unless preceded by \ (backslash), the following characters have special meanings when used in a segment:

• @ denotes the current date/time.
Document Menu

- # denotes the current page number.
- % denotes the name of the index.

[171] Font. This specifies the font in which the header or footer line will be printed. The item at the top of the list (<Default>) represents the standard font in which the index is currently displayed.

[171] Size. This specifies the size of text used in the header or footer. 0 means the size used for index entries.

[171] Style. This displays a dialog box through which you can set the style to be applied to text in the header or footer line.

[170] Copy. When the index is formatted for facing pages, clicking this copies the settings for the currently selected page (left or right) to the other page. The button is dimmed if the pages have identical headers and footers.

[171] First Page Number. This specifies the number (if any) printed on the first page.

[171] Number Format. This specifies the format of numerals (Arabic or Roman).

Date Format

[171] Long/Short. This determines the format in which Cindex will print a date in the header or footer. Define these formats through the Date tab of your computer’s Regional Settings Control Panel.

[171] Add Time. If this is checked, Cindex appends the time to any date it prints in a header or footer.
Grouping Entries...

The dialog box shown in Figure 85 contains settings that govern how Cindex groups entries for display in the formatted index. Settings take effect only when the index is displayed in fully formatted view.

![Grouping Entries dialog box](image)

**FIGURE 85. Grouping Entries dialog box**

- **Title Text.** Text entered here appears as the title to each group. The character % is understood to represent the character that begins the group. This character is the first under which Cindex sorts an entry.

- **Font.** This specifies the font in which Cindex will print any group title. The item at the top of the list (<Default>) represents the standard font in which the index is currently displayed.

- **Style.** This displays a dialog box through which you can set the style in which Cindex will print any group title.

- **Grouping Method.** The item chosen in the drop-down list determines how Cindex groups entries that begin with numbers and symbols (each letter of the alphabet occupies its own group). Elements within a single pair of square brackets are grouped together.

- **Numbers/Symbols Titles.** Specify here any titles to be used for groups that aggregate all numbers, all symbols or all numbers and symbols.
**Style & Layout...**

The dialog box shown in Figure 86 contains settings that govern the style and layout of entries in the formatted index.

![Style & Layout dialog box]

**FIGURE 86. Style & Layout dialog box**

- **Style**
  - **Indented/Run-In.** This determines the basic index style, indented or run-in. In run-in style, the drop-down list specifies the heading level below which entries are run-in (they are indented until that level).

- **Variant.** The item chosen from the drop-down list specifies any variant on the basic indented or run-in style.

- **Collapse Headings below.** This determines the level below which headings will be suppressed, and their page references and cross-references displayed as though belonging to the last visible heading level.

- **Indentation**
  - **Type.** The drop-down list determines how Cindex will calculate the indentation of different levels of heading and runover lines.

  - **Unit.** This determines the unit in which Cindex will calculate the indentation of formatted entries. (An Em space is the width of M in the standard font in which the index is displayed.)

  - **Lead.** This specifies the size of the indent (in the chosen unit) that Cindex will use before a new level of heading.
**Document Menu**

**Runover.** This specifies the size of the indent (in the chosen unit) that Cindex will use before a runover (continuation) line.

**Line Spacing**

**Auto.** When this is checked, Cindex calculates the line spacing automatically for the font and size in which entries are displayed. This item is dimmed if the spacing is set to some other value.

**Extra at Main Headings.** Cindex inserts this number of extra lines between main headings.

**Extra at Alphabetic Groups.** Cindex inserts this number of extra lines between each group of entries. (Groups are identified through settings in “Grouping Entries...” on page 289.)

**Adjusting Punctuation**

**Around Quotation Marks.** If this is checked Cindex will move a trailing period or comma inside any closing quotation mark when it displays formatted entries.

**Around Styled Text.** If this is checked Cindex will move a trailing punctuation mark inside any closing style (italics, boldface, etc.) when it displays formatted entries.

**Headings...**

The dialog box shown in Figure 87 contains settings that govern the punctuation, font and style in which Cindex displays headings at different levels. The settings take effect only when the index is displayed in fully formatted view.
FIGURE 87. Heading Format dialog box

[181] **Main** ... Click the tab corresponding to the heading level to which settings will be applied.

[181] **Font.** This specifies the font in which the heading will be displayed. The first item (<Default>) represents the standard font assigned to the index from the font drop-down list in the toolbar.

[181] **Style.** This brings up a dialog box through which you can specify the style in which the heading will be displayed.

[181] **Leading Text.** This contains text that Cindex will insert immediately before the text of the heading.

[181] **Trailing Punctuation.** This contains any punctuation that Cindex will place after a heading that has no immediately following page reference or cross-reference.

[181] **Suppress.** When this is checked, headings at the specified level, and any associated page references or cross-references, are suppressed.
Cross–References...

The dialog box shown in Figure 88 contains settings that govern how Cindex displays cross-references. Most settings take effect only when the index is displayed in fully formatted view.

**FIGURE 88. Cross–References dialog box**

- **From Main Heading/From Subheading.** Click the tab to make settings for cross-references from the main heading, or cross-references from subheadings.

- **Prefix.** Cindex displays the this text (including spaces) before the first cross-reference of the appropriate kind (See, or See also).

- **Suffix.** Cindex displays this text (including spaces) immediately after the last cross-reference of the appropriate kind (See, or See also).

- **Position.** This determines where Cindex places cross-references: immediately following the heading (after any page references), immediately following the heading (only if there are no page references); as the first subheadings, or as the last subheadings. The setting affects both draft and full-formatted views.

- **Alphabetize Multiple References.** If this is checked Cindex will arrange cross-references alphabetically when more than one is made from a single heading or subheading. If this item is unchecked, cross-references appear in the order in which they were entered in records.

- **Suppress All References.** If this is checked Cindex will suppress the display of all cross-references (fully formatted view only).
[123] **Don’t Apply Style Prefix if it Matches Existing Body Style.** If this is checked Cindex will not apply a prefix style if that style is already applied to the cross-reference body.

[122] **Prefix Style.** This brings up a dialog box through which you can specify the style in which Cindex will display the phrase that introduces a cross-reference.

[122] **Body Style.** This brings up a dialog box through which you can specify the style in which Cindex will display the body of a cross-reference.

**Page References…**

These settings govern how Cindex displays page references, and take effect only when the index is displayed in fully formatted view. Cindex displays the dialog box shown in Figure 89.

![Page References dialog box](image)

**FIGURE 89. Page References dialog box**

**Ranges**

[139] **Connecting Text.** This contains the set of characters that Cindex will display in fully-formatted entries instead of the single character (usually –) used to connect a range in a record.

[140] **Conflate Beyond.** The chosen item identifies the number of separate references to consecutive pages Cindex must encounter before it conflates them into a range (e.g., 55, 56, 57 becomes 55–57).
Document Menu

Abbreviation Rule. The item chosen determines the rule (if any) Cindex will use to abbreviate the higher number in a connected range (e.g., 325–327 becomes 325–27).

Before Single. This contains the characters (including spaces) that Cindex will place between a heading and an immediately following single page reference.

Before Multiple. This contains the characters (including spaces) that Cindex will place between a heading and immediately following multiple page references.

After. This contains the characters (if any) that Cindex will place after the last page reference to a heading.

Right Justify. When this is checked Cindex will right-justify page references (within the width of a column). This setting applies only to indexes formatted in indented style.

Dot Leader. When this is checked, Cindex formats right-justified references with a dotted leader.

Suppress Repeated Parts. When this is checked Cindex will suppress leading segments of multi-part references beyond the first in a series (e.g., displaying XIV 55:10; XIV 55:62; XIV 55:79 as XIV 55:10, 62, 79).

Suppress to. This specifies a (possibly disconnected) sequence of characters that determine how much of the beginning of a multi-part reference Cindex will suppress. Cindex suppresses everything that lies before the last character in the sequence.

Concatenate with. Cindex replaces any suppressed leading segments of multi-part references with the characters entered here.

Arrange in Sorted Order. If this is checked Cindex will display multiple page references from the same heading in sorted order. If this item is unchecked, references appear in their order of entry in records.

Merge Redundant References. If checked, suppresses the output of duplicate references, and merges overlapping ranges of references.

Suppress All References. If this is checked Cindex will suppress the display of all page references (fully-formatted view only).
Locator Style

- **Style.** This brings up the dialog box shown in Figure 90. Through this you specify the style in which Cindex will display the different components of page references.

![Locator Style dialog box](image)

**FIGURE 90.** Locator Style dialog box

- **First … N.** Click the tab to identify the segment of a multi-part reference to which styles will be applied (a simple page reference has only one segment).

- **Locator Element.** Checked styles are applied to the reference element proper.

- **Lead Punctuation.** Checked styles are applied to any punctuation that precedes the reference element.

**Styled Strings…**

The dialog box shown in Figure 91 contains a list of words and phrases to which Cindex will apply a style or styles automatically when it displays a formatted index. Settings take effect only when the index is displayed in fully formatted view.
FIGURE 91. Styled Strings dialog box

[183] The list shows words or phrases to which Cindex will automatically apply a style. Click a word or phrase in the list to see, below it, the styles that Cindex will apply to it.

[183] **Add.** This adds to the list a new word or phrase typed in the text box, with the specified attributes. This item is dimmed if the displayed word or phrase is already in the list.

[183] **Delete.** This removes from the list the selected word or phrase.

**Record Structure...**

The dialog box shown in Figure 92 contains settings that control the structure of index records.
Maximum Characters in a Record. This specifies the maximum number of characters a record can hold. If the index contains records, this number cannot be less than the number of characters contained in the longest record. That number will be shown to the right.

Number of Fields. The Min and Max list settings specify the minimum and maximum number of fields index records can hold. The minimum can be set only if the index contains no.

Subhead Preceding Locator is Required. When this is checked each record will contain a last subheading field (attached to the locator field) that cannot be split or joined to another field. This is dimmed unless the minimum number of fields is at least 3.

First... Each tab contains settings for its corresponding record field. Tab names identify fields by their order of appearance in records (the locator field is always represented by the last tab).

Field Name. This specifies the name Cindex will use to identify the field in the record window and in various drop-down lists.

Maximum/Minimum Characters. These set the maximum and minimum numbers of characters that the field may contain (a setting of 0 implies no limitation).
**Match.** This contains any pattern to which the contents of the field must conform.

**Reference Syntax...**

The dialog box shown in Figure 93 contains settings that specify the structure of cross-references and page references.

![Reference Syntax dialog box](image)

**FIGURE 93. Reference Syntax dialog box**

**Page References**

- **Separator.** This (single) character separates one page-reference from the next when two or more are contained in a record.
- **Connector.** This character separates the parts of an inclusive range of page references, in records. It need not be the character Cindex displays in formatted entries.
- **Maximum Value.** This specifies the maximum value a locator can take. Cindex can check that locators you enter in records do not exceed this value.
- **Greatest Range.** This number specifies the maximum span of pages than can be represented in a consecutive range. Cindex can check that the spans of ranges you enter in records do not exceed this value.

**Cross-References**

- **Lead.** This contains the words that can form the introductory phrase of a cross-reference.
- **Separator.** This specifies the character that is used to identify the end of a cross-reference when two or more appear sequentially in a record.
[112] **General.** This contains the individual words that may begin a general cross-reference that refers to no particular entry (e.g., See specific diseases).

[112] **Recognize Cross-References in Locator Field Only.** Check this to prevent Cindex identifying text in a heading as a cross-reference.

**Smart Flip Words...**

[43] The panel contains the words that Cindex may move within and between record fields when it executes a ‘Smart Flip’.

**TOOLS MENU**

**Check Index...**

This provides three kinds of checks: basic checks for punctuation and letter case; checks for consistency of headings; checks for cross-references and page references. Cindex displays the dialog box shown in Figure 94.

![Check Index Panel](image)

**FIGURE 94. Check Index Panel**

**Basic Checks**

[223] **Misused special characters.** Checks that special Cindex characters ~ \{ \} < > are correctly used in records (e.g., that a ~ is not the last character in a record field).
CHAPTER 14  Reference  301

Tools Menu

[223] **Misplaced or questionable punctuation.** Checks for such things as spaces before closing punctuation, repeated punctuation, and questionable sequences of punctuation characters.

[223] **Missing space before parentheses or brackets.** Finds instances of misplaced parentheses or brackets.

[223] **Unbalanced parentheses or brackets.** Finds instances of unmatched opening/closing parentheses or brackets.

[223] **Unbalanced quotation marks.** Finds instances of unmatched opening/closing quotation marks.

[223] **Mixed case words.** Finds letter case errors.

---

Headsings

**FIGURE 95. Check Headings**

[224] **Inconsistent capitalization.** Finds headings that are identical except for letter case.

[224] **Inconsistent style/typeface.** Identifies entries that are identical except for text style and/or font.

[224] **Inconsistent punctuation.** Finds headings that are identical except for punctuation.
Inconsistent leading conjunctions and prepositions. Flags headings that differ in a leading conjunction or preposition.

Inconsistent endings. Checks for three different kinds of inconsistencies in headings:
- Inconsistent plural endings.
- Headings that differ in a terminal conjunction or preposition.
- Headings that are identical except for any ending phrase in parentheses.

Orphaned subheadings below: Identifies records that contain unnecessary levels of subheading (a single subheading below a heading at the level you specify).

References

Verify cross-references. Enables checks on validity of cross-references.

Require at least \( N \) matches. Specifies the minimum number of target entries that Cindex must find under each heading to which a cross-reference is made. The value must be at least 1.

Require Exact Matches. If this is checked Cindex requires an exact match between the body of a cross-reference and the entry to which it refers. If this item is unchecked, Cindex accepts shortened or modified matches.
Tools Menu

Page References

[228] More than \( N \) undifferentiated. Identifies records that contain more than the specified number of undifferentiated page references.

[228] Overlapping ranges. Flags entries with references that are overlap or are duplicated.

[228] On headings above lowest. Identifies entries in which any heading level above the lowest subheading has a reference attached to it.

Reconcile Headings...

This finds orphaned subheadings, or reconciles heading levels in records by adjusting fields so that no record contains more levels of heading than it needs. Cindex displays the dialog box shown in Figure 97.

FIGURE 97. Reconcile Headings dialog box

[99] Check Headings Below. The chosen item specifies the level below which Cindex may split or join headings.

[100] Modifying Phrases Follow. This specifies the character (usually a comma) that separates a heading from any immediately following modifying phrase.

[100] Preserve Modified Headings. If this is checked, Cindex will not break modified headings before joining fields to remove redundant heading levels.

[100] Protect Names. When this is checked Cindex will never break a field if the text following the potential break point begins with a capital letter.

[100] Convert Orphans to Modifying Phrases/Remove Orphans. Choose how Cindex will deal with orphaned subheadings.
Tools Menu

Manage Cross-References...

This displays the dialog box shown in Figure 98, through which you choose to whether to generate cross-references automatically for specified target entries, or convert existing cross-references to fully-qualified entries.

![Manage Cross-References dialog box]

**FIGURE 98.** Manage Cross-References dialog box

- **Generate from File.** This displays an Open dialog box through which you choose the source of cross-references that Cindex will add to the active index if it contains appropriate target entries. Check “See” References Only to make Cindex generate only See references, vs. both See and See also references.

- **Convert to Fully Qualified Entries.** Choose this to make Cindex convert any see references with fewer than a specified number of target entries into fully qualified entries.

- **For Fewer Targets Than.** Specify the number of target entries below which Cindex will convert a see reference to a fully qualified entry.

Alter References...

This adjusts references to page numbers contained in the locator fields of records. Cindex displays the dialog box shown in Figure 99.
Tools Menu

**FIGURE 99.** Alter References dialog box

- **All References/Range.** This specifies whether Cindex adjusts all references, or only references falling within a range identified by the beginning and ending page numbers in the boxes.

- **Matching Pattern.** This can contain a pattern that specifies any initial parts of a multi-part reference Cindex must skip before the part that it will adjust.

- **Adjust Only/Remove References.** This determines whether Cindex adjusts or removes references that match the specification in Scope. If **Remove References** is specified, Cindex adjusts references to higher numbered pages to take account of those removed, unless **Hold Higher Values** is checked.

- **Adjustment.** This specifies the amount (positive or negative) by which references will be adjusted.

**Split Headings...**

Scans the index looking for headings that contain specified terms (e.g., author names in the form *Surname, Forenames(s)*). If a record heading contains multiple terms, Cindex creates new records as needed to ensure that the heading in each contains a single term.
Tools Menu

**FIGURE 100. Split Headings box**

- **Identify.** Specifies the kind of term Cindex looks for in headings.
- **Mark Records With No Matches.** Marks records that contain no terms of the kind sought.
- **Remove Styles.** Removes any style and font information from extracted terms.
- **Preview Splits.** Displays a window in which Cindex shows that terms found in every record.

**Sort…**

This sorts entries by rules specified via the dialog box shown in Figure 101.
Tools Menu

FIGURE 101. Sort dialog box

Text

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Language.</strong> This is the language whose collation rules Cindex will use.</td>
</tr>
<tr>
<td><strong>Alphabetizing Rule.</strong> This specifies the type of alphabetizing rule Cindex will use.</td>
</tr>
<tr>
<td><strong>Ignore -/.</strong> If this is checked Cindex will ignore - and / in word-by-word alphabetizing. If this is unchecked Cindex treats - and / as spaces.</td>
</tr>
<tr>
<td><strong>Ignore .,:;</strong> If this is checked, Cindex will ignore these characters, in letter-by-letter or word-by-word alphabetizing only. If this is unchecked, Cindex treats these characters as having higher precedence than spaces.</td>
</tr>
<tr>
<td><strong>Evaluate Numbers.</strong> If this is checked, Cindex evaluates a series of digits as a number, in letter-by-letter or word-by-word alphabetizing only. If this is unchecked, Cindex ignores digits while alphabetizing entries.</td>
</tr>
<tr>
<td><strong>Ignore Parenthetical Phrases.</strong> When this item is checked, Cindex ignores parenthetical phrases, in letter-by-letter or word-by-word alphabetizing only. When this item is unchecked, Cindex attends to text in parentheses.</td>
</tr>
<tr>
<td><strong>Ignore Parenthetical Endings.</strong> When this item is checked, Cindex ignores parenthetical endings to words, in letter-by-letter or word-by-word alphabetizing only.</td>
</tr>
</tbody>
</table>
**Tools Menu**

**Substitutions.** Presents a panel through which you specify text that should be sorted as some other text.

[156] **Character Priority.** The position of a character class in this list determines the precedence of that class of characters. (Items in the list can be dragged to new positions.)

**Language Script has Precedence.** When set, characters from the script for the sort language have precedence over characters from other scripts, so that entries in that script appear before entries in all other scripts.

[156] **Ignore Subheading Prefixes.** This list contains words that Cindex will ignore if they appear at the beginnings of subheadings, in letter-by-letter or word-by-word alphabetizing only.

**Fields**

[147] **Order.** The order in which checked items appear in the list determines the order in which Cindex evaluates the corresponding fields in records. Double-clicking an item checks or unchecks it. (Items can be dragged to new positions.)

[150] **Ignore Lowest Subheading.** When this is checked Cindex ignores the contents of the lowest-level text field in a record.

**Locators**

[133] **Segment Order.** This specifies whether, and in what order, Cindex will evaluate a particular segment of a multi-part reference. Cindex evaluates segments appearing at the positions identified by + marks. Double-clicking an item checks or unchecks it. The order in which Cindex evaluates a checked item is determined by the item’s position in the list. (Items can be dragged to new positions.)

[131] **Type Precedence.** This specifies whether or not Cindex will recognize reference components of different classes, and the precedence of the classes Cindex does recognize. Cindex recognizes components of classes that are checked. Double-clicking an item checks or unchecks it. The precedence of a checked item is determined by its position in the list. (Items can be dragged to new positions.)

[132] **Style Precedence.** This specifies the precedence of otherwise identical locator components that differ in text style.

[135] **Ascending Order.** When this is checked, low-valued references precede higher valued ones. When this is unchecked, higher valued references precede lower-valued ones.
Tools Menu

[136] Examine All. When this is checked Cindex sorts by the lowest (or highest) valued reference (per Ascending Order, above). When this item is unchecked, Cindex uses the value of the first reference in a record.

Compress...

This removes records of specified kinds from the index. Cindex displays the dialog box shown in Figure 102.

![Compress dialog box](image)

FIGURE 102. Compress dialog box

[230] Remove Deleted Records. When this is checked Cindex removes deleted records and renumbers records that remain.

[230] Remove Empty Records. When this is checked Cindex removes records that contain no text.

[230] Remove Duplicated Records. When this is checked Cindex removes any record that is an exact duplicate of another.

[231] Remove Generated Records. When this is checked Cindex removes records that contain automatically generated cross-references.

[231] Consolidate References. When this is checked Cindex finds records that are identical, except for their page references or cross-references, and consolidates page references or cross-references into as few records as possible. Cindex removes unnecessary records.

[231] Ignore Different Labels. Check this to make Cindex consolidate references from identical records, regardless of whether they carry the same label.
Tools Menu

Expand

[229] This generates new records as needed so that no record in the index contains more than one page reference or one cross-reference.

Count Records...

[220] This counts records of specified kinds. Cindex displays the dialog box shown in Figure 103.

![Count dialog box](image)

**FIGURE 103.** Count dialog box

Cindex counts records within the scope specified under **Scope**, and containing the attributes checked in **Only Among**. For more information on setting the scope and attributes see “Scope of Operations” on page 261.

[221] **Containing Locators.** This specifies the range of locators for which Cindex will count records. If no range is specified, Cindex counts records regardless of locator value.
Index Statistics…  
This provides various statistics about the active index. Cindex displays the dialog box shown in Figure 104.

![Index Statistics dialog box](image)

**FIGURE 104. Index Statistics dialog box**

Cindex displays information about the formatted entries within the scope specified in **Range to Examine**. For more information on setting the scope see “Scope of Operations” on page 261.

Abbreviations  
Commands in this submenu manage abbreviation files.

Fonts…  
This displays a dialog box (Figure 105) through which you can make font substitutions and cleanup unused fonts.
Each row in the list displays information about a font used (or previously used) in the index. From left to right the row displays the Cindex identifier for the font, the preferred font’s name, then the alternate font’s name.

**Clear Unused.** Click this to remove from the list any previously used fonts that are no longer being used. The button is dimmed if all fonts in the list are being used.

**Preferred.** Type or use the drop-down list to change the preferred font for the selected row in the list.

**Alternate.** Use this drop-down list to change the alternate font for the selected row in the list.

**Hot Keys…**

This displays a window that shows hot key definitions and the text attached to each key. You can change the keys or keystroke combinations that are 'hot' and you can change the text assigned to them.
Tools Menu

**Markup Tags...**

This displays a dialog box (Figure 106) through which you can inspect and edit tag sets for marking-up different elements of a formatted index.

![ Markup Tags dialog box ](image)

**FIGURE 106. Tag Set Selection dialog box**

[193] **XML Tags/SGML Tags.** Determines which kind of markup tags to manage.

[193] **Active Set.** This list shows all tag sets that Cindex possesses. The chosen item specifies the set on which various operations will be undertaken.

[193] **Duplicate.** This duplicates the selected tag set. Cindex asks you to provide a name for the new set.

[193] **New.** Cindex creates and opens a new tag set. Cindex asks you to provide a name for the new set. All new tags except Character Tags are empty.

[193] **View/Edit.** Opens a tag set for inspection or editing.

[193] **Delete.** This deletes the selected tag set.

**XML Tags**

When you create a new or duplicate set of tags, or click **View/Edit**, Cindex opens the dialog box shown in Figure 107.
FIGURE 107. XML Tag Set dialog box

[195] **Structure Elements.** This tab contains tags that identify major structural elements of the index (beginning, end, levels of heading, etc.), together with settings that specify how tags are used.

[196] **Other Elements.** This tab contains tags that identify type styles (italics, boldface, etc.) and fonts used in entries.

**SGML Tags**

When you view or edit an SGML tag set Cindex opens the dialog box shown in Figure 108.
CHAPTER 14 Reference

FIGURE 108. SGML Tag Set dialog box

[197] **Structure Tags.** This tab contains tags that identify major elements of the index (beginning, end, levels of heading, references, etc.).

[198] **Style Tags.** This tab contains tags that identify type styles (italics, boldface, etc.).

[198] **Font Tags.** This tab contains tags that identify different fonts.

[198] **Special.** This tab contains special tags, such as those that represent characters used to form tags.

**Record Events**

[85] Choosing an item from this submenu starts recording of a sequence of keystrokes and mouse clicks that you can later play back. To stop recording hit CONTROL BREAK.
Play Events

Choosing an item from this submenu replays a previously recorded sequence of keystrokes and mouse clicks.

Groups...

This displays a dialog box (Figure 109) through which you can manage the groups that belong to the active index. This item is dimmed if the index has no groups.

![Manage Groups dialog box]

**FIGURE 109. Manage Groups dialog box**

- **All Groups/Group.** The chosen item defines the scope of the action—on all groups or the one chosen in the drop-down list.
- **Info...** Click this to obtain information about a particular group.
- **Rebuild.** Cindex will rebuild the specified group(s) if it can, using information stored within the group(s) about how they were originally formed.
- **Delete.** Cindex will delete the specified group(s).
- **Link Cross-References.** Cindex will examine the whole index to find records that contain cross-references to records in the specified group or groups. Records that contain qualifying cross-references are added to the group.
Window Menu

Window Menu

Clipboard
Displays the contents of the clipboard.

Cascade
Arranges all open windows in a staggered array.

Tile
Arranges all open windows in a rectangular grid on the screen.

Close All
Closes all open windows

Help Menu

Help Topics
Opens the Cindex help window. This provides access to all Cindex on-line help.

About Cindex...
Displays information about the version of Cindex, and about your registration.

Check for Updates...
[5] Checks whether a Cindex update is available.
The following typographical conventions are used in the index: **Tempo** typeface denotes a menu item or an item in a window or dialog box; SMALL CAPS identify a key or key-stroke combination; *f* and *t* identify figures and tables, respectively. The index was typeset from a file produced by Cindex.

- , denoting unknown character, 209
- . See Hyphen/Minus (-); Minus (-) key
- . See Colon (:)
- . See Semicolon (;)
→ key, 24
↑ key, 24, 71
↓ key, 24, 71
? . See Question mark (?)
.. . See Period (.)
[ key, in editing shortcuts, 24
] . See Square brackets ([[]])
@, in header/footer template, 170
* . See Asterisk (*)
/ . See Slash (/)
\ . See Backslash (\)
&, in replacement patterns, 250–252
# . See Pound sign (#)
% . See Percent symbol (%)
* . See Plus (+) entries
* . See Angle brackets (< >)
| . See Vertical bar (|)
$ . See Patterns, 248
} . See Braces ({})
~ . See Tilde (~)

**Abbreviation(s)**
- page references, 129, 141–142
- month names in, 128
- in spelling check, 110
- spelling out, in sorting, 161–162, 163f, 165–166
- as text entry shortcuts, 49–52. See also Abbreviation sets

**Abbreviation Rule** drop-down list, 295

Abbreviation sets
- icon, 7
- working with, 51–52

**Abbreviations** Tools menu item, 311

**About Cindex...** Help menu item, 317

Accented letters, 26
- entering in records, 26
- sorting, 152

Acronyms
- conflict with abbreviations, 52
- exchange text, 42
- in spelling check, 110

Activating inactive index, 13

**Active Set** drop-down list, 313

**Add** button
- Spelling window, 277
- Styled Strings dialog box, 297

**Add Time** check box, 288

Adding records, 22–37. See also New records

**Adjust Only** button, 305

Adjusting punctuation, 181

Adjusting references, 92–97
- breaking an index into parts, 237
- compound locators, 94, 255–257
- connecting and separating characters, 93
- cumulating and combining indexes, 235
- group of records, 94, 95–97
- movement of chapters or sections, 95–97
- rearranging parts, 252–255
- removing, 95, 257
- temporary page numbers, 257–259
- using patterns, 255–259
- volume identifiers and, 255–256

**Adjustment** text box, 305

Adobe InDesign document format, 189

**After** text box, 295
Alignment. See Justification

**All Groups/Group** buttons, 316

**All Records** View menu item, 283
All records, viewing, 68

**All References/Range** buttons, 305
Alphabetical groups of records
formatting, 172–174, 173f
SGML markup tag for, 197
XML markup tag for, 195

**Alphabetize Multiple References** check box, 293
Alphabetizing, 151–159. See also Sorting
abbreviations
expanding, 163f
sorting as expanded, 162–163, 165–166
spelling out, 161–162, 163f, 165–166
ignoring text while
characters or words, 160f, 161f, 163
leading words in subheadings, 156–157
language conventions, 147
letter-by-letter. See Letter-by-letter alphabetizing
modifying basic rules, 156–159
page references, 128
principles, 152–154
punctuation, 157
shortcut, 151
simple. See Simple alphabetizing
symbols and numbers, 163–164, 163f
as spelled-out, 161–162, 162f
unusual spellings, 162–163, 163f
word-by-word. See Word-by-word alphabetizing

**Alphabetizing Rule** drop down list, 307
Alphabets, foreign. See Accented letters
Alphanumeric sequences, spelling check, 110

**Alter References**... Tools menu item, 304–305, 305f
Altering references. See Adjusting references

**Alternate** drop-down list, 311
Alternate font, 214–216
Alternative spellings, 104–105, 109–110

**Always Suggest Alternatives** check box, 278
Ampersand (&), in replacement patterns, 250–252
“and,” conditional searches, 80–82, 81f
**And** drop-down list, 274
Angle brackets (< >)
checking entries with, 30, 223
in exported tab-delimited records, 202
in exported XML records, 201–202
in imported Macrex records, 207
in imported SKY Index records, 206–207
in imported tab-delimited records, 207
as literal characters, 27, 198–199
sorting, 164
mismatched/misused, 30, 223
and page reference separator, 127
in SGML markup tags, 198–199
sorting entries with, 159–161, 160f, 161f, 164
sorting page references, 137–138, 138f
in XML tag name, 195

ANSI character set. See Windows’ character set
**Append** text box, 287
Arabic numerals. See Numerals; Page references
Archive. See Cindex Archive
Archive documents, 11

**Around Quotation Marks** check box, 291
**Around Styled Text** check box, 291

**Arrange in Sorted Order** check box, 295

**Articles**
flipping record fields, 43–44
ignoring in subheading, 156–157

**Ascending Order** check box, 308
Ascending order, page references, 135
ASCII characters, SGML markup tags for, 199
Association of American Publishers (AAP) markup standard, 189

Asterisk (*)
denoting special subheading field, 213
indicating unsaved changes, 11
in patterns, 244–245
**At (@) symbol**, in header/footer template, 170
Attributes
of records
deleted. See Deleted records
generated. See Generated records
labeled. See Labeled records
marked. See Marked records
modified. See Modified records
new. See New records
of text. See Font(s); Text style

**Attributes** button
Find window, 273
Replace window, 276

**Auto** check box, 291

**Auto-Complete Entries** check box, 280
Auto-entry, 38–39
Automatic operations
Cindex update notification, 5, 15
complete page range, 41
completion of entries, 38–39

generation of cross-references. See Generated cross-references

line spacing, 180

opening last-used index, 13

propagation of editing changes, 45–46

removing empty fields, 42

removing leading/trailing spaces in fields, 25, 40, 42

saving of entries, 11, 14–15

switching to draft formatted view, 62

text style application. See Text style, automatically applied

Automatically check for updates check box, 280

B

Backing up, 11

Backslash (\)

checking use of, 223

in header/footer template, 171

identifying headings beginning with numerals, 262

exporting formatted entries, 191

exporting records, 203

finding, 72, 76

index statistics, 219

printing, 84

replacing text, 90

as literal character, 27, 171

sorting, 164

locating records in page order sort, 150

with page reference separator, 127

in patterns, 243–246, 248–252

BACKSPACE key, editing text, 24, 25, 42, 43

Backup format

index copy as, 11

Macrex, importing records from, 207

Bad Cross-Ref buttons, 281

Bad Locator buttons, 281

Badly-formed records

import warnings, 208–209

repair index, 12

Bar (\)

in custom run-in headings, 177

in patterns, 247

Beep. See Warnings

Before Multiple text box, 295

Before Single text box, 295

Beginning an index, 10–12. See also New document

Beginning of entry

ingnoring when sorting entries, 160–161, 161f

locating record by, 72–73

Blank fields. See Empty record fields

Blank records. See Empty records

Blinking text, during macro recording, 86

Blocks of entries, selecting, 67–68, 67f

Body Style button, 294

Bold...

Character menu item, 285

Boldface italic style

SGML markup tag for, 198

XML markup tag for, 196

Boldface style. See also Text style

applying to text, 36

Book pages. See Page proofs

Bookmarks, in embedded index entries, 200

Boolean operators. See Conditional searches

Bottom text box, 286

Braces ({ })

checking entries with, 30, 223

in exported tab-delimited records, 202

in exported XML records, 201–202

in imported Macrex records, 207

in imported SKY Index records, 206–207

in imported tab-delimited records, 207

as literal characters, 27

sorting, 164

mismatched/misused, 30, 223

in patterns, 246–247

sorting entries with

expanding abbreviations and unusual spellings, 162–163, 163f

page references, 136–137, 137f

spelling out numbers, symbols and abbreviations, 161–162, 165–166

Brackets. See Angle brackets (<>); Braces ({ })

Breaking an index into parts, 236–237

Breaking fields

editing records, 25, 42

reconciling heading levels, 42, 99–101

Bullet (•), in draftindex view 29

Buttons. See named dialog box buttons; Toolbar buttons

C

Capitalization of headings, consistency check, 224

Capitalizing. See Case conversion

Caret (^), in patterns, 243, 247–248
Carry Locators Forward check box, 280
Cascade Window menu item, 317
Case conversion, 36. See also Initial capital letter; Lowercase letters; Uppercase letters automatic
  in formatted cross-references, 122–123
  in formatted headings, 182
flipping record fields, 43
using patterns, 251–252, 254
Case-sensitivity
  replacing text, 92
  searching with, 79
Change To text box
  in Replace window, 275
  in Spelling window, 277
Changing records. See Editing records
Chapters, rearranged, adjusting references for, 95–97
Character(s). See also Keystrokes; Letters of alphabet; Special characters
count, in longest record, 220–221
filing order, 156
fixed number on line, 169–170
forbidden in abbreviations, 52
for inclusive page number range, 32, 127
for lead indents to subheadings, 191f, 192
permissible
  in records, 26
    maximum number, 22
    restricting, 214
    total number, 212
  in SGML markup tags, 197
  in XML markup tag set names, 195
reserved, 27
separating multiple cross-references, 112
separating multiple page references, 126–127
sorting. See Sorting
  space available for, in record, 23
unknown, 209
Character classes, in patterns, 240–242
Character encoding. See also Unicode characters; Windows* character set
  importing tab-delimited records, 205–206, 208
  saving plain text documents, 190
  saving tab-delimited records, 204
Character Map… Character menu item, 285
Character menu, 36, 284–285
  Default Font, 284
  Plain, 284
Bold, 285
Character Map…, 285
Character Priority drag list, 308
Character set, in patterns, 240–242
Check for Updates… Help menu item, 317
Check Headings Below drop-down list, 303
Check Index… Tools menu item, 300–303
  basic settings, 300f
  headings settings, 301f
  references settings, 302f
Check Page References check box, 277
Checking
cross-references. See Verifying cross-references
page references. See under Checking records
records. See Checking records
Checking for updates to Cindex, 5, 15
Checking index integrity, 12
Checking records, 221–229
cross-references. See Verifying cross-references
importing records, 208–209
match to template, 30–31
orphaned subheadings, 225
in page order sort, 150
page references, 46–47
  missing or badly-formed, 79
  for undifferentiated strings, 130, 228
permissible characters, 214
spelling. See Spelling check
typographical errors while adding/editing, 30–31
Chicago Manual of Style
  abbreviating page references, rules for, 141–142
  alphabetizing principles, 154
Chronological order, sorting subheadings by page reference number, 149–150, 161–162
Cindex Archive
  icon, 6
  importing records, 204–205
  saving records, 202
Cindex Archive (*.arc), drop-down list item, Import dialog box, 269
Cindex Archive, drop-down list item, Save As dialog box, 265
Cindex for DOS, importing records from, 208
Cindex for Macintosh, exchanging indexes with, 202
Cindex Index, drop-down list item, Save As dialog box, 265
Cindex updates, checking for, 5, 15
Circular cross-references, detecting, 114, 228
Circumflex (^), in patterns, 23, 27–248
Clear Edit menu item, 271
Copying. See also Duplicating documents, 11
embedding index entries, 200
formatted entries, 201
records, 53–54
text, 39–41
Correcting entries. See Editing records
Correcting spelling. See Spelling check
Correctness of index entries, checking for. See Checking records
Count Records… Tools menu item, 310, 310f
Counting records, 220–221
Creating
abbreviations, 49–51, 50f
dictionary, spelling check, 105–106
groups of records, 69
indexes. See New document
markup tag sets, 193–194, 193f
records. See New records
Cross-references, 111–123
adding to groups, 234
automatically generated, 114f, 115–117. See also Generated records
checking. See Verifying cross-references
from collapsed headings, 177
converting to fully-qualified entries, 114–115
counting, 218
in draft view, 118, 122
in embedded index entries, 201
entering in records, 33–34, 112
as subheadings, 113–114
flipping record fields, 43
formatting, 118–123
saved settings, 185
in fully-formatted view, 118
general (nonspecific) forms, 113, 226
automatic styles not applied, 123
controlling sorted position, 121
identifying, 111–113
introductory phrase, 32, 111, 113, 123
from main heading, 118–121
position in formatted entries
from collapsed headings, 177
from main heading, 118–121
from subheading, 121
as subheadings, 119–121
prefixes, 32, 113, 121
punctuation
between, 112, 113, 229, 232
before and after, 118–119, 121
in marked-up documents, 195–197
in records imported from Macrex, 207
“see” used other than in cross-reference, 113
SGML markup tag for, 197
sorting, 121–122
in draft view, 118
general cross references, 113
with page order sort, 149–150
spelling check, 108
structure, specifying, 112–113
from subheadings, 121
in summary view, 64–65
suppressing, 122
text styles, 34, 122–123, 122f
verifying. See Verifying cross-references
XML markup tag for, 195
Cross-References… Document menu item, 293–294, 293f
Cumulating and combining indexes, 234–236
Curly brackets. See Braces ({ })
Current view, scope of operations. See Scope of operations
Custom tags, document markup, 193–199
Customizing Cindex. See Preferences; Toolbars
Cut Edit menu item, 270
Cutting and pasting text, 39–40
D
Damaged index, repairing, 12
Dangling subheadings. See Orphaned subheadings
dat filename extension, import document, 208
Database management programs, saving records for, 202
Date
finding records by, 77
in headers and footers, 171
index creation/modification, 218
month names in references, 128, 131–133
rearranging format, with patterns, 254–255
record creation/modification, 23f, 30–31
finding entries by, 77, 262–263
replacing entries by, 90
Decrement page reference, 41
Deepest heading level, 220–221
Default folder, 15
Default Folder button, 280
Default font, 36
in headers and footers, 171
in headings, 182
restoring selected text to, 36
in search and replace, 89
setting, 15
SGML markup tag for, 198
in style sheets, 185
in titles to entry groups, 173–174
XML markup tag for, 196
Default Font Character menu item, 284
Default Font drop-down list, View preferences, 281
Default settings, 10–11, 216–217. See also Preferences
abbreviation set used, 49, 51
index format, 185
restoring original, 217
from template, 217
Delete button
Manage Groups dialog box, 316
Markup Tags dialog box, 313
Spelling window, 277
Styled Strings dialog box, 297
DELETE key, editing text, 24
Deleted Edit menu item, 272
Deleted records
confining actions to, 263
confining search to, 77
replacing text, 91
counting, 221
in draft view, 55
excluding from search, 77
replacing text, 91
in exported document, 203–204
finding, 77
in fully formatted view, 55, 60
record window, 55
indicator, 23f
removing, 230–232
restoring, 55
verifying cross-references and, 226
Deleting
abbreviations, 50
duplicate words, spelling check, 105
markup tag sets, 194
page references, 95, 257
record groups, 233f, 234
records, 54–55. See also Deleted records
after adjustment of page references, 257
text, with replacement, 88
Delimited format, exporting records in, 202
Delimited Records (*.txt), drop-down list item, Import dialog box, 269
Delimited Records, drop-down list item, Save As dialog box, 265–266
Demoting headings, 44–45
Depth of headings, controlling display of, 63, 64f
Descending order, page references, 135
Designing markup tags, 193–199
Desktop publishing. See Saving documents
Diacritical marks. See Accented letters
Dictionaries, spelling check, 103–104
installing additional, 109
personal, 105–106
Dictionary drop-down list, 277
Digits. See Numerals
Discarding
changes to index, 12, 53, 88, 94, 101
changes to record, 37
new record
duplicate, 53
empty, 28
Display in Formatted View check box, 282
Displaying. See Views and viewing
Document formats, saving indexes, 188–190
Document menu, 285–300
Margins & Columns…, 285–287, 286f
Headers & Footers…, 287–288, 287f
Grouping Entries…, 289, 289f
Style & Layout…, 290–291, 290f
Headings…, 291–292, 292f
Cross-References…, 293–294, 293f
Page References…, 294–296, 294f
Styled Strings…, 296–297, 297f
Record Structure…, 297–299, 298f
Reference Syntax…, 299–300, 299f
Smart Flip Words…, 300
Documents
creating. See New document
Mac and Windows compatibility, 6
opening. See Opening documents
printing, 83–84
saving. See Saving documents
Dollar ($) sign, in patterns, 248
Don’t Apply Prefix Style if it Matches Existing Body Style check box, 294
DOS Cindex Data (*.dat), drop-down list item, Import dialog box, 269
DOS, importing records from Cindex for DOS, 208
Dot Leader check box, 295
Double spacing, 180
Double-clicking
  opening entry for editing, 31, 37
  selecting text, 25–25r
Double-posting, 53–54, 114–115
  converting cross-references to fully-qualified entries, 114–115
Draft Format menu item, 283
Drafted view, 62–64, 62–f
  automatic switch to, 62
  cross-reference display in, 118, 122
  deleted records in, 55
  embedding index entries, 200
  labeled records in, 56
  marked records in, 88–89
  modified records in, 29
  page reference display in, 136, 146
  record numbers in, showing or hiding, 63–f
  toolbar button for, 61
Drag-and-drop
  embedding index entries, 200
  formatted entries, 200
  records, 54
  text, 40–41
    discarding fonts and styles, 41
Dragging, to select entries, 67
Duplicate button, Markup Tags dialog box, 313
Duplicate menu item, 272
Duplicate page references, suppression of, 146
Duplicate records
  consolidating references, 231–232
  removing, 230
  sorting, 154
Duplicate words, spelling check, 105
Duplicating. See also Copying
  markup tag sets, 194
  records, 53–54

E

Edit… button, Spelling panel, 278
Edit menu, 270–282
  Undo, 270
  Redo, 270
  Cut, 270
  Copy, 270–271
  Paste, 271
  Clear, 271
  Select All, 271
  New Record, 271
  Edit Record, 271
  Duplicate, 272
  Deleted, 272
  Labeled, 272
  Find…, 272–274, 273–f
  Find Again, 274
  Replace…, 274–276, 275–f
  Spelling…, 276–278, 278–f
  New Abbreviation…, 278
  Preferences…, 279–282, 279–f
Edit Record menu item, 271
Editing abbreviations, 49–51
Editing markup tags, 193–199, 195–f
Editing records, 37
  balancing headings. See Reconciling headings
  breaking fields, 25, 42
  carrying locators, 41
  copying records, 53–54
  correcting typographical errors. See Spelling check
  cutting and pasting text, 39–40
  deleting records, 54–55
  draft view for, 62–63
  dragging-and-dropping text, 40–41
  duplicating records, 53–54
  empty fields, 30, 42
  exchanging (flipping) fields, 43–44
  finding and. See Finding entries
  fonts, 34–35
  generated cross-references, 117. See also Generated cross-references
  hot keys, 48
  increment/decrement locator, 41
  inserting fields, 25, 42
  joining fields, 42–43
  keystrokes, 23–25, 24–25r, 31, 37, 41
  labeling records, 55–57
  page references, 41
  changing globally. See Adjusting references
  propagating changes, 45–46
  removing deleted records. See Compressing index entries
  restoring deleted records, 55
  restoring view after, 37
  retrieving a field from last-edited record, 41
  saving changes, 37
searching and. See Finding entries
shortcuts, 24r–25t
spaces, leading and trailing, 25, 30, 42
structure, 211–214
warnings, 46–47
window. See Record window
Elements
of an index, 9
of a record, 23f
Elements of an index
SGML markup tags for, 196–199
XML markup tags for, 194–196
Embedding index entries, 200–201
Empty record fields, 42
automatic removal, 42
finding, 79
imported, 205–206
locator field
following reference adjustment, 257
sorting entries in page reference order, 149
warning for, 46
new entries, 25
replacing text with, 88
Empty records
as new entries, 28
removing from index, 230–232
Em-space unit for indentation, 179
Encode Plain Text Documents buttons, 282
Encoding, See Character encoding; Unicode characters
END key, 24t, 71t
En-dash, connecting character for inclusive ranges, 140
Ending punctuation. See Trailing punctuation
Endings of headings, checking, 224–225
Enlarging record size, 212
while importing records, 208
ENTER key, 24t. See also RETURN key
completing entry, 28, 29
Entering new records, 22–37
Entity tags. See Markup tags, for formatted indexes
Entries. See also Cross-references; Page references; Record(s)
automatic completion, 38–40
changing. See Editing records
counting, 218–221
from cross-references, making automatically, 114–115
defined, 9
embedding in other documents, 200–201
filing. See Sorting
making. See New records
printing, 83–84
Entry View drop-down list, View preferences, 282
Erasing. See Deleting
Error report
accessing record(s) in, 222
verifying cross-references, 228
Errors. See also Warnings
damaged index, 12
entering records, 30, 46–47
importing records, 208–209
typographical. See Spelling check
verifying cross-references, 114, 225–228
ESC key, 25t, 71t
discarding changes to record, 28, 37
removing highlighting in main view, 67
European alphabets. See Accented letters
Evaluate numbers check box, 307
Evaluate References check box, 274
Evaluation order, conditional searches, 83
Even numbered pages, in index printed by Cindex
headers and footers, 171
margins, 168
Examine All check box, 309
Exchanging documents with other applications, 187–209
exporting formatted entries, 187–198
exporting records, 201–204
importing records, 205–209
Exchanging (flip-fry) fields, 44
Exit File menu item, 270
Exit, from Cindex, 11
Expand Tools menu item, 310
Expanding abbreviations and unusual spellings, for sorting,
162–163, 163f, 165–166
Expanding entries, 229
restrictions, 68, 70
Explorer. See Windows’ Explorer
Exporting, 187–209
formatted indexes, 187–199
records, 201–204
copying between indexes, 54
Expressions
abbreviations for. See Abbreviation(s)
regular. See Patterns
Extensible Markup Language. See XML entries
Extra at Alphabetic Groups: text box, 291
Extra at Main Headings text box, 291
F

Facing Pages check box, 286
Facing pages, in indexes printed by Cindex
headers and footers, 171
margin settings, 168
Field drop-down list
Find window, 274
Replace window, 276
Spelling window, 277
Field Name text box, 298
Fields. See Empty record fields; Locator field; Record fields
File menu, 264–269
New…, 264
Open…, 264
Close, 264
Save, 264
Save As…, 265–268
Save Backup Copy…, 268
Revert to Saved, 268
Save Style Sheet…, 268
Import…, 269
New Group, 269
Save Group…, 269
Page Setup…, 269
Print…, 270
Recent Files, 270
Exit, 270
Filename extensions
importing records, 205–207
saving formatted indexes as tagged text, 199
Files. See New document; Opening documents; Saving documents
Files of type drop-down list, 264
Filing order. See Sorting
Filter, showing/hiding records, 61
Find Again button
Find window, 273
Replace window, 275
Find Again Edit menu item, 274
Find All button, 273
Find button
Find window, 273
Replace window, 275
Find, drop-down list, 275
Find…, Edit menu item, 272–274, 273f
Finding entries, 70–83, 74f. See also Replace
among generated records, 117
among range of records
beginning with numerals, 76
by modification date, 77
by record number, 76–77
among records with specified attributes, 77–78
backward search, 80
by beginning text in headings and subheadings, 71–73, 155
Boolean searches. See Conditional searches
case sensitive search, 79
conditional search. See Conditional searches
containing specified text, 74f
continuing previous search, 74
cross-references, automatically generated, 117
dismiss found records, 74
excluding records with specified attributes, 77–78
field-specific, 78
by font, 76
forming groups of records. See Groups of records
keyboard shortcuts for, 71
by locators, 79
missing, 79
multi-part, 79, 134–135
misspellings. See Spelling check
navigation shortcuts, 71f
with page order sort, 150
by printed index page number, 73
by record number, 72, 73
shortcuts, 71f
with text styles, 76
with too many page references, 130
toolbar button, 73
by user ID, 77
using patterns, 79–80, 239–249. See also Patterns
whole words only, 79
First (printed) page number, formatting, 171
First Page Number text box, 288
First… tabs
Locator Style dialog box, 296
Record Structure dialog box, 298
Fixed indentation, 178
Flashing text, during macro recording, 86
Flipping field, 8–44
“Flush right” page references, 144
SGML markup tag for, 199–200
Folios, temporary, indexing with, 257–259
Font(s)
adjusting punctuation around, 181
alternate, 214–216
changing, 35
in cross-reference verification, 227
default. See Default font
discarding
  in drag-and-drop, 41
  in paste, 40
in drag-and-drop, 41
drop-down list, 35
in exported records, 202
finding entries by, 76
for formatted headings, 182
for headers and footers, 171
in hot key text, 48
markup tags for. See Font markup tags
missing, 214–216
preferences, 35
preferred, 214–216
replacing, 89–90
SGML markup tags for, 198
size, 35
substitution, 216
  importing records, 205, 207
for titles to groups of entries, 173–174
used in index, 215
Font change, adjusting punctuation around, 181
Font drop-down list
  Grouping Entries dialog box, 289
  Headers & Footers dialog box, 288
  Headings dialog box, 292
main toolbar, 263
Font markup tags, 193
SGML, 198
XML, 196
Font Tags tab, 315
Font-based unit for indentation, 179
Fonts... Tools menu item, 311–312, 312f
Footers. See Headers and footers
For Fewer Targets Than text box, 304
Forcing sort order
  page references, 136–137, 137f, 138f
  special characters for. See Angle brackets (< >); Backslash (\);
    Braces ({}); Tilde (~)
Foreign letters. See Accented letters
Format
  of displayed or printed entries. See Formatting
document, saving formatted indexes, 188–190
imported records, 204–209
Formatting, 167–185. See also Draft formatted view; Fully for-
Greek letters. See Symbols

Group Method drop-down list, 289

Group View menu item, 283

Grouping elements of conditional search, 82

Grouping Entries… Document menu item, 289, 289f

Grouping formatted entries, 172–174

adding cross-references to, 234

excluding from search, 78

permanent, 70, 75

rebuilding, 75, 229, 231, 233

sorting, 69

Groups of records, 68–70

adding cross-references to, 234

creating

by duplicating records, 53

from search results, 75

from selected records, 69

deleting, 233f, 234

icon, 6

information on, 233

invalid, 229, 231

limitations, 70

permanent, 70, 75

rebuilding, 75, 229, 231, 233

sorting, 69

temporary, 68–70, 75

viewing, 69

Groups… Tools menu item, 316, 316f

Gutter, between columns, 168, 169

Gutter text box, 286

H

Half flp 8–44

Hard (non-breaking) space, 140

Hart’s Rules, 141–142

Hash (#) mark. See Pound sign

Header (alphabetic group), 172–174

Header/Footer tabs, 287

Headers and footers

in index printed by Cindex, 170–172

omitting in saved documents, 188

saved settings for, 185

Headers & Footers… Document menu item, 287–288, 287f

Headings, 9. See also Main heading(s); Modified headings; Subheading(s)
checking consistency of, 224–225
confining actions to, 262
  replacing text, 91–92
search, 78
  spelling check, 108
"continued," 169
demoting, 44–45
entering in records, 23–25
finding entries by, 71–73
  in letter-by-letter or word-by-word sort, 155
formatting. See Formatting, headings
level of deepest, 220–221
punctuation for, 181–183
reconciling levels, 99–101
record structure, 20, 22
SGML markup tags for, 197
splitting, 97–99
suppressing, 183
text styles, 181–183
XML markup tags for, 195
Headings… Document menu item, 291–292, 292f
Help menu
  Help Topics, 317
  About Cindex…, 317
  Check for Updates, 317
Help, online, 5
Help Topics Help menu item, 317
Hidden records, 61, 262
Hidden text
  controlling alphabetizing, 161–162
  embedded index entries as, 201
Hide by Attribute… View menu item, 284
Hiding. See also Suppressing
  characters or words, sorting entries, 159–163, 160f, 161f
  deleted records, 55, 60
  record numbers, in draft formatted view, 63, 63f
records, 61, 262
HOME key, 24t, 71t
Hot keys, 48
Hot Keys… Tools menu item, 312
HyperText Markup Language (HTML) markup standard, 189
Hyphen/Minus (-)
  in chapter-page numbering, 127
denoting inclusive range of pages, 127, 140
in patterns
  changing case of text, 251–252
  inside square brackets ([ ]), 243
in replacement patterns, changing case of text, 251–252
  sorting entries with, 153
  ignoring in word-by-word sort, 157

I
Icons, document types, 6
ID. See User identifier
Identical records. See Duplicate records
Identify dialog box, 306
Identifying the indexer. See User identifier
Ignore All button, 277
Ignore Alphanumeric Strings check box, 278
Ignore button, 277
Ignore -/ check box, 307
Ignore, :; check box, 307
Ignore Different Labels check box, 309
Ignore Lowest Subheading check box, 308
Ignore Parenthetical Endings check box, 307
Ignore Parenthetical Phrases check box, 307
Ignore Style & Case check box, 281
Ignore Subheading Prefixes text box, 306
Ignore Words in CAPITALS check box, 278
Ignoring text
during sorting
  characters or words, 159–161, 160f, 161f
  leading words in subheadings, 156–157
  lowest subheading, 150–151
  segments of page references, 133
  specified fields, 149
  during spelling check, 110
  specified fields, 108
Import… File menu item, 269
Importing records, 204–209
Inactive indexes, 13
Inches. See Units of measurement
Include Deleted Records check box, 267
Include Sorting Information when Embedding Entries check box, 282
Inclusive page ranges. See Range of page references
Inconsistent capitalization check box, 301
Inconsistent endings check box, 302
Inconsistent leading conjunctions and prepositions check box, 302
Inconsistent punctuation check box, 301
Inconsistent style/typeface check box, 301
Increment page reference, 41
Incremental indentation, 178, 179
"special last" level, 179, 180
Indentation, formatted entries, 178–180, 178f
in exported documents, 188
  tab characters for, 192
setting size of, 179–180
**Indented** button, 290
Indented index style, 60f, 175–178
cross-references, location and style, 119
draft view, 62, 62f
overriding, 176–177
“runback” style, 176
InDesign document tags, 189
**InDesign Tagged Text**, drop-down list item, Save As dialog box, 266
Index
  checking entries in. See Checking records icon, 6
Index entries. See Entries
Index pages, printed by Cindex, 83–84
  numbering, in headers and footers, 171
ranges
  finding entries on, 73
  saving formatted entries on, 191
**Index Statistics**… Tools menu item, 311, 311f
Index title, asterisk (*) beside, 11
Indicators, record window, 23f
**Info**… check box, 316
Information
  about index, 217–221
  about record groups, 233
Initial capital letter, 36
  cross-references, 122–123
  headings, 182
  pattern for conversion, 254
Initial page number, in index printed by Cindex, 171
Initial settings. See Default settings
Insert, keyboard mode indicator, 23f
Inserting
  abbreviations, 52
  fields, 25, 42
  main headings, 44–45
  text, hot keys for, 48
Inside margins, 168
Insufficient record space
  adjusting references, 94
  entering text, 23
  reconciling heading levels, 101
  replacing text, 88–89
Intelligent flip 8–44

International Standards Organization (ISO), alphabetizing principles, 154
Invalid record groups, 229, 231
ISO alphabetizing principles, 154
Italic style. See also Text style applying to text, 36

**J**
Joining fields, reconciling heading levels, 2–43, 9–101
Justification
  headers and footers, in index printed by Cindex, 171
  page references, 144

**K**
Keyboard control panel, 72
Keystrokes. See also Accented letters; Symbols
  adjusting time delay between, 72
  for editing, 23–25, 24t–25t
  for finding entries, 71
  hot keys, 48
  recording and replaying, 85–86

**L**
**Label Colors** buttons, 282
**Label Sets Change Flag** check box, 281
**Labeled** Edit menu item, 272
Labeled records
  colors for, 55–57
  confining search to, 78
  replacing text, 91
consolidating references, 232
counting, 221
excluding from search, 78
  replacing text, 91
finding, 78
formatted display, 61
hiding, 61, 263
indicator, 23f
Laid-out index style. See Indented index style
Language
  collation convention for sorting, 147
lowercase vs. uppercase collation order, 152
sorting, language script precedence in, 147
for spelling check
  choosing, 103–104, 108–109
  installing dictionary, 108–109
Language drop-down list, 277, 307
Language Script has Precedence check box, 308
Last-saved index, reverting to, 12, 53, 88, 94, 101
Last-used index, automatically opening, 12
Layout. See Formatting; Headers and footers; Indented index style; Margins and columns; Run-in index style; Views and viewing
Lead Punctuation check boxes, 296
Lead text box
  Reference Syntax dialog box, 299
  Style & Layout dialog box, 290
Leading characters
  finding records by, 71–73
  ignoring while sorting entries, 160–161, 161f
Leading punctuation, headings, 183
Leading Text text box, 292
Left/Center/Right text boxes, 287–288
Left-hand pages. See Even numbered pages, in index printed by Cindex
Left/Inside text box, 286
Length
  of index, 218–220
  of index record, 212
  of lines, formatted entries, 169
  of text, new entries, 27–28
Letter-by-letter alphabetizing, 152, 154–155
  overriding rules for, 159–163
Letters of alphabet. See also Character(s) accented. See Accented letters
  counting records falling under, 220–221
  grouping entries under, 172–174
  sorting, 152
Levels. See Headings; Record fields
Limits. See also Maximum number abbreviations, 50
  record size and structure, 211–214
Line(s)
  length, in formatted index, 168
  number, 218
  spacing, 180
Line-breaks
  formatting page references, 140
  run-over lines, omitting in saved documents, 188
 Manage Cross-References… Tools menu item, 304
Managing index documents, 211–237
Manuscript pages. See Page proofs
Margins and columns, 167–169
  headings repeated at column breaks, in index printed by Cindex, 169
  omitting column breaks, saving formatted indexes, 188
  saved settings, 185
Margins and Columns… Document menu item, 285–287, 286f
Mark Records with No Matches check box, 306
Marked records
  after adjusting references, 94
  after importing records, 209
  after reconciling heading levels, 101
  after repairing index, 12
  after replacing text, 88–89
  after splitting records, 98
  confining actions to, 263
  confining search to, 77
    replacing text, 91
    counting, 221
  excluding from search, 77
    replacing text, 91
  finding, 77
  removing mark from, 89
Markup tags, for formatted indexes, 188, 189
  built-in, 194
  creating sets, 194
  examining and modifying, 193–199
  invoking, 194
  removing, 194
Markup Tags… Tools menu item, 313–315, 313f
Master index, cumulating and combining indexes as, 234–236
Match Case check box
  Find window, 274
  Replace window, 276
Match Pattern check box
  Find window, 274
  Replace window, 276
Match text box, 299
Match Whole Word check box
  Find window, 274
  Replace window, 276
Matching Pattern text box, 305
Maximize Cindex check box, 279
Maximize on Opening check box, 279
Maximizing windows, 15
Maximum Characters text box, 298
Maximum characters. See also Limits
  characters in a field, 213–214
  characters in record, 212
  fields in record, 212–213
  of macros, 86
  in page reference, 46–47
  undifferentiated page references, 130
Maximum Number of Recent Indexes drop down list, 279
Maximum Value text box, 299
  .mbk filename extension, import document, 207
Measurement, units. See Units of measurement
Medical dictionary, 103, 109
Menu(s). See also individually named menus
  context-sensitive, 38
  items (summarized), 264–317
Merge Redundant References check box, 295
Merging redundant page references, 146
Microsoft Word
  accented letters, 26
  embedding index entries in, 200–201
Millimeters. See Units of measurement
Minimum Characters text box, 298
Minimum number
  characters in a field, 213–214
  fields in records, 212–213
  export documents, 204
  target entries, for verifying cross-references, 228
Minimum Number of Fields text box, 267
Minus (-) key, 43. See also Hyphen/Minus (-)
Mismatch
  angle brackets or braces, 30
  parentheses or square brackets, 30
  quotation marks, 30
Mismatch to Template buttons, 281
Misplaced or questionable punctuation check box, 301
Misplaced punctuation, checking for, 223
Missing font, 214–216
Missing locators
  finding, 79
  warning, 46–47
Missing space before parentheses or brackets check box, 301
Missing spaces, checking for, 223
Missing targets, cross-references, 225–228
Misspellings, finding. See Spelling check
Misused special characters check box, 300
Misused special characters, checking for, 223
Mixed case words, 223
Mixed case words check box, 301
Modification date. See also Modified records
    confining actions by, 262–263
    finding entries by, 77
    index, 218
    replacing text by, 91
Modified headings
    reconciling heading levels, 101
    verifying cross-references to, 227
Modified records. See also Editing records; Modification date
    confining actions to, 263
    confining search to, 77
    replacing text in, 91
    counting, 221
    excluding from search, 77
    finding, 77
    identifying in draft view, 29
    new entries and, 29
    spelling check, 108
Modifying Phrases Follow text box, 303
Month names, in locators, 128, 131–133
    rearranging format of, 254–255
More than N undifferentiated dialog box, 303
Mouse. See Clicking; Double-clicking
Mouse pointer, 67
Moving chapters or sections, adjusting references following, 95–97
Moving through index. See Navigation
Multi-part references, 125f, 127–128
    adjusting parts, 94, 255–257
    evaluation order for sorting, 133–135
    finding entries, 79, 134–135
    formatting, 142–143
    abbreviating, 141–142
    concatenating, 143
    suppressing repeated parts, 142–143
    overlapping ranges, 228–229
    patterns, 255–257
    text styles, 144–145
Multiple columns. See Margins and columns
Multiple indexes
    concurrent work on, 13
    displaying, 317
Multiple references
    consolidating in single record, 231–232
    entering in records, 32, 33
    single record for each, 229
    sorting cross-references, 121–122
    sorting page references, 136
Multiple spaces, in records, 40
N
Names
    index name in headers and footers, 171
    months, in page references, 128
    proper, when reconciling headings, 101
    splitting headings for author indexes, 97–99
Naming
    dictionary, for spelling check, 105–106
    documents, saving formatted indexes, 191
    markup tag sets, 194
    new indexes, 10, 217
    permanent groups, 70
    record fields, 213–214
Navigation, 31, 71–73, 71t
    searching backward through index, 80
    shortcuts for finding entries, 71–73, 71t
Never/At New Page/At New Column buttons, 286
New Abbreviation… Edit menu item, 278
New… button
    Markup tags dialog box, 313
    Spelling panel, 278
New document. See also Saving documents
    abbreviation set, 51
    index, 10
    initial settings, 216–217
    from template, 217
    personal dictionary, for spelling check, 105–106
New… File menu item, 264
New Group File menu item, 269
New Record Edit menu item, 271
New records
    adding to index, 22–37. See also Editing records
display options, 29–30
    confining actions to, 263
    excluding from search, 77
    identifying in draft view, 29
    replacing text in, 91
    searching among, 77
    spelling check among, 108
    viewing, 68
New Records View menu item, 283
No Action button, 279
Non-breaking hyphen, 140
Non-breaking space, 140
Not check box, 273
“not,” conditional searches, 80, 80f, 81f
Notational conventions, User’s Guide, 5
Notes, 34, 213
Number(s). See also Numerals
characters in fields, 213–214
characters in record, 22, 212
available, 23
longest, 220–221
used, 23
fields in records, 21–22
exporting records, 204
importing records, 205–206, 208
limits, 212–213
pasting records, 54
formatted entries, 218–220
index statistics, 217–221
page references and cross-references, 218–220
in patterns, 246–247
records, 220–221
Roman. See Roman numerals
Number Format drop-down list, 288
Number of Fields drop-down lists, 298
Numbering
printed index pages, 171
records, 20
Numerals. See also Page references; Roman numerals
in alphabetizing, 153–154
evaluating, 158–159
filing order vs. letters and symbols, 156
filing under, 163–164, 163f
spelling out, 161–162, 162f
grouping formatted entries under, 173
headings beginning with
finding by, 72, 76, 90
printing, 84
spelling check, 107
identifying subpatterns, 246–247
ignoring in spelling check, 110

O
Obligatory field, for special text, 34, 213
Odd numbered pages, in index printed by Cindex
headers and footers, 171

P
Page breaks
“continued,” headings, in index printed by Cindex, 169
omitting, when saving formatted indexes, 188
INDEX

PAGE DOWN key, 24t, 31, 71t
Page field. See Locator field
Page layout
for exported formatted index, 187–188
for indexes printed by Cindex. See Headers and footers; Margins and columns
Page locators. See Multi-part references; Page references
Page numbers
on index pages printed by Cindex, 171
temporary folios, compiling index from, 257–259
Page order sort, 149–150
shortcut, 151
Page proofs
adjusting references to rearranged sections and chapters, 95–97
average entry count per page, 221
temporary folios, using to compile index, 257–259
Page references, 125–146. See also Multi-part references
abbreviating, 32, 127, 129, 141–142
changing. See Adjusting references
checking, 46–47, 79, 130, 228–229
conflating, 140–141, 143
counting, 219
in cumulative indexes, 235
deleting. See Adjusting references
duplicate references, 146
in embedded index entries, 200–201
entering in records, 25, 32, 33
finding, 78–80
multi-part, 134–135
formatting, 138–146
saved settings, 185
forms, 125–128
ignoring
sorting entries, 161
in spelling check, 108
inclusive range. See Range of page references
increment/decrement shortcut, 41
letters in, 128
malformed, 46–47
finding, 79
maximum value, 46–47
missing, 46
after altering references, 257
month names in, 128, 131–133
multiple in entry
display order, 145–146
evaluating and sorting, 130
multiple, individual records for, 229
overlapping ranges, 228–229
punctuation
denoting inclusive range, 127
preceding, 143–144
separating successive, 32, 126–127, 229, 232
in SGML marked-up documents, 197
in XML marked-up documents, 195, 196
recognizing, 127–128
redundant references, 146
reorganizing via patterns, 252–255
Roman numerals, 128
SGML markup tag for, 197
sorting, 130–138
suppressing, 146
temporary, 257–259
text styles, 129–130, 144–145
undifferentiated, 130, 228–229
warnings, 46
XML markup tag for, 195
Page References… Document menu item, 294–296, 294f
Page Setup… File menu item, 269
Page setup, for printing, 83
Page size, 83
PAGE UP key, 25t, 31, 37, 71t
Pagination. See Page numbers
Paragraph style. See Run-in index style
Paragraphs
end of, SGML markup tag for, 199
imported records prepared on word processor, 206
styles, for markup, 188, 192
Parentheses
defining subpatterns, 243–244
exchange text content with acronym, 42
ignoring contents, in sort, 157–158
mismatched, in records, 30, 223
Parenthetical endings, ignoring, in spelling check, 103
Paste and Drop Text button, 281
Paste Edit menu item, 271
Pasting
records, 53–54
text, 40
Patterns, 239–259
adjusting references, 94, 255–259
character sets, 240–242
finding entries, 79–80
minimum or maximum match, 246–247
pre-formed elements, 249
Patterns (Continued)

ready-made, 249
replacing text, 92, 250–255
sample, 249
special characters in
finding text, 240–249
replacing text, 250–255
specifying record structure, 214
subpatterns, 243–244
Percent symbol (%)
in header/footer template, 171
representing alpha group header, 171
Period (.)
in patterns, 240
with asterisk (*), 242
within square brackets ([ ]), 241
sorting, 152–153
in letter-by-letter alphabetizing, 157
Personal dictionaries, in spelling check, 105–106
Personal Dictionary drop-down list, 278
Phrases
abbreviations representing. See Abbreviation(s)
attaching to hot keys, 48
finding, 73–83, 74f
replacing. See Replace
type style automatically applied to, 183–184
Picas. See Units of measurement
Plain Character menu item, 285
Plain text
in exported records, 201, 202
in imported records, 206
page references, 128
removing styles, 36
saving formatted indexes, 189–190
Plain Text, drop-down list item, Save As dialog box, 266
Plain Text/RTF/Quark/InDesign buttons, 282
Play Events Tools menu item, 316
Plus (+) character, in patterns, 245
replacing text, 251–252
Plus (+) key, 24f, 43
Plus (+) symbol, in drag list, 132, 148–149
Pointer, mouse, 67
Points. See Units of measurement
Position drop-down list, 293
Pound sign (#)
in draft index view, 88–89, 94
in header/footer template, 171
Preferences. See also Default settings
adding records, 28–29
automatic saving interval, 11, 14–15
editing records, 28–29, 29f, 41, 43, 47, 62
embedding entries, 201
font, 35, 35f
general, 13–17, 14f
labeled records, 55–57
new indexes, 216–217
new record display, 29–30
restoring original, 217
toolbars, 16–17
view, 16, 35f
Preferences… Edit menu item, 279–282, 279f
Preferred drop-down list, 311
Preferred font, 214–216
Prefix Style button, 294
Prefix text
for cross-references, choosing style for, 122–123
for headings, 183
Prefix text box, 293
Prepositions
flipping record fields with, 43–44
ignoring in subheading, 156–157
leading, 224
Preserve Modified Headings check box, 303
Preview Splits check box, 306
Print File menu item, 270
Printed pages. See Index pages
Printing, 83–84
page setup, 83
specified entries, 84
Prompt for User ID check box, 279
Proofs. See Page proofs
Propagate Changes check box, 281
Propagating changes, 45–46
Protect Names check box, 303
Protecting names, when reconciling heading levels, 101
Punctuation
adjusting automatically, 181
cross-references, 112, 113, 118–119
expanding abbreviations, 52
headings, 183, 224
misplaced or questionable, 223
page references, 126–127, 143–144
patterns for, 241
in sorting, 152–153, 157
spelling check, 104
Q
QuarkXPress document format, 189
QuarkXPress document tags, 189
QuarkXPress, drop-down list item, Save As dialog box, 266
Question mark ( ? )
in dialog boxes, 5
in patterns, 246
finding minimum match, 249
Questionable punctuation, 223
Quitting, 11
Quotation marks
closing punctuation around, 181
expanding abbreviations, 52
mismatched, 30, 223

R
Range of page references, 127
abbreviating, 129, 141–142
adjusting, 94
automatically completing, 41
character denoting, 32
checking, 46–47
conflating, 140–141, 143
in embedded index entries, 200
entering, 32
formatting, 139–142
limiting span, 46–47
overlapping
checking for, 228–229
merging duplicate/redundant, 146
searching among multi-part references, 134–135
Range of records
checking spelling in, 107–108
confining actions to, 261–263
counting among, 221
exporting, 203
printing, 84
replacing text in, 90
saving formatted indexes, 191–192
searching in, 76–77
Range to Save buttons, 268
Read Only check box, 264
Read only, opening an index as, 12
Reading records (importing), 208–209
Rebuild button, 316
Rebuilding groups of records, 75, 229, 231, 233
Recent documents, opening, 12
Recognize Cross-References in Locator Field Only check box, 300
Reconcile Headings button, 303
Reconcile Headings… Tools menu item, 303, 303f
Reconciling headings, 43, 99–101
proper names, protecting, 101
restrictions on, 68, 70, 150
Record(s), 9, 19–22, 21f
average number per indexed page, 221
counting, See Checking records
damaged, 12
deleted. See Deleted records
editing, See Editing records
empty. See Empty records
exporting, 201–204
fields. See Record fields
finding. See Finding entries
hidden, 61, 262
new. See New records
obligatory field, 34, 213
range. See Range of records
removing permanently, 230–232
saving. See Saving
selecting, 67–68, 67f
size. See Record size
sorting. See Sorting
special text fields in, 34, 213
structure, 20–22, 211–214, 212f
from template, 217
viewing. See Views and viewing
web address in, 34, 213
Record Events Tools menu item, 315
Record field, 20–21
confining actions to
replacing, 91–92
searching, 78
spelling check, 108
content restriction, 22
empty. See Empty record fields
evaluation order, in sorting entries, 147–151
exchanging/ flipping, 43–44
inserting, 25, 42
joining, 42–43, 99–101
length, 22, 213–214
naming, 21, 213–214
Record fields (Continued)
number, 21–22
in exported records, 204
limits, 212–213
obligatory, 34, 213
retrieving from last-edited record, 41
splitting, 42, 99–101
Record number, 20
change after compressing entries, 231
with deepest heading level, 220
exporting records by, 203
finding entries by, 72, 73
longest record, 220
showing or hiding, in draft view, 63, 63f
specifying records to find, 262
viewing records in order by, 66
Record size, 22
changing, 212
consolidating references from multiple records and, 232
importing records and, 208
longest record, 220
transferring records between indexes and, 54
Record Structure… Document menu item, 297–299, 298f
Record window, 21f, 22–26, 23f. See also Editing records; New
records
buttons in, 31, 37, 43
closing, 28–29
duplicating records, 53
keyboard shortcuts in, 24
moving through entries, 31
status line, 24, 55
Recording keystrokes, 85–86
Recto pages. See Odd numbered pages, in index printed by Cin
dex
Redo Edit menu item, 270
Redundant page references, suppression of, 146
Redundant subheadings. See Orphaned subheadings
Reference Syntax… Document menu item, 299–300, 299f
References. See Cross-references; Multi-part references; Page refer
ences
Refreshing groups, 75
Regional and Language Settings Control Panel, 172
Regular expressions. See Patterns
Remove Deleted Records check box, 309
Remove Duplicated Records check box, 309
Remove Empty Records check box, 309
Remove Extra Spaces check box, 280
Remove Generated Records check box, 309
Remove Mark contextual menu item, 89
Remove Orphans button, 303
Remove References button, 305
Remove Styles check box, 306
Removing abbreviations, 50
orphaned subheadings, 99–101
record groups, 233f, 234
records, 230–232, 230f
generated, 117, 231
redundant subheadings, 99–101
references to entries in selected volumes, 257
references to specified page numbers, 95
spaces, automatically, 40
text, by replacing, 88
Renumbering. See also Adjusting references
indexed (proof) pages, 257–259
records, following index compression, 231
Repagination of text, changing entries following, 257–259
Repair index, 12
Repeating headings
after page or column break, in index printed by Cindex, 169
in formatted display, 177–178
Replace, 87–92. See also Finding entries
clear current settings, 88
fonts, 89–90
removing text, 88
repeating search, 88
styles, 89–90
temporary page numbers, 257–259
undoing changes, 88
using patterns with, 92, 250–255
Replace All button, 275
Replace… Edit menu item, 274–276, 275f
Require at least N matches dialog box, 302
Require exact matches check box, 302
Reserved characters. See Angle brackets (< >); Backslash (\);
Braces ( { } ); Tilde (~)
Reset button
Find window, 273
Replace window, 275
Spelling window, 277
Restoring. See also Revert
deleted records, 55
index to last-saved, 12
original Cindex settings, 217
Resume button, 277
RETURN key, 25
breaking fields, 42
completing entry, 28, 29
completing record field, 25
inserting fields, 42
opening entry for editing, 71

**Return to Entry Point** check box, 281

**Revert to Saved** File menu item, 268

Reverting
edited record, 37
to last-saved index, 12, 53, 88, 94, 101

Rich Text Format (RTF), 188–189
for embedding index entries, 200–201

**Rich Text Format (RTF)**, drop-down list item, Save As dialog box, 266

Right justified page references, 144
SGML markup tag for, 199–200

**Right Justify** check box, 295

Right-click, 36
creating abbreviations, 49

Right-hand pages. See **Odd numbered pages**

**Right/Outside** text box, 286

Roman numerals
in headers and footers, 171
in locators, 128, 131–133

RTF. See **Rich Text Format (RTF)**

**Run-in** button, 290

Run-in index style
cross-references, 119–120
formatting, 175–178
for specified entries, 177

Running head
in index printed by Cindex, 169
omitted in saved formatted index, 188

Runover lines. See **Continuation lines**

**Runover** text box, 291

---

**S**

Sample patterns, 249

**Save As...** File menu item, 265–268

**Save Backup Copy...** File menu item, 268

**Save** File menu item, 265

**Save Group...** File menu item, 269

**Save Open Indexes Every...** text box, 279

**Save Style Sheet...** File menu item, 268–269

Saved index, reverting to, 12, 53, 88, 94, 101

Saving documents
abbreviations, 51
archives, 202
for Cindex for Macintosh, 202
exporting records, 201–204
formatted indexes, 187–199
Adobe InDesign, 189
part of index, 191–192
plain text documents, 189–190
QuarkXPress tagged, 189
Rich Text Format, 188–189
tagged text. See Markup tags, for formatted indexes
style sheets, 185

Saving index entries, 28–29
automatically, at regular intervals, 11, 14–15
changes to, 37

SBL (Society of Biblical Literature), alphabetizing principles, 154

Scope of operations, 261–263
counting records, 221
ten statistics, 219–220
exporting records, 202–204
finding entries, 76–77
replacing text, 91
saving formatted indexes, 191–192
spelling check, 107–108

Scripts, in pattern search, 242
Search. See **Finding entries**; **Replace**
Sections of book rearranged, adjusting references to, 95–97
See also references. See **Cross-references**
“See,” other than in cross-reference, 113
See references. See **Cross-references**

**Segment Order** drag list, 308

Segments, page references, 127–128, 133–135. See also Multi-part references

**Select All** Edit menu item, 271
Selecting entries, 67–68, 67f
Selecting text of entry, shortcuts for, 24t

Semicolon (:) finding entries by beginning text in subheadings, 72, 262
separating cross-references, 113
sorting, 152–153, 157
Separating punctuation cross-references, 112, 113
page references, 126–127

**Separator** text box
Cross-References, 299
Page References, 299
Serial publications, cumulating, 234–236
Set-out style. See Indented index style
Sets of records. See Groups of records
SGML. See Markup tags, for formatted indexes
SGML Tagged Text, drop-down list item, Save As dialog box, 266
SGML Tags tab, 313, 314–315
SHIFT key
  modifying PAGE DOWN, 31, 53
  pasting text, 40
  to restore original settings, while starting Cindex, 217
  reversing flip mode, 43
  selecting entries, 67
  selecting text, 24t
Shortcuts
  abbreviations as, 49–52
  adding and editing entries, 24t
  automatic completion of record fields, 38–39
  customizing toolbars, 16–17, 17f
  finding records, 71t
  hot keys, 48
  increment/decrement locator, 41
Show Numbers View menu item, 284
Show Open Panel button, 279
  restrictions, 157, 158, 159
Single spacing, 180
Size. See also Record size
  indentation units, 179–180
  index statistics, 217–221
  limits, abbreviations, 50
  paper, for printing, 83
  text. See Text size
Size drop-down list, Headers & Footers dialog box, 288
Sky Index, importing records from, 206–207
Sky Text (*.sky7), drop-down list item, Import dialog box, 269
  .sky7 filename extension, 206
Slash (/), sorting, 153
  ignoring in word-by-word sort, 157
Small caps. See also Text style
  applying to text, 36
  display in record-entry window, 36
  in User’s Guide, 5
Smart flip 8–44
  words permissible for title case, 182
Smart flip check box, 280
Smart flip words
  permissible for title case, 182
  splitting headings, 98
Smart Flip Words Document menu item, 300
  Society of Biblical Literature (SBL), alphabetizing principles, 154
Solidus (/). See Slash (/)
Sort…, Tools menu item, 306–309, 307f
Sorted view, 66
  status indicator, 60f
Sorted View menu item, 284
Sorting, 147–166
  alphabetically. See also Alphabetizing toolbar button, 66
cross-references. See Cross-references
embedded index entries, 201
field evaluation order, 147–151
identical records, 154
ignoring fields, 148–151, 161
language script precedence, 147
letter-by-letter. See Letter-by-letter alphabetizing letters, 152
  in page references, 131–133
  precedence, 156
  numbers, 153–154, 158–159
  as literal characters, 163–164, 163f
  precedence, 156
  spelling out, 161–162, 162f
  overriding sorting rules, 159–163
  in page reference order, 149–150
  toolbar button for, 66, 151
page references. See Sorting page references
  punctuation, 157
  saving preferred settings for, 217
  shortcuts, 151
  simple. See Simple alphabetizing
  substitutions of text in, 165–166
  symbols
    as literal characters, 163–164, 163f
    precedence, 156
    spelling out, 161–162
  word-by-word. See Word-by-word alphabetizing
Sorting page references, 131–138
  ascending/descending, 135
  in formatted view, 145–146
  ignoring, 161
  letters in, 131–133
  multi-part
    precedence of segment types, 133–135
    segments evaluation order, 133–135
    multiple in entry, display order, 145–146
    forcing, 136–137, 137f, 138f
overriding standard rules, 136–137, 137f, 138f

Space character
  in alphabetizing, 153
  leading and trailing, 25, 30, 42
  missing, 223
  non-breaking, 140
  omitting between references, 25
  superfluous, removing, 40

Spacing
  alphabetical groups, 180
  columns, 168, 168f
  lines, 180
  main headings, 180

Special characters
  angle brackets (< >). See Angle brackets (< >)
  backslash (\). See Backslash (\)
  bar (|), to override format, 177
  braces ({ }), See Braces ({ })
  in headers and footers, 171
  misused, 223
  in patterns, 240–249
  in replacement patterns, 250–255
  tilde (~). See Tilde (~)
  in titles to groups of entries, 173

Special tab, 315

Special tags, for document markup, 193

Special text field, for comment or URL, 34, 213

Spelling check, 103–110
  alphanumeric sequences, 110
  among specified records, 107–108
  capital letters, 110
  clearing list of words to be ignored, 110
  cross-references, 108
  dictionaries, 103, 105–106
  medical terms, 103, 109
  personal, 105–106
  duplicate words, 105
  languages, 103, 108–109
  numerals, 108, 110
  page references, 108
  in specified record fields, 108
  suggesting alternatives, 104–105
  enabling/disabling, 109–110

Spelling… Edit menu item, 276–278, 278f

Split Headings… Tools menu item, 305–306, 306f

Splitting headings, 97–99

Splitting index into parts, 236–237

Splitting record fields, 99–101

Spreads of page references. See Range of page references

Square brackets ([ ])
  mismatched, in records, 30
  in patterns, 242–243
  in User’s Guide, 5

Stamping records
  date and time, 30–31
  user identifier, 30–31

Standard dictionary, spelling check, 103

Standard font. See Default font

Standard settings. See Default settings; Preferences

Start button, 277

Starting an index, 10–18

Startup, opening an index on 13

Statistics
  general index, 217–220, 218f
  records and alphabetic groupings, 220–221, 220f
  Status line, 60f
  macro recording, 86
  record window, 23, 23f, 55

Storing text
  on hot keys, 48
  for recall via abbreviation. See Abbreviation(s)

Strings. See Text strings

Structure
  cross-references, 112–113
  page references, 126–127
  records, 20–22, 211–214

Structure Elements tab, 314

Structure markup tags
  SGML, 197–198
  XML, 194–196

Structure tags, for document markup, 193

Structure Tags tab, 315

Style
  headings, checking, 224
  index, 174–181, 174f. See also Indented index style; Run-in
  index style
  saved settings, 184–185
  names, setting, 192–193
  text. See Text style

Style and Layout… Document menu item, 290–291, 290f
Style button
   Grouping Entries dialog box, 289
   Headers & Footers dialog box, 288
   Headings dialog box, 292
   Margins & Columns dialog box, 287
   Page References dialog box, 296
Style names, setting, 192–193
Style Precedence drag list, 308
Style sheet, 184–185
   icon, 6
Style tags
   SGML document markup, 198
   XML document markup, 196
Style Tags tab, 315
Styled Strings… Document menu item, 296–297, 297f
Subhead Indent buttons, 268
Subhead Preceding Locator is Required check box, 298
Subheading(s), 9. See also Sub-subheadings
   creating, from modified headings, 99–101
   cross-references as, 113
       displaying in formatted view, 119–120
   cross-references from, formatting, 121
   cross-references to, 227
   display in draft view, 63
   entering in records, 25
   finding entries by, 72, 262
   formatting
       draft view, 62–64
       indentation, 178–180
       styles, 175–178
   limiting text replacement to, 91
   obligatory, 34, 213
   orphaned (redundant), 99–101, 225
   searching among, 78
   SGML markup tags for, 197
   sorting, 147–151
       ignoring, 148–151
       ignoring leading words, 156–157
       special last, 34, 213
   verifying cross-references to, 227
   XML markup tags for, 195
Subpatterns, 243–244
Subscript characters, 36. See also Text style
Subsets of records. See Groups of records
Substitute
   font. See Font(s), substitution
   text. See Replace
Substitution button, 308

Substitution of text, in sorting, 165–166
Substitutions. See Replace
Sub-subheadings
   modified indented style, 177
   modified run-in style, 176
   orphaned (redundant), 99–101, 225
Suffix text box, 293
Suggest button, 277
Suggested alternatives, spelling check, 104–105, 109–110
Summary view, 64–65, 65f
Summary View menu item, 283
Superscript characters, 36. See also Text style
Suppress all References check box
   Cross-References dialog box, 293
   Page References dialog box, 296
Suppress check box, 292
 Suppress Repeated Parts check box, 295
Suppress to text box, 295
Suppressing. See also Hiding
   components of multi-part references
       leading parts, display, 142–143
       in sorting, 133
   cross-references, 122
   deleted entries, 54–55
   duplicate page references, 146
   headings and subheadings, 183. See also Collapsing headings
   leading/trailing punctuation in references, 196, 198
   page references, 146
   redundant page references, 146
   repeated headings, overriding, 177–178
Suspect cross-references, 228
Switch to Draft View check box, 280
Symbol font, imported records, 207
Symbols
   entering in records, 26, 27f
   grouping formatted entries, 173
   patterns for, 241
   sorting, 153
       filing order for, 156
       as literal characters, 163–164, 163f
       spelling out, 161–162, 162f

T

Tab character
   as lead indent to subheading, 192
   markup tag for, 199
Tab key, 25
  editing text, 24
  expanding abbreviation, 52
  selecting record, 67
  showing selected record, 71
Tab-delimited text
  exported records, 202
  imported records, 205–207
tag, filename extension, 199
Tags. See Markup tags, for formatted indexes
Template
  icon, 6
  index format. See Formatting
  for new index, 217
  for patterns. See Patterns
  record fields, 214
    suppressing parts of multi-part references, 142–143
Template, drop-down list item, Save As dialog box, 265
Temporary group of records, 53, 68–70, 75
Temporary Group View menu item, 283
Temporary page numbers, indexing with, 257–259
Text editor, importing records from, 206
Text fields. See Record fields
Text size
  default settings, 15, 35
  in headers and footers, 171
  in style sheets, 185
Text strings
  finding in entries, 73–83, 74
  replacing in entries, 87–92
  style automatically applied to, 183–184, 184
Text style, 36
  adjusting punctuation around, 181
  automatically applied
    cross-references, 34, 122–123
    headings, 182
    page references, 144–145
    specified words and phrases, 183–184, 184
  in automatically completed entries, 39
  boldface italic
    SGML markup tag for, 198
    XML markup tag for, 196
cross-references, 34, 122–123. See also Cross-references
in imported records, 208
discarding
  in drag-and-drop, 41
  in paste, 40
  in drag-and-drop, 40
in embedded index entries, 201
in exported records, 202
finding entries using, 76
headers and footers, 171
headings, 182. See also Headings
hidden, 201
page references, 129–130, 144–145
  sorting, 132–133
preferences, 185
removing, 36
replacing, 89–90
SGML markup tags for, 198
for titles to groups of entries, 173–174
in verification of cross-references, 227
XML markup tags for, 196
Text-only documents, saving formatted indexes, 190
Tilde (~)
  checking use of, 223
  as literal character, 27
    sorting, 164
  in records imported from Macrex, 207
  with smart flip prefix/suffix, 44
in sorting entries
  overriding ignored subheading prefixes, 157
  reserved characters as literal characters, 164
  symbols and numbers as literal characters, 163–164, 163
    suppressing cross-reference recognition, 113
Title Window menu item, 317
Time
  in headers and footers, in index printed by Cindex, 171
  between keystrokes, 72
  record creation/modification, 30–31
    replacing entries by, 90
  work on index, 218
Time delay, between keystrokes, 72
Title. See also Headers and footers
to group of entries, in index printed by Cindex, 173
Title bar, asterisk (*) in, 11
Title case
  automatic application to cross-reference body, 123
  for formatted heading, 182
Title Text text box, 289
To Level drop-down list, 287
Toolbar buttons, 264
copying/pasting records, 53, 54
deleting/restoring records, 54–55
draft formatted view, 61
entering/editing records, 23, 31
Toolbar buttons (Continued)
  default font, 36
  flipping fields, 43
  propagating changes, 46
  restoring record text, 53
  text styles, 36
finding entries, 73
fully formatted view, 59, 60
hiding text from sorting, 160
including text for sorting, 162
labeling/unlabeling records, 55
new record, 22
record window, 31
sorting entries, 151
view all records, 53, 68

Toolbars
  buttons. See Toolbar buttons
customizing, 16–17, 17f
drop-down list
  font, 263
  font size, 263

Tools menu, 300–316
  Check Index… tab, 300–303, 300f
  Reconcile Headings…, 303, 303f
  Manage Cross-References…, 304, 304f
  Alter References…, 304–305, 305f
  Split Headings…, 305–306, 306f
  Sort…, 306–309, 307f
  Compress…, 309, 309f
  Expand, 310
  Count Records…, 310, 310f
  Index Statistics…, 311, 311f
  Abbreviations, 311
  Hot Keys…, 312
  Fonts…, 311–312, 312f
  Markup Tags…, 313–315, 313f, 314f
  Record Events, 315
  Play Events, 316
  Groups…, 316, 316f

Top text box, 286
Track New Entries check box, 30, 280
Track Source check box, 281
Trailing punctuation
  cross-references, 118–119, 121
  headings, 183
  page references, 144
Trailing Punctuation text box, 292
Trailing spaces, 25, 30, 42

Translating characters
  connecting inclusive page ranges, 140
  importing records, 208, 209
Triple-clicking, selecting field, 25f
Type drop-down list, 290
Type Precedence drag list, 308
Type size. See Text size
Type style. See Text style
Typeface
  headings, checking, 224
  in index entries. See Font(s); Text style
  in User’s Guide, 5
Typesetting. See Saving documents
Typographical errors
  correcting. See Spelling check
  warnings, 30
Typography. See Font(s); Text style

U

UCP markup standard, 189
Unbalanced parentheses or brackets check box, 301
Unbalanced quotation marks check box, 301
Underlining. See also Text style
  applying to text, 36
Undifferentiated page references, 130, 228
Undo. See also Reverting
  discarding changes to records, 37
  drag or paste records, 53
Undo Edit menu item, 270
Unformatted view, 65–66, 66f
Unformatted View menu item, 284
Unicode characters
  character categories, 241–242
  entering in records, 26
  in exported formatted index, 190
  in exported index records, 202
  in imported index records, 206
  ordering, 152, 156
  script sets, 242
  in SGML tagged text, 199
  sorting accented letters, 152
  translation, 209
  in XML tagged text, 194
  Unique main headings, 218
Unit drop-down list
  Margins & Columns dialog box, 286
Style and Layout dialog box
  indentation, 290
  line spacing, 291
Units of measurement
  indentation, 178f, 180
  line spacing, 180, 180f
  margins and columns, 168, 168f
University of Chicago Press. See also Chicago Manual of Style
  markup standard, 189
Unknown character (�), 209
Unnecessary records, compressing index entries, 230–232
“Unpacking” references, 229
Unsorted view, 66
Unusual spellings, sorting, 162–163, 163f'
Update Cindex, automatic check for, 5, 15
Uppercase letters. See also Case-sensitivity
  collation order, 152
  conversion. See Case conversion
  ignoring, spelling check, 110
  in page references, 128
  reconciling heading levels and, 101
  sorting, 152
URLs, in records, 34, 213
Use Additional Dictionaries check box, 278
Use Separate Window check box, 280
User dictionary, 105–106
User ID text box, 280
User identifier, 14, 14f, 23f'
  finding records by, 77
  stamping records with, 30–31
User preferences. See Preferences
UTF-8. See Unicode characters
UTF-8 Encoding/ANSI Encoding radio buttons, 267

V
Variant drop-down list, 290
Verify cross-references check box, 302
Verifying cross-references, 225–228, 226f'
  error report, 228
  while entering in record, 47
Verso pages. See Even numbered pages, in index printed by Cindex
  versus and vs., automatically italicized, 183
Vertical bar (|)
  custom run-in headings, 177
  in patterns, 247

View button, Markup Tags dialog box, 313
View Depth submenu, 284
View menu, 282–284
  Go To…, 282–283, 282f
  All Records, 283
  New Records, 283
  Group, 283
  Temporary Group, 283
  Full Format, 283
  Draft Format, 283
  Summary, 283
  Unformatted, 284
  Hide by Attribute…, 284
  Show Numbers, 284
  View Depth, 284
  Wrap Lines, 284
  Sorted, 284
Viewing, markup tag sets, 193–199
Views and viewing, 59–66. See also Draft formatted view; Fully
  formatted view
  abbreviations, 49–51
  adding/editing records, 62–63
  defining scope of operation, 261–263
  deleted records, 54–55, 60
  groups of records, 68–70
  hidden records, 61, 262
  labeled records, 61
  multiple columns, displaying, 168–169
  multiple indexes, displaying, 317
  printing, 84
  in record number order, 66
  restoring after editing, 37
  sorted entries, 66
  summary of entries, 64–65, 65f'
  unformatted view, 65–66, 66f'
  unsorted entries, 66
Visibility, of records, 61
Volume identifiers. See also Page references
  adding to page references, using patterns, 250–251
  altering references, 255–256
  cumulating and combining indexes, 235
  removing references, 257
  repeated, suppressing in formatted display, 142–143
  vs. and versus, automatically italicized, 183
Warnings
badly-specified range of records, 262
impermissible text in record field, 30–31, 214
insufficient text space in record
  dropping text, 40
  expanding abbreviation, 52
  hot keys, 48
  pasting text, 39
mismatched parentheses or square brackets, 30
mismatched quotation marks, 30
missing/malformed page references, 46
Web addresses, in records, 34, 213
Whole words, searching for, 79, 88, 92
Width, margins and columns, 168–169
Window menu
  Clipboard, 317
  Cascade, 317
  Tile, 317
  Close All, 317
Windows. See also Main window; Record window
  abbreviations, 49–50
  default size, 15
  hot key text, 48
Windows’ character set, 190, 202, 204, 206
Windows’ Explorer
  copying an index, 11
  opening a template, 217
  opening an archive, 205
  opening an index, 12
Word boundary, in pattern, 248
Word processor
  exporting indexes to. See Microsoft Word; Saving documents
  importing records prepared on, 206
Word-by-word alphabetizing, 152, 154–155
  angle brackets, spaces and hyphens within, 160
  hyphen and slash, treatment of, 153, 157
  overriding rules for, 159–163
Work time, 218
Wrap Lines View menu item, 284
Wrapping long entries, unformatted view, 66
Write in Record Number Order check box, 267
Writing order, exported records, 204

X
XML document markup, 188
tags, 194–196
XML Records, 11
  exporting, 201–202
  icon, 6
  importing, 204–205
XML Records (*.iXML), drop-down list item
  Import dialog box, 269
  Save As dialog box, 265
XML Tagged Text, drop-down list item, Save As dialog box, 266
XML Tags tab, 313–314

Y
Years, rearranging in dates, via patterns, 254–255