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This Quick Start Guide helps you launch PCDL Manager Software, 
become familiar with the user interface, view PCDLs, and perform 
typical workflows to create and edit a custom PCDL.
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What’s new in B.08.00?
What is Agilent MassHunter PCDL Manager?

Agilent MassHunter Personal Compound Database and Library 
Manager Software (PCDL Manager) is stand-alone software 
used to manage the content of any personal compound database 
and library (PCDL). A PCDL contains a compound database, an 
ion mobility database, and a spectral library.

You can use PCDL Manager to add, remove and edit the 
compounds in your custom PCDL to meet the specific needs of 
your laboratory and your analyses. The compounds in your 
PCDL must contain, at a minimum, identification and mass. You 
can add retention times based on standards and/or based on 
your sample data acquisition method for compounds you 
routinely analyze. For a custom PCDL, you can also add your 
own spectra, in addition to the spectra provided in the master 
PCDL.

With MassHunter Qualitative Analysis B.07.00 and later, you 
can send GC/MS and MS/MS spectra to PCDL Manager. After 
you perform a Find by Formula search to identify compounds in 
your sample data, you can then send the GC/MS or MS/MS 
spectra to your custom PCDL; however, when you send spectra 
be sure to use comparable software versions, such as version 
B.08 for both Qualitative Analysis and PCDL Manager. You can 
also filter spectral noise and correct the fragment ions to their 
theoretical accurate mass. Qualitative Analysis can also be used 
to automate or manually perform searches of a PCDL to identify 
compounds and spectrum peaks in your data files.

What’s new in B.08.00?

• PCDL Manager has been expanded to include ion mobility 
support.

• Updated user interface with fewer, task-oriented tabs: 
Compounds, Spectra, Ion Mobility, and Import.

• Improved search functionality is available in the Compounds, 
Spectra, and Ion Mobility tabs. The improved search 
functionality includes:
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What’s new in B.08.00?
• Must also contain and Must not contain filter boxes in the 
Compounds tab to allow more specificity in your 
compound searches

• Limit results in the Compounds tab for compounds with 
spectra and/or collision cross section values

• Ion species specific searching in the Spectra and Ion 
Mobility tabs

• Searching of MS Chemical Standard and CCS Chemical 
Standard columns in the Spectra and Ion Mobility tabs

• PCDL Manager has been expanded to include additional 
chemical identifiers (BioCyc, Caymen Chemical, Chapman 
and Hall, ChEBI, InChi, InChi Key, Log P, NCBI, PubChem, 
Sigma Aldrich, SMILES, and UniProt) and new columns (CCS 
count, RT created, RT High (theoretical), RT Low 
(theoretical), and Synonyms). 

• A new Import tab replaces the batch search mode and allows 
you to easily update or import retention times and collision 
cross section values.

• In-table editing of compound, spectra, and ion mobility 
information in your PCDL has replaced the Edit menu found 
in prior versions of PCDL Manager. When you view your 
compounds with editing enabled, a selected cell (compound 
and identifier column) is highlighted in a distinct green color 
indicating that the value can be directly edited.

• View compound information, spectra, and molecular 
structures all at the same time for each compound entry by 
launching the Spectra and Molecular Structure viewers.

• View multiple spectra at one time using the Spectra viewer.

• Create new spectra from published work by adding m/z 
versus relative abundance values.

• Create subset PCDLs directly from the Compounds tab by 
searching for multiple identifiers at one time in the 
Compounds search criteria and using the new Must contain 
and Must not contain filters. 
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Features of PCDL Manager
• New traceability for each spectral or CCS entry with MS 
Chemical Std and CCS Chemical Std columns in the Spectra 
and Ion Mobility tabs (you can add the chemical supplier 
product number in these columns).

• Create and manage the external website links available in the 
Links menu to make finding the information you need to 
manage your PCDLs fast and intuitive.

Features of PCDL Manager

• Search for compounds using text, formula, accurate mass, 
and retention time - you can specify retention time as 
optional or required in your compound search. Using 
retention time increases your compound search specificity.

• Search and view GC/MS and MS/MS spectra in PCDLs.

• Create and edit custom PCDLs, including adding proprietary 
compounds, retention times, collision cross sections, and raw 
experimental or theoretically corrected MS/MS and GC/MS 
spectra. 

• Import retention times and collision cross section values 
from CSV files.

• Send spectra to your customized PCDL directly from 
Qualitative Analysis to create your own library. Choose from 
options to filter spectral noise and/or to correct the fragment 
ions to their theoretical accurate mass.

• Load spectra from either a CEF file or using copy-and-paste 
mass spectra from Qualitative Analysis, and search for the 
spectra in the current PCDL. 

• Create new spectra from published work by adding m/z 
versus relative abundance values.

• Perform private, on-site searches using your PCDLs to help 
keep your intellectual property safe. 

• Link to websites for more information on compounds in your 
PCDL. 
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Terminology
Terminology

Custom PCDL A PCDL that you can edit using PCDL Manager. 
A custom PCDL is designated User in the Master or User field 
as described in “View PCDL information” on page 25.

PCDL An accurate mass compound database that may also 
contain retention times, an MS/MS accurate mass spectral 
library, and an ion mobility database including collision cross 
section values.

Compound Name Many compounds are commonly known by 
their salts. The mass spectrometer, however, detects the anion 
or cation portion of the salt, rather than the neutral salt. PCDL 
entries may contain the familiar compound names, but the 
empirical formulae reflect the detectable cation or anion 
portion of the molecule rather than the formula of the neutral 
compound salt. For example, the full name Vecuronium bromide 
may be used for identification in the PCDL, even though the 
mass/formula only includes the Vecuronium cation.

Where to Find More Information

Use the online Help for in-depth information as you use PCDL 
Manager. Display online Help in one of two ways:

• Select Contents, Index, or Search from the Help menu.
• Press F1 to get context specific information about an active 

window, tab, or dialog box.

Go to www.agilent.com for the most current information on Agilent 
products.
6 PCDL Manager Quick Start Guide



User Interface 

Main window
User Interface

Main window

The main PCDL Manager window consists of five parts: (1) 
Menu Bar, (2) Toolbar, (3) Action Tabs, (4) Action Pane, and (5) 
Compound Results Pane. The number of compounds that meet 
your search criteria is shown above the table in the Compounds 
Results Pane. The window areas are shown in Figure 1.

1. Menu Bar The menu bar provides actions that are used to 
create and manage your custom PCDL. More information 
regarding the menu bar is provided in the section “Menu bar” on 
page 8.

Figure 1 The main functional areas of PCDL Manager window
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User Interface 

Menu bar
2. Toolbar The toolbar is located below the menu bar and 
contains buttons for commonly performed tasks. More 
information regarding the toolbar is provided in the section 
“Toolbar” on page 12.

3. Action Tabs Four tabs - Compounds, Spectra, Ion Mobility, 
and Import - provide options for you to search, view, and edit 
compound data and spectra in the open PCDL. More 
information regarding the tabs is provided in the section 
“Action Tabs” on page 13.

4. Action Pane The Action Pane is where you enter and select 
parameters, information, and options, and then view the 
compound, spectra, and ion mobility results. Content of the 
Action Pane changes based on the tab selected.

5. Compound Results Pane Lists the compounds and the 
compounds data that meet your search criteria. This pane 
changes based on the selected action tab and is replaced with a 
Matched Compounds table when you select the Import tab.

Menu bar

The menu options available in PCDL Manager are shown in 
Figure 2.

Figure 2 PCDL Manager menu bar

File: Open, backup, and create new PCDLs. You can also create 
subset PCDLs, convert older PCDLs, import compounds from a 
CSV file, and print and export your search results.

View: Manage the columns in the compound results table in the 
Compounds Results pane, view molecular structure details in a 
separate Compound window, and view spectra in a separate 
Spectra Viewer window.

PCDL: Search for compounds, spectra or conformers in your 
PCDL, toggle the Allow Editing mode, and review information 
about your PCDL.
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Menu bar
Configuration: Manage the links (URLs) to online compound 
databases.

Links: Open your default Internet browser to the selected 
website. When the editing mode is enabled, you can add, edit, 
and remove links in this menu.

Help: Provides a link to online Help and information about 
PCDL Manager software.

File menu New PCDL Create a custom PCDL that can be edited and 
personalized for your lab. You can create a new PCDL by making 
a clone of an existing PCDL, including the open PCDL, with a 
new name, or you can create a new empty PCDL. When you 
make a clone of a master PCDL, the clone can be edited. See 
“Create a new PCDL” on page 30.

Open PCDL Select and open an existing PCDL. The currently 
open PCDL is closed automatically when you open a new PCDL.

Note: When you use Open PCDL on an older PCDL, PCDL 
Manager automatically notifies you that the PCDL is an older 
version and converts the PCDL to the current format. The 
original PCDL is archived in the folder \MassHunter\PCDL\ 

B.0X.00\Archive, where X is the PCDL Manager version 
compatible with the original PCDL. If you click Cancel in the 
Open PCDL dialog box when you launch PCDL Manager, 
PCDL Manager has limited functionality until you open or 
create a new PCDL.

Backup PCDL Create a copy of the open PCDL. This is a 
convenient way to archive an existing PCDL and to save 
incremental progress while you are creating or editing a new 
PCDL.

Convert PCDL Opens the Convert PCDL dialog box. You must 
convert a PCDL which was developed with an older version of 
PCDL Manager to the current format. Once you convert a PCDL 
to version B.08, you cannot use the converted PCDL in a version 
of Qualitative Analysis that is prior to B.08.

Note: When you use Convert PCDL on an older PCDL, PCDL 
Manager saves the original PCDL in the folder \MassHunter\ 
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Menu bar
PCDL\B.0X.00\Archive, where X is the PCDL Manager version 
compatible with the original PCDL.

Create Subset PCDL Create a new PCDL containing the only 
the selected compound rows in the open PCDL.

Import Compounds  Add compounds from a CSV file to the 
open PCDL. If you start with an empty PCDL, then you are 
creating a new PCDL from the imported compounds. This menu 
option is only available when editing is enabled.

Print Results  Print search results and structures to a printer 
configured on your personal computer.

Exit Close the PCDL Manager window. The open PCDL is 
automatically saved.

View menu Autosize Columns Changes the width of each column in the 
tables so that the data displayed in the tables is optimized.

Hide Empty Columns Hides columns in tables that do not have 
any content. You can display hidden columns again when you 
right-click on a table column heading and then click 
Add/Remove Columns or Restore Default Columns.

Molecular Viewer Opens the Compound window where you 
can view, edit, and load the molecular structure data related to 
the selected compound.

Spectra Viewer Opens the Spectra Viewer window where you 
can view, create, add, edit, delete, and load acquired spectral 
data for the selected compound.

PCDL menu Find Compounds Searches the PCDL for compounds that match 
the criteria specified in the Action Pane. This menu option is 
only available when Compounds tab is active. You can also 
press the F5 key to find compounds.

Find Spectra Searches the PCDL for spectra that match the 
criteria specified in the Action Pane when the Spectra tab is 
active. This menu option is only available when the Spectra tab 
is active. You can also press the F5 key to find spectra.
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Menu bar
Find Conformers Searches the PCDL for compounds that match 
the criteria specified in the Action Pane when the Ion Mobility 
tab is active. This menu option is only available when the Ion 
Mobility tab is active. You can also press the F5 key to find 
conformers.

Allow Editing Enable, or disable, editing operations for a 
custom PCDL. You can also press the F2 key to enable and 
disable editing. When editing is enabled, a check mark ( ) 
appears next to this menu option and an Add button indication 
( ) appears above the Compounds Results table in the 
Compounds tab. 

Note: A master PCDL cannot be edited.

PCDL Information Opens the PCDL Information dialog box 
where you can view information about the current PCDL. When 
editing is enabled, you can edit the PCDL Type and 
Description.

Configuration Modify URLs in Link Columns Manage the links (URLs) to online 
compound databases that are contained in the chemical 
identifier columns in the PCDL.

Links menu Quick, customizable access to websites specific to your custom 
PCDL application area such as pesticides or metabolites web 
sites that contain additional chemical information on 
compounds or metabolites. When editing is enabled, you can 
edit, add new links, and delete links in the Links menu.

Help menu Contents, Index, and Search Opens the online Help window for 
PCDL Manager, with the appropriate tab displayed.

View EULA Displays the license agreement for MassHunter 
PCDL Manager in a Notepad window.

About Displays the version, build, and notes of the 
MassHunter PCDL Manager software.
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Toolbar
Toolbar

The toolbar is located below the menu bar and contains four 
groups of buttons for commonly performed tasks.

 

Button Equivalent Command

 
Button changes based on the active action tab: 
PCDL > Find Compounds, or press F5 

PCDL > Find Spectra, or press F5 

PCDL > Find Conformers, or press F5

 
File > New PCDL, or press Ctrl+N

 
File > Open PCDL, or press Ctrl+O

 
File > Print Results, or press Ctrl+P

 
View > Autosize Columns

 
View > Hide Empty Columns

 
View > Molecular Viewer

 
View > Spectra Viewer

 
PCDL > Allow Editing, or press F2 

This command is not available when a master 
PCDL is open.
 
Help > Contents, or press F1
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Action Tabs
Action Tabs

Four Action Tabs are available in PCDL Manager: Compounds, 
Spectra, Ion Mobility, and Import.

Working with the 

Action Tabs

Searching for compounds in a PCDL is performed by entering 
search criteria in one of the Action tabs: Compounds, Spectra, 
or Ion Mobility. Each of these Action Tabs provides you with 
search parameters optimized to search your PCDL based on 
either the compound data columns (Compounds tab), basic 
compound information with spectra specific parameters 
(Spectra tab), and basic compound information with ion 
mobility specific parameters (Ion Mobility tab). The search 
results in the Spectra and Ion Mobility tabs include an 
additional results table to help you view the spectra or ion 
mobility data for the compounds results from your search.

The search results obtained by performing a search in any one 
of the Action Tabs can be viewed in any of the other Action Tabs 
by simply changing tab. For example, if you search for a 
compound in the Compounds tab using formula, switching to 
the Spectra tab and Ion Mobility tab allows you to view the 
corresponding spectral and ion mobility information for each 
compound that matched your original search. 

Note: Each time you perform a search, the previous results 
are disregarded. When you change between Action Tabs 
without performing a new search on the PCDL, the 
compound results displayed do not match the search criteria 
present in the current action tab until you perform a search.

The Import tab is used to update your PCDL with new 
retention times or CCS values and related information.

Compounds tab You can search for compounds in the PCDL using parameters in 
the Action Pane when the Compounds tab is selected. Search 
results are displayed in a Compound Results table in the 
Compound Results Pane. When editing is enabled, you can edit 
the compound data directly in the Compound Results table.

Figure 3 on page 14 shows a view of the Compounds tab using 
the Search Action Pane. Figure 4 on page 15 shows a view of 
the Compounds tab using the Advanced Search Action Pane. 
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Action Tabs
For more information on using the Compounds tab see: 
“Editing a PCDL” on page 30 and “Find Compounds in your 
PCDL” on page 47.

Search tips Use the following search tips to help find your compounds more 
efficiently:

• Enter one search element per line.

• When searching for a molecular formula, the formula must 
match an entry in the Formula column exactly. Partial 
molecular formulas are not matched during the search.

• Enter the first digits of the CAS number and include the 
hyphen. For example, to search for 551-92-8 enter 551- in the 
search.

• When searching for Mass, RT, and RI values, include a 
decimal point in your value as shown in the following 
examples:

• Mass: For mass 121, search for 121.12, 121.123, 121.1234

• RT: For a retention time of 10 minutes, search for 10.0

• RI: For a retention index of 10, search for 10.0 or 10.00

Figure 3 The Compounds tab for the Search Action Pane in PCDL Manager without any search criteria en-
tered for Find Compounds
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Action Tabs
Viewing structures When available in your PCDL, the molecular structure of the 
selected compound can be viewed in the Advanced Search view 
on the Compounds tab or in a separate Molecular Viewer 
dialog box. The Molecular Viewer dialog box is visible even 
when you change your views among the Action Tabs allowing 
you to view structural information at the same time as 
compound, spectral, and ion mobility information.

See “View molecular structures” on page 26 for more 
information about viewing molecular structures.

Figure 4 The Compounds tab for the Advanced Search Action Pane in PCDL Manager without any search cri-
teria entered for Find Compounds
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Action Tabs
Spectra tab You can search for spectra and their associated compounds in 
the PCDL using parameters in the Action Pane when Spectra 
tab is selected. Search results are displayed in two tables, 
Spectra for Compound and Compound Results, that are shown 
in the Compound Results Pane (Figure 5).

Viewing spectra When available in your PCDL, the spectra of the selected 
compound are viewed in the Spectral Viewer window that is 
visible even when you change your views among the Action 
Tabs (see Figure 6 on page 17). The spectra of the selected 
compound can be viewed in one of several ways:

• From the Menu bar: Click View > Spectra Viewer to 
launch the Spectra Viewer window.

Figure 5 The Spectra tab in PCDL Manager without any search criteria entered for Find Spectra
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Action Tabs
• From the Toolbar: Click the View Spectra icon , 
located on the toolbar, to launch a the Spectra Viewer 
dialog box.

Figure 6 Spectra Viewer dialog box

Working with spectra If editing is enabled, you can create, add, edit, and delete 
spectra in a custom PCDL from within the Spectra Viewer 
dialog box. You can edit the molecular or precursor ion 
information, including ion species, precursor ion m/z and the 
MS Chemical Standard information. You can also remove noise 
peaks from raw experimental spectra such as spectra which 
were loaded from a CEF file. Before you can work with the 
spectra for a compound, you must perform a search so that the 
compounds and associated spectra you want to manage are 
present in the Compound Results table.
PCDL Manager Quick Start Guide 17
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Action Tabs
Note: It is recommended to use the Send Spectra to PCDL 
feature in MassHunter Qualitative Analysis to import spectra 
to a PCDL when creating your own custom PCDL, rather than 
using copy and paste of spectra from MassHunter Data 
Analysis software or loading spectra from CEF files. This 
feature allows you to apply the following options: to filter 
spectral noise, set a pass/fail base peak height filter, and 
correct the fragment ions to their theoretical accurate mass.

Ion Mobility tab You can search for compounds in the PCDL using parameters 
associated with ion mobility in the Action Pane when the Ion 
Mobility tab is selected. Search results are displayed in two 
tables, Ion Mobility information for compound and Compound 
Results, that are shown in the Compound Results Pane 
(Figure 7).

Figure 7 The Ion Mobility tab in PCDL Manager without any search criteria entered for Find Conformers
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Action Tabs
Import tab You can import retention times (RTs) and collision cross section 
(CCS) values for the compounds in your PCDL. The imported 
values are obtained from a previously prepared CSV file (see 
“Import CSV File Format” on page 33).

The compounds in your open PCDL that match compounds in 
the import file are displayed in the Matched Compounds table 
(the left table in Figure 8 and Figure 9) that replaces the 
Compound Results Pane. 

When you select a compound in the Matched Compounds table, 
the table to the right shows the RT or CCS matches depending 
on whether the Imported RT tab (Figure 8) or the Imported 

Figure 8 The Import tab in PCDL Manager, Imported RT tab

Figure 9 The Import tab in PCDL Manager, Imported CCS tab
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Action Tabs
CCS tab (Figure 9 on page 19) is selected, respectively. If there 
is more than one match for an RT import, you select the match 
that is the best fit. If there is more than one match for the CCS 
import, you can select which matches you want to import as 
new conformers and which matches you want to ignore.
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Install and run PCDL Manager
Getting Started

The following topics help you get started using PCDL Manager 
to open, convert, backup, and view PCDLs:

• “Install and run PCDL Manager” below

• “Open a PCDL” on page 22

• “Convert an older PCDL” on page 23

• “Backup a PCDL” on page 24

• “View PCDL information” on page 25

• “View molecular structures” on page 26

• “View linked websites” on page 29

Install and run PCDL Manager

1 Install PCDL Manager. Follow the instructions in “PCDL 
Manager Installation” on page 77.

2 Double-click the PCDL Manager B.08.00 icon  located on 
your desktop. 

Alternatively, you can click Start > All Programs > Agilent > 
MassHunter Workstation > PCDL Manager B.08.00 
(Windows 7), or click Start > All apps > Agilent > PCDL 
Manager B.08.00 (Windows 10) to launch PCDL Manager.

3 Select the example PCDL Sulfas_AM_PCDL.cdb in the Open 
PCDL dialog box. 

To open a different PCDL, see “Open a PCDL” on page 22.

Note: The PCDL that was last viewed is displayed as the 
default PCDL to open in the Open PCDL dialog box. 

4 Click Open. You are now ready to become familiar with the 
operations available in PCDL Manager.
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Open a PCDL
Open a PCDL

You open a PCDL when you (1) launch PCDL Manager and (2) 
when you want to change the active PCDL after PCDL Manager 
is running. PCDL files have a .cdb extension.

Note: Master PCDLs cannot be edited, but they can be used to 
create custom PCDLs that can be edited. See “Create a new 
PCDL” on page 30.

(1) Launch PCDL Manager When you initially start PCDL 
Manager you are prompted to select a PCDL to open.

1 Double-click the PCDL Manager B.08.00 icon  located on 
your desktop.

Note: From File Explorer you can double-click on a .cdb file 
to launch PCDL Manager and open the chosen PCDL.

Alternatively, you can click Start > All Programs > Agilent > 
MassHunter Workstation > PCDL Manager B.08.00 
(Windows 7), or click Start > All apps > Agilent > PCDL 
Manager B.08.00 (Windows 10) to launch PCDL Manager.

2 Select the PCDL to open in the Open PCDL dialog box. 

Note: The PCDL that was last viewed is displayed as the 
default PCDL to open in the Open PCDL dialog box. You can 
choose to open the previously opened PCDL, or navigate to 
and select a different PCDL.

3 Click Open.

Note: If you click Cancel in the Open PCDL dialog box when 
you launch PCDL Manager, PCDL Manager has limited 
functionality until you open or create a new PCDL.

(2) Open a different PCDL After PCDL Manager is open, 
perform the following steps to open a different PCDL.

1 Click File > Open PCDL, click  on the toolbar, or press 
Ctrl+O to open the Open PCDL dialog box.

2 Select the PCDL file of interest.

3 Click Open.
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Convert an older PCDL
Note: When you open an older PCDL, PCDL Manager 
automatically notifies you that it detected that the PCDL is 
an older version and converts the PCDL to the current 
format. The original PCDL is archived in the folder 
\MassHunter\PCDL\ B.0X.00\Archive, where X is the PCDL 
Manager version compatible with the original PCDL.

Convert an older PCDL

PCDLs created from previous versions of PCDL Manager can be 
converted for use in PCDL Manager B.08.00 and later.

1 Click File > Convert PCDL to open the Convert PCDL dialog 
box (Figure 10).

Figure 10 Convert PCDL dialog box

2 Click the select PCDL icon  to open the Open PCDL dialog 
box. 

Alternatively, you can type the full path and filename of a 
PCDL to convert directly into the Convert PCDL dialog box 
(Figure 11 on page 24) and skip the next step.

3 Select the PCDL that you want to convert and then click 
Open to return the path and filename to the Convert PCDL 
dialog box.

4 Click Convert. The PCDL is converted to the latest schema.

• If the PCDL is converted, the original PCDL is archived in 
the folder \MassHunter\PCDL\B.0X.00\Archive, where X is 
the PCDL Manager version compatible with the original 
PCDL.
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Backup a PCDL
• If a copy of the PCDL is already saved in the \MassHunter\ 

PCDL\B.0X.00\Archive folder, a dialog box informs you that 
the conversion was not performed because the PCDL was 
previously converted. To proceed with the conversion you 
need to either delete or change the file name of the PCDL 
in the \MassHunter\PCDL\B.0X.00\Archive folder and then 
repeat the steps to convert the PCDL.

Figure 11 Convert PCDL dialog box with a PCDL specified

Backup a PCDL

When you edit a PCDL the changes are made to your PCDL 
immediately and in real-time. Since PCDL Manager does not 
have an undo function, you can create a backup of the current 
state of your PCDL at any time. You can save time restoring a 
previous version of your PCDL if you create a backup of your 
PCDL at various times.

1 Click File > Backup PCDL to launch the Backup PCDL 
dialog box. 

2 Select a folder for the backup file, or accept the default folder 
MassHunter\PCDL\Archive.

3 Type a file name for the backup file, or accept the proposed 
file name - the proposed file name is the PCDL file name with 
the current date appended in the form 
<name>.<yyyy.mm.dd>.cdb where name is the name of the 
open PCDL, yyyy is the current year, mm is the current month, 
and dd is the current day of the month.

4 Click Save. A backup copy of the PCDL is created using the 
specified file name in the specified location.
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View PCDL information

You can view general information about an open PCDL using 
the PCDL Information dialog box. If the open PCDL is not a 
master but a user PCDL, and if editing is enabled, you can edit 
some of the general information.

1 Click PCDL > PCDL Information to launch the PCDL 
Information dialog box. 

2 View the following information about the open PCDL. If 
editing is enabled, you can edit the fields marked editable field 
while you are viewing the PCDL information. 

• File name

• # Compounds

• Master or User: Master indicates the PCDL is not editable 
and User indicates the PCDL is editable (also referred to 
as a custom PCDL).

• Type (editable field): Select a type from the list.

Note: The Type value is used to determine the default data 
columns that are shown in the Compounds Results table 
and the default Links available in the menu bar.

• Edit allowed: An indication of the current status of the 
PCDL. Yes indicates PCDL editing is enabled and No 
indicates that PCDL editing is disabled.

• Last modified: A time stamp indicating when the PCDL 
was last modified using PCDL Manager.

• Version: The PCDL Manager schema version of the PCDL.

• Description (editable field): Text that describes the PCDL.

3 Click Apply if you made changes to the PCDL Type or edited 
the Description (see Figure 12 on page 26).

4 Click Close to exit the PCDL Information dialog box.
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Figure 12 PCDL Information dialog box with editing enabled

View molecular structures

When available in your PCDL, the molecular structure of the 
selected compound can be viewed in the Advanced Search view 
on the Compounds tab or in a separate Molecular Viewer 
dialog box. The Molecular Viewer dialog box is visible even 
when you change your views among the Action Tabs allowing 
you to view structural information at the same time as 
compound, spectral, and ion mobility information.

Molecular structures can be viewed in one of several ways:

• From the Menu bar: Click View > Molecular Viewer to 
launch the Molecular Viewer dialog box.

• From the Toolbar: Click the View Molecular Structure 
icon , located on the toolbar, to launch the Molecular 
Viewer dialog box (Figure 13 on page 27).

• From the Action Pane: Click the view Molecule icon , 
located in the Advanced Search part of the Action Pane, 
to launch the Molecular Viewer dialog box (see Figure 13 
on page 27).

• In the Action Pane: Click Advanced Search in the Action 
Pane. When available, the molecular structure is visible in 
the Action Pane (Figure 4 on page 15). The parameters 
and options available for searching the PCDL also change 
when you are in Advanced Search.
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Figure 13 Molecular Viewer dialog box

Editing the 

molecular structure

When editing is enabled, you can edit the molecular structure 
information for a custom PCDL. Within the MOL Text tab you 
can edit and perform cut-and-paste operations to edit the 
molecular structure. See “Edit a molecular structure” on 
page 41 for information on editing the molecular structure. If 
you edit the information in the Molecular Viewer dialog box, 
click Save to update the PCDL with your changes.

Editing the notes When editing is enabled, you can edit the notes information for 
a custom PCDL. If you edit the information in the Molecular 
Viewer dialog box, click Save to update the PCDL with your 
changes. 

Note: The content displayed in the Notes field in the 
Molecular Viewer dialog box is identical to the values in the 
compound Description column of the Compound Results 
table.

View mass spectra

When available in your PCDL, the mass spectra of the selected 
compound can be viewed in the Spectra Viewer dialog box. The 
Spectra Viewer dialog box is visible even when you change your 
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views among the Action Tabs allowing you to view spectral 
information at the same time as compound, structure, and ion 
mobility information.

Mass spectra can be viewed in one of several ways:

• From the Menu bar: Click View > Spectra Viewer to 
launch the Spectra Viewer dialog box.

• From the Toolbar: Click the View Spectra icon , 
located on the toolbar, to launch the Spectra Viewer 
dialog box (Figure 14).

Figure 14 Spectra Viewer dialog box
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View linked websites

The PCDL Manager interface allows you to create customized 
links to websites, such as pesticides, metabolomics, or forensics 
websites, that contain additional chemical information on 
compounds or metabolites.

1 Click Links.

2 Click a website link of interest as shown in Figure 15. The 
selected website opens in your default Internet browser.

Figure 15 Linked websites for a PCDL Type LC/MS Metabolomics with 
editing disabled

Edit links When editing is enabled, you can edit, add new links, and delete 
links in the Links menu as shown in Figure 16.

Figure 16 Linked websites with editing enabled
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Editing a PCDL

The following topics help you get started using PCDL Manager 
to create and edit PCDLs:

• “Create a new PCDL” below

• “Import compounds into a PCDL” on page 32

• “Import CSV File Format” on page 33

• “Add compounds manually to a PCDL” on page 35

• “Append compounds to a PCDL” on page 36

• “Create a subset PCDL” on page 39

• “Edit a molecular structure” on page 41

Create a new PCDL

These steps describe how you can create a new PCDL.

Note: You can also create a new PCDL by creating a subset of 
an existing PCDL as described in “Create a subset PCDL” on 
page 39

1 Click File > New PCDL, click the Create a New PCDL icon 
 on the toolbar, or press Ctrl+N to launch the Create New 

PCDL dialog box.

2 Select whether to create an empty PCDL or to create a PCDL 
by starting with a copy of the compounds in an already 
existing PCDL (see Figure 17 on page 31).

• Select Create New PCDL to create an empty PCDL that 
does not contain any initial compounds. Continue with 
step 4.

• Select Clone Existing PCDL to create a PCDL containing 
a copy of the compounds in an existing PCDL. Continue 
with step 3.

3 Select a PCDL to clone for the new PCDL from the Select an 
existing PCDL list.

The default path is \MassHunter\PCDL.
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A small example PCDL (Sulfas_AM_PCDL.cdb) is supplied with 
PCDL Manager and can be used to create a custom PCDL; 
remember to remove the example compounds from your 
custom PCDL.

Figure 17 Create New PCDL dialog box parameters: Create New PCDL 
(left) and Clone Existing PCDL (right)

4 Select the type of new PCDL from the list available in Select 
the PCDL type (see Figure 18).

The PCDL type you select determines the default data 
columns shown in the Compound Results table and the 
default URLs available in the Links menu.

Figure 18 List of available PCDL types

5 Type a name in Enter the new PCDL name.

6 Type a description in Enter a description of this PCDL. 
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7 Click Create to generate the new PCDL and automatically 
open the new PCDL in PCDL Manager. 

8 You can add compounds to the new, and now active, PCDL in 
any of the following ways:

• “Import compounds into a PCDL” starting below

• “Add compounds manually to a PCDL” on page 35

Import compounds into a PCDL

Use the following steps to import compounds into an open 
custom PCDL, or to create a custom PCDL from a compound list 
created by another application.

Note: When you start with an empty PCDL using Create New 
PCDL (see step 2 on page 30) you are creating a new custom 
PCDL from the compounds you import.

1 Prepare an import file.

An example Compound_import.csv file can be found in 
\\MassHunter\PCDL\Import Files; this file can be used as a 
template. The format required for the import file is described 
in “Import CSV File Format” on page 33 and in the online 
Help topic Import File Format. The import CSV file can be 
created manually using a spreadsheet or text editing 
program.

2 Open the custom PCDL of interest, or create a new PCDL as 
described in “Create a new PCDL” on page 30.

3 Click PCDL > Allow Editing, click  on the toolbar, or 
press F2 to enable editing of the open PCDL.

4 Click File > Import Compounds.

5 Select the .CSV file you prepared in step 1 that contains the 
compounds of interest.

6 Click Open.

7 Click PCDL > Allow Editing, click  on the toolbar, or 
press F2 to disable editing of the open PCDL.

8 Click PCDL > Find Compounds, click  on the 
toolbar, or press F5 to view the compounds in the PCDL. The 
compounds are listed in the Compound Results table. 
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9 Examine the log file, if created. Compounds that were not 
imported due to problems with the input file are saved in a 
file <ImportFileName>-ImportLog.csv, where <ImportFileName> 
is the name of the PCDL selected in step 5. Examine the log 
file to determine how to fix the problem and then import the 
corrected file. 

Note: During import, the mass is calculated from the formula 
and that value is used for the PCDL. If the difference between 
the calculated value and the mass contained in the import 
file is > 0.0001 Da, then that compound is added to the log 
file. Common problems that result in mass errors are (1) the 
mass value is the mass from the spectrum and not a neutral 
mass, and (2) the formula contains the adduct (such as Cl-). 
The information in the log file can be used to determine the 
correct formula or mass. 

10 (Optional) See “Editing a PCDL” on page 30 if you want to 
change information for the imported compounds. 

Import CSV File Format

A file for importing compounds into a PCDL must have the 
values separated by commas (CSV file). The file can be created 
in any of the following ways:

• Export from another application such as Qualitative 
Analysis.

• Create manually using a spreadsheet program or text 
editor (saved in CSV format).

The first line(s) in the CSV file may be designated for your 
comments. Start such comment lines in your CSV file with a #. 
The first non-comment line of the CSV file contains the column 
header names with each column identifier name separated by a 
comma. The subsequent lines contain the values for each 
column separated by a comma, one compound per line.

Compound import • For File > Import Compounds, you must have at minimum a 
name and either a formula or a mass to create a new 
compound in the PCDL. The mass is auto-calculated from the 
formula if there is no mass.
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• Typical data column header names for compound import 
include: Name, Formula, Mass, Anion, Cation, METLIN, KEGG, CAS, 
LMP, HMP, ChemSpider, RT, RI, Log P, RT Low(Theor.), RT 

high(Theor.), Synonyms, SMILES, InChI, InChI Key, Sigma-Aldrich, 
Cayman Chemical, Description, PubChem, ChEBI, BioCyc, Chapman 

Hall, NCBI, Uniprot, IUPAC.

• Multiple synonyms can be entered into the Synonyms column 
when separated by a semicolon (;), for example, L-Isoleucine; 

2-Amino-3-methylvaleric acid.

• All compounds are assumed to be represented in their 
neutral form, unless a value of 1 is entered in the Cation or 
Anion column.

Tips when importing 

compounds

• Review the import file format and column headers to make 
sure they conform to the expected format described in this 
section and in one of the example CSV files.

• If errors are found while importing a file, a log file consisting 
of the following name is created during import. The log file 
contains lines that were not correctly parsed and not 
imported: <ImportFileName>-ImportLog.csv, where 
ImportFileName is the original import file name. You can edit 
this file, make corrections, and then import the corrected 
file.

• The Mass is calculated from the formula, unless the 
difference between the mass calculated from the formula 
versus the mass indicated in the import file is > 0.0001 Da. 
Then the mass difference is greater than > 0.0001 Da, the 
compound is not imported into the PCDL but instead the 
Mass and Formula values are read from the input file added 
to the mass error log file: <ImportFileName>-MassErrorsLog.csv. 

The information in the log file can be used to determine the 
correct Formula or Mass. Typically errors occur when (1) 
the Mass value was the mass from the spectrum and not a 
neutral mass, or (2) the Formula contained an adduct (such 
as Cl-).

• Special characters cause PCDL Manager to fail to import the 
compounds contained in a CSV file. This can sometimes arise 
when values are copied and pasted from Internet chemical 
database sources.
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• If a compound name, or other data column containing an 
alphanumeric string, contains a comma, be sure to enclose 
the text containing a comma in double quotation marks as 
shown in the compound name “1,3-bisphoglycerate”. 

Many spreadsheet programs automatically enclose text with 
commas in quotes when saving a file in a CSV format. Open a 
saved CSV file in a text editor to view characters that may be 
hidden when viewed in a spreadsheet.

RT import • For RT import, available in the Import tab, you must have at 
minimum one identifier (Agilent ID, Metlin ID, KEGG, CAS, 
Formula, Name, LMP, or HMP, ChemSpider) and a retention 
time. 

CCS import • For CCS import, available in the Import tab, you must have 
at minimum one identifier (Agilent ID, Metlin ID, KEGG, 
CAS, Formula, Name, LMP, or HMP, ChemSpider) and a CCS 
value, Ion Polarity, Ion Species, and Gas.

Example CSV files Three example import file templates are provided in the 
\MassHunter\PCDL\Import Files folder. Use one of these three 
example files as a template when you manually create your own 
CSV file for import.

• Compound_import.csv - An example compound import file 
that can be used to import compounds using File > Import 
Compounds (Import Compounds dialog box).

• CCS_import.csv - An example collision cross section import 
file that can be used to import CCS values from the 
Import tab, Imported CCS tab.

• RT_import.csv - An example retention time import file that 
can be used to import RT values from the Import tab, 
Imported RT tab.

Add compounds manually to a PCDL

You can add compounds individually to any custom PCDL by 
enabling editing mode and entering the information directly in 
the Compounds tab.

1 Press the F2 key, click  on the toolbar, or click PCDL > 
Allow Editing to enable editing, if editing is not already 
enabled.
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When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

2 Click Add to create a new compound row to the end of your 
PCDL (see Figure 19).

Figure 19 New compound added and ready for your data (shown added 
to the example PCDL Sulfas_AM_PCDL .cdb)

3 Click on the cells under the respective heading and type the 
information for the new compound.

When editing is enabled, a selected cell is highlighted in a 
distinct green color indicating that the value can be directly 
edited. You must tab through to the next cell that you wish to 
enter data, or press Enter, to save the value to the cell.

Append compounds to a PCDL

You use the following procedure to add the compounds selected 
in the Compounds Results table of your open PCDL to a saved 
PCDL. You can only append to a custom PCDL (a PCDL 
designated User in the Master or User field as described in 
“View PCDL information” on page 25).

1 View the compounds in the PCDL. Click PCDL > Find 
Compounds, click  on the toolbar, or press F5, 
if necessary, to view the compounds in the PCDL. The 
compounds are listed in the Compound Results table. 

2 Sort on any of the compound identifier columns or use the 
advanced searching functionality of the Compound search 
criteria, along with the Must also contain and Must not 
contain filters to find your compounds of interest (see “Find 
Compounds in your PCDL” on page 47).
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3 Select the compounds you want to append to the saved 
PCDL.

To select a set of adjacent compound rows, click the first 
compound row, and then hold down the Shift key while you 
click on the last compound row.

To add additional compounds, adjacent or nonadjacent, to 
your selection, hold down the Ctrl key while you individually 
click additional compound rows. 

You can use the scroll bar while holding down the Ctrl key to 
bring additional compounds into view within the 
Compounds Results table to add to your selection.

4 Right-click on any highlighted compound, and then click 
Append to PCDL as shown in Figure 20.

Figure 20 Append to PCDL
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5 Click the select folder icon  to open the Browse for 
Folder dialog box or skip to step 6 on page 38. 

Alternatively, you can type the full PCDL path directly into 
the Append to PCDL dialog box (Figure 21).

Figure 21 Append to PCDL dialog box

6 Select the PCDL that you want to append to from the list of 
PCDLs in Select the PCDL to append to (see Figure 21).

7 Mark Include spectra for compounds if present to include 
mass spectra for each compound when available.

8 Mark Include ion mobility info for compounds if present to 
include ion mobility data for each compound when available.

9 Click Append to add the compounds you highlighted to the 
selected PCDL (Figure 20 on page 37).

10 Click Yes in the Compounds Appended dialog box to open 
the PCDL that contains the appended compounds (see 
Figure 22 on page 39). 

Click No to continue appending additional compounds to the 
same or another custom PCDL; repeat steps 1 through 7.
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Figure 22 Append to PCDL dialog box

11 Review the custom PCDL that contains the appended 
compounds. In the default view of the Compound Results 
table, the appended compounds are found at the end of the 
table.

Create a subset PCDL

You use the following procedure to create a custom subset PCDL 
from the open PCDL. You can use a master PCDL or a custom 
PCDL as the starting template.

1 Click File > Open PCDL, click  on the toolbar, or press 
Ctrl+O to open the Open PCDL dialog box.

2 Navigate to and click on the PCDL that contains the 
compounds you want to save as a subset PCDL.

3 Click Open.

4 View the compounds in the PCDL. Click PCDL > Find 
Compounds, click  on the toolbar, or press F5, 
if necessary, to view the compounds in the PCDL. The 
compounds are listed in the Compound Results table. 

5 Sort on any of the compound identifier columns or use the 
advanced searching functionality of the Compound search 
criteria, along with the Must also contain and Must not 
contain filters to find your compounds of interest (see “Find 
Compounds in your PCDL” on page 47).

6 Select the compounds you want to include in the subset 
PCDL. 

To select a set of adjacent compound rows, click the first 
compound row, and then hold down the Shift key while you 
click on the last compound row.
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To add additional compounds, adjacent or nonadjacent, to 
your selection, hold down the Ctrl key while you individually 
click additional compound rows. 

You can use the scroll bar while holding down the Ctrl key to 
bring additional compounds into view within the 
Compounds Results table to be added to your selection.

7 Click File > Create Subset PCDL to open the Create Subset 
PCDL dialog box (see Figure 23).

Figure 23 Create Subset PCDL dialog box

8 Select the subset PCDL type from the list of available types 
(see Figure 18 on page 31).

9 Type a name for the subset PCDL in Enter the subset PCDL 
name.

10 Mark Include spectra for compounds if present to include 
mass spectra for each compound when available.

11 Mark Include ion mobility info for compounds if present to 
include ion mobility data for each compound when available.

12 Type in a description for the subset PCDL in Enter a 
description of the subset PCDL.

13 Click Create.

The subset PCDL is created and a message is displayed that 
informs you of the subset PCDL file name and the number of 
compounds that were copied into the new subset PCDL.
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14 Review the information presented in the Subset PCDL 
Created dialog box (see Figure 24).

Figure 24 Subset PCDL Created dialog box

15 Click Yes to load the new subset PCDL into PCDL Manager.

Click No if you want to continue working with the current 
PCDL.

Edit a molecular structure

You use the following procedure to edit the molecular structure 
of a compound in your custom PCDL.

1 Select the compound of interest in the Compound Results 
table. Click any data cell in the same row of the compound of 
interest to select the compound.

2 Enable editing. Press the F2 key, click  on the toolbar, or 
click PCDL > Allow Editing to enable editing, if editing is not 
already enabled.

When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

3 Open the Molecular Viewer dialog box (Figure 13 on 
page 27) in one of the following ways:

• From the Menu bar: Click View > Molecular Viewer.

• From the Toolbar: Click the View Molecular Structure 
icon  located on the toolbar.

• From the Action Pane: Click the view Molecule icon , 
located in the Advanced Search part of the Action Pane.

4 Edit molecular structure information in either of the 
following ways:
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• Click the MOL Text tab and paste MOL file text that you 
have copied from a molecular drawing tool (Ctrl+V, or 
right-click, and then click Paste from the shortcut menu), 
or 

• Click load structures file icon  to open the Open 
Structure File dialog box to select a MOL file to load.

Both MOL and glycan structures are supported by PCDL 
Manager. If the structure attached to the currently selected 
compound is in the glycan format, then the glycan cartoon is 
displayed in the Structures tab. Right-click on a glycan 
drawing to change the display settings, such as Show 
Linkage and Switch Direction.

The MOL Text tab displays the text version of the molecular 
structure. If the current PCDL is a custom PCDL and editing 
enabled, you can copy text from a molecular drawing tool 
that is capable of generating MOL file text or a glycan 
structure and paste it into this area to edit the structure of 
the selected compound. You can also click the Load 
Structure from File  button in the Molecular Viewer 
dialog box to load a structure from a Mol (.mol), an SDF (.sdf), 
a Keff Glycan (.kcf), a Linucs Glycan (.linucs), or a GlycoCT 
Condensed (.glycoct_condensed) file.

Note: If the new MOL file contains a structure with a different 
molecular formula from the value currently in the Formula 
box, a warning appears stating that the mass for the new 
molecular structure differs from the mass associated with 
the Formula box:

Click Yes to apply the new structure’s formula and 
automatically update the Formula and Mass information 
boxes.

If you click No, the MOL file is updated, but the compound 
information is not changed.

5 Click Save when you are satisfied with your changes to the 
molecular structure and notes.

Note: The content displayed in the Notes field in the 
Molecular Viewer dialog box is identical to the values in the 
compound Description column in the Compound Results 
table.
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Edit mass spectra

You use one of the following procedures to edit mass spectra in 
your open PCDL. You can edit the molecular or precursor ion 
information, including ion species, precursor ion m/z and the 
MS Chemical Standard information. You can also remove noise 
peaks from raw experimental spectra such as spectra which 
were loaded from a CEF file. 

Note: The recommend procedure to add spectra to your 
PCDL is to use “Send Spectra to a PCDL from Qualitative 
Analysis” on page 66. The Qualitative Analysis workflow 
automatically adds the correct ion species and provides you 
with options to set the options to filter spectral noise, set a 
pass/fail base peak height filter, and correct the fragment 
ions to their theoretical accurate mass.

The following procedures allow you to edit spectra from within 
PCDL Manager.

Load a spectrum from a CEF file

This procedure loads spectra that have been exported to a CEF 
file from another program such as MassHunter Qualitative 
Analysis software. 

1 Select the compound of interest in the Compound Results 
table. Click any data cell for the compound of interest to 
select the compound.

2 Enable editing. Press F2, click  on the toolbar, or click 
PCDL > Allow Editing to enable editing, if editing is not 
already enabled.

When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

3 Open the Spectra Viewer dialog box (Figure 14 on page 28) 
in one of the following ways:

• From the Menu bar: Click View > Spectra Viewer.

• From the Toolbar: Click the View Spectra icon , 
located on the toolbar.
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4 Click the load spectra icon  to open the Load Spectra 
dialog box.

5 Navigate to and select the CEF file of interest.

6 Click Open. The available spectra in the CEF file are loaded.

If profile spectra or spectra which are not supported in PCDL 
Manager are contained in the file, a message is displayed 
saying that they have been skipped. Only centroided GC/MS 
and MS/MS spectra can be loaded for use in MassHunter 
PCDL Manager.

The spectra appear in the Acquired spectra table and can be 
compared to the library spectra in either a graphics or table 
format as shown in Figure 25. 

Figure 25 Spectra Viewer dialog box with acquired spectra imported from a CEF file: Graphics tab (left) and 
Mass Lists tab (right)
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Add spectra to the compound

1 Click to select the spectrum of interest in the Acquired 
Spectra table. Use Ctrl+click or Shift+click select multiple 
spectra.

2 Click Add Spectra. The Library spectra table is refreshed to 
show the new list of spectra for the compound. 

3 Click each spectrum and then click Edit Species to enter the 
revised or corrected information in the Edit Species dialog 
box (Figure 26).

Figure 26 Edit Species dialog box

Delete spectra from the compound

1 Click to select the spectrum of interest in the Library 
spectra table. Use Ctrl+click or Shift+click select multiple 
spectra.

2 Click Delete Spectra. The Library spectra table is refreshed 
to show the revised list of spectra for the compound.

Move spectra between compounds

The following procedure moves spectra between compounds 
and can be performed within a single PCDL running on a single 
instance of PCDL Manager, or between two PCDLs running on 
two instances of PCDL Manager.
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1 Click the compound to copy the spectra from in the 
Compound Results table, or the Spectra for Compound table. 

The spectra for the selected compound are listed in the 
Spectra Results table, and simultaneously listed and shown 
in the Spectra Viewer dialog box.

2 Click to select the spectra of interest in the Library spectra 
table in the Spectra Viewer dialog box, press Ctrl+C or 
right-click and then click Copy Spectra from the shortcut 
menu.

Use Ctrl-click or Shift-click before copying if you want to select 
multiple spectra.

3 Press Ctrl+V in the Acquired spectra table, or right-click in 
the upper left cell of the table and then click Paste Spectra 
from the shortcut menu.

The Acquired spectra table of interest can be from within the 
open PCDL or from a second instance of PCDL Manager that 
has different PCDL (.cdb) file open.

The spectra are added to the Acquired spectra table.

4 Click to select the compound to copy the spectra to in the 
Compound Results table, or the Spectra for Compound table.

5 Click Add Spectra in the Spectra Viewer dialog box.

The Library spectra table is refreshed to show the revised list 
of spectra for the compound.
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Find Compounds in your PCDL

Search for compounds in the PCDL using parameters you enter 
in the Action Pane. Search results are displayed in the 
Compound Results table in the Compound Results Pane. When 
editing is enabled, you can also edit the compound data directly 
in the Compound Results table.

Figure 3 on page 14 shows a view of the Compounds tab using 
the Search Action Pane. Figure 4 on page 15 shows a view of 
the Compounds tab using the Advanced Search Action Pane. 

The following topics help you find compounds in your PCDL:

• “Prepare to find compounds” below

• “Enter search parameters” on page 48

• “Change how data is displayed in the results tables” on 
page 51

• “Print compound results” on page 52

Prepare to find compounds

1 Click File > Open PCDL, click  on the toolbar, or press 
Ctrl+O if the PCDL you want to search is not already open.

2 Click the Compounds tab.

3 Disable editing. Press F2, click  on the toolbar, or click 
PCDL > Allow Editing to disable editing, if editing is already 
enabled.

When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

Enter search parameters

1 Enter your search parameters in the Action pane. To return 
the contents of the entire PCDL, leave the search parameters 
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blank. See Figure 3 on page 14 for the Search Action Pane.

a Compounds search criteria

• Enter one search attribute per line; each line is 
combined as a logical OR. For example: 
140-87-4 

Glycine 

200.01 

C6H14N4O2

• When searching for a molecular formula, the formula 
must match an entry in the Formula column exactly. 
Partial molecular formulas are not matched during the 
search.

• Enter the first digits of the CAS number and include the 
hyphen. For example, to search for 551-92-8 enter 551- in 
the search.

• When searching for Mass, RT, and RI values, include a 
decimal point in your value, for example: 
Mass: For mass 121, search for 121.12, 121.123, or 121.1234 

RT: For a retention time of 10 minutes, search for 10.0 

RI: For a retention index of 10, search for 10.0 or 10.00

b (Optional) Must also contain: Enter criteria that must be 
found in each compound that matches an attribute in the 
Compounds search criteria. Enter one search attribute 
per line; each line is combined as a logical OR. If there are 
no entries in the Compounds search criteria, the Must 
also contain filter box is disabled.

c (Optional) Must not contain: Enter criteria that must not 
be found in any compound that matches an attribute in the 
Compounds search criteria. Enter one search attribute 
per line; each line is combined as a logical OR. If there are 
no entries in the Compounds search criteria, the Must 
not contain filter box is disabled.

d Mark the options under Ion search mode:

• Include neutrals is typically marked. Clear the check box 
if you want to search anions and cations only.

• Mark Include anions if the data was acquired in negative 
ion mode and you want the search to include anions.
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• Mark Include cations if the data was acquired in positive 
ion mode and you want the search to include cations.

Note: All three modes are marked as default. Ensure to 
mark Include anions or Include cations if you also want 
to consider those chemicals that don't pick up or lose a 
proton to ionize.

e Enter applicable Tolerances for Mass, RT, and RI.

f Select whether the search includes only visible data 
columns (Search only visible columns) or all of the data 
columns, even if the column is not currently displayed in 
the Compound Results table (Search all columns).

Note: Searching all columns on a large PCDL may take a 
significant amount of time depending on the search 
parameters entered. METLIN is an example of a large 
PCDL.

g (Optional) Mark whether the search requires the 
compound to have spectra (With spectra) and/or a 
collision cross section value (With CCS).

2 (Optional) Click Advanced Search to enter more specific 
search criteria. Each of the criteria is combined as a logical 
AND. See Figure 4 on page 15 for the Advanced Search 
Action Pane.

a Select type of Mass ([M+H]+, Neutral, or [M-H]-)

• Select [M+H]+ mass type if you are searching for an 
observed positive ion in the compound entries. The 
neutral mass value is automatically calculated, assuming 
the ion was a positive protonated ion. If Include cations is 
selected in Step 4d, the neutral mass of a cation is also 
calculated.

• Select Neutral mass type if the mass is the calculated 
neutral mass value, usually a value that was calculated by 
Molecular Feature Extraction (MFE). Do not select this 
value for a mass observed in a spectrum. Ions observed in 
a spectrum have a charge and need to be converted to 
neutral to work with the PCDL. For observed ions use 
either the [M+H]+ or [M-H]- selection.
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• Select [M-H]- mass type if you are searching for an 
observed negative ion in the compound entries. The 
neutral mass value is automatically calculated, assuming 
the ion was a negative deprotonated ion. If Include anions 
is selected in Step 4d, the neutral mass of an anion is also 
calculated.

3 Enter Retention time parameters, keeping the following 
guidelines in mind:

• When searching a PCDL without retention time data, be 
sure to clear the Require checkbox. 

• When searching a PCDL that contains retention time 
information for compounds, enter a Retention time and 
RT tolerance if you want to consider retention times in 
the search.

4 If desired, enter search text for Formula, Name, Notes, 
IUPAC, and/or identifiers CAS, ChemSpider, METLIN, 
KEGG, HMP, and LMP to find compounds based on these 
chemical identifier fields. You can also enter text in the 
Notes field to search for a text string, such as “antidiabetic”. 
Your search text may include any special character typically 
used in a chemical name (hyphens, spaces, commas, single 
quote, or other specific characters).

5 Start the compound search in any of the following ways: 

• Click  on the toolbar, 

• Click PCDL > Find Compounds, or 

• Press the F5 key. 

6 View the search results in the Compound Results table. Data 
that match your search criteria are highlighted in a light 
yellow color, for example the column for a compound with an 
exact formula match appears as .

• Click on a compound in the Compound Results table to 
view its molecular structure information, when applicable, 
in the Advanced Search and the Molecular Viewer dialog 
box. See “View molecular structures” on page 26 for more 
information.
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• Click on a compound in the Compound Results table to 
view its mass spectra, when applicable, in the Spectra tab, 
and the Spectral Viewer dialog box. See “View mass 
spectra” on page 27 for more information.

• Click on a compound in the Compound Results table to 
view its collision cross section, when applicable, in the Ion 
Mobility tab. See “Find Conformers in your PCDL” on 
page 58 for more information.

• See “Editing a PCDL” on page 30 for more information 
regarding editing your PCDL

Change how data is displayed in the results tables

The available changes described are applicable to any results 
table in PCDL Manager.

1 Sort the table by the entries in a particular column: Click 
the heading for the column of interest.

2 Change the order of the columns of information in the 
table: Drag a column heading to a different position. Repeat 
this until the desired order is achieved.

3 Resize a column to fit the information contained in the 
column: Double-click on the right column divider in the 
heading of the column of interest.

4 Resize a column to a specific width: Drag the separator 
between the column headings to the right or left until the 
column is the desired width.

5 Resize a column to fit the information: Click View > 
Autosize Columns, or click  on the toolbar, to resize the 
widths of columns to the width of the widest content in any 
cell of the column.

6 Change the columns of information displayed in the table:

a Right-click the table and click Add/Remove Columns from 
the shortcut menu to open the Add/Remove Columns 
dialog box.

b Move the items of information that you want to display 
from the Available columns list to the Show these 
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columns list by clicking Add -> or by double-clicking on 
them.

c Remove any unwanted items of information from the 
Show these columns list by clicking <- Remove or by 
double-clicking on them.

d Click OK to save your changes. The results table is 
refreshed to reflect the selected columns of information.

e Click View > Hide Empty Columns, or click  on the 
toolbar, to automatically hide columns that do not have 
any content. The results table is refreshed to reflect the 
selected columns of information.

f Right-click anywhere in a table, and then click Restore 
Default Columns in the shortcut menu to automatically 
restore the default setting for the table view. The results 
table is refreshed to reflect the selected columns of 
information.

Print compound results

If you want to print only certain compounds, first highlight 
those rows in the Compound Results table:

To select a set of adjacent compound rows, click the first 
compound row, and then hold down the Shift key while you 
click on the last compound row.

To add additional compounds, adjacent or nonadjacent, to 
your selection, hold down the Ctrl key while you individually 
click additional compound rows. 

You can use the scroll bar while holding down the Ctrl key to 
bring additional compounds into view within the 
Compounds Results table to be added to your selection.

1 Open the Print Results dialog box in one of several ways:

• From the Menu bar: Click File > Print Results.

• From the Toolbar: Click the Print Results icon  
located on the toolbar.

• From the Compound Results table: Right-click and then 
click Print Results, or press Ctrl+P.
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2 Select the desired Report destination options from the 
following:

• Printer - Choose from your PCs default system printers.

• Print Preview - Mark if you want to view the report in the 
Print Preview dialog box before sending the report to your 
selected Printer.

• Fit to page to size the report to fit the height and width of 
the page.

• Orientation (Landscape or Portrait). The default is 
Landscape; it allows more columns of information.

3 Select the desired Report contents options from the 
following: 

• Select All rows or Only highlighted rows of the 
Compounds Results table 

• Mark whether to Print structures and the size (240 x 160, 
360 x 240, or 540 x 360)

• Mark whether print the report in a summary format, Print 
in Summary Format.

4 Click OK to generate the report. 

If you clear the Print in Summary Format check box, then up 
to the first 30 Agilent created compounds selected are 
printed with all of the columns displayed in the Compound 
Results table.

If you mark the Print in Summary Format check box, then 
all compounds selected, or all compounds, are printed with 
enough information to unambiguously identify the 
compound. The compounds are printed in the following 
summary format:

For compounds created by Agilent (compounds that have 
either an Agilent or METLIN ID), the following values are 
printed:

Compound Name

Formula

Mass

RT
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RT Modified

Agilent ID

One of the following external chemical identifiers are 
printed using the following priority list:

CAS registry number - if this value is empty then go to

Chemspider ID - if this value is also empty then go to

IUPAC Name

METLIN ID

Date Modified

For user created compounds, the values listed above are 
printed, with the following exceptions:

The Agilent ID and METLIN ID values are not included since 
these identifiers are blank in user created compound 
entries.

5 Click  on the toolbar to print from the Print Preview.
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Find Spectra in your PCDL

The following topics help you find spectra in your PCDL:

• “Prepare to find spectra” below

• “Enter search parameters” below

• “Clean up noisy spectra” on page 56

Prepare to find spectra

1 Click File > Open PCDL, or click  on the toolbar, if the 
PCDL you want to search is not already open.

2 Click the Spectra tab.

3 Disable editing. Press F2, click  on the toolbar, or click 
PCDL > Allow Editing to disable editing, if editing is already 
enabled.

When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

Enter search parameters

1 Enter your search parameters in the Action pane. To return 
the contents of the entire PCDL with compounds which 
contain spectra leave the search parameters blank. See 
Figure 5 on page 16 for the Spectra tab Action Pane.

a Spectra search criteria

Enter one search attribute per line. Only the Compound 
Name, Ion Species, and MS Chemical Std columns are 
searched for text that you enter; each line is combined as a 
logical OR. For example: 
Glycine 

(M+H)+

b (Optional) Select values for the Additional search 
parameters: Ion polarity, Ionization mode, Precursor 
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ion species, and Instrument type. Each parameter line is 
combined as a logical AND to the Spectra search criteria.

c (Optional) Enter values for the Mass section: Precursor 
ion and Tolerance.

d (Optional) Enter values for the Collision energy section: 
collision energy and Tolerance in volts.

2 Start the spectra search in any of the following ways: 

• Click  on the toolbar, 

• Click PCDL > Find Spectra, or 

• Press the F5 key. 

3 Open the Spectra Viewer dialog box (Figure 14 on page 28) 
in one of the following ways:

• From the Menu bar: Click View > Spectra Viewer.

• From the Toolbar: Click the View Spectra icon , 
located on the toolbar.

4 View the search results in the Spectra for compound tables 
in the Spectra tab and the corresponding spectra in the 
Spectra Viewer dialog box. Data that match your search 
criteria are highlighted in a light yellow color in the Spectral 
results pane (upper table) which is labeled Spectra for 
compound: <highlighted compound name>.

5 Click on a compound in the Compound results pane (lower 
table in the Spectra tab) to refresh the spectra list for the 
highlighted compound in the Spectral results pane (upper 
table). 

6 See “View mass spectra” on page 27 and “Edit mass 
spectra” on page 43 for more information.

Clean up noisy spectra

Use this procedure to remove small noise peaks from spectra in 
a user (custom) PCDL. Using the Send Spectra to PCDL feature 
in MassHunter Qualitative Analysis Workflows eliminates the 
need for this step. Qualitative Analysis Workflows automatically 
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sets the correct ion species and provides options for filtering 
spectral noise, setting a pass/fail base peak height filter, and 
correcting the fragment ions to their theoretical accurate mass.

1 Click PCDL > Allow Editing, click  on the toolbar, or 
press F2 to enable editing of the open PCDL.

2 Open the Spectra Viewer dialog box in one of several ways:

• From the Menu bar: Click View > Spectra Viewer.

• From the Toolbar: Click the View Spectra icon .

3 Select the spectrum of interest from the Library spectra 
table.

4 Click the Mass Lists tab. By default, the masses are sorted in 
descending order by relative abundance value. Click the Rel 
Abund column header if you want the lowest relative 
abundance values (likely noise peaks) to appear at the top of 
the table.

5 Click on a row in the Library masses list to select a mass to 
delete. Use Ctrl-click or Shift-click to select multiple rows.

6 Press Delete on the keyboard.

7 Click Save to update the selected library compound with 
modified (cleaned) spectra.
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Find Conformers in your PCDL

The following topics help you find conformers in your PCDL. A 
conformer is an isomer of a molecule that differs from another 
isomer by the rotation of a single bond in the molecule. 
Conformers can be resolved with the addition of ion mobility 
data.

• “Prepare to find conformers” below

• “Enter search parameters” below

Prepare to find conformers

1 Click File > Open PCDL, click  on the toolbar, or press 
Ctrl+O, if the PCDL you want to search is not already open.

2 Click the Ion Mobility tab.

3 Disable editing. Press F2, click  on the toolbar, or click 
PCDL > Allow Editing to disable editing, if editing is already 
enabled.

When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

Enter search parameters

1 Enter your search parameters in the Action pane. To return 
the contents of the entire PCDL with compounds which 
contain collision cross section values leave the search 
parameters blank. See Figure 7 on page 18 for the Ion 
Mobility tab Action Pane.

a Ion Mobility search criteria

Enter one search attribute per line. Only the Ion Species, 
CCS column, Description, CCS Chemical Std, and Notes 
columns are searched for text or numbers that you enter 
here. Each line is combined as a logical OR.

b (Optional) Select values for the Additional search 
parameters: Ion polarity, Gas, and Ion species. Each 
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parameter line is combined as a logical AND to the Ion 
Mobility search criteria.

c (Optional) Enter values for the Tolerance section: CCS 
value.

2 Start the conformer search in any of the following ways: 

• Click  on the toolbar, 

• Click PCDL > Find Conformers, or 

• Press the F5 key. 

3 Click on a compound in the lower table to refresh the ion 
mobility list for the highlighted compound in the upper table.

4 View the search results in the Ion Mobility information for 
compound tables. Data that match your search criteria are 
highlighted in a light yellow color in the Ion Mobility Results 
table (upper table).
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Import RT and CCS Values

Importing works on the current dataset shown in the 
Compounds tab. For example, if you searched and found a 
subset of the compounds in the PCDL, then when you try to 
import values, the import is restricted to the compounds in the 
Compound Results table. To match the entire PCDL, first find 
compounds in the Compounds tab with all of the search 
criteria cleared.

The following topics help you import RT and CCS values into 
your PCDL:

• “Prepare to import” below

• “RT CSV files” on page 61

• “Import RT User Interface” on page 62

• “CCS CSV files” on page 63

• “Import CCS User Interface” on page 63

Prepare to import

1 Click File > Open PCDL, click  on the toolbar, or press 
Ctrl+O, if the PCDL you want to search is not already open.

2 Find the compounds you want to be part of the import (“Find 
Compounds in your PCDL” on page 47). From the 
Compounds tab, find your compounds in any of the 
following ways: 

• Click  on the toolbar, 

• Click PCDL > Find Compounds, or 

• Press the F5 key. 

3 Review the compounds shown in the Compound Results 
table on the Compounds tab.

4 Click the Import tab.

5 Disable editing. Press F2, click  on the toolbar, or click 
PCDL > Allow Editing to disable editing, if editing is already 
enabled.
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When editing is enabled, a check mark ( ) appears next to 
the PCDL > Allow Editing menu option and an Add button 
and indication ( ) appears above the Compounds Results 
table in the Compounds tab. 

6 Click either the Imported RT tab or the Imported CCS tab 
and proceed to the section that covers the data you are 
importing, RT or CCS values.

RT CSV files

You can manually create an RT import file by copying and 
editing the provided example retention time import file. The 
template is located in the \MassHunter\PCDL\Import Files folder: 

RT_import.csv - An example retention time import file that can 
be used to prepare the CSV file according to the correct 
format to import RT values from the Import tab, Imported 
RT tab.

You can also import retention times from compound results 
files exported directly from MassHunter Qualitative Analysis 
Workflows. Perform the following steps within MassHunter 
Qualitative Analysis Workflows:

1 Identify the compounds of interest in your PCDL using 
MassHunter Qualitative Analysis Workflows. For example, 
use Find by Formula or Library/DB Search to identify your 
compounds.

2 Export the compound results. Right-click in the Compound 
List table and then click Export as shown in Figure 27 on 
page 62. Use the default settings in the Export dialog box to 
export a CSV file which you can use for RT import.
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Import RT User Interface

Browse button   Opens the Open Import List dialog box.

Clear existing database RTs Clears any retention times from the 
compounds in the PCDL.

Generate Error Log Generates a log file that is saved in the 
\MassHunter\PCDL\Import Files folder.

Matched Compounds list The first list (left) contains the 
compounds from the PCDL that were matched to your imported 
file.

The second list (right) shows you the difference between the 
retention time in the PCDL and the retention time in the 
imported file. This list contains all of the matches from the 
PCDL with the current compound in the first list. Mark the Best 
match when there is more than one match to the compound.

Figure 27 Shortcut menu from the Compound List table (left) and Export dialog box (right) in MassHunter 
Qualitative Analysis Workflows
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You can also clear all Best matches and choose not to import a 
RT for certain Matched Compounds. This feature is useful when 
you have used a compound results file from MassHunter 
Qualitative Analysis as the input file, and you do not wish to 
update the RTs for all of compounds contained in this file.

Note: The following two buttons are at the bottom of the Import 
tab; you may need to adjust your main window size to view 
these buttons.

Export RT matches Creates an export file that contains a list of 
the matched compounds.

Import RT Updates the retention times in the Compound 
Results table for all of the compounds in the first (left) Matched 
Compounds list.

CCS CSV files

You can manually create a CCS import file by copying and 
editing the provided example collision cross section import file. 
The template is located in the \MassHunter\PCDL\Import Files 
folder: 

CCS_import.csv - An example collision cross section import 
file that can be used to import CCS values from the Import 
tab, Imported CCS tab.

Import CCS User Interface

Browse button   Opens the Open Import List dialog box.

CCS tolerance The tolerance value to use when adding the CCS 
information to the PCDL.

The CCS tolerance is a tool used to prevent duplicate 
conformers being added to a compound. Duplicate CCS values 
may not have exactly the same CCS values as the current 
conformers, but are essentially duplicates of current 
conformers within the instrument resolution.
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If the CCS values are without the tolerance percentage given 
from the current value in the PCDL, then the CCS values are 
added as additional conformers. If the CCS values are within 
the tolerance percentage, then the blue highlighted Import 
check box in the CCS Matches list is cleared by default, 
generating a conflict in the Matched Compounds list. If you 
want to also import these values as additional conformers, then 
mark the appropriate Import check boxes in the CCS Matches 
list.

Click Generate Error Log to generate a log file containing a 
record of the unmatched compounds which were not imported 
and compounds which registered as multiple matches which 
were imported as individual conformers. You can use this 
information to curate your CCS entries.

Clear Existing IM Information Clears any ion mobility 
information from the compounds in the PCDL.

Generate Error Log Generates a log file that is saved in the 
\MassHunter\PCDL\Import Files folder.

This file contains unmatched compounds which were not 
imported and compounds which registered as multiple matches 
which were imported as individual conformers

Matched Compounds table The left table in the Imported CCS 
tab in the Import tab (Figure 28 on page 65). The Matched 
Compounds table contains the compounds from the PCDL that 
were matched when you selected the import file.

CCS Matches table The right table in the Imported CCS tab in 
the Import tab (Figure 28 on page 65). The CCS Matches table 
shows you the difference between the CCS values in the PCDL if 
available and the CCS values in the import file. If the difference 
is below the CCS tolerance, then a conflict is shown in the 
Matched Compounds list, and the blue highlighted Import 
check box is cleared so that additional conformers which are 
duplicates are not created upon import. You can choose to mark 
the Import check box and import it as an additional conformer. 
Multiple matches are noted in the error log.
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If the difference between the CCS values are more than the CCS 
tolerance, then the CCS values are added as additional 
conformers.

Note: The following two buttons are at the bottom of the Import 
tab; you may need to adjust your main window size to view 
these buttons.

Export IM Information Creates an export file that contains a list 
of the matched compounds.

Import Conformers Adds the information in the Compound 
Results table for all of the compounds in the Matched 
Compounds list which have the Import check box marked in the 
CCS Matches table. CCS data is not updated or overwritten 
within the Import tab.

Figure 28 The Import tab in PCDL Manager, Imported CCS tab
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Send Spectra to a PCDL from Qualitative Analysis

You can use the following procedures to send spectra of 
identified compounds from MassHunter Qualitative Analysis to 
PCDL Manager. The following procedures are performed in the 
Qualitative Analysis software.

• “Send spectra from Qualitative Analysis Workflows”

• “Send spectra from Qualitative Analysis Navigator” on 
page 68

• “Options to send theoretically mass corrected spectra to a 
PCDL” on page 69

Note: Use the Find by Formula algorithm to identify 
compounds for sending spectra to a PCDL. Fragment 
annotations, needed for sending theoretically corrected 
spectra, are not currently supported by Database search.

For MS/MS spectra creation: In order to obtain the best 
scoring, it is highly recommend that you only select the 
lowest monoisotopic m/z ion as the precursor ion in 
MS/MS library acquisition, the use of higher isotope 
precursor m/z ions is not currently supported in PCDL 
Manager related workflows. In order to ensure that higher 
isotope m/z ions do not interfere with the lowest 
monoisotopic precursor ion fragmentation pattern the 
quadrupole resolution during acquisition must be set to 
narrow in order to ensure the best possible match to the 
MS/MS fragmentation library when you have complex 
mixtures. 

Send spectra from Qualitative Analysis Workflows

1 Launch MassHunter Qualitative Analysis Workflows.

2 Open an MS/MS or GC/MS data file.

3 Create the spectrum that you want to send to a PCDL. See 
“Extract spectra in Qualitative Analysis Workflows” on 
page 71.
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Note: When you use a large PCDL, such as METLIN, as the 
Formula source for identification, multiple hits for each 
compound are expected and require manual sorting to 
identify the correct compound.

4 Select all of the compounds that you want to send to PCDL in 
the Compound List window.

5 Open the Send Spectra to PCDL dialog box by performing 
one of the following actions:

Right-click the selected compounds in the Compound List 
window, and then click Send Spectra to PCDL, or 
right-click the selected spectra in the Compound 
Fragment Spectrum Results window, and then click Send 
Spectra to PCDL.

6 Select the Library path. The spectra are added to the 
selected PCDL

7 (Optional) Mark Minimum base peak height if you want to 
enter the minimum base peak counts that are needed to add 
the spectrum to the library. A default value of 1000 counts is 
recommended. You can change this value as necessary to 
achieve your desired results. This option allows you to set a 
pass/fail criteria based on base peak height to ensure good 
ion statistics in the spectral library.

8 Click one of the Annotation filter options. You can click 
either Formula annotated peaks (excludes unknowns) if 
present else all peaks or All peaks. When Formula 
annotated peaks (excludes unknowns) if present else all 
peaks is selected, the program checks that the m/z fragment 
ions observed are consistent with the assigned precursor ion 
species (for MS/MS spectra) or molecular ion species (GC/MS 
spectra) and assigns the fragment ion species as an 
annotation above each fragment ion peak.

9 Click one of the m/z selection options. You can click either 
Calculated m/z if present else observed m/z or Observed 
m/z.

10 Click one of the Conflict resolution options. If the spectrum 
already exists in the library, you can select either Send and 
replace the spectrum in library or Skip sending this 
spectrum.
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Note: If profile or spectra which are not supported in PCDL 
Manager are contained in the file, a message is displayed 
stating that spectra have been skipped. Only identified, 
centroided MS/MS and GC/MS spectra are loaded for use in 
PCDL Manager.

11 The spectra can be viewed in the Spectra Viewer dialog box 
in PCDL Manager. 

Send spectra from Qualitative Analysis Navigator

1 Launch MassHunter Qualitative Analysis Navigator.

2 Open a GC/MS data file. You should only send GC/MS spectra 
from the Qualitative Analysis Navigator.

3 Create the spectrum that you want to send to a PCDL. See 
“Extract spectra in Qualitative Analysis Navigator” on 
page 75.

4 Select all of the spectra that you want to send to PCDL in the 
MS Spectrum Results window.

5 Right-click the selected spectra in the MS Spectrum Results 
window, and then click Send Spectra to PCDL to open the 
Send Spectra to PCDL dialog box.

6 Select the Library path. The spectra are added to the 
selected PCDL

7 (Optional) Mark Minimum base peak height if you want to 
enter the minimum base peak counts that are needed to add 
the spectrum to the library. A default value of 1000 counts is 
recommended. You can change this value as necessary to 
achieve your desired results. This option allows you to set a 
pass/fail criteria based on base peak height to ensure good 
ion statistics in the spectral library.

8 Click one of the Annotation filter options. You can click 
either Formula annotated peaks (excludes unknowns) if 
present else all peaks or All peaks. When Formula 
annotated peaks (excludes unknowns) if present else all 
peaks is selected, the program checks that the m/z fragment 
ions observed are consistent with the assigned precursor ion 
species (for MS/MS spectra) or molecular ion species (GC/MS 
spectra) and assigns the fragment ion species as an 
annotation above each fragment ion peak.
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9 Click one of the m/z selection options. You can click either 
Calculated m/z if present else observed m/z or Observed 
m/z.

10 Click one of the Conflict resolution options. If the spectrum 
already exists in the library, you can select either Send and 
replace the spectrum in library or Skip sending this 
spectrum.

Note: If profile or spectra which are not supported in PCDL 
Manager are contained in the file, a message is displayed 
stating that spectra have been skipped. Only identified, 
centroided MS/MS and GC/MS spectra are loaded for use in 
PCDL Manager.

11 The spectra can be viewed from the Spectra tab. 

Options to send theoretically mass corrected spectra to a PCDL

The following options should be selected to send theoretically 
mass corrected spectra to a PCDL:

• Minimum base peak height

• Formula annotated peaks (excludes unknowns) if present, 
else all data

• Calculated m/z if present, else observed m/z

Before sending the spectra to the PCDL, manually inspect each 
spectrum and ensure that all peaks have been annotated. 
Annotated peaks are green and have the formula annotated 
above each peak. You may need to expand the x-axis to view the 
annotation.

Any un-annotated peaks indicate the following:

1 An impurity ion in the chemical standard which cannot be 
present according to the assigned precursor ion species (for 
MS/MS spectra) or molecular ion species (GC/MS spectra) 
empirical formula.

2 A background ion in the GC/MS spectra.

3 A higher m/z isotope which can be seen when the quadrupole 
resolution has not been set to narrow during MS/MS spectral 
data acquisition.
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4 An unsupported workflow has been used for fragment 
annotation. 

• Only Find by formula fragment annotation is supported 
for the Send Spectra to PCDL function for MS/MS 
spectra. 

• Manual identification and annotation is recommended for 
GC/MS spectra.

When pure single compound standards have been used along 
with a quadrupole resolution set to narrow during MS/MS 
spectral acquisition but un-annotated peaks are still seen, 
please retune and calibrate the instrument before reacquiring 
data.
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Extract Spectra for a PCDL in Qualitative Analysis

This topic describes how to extract spectra using MassHunter 
Qualitative Analysis so you can send the spectra to a PCDL. 

Extract spectra in Qualitative Analysis Workflows

1 Launch MassHunter Qualitative Analysis Workflows.

2 In the method editor, review the Target/Suspect Screening > 
Find by Fragments section to extract GC/MS spectra or the 
Target/Suspect Screening > Find by Formula section to 
extract MS/MS spectra and identify compounds.

a Click the Target/Suspect Screening > Find by Fragments 
tab (for GC/MS) or the Target/Suspect Screening > Find 
by Formula tab (for MS/MS) in the Method Editor 
window.

b Click the Target Source tab and select a PCDL that 
contains the compounds of interest.

Note: When you use a large PCDL, such as METLIN, as the 
Formula source for identification, multiple hits for each 
compound are expected and require manual sorting to 
identify the correct compound.

3 Setup Generate Formulas parameters:

Assign correct possible ion species

a In the Method Editor window, click the Compound 
Identification > Generate Formulas section.

b Click the Allowed Species tab.

c Mark all desired ion species under Charge carrier to be 
assumed if not known.

d Verify the appropriate elements and limits are set under 
Elements and Limits.

Note: For general LC and GC/MS spectrometry, the default 
value of MS ion electron state should be set to Allow both 
even and odd.
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Add fragment annotation

a For GC/MS spectra click the Find by Fragments > 
Fragment Annotation tab. For MS/MS spectra click the 
Find by Formula > Fragment Annotation tab.

Note: If the Find by Fragments > Fragment Annotation 
tab is not visible, click Configuration > Show Advanced 
Settings and then click the Find by Fragments > 
Fragment Annotation tab. 

b Mark Annotate fragment spectrum peaks with formulas.

Note: When Annotate fragment spectrum peaks with 
formulas is marked in the Target Screening workflow in 
Qualitative Analysis Workflows, observed m/z fragment ions 
are compared to the assigned precursor, or molecular ion 
species, for consistency. The fragmented ion species is 
assigned as an annotation above each fragment ion peak.

Note: When using Find by Formula for MS/MS spectra, it is 
highly recommended to mark Annotate fragment spectrum 
peaks with formulas. This allows you to send theoretically 
corrected mass spectra to your PCDL. 

When using Find by Fragments with Annotate fragment 
spectrum peaks with formulas marked, GC/MS ions which 
have been automatically annotated as an allowed fragment 
ion, based on the molecular ion formula, must be rigorously 
inspected to ensure background ions, such as column bleed, 
which also correspond to an allowed fragment ion formula 
are not sent to the PCDL.

Set spectral noise filters for GC/MS spectra

a Click the Find by Fragments > Fragment Annotation tab.

b Mark Absolute height and type 50 for the counts.

c Clear the Relative height check box.

Set spectral noise filters for MS/MS spectra

a Click the Find by Formula > Fragment Annotation tab.

b Mark Absolute height and type 10 for the counts.

c Mark Relative height and type 1 for the % of largest peak.
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Note for spectral noise filters 
for both GC/MS and MS/MS

Note: The spectral noise filters can be adjusted to achieve 
desired results.

Note for spectral noise filters 
for both GC/MS and MS/MS

Note: For large molecules and/or molecules which have a 
high degree of fragmentation, you may need to set the 
Maximum number of peaks to a value that is higher than 
250. This value is set on the Fragment Annotation tab.

4 Click Find > Find by Fragments (for GC/MS spectra) or Find 
> Find by Formula (for MS/MS spectra) to run the algorithm.

5 Verify that the compounds are identified properly, and 
inspect the degree of spectral annotation.

6 (Optional) Click a compound in the Compound List window. 
Right-click the compound and then click Add/Edit Manual 
Identification. You can enter a Formula, Charge, Ion 
Species, CAS ID, KEGG ID, UniProt ID, LMP ID, and HMP 
ID in the dialog box. You can also add Notes and load a 
structure.

7 (Optional) Click a compound in the Compound List window. 
Right-click the Compound Fragment Spectrum Results 
window (for MS/MS spectra) or the Compound MS Spectrum 
Results window (for GC/MS spectra), and then click Adjust 
Peak Threshold. You can change the threshold to label a 
peak.

Annotated peaks are green and have the formula annotated 
above each peak. You may need to expand the x-axis to view the 
annotation. In the case when the spectrum itself is green, 
right-click either the Compound MS Spectrum Results window 
or the Compound Fragment Spectrum Results window, and 
then click Choose Defined Color and choose a different color.

Any un-annotated peaks indicate the following:

a An impurity ion in the chemical standard which cannot be 
present according to the assigned precursor ion species 
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(for MS/MS spectra) or molecular ion species (for GC/MS 
spectra) empirical formula.

b A background ion in GC/MS spectra.

c A higher m/z isotope which can be seen when the 
quadrupole resolution has not been set to narrow during 
MS/MS spectral data acquisition.

d An unsupported workflow has been used for fragment 
annotation. 

•Only Find by Formula fragment annotation is supported 
for the Send Spectra to PCDL function for MS/MS 
spectra. 

•Manual identification and annotation is recommended 
for GC/MS spectra.

Note: MS/MS spectra acquired for library creation must have 
the quadrupole resolution set to narrow during acquisition. 
However, MS/MS spectra acquired for library matching 
purposes can be routinely acquired with a lower resolution 
with the consequence that higher m/z isotopes appear in the 
sample MS/MS spectrum, but not the library MS/MS 
spectrum, and lower the forward search score.

Note: When acquiring MS/MS spectra for library creation and 
pure single compound standards have been used along with a 
quadrupole resolution set to narrow during acquisition but 
un-annotated peaks are still seen, you should tune and 
calibrate the instrument again before re-acquiring your data.
74 PCDL Manager Quick Start Guide



Extract Spectra for a PCDL in Qualitative Analysis 

Extract spectra in Qualitative Analysis Navigator
Extract spectra in Qualitative Analysis Navigator

1 Launch MassHunter Qualitative Analysis Navigator.

2 Extract an EIC of your compound of interest.

a Click Chromatograms > Extract Chromatograms.

b Set Type to EIC.

c Mark the Integrate when extracted check box.

d Set the m/z value(s) to your compound of interest.

e Click the Advanced tab.

f Select Symmetric (m/z) and type +/- 0.5 for GC/MS 
spectra.

g Click OK.

3 (Optional) Extract a background spectrum. Select a range 
before and after the peak in the Chromatogram Results 
window. Right-click the window and then click Extract 
Spectrum to Background.

4 (Optional) Modify the method to subtract the background 
spectrum when you manually extract a spectrum. In the 
Method Editor window, click Spectra > Extract (MS). On the 
Manual Extraction tab, select Current background 
spectrum.

5 Extract a spectrum from the EIC in the Chromatogram 
Results window. Select a region in the EIC near the peak. 
Right-click and then click Extract MS Spectrum. You can 
instead double-click the selected region.

6 Right-click the spectrum and then click Find Spectrum 
Peaks.

7 Right-click the spectrum and then click Add/Edit Manual 
Identification. You can add or edit the Compound name, 
Formula, Charge, Ion Species, CAS ID, Notes, Structure, 
and other identifiers in the Add/Edit Manual Identification 
dialog box.

8 (Optional) Right-click the spectrum and then click Edit Peak 
Annotations. You can change the Species, Formula, and Ion 
Type for peaks in the spectrum.
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Note: If Edit Peak Annotations is not available, click 
Configuration > Show Advanced Settings, and then 
right-click the spectrum and then click Edit Peak 
Annotations.

Annotated peaks are green and have the formula annotated 
above each peak. You may need to expand the x-axis to view the 
annotation. In the case that the spectrum itself is green, click 
Edit > Choose Defined Color and choose a different color.
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PCDL Manager Installation

Install PCDL Manager B.08.00

PCDL Manager is installed from a Setup Wizard, which you run 
from the main installation program. You can install this version 
of PCDL Manager concurrent with a prior version.

• Double-click PCDLSetup.exe, or right-click 
PCDLSetup.exe, and then click Run as administrator.

PCDL Manager is installed along with the following example 
PCDL: 

Sulfas_AM_PCDL.cdb - a small example custom PCDL 
containing four compounds with spectra that can be used to 
become familiar with PCDL Manager and to create your own 
custom PCDL.

Uninstall a prior copy of PCDL Manager

Since this version of PCDL Manager provides tools for you to 
convert PCDLs created using prior versions of PCDL manager, 
maintaining a prior version of PCDL Manager is optional. You 
can remove an older version of PCDL Manager using Programs 
and Features found on your PC.

1 Click Start > Control Panel on a PC running Windows 7, or 
click Start > All apps > Windows System > Control Panel on 
a PC running Windows 10.

2 Click Programs and Features.

3 Click Agilent MassHunter PCDL Manager Software.

4 Click Uninstall/Change to uninstall PCDL Manager.
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