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Overview and Data Import Quick Start 
Guide

What is Agilent Mass Profiler Professional?

Agilent Mass Profiler Professional (MPP) is a powerful visualization 
and statistical analysis solution designed for the chemometric 
analysis of mass spectral data.  MPP is applicable to all Agilent 
mass spectrometric instruments and the markets served by those 
instruments.  MPP is ideally suited for applications characterized 
by complex sample matrices such as metabolomics, proteomics, 
natural products, food, beverages, flavors, fragrances, and 
environmental analyses. 

MPP’s powerful analytical capabilities fully exploit the high 
information content of chromatographic/mass spectrometry (MS) 
data to quickly and easily discover differences between sample 
groups, plot changing patterns of compound abundances over time, 
and develop multivariate models for class prediction.  An 
integrated ID Browser that mirrors MassHunter's Qualitative 
Analysis functionality allows identification using LC/MS Personal 
Compound Databases such as METLIN or Forensics / Tox, and 
GC/MS libraries (NIST and Fiehn library). MPP allows you to 
display and analyze large GC/MS or LC/MS data sets on your 
personal computer, regardless of whether the peaks are identified 
or are unknown.

MPP addresses the needs of discovery analysis validation, the 
combination of statistical analysis with identification, and then 
provides features that allow you to put the compounds identified 
into a biological context using integrated pathway analyses.
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Mass Profiler Professional Quick Start Guides

This Overview and Data Import Quick Start Guide is one of three 
quick start guides developed to help you use Mass Profiler 
Professional with your data. The Overview and Data Import guides 
you through the steps to import your data and is common to all 
other workflows.  It should be used when the other workflows are 
not appropriate or when ad hoc analysis is to be performed by an 
experienced chemometrician.  Because this workflow is common to 
all workflows, the critical steps of filtering, alignment, 
normalization, and baselining are described in this quick start 
guide.

This quick start guide covers:
1 Overview to Mass Profiler Professional

a User interface

b License management

c Opening a recent or existing project

d Setting up your project
2 Importing your data
3 Next steps

The next two quick start guides are:
Analysis: Significance Testing and Fold Change. This guide 
guides you through a pre-defined set of filters and models to 
help you properly assign your data conditions and obtain an 
initial expression of differential analysis.
Class Prediction: Build and Test Model. This guide guides you 
through the process to create a class prediction model based on 
your data. Class prediction is the process where you use samples 
with a known class membership to establish rules that are used 
to classify new samples. The class prediction model can be 
exported to a model file that is used to automatically process 
new sample data using Agilent’s Automated Class Prediction 
workflow.
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Where to find new information

Online help

Press F1 To get more information about a pane, window, or dialog 
box place the cursor on the part of the pane, window, or dialog box 
of interest and press the F1 key.

Help menu Click Help > Documentation Index to access the 
release notes, quick start guides, and HTML and PDF versions of 
the Mass Profiler Professional manual.

Documents

MPP Manual Agilent Mass Profiler Professional (Agilent 
publication n/a, March 2009). You can find a PDF copy of the MPP 
manual on the installation disk, in the Manuals folder.

Unbiased Differential Analysis Workflow Agilent Mass Profiler 
Professional - Metabolomics Discovery Workflow (Agilent 
publication 5990-7067EN, June 2011)

Qualitative Analysis Familiarization Guide Agilent MassHunter 
Workstation Software Qualitative Analysis (Agilent publication 
G3336-90018, Revision A, September 2011)

Quantitative Analysis Familiarization Guide Agilent MassHunter 
Workstation Software Quantitative Analysis (Agilent publication 
G3335-90061, Fourth Edition, April 2010)

Training

Quick Start Guides Use the quick start guides for MPP to get to 
know the program.

Training Courses  Visit www.chem.agilent.com to view a listing of 
training courses for MPP.
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1. Overview to Mass Profiler Professional

How do I get started with Agilent Mass Profiler Professional?

After installation of MPP, you can get started immediately using the 
preloaded demonstration experiment. The demonstrated 
experiment will familiarize you with the software functionality and 
workflow. The project called “Malaria” contains an experiment 
called “Malaria LCMS ESI+ pH 7” that consists of eight samples — 
four replicate healthy (control) samples and four replicate infected 
blood samples. You are encouraged to explore this demonstration 
project along with your own data to get to know MPP.

Quick Start Guide for Data Import

This quick start guide is the first of several quick start guides 
designed to help you quickly develop a working knowledge of MPP.

The data import workflow guides you through the steps to import 
your data. The data import workflow is common to all other 
workflows.  It should be used when the other workflows are not 
appropriate or when ad hoc analysis is to be performed by an 
experienced chemometrician.  Because this workflow is common to 
all workflows, the critical steps of filtering, alignment, 
normalization, and baselining are described in this quick start 
guide.

Since the advanced analysis operations available in the Workflow 
Browser do not guide you through the initial steps of condition 
assignment and differential analysis, it is not recommended to skip 
the “Analysis: Significance Testing and Fold Change” workflow.
4 Mass Profiler Professional Overview and Data Import Quick Start Guide



A. User Interface

Note:  Help and detailed information regarding the various fields 
and statistical treatments are available at anytime by pressing the 
F1 key on the keyboard or by referring to the MPP User Manual.

Main Functional Areas

The main functional areas of Mass Profiler Professional are shown 
in Figure 3 on page 6.

The main MPP window consists of four parts: (1) the Menu Bar, (2) 
the Toolbar, (3) the Display Pane, and (4) the Status Bar.

1. Menu Bar The menu bar shown in Figure 1 provides actions 
that are used for managing your projects, experiments, pathways, 
and display pane views.

Figure 1 Menu bar

2. Toolbar The toolbar shown in Figure 2 is located below the 
menu bar and contains four sections of buttons for the following 
commonly used tasks:

Project section: New project, Open project, and Close project
Experiment section: New experiment and Add experiment
Entity List section: Create entity list from selection, Inspect 
selected entity, and Import entity list from file
Plots, Statistics, and Pathways section: Scatter plot, Profile 
plot, Histogram plot, Matrix plot, Venn diagram plot, 
Box-and-whisker plot, Heat map plot, Data spreadsheet, 
Summary statistics, Create new pathway, and Select data source 
for plots.

Figure 2 Toolbar
Mass Profiler Professional Overview and Data Import Quick Start Guide 5
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3. Display Pane The display pane, see Figure 3 on page 6, is 
further divided into five areas — the Project Navigator, the 
Experiment Navigator, the Desktop Area, the Workflow Browser, 
and the Legend.

Project Navigator

Displays the current project and lists all the experiments with 
the project.

Experiment Navigator

Displays information related to Samples, Interpretation, 
Analysis, and My Favorites in folder related to the selected 
experiment in the Project Navigator. Each experiment within a 
project has a separate experiment navigator window.

Desktop

Display of one or more interactive views associated with the 
experiments. You can configure each view in the desktop area 
separately. Window views can be arranged using tile or cascade 
from the Window menu. The active view, noted using bold font 
in the Project Navigator and the Experiment Navigator, is 
represented by one of the views in the desktop area. 
Right-clicking anywhere in the active view shows you a menu of 
options (Figure 4) to customize the view, copy the view to the 
system clipboard, and export the view as an image in one of the 
standard formats (jpg, png, jpeg, bmp, and tiff).

Figure 4 The menu of options available by right-clicking within the 
desktop view automatically adjusts to the type of view.
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Workflow Browser

The Workflow Browser (Figure 5) is organized into sequential 
groups of operations for the analysis of your data: Experiment 
Setup, Quality Control, Analysis, Class Prediction, Results 
Interpretations, Pathway Analysis (optional), NLP Networks 
(optional), and Utilities.

Legend

The Legend (Figure 6) shows the key (scale) to the use of color in 
the active desktop view. Right-clicking on the window title 
allows you to copy and export the legend as described in the 
Desktop area description.

4. Status Bar The status bar (Figure 7) has three informative 
areas: the Status Area, the Ticker Area, and the Memory Monitor.

Status Area: Displays high-level information of the current view 
such as the number of rows and columns in table views and the 
number of entities or conditions selected in plot views. 
Ticker Area: Displays the coordinates of the cursor in active 
plot views or the entity identification and value in table views.
Memory Monitor: Displays the total memory being used and the 
total memory allocated by MPP. You can click the garbage can 
icon  at any time to reduce the memory usage.

Figure 7 Status Bar

Figure 5 Workflow 
browser operations

Figure 6 Legend
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B. License Management

Activating a License

The first time you start MPP you need to select your license type 
and enter your MassProfiler and GeneSpring Order IDs. You can 
also select and enter any applicable proxy settings at this time.

License activation information is entered in the Mass Profiler 
Professional License Activation dialog box shown in Figure 8.

Figure 8 Mass Profiler Professional License Activation dialog box

Moving a License

MPP licensing is automatically enforced.  You may move a license to 
another computer by surrendering it on the current computer and 
then activating it on the new computer.  If you need to un-install 
MPP, it is always best to surrender the existing license before 
un-installing MPP.

To surrender your license:
1 Click Help > License Manager in the menu bar. See Figure 9 on 

page 10.
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Figure 9 License Manager is available within the Help menu from the 
menu bar.

2 Click Surrender in the License Manager dialog box. You will then be 
presented with a dialog box where you can select MassProfiler as 
the product to surrender.

Figure 10 License Manager dialog box

3 Mark MassProfiler and GeneSpring when prompted to chose the 
products(orderIDs) to surrender.

Figure 11 Product selection

4 Click OK. You will then have the opportunity in the next dialog box 
to confirm or decline surrendering your MPP license.

5 Click Yes in the Confirm Surrender dialog box.

Figure 12 Confirm Surrender dialog box
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Uninstalling ID Browser

If Mass Profiler Professional was previously installed on your 
computer, you must manually uninstall ID Browser before 
installing or re-installing Mass Profiler Professional.

If you are not sure whether ID Browser was previously installed, 
you can also determine whether ID Browser is currently installed 
by following the steps below.
1 From your Windows desktop click Start > Control Panel

2 Click Programs and Features ( ). 

3 Find Agilent MassHunter ID Browser under the program Name 
column. If Agilent MassHunter ID Browser is not displayed in 
the list of programs you may stop, close the Programs and 
Features window, and install Mass Profiler Professional.

4 Click Agilent MassHunter ID Browser from the list of programs in 
the Programs and Features window as shown in Figure 13.

Figure 13 Select and delete Agilent MassHunter ID Browser from with-
in Programs and Features on a PC operating with Windows 7.

5 Right-click the Agilent MassHunter ID Browser program and 
immediately select Uninstall/Change. ID Browser will be 
uninstalled from your computer.

6 Close the Programs and Features window.
Mass Profiler Professional Overview and Data Import Quick Start Guide 11



C. Opening a recent or existing project - Malaria Demo project

The feature files you need are located in the samples directory of 
the main installation folder C:\Program Files\Agilent\Mass 
ProfilerPro\samples\Malaria Demo.

Follow the steps below to (1) open the Malaria Demo project or to 
(2) import the Malaria Demo experiment into a new project.

Steps Detailed Instructions Comments

1 Start Mass Profiler Professional. Click the MassProfilerPro icon  on 
your desktop, or
click Start > Programs > Agilent > 
MassProfilerPro > MassProfilerPro.

• This will open the Startup dialog 
box.

Open a recent project:
2 Open the recent project named 

Malaria in the Startup dialog box.

a Click the Open recent project button.
b Select Malaria from the Select recent 

project list.
c Click the OK button.

• Open recent project opens the 
project and the experiment that 
was stored in the project.

• A project is a container for a 
collection of experiments. A project 
can have multiple experiments on 
different sample types and 
organisms.
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Open an existing project:
3 Open an existing project named 

Malaria in the Startup dialog box.

a Click the Open existing project button 
in the Startup dialog box in step 2 on 
page 12.

b Click the OK button.
c Select the Malaria project row from 

the Open Project dialog box.
d Click the Open button.

• Open existing project allows you to 
open a project that is no longer 
displayed in the recent project list.

• Opens the project and the 
experiment that was stored in the 
project.

• When you have a large number of 
prior projects you may have to use 
the page navigation buttons in the 
Open Project dialog box.

• A selected project will be 
highlighted by a color based on 
your PC’s system settings.

Import into a new project:
4 Alternate way to Open: Create a 

new project in the Startup dialog 
box and import the Malaria project 
experiment. See “D. Setting up 
your project” on page 15 for 
creating a new project and a new 
experiment.

a Click the Create new project button in 
the Startup dialog box in step 2 on 
page 12.

b Click the OK button.
c Enter the new project details, Name 

and Notes, in the Create New Project 
dialog box.

d Click the OK button.

• Create new project allows you to 
import an existing project and 
experiments into the new project.

• Creating a new project allows you 
to enter new project detail 
information that will reflect your 
new data analyses.

Steps Detailed Instructions Comments

>
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e Click the Open existing experiment 
button in the Experiment Selection 
Dialog dialog box.

f Select the Malaria experiment in the 
Add Experiment dialog box.

g Click the Add button.

• A selected experiment will be 
shown highlighted using a 
background color.

• The Malaria project is now 
imported and appears as if it were 
opened using Open recent project.

Steps Detailed Instructions Comments
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D. Setting up your project

You will be guided through four steps to create a new project and 
experiment to receive imported data:

1 Startup:  Select creation of a new project.

2 Create New Project:  Type descriptive information about 
the project.

3 Experiment Selection:  Select create a new experiment as 
part of the project.

4 New Experiment:  Type and select custom information to 
store with the experiment.

Follow the steps below to setup your new project. The Agilent 
Malaria demo data set is used as an example in each step. You may 
substitute the demo information with information for your data.

Steps Detailed Instructions Comments

1 Start Mass Profiler Professional. Click the MassProfilerPro icon  on 
your desktop, or
click Start > Programs > Agilent > 
MassProfilerPro > MassProfilerPro.

• This will open the Startup dialog 
box.

2 Create a new project in the Startup 
dialog box.

a Click the Create new project button.
b Click the OK button.

• Create new project allows you to 
import an existing project and 
experiments into the new project.

• After closing an open project, you 
may create a new project from the
(1) Menu bar by clicking 

Project > New Project, or
(2) Toolbar by clicking

the New project  button.
You will then be prompted to enter 
your project information in the next 
step.

• A project is a container for a 
collection of experiments. A project 
can have multiple experiments on 
different sample types and 
organisms.
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3 Type descriptive information in the 
New Project Details in the Create 
New Project dialog box.

a Type Malaria Project in Name.
b Type Project containing the 

Agilent Malaria demo in 
Notes.

c Click the OK button.

• The project name and notes may be 
viewed and edited at any time using 
the Project Inspector dialog box by 
clicking Project>Inspect Project 
from the menu bar.

4 Select the option to create a new 
experiment in the Choose 
Experiment in the Experiment 
Section Dialog dialog box.

a Click the Create new experiment 
button.

b Click the OK button.

• You may create or add a new 
experiment from the
Menu bar by clicking 

Project > New Experiment, or
Toolbar by clicking

the New experiment  
button, or
the Add experiment  
button.

You will then be prompted to enter 
your experiment information in the 
next step.

• If you click the Open existing 
experiment button, you are 
prompted for the experiment to add 
to the project as described in 
“Import into a new project,” step 4 
under “C. Opening a recent or 
existing project - Malaria Demo 
project” on page 12.

Steps Detailed Instructions Comments

>
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5 Type and select information that 
guides the experiment creation in 
the New Experiment dialog box. 

a Type the descriptive name Malaria 
Demo for the experiment in 
Experiment name.  This name may be 
different from the project name 
previously entered.

b Select Mass Profiler Professional for 
Analysis type.

c Select Unidentified for the Experiment 
type.

d Select Data Import Wizard for 
Workflow type. Analysis: Significance 
Testing and Fold Change is covered in 
another Quick Start Guide.

e Type Agilent demonstration 
data in Experiment notes.

f Click the OK button.

• The selection of experiment type 
determines how Mass Profiler 
Professional manages the data.

• Unidentified is the proper 
experiment type selection when the 
compounds have only been 
identified by their molecular 
features of neutral mass and 
retention time.

• Combined (Identified + 
Unidentified) is the proper 
experiment type when you are 
unsure if the data has been 
Identified in full or in part, or when 
MassHunter Qualitative Analysis 
has been previously used to identify 
some of the compound features.

• Your new project is now set up.
• You will be immediately guided 

through importing your data as 
described in “2. Importing your 
data” on page 18.

Steps Detailed Instructions Comments

>
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2. Importing your data

Import data into a new project and experiment

The Data Import Wizard will guide you through the necessary 
parameters and values that will prepare the data for analysis by ad 
hoc interactive processing or subsequent processing by the other 
workflow types.

Up to eleven steps are involved in the experiment creation. The 
steps you will use with your experiment depends on your exper-
iment description and data source. Importing data involves only 
the steps presented below:

Step 1. Select Data Source:  This allows you to select the data 
source that will be used for the experiment.

Step 2. Select Data to Import:  Select the feature sample files.

Step 5. Sample Reordering: You may deselect individual samples 
and reorder the selection to group the samples, such as with 
respect to the independent variables.

Step 6. Experiment Grouping: This allows you to define the 
sample grouping with respect to the independent variables 
including the replicate structure of your experiment.

Step 7. Filtering:  Filters the molecular features by abundance, 
mass range, number of ions per feature, and by charge state.

Step 8. Alignment:  This allows you to align the features across the 
samples based on retention time and mass based on tolerances. 
This step is omitted when the experiment type is “identified” 
because identified compounds are treated as aligned by 
identification

Step 9. Sample Summary:  Displays mass versus retention time 
plot, spreadsheet, and compound frequency for the distribution of 
aligned and unaligned entities in the samples. Compound 
Frequency charts provide a quick view into the effectiveness of the 
alignment of unidentified experiment types.  The use of the back 
and next buttons in the wizard allow different alignment and 
filtering options to be selected and the results to be reviewed.

Step 10. Normalization Criteria:  Scales the sample features to a 
value calculated by the specified algorithm or an external scalar.
18 Mass Profiler Professional Overview and Data Import Quick Start Guide



Step 11. Baselining Options:  Compares each sample to a 
representative value calculated across all of the samples or the 
control samples.

Follow the steps below to import your data. The Agilent Malaria 
demo data set is used as an example in each step.

Steps Detailed Instructions Comments

1 Create a new project. • If you need to create a new project for 
your data refer to section “1. Overview 
to Mass Profiler Professional - D. 
Setting up your project.”

• A project is a container for a 
collection of experiments. A project 
can have multiple experiments on 
different sample types and 
organisms.

2 Create a new experiment. a Click the Create new experiment 
button or Project > New Experiment.

b Click the OK button.

3 Type and select information that 
guides the experiment creation in 
the New Experiment dialog. 

a Type the descriptive name of your data, 
such as My Malaria Demo for the 
demo data in Experiment name.

b Select Mass Profiler Professional for 
Analysis Type.

• Table 1and Table 2 on page 20 show 
selection and entry options 
available for the New Experiment 
dialog box
Mass Profiler Professional Overview and Data Import Quick Start Guide 19



Steps Detailed Instructions Comments

Table 1 Table of selections and entries for the New Experiment dialog box

Table 2 Table of data sources and file extensions based on Experiment Type
20 Mass Profiler Professional Overview and Data Import Quick Start Guide



c Select your Experiment type, such as 
Unidentified for the demo data.

d Select Data Import Wizard for 
Workflow type.
• NOTE: The same import steps apply 

if you select Analysis: Significance 
Testing and Fold Change.

e Type information relevant to your 
experiment in Experiment notes, such 
as Test experiment to 
recreate the Malaria 
project supplied in MPP 
data.

f Click the OK button.

• Unidentified is the proper selection 
when the compounds have only 
been identified by their molecular 
features of neutral mass and 
retention time.

• Combined (Identified + 
Unidentified) is the proper 
selection when you are unsure if 
the data is identified in full or in 
part or when MassHunter 
Qualitative Analysis has been used 
previously to identify some of the 
compound features.

4 Select the data source in the MS 
Experiment Creation Wizard (Step 
1 of 11).

a Click the description that matches the 
source of your data.
• If you are using the sample Malaria 

data set click MassHunter Qual.
• If you are using your own data set, 

click the source of the sample files.
b Select the organism represented by 

your data.
c Click the Next >> button.

• The available data sources will 
depend on your selection of 
Experiment type in the previous 
step shown in Table 2.

• Selection of an Organism is 
important if you plan to use 
pathways.

• To control your progress through 
the wizard dialog boxes:
• Click the Next>>  

button to go to the next step. 
• Click the <<Back  

button to return to prior steps 
and make modifications to your 
settings and previous entries. 

• Click the Cancel  
button to end the MS 
Experiment Creation without 
saving. You may then restart 
creating a new project and 
experiment.

Steps Detailed Instructions Comments
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5 Select the sample data to import in 
the MS Experiment Creation 
Wizard (Step 2 of 11).

a Click the Select Data Files button.

b The Open dialog box will most likely 
already point to the samples directory 
in the main Mass Profiler Professional 
installation directory, but if not, 
browse to C:\Program Files\Agilent\ 
MassProfilerPro\samples and then 
select the Malaria Demo folder.

c Browse for the proper data file types 
based on your data source selection.

• The file type you need to select will 
depend on the data source you 
selected in the MS Experiment 
Creation Wizard (Step 1 of 11).

• See Table 2 on page 20 for a 
comprehensive list of data sources 
you may select from based on your 
experiment type.

Steps Detailed Instructions Comments
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d Click the sample molecular feature 
data files to import into the 
experiment. The example Malaria data 
files are:
• 1-1_pH7_pos_01.cef
• 1-2_pH7_pos_01.cef
• 1-3_pH7_pos_01.cef
• 1-4_pH7_pos_01.cef
• 3-1_pH7_pos_01.cef
• 3-2_pH7_pos_01.cef
• 3-3_pH7_pos_01.cef
• 3-4_pH7_pos_01.cef

e Click the Open button to load the 
selected files for further preparation.

• The Open dialog box uses 
conventional buttons and icons 
that allow you to navigate and view 
your file system.

• You may select a continuous range 
of files with a click on a first file and 
a Shift-click on a last file that 
includes the range of files you want 
to select.

• You may select discontinuous, 
individual files with a Ctrl-click on 
any file.

• A progress indicator will be 
displayed while the files are being 
imported into Mass Profiler 
Professional.

Steps Detailed Instructions Comments
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f Click the Next >> button. • You can review and make changes 
to your selection during the next 
step before finalizing the 
experiment creation.

• Replicate samples are from the 
collection of multiple identical 
samples from a population. When 
replicate samples are evaluated a 
result is obtained that more closely 
approximates the true value of the 
population.

6 Review and order the selected files 
that will be imported in the MS 
Experiment Creation Wizard (Step 
5 of 11).

a Click one or more samples that you 
want to reorder.

b Click the Up  or Down  buttons 
to reorder the selected sample or 
samples.

c Repeat the reordering actions as often 
as necessary to obtain your order.

d Mark the sample names that will be 
imported into your experiment.

e Click the Next >> button.

• NOTE: This step presents the only 
opportunity you have to reorder 
your samples. After completing the 
Data Import Wizard you will need to 
create a new project and repeat 
this process to reorder your 
samples.

• You may select a continuous range 
of files with a click on a first file and 
a Shift-click on a last file that 
includes the range of files you want 
to select.

• You may Ctrl-click any sample name 
to select multiple samples.

• Click the Restore  button at any 
time after any sample reorder to 
return the sample order to your 
starting point when this step was 
begun.

Steps Detailed Instructions Comments
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7 Enter the sample grouping with 
respect to the independent 
variables and the replicate 
structure of your experiment in the 
MS Experiment Creation Wizard 
(Step 6 of 11).

a Click the Add Parameter... button.
b Type a name for your Parameter name 

in the Add/Edit Experiment 
Parameter dialog box. Infection is 
typed in the example using the Malaria 
data set.

c Click your replicate Samples that 
share the same first parameter value in 
your data. For example:
• 1-1_pH7_pos_01
• 1-2_pH7_pos_01
• 1-3_pH7_pos_01
• 1-4_pH7_pos_01

d Select the Parameter type for your 
grouping. Non-Numeric is selected for 
the example Malaria data set.

e Click the Assign Value... button.

• NOTE: Grouping at this time is 
optional. You may add grouping or 
change your grouping at any time.

• An independent variable is an 
essential element, constituent, 
attribute, or quality in a data set 
that is deliberately controlled in an 
experiment. An independent 
variable is referred to as a 
parameter and is assigned a 
parameter name.

• The attribute values within an 
independent variable are referred to 
as parameter values.  Samples with 
the same parameter values within a 
parameter name are treated as 
replicates.

Parameter Type options:
• Select Non-Numeric if the 

grouping is not a quantitative value. 
• Select Numeric if the grouping 

value will be quantitative or a value 
that reflects a degree of 
proportionality among the samples 
with respect to an independent 
variable.

• Entry of numerical parameter 
values for a numeric parameter 
type will allow some data plots to 
be scaled by the parameter value.

• You may select a continuous range 
of files with a click on a first file and 
a Shift-click on a last file that 
includes the range of files you want 
to select.

• You may select discontinuous, 
individual files with a Ctrl-click on 
any file.

Steps Detailed Instructions Comments
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f Type the value for your first grouping in 
the Assign Value dialog box. For the 
Malaria data set the first value typed is 
Not Infected.

g Click the OK button.
h Click your replicate Samples that 

share the same second parameter 
value in your data. For example:
• 3-1_pH7_pos_01
• 3-2_pH7_pos_01
• 3-3_pH7_pos_01
• 3-4_pH7_pos_01

i Select the Parameter type for your 
grouping. Non-Numeric is selected for 
the example Malaria data set.

j Click the Assign Value... button.
k Type the value for your second 

grouping in the Assign Value dialog 
box. For the Malaria data set the 
second value typed is Infected.

l Click the OK button.
m Repeat the value assignment steps 

until you have assigned a parameter 
name, type, and value to all of your 
samples.

n Review your entries and grouping 
assignment accuracy in the Add/Edit 
Experiment Parameter dialog box.

o Repeat the value assignments for 
individual or multiple samples as 
necessary to make corrections or 
changes.

p Click the OK button when the grouping 
for this parameter is complete.

• In this example the samples will be 
assigned a value representing the 
Infection Parameter name.

• The highlighted samples will be 
assigned the value typed in the 
Assign Value dialog box.

• In this example the samples will be 
assigned a value representing the 
Infection Parameter name.
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q Repeat the Add Parameter... steps if 
your data has more than one 
independent variable.
• Click the Add Parameter... button.
• Repeat the steps above until you 

have assigned a parameter name, 
type, and value to all of your data.

• Before continuing, review the 
following OPTIONAL and HIGHLY 
RECOMMENDED step 8 “Re-ordering 
parameter values in the Spreadsheet” 
on page 28 and step 9 “Saving and 
importing experiment grouping 
information in the Spreadsheet” on 
page 29. These steps provide 
advanced instructions to manage your 
parameters and parameter name 
assignments.

r Click the Next >> button when you 
have completed the experiment 
grouping.

• You may review and edit the 
parameters and parameter value 
assignments.

• You may change the value of any 
sample, or group of samples, by 
highlighting the sample and 
clicking on the Assign Value... or 
Clear button.

• NOTE: You may add grouping or 
change your grouping at any time 
after you complete the Data Import 
Wizard.
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8 OPTIONAL: Re-ordering parameter 
values in the Spreadsheet.

a Click any one value in the parameter 
column to select the whole parameter 
column.

b Re-order the parameter columns by 
selecting a parameter column and then 
clicking on the Left  or Right  
button.

c Re-order the parameter values by 
selecting a parameter column and then 
clicking on the Re-order parameter 
values  button.

d Click one or more values that you want 
to reorder.

e Click the Up  or Down  buttons 
to reorder the selected value or values.

f Click the OK button when the order for 
this parameter is complete.

• When you have more than one 
parameter associated with your 
samples, each parameter and its 
values will be displayed in a 
separate column in the completed 
MS Experiment Creation Wizard 
(Step 6 of 11) dialog box.

• When the parameter column is 
selected the column will be 
highlighted.
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9 OPTIONAL: Saving and importing 
experiment grouping information in 
the Spreadsheet.

a Once you have setup the experiment 
parameters and parameter values, you 
may save them to a .tsv file by clicking 
the Save experiment parameters  
button.

b When you create your experiment 
parameter grouping, you may load the 
values from a .tsv file instead of using 
the MPP user interface by clicking the 
Load experiment parameters  
button.

c Experiment parameter grouping may 
also be found in some sample files by 
clicking the Import parameters from 
samples  button.

• An example experiment grouping 
file that may be found in the 
Malaria demo directory under the 
named “MALARIA EXPERIMENT 
PARAMETERS (to be loaded from 
file).tsv”

• The .tsv file is organized using tab 
separated values (tsv) that may be 
created, edited, and viewed using 
Microsoft Excel or Notepad.

• Creating and editing experiment 
parameter groupings may be more 
convenient for you using Excel.
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10 Select and enter the data filter 
parameters in the MS Experiment 
Creation Wizard (Step 7 of 11).

a Mark the Minimum absolute 
abundance check box under the 
Abundance filtering heading.
• NOTE: Example values are for the 

Malaria data set.
b Type a value of 5000 counts.
c Clear the Limit to the largest and 

Minimum relative abundance check 
boxes.

d Mark the Use all available data check 
box under the Retention time filtering 
heading.

e Clear the Use all available data check 
box and type 50.01 for the Min Mass 
and 1000 for the Max Mass under 
the Mass filtering heading.

f Click the Minimum number of ions 
button and type 2 under the Number of 
ions heading.  The mass filter need not 
be set to include reference ions.

g Click the Multiple charge states 
forbidden button under the Charge 
states heading.

h Click the Next >> button.

• The filtering parameters dialog box 
will be unique for each experiment 
type. More information may be 
found in the online help.

• MassHunter Qualitative Analysis 
data used in this example presents 
the most active fields.

• Filtering during the data import 
process may be used to reject 
low-intensity data or restrict the 
range of data.

• In a find by molecular feature 
generated data file the term 
abundance actually refers to the 
feature volume.  

• In a find by formula generated data 
file the term abundance actually 
refers to the feature 
chromatographic area.

• Filtering by maximum mass may 
improve the statistical analysis by 
rejecting masses that are not 
significant to the experiment. This 
is especially relevant to 
metabolomic samples.

• The filter parameters may be 
cleared to preserve the prior 
filtering that was used to generate 
the feature data file.

• Filtering works with both GC/MS 
and LC/MS data.

• After data is imported, several 
additional filtering options may be 
applied:  Abundance, Retention 
Time, Mass, Flags, Number of ions, 
Mass and Minimum Quality Score.
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11 Select and enter the retention time 
and mass alignment parameters in 
the MS Experiment Creation 
Wizard (Step 8 of 11).

a Clear the Perform RT correction check 
box under the Retention Time 
correction heading.
• NOTE: Example values are for the 

Malaria data set.
b Type 0.1 % and 0.15 min for RT 

Window under the Compound 
alignment heading.
• Smaller RT Window values result in 

reduced compound grouping 
among the samples leading to a 
larger list of unique compounds in 
the experiment

c Type 5.0 ppm and 2.0 mDa for Mass 
Window.  
• It is not recommended to set the 

mass window less than 2.0 mDa for 
higher masses.

d Click the Next >> button.

• The alignment parameters dialog 
box will be unique for each 
experiment type. More information 
may be found in the online help.

• MassHunter Qualitative Analysis 
data used in this example presents 
more active fields. GC/MS data 
alignment will involve retention 
time difference and mass spectral 
match factor.

• A larger retention time shift may be 
used to compensate for less than 
ideal chromatography.

• If retention time correction is used, 
it is recommended to perform 
retention time correction with 
standards provided that at least 
two widely spaced standards exist, 
and those standards must be 
present in every sample.  With 
standards the correction is based 
on a piecewise linear fit

• Unidentified compounds from 
different samples are aligned or 
grouped together if (1) their 
retention times are within the 
specified tolerance window and (2) 
the mass spectral similarity, as 
determined by a simple dot product 
calculation, are above the specified 
level.

• The alignment methodologies for 
the data types are explained in 
Section 2.1.5 in the Mass Profiler 
Professional User Manual.

• Retention alignment rewrites the 
retention times in the data file so 
that the user input or 
algorithmically selected features 
are used to correct the retention 
times.

Steps Detailed Instructions Comments
Mass Profiler Professional Overview and Data Import Quick Start Guide 31



12 View and review the compounds 
present and absent in each sample 
in the MS Experiment Creation 
Wizard (Step 9 of 11).

a Clear the Export for Recursion check 
box.
• It is not recommended to export the 

compounds for recursion at this 
step in the MS Experiment 
Creation.  Better results are 
obtained after the data has been 
filtered for significance in the 
following steps.

b Click the Next >> button.

• This step allows you to see a 
summary of the compounds 
present and absent in each of the 
samples based on the experiment 
parameters including the 
application of the filter and 
alignment parameters. 

• It is useful to click the << Back 
button to make changes in the 
Filtering (Step 7 of 11) page and the 
Alignment (Step 8 of 11) page 
parameters and then return to this 
Sample Summary (Step 9 of 11) 
page several times to develop a feel 
for how each of the parameters 
affects the compound summary.  
You can even independently assess 
the effects of retention time 
alignment versus compound 
alignment.

• Replicates should have similar 
numbers of compounds present 
and absent.  You can see this easily 
if the files have a systematic 
naming system that allows 
replicates to be sorted together.

• Any part of the sample summary 
may be exported by Right-Clicking 
on that part of the summary and 
clicking Export As and clicking on 
the image type.  The option Image 
allows you to enter the image file 
location, file name, image size and 
resolution to meet you organization 
and publication requirements.
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13 View and review the compounds 
present and absent in each sample 
in the MS Experiment Creation 
Wizard (Step 10 of 11).

a Select None for the Normalization 
Algorithm in the Normalization tab.

b Clear the Use External Scalar check 
box in the External Scalar tab.

c Click the Next >> button.

• You may use normalization and 
external scalar techniques to 
reduce the variability caused by 
sample preparation and instrument 
response.
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14 Select whether to compare 
features in each sample to the 
response of the features across 
multiple samples in the MS 
Experiment Creation Wizard (Step 
11 of 11).

a Click the Baseline to ____ of all 
samples button.

b Select median for the Baseline to 
____of all samples.

c Click the Finish button .

• There are four baselining options:

• None:  Recommended if only a few 
features in the samples exist.

• Z-Transform:  Recommended if the 
data sets are very dense, data 
where very few instances of 
compounds are absent from any 
sample, such as a quantitation data 
set from recursion.

• Baseline to ____ of all samples: 
The abundance for each compound 
is normalized to its selected 
statistical abundance across all of 
the samples.  This has the effect of 
reducing the weight of very large 
and very small compound features 
on later statistical analyses. 

• Baseline to ____ of control 
samples: The abundance for each 
compound is normalized to its 
selected statistical abundance 
across just the samples selected as 
the control samples. This has the 
effect of weighting the compound 
features to a known value that is 
considered to be normal in the 
population while reducing the 
effect of large and small compound 
features.
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15 Export your project. This is the end 
of the Data Import Wizard.

a Your MPP screen view will appear with 
a profile plot of your data.

b It is recommended that you export 
your project by clicking Project > 
Export Project.
• The project may be loaded by 

clicking Project > Import Project 
after you close an open project or 
when you start a new session of 
MPP.

• Your project is now ready to begin 
your analysis.

• Exporting your project allows you to 
quickly return to the “saved” point 
in your analysis. You may export 
frequently.

• NOTE: If you selected Analysis: 
Significance Testing and Fold 
Change for the Workflow type in 
the New Experiment dialog box in 
Step 3, you will immediately start 
the Significance Testing and Fold 
Change workflow.
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3. Next steps

Generate your initial differential analysis

After you create your project and import your data into an 
experiment, you are ready to generate your initial differential 
expression. The “Analysis: Significance Testing and Fold Change 
Quick Start Guide”(G3835-90003) guides you through a pre-defined 
set of filters and models to help you properly assign your data 
conditions and obtain an initial expression of differential analysis.

Steps Detailed Instructions Comments

1 Continue to your first analysis by 
following the Analysis: 
Significance Testing and Fold 
Change wizard.

a Obtain a copy of the “Analysis: 
Significance Testing and Fold Change 
Quick Start Guide” (G3835-90003).

b Click Analysis: Significance Testing 
and Fold Change under the Utilities 
section of the Workflow Browser.

c Follow the steps presented in the 
quick start guide.

• Regardless of you personal 
expertise, the Analysis: 
Significance Testing and Fold 
Change wizard provides you with a 
quality control to your analysis that 
improves your results.

2 Customize your analysis using 
operations available within the 
Workflow Browser.

• Operations available within the 
Workflow Browser allow you to 
customize your experiment.
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