Document Editor

OfficeSuite for iOS supports all of the major Word document types including .DOC, .DOCX, .RTF, .TXT, .LOG, and .ODT (available in OfficeSuite Pro/Premium only). To access the Document Editor, either open or create a new word file from the OfficeSuite Homescreen.

The Contextual menu provides additional options for the Document Editor:

Save – Saves any changes you have made to the document.
Save As – Saves any changes you have made to the document, but gives you the option to change the file type or name of the file.
Export to PDF – Export the file to PDF.
Print – Print the document, options include:
  • Printer – Select which printer to use.
  • Copies – How many copies to make.
  • Range – Select which parts of the document to print.
Share – Allows you to share the document. The options include to Email it, Zip & Email it, as well as to Open it in Another App.
Protect – Set a user-generated password. Please note that document passwords are not recoverable. To remove a document password, simply select the Protect option again.
Settings – Includes further options for managing the file.
  • User Information – Includes the author's name and initials.
  • Autocorrect – Toggles the autocorrect feature.
  • Spell Check – Includes options to turn the spell check on or off, select which language it corrects in, as well as see the list of learned words.
  • Units – Select your prefered unit of length. Includes inches, centimeters, millimeters and points.
  • Reset Defaults – Restores the settings to their default state.
Help – Opens this help documentation.
About – Displays the app version number, useful links, and the third party libraries used in OfficeSuite. From here you can also apply to become an OfficeSuite Beta tester.

OfficeSuite's Document Editor includes an integrated Page Finder that is accessed by swiping inward from the left edge of the screen. It displays a page sidebar that lets you quickly jump to a relevant page in your document.

Viewer mode

Existing Word documents are automatically opened in Viewer mode. This mode lets you view documents with minimal interference from the interface. To enable editing, tap on the Editor icon to enter Editor mode.

To toggle the menu bar, tap anywhere in the document. You can browse between pages with vertical swipes, and zoom in and out of the interface with a pinch gesture.

There are a number of several shortcuts available at the top of the interface:

Reflow – Provides a reflow view of your document, which can be adjusted using a pinch gesture.
Go to... – Takes you to the relevant page/bookmark/location in the document. Bookmarks can be created and deleted in the Insert and View tabs, respectively, in Editor mode.
Search – Finds the entered text in the document. The Gear icon provides options to:
  • Match case such as capitalized or all lowercase letters.
  • Match whole words will filter out results that have the searched text as a part of a larger word.
Editor – Enables the full range of OfficeSuite's editing features for the document.

Editor mode

New Word documents are automatically created in Editor mode. This mode lets you immediately start creating and formatting your Word documents using the full range of OfficeSuite's editing features. To switch to Viewer mode, tap on the Viewer icon in the upper right.

While editing, you can tap on the Undo/Redo icon to retract the latest change you have made. Holding down on this icon will reveal the Redo option, where you can reapply document changes.

Home

The Home tab is where you'll find the standard range of tools for adjusting font sizes, colors, and styles; formatting options for paragraphs and headings; and more.

The multitude of options available in Editor mode are detailed below.

Style – Shows the styles menu, which gives you a quick preview of styles you can apply to selected text. The ¶ Paragraph icon and a Text icon show which styles alter paragraphs, text, or both.
 Arial Font Families – Opens the font menu, which lists your available OfficeSuite fonts in their relevant style.
  12 Font Size – Adjusts font size, in pixels. Can be incremented by using the - and + buttons, or to a predefined value by tapping on the number.
Change Case – Quickly make the text all uppercase, lowercase or a combination of the two.
Bold – Embolden text.
Italics – Italicize text.
Underline – Underline text.
Text Effects – Features a number of effects you can insert into text, these include
Subscript – Write text as subscript, or lower than the text around it.
Superscript – Write text as superscript, or higher than the text around it.
Strikethrough – Add a strikethrough effect to text.
Double Strikethrough – Add a double strikethrough effect to text.
Font Color – Specify the text color.
Highlight Color – Specify the highlight color.
Ordered List – Displays the ordered list menu, where you can choose from a variety of ways to order lists (letters, numbers, roman numerals, etc.).
Bulleted List – Creates a list with a variety of bullet styles.
Multilevel List – Creates a multilevel or tiered list.
Indent Right – Shifts text entries to the right.
Indent Left – Shifts text entries to the left.
Align Left – Aligns text against the left margin.
Align Center – Centers text between both margins.
Align Right – Aligns text against the right margin.
Justify – Distributes text evenly between both margins.
Line Spacing – Determines the amount of spacing between lines in your text.
Toggle markup – Shows/hides paragraph, indentation, and spacing symbols for advanced formatting control.
Paste – Place cut or copied elements in your document.
Cut – Cut elements from one location, and move them to another via paste.
Copy – Copy elements from one location to another via paste.
Format Painter – Copies the formatting and style of the selected text.
Paste Format – Applies formatting to text as copied with the format.
Go to Page – Goes to the selected page in your document.
Select All – Selects all the elements in your document.
Find & Replace – Will search for instances of text entered in the Search field, and will replace them with text entered in the Replace field. Browsing between search results is done with the Back and Forth arrows. The Gear icon provides options to:
  • Match Case such as capitalized or all lowercase letters.
  • Match Whole Words will filter out results that have the searched text as a part of a larger word.

Insert

The Insert tab is used for placing a wide range of visual additions to your text documents, such as graphics and tables.

Picture – Inserts an image into your document from your iOS Photos app. You may be prompted to grant OfficeSuite access to your Photos in order for this feature to work. Placed images can be modified using the resize and scale anchors, and rotated using the protruding rotate anchor.
Camera Picture – Allows you to insert an image using your iPhone or iPad camera.
Table – Inserts a table that will automatically expand to fill the space between the document margins. You can specify the number of rows and columns by dragging across the creation grid, or using the - Minus and + Plus icons underneath. Once a table is inserted, you can modify it under Table tab.
Text – Insert a text box in the document.
Shape – Select a shape from the avilable choices and insert it.
Watermark – Insert a watermark such as "Confidential", "Draft", "Copy" into the document.
Hyperlink – Adds a hyperlink to any selected text. It can be a web address, email address, or a bookmark within the document.
Bookmark – Adds a bookmark to your document. Bookmarks can be navigated within Viewer mode.
Symbol – Adds custom symbols from your installed fonts.
Footnote – Allows you to add a numbered footnote to the current page.
Endnote – Allows you to add a numbered endnote to the last page of the document.
Header – Allows you to write text in the header of the current page.
Footer – Allows you to write text in the footer of the current page.
Page Number – Brings up the page number menu, which allows you to add custom page numbers in a variety of locations on the document.
Tab – Indents the text one increment to the right.
Line Break – Inserts a line break that moves the text after the type cursor down by one line.
Page Break – Inserts a page break that moves the text after the type cursor to the next page.

Format

The Format tab is a quick way adjust the formatting of the various elements of your document. The most common formatting options from the Document Editor are gathered here for easier access.

Font – Adjusts font faces, styles, size, effects, colors, and highlights.
Paragraph – Adjusts line and paragraph alignment, as well as indentation and spacing between lines.
Table – Provides options for selecting a new table style from a predefined list, as well as additional table customizations.
Page Setup – Provides customizable page layout, orientation ( portrait or landscape), and margin options. You can adjust the page size for printing, including a large number of predefined page templates. Measurement units (inches, centimeters, points, etc.) can be set under the Settings option in the Contextual menu.
Select All – Selects all of the elements in the document, including text, images, and tables.
Bullets – Inserts a bulleted list with a selection of bullet styles.
Numbering – Inserts an ordered list sorted by numbers, letters, roman numerals, etc.
Multilevel List – Inserts a multilevel or tiered list.
Line Spacing – Allows you to adjust the spacing between lines.

Layout

The Layout tab lets you modify the look of pages, providing options to customize page margins, orientation, size, and text breaks.

Margins – Adjusts the size of the empty space along the edges of the document from a set of predefined values.
Orientation – Switches between landscape (horizontal) and portrait (vertical) page orientation.
Size – Provides a selection of predefined page sizes that are useful when printing.
Columns – Shows various options for managing your columns, including setting the Width and Spacing of individual columns or the entire document, as well as their humber and alignment (detailed below).
One – One entire column that covers the page.
Two – Two columns split evenly between the page.
Three – Three columns split evenly between the page.
Left – Two columns with a smaller left column.
Right – Two columns with a smaller right column.
Page Setup – Provides customizable page layout, orientation ( portrait or landscape), and margin options. You can adjust the page size for printing, including a large number of predefined page templates. Measurement units (inches, centimeters, points, etc.) can be set under the Settings option in the Contextual menu.
Section Breaks – Allows you to arrange text between pages and sections using breaks:
Page – Marks the point where one page ends and another begins.
Continuous – Creates a new section of text on the same page.
Even Page – Creates a new text section that stars on the next even-numbered page.
Odd Page – Creates a new text section that stars on the next odd-numbered page.
Breaks – Provides additional text-breaking options, such as around images and in columns:
Page – Marks the point where one page ends and another begins.
Column – Creates a text section that starts at a new column.
Text Wrapping – Creates text around elements in the document, useful for image captions.
Page Colour – Selects the background colour of the page.

View

Similar to Viewer mode, the View tab provides a breakdown of document statistics, as well as quick navigation options and bookmarks.

Web View/Page View – Toggles between viewing the document as a text file (page view), and a webpage (web view). In web view, the document takes up the entire page.
Go to Top – Moves the view to the beginning of the document.
Got to Bottom – Moves the view to the end of the document.
Go to Page – Goes to the selected page in your document.
Go to Bookmark – Moves the view to a created bookmark. Bookmarks are created from the Insert tab.
Delete Bookmark – Brings up a list of document bookmarks that can be removed by adding checkmarks to them.
Zoom – Provides a list of predefined values to which to zoom the view.

Review

From the Review tab, you can examine the range of modifications you're able to make using OfficeSuite's Track Changes feature with multiple author support.

Word Count – Displays document statistics, including word, page, paragraph, and character counts.
Track Changes – Enables OfficeSuite's Track Changes features, which highlights any changes you make to the document. It includes multiple author support for changes made from multiple devices.
Merged/Final/Original View – Toggles between showing the original document, the document after the changes performed, and a merged view of both.
Accept Change – Accepts the currently highlighted change.
Reject Change – Rejects the currently highlighted change.
Previous Change – Moves back to the previous change in the document.
Next Change – Moves to the next change in the document.
New Comment – Insert a new comment.
Delete Comment – Removes a comment.
Previous Comment – Moves to the previous comment in the document.
Next Comment – Moves to the next comment in the document.

Table

The Table tab appears whenever you select a table in the Document Editor. It provides a wide range of options for manipulating tables.

Change Style – Adjusts the table color scheme from a list of predefined styles. The Settings tab features additional table options:
  • Header row – The topmost row will be used as a header with special formatting.
  • Total row – The bottommost row will be used as a total row with special formatting.
  • First column – Displays special formatting for the first column of the table.
  • Last column – Displays special formatting for the last column of the table.
  • Banded rows – Applies different visual formatting to alternating rows, making them easier to read.
  • Banded columns – Applies different visual formatting to alternating columns, making them easier to read.
Cell Border – Select the type of the cell border from the available choices.
Cell Shading – Select the background colour of the cell.
View Gridlines – Toggles whether the gridlines of the table are visible or not.
Insert Above – Adds a new row above the table.
Insert Below – Adds a new row at the bottom of the table.
Insert to the Left – Adds a new column to the left of the table.
Insert to the Right – Adds a new column to the right of the table.
Delete Row – Deletes the currently selected row.
Delete Column – Deletes the currently selected column.
Delete Cells – Deletes the currently selected cell.
Delete Table – Deletes the currently selected table.