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1              Overview 

______________________________________________ 

Machine Link™ QUICK Serve continuously monitors all machines for CNC file 
requests made across wireless or wired serial connections. When a request is received, 
the requested CNC file is quickly served back to the machine tool control.  

 

Machine operators initiate all file requests without needing to leave their machine or 
manually interact with the PC. The request is initiated from the machine tool control at 
the shop floor level using simple keywords embedded into the CNC Program Request 
file. The keyword configuration is extremely flexible and will accommodate all CNC 
machine tool controls – the only limitation is your creativity! 

Email/Text MSG support is an optional feature that allows file requests to be emailed 
or sent via text message directly to Machine Link™ QUICK Serve, and then quickly 
served to the specified CNC machine tool control. This is the ideal solution for machines 
that communicate in one direction (to the control), such as ADR BTRs. 
 
The following product icon indicates that Email/Text MSG support is enabled.  
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1.1   How it Works 
 
To receive a file, open the CNC Request Program (O1111) at the machine tool control 
and enter the desired CNC file name into the Request Line.  
 
CNC Request Program 

 
Output the edited ‘O1111’ program from the machine tool control and then prepare the 
machine tool control to receive the desired CNC file entered into the Request Line 
‘(Oxxxx)’.  
 
After a short, adjustable delay Machine Link™ QUICK Serve will serve the requested 
CNC file back to the machine tool control.  
  

% 

O1111                    Recommended Program Name 

(SENDME)                 Keyword 

(Oxxxx)                  Request Line          

 

M30 

% 



P a g e  |  5                 Machine Link™ QUICK Serve                      by Controlink Systems LLC 
 

2   Configuration 
______________________________________________ 
 
Press [CONFIGURE] to access the Configuration Table shown below. Each machine is 
given a NAME and is assigned a unique PORT number. Only Machines marked with a 
‘Y’ (Yes) in the ACTIVE column will be monitored for requests. 

 

 

Rows of the Configuration Table can be modified 
through the [Table] dropdown menu located on the 
top menu bar. 
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2.1   Configuration Utility 

Although the Configuration Table can be edited directly, press [CONFIGURE] to gain 
access to the Configuration Utility. 

The Configuration Utility is used to guide you through the setup parameters necessary 
for each PORT/CNC Control. 

 

Configured CNC Name: specifies the CNC control name. 

SEND FROM – Folder specifies the folder location where CNC files will be pulled from 
and served to the machine. 
 
SAVE TO – Folder specifies the folder location where received CNC files will be saved. 

PORT specifies the unique serial communication port. 
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Active in Scan List specifies if the port will be monitored. 
 
PARAMETERS 
(Consult your Manuals, the Control Manufacturer, and/or the Machine Tool Builder to 
determine appropriate communication settings.) 
 

baud rate specifies the rate of transmission in bits per second. Typical rates are 
300, 1200, 2400, 4800, 9600, or faster. 
 
data bits specify the numbers of bits in the incoming data. Typical values are 
between 5 and 8. 
 
parity specifies the error-checking procedure. Typical value is ‘no parity’. 
 
stop bits specifies the number of stop bits. Typical value is 1. 
 
Protocol specifies the communication protocol. Typical serial communication 
protocol is ‘XON/XOFF’. 
 
EOL Delay (End of Line Delay) specifies the number of milliseconds to wait after 
sending each line of the CNC program. Typical value is 0.  
 
CHAR Delay (Character Delay) specifies the number of milliseconds to wait after 
sending each character of the CNC program. Typical value is 0. 

 
ADVANCED 
 

Seconds to WAIT before Sending controls the delay interval to wait before the 
requested file is served to the CNC control. This delay gives the operator time to 
prepare the machine to receive the requested CNC program.  

 
On Receive: Strip Extra Line Feed will force Machine Link™ QUICK Serve to 
wait before sending a CNC file until the machine tool requests the file. (This is an 
advanced feature that is designed primarily for DNC sessions and may not be 
applicable with all machine tool controls.) 

 
Start of Transmission specifies the character that will be automatically inserted to the 
beginning (FRONT) of the CNC program during transmission. Use ‘None’ if the 
character is already embedded in the CNC program contents.  
 
End of Line specifies the character or character combination that will be automatically 
appended to the end of each program line prior to sending the file to the CNC machine 
control. Typical value is ‘CR then LF’ (Carriage Return then Line Feed).  
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End of Transmission specifies the character that will be automatically inserted at the 
end (BACK) of the CNC program during transmission. Use ‘None’ if the character is 
already embedded in the CNC program contents.  
IMPORTANT NOTE: Many machine controls will not terminate the communication 
session successfully until the correct End of Transmission character is received. 
 
CNC Format specifies the data format. Typical value is ‘ASCII’. 
 
 
 

2.2   AUTO Send  

The “Auto Send Table” is used to assign the parameters required to initiate requests 
from the CNC machine tool control. 

 

SEND COMMAND specifies the keyword to initiate a File Transfer to the CNC control. 
Note: The SEND COMMAND characters are configurable to accommodate all CNC 
controllers. For additional creativity, one “AND” statement is supported.  

Trigger START specifies the character that marks the start of the File Name to send. 

Trigger END specifies the character that marks the end of the File Name to send.  
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Auto PREFIX specifies characters to be inserted before the found File Name.  

Auto EXTENSION specifies characters to be appended to the end of the found File 
Name. 
Note: this can be used to save operator typing at the CNC control if the CNC programs 
end with a specific extension.  

SEND FROM FOLDER specifies the folder location where CNC files will be pulled from 
and served to the machine. 
 
 
 
2.2.1   AUTO Send Examples 

AUTO Send Table Configuration 

 SEND 
COMMAND 

Trigger 
START 

Trigger 
END 

Auto 
PREFIX 

Auto 
EXTENSION 

SEND FROM 
FOLDER 

CNC 1 SENDME [ ]   C:\CNCPROGS 

CNC 2 M74 X Y  .TPE C:\YourFolder 

CNC 3 SENDPARTNO ( )  .NC C:\CNCMills 

AUTO Send Example – CNC 1 

% 

O1111                    Recommended Program Name 

(SENDME)                 Keyword 

[O2137.NC]               Request Line          

  

(CONTROLINK SYSTEMS LLC) 

(PHONE 812-637-6800) 

(ML QUICK SERVE) 

 

M30 

% 

In the example above, after the SEND COMMAND characters ‘SENDME’ are found, the 
Trigger START character ‘[‘ specifies the start of the File Name, and the Trigger END 
character ‘]’ specifies the end of the File Name. 

Outputting this program from CNC 1 will result in CNC program ‘O2137.NC’ from 
‘C:\CNCPROGS’ being sent to the CNC control. 

AUTO Send Example – CNC 2 

% 

O1111                    Recommended Program Name 
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(M74)                    Keyword 

XO2321Y                  Request Line                 

  

(CONTROLINK SYSTEMS LLC) 

(PHONE 812-637-6800) 

(ML QUICK SERVE) 

 

M30 

% 

In example two, ‘M74’ is the SEND COMMAND. Again, after the SEND COMMAND 
characters are found, the Trigger START character ‘X‘ specifies the start of the File 
Name, and the Trigger END character ‘Y’ specifies the end of the File Name. 

CNC 2 has an Auto EXTENSION ‘.TPE’ specified, so outputting this program from CNC 
2 will result in CNC program ‘O2321.TPE’ from ‘C:\YourFolder’ being sent to the CNC 
control. 

AUTO Send Example – CNC 3 (SPECIAL CASE) 

% 

O1111                    Recommended Program Name 

(SENDPARTNO)             Keyword 

(O6289,PARTNO1)          Request Line 

  

(CONTROLINK SYSTEMS LLC) 

(PHONE 812-637-6800) 

(ML QUICK SERVE) 

 

M30 

% 

In this last example, ‘SENDPARTNO’ (special keyword) is the SEND COMMAND. Like 
normal, after the SEND COMMAND characters are found, the Trigger START character 
‘(‘ specifies the start of the File Name, and the Trigger END character ‘)’ specifies the 
end of the File Name. 

CNC 3 has an Auto EXTENSION ‘.NC’ specified, so outputting this program from CNC 
3 will result in CNC program ‘O6289.NC’ being sent to the CNC control; however, with 
SENDPARTNO as the keyword, the folder location of the CNC program will now be 
‘C:\CNCMills\PARTNO1’.  

Using the ‘SENDPARTNO’ keyword offers an additional level of flexibility in the CNC 
program folder structure and is particularly useful for job shops that use the same 
program number across different part numbers.  
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2.3   AUTO Save 

The “Auto Save Table” is used to assign the parameters required to capture and store 
CNC program modifications that were made on the shop floor at the CNC machine tool 
control and sent back to Machine Link™ QUICK Serve. 

 

SAVE COMMAND specifies the keyword to initiate an Auto Save of the CNC program. 
Note: The SAVE COMMAND characters are configurable to accommodate all CNC 
controllers. For additional creativity, one “AND” statement is supported. 

Trigger START specifies the character that marks the start of the File Name to save. 

Trigger END specifies the character that marks the end of the File Name to save.  

Auto PREFIX specifies characters to be inserted before the found File Name.  

Auto EXTENSION specifies characters to be appended to the end of the found File 
Name. 
Note: this can be used to save operator typing at the CNC control if the CNC programs 
end with a specific extension.  

SAVE TO FOLDER specifies the folder location where CNC files will be saved to. 
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2.3.1   AUTO Save Examples 

Auto Save Table Configuration 

 SAVE 
COMMAND 

Trigger 
START 

Trigger 
END 

Auto 
PREFIX 

Auto 
EXTENSION 

SAVE TO 
FOLDER 

CNC 1 SAVEAS [ ]   C:\CNCPROG 
\RECEIVED 

CNC 2 : AND G S A  .NC C:\YourFolder 
\RECEIVED 

AUTO Save Example – CNC 1 

% 

O4005(DRILLING WITH TORQUE/THRUST) 

(SAVEAS)                              Keyword 

[O4005EDIT1.NC]                       Trigger Characters 

 

N10(START) 

G20G80G90G40G55 

N100(POSITION AND DRILL) 

#127=3.82*#101/#104(RPM) 

#128=#127*#102(IPM) 

M03S#127  

In the example above, after the SAVE COMMAND characters ‘SAVEAS’ are found, the 
Trigger START character ‘[‘ specifies the start of the File Name, and the Trigger END 
character ‘]’ specifies the end of the File Name. 

Outputting this program from CNC 1 will result in CNC program ‘O4005EDIT1.NC’ being 
saved to the folder ‘C:\CNCPROGS\RECEIVED’. 

AUTO Save Example – CNC 2 

% 

O4005(DRILLING WITH TORQUE/THRUST) 

(: AND G)                             Keyword 

(SO4005EDIT2A)                        Trigger Characters 

 

N10(START) 

G20G80G90G40G55 

N100(POSITION AND DRILL) 

#127=3.82*#101/#104(RPM) 

#128=#127*#102(IPM) 

M03S#127  
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In this last example, ‘: AND G’ is the SAVE COMMAND. Again, after the SAVE 
COMMAND characters are found, the Trigger START character ‘S‘ specifies the start of 
the File Name, and the Trigger END character ‘A’ specifies the end of the File Name. 

Outputting this program from CNC 2 will result in CNC program ‘O4005EDIT2.NC’ being 
saved to the folder ‘C:\YourFolder\RECEIVED’. 

 

2.4   Special Options 

The “Options Table” helps manage CNC files that were edited on the shop floor and 
returned using the AUTO Save feature. 

 

AUTO Print (Y/N) specifies if the AUTO Saved file should be automatically printed.  

AUTO Update (Y/N) specifies if the AUTO Saved file should overwrite an existing file 
with the same name. Setting AUTO Update to ‘N’ will store the received file into the 
designated folder for engineering review. After engineering approval, the file can be 
placed into the appropriate AUTO Send folder where it will be served back to the CNC 
control when requested. 
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No. of Files to Keep specifies the number of historic files to keep. Additional files are 
automatically deleted to conserve disc storage space.  

 
 
 

3   Requesting a CNC File 
______________________________________________ 

CNC Request Program ‘O1111’ (recommended program name) on each CNC machine 
should contain the configured SEND COMMAND keyword for that specific machine tool 
control. As outlined in Section 2.2.1, after the SEND COMMAND keyword is found, the 
Trigger START and Trigger END characters are used to find the desired CNC file to 
serve. Between the Trigger START and Trigger END characters is called the Request 
Line. The Request Line is the only line that needs to be altered by the user to request a 
specific CNC file. 

CNC Request Program O1111 

 

 

3.1   Steps to Receive a CNC File 
 

1) At the machine tool control, open the ‘O1111’ CNC Request Program.  
2) Enter the desired CNC file name into the Request Line. 
3) Output the ‘O1111’ program from the machine tool control. 
4) Prepare the machine tool control to receive the desired CNC file.  
5) Wait the Seconds to WAIT before Sending specified for the machine tool 

control.  
6) Receive the CNC file.  

 
 
  

% 

O1111                    Recommended Program Name 

(SENDME)                 Keyword 

(OXXXX)                  Request Line          

  

(CONTROLINK SYSTEMS LLC) 

(PHONE 812-637-6800) 

(ML QUICK SERVE) 

 

M30 

% 
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4   COM Port/Cable Test 
______________________________________________ 
 

The “COM Port Test” is used to validate wireless and wired COM Port assignments and 
troubleshoot COM Port/Cable problems. It is accessed through the top menu bar by 
clicking [Operate > COM Port/Cable Test]. 

The utility is incredibly useful for validating all COM Port assignments.  

 

COM port specifies the communication port to troubleshoot.  

TEST PORT initiates the COM Port/Cable Test. 
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4.1   Performing a COM Port/Cable Test 
 
Select the COM port to test and then disconnect the cable from the selected machine. 
Once disconnected, insert a jumper across pins 2(TX) and 3(RX).  
Press [TEST PORT] 
 

 
4.2   Interpreting the COM Port/Cable Test Results 
 

PASS 

1) Validates the wire and that all connections are unbroken. 

2) Validates that the correct COM port was selected and that it is working 

properly. 

3) Validates that the selected COM port is compatible with the specified 

communication parameters. 

 
FAIL 

1) A wire is loose and/or a connection is broken. 

2) The incorrect COM port was selected. 

3) The selected COM port is not compatible with the specified 

communication parameters. 

  



P a g e  |  1 7                 Machine Link™ QUICK Serve                      by Controlink Systems LLC 
 

5   Scan Log 
______________________________________________ 
 
The Scan LOG shows when the program was started and stopped, along with all 
service activities for each active machine. It is accessed through the top menu bar by 
clicking [Operate > View Scan Log]. 
 
File names and folder path details are provided for a thorough review of any errors or 
issues. Inaccurate requests initiated from the shop floor can also be investigated when 
necessary. 
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6   Manually Select and Send 
______________________________________________ 
 

The “Select and Send” utility is used to manually send CNC files to the selected 
machine tool control. It is accessed through the top menu bar by clicking [File > Send to 
CNC]. 

 

Configured Machine Controls specifies the machine tool control to manually send a 
CNC file to.  

SELECT FOLDER browses to a specific folder location. The desired CNC file can then 
be selected from the CNC Program list.  

SELECT FILE browses to a specific CNC program location. 

SEND outputs the selected CNC program to the selected machine tool control. 

EXIT returns to the main monitor. 
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7   Manually Receive and Save 
______________________________________________ 
 

The “Receive and Save” utility is used to manually receive CNC files from the selected 
machine tool control. It is accessed through the top menu bar by clicking [File > Receive 
from CNC]. 

The “Receive and Save” utility is a useful tool for troubleshooting CNC file request 
issues. Using it allows you to capture outputted files from the machine tool control for 
review. 

 

Configured Machine Controls specifies the machine tool control to manually receive a 
CNC file from.  

RECEIVE launches a communication session to receive a CNC file from the selected 
machine tool control. 

SAVE performs a Save As for the received CNC file. 

EXIT returns to the main monitor. 
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8   Print CNC File 
______________________________________________ 
 

The “Print CNC File” utility is used to manually print the selected CNC file. It is accessed 
through the top menu bar by clicking [File > Print CNC File]. 

Printing a CNC file using the “Print CNC File” utility documents the CNC file name, 
folder location, and CNC file contents and is a useful hardcopy for review and archive 
purposes. 
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9   Optional Features 
______________________________________________ 
 
 

9.1   AUTO Send via Email/Text MSG (ADR BTRs Support) 
 
Machine Link™ QUICK Serve with Email/Text MSG support allows CNC file requests 
to be emailed or sent via text message, and then quickly served to the specified CNC 
machine tool control. A message will be returned to the sender after the file request has 
been served.  
Email/Text MSG support is the ideal solution for ADR BTRs that communicate in one 
direction (to the control). This feature replaces the need for terminal hardware used for 
machines that cannot output CNC file requests. 
 
 
9.1.1   EMAIL Configuration 

The “EMAIL” section is used to configure email account settings and assign the email 
accounts and cell phone numbers to monitor for CNC file requests. 

An email account is required for Email Support, and it is recommended that the account 
be dedicated for Machine Link™ QUICK Serve. (A Gmail account is recommended). 
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Monitored Email Addresses specifies the email accounts and cell phone numbers to 
monitor for CNC file requests. Messages from recipients not on this list will be ignored.  

Email Address Format 

user@yourbusiness.com 

Cell Phone Number Format 

Verizon Wireless phonenumber@vzwpix.com 

Sprint phonenumber@messaging.sprintpcs.com 

T-Mobile phonenumber@tmomail.com 

AT&T phonenumber@txt.att.net 

Other phonenumber@custom 

POP3 Server is monitored for incoming emails. Typical value for Gmail account is 
‘pop.gmail.com’. 

SMTP Outgoing manages outgoing emails. Typical value for Gmail account is 
‘smtp.gmail.com’. 

username specifies the email address for Machine Link™ QUICK Serve to monitor for 
CNC file requests. 

password specifies the password to log in to the email account. 

SMTP port specifies the SMTP port. Typical value for Gmail account is ‘587’. 

POP3 port specifies the POP3 port. Typical value for Gmail account is ‘995’. 

Use SSL specifies if the Secure Sockets Layer (SSL) will be used to establish an 
encrypted link between a mail server and a mail client. Typical value is ‘True’. 

 
9.1.2   Gmail Account Security Settings 
 
After creating a dedicated Gmail account for Machine Link™ QUICK Serve, it is 
required to modify the [Security] setting to allow “Less secure app access” (turn it ON). 
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9.1.3   AUTO Send via Email/Text MSG Example 

AUTO Send via Email Example 

AUTO Send via Text MSG Example 

 

 
 

 
In the examples above, the ‘Subject Line’ specifies that it is an Email request, the 
‘Request Line’ specifies which CNC file to send, and the ‘Machine Name’ specifies 
which active CNC control to send the requested file to.  
Note: the sender of the message must be on the Monitored Email Addresses list. 
 
After preparing the machine tool control to receive the desired CNC file, sending this 
request to the dedicated email account will result in CNC program ‘FileName.txt’ being 
served back to the ‘FANUC’ control, and a message indicating the status of the request 
will be returned to the sender after the file request has been processed.  
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10   Help 
______________________________________________ 
 
 
10.1   Context Help 

Context Help provides helpful hints, useful details, and explanations. It is accessed 
through the top menu bar by clicking [Help > Show Help]. Once active, simply hover the 
mouse cursor over any item to view its details.  
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10.2   How to Videos 

The How to Video Directory provides helpful videos for learning how to configure 
machines in Machine Link™ QUICK Serve, receive CNC programs, register your 
product, and more! It is accessed through the top menu bar by clicking [Help > How To 
Videos]. 
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10.3   Help About 

Help About provides version and contact information necessary to connect with 
Controlink Systems LLC for support. It is accessed through the top menu bar by clicking 
[Help > About]. 
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11   MOXA Wireless Hardware LED Indicators 
______________________________________________ 

Top Panel LED Indicators 

 


