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Working with Data - Advanced 
 

Applying Conditions to Cells 
The Conditional Formatting feature in Excel 2013 allows you to apply a certain format to one or more 
cells based on the values contained in those cells. 

For example, let’s say you are tracking attorney’s billable hours on an Excel spreadsheet, and you want 
to quickly see who has billed more than 175 hours in a month. 

1. Select the range of cells to which you wish to apply the rule. 
 

2. From the Home tab, click the Conditional Formatting button. A drop-down menu will appear. 
Select the rule that you wish to apply. In our example, we want to highlight values higher than 
175, so we select Highlight Cells Rules > Greater Than… 

 

3. A dialog box will appear. For our example, we entered ‘175.’ 
4. Select a formatting style from the drop-down menu. We’ve chosen Green Fill with Dark Green 

text. 
5. Once you’ve selected your options, click OK. 
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The conditional formatting will be applied to the selected cells. In our example, it's easy to see which 
attorneys billed more than 175 hours in which months. 

 

 
You’re not limited to one condition. You can apply multiple formatting rules to a cell range or 
worksheet. 

 
To Remove Conditional Formatting 

1. Go to Home Tab > Styles Group > Conditional 
Formatting. 

2. Select Clear Rules and then choose which rules you 
wish to clear. Your options are to clear rules from 
Selected Cells or from Entire Sheet. 

The Manage Rules option allows you to edit or delete 
individual rules. This is especially useful if you have applied 
multiple rules to a worksheet. 

 
 
 

Conditional Formatting Presets 
Excel has several predefined conditional styles, or presets, that you can use to quickly apply conditional 
formatting to your data. The available options are… 

• Data Bars are similar to bar graphs. They present 
your data in horizontal bars and give you a quick 
reference to the information in your sheet. 

 
 
 
 
 
 
 
 
 
 
 

Data Bars 
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• Color Scales use color gradients to reflect the value 
of a cell or cell range. In the example, to the right, 
the highest values are green, the middle or average 
values are yellow, and the lowest values are red. 

 
 
 
 
 

 
• Icon Sets add an icon to each cell based on its 

value. 
 
 
 
 
 
 
 
 

You apply the preset formatting in the same manner that you apply specific rules. 
 
 

 
Text to Columns 
The Text to Columns feature allows you to separate 
data that appears in columns. 

In this example, we have a list of last and first names in 
the same column. However, let’s say we want to have 
the last names in one column and first names in 
another column. You could do this manually, by re-
typing last names into column A and first names into 
column B. But what if you had hundreds of rows of 
data? The Text to Columns feature makes this easy. 

 
 
 
 
 
 
 
 
 

 
Color Scales 

Icon Sets 
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Here’s how… 

1. First of all, make sure you have an empty column to the right of the column that contains your 
data. 

2. Highlight the column that contains the information that you wish to split. In our case, we’re 
highlighting column A. 

 

3. From the Data Tab > Data Tools Group select the Text to Columns button. 
 

 
4. The Convert Text to Columns Wizard dialogue box appears. 

 

5. You have a choice of two methods to change the text: 
• Delimited – This method uses characters such as commas or tabs to determine where to 

separate the data. 
• Fixed width – This method is a little more complicated. Using Fixed Width, you can 

manually select where the data breaks. You select at which points in the data the new 
columns are created. It’s not as easy as it sounds because the data doesn’t always line 
up. 

6. For our purposes, we are going to use Delimited. Select Delimited and then click Next. 
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7. In step 2 of the wizard, you’re presented with the option to set the delimiters that your data 
contains, i.e. where the text will be separated into columns. Since our data has a comma, and 
since we want the data separated into last name and first name columns, select Comma, click 
Next and then click Finish. 

 
 

8. Our data is now separated into 2 columns… 
 

 
Linking Data in Different Worksheets 
Linking data between worksheets eliminates the need to manually enter identical data in multiple 
sheets. This feature saves time and minimizes mistakes. 

In the example we’ve been using, we’re tracking attorneys’ billable hours by month. But what if we 
simply wanted a sheet that identified each attorney’s total hours billed and revenue generated year to 
date? We can create a sheet that links to that data, and which changes information as the data in the 
master sheet changes. 
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So, we want to take data from our original sheet, specifically, the total hours billed YTD and total billed 
YTD for each attorney... 

 

…and create a spreadsheet that provides a summary of that data. 

We’ve created a new sheet with the column headings Last Name, First Name, Total Hours Billed YTD 
and Total Billed YTD…. 

 

Now to create the linked data… 

1. Click within the cell on the new spreadsheet where you want the data to appear –in this case, 
total hours billed – and type =. 

2. Switch back to the sheet where the original data is and click on the box that contains the data 
that you wish to copy to the new summary spreadsheet. So, for our example, we’ve clicked in 
cell C2 of the new sheet, typed in =, and then switched back to the other sheet and clicked on 
cell K2… 

 

3. Hit Enter on your keyboard. Cell C2 in the new spreadsheet contains the number 961. 
Note that the formula bar reflects a formula in cell C2. The formula should include the name of 
the sheet to which the new cell is referring. In our example here, the formula is ='Conditional 
Formatting'!K2. 
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4. Now you can simply click, hold and drag the fill handle to copy that formula to the remaining 
cells on the new sheet. 

 

 
Do this by left clicking on the tiny green square in the bottom right corner of the cell. While 
holding the left button down, drag and highlight the cells to which you want to copy the 
formula. Excel intuitively reads the data from the other sheet and recognizes what you’re 
trying to do. 

 

Note that the data was copied into column D, but the text format was not. We still may need to 
format data. 

 
Now that this data is linked, if you change data on the master sheet, the data will change on the 
new sheet that you created. 
You can apply this same process to the names in this spreadsheet. 
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Advanced Formulas, Functions & Actions 

In this section, we’ll review a few advanced formulas and functions. Except where noted, these 
functions can be found at Home Tab > Editing Group > AutoSum Drop Down Menu. 

 
Average 
Averages the data within a cell range. Go to the empty cell at the end of a 
column or a row, then Home Tab > Editing Group > AutoSum Drop Down > 
Average. 

In this example, we’ve averaged all 59 data entries in column K, total billable 
hours. 

 
 
 
 
 

Minimum/Maximum 
Using the same steps described in the entry for Average, Minimum will identify the lowest number 
within a cell range, and Maximum will identify the highest number. 

 
Date and Time Functions 
You can use the drag and copy function in Excel to enter time intervals. 

1. For example, if we wanted a series of dates spaced out every 7 days, simply type in the starting 
date in one cell. 

2. In the next cell, add 7 days and enter that date. 

Enter the 1st 2-3 dates of 
your interval. 

 
 
 
 
 

 
3. Select both of those cells and drag the fill handle down to or across to where you want the dates 

to end. 
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4. Note that your dates will be exactly 7 days apart. 
 

This same process can be applied to time intervals. For example, if you wanted a time sheet that 
started at 8:30 am at 15-minute intervals. Following the steps listed above, your first two cells would 
contain 8:30 and 8:45 respectively. Then simply drag and copy the formula from those 2 cells. 

 
Concatenate 
The Concatenate function allows you to combine data in cells into one cell. 

For example, we have a list of first names and last names, but we want to combine them so that first 
names and last names are in one cell. 

 

 
1. Click in cell C1. 
2. From Formulas Tab > Text Button select Concatenate. 

 

3. The Function Arguments window opens. In this window, click inside the Text 1 box. Then click 
on cell A1, the one that contains the name “Shirley.” 

4. Click inside the Text 2 box. Type a space in this box by simply clicking spacebar on your 
keyboard. Note: This will put a space between the first and last names. 
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5. Click inside the Text 3 box, and then click on cell B1, the one that contains the name “Paige” and 
then click OK. 

 

“Shirley Paige” now appears in cell C1. 
 

As is always the case, you can drag and copy the Concatenate formula to the other cells. 
 

 
IMPORTANT NOTE ABOUT FUNCTIONS… 

If you need to copy or cut and paste data resulting from functions such as linking data or the 
concatenate function, you will need to paste special > paste values. This will retain the newly-created 
data. 
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Analyzing Data 

One of Excel’s biggest strengths is its ability to help you analyze and manage data. In this section, we’ll 
discuss a number of ways to help you see your data in a different way. 

 
Chart Types 
Excel has a variety of chart types, each with its own advantages. 

• Column charts use vertical bars to reflect the data in a table. They’re quite flexible and can 
work with a variety of data. However, most of the time they're used for comparing information. 

• Bar charts are just like Column charts, except they use horizontal bars instead of vertical bars. 
• Line charts are very helpful in reflecting trends. Data points are connected using lines, giving the 

reviewer a quick glimpse at the trends. 
• Area charts are similar to line charts. The only difference is that the areas underneath the lines 

are filled in. 
• Pie charts allow you to compare proportions by presenting each data point as a piece of a pie, 

making it easy to see which values make up the bulk of the results. 
• Surface Charts display data in a 3D view. They are very useful when working with large data 

sets, presenting a variety of information at the same time. 

 
Components of a Chart 
Charts comprise several elements that can help you interpret the data. This Column Chart provides a 
good example: Chart Title 

 
 
 
 
 

Vertical Axis or 
Y Axis  

Legend 
 
 
 

 
 

Horizontal Axis or 
X Axis 

Creating and Modifying a Simple Graph or Chart 
1. Select the cells that you want to chart, including the column titles and row labels. The titles and 

labels will serve as the source data for the chart. 
2. Go to Insert Tab > Charts and choose the desired chart type from the drop-down menu. For our 

purpose, we’re going to use a pie chart. 
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3. The chart will be inserted into the worksheet. 
HINT: The Recommended Charts button can help you determine which sort of chart you 
should consider. 

 

 
Modifying Chart Layout and Styles 
Once you’ve inserted it you can modify the way it looks. There are a number of components in the 
chart that you can modify, including: 

• Chart titles 
• Legends 
• Data Labels 
• Axis Labels/Names 

To add a chart element… 
1. Click Add Chart Element command in the Design tab. 
2. Choose the desired element from the drop-down menu. 

Editing a Chart Element 
To edit a chart element, like a chart title, simply double-click the placeholder and begin typing. 
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Quick Layout Command 
As the name implies, this button allows you to quickly add a pre-set format to your chart. The presets 
change depending upon the type of chart you’re working on. 

 

 
Chart Styles 
Excel provides several chart styles that allow you to easily change the look of your chart. Simply select 
the chart style that you wish you to apply from the Chart Styles group. 

 

 
Pivot Tables 
Pivot Tables allow you to summarize and manipulate data in a number of ways. It allows you to 
rearrange – or pivot – the information to give you a multitude of views. Most people don’t use Pivot 
Tables, primarily because they seem a little intimidating. This should take care of that. 

We want to know how much each attorney has billed so far this year. So let’s get started. 

1. Select the cells - including column headers – that contain the data you want to use. 
2. Go to Insert tab, select PivotTable. 

 

3. The Create PivotTable dialog box appears. You’ve already selected your data, so you don’t need 
to change it. And it’s always a good practice to create a new worksheet. That way you won’t 
disrupt any of your data on the current sheet. 
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4. Your new blank PivotTable and Field List will appear on a new worksheet. 
 

5. The column headers from your source data appear as fields in the PivotTable Field List. From 
here it’s a matter of determining which data you want to pivot – or switch - in and out check the 
box for each field you wish to add. In our example, we want to know the total amount billed by 
each attorney. So, we'll check Last Name and Total Billed. 

6. Note how each has been added to a field in the lower half of the Pivot Chart Field box…  
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7. The PivotTable summarizes the selected fields. In our example, the PivotTable shows us the 
amount each attorney billed. 

 

Just like with any other spreadsheet data, you can sort the data in a Pivot Table by using the Sort & 
Filter command in the Home tab. You can also apply any type of formatting. 

 
But the true strength of the Pivot Table is its ability to pivot information and provide you with a 
multitude of views of your data. 

 
By simply adding Month to the Columns window in our Pivot Chart Fields window, not only do we 
see the total each attorney has billed, but we can also see how much each attorney billed monthly. 

 

 
Sparklines 
Sparklines allow you to analyze and view trends in your data without creating an entire chart. They’re 
sort of like mini charts that fit inside a single cell. 

So why not just use a chart? Well, if you have 700 rows of data, your typical chart would have 700 series 
of data. The data that matters to you might get lost in all of that. However, a sparkline on each row it’s 
easier to see relationships and trends for many series at once. 

Before you start, make sure you have an empty cell or cells to the right of your data. 

1. Select the cells where your source data for your sparklines is. In our example, we'll select the 
cell range E2:J2. 
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2. Go to the Insert Tab > Sparklines group and select the style you wish to use. We’re going to use 
the line style. 

3. The Create Sparklines dialog box appears. Using your mouse, select the cell where the sparkline 
will appear, then click OK. 

 
4. The sparkline will appear in the specified cell. 
5. Click, hold, and drag the fill handle to add sparklines to the remaining cells. 

The sparklines now show a clear trend for each attorney over time. 

 
Customizing Sparklines 
Use the Sparkline Tools Design > Contextual Tab to add additional emphasis to your sparklines. In the 
case above, we’ve added red dots to the high points, but you can also change the color, add data 
markers as well as a number of other things to customize your sparklines. 


