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 Security in MyEducation BC 

This document defines the security model in MyEducation BC. It is focused on access to data 
and permissions to view or edit it, as well as account management. This information is intended 
for district personnel who are responsible for security in MyEducation BC. User creation is 
covered in a separate document.  

The document is divided into two main sections: Section 1 focuses on the functionality of the 
security components of MyEducation BC and Section 2 details the provincial level baseline 
security roles as they exist currently. If baseline security roles are created or updated, this 
document will be revised to reflect the changes. 

Security roles can be created and managed at both the Provincial (Enterprise) level and the 
District level. Users can be created at either the district or school level but user account 
management, i.e. what security roles are required for the user to perform their work, takes place 
only at the district level.  

Districts and schools have many types of users with different access needs to data and 
functionality. A very important part of setting users up is to ensure that they can access all of the 
information necessary to perform their jobs, while restricting access to other data and functional 
areas of the application. 

 

 

 

1.1 Roles 

Permissions and access to MyEducation BC are controlled by security roles. Security roles 
‘stack’ on top of each other, with the highest level of security in the combined roles being 
applied. A user can have as many roles as necessary. 

Example: A user has School Administrator and Student Services – School roles 
assigned. With this combination, they will have full write access to all areas that a School 
Administrator has access to as well as all areas that a Student Services – School user 
has access to. 

A district can also limit a user’s role to a specific school or groups of schools.  

Example: If a user teaches a class in a district’s middle school and is a vice principal at 
the high school, the Teacher role in the middle school is scoped only to the middle 
school and provides access only to those students in the teacher’s class. The School 
Administrator role gives full access to all data for all students, including Student Services 
information, but only in the high school.  

Roles also determine which views (District, School, Staff etc.) a user can access.  

 

All roles available in a district can be found at: District View > Admin > Security > Roles 

Training is an essential component of all district and school processes. It is imperative to 

emphasize the importance of and the responsibility involved in having access to information 

and the ability to make changes to access. 
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There are three areas of information for each security role: 

Details: Information on the composition of each role 

Security Tags: Provides the ability to restrict access to individual fields on a screen 

Users: A list of all users within the District with that role 

 

 

 

 

  

Do not assign or stack roles that will give a user more access than intended.  

Check the functionality of a role by going to District View > Admin > Security > Roles > 

Details. You can also refer to the Security Role Matrix document, posted in the L1 

Information Station - this document lists the access provided with every Enterprise role. 

District processes are essential in determining and enforcing who can perform certain tasks. 

A clerical user, for example, may have functionality available to them with their role, or with 

stacked roles, that are beyond their need or authority for the work they perform. This is up to 

each district to decide the appropriate role or combination of roles. 
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1.2 Role Details 

Section 2 of this document explains in real world language the tasks that each Enterprise level 
baseline role is designed to accomplish. A District may identify a need to customize a baseline 
security role or create new ones to meet their specific requirements and, in MyEducation BC, 
districts have the ability to do this. However, it is very important to understand and manage the 
potential impacts of maintaining a unique District set of user roles before moving away from 
the baseline roles. 

Standardized baseline roles are vital to the ongoing operation of MyEducation BC. When a 
security role is updated at the Enterprise level to reflect new or revised functionality, the 
changes are automatically applied to all users with the given role assigned. District customized 
or created roles are NOT updated with Enterprise changes. 

 

Role details can be found at: District View > Admin > Security > Roles > Details 

 

• Customize: Appears only on Baseline Enterprise roles. Allows Districts to modify a baseline 
role to meet their needs. When used, ALL users who are assigned to the baseline role will 
automatically be moved to the newly created role. If the customized role is removed, users will 
be returned to the Baseline role by using the Revert button, see section 1.4.2 for details. 

• General & Navigation Tabs: The General tab shows the Data Dictionary Tables that the role 
provides access to. Data Dictionary Tables are the areas in the system where specific data 
resides; data is accessed from these tables from different screens in the application. The 
Navigation tab controls which Top Tabs, Side Tabs, and Leaves are accessible. 

• General - View Selector: Defines which Views the role provides access to. 

• General - Security Access: Adjusts the permissions for the tables that the role has access to, 
by defining which of the following privileges apply: 

It is recommended that, wherever possible, users are assigned to Baseline Security Roles to 

ensure up to date security access and functionality. Troubleshooting District customized 

roles may require a catalogue service request to the provincial team. 
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Privilege Users with this role can... 

C - Create Create new records in this Data Dictionary table. (Options > Add) 

R - Read View information in this Data Dictionary table. This privilege determines if information is 
visible. 

U - Update Update existing records in this Data Dictionary table. This privilege determines if the Save 
button appears on pages. 

D - Delete Delete records in this Data Dictionary table. (Options > Delete) 

G - Global access Gives user access to an unfiltered list of records for any table in the MyEducation BC 
database that they have privileges for. 

M - Mass Update Update several records on a list. (Options > Mass Update) 

Other Some roles need to perform tasks that require extra privileges. The Other column displays 
additional access and privileges users have with the data in some areas. Select a checkbox 
to give the role access to the specific data or action. Deselect a checkbox to restrict access 
to the data or action.  

Example: a Schedule Builder needs to be able to Allow course maximum override enrollment 
restrictions. 

 

Example: The Student Attendance and Student Class Attendance system tables have edit 
privilege levels They range from level 1 through level 5; level 5 has the most editing 
privileges. The system administrator has all edit privilege levels enabled by default, and can 
edit the privilege levels of other user roles. 
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• Navigation – Selector: View toggles which view will be displayed by default – Only 
views assigned to the role will be selectable. Show inaccessible will display the tabs 
which have not been granted to the role. Show leaves will display the leaves for the 
side-tabs. 

• Navigation – Permissions: This automatically displays the areas the role has access 
to. Additional areas can be viewed by toggling the options above. When creating or 
customizing roles, districts can Add or Remove access to different areas. 

 

Column Description 

Type Displays whether the item is a Top Tab, Side-tab, or Leaf 

Name Displays label of item 

Required Privileges The minimum Data Dictionary access required to enable the tab. This 
is granted on the General sub-tab for the role. 

Analysis Displays reasons why the tab may not be available. Missing privilege 
notes that Data Dictionary access has not been granted. Parent 
Excluded notes that the higher level Tab or Side-tab has not been 
added  

Available Action When viewing an editable role, districts can add or remove access to 
the tabs 
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1.3 Security Tags 

Security tags are a very powerful tool to restrict access to specified fields throughout the 
application. Great caution should be used when adding tags to existing security roles. Tags 
have the ability to remove view access to fields throughout the application. The data is not 
touched, but access is removed. 

Example: A security tag was added to a customized Clerical SIS Admin role which listed 
the Person - Usual First Name and Usual Last Name as No access. ALL users with this 
role would no longer be able to view ANY usual names in the application. Removing this 
tag would restore the users’ view to normal. 

Using Security tags is a multi-step process:  

1. Tags are created 
2. Fields are assigned to the tag 
3. Tags are assigned to roles.  

Each tag is for a specific table. 
 

1.3.1 Creating a Tag 
District View > Admin > Security > Security Tags > Options > Add 

 

1. Name the tag 

2. Choose the table – This specifies which data dictionary table the field exists in. 
These tables provide access to the information system wide, not just by functional 
area. Only one table can be added to a tag, but a single security role can have 
more than one tag. 
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1.3.2 Assign Fields 
District View > Admin > Security > Security Tags > Fields > Options > Add 

 

Choose all the fields applicable for the tag. This list is populated by the list of fields in the 
Data Dictionary Table selected in the previous step. This list is editable later. 

The field set columns of Enabled, ListEdit, Update, Require and Read-Only are flags set 
on the fields at the Enterprise level, and cannot be adjusted. These are displayed for 
informational purposes only. 
 

1.3.3 Assigning Tags to Roles 
Tags have three Access Types which are determined when assigning to a role.  

Access Type Description 

No access Removes all the fields in the Security tag from the Security Role 

Read-only Forces Read-only access to the fields  

Full Access Provides regular access only to the fields listed (Normal security 
permissions apply). This removes access to all other fields not included 
in the list 
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There are two methods of assigning tags to roles: 

1.3.3.1 By Role 

District View > Admin > Security > Roles > Security Tags 

This lists all the Security Tags assigned to a particular role.  

Options > Add provides a list of Security Tags which match the permissions 

given to the role. Multiple tags may be added, with the highest level of permission 

being applied. 

 

1.3.3.2 By Tag 

District View > Admin > Security > Security Tags > Roles 

This shows a list of all the Roles to which the Security Tag is assigned. 

Options > Add provides a list of Roles which match the fields in the Security Tag 
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1.3.3.3 Modifying Access Type 

After assigning the Access Type to either a Tag or a Role it can be adjusted by 

using the Options > Modify List function. 

1.3.4 Testing and Deploying Security Tags 
Security Tags are very powerful and should be deployed with caution. It is strongly 

recommended, when creating tags, that a test security role and user account is created in 

SDTest. Make changes to the tags, logging off and back into the test account after every 

change verifying the results. Applying tags to existing user records may cause unintended 

consequences as some items may be removed from a user’s interface.  

Note: Reports are not affected by security tags. 
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1.4 Role Customization, Creation and Editing 
Baseline Roles in MyEducation BC are not editable by districts. However, they can be 

customized and, when this is done, ALL users who are assigned to the baseline role will 

automatically be moved to the customized role. If the customized role is removed, users can 

be returned to the Baseline role by using the Revert button. 

In addition, districts have the ability to create new roles unique to their needs. The 

modification of roles should be done by users with the highest level of permissions in the 

district, e.g. users with the District Support (Help Desk/Level 1) role, because a user can only 

create a role with permissions equal to or less than their own role. Only the areas for which a 

user has permissions can be added, modified or customized. 

Example: A school user cannot create an account with District level access. 

 

When customizing or creating unique security roles, it is recommended that districts create a 

user in SDTest with the roles assigned to confirm that they are working as expected. As 

changes are being made, either to a user’s roles or to the role itself, log out of the test 

account and login again to ensure the changes are being reflected. 

 

1.4.1 Stand Alone vs Add-On Roles 
Roles are defined as either Stand Alone or Add-on. This is a reflection of the different 

security permissions granted to a role.  

A Stand Alone role can be the only role assigned to a user; it provides sufficient privileges 

to login and access the application. However, if a user is given only an Add-on role they 

may encounter an error message on login, or may not be able to navigate anywhere within 

the application. 

Add-On roles can quickly and easily provide additional permissions to a user’s existing 

security roles. They can be a useful tool to increase user access by incremental amounts. 

Example: A teacher is now in charge of monitoring detention. Her user account 

currently has only the Teacher role assigned, which does not provide access to 

the Conduct module. However, as the detention monitor, she needs to be able to 

mark detention participation and to enter notes. Assigning the Detention Room 

Monitor Add-on role gives access only to the additional portions of Conduct 

required to perform the new duties. 

Important: Security roles often require security tags to be applied by the Ministry of 

Education. Baseline and customized roles will automatically inherit these tags, but newly 

created roles will not. If a user creates a brand new role in MyEducation BC, they must 

submit a service request to have the relevant security tag(s) added (e.g.: VTRA). 
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Section 2 indicates the role type, Stand Alone or Add On, for each of the Baseline roles. It 

is recommended that districts include Add-On in the title of their locally created roles will 

clarify the type of permissions that are being granted. 

1.4.2 Customization 
Baseline roles are maintained at the Provincial (Enterprise) level. Districts can customize 

baseline roles to better suit their needs. Note: District created roles cannot be customized.  

The Customize button is accessed at District View > Admin > Security > Roles > 

Details.  

 

When a customized role is created, the District Name is appended to the title. It is 

recommended that the district change the role title to better reflect the changes made in 

the role. If the baseline role is customized a second time, the title can be identical, making 

it a challenge to know which role serves which purpose. It is important to note that you 

cannot create a user role with greater privileges than your own, so role customization 

should be done by the user with the highest level of permissions. 

Once the customized role is created it should be added to the ‘District Staff – Primary 

School Association’ security tag, so that users assigned this role have only Read Only 

access to staff primary school association on the Staff TT > Detail screen. The security 

tag type should be read only. 

See section 1.3.3.2 for information on how to add roles to security tags. 

Once a customized role has been created, the details can be adjusted as desired. It is 

recommended that all changes made to customized roles are well documented and that 

the information is kept current. This will be helpful if districts choose to revert to a baseline 

role and then customize the role again to apply any Enterprise changes. 

1.4.2.1 Reverting a Role 

If a customized role is no longer required, clicking on the Revert button on 

District View > Admin > Security > Roles > Details will return all attached 

users to the Baseline role and remove the customized role completely. THERE 

ARE NO WARNING PROMPTS, the changes take effect immediately. 

1.4.3 Creating and Editing 
Districts may choose to create unique roles within MyEducation BC rather than customize 

an existing baseline role. It is strongly recommended that when creating custom roles a 

test user account be created. Make the changes to the role, logging off and back into the 

test account after every change verifying the results.  

ALL users with the baseline role assigned will have the customized role 

automatically assigned when completed. Customized roles are not updated 

with Enterprise changes. 
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District View > Admin > Security > Roles > Options > Add 

The order in which a role is created is important. Navigation options are dependent on the 

permissions granted on the General tab.  

1. Choose which views the role will have access to 
2. Select the Security Access areas, and their permissions. Use of the [all] and 

[none] buttons can assist with mass selecting/de-selecting the permissions for that 
table. If the user creating the roles does not have security permissions to that area 
of the table, the box will be greyed out, and the option will not be available to 
select. 

 
3. Save 
4. Move to the Navigation tab and select which View to edit

 
5. Save 
6. Move to the next view if applicable. 

See Section 1.2 for more information on the details of these screens. 

  

Important: Users with the ability to create user account roles for district and school level.  

Ensure any users with these roles are aware of the district security processes and protocols 

to ensure the safety of the student data. Roles should be created with careful consideration of 

data available for viewing, printing, and email capability, e.g. do roles assigned follow district 

privacy? Are the roles created with security in mind? 

Do these users have the knowledge they need to protect the students’ and families’ security? 
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1.5 Staff School Associations 
This functionality is an enhancement from the SMC to provide districts with greater control over 

which individuals have the ability to assign school staff primary or secondary associations.   

The staff primary and secondary school associations determine which students a staff member 

will see.  The district can now assign the District Staff – Primary School Association add on 

security role to those specific individuals that will determine staff primary or secondary school 

associations.   

 

1.5.1.1 Primary School Association for a Staff Record  

 

 

1.5.1.2 Clerical – School View Access – Clerical Role 

When creating a new staff record the Primary School Association (on saving the record), will be 

auto populated with the school you are currently in, if your security role gives you these 

privileges. 

 

1.5.1.3 L1 – District Access - District Support (Help Desk/Level 1) Role 

Primary School Association cannot be added/updated from the District View.  It must be created 

at the School View level.  

When creating a new staff record the Primary School Association, on saving the record, it will be 

auto populated with the school you are currently in.   
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1.5.1.4 Secondary School Associations for a Staff Record 

 

1.5.1.5 Clerical – School View Access – Clerical Role 

Clerical do not have access to: 

• Add the Secondary School Association  

• Use the Manage School Associations functionality 

• Use the Rollover Staff Schools 

 

1.5.1.6 L1 – District Access - District Support (Help Desk/Level 1) Base Role 

• District User has access to edit District View > Staff Top Tab > Schools Side Tab and 
add schools to users 

• District User has access to edit School View > Staff Top Tab > Schools and add 
schools to users 

• District User has access to Manage School Association procedure under District View 
> Staff Top Tab > Options 

• District User has the access to Manage School Association procedure under School 
View > Staff Top Tab > Options 

• District User has the access to Rollover Staff Schools procedure under School View > 
Staff Top Tab > Options  
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1.6 District Staff – Primary School Association Add On Role 
 

The purpose of the add on role is to allow a district role user to make changes to staff record’s 

primary school association. 

The district user has the ability to add/update Primary School Association from District View > 

Staff Top Tab > Detail leaf. This does NOT give the district user the ability to edit staff primary 

school associations at the school view level. 
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1.7 Account Management 

1.7.1  User Information 

District View > Admin > Users 

This provides a list of all the users in your district. There are many filters on this screen 

which help to refine the information presented.  

System Filter Description 

Enabled Login Status = Enabled 

Disabled Login Status = Disabled 

Self Created Accounts created through self serve creation “Request and Account”

 
Online Registration 

• Parents can use this functionality to create a new (limited functionality) 
user account for the purpose of Online Registration. Confirming that 
they are “a parent or guardian registering my child online” 

• Districts who have chosen to use Online Registration will have their 
district name as a choice in the School district list that parents can 
choose from. 

 

All Records All User accounts 

Contact School = ? Prompts for school name (contains). Returns all contacts (parents) with an 
account for that school. 
 

Contacts with no Portal 
Access 

User Accounts that no portal access with Students 

Contacts with Student 
Status/School = ? 

Prompts for school name (contains) and student Enrolment Status Returns all 
contacts (parents) with an account for that school for a student with the specified 
enrolment status.  
Note: if the contact is attached to multiple students with different enrolment 
statuses (e.g. Active and Graduated) the contact will appear on both lists. Be 
aware of this prior to disabling accounts! 
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System Filter Description 

Contact Not attached to 
Active Student 

User accounts with no active students attached 

Parent OLR Add-On Role 
Only 

User accounts that have only the 'Parent/Guardian - Online Registration Add-On' 
role 

Parent/Guardian Contact flag (Default field set) set to Y 

Password Expiration = ? Filters on Password Expiration Date 

Staff Staff flag set to Y 

Staff School = ? Prompts for school name (picklist). Returns primary users for the selected school 

Student Student flag (Default field set) set to Y 

Student Enrollment Status 
= ? 

Prompts for Student Enrolment Status. Returns student users with selected 
status. 

Student School = ? Prompts for school name (contains). Returns primary students only with an 
account for that school 

Student School and 
Enrollment = ? 

Filters to students from a single school and with a certain Enrollment status e.g. 
Active, Withdrawn etc. 

The filters that appear in the list have been created at the system or district level. 

Click the  icon and select Manage Filters. In the Manage Filters pop-up window, users 
see the following in brackets beside the name of the filters: 

o System:  these filters are part of the core application.  They can be hidden or 

moved up or down in the list, but cannot be modified. 

o Enterprise:  these filters have been created at the enterprise level and display for 

all districts and schools.  They can be hidden or moved up or down in the list, but 

cannot be modified. 

o District:  these filters have been created at the district level for the district level 

views. They can be hidden or moved up or down in the list but cannot be modified 

unless the user has access to the District view. 

o School:  these filters have been created either by a school user, or by a district 

user in the school view. They are visible to all users with access to the School view.  

These filters can only be modified or deleted by a school user or a district user with 

school view access. 
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o User: an individual user has created these filters.  They will only show in the list for 

the user who created them and therefore can only be modified or deleted by the 

user who created them.  
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1.7.1.1 User Details Fields 
District View > Admin > Users > Details 

  

Leaf Description 

Details Information related to a User – including Login ID, 
Password, account status and login attempts 

Audit If the user has made a change to an Audit Tracked 
field, it would be displayed here. 

Roles The roles assigned to the user. 

Schools The schools the user is associated with. By default 
this will only be populated for users with School 
View. See 1.5.5 for more options  

Organizations The districts the user is associated with. By default 
this will only be populated for users with District 
View. 

Snapshots A list of snapshots that this user is attached to 

Access Log A record of user connectivity. Default filter is Today 

Tool Log A record of tools (reports, procedures etc.) the user 
has run. Error messages are available for review. 
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Field Description 

Legal first name Legal first name 

Legal middle name Legal middle name 

Legal last name Legal last name. The magnifying glass pulls all Person records in a district. 
This can be used for manually linking accounts. 

Login ID User login ID – Must be a unique id within the entire province. 

Account expiration date Date in which the user account is disabled automatically. 

Password The password can be manually reset to a chosen password by clicking edit 

Password expiration 
date 

When the current password expires – blank unless there is a Generated 
Password, which expire the day they are created. 

Allow access from Limit the user’s ability to login to specific IP addresses. It is recommended to 
not use this feature. 

Attempts allowed Number of failed login attempts before the account is disabled. 0 (default 
value) refers to the provincial setting which is currently set to 5 attempts. 

Login Status 1. Enabled 

2. Disabled but allow re-enable from password recovery 

• The account has been locked, but the user can re-enable 
their account using the password recovery option. 

3. Disabled and locked 

• The account is disabled. It can not be reset by the user. It 
can be reset at the school or district level. 

Invalid attempts Displays the number of invalid login attempts. This resets after a successful 
login. 

Authentication type Not used in MyEducation BC. Do not adjust. 

Active directory ID Not used in MyEducation BC. Leave blank. 

Generated password Displays a one-time-use, system generated password. Once the user has 
reset the password, this is blank. 

Password Disabled Indicates if the user’s password no longer functions 

Invalid attempts Displays the number of invalid password recovery attempts. This resets 
after a successful password recovery 
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1.7.2 Passwords 

1.7.2.1 Password requirements 

Password format policy is set at the Enterprise level, and the following restrictions 
apply: 

1. Password must be minimum 8 characters. 

2. Password must have at least one digit. 

3. Password must contain both upper and lower case letters. 

4. Password requires non-alphanumeric characters such as: 
! @ # $ % ^ & * ( ) - _ [ ] ? 

5. Password validates with heuristics (i.e., cannot be password or any similar 
(i.e. P@ssw0rd); cannot be a variation of the user name; etc.) 

1.7.2.2 Password Expiration 
MyEducation BC has the following standards for password expirations: 

1. When creating a new User Account, or resetting a password, 
MyEducation BC defaults to the password expiring the next time the user 
logs in. This way the user will be able to create something more 
memorable to them. 

2. Passwords set by the user will automatically expire 90 days after they are 
changed. This is an Enterprise-level setting, and can not be modified by at 
the District or School level. 

1.7.2.3  Password Reset  

Passwords can be changed in different ways depending on the security permissions 
of the user. 

1.7.2.3.1 District Level 

District View > Admin > Users 

There are three methods of resetting passwords 

1. Creating a system generated Password – Select the users that require 

password resets and go Options > Show selected, then Options > Reset 

Passwords  
 

IMPORTANT: READ THE POP-UPS! 

ENSURE that only the users whose passwords you want to reset are selected. Read all 

the pop-ups. You have the ability to reset EVERY password in the district an there is 

NO UNDO function. 
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Password choices: 

I. Mnemonic: two 4-letter words with a 3-digit number in the middle, such as 
GONE987book It is case sensitive. This will appear in the GenPW field, and is 
a one-time use password. 

II. Numeric: a random number containing the specified number of digits. This will 
appear in the GenPW field, and is a one-time use password. 

III. Constant: entered by the district user. This will appear in the GenPW field, and 
is a one-time use password. 
 

2. Manually editing a password – Details > Password > Edit 
1. Regular password requirement apply. 
2. The password will have the same expiry date as it currently has. 

 
3. District View > Admin > Users > Password Recovery 

This option is only available to users with the Password Recovery – District 

Security role. It functions the same as the School level procedure described 

below. 

1.7.2.3.2 School Level 

School View > School > Options > Password Reset 

This option is only available to users with the Password Recovery – School 

Security role. 

 

This is divided into three sections for the 

different user types. The  will display a 

list of all users of that type, where the 

Account Expiration Date has not passed.  

Set any of the unused user types to No 

This procedure will do three things: 

1. Generate a new mnemonic password 

which will appear in the GenPw field. 

2. Email the primary email address for 

that user with the username and 

generated password. 

3. Re-enable disabled accounts, and 

reset the Login Invalid Attempts to 0. 

  



 

Security Management 6.4 Page 26 

1.7.2.3.3 User Level 

Any user can change their own password.  

• If the password has reached its expiration date (after a system generated password has 
been used, or 90 days after the last password change) the user will be prompted upon 
login to change it. Regular password requirements apply, and the password must be 
different than the expired password. 

• If a user wants to change their own password they can click their name on the top right 
corner of the screen Set Preferences > Security  

• If a user has forgotten their password they can click on the I forgot my password link on 
the login screen. They will be prompted for their Login ID, Primary email address and 
Security question. An email will then be sent to the Primary email address containing a 
system generated password. This will also appear in the GenPw field. 
 

1.7.2.4 Password Recovery Security question 

Upon initial login users are required to set a Security Question to facilitate user 

password reset. The questions and answers are not able to be seen by anyone 

except the user. Changes can be made to this by the user by clicking on their name 

on the top right corner of the screen Set Preferences > Security. A user has three 

attempts to answer the question correctly before their account is locked and 

disabled. 

 

1.7.3 Account Status 
Only Enabled accounts with a future expiration date can access the system. Account 

status can be mass updated if desired. District View > Admin > Users > Options > 

Mass Update > Login Status 

Example: If district policy is to disable staff (teacher) accounts at the end of the 

school year, you could filter the users by type, then mass update the Login Status to 

Disabled and locked. This will prevent the teachers from logging in. The accounts 

can be re-enabled when appropriate. 

The account status also determines at which level password resets can occur. 

Status U
s
e
r 

S
c
h

o
o

l 

D
is

tr
ic

t 

Enabled Y Y Y 

Disabled but allow re-enable from password recovery Y Y Y 

Disabled and locked N Y Y 

Expired (with any of the above status) N N Y 
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1.7.3.1 Account Expiration 

The Account Expiration date allows for an account to be automatically disabled. This 
function can be used to ensure that only individuals who are still active in a school or 
district can access the application.  

Example: Family Portal accounts can be set to expire on June 30. After school 
resumes in September, the expiration date can be updated to a future date for 
only those students who are currently Active. 

1.7.4 Disabling & Deleting Accounts 

There are two ways of removing a user’s access to the system: Disabling and Deleting 
accounts. 

Disabling accounts should be the choice in ALL situations except when an account has 
been created in error. As mentioned in section 1.5.3, disabled accounts can be re-enabled 
a variety of ways.  

To ensure a disabled account cannot be re-enabled by a reset procedure, set the account 
expiration date to a date in the past, change the password and the primary email account. 

1.7.4.1 Disabling  

Accounts can be disabled in a number of ways 

1. District Level users can view the account details and set the status to 
Disabled and Locked. District View > Admin > Users > Details 

2. District and School level users can disable Staff accounts by setting the 
staff member’s Status to Inactive. District/School View > Staff > Details  

• This removes the staff member from active lists and sets their login 
status to Disabled and Locked. Note: after a staff record has been 
set to Inactive changing the staff back to Active will not re-enable 
their login. 

Example: A teacher went on paternity leave. The school set 
the Staff record to Inactive. The teacher has now returned so 
the school changed the Staff record back to Active. The user 
account will remain disabled until it has been re-enabled. 
See 1.5.3 

3. District and School level users can disable Student accounts when 
withdrawing a student. Parent accounts are not affected by this. 
District/School View > Student > Options > Registration > Withdraw 
Student > Disable related user accounts 

4. Users can disable their own accounts if they exceed the set number of 
invalid login attempts. 

1.7.4.2 Deleting Accounts 

User accounts have numerous connections to different data points. Access to files 
or other records may be removed permanently from the system if an account is 
deleted. Accounts should ONLY be deleted when created in error and this should be 
done immediately after being created.  
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To ensure a disabled account cannot be re-enabled by a reset procedure, set the 
account expiration date to a date in the past, change the password and the primary 
email account. 

An account can be deleted by going to District View > Admin > Users > Details > 
Options > Delete 

 

1.7.5 Access Management 
Access and permissions for users within the application are determined in two areas: 

user roles, and organization/school access. 

1.7.5.1 Adding and Removing Roles 

The primary method of controlling permissions is by adding Roles which can be 
done three ways: 

1. Adding multiple roles when initially creating an account via the Create 
User Account wizard, such as the one at District/School View > Staff > 
Options > Create User Accounts 

2. Adding roles by individual users: District View > Admin > Users > Roles 
> Options >  

• Add: Provides the ability to choose one role at a time and configure 
school level access (for mass assign see 1.5.5.2) 

• Multi-Add: Provides the ability to select multiple roles at once.  

3. Adding users to a role: District View > Admin > Security > Roles > 
Users > Options > Add: This provides the ability to add users to a 
specific role. The list can be sorted by User Type 

1.7.5.2 Mass Assign Role to Multiple Users 

Adding multiple users to a role: District View > Admin > User > Roles >Options – 
Show Selected> Options > Add Role to Users 

 

 

 

1.7.5.3 Adding and Removing Schools 

This is advanced functionality. By default a user will have the same access across 
all the schools that they have been given access to. However, access can be 
tailored to reflect different permissions at different schools. 

Granting access for Staff users to different schools can be granted in four distinct 
areas. Note: These areas are independent of each other, and do not reflect in the 
other areas. 

Note:   Exercise caution when using this mass assign as there is no 

functionality for Mass Delete. 
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1. The Primary school belonging to the staff record. This typically is the primary 
place where a user’s school association is set. When a user account is linked 
(either through account creation or choosing the staff record) to a staff member 
in a school, this association is automatically made. It may or may not display on 
Staff > Schools depending on how the account was created. 

2. District View > Staff > Schools Staff can be assigned to additional schools 
within the district for specific school years. This will also add the person to the 
Staff list in each school. Access to these secondary schools ends with EOYR. 
The user will have the same access in each school that their security roles grant 
them. School associations can be mass added or removed from a group of staff 
at District View > Staff > Options > Manage School Associations 

3. District View > Admin > Users > Schools Users can be added to additional 
schools, they are not tied to a school year, nor are they added to the Staff list. 
They will have the access their security role grants them.  
 

 

4. District View > Admin > Users > Roles > Details You can grant security roles 
for a user to just one school, or to multiple schools that they associated with 
using the Include/Exclude visibility function. 

Exclude: “Exclude access to the following schools” This role will not be 
available in any schools added to this list. If this list is blank, the user will 
have access to this role’s permissions in all of their schools. 

Include: “Include access to only the following schools” The user will only 
have this role in the schools listed. A school added here will grant the 
user access to that school. The user will inherit the permissions granted 
by the other roles assigned to them, presuming there is not an exclude 
added to the roles for that school 

Example: A music teacher teaches at three different schools, Mountain, Forrest 

and Lakes, but is also a vice principal at Mountain. The staff record and user 

exists at Mountain, where the user has the Teacher and School Administrator 

roles. The two secondary schools (Forrest and Lakes) can be added to District 

View > Staff > Schools for the current school year. There are two ways of 

ensuring that the user only has teacher permission at Forrest and Lakes. 

Choose one method, they accomplish the same end result. 

  

Note:  Users added to additional schools will have the access their 

security role grants them. For example, whatever access clerical staff 

have in their primary school, they will also have in any additional school(s) 

assigned to them. It is up to each district to train clerical and admin staff on 

how to appropriately view and protect student information in any school 

they have access to, as well as who is responsible for performing functions 

such as maintaining school associations. If a teacher is given access to a 

school they will be able to select the school in School View, but can only 

see students who are in their classes or groups.  
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• District View > Admin > Users > Roles Select the School Administrator role, set the School 
Visibility Type to Exclude and add both Forrest and Lakes. (This Excludes the School 
Administrator Role from these schools) 

• District View > Admin > Users > Roles Select the School Administrator role, set the School 
Visibility Type to Include and add only Mountain. (This Includes the School Administrator Role 
for only this school) 

 

1.7.6 Merging User Accounts 

It may be necessary at times to merge two user accounts together. This should be done with 
caution, and it is important to review the security roles and permissions after merging to 
ensure that access remains the same. Only two accounts can be merged at a time. If there 
are multiple records, use the primary staff record and merge others, one at a time into this 
master record. Once you have identified and confirmed the accounts to merge the process 
can be found at District View > Admin > Users > Options > Merge Records  

 

Choose which person will be the Primary, and which will be the Duplicate.  

 

 

Verify which pieces of information will be merged into the primary record. When merging staff 
records from multiple schools, each one having a different Primary School, create a new 
secondary school association to ensure the user still has access and appears on the staff 
lists of all of their schools. See 1.5.5.2 

It is also important to verify the roles and Include/Exclude visibility after a merge to ensure 
the account has the appropriate permissions.  

Note:  This will pull up all people in the district. Always ensure that the correct 

individuals are selected  
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 MyEducation BC Security Roles 

The Baseline security roles detailed in this section are intended to address a variety of user 

types within districts. More than one security role may be assigned to a single user. Roles are 

listed in alphabetical order.  

Stand-Alone and Add-On roles are colour coded. 

 

Please see the Security Role Matrix document for details on the privilege settings associated 
with each Category and Data Reference Table for each of the baseline security roles. 
 
 

2.1 1701 Designations 

Role Type Intended For Accessible Views Restrictions 

Add-On District users, Clerical 
Staff 

• District 

• School 

 

Privileges 

Student Information 

• Create 1701 Student Services Supplementary Funding programs  

 
 

2.2 AIP Add-On – School  

Role Type Intended For Accessible Views Restrictions 

Add-On School Admins, Clerical 
Staff 

• District 

• School 

• Staff 

 

Privileges 

Student Information 

• Create AIP’s and run the AIP Copy Procedure  

 

These tables are provided as an informational snapshot. Districts should review the actual 

permissions granted to a user and ensure the access conforms to district policies. 
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2.3 AIP Add-On - Staff 

Role Type Intended For Accessible Views Restrictions 

Add-On District users, Teachers • District 

• School 

• Staff 

 

Privileges 

Student Information 

• Create AIP’s and run the AIP Copy Procedure  

 
 

2.4 At Risk Add-On – District 

Role Type Intended For Accessible Views Restrictions 

Add-On Admins, Clerical Staff • District 

• School 

 

Privileges 

Student Information 

• Run At Risk definitions at the district level.  

• Users with this role can also delete at risk results.  

• At Risk definitions run at the district level will display the results for affected students in all 
schools associated with that student. These results cannot be deleted by the schools. 

 
 

2.5 At Risk Add-On – School 

Role Type Intended For Accessible Views Restrictions 

Add-On Admins, Clerical Staff • School  

Privileges 

Student Information 

• Run At Risk definitions at the School level.  

• Users with this role can also delete at risk results. 
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2.6 At Risk Results – Read Only 

Role Type Intended For Accessible Views Restrictions 

Add-On Admins, Clerical Staff • School  

Privileges 

Student Information 

• View At Risk results in Tools > At Risk Results 

• Users can also see the Alerts on the Student top tab when moving the “AtRisk” column into 
a field set. 

 
 

2.7 BC Student Permission – School Admin 

Role Type Intended For Accessible Views Restrictions 

Add-On Admins, Clerical Staff • District 

• School 

 

Privileges 

Edit Home Page 

• This add- on role allows the school clericals to edit their respective home page to add the 
Task widget. 

Initiate forms / workflows 

• This add-on role allows school admin staff to initiate workflows for permission forms and 
other form types 

• Used for the following On-Line forms: BC Student Permission – Field Set, BC Student 
Permission – Release of Photo, BC Student Permission – Walk From Home, BC Student 
Permission – Email & Autodialer calls, BC Student Permission – Internet Access, BC 
Student Permission – Internet Access, BC Student Permission – Release Info to PAC - 
School 
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2.8 BC Student Permission – Student Contact 

Role Type Intended For Accessible Views Restrictions 

Add-On Student Contacts • District 

• School 

 

Privileges 

Edit Home Page 

• This add- on role allows the student contacts to edit their respective home page to add the 
task widget. Once enabled the Student Contact can see the link to the form permission 
task. 

Student Information 

• This add-on role allows student contacts to update student demographic permissions 
based on the forms workflow 

• Used for the following On-Line forms: BC Student Permission – Field Set, BC Student 
Permission – Release of Photo, BC Student Permission – Walk From Home, BC Student 
Permission – Email & Autodialer calls, BC Student Permission – Internet Access, BC 
Student Permission – Internet Access, BC Student Permission – Release Info to PAC - 
School 

 

 
 

2.9 Clerical – Auxiliary/On-Call 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Temporary/New Clerical • School  Write access limited to 
attendance 

Privileges 

Student Information 

• Read student information, including: 

o Student demographics (name, birthdate, address, phone number, etc.). 

o Student alerts. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student Program Participation. 

o Enrollment information, including Cross-Enrolled schools. 

• Take attendance for all students. 

Reporting 

• All student and school reports, including, but not limited to: 

o Enrollment. 

o Attendance 
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2.10 Clerical – Career Programs 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Career Centre Staff • School  Write access limited to 
programs 

Privileges 

Student Information 

• Read student information, including: 

o Assessments. 

o Grading. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Program participation. 

o Student legal alerts. 

o Fees and payments. 

o Online payments 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes, including course requests. 

o Student events and schools students are associated with. 

o Programs of study, graduation summary, and graduation progress information. 

o Documents. 

o Information about families and view what addresses attend which schools. 

o Student credit adjustments and student transcripts. 

o Student journals. 

• Create career program assignments for students 

• View special education information, including IEPs, student accommodations and student 
disabilities. 

 

Reporting 

• All student and school reports, including, but not limited to: 

o Enrollment. 

o Student information. 

o Staff information. 

o Report cards. 

o GPA & Honour Roll. 

o Transcripts. 

o Permanent Student Record (BC legal requirement). 

o Timetables – school and student level. 

o Ministry of Education extracts: 

▪ 1701 
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2.11 Clerical – School Admin Assistant 

Role Type Intended For Accessible Views Restrictions 

Stand-alone School Admin Assistant 
(Clerical) 

• School  

• Staff  

 

Privileges 

System Information 

• Create, update, delete, and mass update notices on the portal and mass update URL links 
for use in widgets. 

• View learning standards. 

• Create, update, delete, and mass update fees. 

• Create Online payment and Refunds 

• Manage all school-owned resources. 

• Update system configuration. 

• Delete and mass update preferences in the system and the default value for the preference. 

• Create, read and update schedule information, including the master schedule, courses, 
classrooms, days, periods, terms, staff and student schedules. 

• Allow course maximum override. 

• Create, update, delete, and mass update reference codes. 

• Create, delete, and mass update all person files in the system. 

• View available email subscriptions/subscription definition. 

• Create, read, update and delete information about the schedule, including the master 
schedule, days, periods, terms, and student schedules. 

• Add sections to courses, view and update course requests. 

• Create, read, update and delete staff information. 

• Create, read, and update the history of attendance records staff has posted. 

• Create, read, update, delete, and mass update grading information, such as assignments, 
GPA definition, grade post controls, grade term definition, grade trends, gradebook access 
log, gradebook remarks, scores, student information, qualification lists, student credit 
adjustment, progress reports, report cards, grading scales, rubrics, GPAs, and transcripts. 

• Create, read, update, and delete rubric scores, libraries, and scales.  

• Create, read, update and delete grading information, including GPA definitions, grade post 
controls, grade scales, grade term definitions, gradebook remarks, student grade points, 
and the setup of report cards and progress reports. 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone School Admin Assistant 
(Clerical) 

• School  

• Staff  

 

Privileges 

Student Information 

• Manage enrollment information. 

• Register and withdraw for new and existing students. 

• Archive students, graduate seniors, register students, transfer students, withdraw students, 
and change status/YOG for students. 

• Create, read, update, delete and mass update all student information, including: 

o Assessments. 

o Grading – update student term mark or historical marks. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Program participation. 

o Student legal alerts. 

o Fees and payments. 

o Online payment 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes, including course requests. 

o Student events and schools students are associated with. 

o Programs of study, graduation summary, and graduation progress information. 

o Documents. 

o Student credit adjustments and student transcripts. 

o Student journals. 

• View special education information, including IEPs, student accommodations and student 
disabilities. 

• Override grade level on the student transcript. 

• Allow the user to publish student reports on student and family portals. 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone School Admin Assistant 
(Clerical) 

• School  

• Staff  

 

Privileges 

Reporting 

• All student and school reports, including, but not limited to: 

Enrollment. 

Student information. 

Staff information. 

Report cards. 

GPA & Honour Roll. 

Transcripts. 

Permanent Student Record (BC legal requirement). 

Timetables – school and student level. 

Ministry of Education extracts: 

o 1701 

o SADE 

o TRAX 

o Class Size 
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2.12 Clerical – SIS Admin 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Clerical staff 
administering the SIS 

• School 

• Staff 

• Build 

 

Privileges 

System Information 

• Create, update, delete, and mass update notices on the portal and mass update URL links 
for use in widgets. 

• View learning standards. 

• Mass update system preferences. 

• Create, read, update, delete, mass update data foreign field mapping. 

• Create, update, delete, and mass update fees. 

• Create Online payment and Refunds 

• Manage all school-owned resources. 

• Update system configuration. 

• Delete and mass update preferences in the system and the default value for the preference. 

• Create, read and update schedule information, including the master schedule, courses, 
classrooms, days, periods, terms, staff and student schedules. 

• Allow course maximum override. 

• Create, update, delete, and mass update reference codes. 

• Create, delete, and mass update all person files in the system. 

• View available email subscriptions/subscription definition. 

• Create, read, update and delete information about the schedule, including the master 
schedule, days, periods, terms, and student schedules. 

• Add sections to courses, view and update course requests. 

• Create, read, update and delete staff information. 

• Create, read, and update the history of attendance records staff has posted. 

• Create, read, update, delete, and mass update grading information, such as assignments, 
GPA definition, grade post controls, grade term definition, grade trends, gradebook access 
log, gradebook remarks, scores, student information, qualification lists, student credit 
adjustment, progress reports, report cards, grading scales, rubrics, GPAs, and transcripts. 

• Create, read, update, and delete rubric scores, libraries, and scales.  

• Create, read, update and delete grading information, including GPA definitions, grade post 
controls, grade scales, grade term definitions, gradebook remarks, student grade points, 
and the setup of report cards and progress reports. 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone Clerical staff 
administering the SIS 

• School 

• Staff 

• Build 

 

Privileges 

Student Information 

• Manage enrollment information. 

• Register and withdraw for new and existing students. 

• Archive students, graduate seniors, register students, transfer students, withdraw students, 
and change status/YOG for students. 

• Create, read, update, delete and mass update all student information, including: 

o Assessments. 

o Grading – update student term mark or historical marks. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Program participation. 

o Student legal alerts. 

o Fees and payments. 

o Online payment 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes, including course requests. 

o Student events and schools students are associated with. 

o Programs of study, graduation summary, and graduation progress information. 

o Documents. 

o Student credit adjustments and student transcripts. 

o Student journals. 

• View special education information, including IEPs, student accommodations and student 
disabilities. 

• Override grade level on the student transcript. 

• Allow access to publish reports on Student and family portal 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone Clerical staff 
administering the SIS 

• School 

• Staff 

• Build 

 

Privileges 

Reporting 

• All student and school reports, including, but not limited to: 

Enrollment. 

Student information. 

Staff information. 

Report cards. 

GPA & Honour Roll. 

Transcripts. 

Permanent Student Record (BC legal requirement). 

Timetables – school and student level. 

Ministry of Education extracts: 

o 1701 

o SADE 

o TRAX 

o Class Size 
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2.13 Clerical – SIS Clerk 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Clerical staff doing 
attendance, student info 
maintenance 

• School 

• Staff 

No Scheduling or Grades 
writing 

Privileges 

System Information 

• Create, update, delete, and mass update notices on the portal and mass update URL links 
for use in widgets. 

• View learning standards. 

• Create, update, delete, and mass update fees. 

• View available email subscriptions/subscription definition. 

• Create Online payment and Refunds 

• Read information about the schedule, including the master schedule, days, periods, terms, 
and student schedules. 

• View and update course requests. 

• Create, read, update and delete staff information. 

• Create, read, and update the history of attendance records staff has posted. 

• Create, read, update, delete, and mass update gradebook remarks, scores, student 
information, qualification lists, student credit adjustment, progress reports, and report cards. 

• Create, read, update, and delete rubric scores, libraries, and scales.  

Student Information 

• Manage enrollment information. 

• Register and withdraw for new and existing students. 

• Archive students, graduate seniors, register students, transfer students, withdraw students 
and change status/YOG for students. 

• Create, read, update, delete and mass update all student information, including: 

o Assessments. 

o Grading. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Program participation. 

o Student legal alerts. 

o Fees and payments. 

o Online payment 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes, including course requests. 

o Student events and schools students are associated with. 

o Programs of study, graduation summary, and graduation progress information. 

o Documents. 

o Information about families and view what addresses attend which schools. 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone Clerical staff doing 
attendance, student info 
maintenance 

• School 

• Staff 

No Scheduling or Grades 
writing 

Privileges 

o Student credit adjustments and student transcripts. 

• Student journals. 

View special education information, including IEPs, student accommodations and student disabilities. 

Override grade level on the student transcript. 

Reporting 

• All student and school reports, including, but not limited to: 

Enrollment. 

Student information. 

Staff information. 

Report cards. 

GPA & Honour Roll. 

Transcripts. 

Permanent Student Record (BC legal requirement). 

Timetables – school and student level. 

Ministry of Education extracts: 

o 1701. 

o SADE. 

o TRAX. 

o Class Size. 
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2.14 Counsellor 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Counsellors • School  

Privileges 

System Information 

• View learning standards. 

• Read schedule information, including the master schedule, courses, classrooms, days, 
periods, terms, staff and student schedules. 

• Allow course maximum override. 

Student Information 

• Graduate seniors. 

• Read all student information, including: 

o Assessments. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Student legal alerts. 

o Program participation. 

o Fees and payments. 

o Online payment 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student events and schools students are associated with. 

o Special education information, including IEPs, student accommodations and student 
disabilities. 

• Update student schedules and their attributes, including course requests. 

• Update programs of study, graduation summary, and graduation progress information. 

• Update student credit adjustments and student transcripts. 

• Student journals. 

• Override grade level on the student transcript. 

Reporting 

• All student and school reports, including, but not limited to: 

Master schedule enrollment. 

Student information. 

Report cards. 

GPA & Honour Roll. 

Transcripts. 

Permanent Student Record (BC legal requirement). 

Timetables – school and student level. 
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2.15 Course Manager 

Role Type Intended For Accessible Views Restrictions 

Add-on Staff who need to pull down 
courses to the school level 
and/or adding sections. 

• School  

Privileges 

System Information 

• View learning standards. 

• Add or modify schedule information, including the master schedule, courses, classrooms, 
days, periods, terms, staff and student schedules. 

• Allow course maximum override. 

• Add/modify/delete courses from the district catalog. 

• Add/modify/delete sections to courses, view and update course requests. 

Student Information 

Update student schedules and their attributes, including course requests. 

 

2.16 Department Head 

Role Intended For Accessible Views Restrictions 

Add-on Add-on to an existing 
Teacher 

• School  Cannot create or update 
any data  

No access to district or 
school preferences 

Privileges 

System Information 

View data from across multiple departments in school. 

Student Information 

• View information about students, including: 

o Basic student demographics (addresses, phone numbers, contacts, families, independent 
contacts, alerts). 

o Assessment history. 

o Attendance. 

o Contacts. 

o Student schedules and their attributes. 

o Program participation. 

o Student Services designation. 

Reporting 

• Report cards. 

• GPA & Honour Roll. 

• Transcripts. 

• Timetables – school and student level. 
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2.17 Detention Room Monitor 

Role Type Intended For Accessible Views Restrictions 

Add-on Staff who monitor detentions • School  

Privileges 

System Information 

• Access School View > Conduct > Detentions  

• Mark students present for assigned detentions, leave notes as required. 

 
 

2.18 District Staff – Primary School Association Add On 

Role Type Intended For Accessible Views Restrictions 

Add-on District Staff • District view Give access to primary 
school association  

Privileges 

District View 

• Access to edit staff primary association on District View > Staff TT > Detail  

 
 

2.19 District Support (Level 1) 

Role Type Intended For Accessible Views Restrictions 

Stand-alone District SIS support staff • District 

• School 

• Staff 

• Build 

• Health 

 

Privileges 

System Information 

• All district level system administration access. 

• Access to all schools in the district. 

• Access to user accounts for all users in the district. 

• Access to all functionality for all schools and users in the district. 

• Access to publish reports on student and family portals. 

• Access to the Staff primary school on the District view staff detail screen can be given to 
this role by adding the Staff – Primary School Association Add On Role 

• Create, Read, Update, Delete, Mass Update and Global permission for Staff School 
Association  

Added a security tag to limit the staff primary school association field – read only field 
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2.20 District User (Read Only) 

Role Intended For Accessible Views Restrictions 

Stand-alone District Level users (SBO, 
District Learning Support 
Teams, International 
Departments 

• District 

• School  

Cannot create or update 
any data in 
MyEducation BC 

No access to district or 
school preferences 

Privileges 

System Information 

• View data from across multiple departments in school. 

• View assessment information, including learning standards, learning standards assignment 
and course alignments, rubric scores, the rubric library, and rubric rating scales. 

Student Information 

• View information about students, including: 

o Student demographics (addresses, phone numbers, contacts, families, independent 
contacts, alerts). 

o Assessment history. 

o Attendance. 

o Conduct History 

o Contacts. 

o Course requests. 

o Enrollment. 

o Program participation. 

o Student Services designation. 

Reporting 

• Student information. 

• Report cards. 

• GPA & Honour Roll. 

• Transcripts. 

• Permanent Student Record (BC legal requirement). 

• Timetables – school and student level. 
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2.21 Gradebook add-on 

Role Type Intended For Accessible Views Restrictions 

Add-on Clerical • Staff Cannot view 
assignments, marks or 
grades 

Privileges 

System Information 

• Read information on Staff View > Gradebook 

• Only able to view Details, Roster, Seating Chart and Groups side tabs under Gradebook top 
tab. 

• No Write or Edit privileges under this top tab. 

• Able to run Blank Grading Sheet, Class List, Grade Input Sheets reports for all classes for a 
particular teacher’s section(s). 

 
 

2.22 Health View Add-On 

Role Type Intended For Accessible Views Restrictions 

Add-On  • Health  

Privileges 

Student Information 

• Read student information, including: 

o Student demographics (name, birthdate, address, phone number, etc.). 

o Student alerts. 

o Student Health Conditions. 

o Student Screening Reports. 

o Student Appointment History. 

o Student Medication History. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student Program Participation. 

o Enrollment information, including Cross-Enrolled schools. 

• Create, read, update, and delete Health Medication Orders. 

• Create, read, update, and delete Health Screenings. 

• Create, read, update, and delete Medical Appointments 

• Create, read, update, and delete Medication Orders and Inventory Levels. 

Reporting 

• All student and school reports, including, but not limited to: 

o Health Profile. 

o Health Screening Record. 
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2.23 Health View Add-On – Read Only 

Role Type Intended For Accessible Views Restrictions 

Add-On  • Health  

Privileges 

Student Information 

• Read student information, including: 

o Student demographics (name, birthdate, address, phone number, etc.). 

o Student alerts. 

o Student Health Conditions. 

o Student Screening Reports. 

o Student Appointment History. 

o Student Medication History. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student Program Participation. 

o Enrollment information, including Cross-Enrolled schools. 

• Read School Medication Inventory Levels. 

• Read School Medication Order History. 

• Read Group Screening Results 

Reporting 

• All student and school reports, including, but not limited to: 

o Health Profile. 

o Health Screening Record. 

 
 

2.24 IB 

Role Type Intended For Accessible Views Restrictions 

Add-On IB School Administrators 
& Teachers 

 Must be an accredited IB 
School 

Privileges 

System Information 

• Grants access to the IB marking and reporting functionality. 
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2.25 Library User 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Library Staff • School Cannot create or 
update any data  

No access to school 
preferences 

Privileges 

Student Information 

• Read student information, including: 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Student legal alerts. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes. 

Reporting 

• Class information. 

• Student demographics (name, birthdate, address, phone number, alerts, etc.). 

 

 
 

2.26 OLR Registrar - District 

Role Type Intended For Accessible Views Restrictions 

Add-On Staff processing online 

student registrations at a 

District level 

• District 

• School 

• Family 

 

Privileges 

View and Process Online Registrations 

• This add- on role allows the district staff to view and process online student registrations submitted by 
parents in their district. They can view and modify the data submitted by the parent, search for a 
matching student already in MyEducation BC, and approve or deny the registration. 
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2.27 OLR Registrar - School 

Role Type Intended For Accessible Views Restrictions 

Add-On School staff processing 

online student 

registrations for their 

school 

• School 

• Family 

 

Privileges 

View and Process Online Registrations 

• This add- on role allows school staff to view and process online student registrations submitted by 
parents wishing to register at their school. They can view and modify the data submitted by the 
parent, search for a matching student already in MyEducation BC, and approve or deny the 
registration. 

 

 
 

2.28 Parent/Guardian – Online Registration Add-On 

Role Type Intended For Accessible Views Restrictions 

Stand-alone and 

Add-On 

Parents intending to 

submit an Online 

Student Registration 

• Family  

Privileges 

Family Portal Access 

• As a stand-alone role, this role will allow a parent to login to MyEducation BC and get a minimal 
Family Portal access configuration. 

 

• Once an online registration has been approved, this role will allow parents to see some of the typical 
Parent Portal data, but not all.  In order for parents to be able to use the full Parent Portal functionality 
they will need to be granted the regular Parent role that the district currently assigns to parent users. 

 

Initiate and Submit Online Student Registrations 

• This role will allow a parent to initiate a new student online registration, modify a registration that they 
have already started but not submitted and print out already submitted registrations. 
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2.29 Pages View Only 

Role Type Intended For Accessible Views Restrictions 

Stand-alone New users • School Cannot create or 
update any data 

Only access to the 
Pages top tab 

Privileges 

System Information 

• Designed for users being trained how to use the MyEducation BC system. 

• Assign this role to a new user in order for them to test their Login credentials. 

 
 

2.30 Parent/Guardian 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Parents or guardians of 
students 

• Family  

Privileges 

Student Information 

• Track information about their students, including: 

o Academics. 

o Address. 

o Alerts. 

o Attendance. 

o Contacts. 

o Independent contacts. 

o Course requests. 

o Educational plans. 

o Enrollment. 

o Events. 

o Fees. 

o Groups. 

o Schedule. 

• View assignments and other progress indicators. 

• Create, read, update, and delete email subscriptions and view all available subscriptions. 

• View information about the school’s schedule and its attributes, such as the master 
schedule, courses and course attributes, bell schedules, periods, terms, and classrooms 

• Pay student’s outstanding fee online if the school is configured for it 
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2.31 Parent/Guardian – Student Self Assessment add-on 

Role Type Intended For Accessible Views Restrictions 

Add-on Parents or guardians of 
students 

• Family  

Privileges 

Student Information 

• View completed Self assessment. 

 
 

2.32 Password Recovery - District 

Role Type Intended For Accessible Views Restrictions 

Add-on District Support • District  

Privileges 

System Information 

• Reset passwords for students, staffs and parent contact user accounts. 

 
 

2.33 Password Recovery - School 

Role Type Intended For Accessible Views Restrictions 

Add-on School Clerical • School  

Privileges 

System Information 

• Reset passwords for students, staffs and parent contact user accounts. 

 
 

2.34 Period Attendance Add-On 

Role Type Intended For Accessible Views Restrictions 

Add-on School Clerical • School  

Privileges 

Student Information 

• Access to  Global > Student > Student Class Attendance. 
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2.35 Publish Add-On – School View 

Role Type Intended For Accessible Views Restrictions 

Add-On Admins, Clerical Staff • School  

Privileges 

Student Information 

• Run Publish Add-on definitions at the School level.  

• Users with this role can publish reports to the portal. 

 
 

2.36 Publish Add-On – Staff View 

Role Type Intended For Accessible Views Restrictions 

Add-On Teachers • Staff  

Privileges 

Student Information 

• Run Publish Add-on definitions at the Staff/Teacher level.  

• Users with this role can publish reports to the portal. 

 
 

2.37 Publish Add-On – Special Education View 

Role Type Intended For Accessible Views Restrictions 

Add-On District Level Special 
Education Users 

• Special Education 
Organization View 

 

Privileges 

Student Information 

• Run Publish Add-on definitions at the Special Education Organization School View.  

• Users with this role can publish reports to the portal. 
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2.38 Publish Add-On – Special Education School View 

Role Type Intended For Accessible Views Restrictions 

Add-On School Level Special 
Education Users 

• Special Education 
School View  

 

Privileges 

Student Information 

• Run Publish Add-on definitions at the Special Education School View.  

• Users with this role can publish Student reports to the portal. 

 
 

2.39 Registrar 

Role Intended For Accessible Views Restrictions 

Stand-alone School Level Registrars • School   

Privileges 

Student Information 

• Manage enrollment information 

• Create, read, update register, withdraw and transfer new and existing students  

• Archive students and change status/YOG for students  

• Read student addresses, phone numbers 

• Create, read, update, delete, and mass update contacts, families and independent contacts  

• Create, delete, and mass update all person files in the system  

• View available email subscriptions/subscription definition  

• Create, read, and delete student schedules and their attributes  

• Create, read, and update, delete student information and set student legal and other alerts 

• Create, read, update, delete, and mass update student events and schools students are 
associated with, Student case person, Student contact. 

 
 

2.40 Reports Developer Add-on 

Role Intended For Accessible Views Restrictions 

Add-on District users adding/modify 
reports 

• District  

Privileges 

System Information 

• Access to the District view > Tools top tab > Reports side tab. 

• Ability to add, edit or delete District-wide customized reports. 

• Ability to publish reports on student and family portal. 
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2.41 Schedule Builder 

Role Type Intended For Accessible Views Restrictions 

Add-on Timetable building staff • School 

• Build 

No edit access to 
student 
demographics, with 
the exception of next 
school schedules 

Privileges 

System Information 

• View student addresses and phone numbers.  

• Create, update, delete, and mass update reference codes. 

• Override grade level on the student transcript. 

• View programs of study, graduation summary, and graduation progress information. 

• Create, read, update, delete, and mass update all aspects of the schedule and student. 

• Course requests. 

• Allow course maximum override. 

• View schools to which students are associated. 

• Build view access. 

 
 

2.42 Schedule Builder – Limited 

Role Type Intended For Accessible Views Restrictions 

Add-on Counsellors • Build No edit access to 
student 
demographics, with 
the exception of 
next school 
schedules 

Privileges 

System Information 

• Allows Counsellors to manage student schedules in the coming (Build) year. 

• View student addresses and phone numbers  

• View programs of study, graduation summary, and graduation progress information 

• Create, read, update, delete, and mass update all aspects of a student’s schedule 

• course requests 

• Allow course maximum override. 

• View schools to which students are associated. 
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2.43 School Administrator  

Role Type Intended For Accessible Views Restrictions 

Stand-alone School Principals & Vice-
Principals 

• School 

• Build 

• Staff 

 

Privileges 

System Information 

• Create, update, delete, and mass update notices on the portal and mass update URL links 
for use in widgets. 

• View learning standards. 

• Create, update, delete, and mass update fees. 

• Create Online payment and Refunds 

• Manage school-owned resources. 

• Update system configuration at the school level. 

• Delete and mass update preferences in the system and the default value for the preference. 

• Create, read and update schedule information, including the master schedule, courses, 
classrooms, days, periods, terms, staff and student schedules. 

• Allow course maximum override. 

• Create, update, and delete reference codes that have been shared down to the school level.  

• Create, delete, and mass update all person files in the system at the school level. 

• View available email subscriptions/subscription definition. 

• Create, read, update and delete information about the schedule, including the master 
schedule, days, periods, terms, and student schedules. 

• Add sections to courses, view and update course requests. 

• Create, read, update and delete staff information. 

• Create, read, and update the history of attendance records. 

• Create, read, update, delete, and mass update grading information, such as assignments, 
GPA definition, grade post controls, grade term definition, grade trends, gradebook access 
log, gradebook remarks, scores, student information, qualification lists, student credit 
adjustment, progress reports, report cards, grading scales, rubrics, GPAs, and transcripts. 

• Create, read, update, and delete rubric scores, libraries, and scales. 

Student Information 

• Manage enrollment information. 

• Register and withdraw for new and existing students. 

• Archive students, graduate seniors, register students, transfer students, withdraw students, 
and change status/YOG for students. 

• Create, read, update, delete and mass update all student information, including: 

o Assessments. 

o Grading – update student term mark or historical marks. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Student legal alerts. 

o Program participation. 

o Fees and payments. 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone School Principals & Vice-
Principals 

• School 

• Build 

• Staff 

 

Privileges 

o Online payment 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes, including course requests. 

o Student events and schools students are associated with. 

o Programs of study, graduation summary, and graduation progress information. 

o Documents. 

o Student credit adjustments and student transcripts. 

o Student journals. 

• View special education information, including IEPs, student accommodations and student 
designation. 

• Override grade level on the student transcript. 

• Allow access to publish reports on Student and family portal. 

Reporting 

• All student and school reports, including, but not limited to: 

Enrollment. 

Student information. 

Staff information. 

Report cards. 

GPA & Honour Roll. 

Transcripts. 

Permanent Student Record (BC legal requirement). 

Timetables – school and student level. 

Ministry of Education extracts: 

o 1701. 

o SADE. 

o TRAX. 

o Class Size. 
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2.44 School Administrator (Read Only) 

Role Type Intended For Accessible Views Restrictions 

Stand-alone School Principals & Vice-
Principals 

• School 

• Build 

• Staff 

• Cannot create 
or update any 
data  

• No access to 
school 
preferences 

Privileges 

System Information 

• Read URL links for use in widgets. 

• View learning standards. 

• Read fees. 

• View school-owned resources. 

• View system configuration at the school level. 

• Read schedule information, including the master schedule, courses, classrooms, days, 
periods, terms, staff and student schedules. 

• View reference codes that have been shared down to the school level. 

• Read all person files in the system at the school level. 

• View available email subscriptions/subscription definition. 

• View information about the schedule, including the master schedule, days, periods, 
terms, and student schedules. 

• View staff information. 

• View the history of attendance records. 

• View grading information, such as assignments, GPA definition, grade post controls, 
grade term definition, grade trends, gradebook access log, gradebook remarks, scores, 
student information, qualification lists, student credit adjustment, progress reports, 
report cards, grading scales, rubrics, GPAs, and transcripts. 

• View rubric scores, libraries, and scales. 

Student Information 

• View enrollment information. 

• Read all student information, including: 

o Assessments. 

o Grading – update student term mark or historical marks. 

o Conduct. 

o Scheduling. 

o Enrollment. 

o Student demographics (name, birthdate, address, phone number, alerts, etc.). 

o Student legal alerts. 

o Program participation. 

o Fees and payments. 

o Online payment 

o Payment items. 

o Student attendance. 

o Contacts, families and independent contacts. 

o Student schedules and their attributes, including course requests. 
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Role Type Intended For Accessible Views Restrictions 

Stand-alone School Principals & Vice-
Principals 

• School 

• Build 

• Staff 

• Cannot create 
or update any 
data  

• No access to 
school 
preferences 

Privileges 

o Student events and schools students are associated with. 

o Programs of study, graduation summary, and graduation progress information. 

o Documents. 

o Student credit adjustments and student transcripts. 

o Student journals. 

• View special education information, including IEPs, student accommodations and 
student designation. 

• Override grade level on the student transcript. 

Reporting 

• All student and school reports, including, but not limited to: 

Enrollment. 

Student information. 

Staff information. 

Report cards. 

GPA & Honour Roll. 

Transcripts. 

Permanent Student Record (BC legal requirement). 

Timetables – school and student level. 

Ministry of Education extracts: 

o 1701. 

o SADE. 

o TRAX. 

o Class Size. 
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2.45 School Support Roles 

Role Intended For Accessible Views Restrictions 

Stand-alone School Support Roles 
(Education Assistants, 
First Nations, Advocates, 
Learning Assistance 
Staff) 

• School Cannot create or update 
any data in Aspen 

No access to district or 
school preferences 

Privileges 

System Information 

• View data from across multiple departments in school. 

Student Information 

• View information about students, including: 

o Basic student demographics (addresses, phone numbers, contacts, families, independent 
contacts, alerts). 

o Assessment history. 

o Attendance. 

o Conduct. 

o Contacts. 

o Student schedules and their attributes 

o Program participation. 

o Student Services designation. 

Reporting 

• All student and school reports, including, but not limited to: 

Enrollment. 

Student information. 

Attendance 

Conduct 

Contacts 

Report cards. 

GPA & Honour Roll. 

• Transcripts. 

• Timetables – school and student level 
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2.46 Special Group User 

Role Intended For Accessible Views Restrictions 

Stand-alone Itinerant Workers 

(Aboriginal workers, 
Music Teachers, Speech 
pathologists, etc.) 

• Staff Cannot create or update 
any data 

No access to district or 
school preferences 

Restricted to specific 
groups of students 
across multiple 
schools 

Privileges 

System Information 

• View data from across multiple departments in school (e.g.: demographics, attendance, 
schedule, etc.) 

Student Information 

• View information about students, including: 

o Basic student demographics (addresses, phone numbers, contacts, families, alerts 

o Assessment history. 

o Attendance. 

o Contacts. 

o Student schedules and their attributes 

o Program participation. 

o Student Services designation. 

Reporting 

• All student and school reports, including, but not limited to: 

o Enrollment. 

o Student information. 

o Attendance 

o Contacts 

o Report cards. 

o GPA & Honour Roll. 

o Transcripts. 

o Timetables – school and student level. 
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2.47 StrongStart Facilitator - Basic  

Role Type Intended For Accessible Views Restrictions 

Stand-alone StrongStart Facilitators • Staff  

Privileges 

• Read access to student demographics 

• Read access to student contacts 

• Take Positive Attendance for Classes 

StrongStart Facilitator - 

School 

Role Type 

Intended For Accessible Views Restrictions 

Stand-alone StrongStart Facilitators • School 

• Staff 

 

Privileges 

School View 

• Read access to student demographics 

• Read access to student contacts 

• Take Positive Attendance for Classes 

• Access to GDEs, Exports and school level reports 

• Ability to email students and contacts 

• Access to Attendance History 

Staff View 

• Read access to student demographics 

• Read access to student contacts 

• Take Positive Attendance for Classes 
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2.48 Student 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Students • Student  

Privileges 

Student Information 

• View information about themselves in MyEducation BC, including, basic demographics, 
assessments, attendance, and transcript records. 

• Submit assignments 

• View information about their grades, such as assignments, gradebook remarks, and scores  

• View schedule information. 

• Create, read, update, and delete course requests. 

 

2.49 Student – Student Self Assessment add-on 

Role Type Intended For Accessible Views Restrictions 

Add-on Students • Student  

Privileges 

Student Information 

• Access to Workflow:  

• Permission to ‘Edit Home Page” and add the Tasks Widget. 
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2.51 Student Services – District 

Role Type Intended For Accessible Views Restrictions 

Stand-alone District Student Services 
staff 

• Student Services:  

o Organization  

o School 

 

Privileges 

System Information 

• Enroll students to Student Services 

• Manage the district’s goal banks and educational plans. 

• View the IEP access log. 

• Create and read IEP data. 

• Delete IEP 

• Manage and directly add progress reports. 

• View all special education students. 

• Read and update staff information for those identified as Student Services. 

• Read fields, tables, and reference codes in the Data Dictionary. 

• Read log entry, log history. 

• Global table access. 

Reporting 

• All student and school reports, including, but not limited to: 

o Enrollment. 

o Student information. 

o Attendance 

o Conduct 

o Contacts 

o Report cards. 

o GPA & Honour Roll. 

o Transcripts. 

o Timetables – school and student level. 

o 1701 
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2.52 Student Services – School 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Itinerant/School 
Student Services staff 

• Student Services 

o School 

 

Privileges 

System Information 

• Enroll students to Student Services 

• Manage IEPs and all related special education records. 

• View student information necessary to monitor student progress toward meeting goals. 

• Read student addresses, phone numbers, contacts, families, independent contacts, and 
documents. 

• Create, read, update, delete, and mass update IEP data. 

• View all special education students at the school. 

• Directly add progress reports. 

• View grading information, such as assignments, scores, and grade terms. 

• View student credit adjustments, transcripts, and the setup of report cards and progress 
reports. 

• View school locker information. 

• View staff information for those identified as Student Services. 

• View information about the schedule, including courses, master schedule, and student 
schedules. 

• Read log entry, log history. 

• Global table access. 

Reporting 

• All student and school reports, including, but not limited to: 

o Enrollment. 

o Student information. 

o Attendance 

o Conduct 

o Contacts 

o Report cards. 

o GPA & Honour Roll. 

o Transcripts. 

o Timetables – school and student level 
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2.53 Student Services: Enroll & Read – School 

Role Type Intended For Accessible Views Restrictions 

Stand-alone  Itinerant/School Student 
Services staff 

• Student Services 

o School 

 

Privileges 

System Information 

• Access to student information necessary to monitor student progress toward meeting goals. 

• Read student addresses, phone numbers, contacts, families, independent contacts, and 
documents. 

• Read IEP data, student accommodations. 

• View all special education students at the school. 

• Read staff information for those identified as Student Services.  

• Directly add progress reports. 

• Create person records. 

• View grading information, such as assignments, scores, and grade terms. 

• View student credit adjustments, transcripts, and the setup of report cards and progress 
reports. 

• View school locker information. 

• View staff information for those identified as Student Services. 

• View information about the schedule, including courses, master schedule, and student 
schedules. 

• Read log history. 

Reporting 

• All student and school reports, including, but not limited to: 

• Enrollment. 

• Student information. 

• Attendance 

• Conduct 

• Contacts 

• Report cards. 

• GPA & Honour Roll. 

• Transcripts. 

• Timetables – school and student level. 
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2.54 Student Services: Read Only – District 

Role Type Intended For Accessible Views Restrictions 

Stand-alone District Student Services 
staff 

• Student Services: 

o Organization  

o School 

 

Privileges 

System Information 

• View the IEP access log. 

• View all special education students. 

• Read IEP data for all students. 

• Read all related student data such as transcripts, attendance, memberships, etc. 

• View student eligibilities. 

• Read progress reports. 

• Read staff information for those identified as Student Services. 

• Read log history. 

Reporting 

• All student reports, including, but not limited to: 

o Enrollment. 

o Student information. 

o Attendance 

o Conduct 

o Contacts 

o Report cards. 

o Transcripts. 

o Timetables – school and student level 
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2.55 Student Services: Read Only – School 

Role Type Intended For Accessible Views Restrictions 

Stand-alone  Itinerant/School 
Student Services staff 

• Student Services 

o School 

 

Privileges 

System Information 

• View the IEP access log. 

• View all special education students. 

• Read IEP data for all students. 

• Read all related student data such as transcripts, attendance, memberships, etc. 

• View student eligibilities. 

• Read progress reports. 

• Read staff information for those identified as Student Services. 

• Read log history.  

Reporting 

• All student reports, including, but not limited to: 

o Enrollment. 

o Student information. 

o Attendance 

o Conduct 

o Contacts 

o Report cards. 

o Transcripts. 

o Timetables – school and student level. 
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2.56 Teacher 

Role Type Intended For Accessible Views Restrictions 

Stand-alone Teachers • Staff  

Privileges 

System Information 

• Create, read, update, and delete learning standards assignment alignments 

• Create, read, update, delete, and mass update rubric scores; and view rubric libraries and 
scales 

• Manage and edit their gradebook and class web pages 

• View student information, including address, phone numbers, contacts, alerts, assessments, 
educational plans, enrollment, events, program participation, and school association 

• Create, read, update, and delete student attendance 

• View district groups, families, and contacts for which they have access 

• Create, read, update, delete, and mass update seating charts, assignments, categories, 
scores, grade scales, gradebook remarks, special codes, footnotes, and gradebook student 
information 

• Create, read, update, and delete assignments on the assignment submission tool  

• Create, read, update, delete, and mass update the setup of progress reports in the teacher 
gradebook. 

• View Alerts 

• Create, read, and update the history of attendance records they have posted. 

• Create, read, update, delete, and mass update student journal. 

• Access to Staff view’s My Info and Professional Development tabs. 

• View students’ schedules. 

• Read and update professional development activity information. 

• View the history of attendance they have posted. 

• Administer all groups within their gradebook. 
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2.57 Teacher - Academics Add-On 

Role Type Intended For Accessible Views Restrictions 

Add-On Teachers • Staff Does not include student 
assignments 

Privileges 

Student Information 

• Student > Academics side tab – Read-only 

 

2.58 Teacher – Conduct add-on 

Role Type Intended For Accessible Views Restrictions 

Add-on Teachers • Staff Read-Only 

Privileges 

Student Information 

• Student > Conduct side tab – read only 

 

2.59 Transportation Manager/Clerk 

Role Intended For Accessible Views Restrictions 

Stand-alone District Level users • District 

• School  

Read only 

No access to district or 
school preferences 

Privileges 

System Information 

• View data from across multiple schools. 

Student Information 

• Basic student demographics (addresses, phone numbers, contacts, families, independent 
contacts, alerts). 

• Health condition. 

• Contacts. 

• Enrollment. 

• Program participation. 

• Student Services designation. 

Reporting: 

• Enrollment Report by school or district 

• Student information 

• Contacts 
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2.60 Transportation Side Tab – District 

Role Intended For Accessible Views Restrictions 

Add-on District Level users • District Cannot create or 
update student 
demographics  

No access to district or 
school preferences 

Privileges 

System Information 

• View data from across multiple schools. 

• District > Membership > Transportation Resources & Student Transportation read & write 
access 

Student Information 

• Read only basic student demographics (addresses, phone numbers, contacts, families, 
independent contacts, alerts). 

• Health condition. 

• Contacts. 

• Enrollment. 

• Program participation. 

• Student Services designation. 

• Student > Membership >Transportation read & write access 
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2.61 Transportation Side Tab – School 

Role Intended For Accessible Views Restrictions 

Add-on School Level users • School Cannot create or 
update student 
demographics  

No access to district or 
school preferences 

Privileges 

System Information 

• View data from across multiple schools. 

• School > Membership > Transportation Resources & Student Transportation read & write 
access 

Student Information 

• Read only basic student demographics (addresses, phone numbers, contacts, families, 
independent contacts, alerts). 

• Health condition. 

• Contacts. 

• Enrollment. 

• Program participation. 

• Student Services designation. 

Student > Membership >Transportation read & write access 

 

 

2.62 User Manager – District 

Role Intended For Accessible Views Restrictions 

Add-On District Level users who 
create accounts 

• District 

• School  

Cannot create or 
update any data  

No access to district or 
school preferences 

Privileges 

System Information 

• View data from across multiple schools and assigned district 

• Create User Accounts for Staff, Students and Student Contacts by School or all Schools in a 
District 

• Modify or delete existing User Accounts from the District view 

Student Information 

• Read access to Student Details and Demographics 
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2.63 User Manager – School 

Role Intended For Accessible Views Restrictions 

Add-On School Level users who 
create accounts 

• School  Cannot create or 
update any data  

No access to school 
preferences 

Privileges 

System Information 

• View data from across assigned school(s)  

• Create User Accounts for Staff, Students and Student Contacts by School 

Student Information 

• Read access to Student Details and Demographics 

 

 

 

2.64 VTRA District 

Role Type Intended For Accessible Views Restrictions 

Add-On District-specific VTRA 
team lead  

• School 

• District 

Tabs removed from 
District and School 
Views. Role cannot be 
used as stand-alone.  

Privileges 

Restrictions 

• Districts appoint a Violence Threat Risk Assessment (VTRA) team leader to oversee the 
activation of the community VTRA protocol.  

Student Information 

• Create, Read and Write access to the Student Table. 

• Can access VTRA field by creating a field set or running a query. 

 

 

Important: Users with the ability to create user account roles for district and school level.   

Ensure any user with these roles are aware of the District security processes and 

protocols to ensure the safety of the student data. Roles should be created with careful 

consideration of data available for viewing, printing, and email capability eg. Do roles 

assigned follow district privacy, are the roles created with security in mind 

Do these users have the knowledge they need to protect the staff, students and families 

security? 
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2.65 VTRA District (Read-Only) 

Role Type Intended For Accessible Views Restrictions 

Add-On District-specific VTRA 
team members  

• School 

• District 

Tabs removed from 
District and School 
Views. Role cannot be 
used as stand-alone.  

Privileges 

Restrictions 

• Districts appoint a Violence Threat Risk Assessment (VTRA) team leader to oversee the 
activation of the community VTRA protocol. 

Student Information 

• Read-Only access to the Student Table. 

• Can access VTRA field by creating a field set or running a query. 

 

 

2.66 VTRA School 

Role Type Intended For Accessible Views Restrictions 

Add-On School site-specific 
VTRA team lead  

• School 

 

Tabs removed from 
School Views. Role 
cannot be used as stand-
alone.  

Privileges 

Restrictions 

• Districts appoint a Violence Threat Risk Assessment (VTRA) team leader to oversee the 
activation of the community VTRA protocol.  

Student Information 

• Create, Read and Write access to the Student Table. 

• Can access VTRA field by creating a field set or running a query. 
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2.67 VTRA School (Read-Only) 

Role Type Intended For Accessible Views Restrictions 

Add-On School site-specific 
VTRA team members  

• School 

 

Tabs removed from 
School Views. Role 
cannot be used as stand-
alone.  

Privileges 

Restrictions 

• Districts appoint a Violence Threat Risk Assessment (VTRA) team leader to oversee the 
activation of the community VTRA protocol. Each school should have a Site-Specific VTRA 
team. 

Student Information 

• Read-Only access to the Student Table. 

• Can access VTRA field by creating a field set or running a query. 
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APPENDIX 1 - Login ID Tokens 

When creating User Accounts, Custom Expression can be used for assigning Login ID names 
for users. There are two different expression types – called Tokens – that can be used: 

1. Literal 

2. Variable 

A Literal token is a static expression that will not change from person to person.  

For example: If District 12, who has 100 teachers, wanted all of the teacher Login ID’s to 
use the school district number followed by the word teacher, and then each an 
ascending number for the Login ID, enter the following in the Custom Expression field:  
 
12teacher 
 
This will create user accounts 12teacher through 12teacher100. Note: the system will 
skip #1 and just use the original Custom Expression, and then continuing with 2 then 3, 
etc. 

 

A Variable token will pull a field value from a table associated with that User’s Person Record 
(Staff Record, Student Record, etc.) It can then be customized to each individual user. This 
system will append a number to the end of the Login ID only if there are multiple users who fit 
that criteria in the entire system,  

For example: If a district wanted to use first initial, last name, followed by district number, 
and had John Smith and Jane Smith both in the district, the login IDs jsmith12 and 
jsmith122 would be created. If first initial and last name were used, and John Smith was 
in a different district than Jane Smith, there would be a jsmith and jsmith2. 

 

Variable tokens are enclosed in braces {  } and are made up of a table name, and a field name, 
separated by a period.  

For example: to use the person’s first name and last name, use the following variable 
tokens:  
 
{person.firstName}{person.lastName} 
 
In John Smith’s case, the user name would then be johnsmith. 

 

Literal and Variable tokens can be mixed in custom expressions.  

For example: If the desired format is to have first name last name separated by a period, 
use the following: 
 
{person.firstName}.{person.lastName} 
 
This would create the Login ID john.smith 
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Common Variable Tokens 

More information can be found in the MyEducation BC online help system Search for 
“expression” 

 

Note: the capitalization of the Variable tokens is very important. The field name comes 
from the Java name that is found on the table (not references table) in the Enterprise-
level Data Dictionary, and if the capitalization is incorrect, the Variable token will not 
work. 

 

A quick guide to some common tokens: 

First name {person.firstName} 

First initial {PADR(person.firstName,1,’ ’)} 

Middle name {person.middleName} 

Middle initial {PADR(person.middleName,1,’ ’)} 

Last name {person.lastName} 

District # {organization2.id} 

Primary email address {person.email01} 

Pupil Number (created by system) {student.localId} 

Staff Number (created by system) {staff.localId} 

Employee Number (manually entered) {staff.fieldB002} 

 

Examples of custom expressions: 

Token string Example 

{PADR(person.firstName,1,’ ’)}{person.lastName}{organization2.id} jsmith12 

{person.lastName}, {person.firstName} smith, john 

teacher{organization2.id}{person.lastName} teacher12smith 
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APPENDIX 2 -Creating a TOC/Substitute Teacher 

Below is an example of creating a user account and setting up School Associations. 

Using a Teacher On Call (TOC) as an example. 

Create or Modify Staff Record 

• To create a new TOC, choose either the District view or School view, and click the 
Staff top tab. From the Options menu, select Add, and the New Staff template will 
appear. Add the following information at minimum: 

• Legal First and Legal Last Name 

• School>Name will be blank 

• Staff Type – You will set this to TOC. 

• Employee Number – enter in School district employee number 

• Status (Active/Inactive). The Default for this is Active. This indicates whether this record will be 
displayed in the Staff List when the filter is set to Active Staff (which is the default filter), and it 
will also allow them to appear in the TOC list when doing TOC assignment. 

• Click on SAVE 
 

Creating School Associations for the Current School Year 

• District or School View>Staff Top Tab> Filter for all Type = TOC  

 

• Staff Top Tab>Options>Manage School Associations.  Mode = Create School 
Associations.   School year = Current School Year. Staff = Current Selection. Schools = 
All schools. Click on OK 
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• In the Schools section, either choose “All Schools” if you wish them to be available to 
every school in your district, or else “Selection” if you wish to pick certain schools to give 
access to, and select them from the pop up. When you are finished, click OK and the 
associations will all be set for the indicated school year. 

Creating Accounts and adding security role of Teacher 

• TOCs are assigned the Security role of Teacher 

• Create User Account from Staff Top Tab 

o Options>Create User Accounts (make sure that you have used the Show 
selected functionality.  Do not have all of the staff accounts showing) 

o Create User Accounts = Current Selection 

o Login Id, password, account expiration date all should be entered as per District 
Policy 

o Roles=Teacher, Schools= do not add schools (use School Associations for 
TOCs) 

TOCs taking attendance or accessing gradebook 

• Schools can assign TOCs to their school for one day or length of time using the 
instructions in Assigning TOCs on the MyEducationBC.Info site  
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APPENDIX 3 – Staff School and Role Assignment Extract 

The Staff School and Role Assignment Extract was developed to assist District L1s and School 
Administrators in reviewing the level of access that each staff member has within their school. 
The extract displays all staff user records with their assigned schools and user roles.  

This extract is available in both the District and School Views.  

District view > Admin top tab > User side tab > Options > Exports  

School View > Staff top tab > Options > Exports  

 

 

The parameter screen has School and Role picklists. Every school selected will display all staff 
users associated to that school in the current year. Select one or multiple security roles, and the 
extract will display users with any of the selected security roles.  

If we select just the Teacher role, we will see a list of all staff user accounts who have the 
Teacher role, as well as the other security roles associated to those users. If the user has 
multiple roles, each role is displayed separately in the CSV file. 
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Note: This extract will only display a Staff users’ current year school associations (it will not 
display previous year staff school associations).  

A Staff Primary School Association is visible from the Staff top tab > Details side tab 

Individual Staff Secondary School Associations are visible from the Staff top tab > Schools 
side tab (the school associations for multiple years are visible in this view).   

 

 

 

 


