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What is CHIRP?

• CHIRP is a freeware open-source software utility designed for easy 
programming of amateur radios,

• Developed by Dan Smith
• Located on the web at 

https://chirp.danplanet.com/projects/chirp/wiki/Home
• Directly supports a few hundred different makes and models of radios
• Usually provides access to radio features in addition to memory locations
• Is available for Microsoft Windows, Linux, and Apple MacOS platforms
• Is frequently updated to add additional support and/or features
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Installing CHIRP

• The CHIRP installation will, of course, vary by platform.  We will 
discuss the Microsoft Windows iteration today.

• Begin by downloading the current version…
• https://trac.chirp.danplanet.com/chirp_next/next-20230427/
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Installing CHIRP

• The frequent updates are called “dailies”…
• The dailies file names indicate the date of the release…

• e.g.,  a daily named “chirp-next-20230427-installer.exe” was released on 
27 April 2023.

• It is recommended that the CHIRP daily that you install be 
retained at least until the next update is successfully running

• Occasionally, a new release will be problematic, and by uninstalling that 
update and reinstalling the previous version, you can keep on working.

• Some anti-virus apps may flag CHIRP dailies as being infected
• It is safe to ignore these warnings, provided that you obtained the CHIRP 

file directly from the CHIRP website.
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Windows Defender

• If Windows Defender flags 
the CHIRP install program as 
an infector, the dialog at 
right will appear.

• Click the “More info” link to  
continue the installation.
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Windows Defender

• In the next dialog that 
appears, shown at right, you 
must click on the “Run 
Anyway” button in order to 
continue with the CHIRP 
installation routine.
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Windows User Account Control Issue
• The Windows UAC system 

may prompt you, depending 
upon its settings, to approve 
the installation of the 
program.

• Click “Yes” to continue with 
the installation.
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• When downloading CHIRP via the Microsoft Edge web browser, a 
unique problem can crop up whenever you download a file that 
Edge flags as “not commonly downloaded”.

• This happens frequently with .exe files and other executable files.
• It is a behavior that is by design, and is intended to protect your 

system.
• The next four slides explain how to get around this issue…

Microsoft Edge Browser Issues
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Step 1

• Edge flags the file, and may 
list it in the browser 
Downloads list as 
“unconfirmed”. 

• The dialog at right will 
appear if you click on the file 
in the list. If not, right-click 
on the file entry in the 
Downloads list.
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Step 2

• Click the ellipsis button (the 
three dots) to get the context 
menu as shown at right.

• Select “Keep” from this 
context menu.
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Step 3

• The dialog at right will then appear.
• Click the “Show More” text to 

continue with the download.
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Step 4

• To finish up, click the “Keep Anyway” 
item from the list in the dialog that 
appears.

• The file will then be confirmed and 
will thus be ready for installation.
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Installing CHIRP

• Once the download has been successful, browse to the 
downloaded file location, which is usually the Downloads folder 
under the current user, and then double-click on the downloaded 
CHIRP daily.

• Follow the simple installation routine, confirming the options as 
they are presented.

• The install itself takes a matter of seconds to complete.
• If you are installing a CHIRP update, the previous install does not 

have to be uninstalled, but it does need to be in a not-running 
state.
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Running CHIRP

• Double-click on the new CHIRP icon to launch the application.
• The icon may be on the Desktop, and it will also be found in the Start 

Menu programs list.

• Make sure that your radio is connected to the PC and that the 
radio is in its ready-to-program mode.

• Some models simply have to be turned on with the audio gain turned up 
to about 75% of maximum.

• Others may need to be started in a certain manner, or may need to be 
placed into a program or clone mode.

• Check and follow the manual directions for entering the program or clone 
mode.
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The CHIRP Screen
• The Welcome screen is the 

start-up launching point.
• Five menus are available…

• File
• Edit
• View
• Radio
• Help

• Each of these menus will be 
discussed and explained in 
detail…

• Note the keyboard shortcuts!
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File Menu
• New… opens a new, blank CHIRP file and 

grid
• Open… provides a dialog to allow the user 

to open an existing CHIRP .IMG file
• Open Stock Config… provides the user a 

choice of existing pre-defined frequency 
sets

• Open Recent… provides a list of the most 
recently used CHIRP .IMG files for quick 
re-opening of those files
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File Menu
• Save… allows the user to save an already-

named .IMG file to disk
• Save As… allows the user to save a CHIRP 

.IMG file to a new filename
• Export to CSV… provides a data dump of 

the CHIRP grid into a comma separated 
values text file

• Print… sends the screen contents to the 
default printer via the print dialog
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File Menu
• Print Preview… allows the user to see how 

the oriented output will appear
• Close… Closes the active CHIRP .IMG file
• Quit… exits and ends the program
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Edit Menu

• Cut… removes the selected text from 
the grid and places it on the clipboard

• Copy… places the selected text on the 
clipboard without removing it from 
the grid

• Paste…  Places the test on the 
clipboard into the selected location in 
the grid

• Select All… Selects all text in the grid
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Edit Menu

• Delete… removes the selected text 
from the grid and discards it

• Find… executes a search routine to 
locate the cited text in the grid

• Find Next… repeats a search routine 
to locate the next occurrence of the 
cited text in the grid

• Goto… jumps the focus to a given 
memory slot in the grid
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Edit Menu

• Move Up…  shifts the selected line 
upward in the grid, displacing others 
downward

• Move Down… shifts the selected line 
downward in the grid, displacing 
others upward
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View Menu

• The View menu is a relatively new 
addition to the CHIRP interface.  It 
provides only two menu options…

• Use fixed-width font… instructs the 
interface to use a font with consistent 
character spacing rather than the 
native Windows font

• Use larger font…  magnifies the text 
size in the user interface

Note that both menu items 
here can be toggled on, 
meaning that the font will be 
changed to a fixed-width font 
and it will be magnified.  
They can also be used 
separately.
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Radio Menu
• Download from radio… launches the 

dialog that allows cloning the radio 
into the software

• Upload to radio… launches the dialog 
that allows cloning the software 
values into the radio

• Query source… allows the user to 
obtain a list of frequencies from 
several well-known data sources

• Enable Automatic Edits…  toggles 
the software’s ability to make text 
entries autonomously as regards 
offset, offset direction, and mode

• Select Bandplan…  selects one of 
five defined bandplans for use 
with the software
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About the Main Screen

• Note that when CHIRP is opened, it creates a default top-level tab 
with an almost empty memory grid on a single lower-level 
Memories tab

• Downloading from a radio or opening a CHIRP .IMG file creates an 
additional upper-level tab for each radio downloaded or file 
opened

• These upper-level tabs will often have two or more lower-level tabs 
including at least a Memories tab and usually a Settings tab

• Each import from a data source will also create a new upper-level 
tab

• Always be aware of which upper-level tab is being edited!
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The CHIRP Memory Grid
Upper-level tab

Lower-level tabs
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Memory Grid Columns

• Frequency… the receive frequency of the programmed station
• Name… an alphanumeric identifier applied to the programmed 

station
• Tone Mode… the access tone methodology employed by the 

programmed station
• Tone… the access tone frequency for basic Tone mode – used on 

TX only
• Tone Squelch… the access tone frequency used for Tone Squelch 

mode – used on both TX and RX
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Memory Grid Columns

• DTCS… the DTCS code to be transmitted and used for receiver 
squelch when the Tone Mode is set to DTCS

• RX DTCS… sets the DTCS code to be used for RX if radio-supported 
and Tone  mode is set to Cross

• DTCS Polarity… sets the polarity of the transmitted DTCS code
• Cross Mode… controls squelch behavior when Tone mode is set to 

Cross
• Duplex… sets the duplex mode for the programmed station, either 

off, +, -, or split
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Memory Grid Columns

• Offset… sets the frequency difference between RX and TX 
frequencies in Duplex mode

• Mode… controls the RX and TX mode of operation for the 
programmed station, either FM, NFM, WFM, AM, or DV

• Skip… sets the programmed station as either a prioity channel (P) 
or a skipped channel (S) during scanning

• Power… sets the RF output power of the programmed station
• Comment… an alphanumeric note regarding the programmed 

station
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Making Grid Entries

• The memory grid can be edited manually or via cut-and-paste 
operations from other parts of the grid or from another open radio 
grid.

• When Automatic Editing is enabled, portions of the grid line will be 
entered automatically when the frequency is entered, absed upon 
that frequency and the customary norms.

• Earlier versions of CHIRP allowed “hiding” of unused colums, but 
that feature is no longer available.

• Any unused column in a given grid line should simply be left 
empty.
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About COM Ports

• Microsoft Windows will assign virtual communications (COM) port 
numbers to each instance of an active USB communications 
device that can emulate a standard communications port.

• Moving a USB device from one USB port to another will generally 
cause Windows to create a new COM port number for the device in 
its new location.

• Selecting the wrong COM port number in the Radio> Upload… or 
Radio > Download… dialog will cause an error, which will prevent 
the operation from completing successfully.
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Cloning From A Different Radio

To build a memory list based on the entries in a different radio…
1. Download the data from the source radio and optionally save that 

data as a CHIRP .IMG file
2. Connect the target radio and download its data (or open a CHIRP 

.IMG file appropriate for the target radio)
3. Select (highlight) and copy (Ctrl+C) the rows of data in the source 

radio  memory tab to be cloned into the target radio
4. Click into the target radio memory tab and choose the destination 

location rows for the new rows of data
5. Paste (Ctrl+V) the data into those rows
6. Upload the new data to the target radio
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Downloading from Radio

To download data from a radio…
1. Connect the radio to the PC and ensure that it is ready to clone
2. Click Radio > Download from radio
3. Select the correct COM port
4. Select the correct radio make and model
5. Click OK to begin download
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Uploading to Radio

To upload data to a radio…
1. Connect the radio to the PC and ensure that it is ready to clone
2. Click Radio > Upload to radio
3. Select the correct COM port
4. Select the correct radio make and model
5. Click OK to begin upload
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About Uploading…

• CHIRP will not permit uploading of unformatted data to a radio.
• The data must be entered into a memory grid that is formatted for the 

specific radio make and model into which the user desires to upload the 
data.

• A formatted memory grid can be obtained by either one of two methods…
• Download the existing format from the target radio, or
• Open a CHIRP .IMG file that is formatted for that particular radio make and model.

• The radio make and model for which a CHIRP .IMG file is formatted will 
appear as a part of the automatically-generated filename of the .IMG file.

• It is highly recommended that the filename assigned by the software always be 
accepted with the addition of the save time to the end of the filename, such as 
Baofeng_BF-F8HP_20230429_2008.img.
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Other Radio Settings
• Depending upon the 

radio make and 
model, there will 
usually be two lower-
level tabs showing 
under the radio’s 
upper-level tab in 
CHIRP

• The first lower-level 
tab is the Memories
tab

• The second lower-
level tab is the 
Settings tab, as 
shown at right

• The options available on the Settings tab will 
vary from one radio to the next

• These are the radio “personality” settings
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Things to remember

• It is always advisable to save the downloaded data from a new 
radio so that it can be restored later if necessary

• Click File > Save As to save the CHIRP .IMG file

• CHIRP can import .CSV files, but they cannot be directly uploaded
• Data from a .CSV file must be entered into a radio-formatted memory grid 

in order to upload it

• CHIRP can also export its data to a CSV file for use in other 
applications

• CHIRP can open numerous different radio file types, all found in 
the File > Open dialog in the file types drop list
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Things to remember

• Sometimes, a radio must be listed as a different make and/or 
model radio in order for CHIRP to program it successfully

• A Google search for “CHIRP” and the radio make and model will often 
turn up the necessary information.

• Always be sure that the data cable is fully seated into the jack(s) 
on the radio

• Always make sure that the operating system recognizes the radio 
and has assigned a COM port value to it

• Switching USB ports will usually garner a new COM port 
designation for a given data cable
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Things to remember

• Data in the Memories tab can be edited directly in the grid, or can 
be edited in a pop-up window that will appear if the grid row is 
right-clicked, and Properties is chosen from the context menu that 
appears.

• That same context menu will allow some manipulation of the data 
rows…

• …insertion of a blank row above the current row(s)
• …deletion of the current row(s)
• …sorting of the data, ascending or descending, in the current row(s)
• …display of the raw memory contents (useful for development team)

5/9/2023 Radio Programming with CHIRP 38

Copyright © 2023 by CMS  Pitman, NJ  USA  -  Page 38



Things to remember

• Double-clicking most cells in the memory grid will launch a drop list of 
available optional values for that cell

• Selecting a value in this way will also change the underlying data 
structure

• …e.g., if you have set the Tone mode to Tone, but then select a value in the DCS 
cell  for that row, the Tone mode will be automatically changed, even if the 
Enable Automatic Edits option is toggled off

• Use this method carefully until you are well acclimated to its behavior 
to avoid erroneous values from appearing in the grid

• It is always advisable to append the save time to the automatic file 
naming convention so as to differentiate between multiple files saved 
on the same day
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Questions?

5/9/2023 Radio Programming with CHIRP 40

Copyright © 2023 by CMS  Pitman, NJ  USA  -  Page 40


	Radio Programming�with CHIRP
	What is CHIRP?
	Installing CHIRP
	Installing CHIRP
	Windows Defender
	Windows Defender
	Windows User Account Control Issue	
	Microsoft Edge Browser Issues
	Step 1
	Step 2
	Step 3
	Step 4
	Installing CHIRP
	Running CHIRP
	The CHIRP Screen
	File Menu
	File Menu
	File Menu
	Edit Menu
	Edit Menu
	Edit Menu
	View Menu
	Radio Menu
	About the Main Screen
	The CHIRP Memory Grid
	Memory Grid Columns
	Memory Grid Columns
	Memory Grid Columns
	Making Grid Entries
	About COM Ports
	Cloning From A Different Radio
	Downloading from Radio
	Uploading to Radio
	About Uploading…
	Other Radio Settings
	Things to remember
	Things to remember
	Things to remember
	Things to remember
	Questions?



